mAirListScript - The scripting interface to mAirList

mAirListScript
Content
Index
Previous
Next

Project
mAirListScript

Summary
The scripting interface to mAirList

Description
The scripting interface to mAirList

Author
Torben Weibert

Files
File | Description
mAirListScript |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next

Created with DelphiCodeToDoc. To obtain the latest revision, please see http://dephicodetodoc.sourceforge.net/
Under GNU GPL licence. Copyright (c) 2003 - TridenT.


Previous
Next

Unit
mAirListScript

Classes
Class | Description
IAction |
IActionList |
ICartPlayerControl |
ICartWallControl |
IComPort |
ICuePosition |
IDatabase |
IDatabaseList |
IEngine |
IEventList |
IEventListItem |
IIOPort |
IIOWarrior |
IMixer |
IPlaybackControl |
IPlayerControl |
IPlaylist |
IPlaylistItem |
IRemoteController |

Types
Type | Description
TCuePositionType |
TDatabaseCapabilities |
TDatabaseCapability |
TEngineOption |
TEngineOptions |
TEventActionType |
TExpandAction |
TPlayerButton |
TPlayerButtons |
TPlayerCommand |
TPlayerState |
TPlayerStates |
TPlaylistItemCapabilities |
TPlaylistItemCapability |
TPlaylistItemOption |
TPlaylistItemOptions |
TSourceCapabilities |
TSourceCapability |
TStartTimeType |

Functions
Function | Description
BuildAudioDevice | Create an IAudioSource object, based on a description passed as a string.
ComPort |
CreateContainerPlaylistItem |
CreateEmptyPlaylist |
CreateFilePlaylistItem |
CreatePlaylist |
CreatePlaylistFromFile |
CreatePlaylistFromFile |
CreatePlaylistItemFromFile | Creates a playlist item from the given file.
CreatePlaylistItemFromXMLString |
CurrentDatabase |
CurrentPlaybackControl |
CurrentPlaylist |
Database |
DatabaseCount |
Engine |
ExecuteCommand |
ExecuteCommandRPC |
HTTPGet |
IOPort |
IOWarrior |
ISOWeek | Calculates the week number according to ISO 8601.
MidiOut |
MidiOutGetNumDevs |
MidiOutListDevices |
Mixer |
MixerCount |
PlaybackControl |
Playlist |
PlaylistCount |
Random |
RunScript |
SASComPort |
SelectDatabase |
SelectPlaylist |
SetApplicationTitle |
ShellExecute |
ShellExecuteHidden |
SystemLog |
URLEncode | Encode a string so that it can by safely used as a parameter inside an

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next


Previous
Next (IActionList)

Class
IAction

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Assign (+) |
Clone (+) |
Execute (+) |
GetCaption (+) |
GetEditFrame (+) |
GetOnChange (+) |
SetOnChange (+) |

Properties
Property | Description
OnChange (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous
Next (IActionList)


Previous
Next

Member
OnChange

Visibility
PUBLIC

Related Class
IAction

Description

Source code
property OnChange : TNotifyEvent read GetOnChange write SetOnChange

Read Access
GetOnChange

Write Access
SetOnChange

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next


Previous
Next (Clone)

Member
Assign

Visibility
PUBLIC

Related Class
IAction

Source code
procedure Assign ( iAction : IAction )

Parameters
Parameter | Description
iAction : IAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Clone)


Previous (Assign)
Next (Execute)

Member
Clone

Visibility
PUBLIC

Related Class
IAction

Source code
function Clone : IAction

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Assign)
Next (Execute)


Previous (Clone)
Next (GetCaption)

Member
Execute

Visibility
PUBLIC

Related Class
IAction

Source code
procedure Execute ( iEngine : IEngine ; iPlaybackControl : IPlaybackControl )

Parameters
Parameter | Description
iEngine : IEngine |
iPlaybackControl : IPlaybackControl |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clone)
Next (GetCaption)


Previous (Execute)
Next (GetEditFrame)

Member
GetCaption

Visibility
PUBLIC

Related Class
IAction

Source code
function GetCaption : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Execute)
Next (GetEditFrame)


Previous (GetCaption)
Next (GetOnChange)

Member
GetEditFrame

Visibility
PUBLIC

Related Class
IAction

Source code
function GetEditFrame ( AOwner : TComponent ) : TFrame

Parameters
Parameter | Description
AOwner : TComponent |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCaption)
Next (GetOnChange)


Previous (GetEditFrame)
Next (SetOnChange)

Member
GetOnChange

Visibility
PUBLIC

Related Class
IAction

Source code
function GetOnChange : TNotifyEvent

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEditFrame)
Next (SetOnChange)


Previous (GetOnChange)
Next

Member
SetOnChange

Visibility
PUBLIC

Related Class
IAction

Source code
procedure SetOnChange ( iValue : TNotifyEvent )

Parameters
Parameter | Description
iValue : TNotifyEvent |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOnChange)
Next


Previous (IAction)
Next (ICartPlayerControl)

Class
IActionList

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
ADD (+) |
Assign (+) |
BeginUpdate (+) |
Clear (+) |
Delete (+) |
EndUpdate (+) |
GetClients (+) |
GetCount (+) |
GetItem (+) |
IndexOf (+) |
Insert (+) |
LoadFromFile (+) |
LoadFromXML (+) |
Move (+) |
SaveAsXML (+) |
SaveToFile (+) |
SetItem (+) |

Properties
Property | Description
Clients (+) |
Count (+) |
Items (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IAction)
Next (ICartPlayerControl)


Previous
Next (Count)

Member
Clients

Visibility
PUBLIC

Related Class
IActionList

Description

Source code
property Clients : IInterfaceList read GetClients

Read Access
GetClients

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Count)


Previous (Clients)
Next (Items)

Member
Count

Visibility
PUBLIC

Related Class
IActionList

Description

Source code
property Count : integer read GetCount

Read Access
GetCount

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clients)
Next (Items)


Previous (Count)
Next

Member
Items

Visibility
PUBLIC

Related Class
IActionList

Description

Source code
property Items [ Index : Integer ] : IAction read GetItem write SetItem ; default

Read Access
GetItem

Write Access
SetItem

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Count)
Next


Previous
Next (Assign)

Member
ADD

Visibility
PUBLIC

Related Class
IActionList

Source code
function Add ( const iItem : IAction ) : integer

Parameters
Parameter | Description
iItem : IAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Assign)


Previous (ADD)
Next (BeginUpdate)

Member
Assign

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure Assign ( iValue : IActionList )

Parameters
Parameter | Description
iValue : IActionList |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ADD)
Next (BeginUpdate)


Previous (Assign)
Next (Clear)

Member
BeginUpdate

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure BeginUpdate

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Assign)
Next (Clear)


Previous (BeginUpdate)
Next (Delete)

Member
Clear

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure Clear

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (BeginUpdate)
Next (Delete)


Previous (Clear)
Next (EndUpdate)

Member
Delete

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clear)
Next (EndUpdate)


Previous (Delete)
Next (GetClients)

Member
EndUpdate

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure EndUpdate

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Delete)
Next (GetClients)


Previous (EndUpdate)
Next (GetCount)

Member
GetClients

Visibility
PUBLIC

Related Class
IActionList

Source code
function GetClients : IInterfaceList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (EndUpdate)
Next (GetCount)


Previous (GetClients)
Next (GetItem)

Member
GetCount

Visibility
PUBLIC

Related Class
IActionList

Source code
function GetCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetClients)
Next (GetItem)


Previous (GetCount)
Next (IndexOf)

Member
GetItem

Visibility
PUBLIC

Related Class
IActionList

Source code
function GetItem ( iIndex : Integer ) : IAction

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCount)
Next (IndexOf)


Previous (GetItem)
Next (Insert)

Member
IndexOf

Visibility
PUBLIC

Related Class
IActionList

Source code
function IndexOf ( iItem : IAction ) : integer

Parameters
Parameter | Description
iItem : IAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetItem)
Next (Insert)


Previous (IndexOf)
Next (LoadFromFile)

Member
Insert

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure Insert ( iIndex : integer ; const iItem : IAction )

Parameters
Parameter | Description
iIndex : INTEGER |
iItem : IAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IndexOf)
Next (LoadFromFile)


Previous (Insert)
Next (LoadFromXML)

Member
LoadFromFile

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Insert)
Next (LoadFromXML)


Previous (LoadFromFile)
Next (Move)

Member
LoadFromXML

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter | Description
iXML : IXMLNode |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromFile)
Next (Move)


Previous (LoadFromXML)
Next (SaveAsXML)

Member
Move

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure Move ( oldIndex : integer ; newIndex : integer )

Parameters
Parameter | Description
oldIndex : INTEGER |
newIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (Move)
Next (SaveToFile)

Member
SaveAsXML

Visibility
PUBLIC

Related Class
IActionList

Source code
function SaveAsXML ( iDocument : IXMLDocument ; iNodeName : string ) : IXMLNode

Parameters
Parameter | Description
iDocument : IXMLDocument |
iNodeName : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Move)
Next (SaveToFile)


Previous (SaveAsXML)
Next (SetItem)

Member
SaveToFile

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveAsXML)
Next (SetItem)


Previous (SaveToFile)
Next

Member
SetItem

Visibility
PUBLIC

Related Class
IActionList

Source code
procedure SetItem ( iIndex : Integer ; iValue : IAction )

Parameters
Parameter | Description
iIndex : INTEGER |
iValue : IAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveToFile)
Next


Previous (IActionList)
Next (ICartWallControl)

Class
ICartPlayerControl

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
GetFadeTrigger (+) |
GetPFLMode (+) |
GetPlayerCount (+) |
GetStack (+) |
GetStartTrigger (+) |
GetStopTrigger (+) |
SetFadeTrigger (+) |
SetPFLMode (+) |
SetStartTrigger (+) |
SetStopTrigger (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IActionList)
Next (ICartWallControl)


Previous
Next (GetPFLMode)

Member
GetFadeTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetFadeTrigger ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetPFLMode)


Previous (GetFadeTrigger)
Next (GetPlayerCount)

Member
GetPFLMode

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetFadeTrigger)
Next (GetPlayerCount)


Previous (GetPFLMode)
Next (GetStack)

Member
GetPlayerCount

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPFLMode)
Next (GetStack)


Previous (GetPlayerCount)
Next (GetStartTrigger)

Member
GetStack

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetStack : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerCount)
Next (GetStartTrigger)


Previous (GetStack)
Next (GetStopTrigger)

Member
GetStartTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetStartTrigger ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStack)
Next (GetStopTrigger)


Previous (GetStartTrigger)
Next (SetFadeTrigger)

Member
GetStopTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
function GetStopTrigger ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStartTrigger)
Next (SetFadeTrigger)


Previous (GetStopTrigger)
Next (SetPFLMode)

Member
SetFadeTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
procedure SetFadeTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter | Description
iIndex : INTEGER |
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStopTrigger)
Next (SetPFLMode)


Previous (SetFadeTrigger)
Next (SetStartTrigger)

Member
SetPFLMode

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetFadeTrigger)
Next (SetStartTrigger)


Previous (SetPFLMode)
Next (SetStopTrigger)

Member
SetStartTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
procedure SetStartTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter | Description
iIndex : INTEGER |
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetPFLMode)
Next (SetStopTrigger)


Previous (SetStartTrigger)
Next

Member
SetStopTrigger

Visibility
PUBLIC

Related Class
ICartPlayerControl

Source code
procedure SetStopTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter | Description
iIndex : INTEGER |
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetStartTrigger)
Next


Previous (ICartPlayerControl)
Next (IComPort)

Class
ICartWallControl

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
CloseAll (+) |
GetPFLMode (+) |
GetPlayerControl (+) |
GetPlayerCount (+) |
GetPlayerCountX (+) |
GetPlayerCountY (+) |
SetPFLMode (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (ICartPlayerControl)
Next (IComPort)


Previous
Next (GetPFLMode)

Member
CloseAll

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
procedure CloseAll

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetPFLMode)


Previous (CloseAll)
Next (GetPlayerControl)

Member
GetPFLMode

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CloseAll)
Next (GetPlayerControl)


Previous (GetPFLMode)
Next (GetPlayerCount)

Member
GetPlayerControl

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
function GetPlayerControl ( iIndex : integer ) : IPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPFLMode)
Next (GetPlayerCount)


Previous (GetPlayerControl)
Next (GetPlayerCountX)

Member
GetPlayerCount

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerControl)
Next (GetPlayerCountX)


Previous (GetPlayerCount)
Next (GetPlayerCountY)

Member
GetPlayerCountX

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
function GetPlayerCountX : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerCount)
Next (GetPlayerCountY)


Previous (GetPlayerCountX)
Next (SetPFLMode)

Member
GetPlayerCountY

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
function GetPlayerCountY : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerCountX)
Next (SetPFLMode)


Previous (GetPlayerCountY)
Next

Member
SetPFLMode

Visibility
PUBLIC

Related Class
ICartWallControl

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerCountY)
Next


Previous (ICartWallControl)
Next (ICuePosition)

Class
IComPort

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Open (+) |
SendStr (+) |
SetParameters (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (ICartWallControl)
Next (ICuePosition)


Previous
Next (SendStr)

Member
Open

Visibility
PUBLIC

Related Class
IComPort

Source code
procedure Open

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (SendStr)


Previous (Open)
Next (SetParameters)

Member
SendStr

Visibility
PUBLIC

Related Class
IComPort

Source code
procedure SendStr ( const Tx : string )

Parameters
Parameter | Description
Tx : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Open)
Next (SetParameters)


Previous (SendStr)
Next

Member
SetParameters

Visibility
PUBLIC

Related Class
IComPort

Source code
procedure SetParameters ( iBaudRate : integer ; iByteSize : byte ; iParity : char ; iStopBits : Single )

Parameters
Parameter | Description
iBaudRate : INTEGER |
iByteSize : BYTE |
iParity : CHAR |
iStopBits : SINGLE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SendStr)
Next


Previous (IComPort)
Next (IDatabase)

Class
ICuePosition

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
AddAlternative (+) |
ClearAlternatives (+) |
DeleteAlternative (+) |
GetAlternative (+) |
GetAlternativeCount (+) |
GetPositionType (+) |
GetValue (+) |
IndexOfAlternative (+) |
SetValue (+) |
SortAlternatives (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IComPort)
Next (IDatabase)


Previous
Next (ClearAlternatives)

Member
AddAlternative

Visibility
PUBLIC

Related Class
ICuePosition

Source code
procedure AddAlternative ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (ClearAlternatives)


Previous (AddAlternative)
Next (DeleteAlternative)

Member
ClearAlternatives

Visibility
PUBLIC

Related Class
ICuePosition

Source code
procedure ClearAlternatives

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AddAlternative)
Next (DeleteAlternative)


Previous (ClearAlternatives)
Next (GetAlternative)

Member
DeleteAlternative

Visibility
PUBLIC

Related Class
ICuePosition

Source code
procedure DeleteAlternative ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ClearAlternatives)
Next (GetAlternative)


Previous (DeleteAlternative)
Next (GetAlternativeCount)

Member
GetAlternative

Visibility
PUBLIC

Related Class
ICuePosition

Source code
function GetAlternative ( iIndex : integer ) : int64

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (DeleteAlternative)
Next (GetAlternativeCount)


Previous (GetAlternative)
Next (GetPositionType)

Member
GetAlternativeCount

Visibility
PUBLIC

Related Class
ICuePosition

Source code
function GetAlternativeCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetAlternative)
Next (GetPositionType)


Previous (GetAlternativeCount)
Next (GetValue)

Member
GetPositionType

Visibility
PUBLIC

Related Class
ICuePosition

Source code
function GetPositionType : TCuePositionType

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetAlternativeCount)
Next (GetValue)


Previous (GetPositionType)
Next (IndexOfAlternative)

Member
GetValue

Visibility
PUBLIC

Related Class
ICuePosition

Source code
function GetValue : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPositionType)
Next (IndexOfAlternative)


Previous (GetValue)
Next (SetValue)

Member
IndexOfAlternative

Visibility
PUBLIC

Related Class
ICuePosition

Source code
function IndexOfAlternative ( iValue : int64 ) : integer

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetValue)
Next (SetValue)


Previous (IndexOfAlternative)
Next (SortAlternatives)

Member
SetValue

Visibility
PUBLIC

Related Class
ICuePosition

Source code
procedure SetValue ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IndexOfAlternative)
Next (SortAlternatives)


Previous (SetValue)
Next

Member
SortAlternatives

Visibility
PUBLIC

Related Class
ICuePosition

Source code
procedure SortAlternatives

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetValue)
Next


Previous (ICuePosition)
Next (IDatabaseList)

Class
IDatabase

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Connect (+) |
CreatePlaylistItem (+) |
Disconnect (+) |
ExecuteSQL (+) |
FillDatabaseTree (+) |
GetCapabilities (+) |
GetCaption (+) |
GetCurrentPlaylist (+) |
GetID (+) |
GetNextPlaylist (+) |
GetParameters (+) |
GetPlaylist (+) |
GetPlaylistCaption (+) |
GetUniqueID (+) |
IsConnected (+) |
SavePlaylistItem (+) |
SearchItems (+) |
SetParameters (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (ICuePosition)
Next (IDatabaseList)


Previous
Next (CreatePlaylistItem)

Member
Connect

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure Connect

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (CreatePlaylistItem)


Previous (Connect)
Next (Disconnect)

Member
CreatePlaylistItem

Visibility
PUBLIC

Related Class
IDatabase

Source code
function CreatePlaylistItem ( iData0 , iData1 , iData2 , iData3 : integer ) : IPlaylistItem

Parameters
Parameter | Description
iData0 : INTEGER |
iData1 : INTEGER |
iData2 : INTEGER |
iData3 : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Connect)
Next (Disconnect)


Previous (CreatePlaylistItem)
Next (ExecuteSQL)

Member
Disconnect

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure Disconnect

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreatePlaylistItem)
Next (ExecuteSQL)


Previous (Disconnect)
Next (FillDatabaseTree)

Member
ExecuteSQL

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure ExecuteSQL ( iSQL : string )

Parameters
Parameter | Description
iSQL : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Disconnect)
Next (FillDatabaseTree)


Previous (ExecuteSQL)
Next (GetCapabilities)

Member
FillDatabaseTree

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure FillDatabaseTree ( iTree : IDatabaseTree ; iParent : cardinal ; const iParentData : TDatabaseNodeData )

Parameters
Parameter | Description
iTree : IDatabaseTree |
iParent : CARDINAL |
iParentData : TDatabaseNodeData |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteSQL)
Next (GetCapabilities)


Previous (FillDatabaseTree)
Next (GetCaption)

Member
GetCapabilities

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetCapabilities : TDatabaseCapabilities

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (FillDatabaseTree)
Next (GetCaption)


Previous (GetCapabilities)
Next (GetCurrentPlaylist)

Member
GetCaption

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetCaption : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCapabilities)
Next (GetCurrentPlaylist)


Previous (GetCaption)
Next (GetID)

Member
GetCurrentPlaylist

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetCurrentPlaylist : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCaption)
Next (GetID)


Previous (GetCurrentPlaylist)
Next (GetNextPlaylist)

Member
GetID

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetID : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCurrentPlaylist)
Next (GetNextPlaylist)


Previous (GetID)
Next (GetParameters)

Member
GetNextPlaylist

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetNextPlaylist : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetID)
Next (GetParameters)


Previous (GetNextPlaylist)
Next (GetPlaylist)

Member
GetParameters

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetParameters : TStrings

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextPlaylist)
Next (GetPlaylist)


Previous (GetParameters)
Next (GetPlaylistCaption)

Member
GetPlaylist

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetPlaylist ( iData0 , iData1 , iData2 , iData3 : integer ) : IPlaylist

Parameters
Parameter | Description
iData0 : INTEGER |
iData1 : INTEGER |
iData2 : INTEGER |
iData3 : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetParameters)
Next (GetPlaylistCaption)


Previous (GetPlaylist)
Next (GetUniqueID)

Member
GetPlaylistCaption

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetPlaylistCaption ( iPlaylistID : integer ) : string

Parameters
Parameter | Description
iPlaylistID : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaylist)
Next (GetUniqueID)


Previous (GetPlaylistCaption)
Next (IsConnected)

Member
GetUniqueID

Visibility
PUBLIC

Related Class
IDatabase

Source code
function GetUniqueID : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaylistCaption)
Next (IsConnected)


Previous (GetUniqueID)
Next (SavePlaylistItem)

Member
IsConnected

Visibility
PUBLIC

Related Class
IDatabase

Source code
function IsConnected : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetUniqueID)
Next (SavePlaylistItem)


Previous (IsConnected)
Next (SearchItems)

Member
SavePlaylistItem

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure SavePlaylistItem ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IsConnected)
Next (SearchItems)


Previous (SavePlaylistItem)
Next (SetParameters)

Member
SearchItems

Visibility
PUBLIC

Related Class
IDatabase

Source code
function SearchItems ( iSearchString : string ) : IPlaylist

Parameters
Parameter | Description
iSearchString : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SavePlaylistItem)
Next (SetParameters)


Previous (SearchItems)
Next

Member
SetParameters

Visibility
PUBLIC

Related Class
IDatabase

Source code
procedure SetParameters ( iValue : TStrings )

Parameters
Parameter | Description
iValue : TStrings |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SearchItems)
Next


Previous (IDatabase)
Next (IEngine)

Class
IDatabaseList

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
GetCount (+) |
GetItem (+) |

Properties
Property | Description
Count (+) |
Items (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IDatabase)
Next (IEngine)


Previous
Next (Items)

Member
Count

Visibility
PUBLIC

Related Class
IDatabaseList

Description

Source code
property Count : integer read GetCount

Read Access
GetCount

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Items)


Previous (Count)
Next

Member
Items

Visibility
PUBLIC

Related Class
IDatabaseList

Description

Source code
property Items [ iIndex : integer ] : IDatabase read GetItem ; default

Read Access
GetItem

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Count)
Next


Previous
Next (GetItem)

Member
GetCount

Visibility
PUBLIC

Related Class
IDatabaseList

Source code
function GetCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetItem)


Previous (GetCount)
Next

Member
GetItem

Visibility
PUBLIC

Related Class
IDatabaseList

Source code
function GetItem ( iIndex : integer ) : IDatabase

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCount)
Next


Previous (IDatabaseList)
Next (IEventList)

Class
IEngine

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
ExecuteCommand (+) |
GetActivePlayers (+) |
GetCartwallControl (+) |
GetDatabases (+) |
GetOnAir (+) |
GetPlaybackControl (+) |
GetPlaybackControlCount (+) |
GetRecycleBin (+) |
GetRemoteController (+) |
RunScript (+) |
SetOnAir (+) |
SystemLog (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IDatabaseList)
Next (IEventList)


Previous
Next (GetActivePlayers)

Member
ExecuteCommand

Visibility
PUBLIC

Related Class
IEngine

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetActivePlayers)


Previous (ExecuteCommand)
Next (GetCartwallControl)

Member
GetActivePlayers

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetActivePlayers : IInterfaceList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteCommand)
Next (GetCartwallControl)


Previous (GetActivePlayers)
Next (GetDatabases)

Member
GetCartwallControl

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetActivePlayers)
Next (GetDatabases)


Previous (GetCartwallControl)
Next (GetOnAir)

Member
GetDatabases

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetDatabases : IDatabaseList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCartwallControl)
Next (GetOnAir)


Previous (GetDatabases)
Next (GetPlaybackControl)

Member
GetOnAir

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetOnAir : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDatabases)
Next (GetPlaybackControl)


Previous (GetOnAir)
Next (GetPlaybackControlCount)

Member
GetPlaybackControl

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetPlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOnAir)
Next (GetPlaybackControlCount)


Previous (GetPlaybackControl)
Next (GetRecycleBin)

Member
GetPlaybackControlCount

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaybackControl)
Next (GetRecycleBin)


Previous (GetPlaybackControlCount)
Next (GetRemoteController)

Member
GetRecycleBin

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetRecycleBin : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaybackControlCount)
Next (GetRemoteController)


Previous (GetRecycleBin)
Next (RunScript)

Member
GetRemoteController

Visibility
PUBLIC

Related Class
IEngine

Source code
function GetRemoteController : IRemoteController

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetRecycleBin)
Next (RunScript)


Previous (GetRemoteController)
Next (SetOnAir)

Member
RunScript

Visibility
PUBLIC

Related Class
IEngine

Source code
procedure RunScript ( iFilename : string ; iCurrentPlaylist : integer )

Parameters
Parameter | Description
iFilename : STRING |
iCurrentPlaylist : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetRemoteController)
Next (SetOnAir)


Previous (RunScript)
Next (SystemLog)

Member
SetOnAir

Visibility
PUBLIC

Related Class
IEngine

Source code
procedure SetOnAir ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (RunScript)
Next (SystemLog)


Previous (SetOnAir)
Next

Member
SystemLog

Visibility
PUBLIC

Related Class
IEngine

Source code
procedure SystemLog ( iCategory : TLogCategory ; iMessage : string )

Parameters
Parameter | Description
iCategory : TLogCategory |
iMessage : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetOnAir)
Next


Previous (IEngine)
Next (IEventListItem)

Class
IEventList

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
ADD (+) |
AddItem (+) |
Clear (+) |
Delete (+) |
GetCount (+) |
GetFilename (+) |
GetItem (+) |
GetNextExecution (+) |
GetNextItem (+) |
GetNextItemAssist (+) |
GetNextItemAutomation (+) |
IndexOf (+) |
LoadFromFile (+) |
SaveToFile (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IEngine)
Next (IEventListItem)


Previous
Next (AddItem)

Member
ADD

Visibility
PUBLIC

Related Class
IEventList

Source code
function Add ( iItem : IEventListItem ) : integer

Parameters
Parameter | Description
iItem : IEventListItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (AddItem)


Previous (ADD)
Next (Clear)

Member
AddItem

Visibility
PUBLIC

Related Class
IEventList

Source code
function AddItem : IEventListItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ADD)
Next (Clear)


Previous (AddItem)
Next (Delete)

Member
Clear

Visibility
PUBLIC

Related Class
IEventList

Source code
procedure Clear

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AddItem)
Next (Delete)


Previous (Clear)
Next (GetCount)

Member
Delete

Visibility
PUBLIC

Related Class
IEventList

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clear)
Next (GetCount)


Previous (Delete)
Next (GetFilename)

Member
GetCount

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Delete)
Next (GetFilename)


Previous (GetCount)
Next (GetItem)

Member
GetFilename

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetFilename : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCount)
Next (GetItem)


Previous (GetFilename)
Next (GetNextExecution)

Member
GetItem

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetItem ( iIndex : Integer ) : IEventListItem

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetFilename)
Next (GetNextExecution)


Previous (GetItem)
Next (GetNextItem)

Member
GetNextExecution

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetItem)
Next (GetNextItem)


Previous (GetNextExecution)
Next (GetNextItemAssist)

Member
GetNextItem

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetNextItem : IEventListItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextExecution)
Next (GetNextItemAssist)


Previous (GetNextItem)
Next (GetNextItemAutomation)

Member
GetNextItemAssist

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetNextItemAssist : IEventListItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextItem)
Next (GetNextItemAutomation)


Previous (GetNextItemAssist)
Next (IndexOf)

Member
GetNextItemAutomation

Visibility
PUBLIC

Related Class
IEventList

Source code
function GetNextItemAutomation : IEventListItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextItemAssist)
Next (IndexOf)


Previous (GetNextItemAutomation)
Next (LoadFromFile)

Member
IndexOf

Visibility
PUBLIC

Related Class
IEventList

Source code
function IndexOf ( iItem : IEventListItem ) : integer

Parameters
Parameter | Description
iItem : IEventListItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextItemAutomation)
Next (LoadFromFile)


Previous (IndexOf)
Next (SaveToFile)

Member
LoadFromFile

Visibility
PUBLIC

Related Class
IEventList

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IndexOf)
Next (SaveToFile)


Previous (LoadFromFile)
Next

Member
SaveToFile

Visibility
PUBLIC

Related Class
IEventList

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromFile)
Next


Previous (IEventList)
Next (IIOPort)

Class
IEventListItem

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Commit (+) |
GetActionParameter (+) |
GetActionType (+) |
GetDay (+) |
GetDescription (+) |
GetExpiration (+) |
GetExpires (+) |
GetHour (+) |
GetLastExecution (+) |
GetMinute (+) |
GetMonth (+) |
GetNextExecution (+) |
GetRunInAssist (+) |
GetRunInAutomation (+) |
GetSecond (+) |
GetWeekday (+) |
GetYear (+) |
SetActionParameter (+) |
SetActionType (+) |
SetDescription (+) |
SetExpiration (+) |
SetExpires (+) |
SetRunInAssist (+) |
SetRunInAutomation (+) |
SetYear (+) |
UpdateExecution (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IEventList)
Next (IIOPort)


Previous
Next (GetActionParameter)

Member
Commit

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure Commit

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetActionParameter)


Previous (Commit)
Next (GetActionType)

Member
GetActionParameter

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetActionParameter : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Commit)
Next (GetActionType)


Previous (GetActionParameter)
Next (GetDay)

Member
GetActionType

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetActionType : TEventActionType

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetActionParameter)
Next (GetDay)


Previous (GetActionType)
Next (GetDescription)

Member
GetDay

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetDay : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetActionType)
Next (GetDescription)


Previous (GetDay)
Next (GetExpiration)

Member
GetDescription

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetDescription : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDay)
Next (GetExpiration)


Previous (GetDescription)
Next (GetExpires)

Member
GetExpiration

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetExpiration : TDateTime

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDescription)
Next (GetExpires)


Previous (GetExpiration)
Next (GetHour)

Member
GetExpires

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetExpires : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetExpiration)
Next (GetHour)


Previous (GetExpires)
Next (GetLastExecution)

Member
GetHour

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetHour : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetExpires)
Next (GetLastExecution)


Previous (GetHour)
Next (GetMinute)

Member
GetLastExecution

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetLastExecution : TDateTime

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetHour)
Next (GetMinute)


Previous (GetLastExecution)
Next (GetMonth)

Member
GetMinute

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetMinute : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetLastExecution)
Next (GetMonth)


Previous (GetMinute)
Next (GetNextExecution)

Member
GetMonth

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetMonth : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetMinute)
Next (GetNextExecution)


Previous (GetMonth)
Next (GetRunInAssist)

Member
GetNextExecution

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetMonth)
Next (GetRunInAssist)


Previous (GetNextExecution)
Next (GetRunInAutomation)

Member
GetRunInAssist

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetRunInAssist : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextExecution)
Next (GetRunInAutomation)


Previous (GetRunInAssist)
Next (GetSecond)

Member
GetRunInAutomation

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetRunInAutomation : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetRunInAssist)
Next (GetSecond)


Previous (GetRunInAutomation)
Next (GetWeekday)

Member
GetSecond

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetSecond : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetRunInAutomation)
Next (GetWeekday)


Previous (GetSecond)
Next (GetYear)

Member
GetWeekday

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetWeekday : TByteSet

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetSecond)
Next (GetYear)


Previous (GetWeekday)
Next (SetActionParameter)

Member
GetYear

Visibility
PUBLIC

Related Class
IEventListItem

Source code
function GetYear : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetWeekday)
Next (SetActionParameter)


Previous (GetYear)
Next (SetActionType)

Member
SetActionParameter

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetActionParameter ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetYear)
Next (SetActionType)


Previous (SetActionParameter)
Next (SetDescription)

Member
SetActionType

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetActionType ( iValue : TEventActionType )

Parameters
Parameter | Description
iValue : TEventActionType |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetActionParameter)
Next (SetDescription)


Previous (SetActionType)
Next (SetExpiration)

Member
SetDescription

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetActionType)
Next (SetExpiration)


Previous (SetDescription)
Next (SetExpires)

Member
SetExpiration

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetExpiration ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDescription)
Next (SetExpires)


Previous (SetExpiration)
Next (SetRunInAssist)

Member
SetExpires

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetExpires ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetExpiration)
Next (SetRunInAssist)


Previous (SetExpires)
Next (SetRunInAutomation)

Member
SetRunInAssist

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetRunInAssist ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetExpires)
Next (SetRunInAutomation)


Previous (SetRunInAssist)
Next (SetYear)

Member
SetRunInAutomation

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetRunInAutomation ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetRunInAssist)
Next (SetYear)


Previous (SetRunInAutomation)
Next (UpdateExecution)

Member
SetYear

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure SetYear ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetRunInAutomation)
Next (UpdateExecution)


Previous (SetYear)
Next

Member
UpdateExecution

Visibility
PUBLIC

Related Class
IEventListItem

Source code
procedure UpdateExecution

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetYear)
Next


Previous (IEventListItem)
Next (IIOWarrior)

Class
IIOPort

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
READ (+) |
WRITE (+) |
WriteAND (+) |
WriteOR (+) |
WriteXOR (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IEventListItem)
Next (IIOWarrior)


Previous
Next (WRITE)

Member
READ

Visibility
PUBLIC

Related Class
IIOPort

Source code
function Read : byte

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (WRITE)


Previous (READ)
Next (WriteAND)

Member
WRITE

Visibility
PUBLIC

Related Class
IIOPort

Source code
procedure Write ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (READ)
Next (WriteAND)


Previous (WRITE)
Next (WriteOR)

Member
WriteAND

Visibility
PUBLIC

Related Class
IIOPort

Source code
procedure WriteAND ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (WRITE)
Next (WriteOR)


Previous (WriteAND)
Next (WriteXOR)

Member
WriteOR

Visibility
PUBLIC

Related Class
IIOPort

Source code
procedure WriteOR ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (WriteAND)
Next (WriteXOR)


Previous (WriteOR)
Next

Member
WriteXOR

Visibility
PUBLIC

Related Class
IIOPort

Source code
procedure WriteXOR ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (WriteOR)
Next


Previous (IIOPort)
Next (IMixer)

Class
IIOWarrior

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
GetPort (+) |
SetPort (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IIOPort)
Next (IMixer)


Previous
Next (SetPort)

Member
GetPort

Visibility
PUBLIC

Related Class
IIOWarrior

Source code
function GetPort ( iIndex : integer ; iPort : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |
iPort : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Member
SetPort

Visibility
PUBLIC

Related Class
IIOWarrior

Source code
procedure SetPort ( iIndex : integer ; iPort : integer ; iValue : boolean )

Parameters
Parameter | Description
iIndex : INTEGER |
iPort : INTEGER |
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPort)
Next


Previous (IIOWarrior)
Next (IPlaybackControl)

Class
IMixer

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
GetDestinationCount (+) |
GetProductName (+) |
GetVolume (+) |
IsMuted (+) |
Mute (+) |
SetVolume (+) |
Unmute (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IIOWarrior)
Next (IPlaybackControl)


Previous
Next (GetProductName)

Member
GetDestinationCount

Visibility
PUBLIC

Related Class
IMixer

Source code
function GetDestinationCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetProductName)


Previous (GetDestinationCount)
Next (GetVolume)

Member
GetProductName

Visibility
PUBLIC

Related Class
IMixer

Source code
function GetProductName : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDestinationCount)
Next (GetVolume)


Previous (GetProductName)
Next (IsMuted)

Member
GetVolume

Visibility
PUBLIC

Related Class
IMixer

Source code
procedure GetVolume ( iDestination , iConnection : integer ; var oLeft , oRight : integer )

Parameters
Parameter | Description
iDestination : INTEGER |
iConnection : INTEGER |
oLeft : INTEGER |
oRight : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetProductName)
Next (IsMuted)


Previous (GetVolume)
Next (Mute)

Member
IsMuted

Visibility
PUBLIC

Related Class
IMixer

Source code
function IsMuted ( iDestination , iConnection : integer ) : boolean

Parameters
Parameter | Description
iDestination : INTEGER |
iConnection : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetVolume)
Next (Mute)


Previous (IsMuted)
Next (SetVolume)

Member
Mute

Visibility
PUBLIC

Related Class
IMixer

Source code
procedure Mute ( iDestination , iConnection : integer )

Parameters
Parameter | Description
iDestination : INTEGER |
iConnection : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IsMuted)
Next (SetVolume)


Previous (Mute)
Next (Unmute)

Member
SetVolume

Visibility
PUBLIC

Related Class
IMixer

Source code
procedure SetVolume ( iDestination , iConnection : integer ; iLeft , iRight : integer )

Parameters
Parameter | Description
iDestination : INTEGER |
iConnection : INTEGER |
iLeft : INTEGER |
iRight : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Mute)
Next (Unmute)


Previous (SetVolume)
Next

Member
Unmute

Visibility
PUBLIC

Related Class
IMixer

Source code
procedure Unmute ( iDestination , iConnection : integer )

Parameters
Parameter | Description
iDestination : INTEGER |
iConnection : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetVolume)
Next


Previous (IMixer)
Next (IPlayerControl)

Class
IPlaybackControl

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
AutomationBreak (+) | Stops automation after the current item.
AutomationJump (+) | Jumps to a specific item.
AutomationJumpSoft (+) | Marks all items before the specified one as played, so that iItem will
AutomationNext (+) | Makes the automation jump to the next item, or starts playback in case
AutomationPlay (+) | Starts automation playback. Automation must be activated with SetAutomation
AutomationStop (+) | Stops automation playback. The current item is faded out.
ExecuteCommand (+) |
GetAutomation (+) | Determines whether automation mode is active or not.
GetAutomationPlaying (+) |
GetDefaultFadeDuration (+) |
GetEventList (+) |
GetIndex (+) | Returns the index of this PlaybackControl object within the mAirList system.
GetMaxHistoryCount (+) |
GetNextIndex (+) | Determines the index of the item which will be played next. If one of
GetOptions (+) |
GetPlayer (+) | Returns a player object.
GetPlayerCount (+) | Returns the number of players associated with this PlaybackControl object.
GetPlayerOfItem (+) | Returns the player object in which a specific item is loaded.
GetPlaylist (+) | Returns the playlist data associated with this PlaybackControl object.
MoveToHistory (+) |
PFLOff (+) | Deactivates PFL of a player.
PFLOn (+) | Activates PFL of a player.
PlayerAutoLoad (+) | Loads a player with the next available, unused item. The player must be empty.
PlayerClose (+) | Closes (unloads) a player.
PlayerFadeOut (+) | Fades out a player.
PlayerLoad (+) | Loads a player with a specific item. The player is unloaded if a different
PlayerPause (+) | Pauses a player.
PlayerReset (+) | Resets a player, causing it to go back to the cue in marker or beginning
PlayerStart (+) | Starts a player.
PlayerStop (+) | Stops a player.
PlayItemDetached (+) | Start playback of an item on the given device, without caring for it thereafter.
RecycleFromHistory (+) |
SetAutomation (+) | Enables or disables automation mode.
SetDefaultFadeDuration (+) |
SetMaxHistoryCount (+) |
SetPlayerCount (+) |
SwapPlayers (+) | Swaps the items loaded in the specified players.

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IMixer)
Next (IPlayerControl)


Previous
Next (AutomationJump)

Member
AutomationBreak

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Stops automation after the current item.

Source code
procedure AutomationBreak

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (AutomationJump)


Previous (AutomationBreak)
Next (AutomationJumpSoft)

Member
AutomationJump

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Jumps to a specific item.

Source code
procedure AutomationJump ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item, which must be inside the current playlist.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationBreak)
Next (AutomationJumpSoft)


Previous (AutomationJump)
Next (AutomationNext)

Member
AutomationJumpSoft

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Marks all items before the specified one as played, so that iItem will
be played next.

Source code
procedure AutomationJumpSoft ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationJump)
Next (AutomationNext)


Previous (AutomationJumpSoft)
Next (AutomationPlay)

Member
AutomationNext

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Makes the automation jump to the next item, or starts playback in case
playback is stopped at the momemnt. Automation must be activated.

Source code
procedure AutomationNext

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationJumpSoft)
Next (AutomationPlay)


Previous (AutomationNext)
Next (AutomationStop)

Member
AutomationPlay

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Starts automation playback. Automation must be activated with SetAutomation
first.

Source code
procedure AutomationPlay

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationNext)
Next (AutomationStop)


Previous (AutomationPlay)
Next (ExecuteCommand)

Member
AutomationStop

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Stops automation playback. The current item is faded out.

Source code
procedure AutomationStop

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationPlay)
Next (ExecuteCommand)


Previous (AutomationStop)
Next (GetAutomation)

Member
ExecuteCommand

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AutomationStop)
Next (GetAutomation)


Previous (ExecuteCommand)
Next (GetAutomationPlaying)

Member
GetAutomation

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Determines whether automation mode is active or not.

Source code
function GetAutomation : boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | true if automation is active, false otherwise.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteCommand)
Next (GetAutomationPlaying)


Previous (GetAutomation)
Next (GetDefaultFadeDuration)

Member
GetAutomationPlaying

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
function GetAutomationPlaying : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetAutomation)
Next (GetDefaultFadeDuration)


Previous (GetAutomationPlaying)
Next (GetEventList)

Member
GetDefaultFadeDuration

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
function GetDefaultFadeDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetAutomationPlaying)
Next (GetEventList)


Previous (GetDefaultFadeDuration)
Next (GetIndex)

Member
GetEventList

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
function GetEventList : IEventList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDefaultFadeDuration)
Next (GetIndex)


Previous (GetEventList)
Next (GetMaxHistoryCount)

Member
GetIndex

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Returns the index of this PlaybackControl object within the mAirList system.

Source code
function GetIndex : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The index, where 0 is the first PlaybackControl object.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEventList)
Next (GetMaxHistoryCount)


Previous (GetIndex)
Next (GetNextIndex)

Member
GetMaxHistoryCount

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
function GetMaxHistoryCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetIndex)
Next (GetNextIndex)


Previous (GetMaxHistoryCount)
Next (GetOptions)

Member
GetNextIndex

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Determines the index of the item which will be played next. If one of
the players is marked as IsNext, the result of this function corresponds
to the index of that player's items. If all players are active, the result
will be the index of the "downmost" player plus one. If no players are
loaded, the result will correspond to GetPlayer.GetHistoryCount.

Source code
function GetNextIndex : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetMaxHistoryCount)
Next (GetOptions)


Previous (GetNextIndex)
Next (GetPlayer)

Member
GetOptions

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
function GetOptions : TPlaybackControlOptions

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNextIndex)
Next (GetPlayer)


Previous (GetOptions)
Next (GetPlayerCount)

Member
GetPlayer

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Returns a player object.

Source code
function GetPlayer ( iIndex : integer ) : IPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER | The number of the player to retrieve.

Return
Types | Description
IPlayerControl | The player object.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOptions)
Next (GetPlayerCount)


Previous (GetPlayer)
Next (GetPlayerOfItem)

Member
GetPlayerCount

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Returns the number of players associated with this PlaybackControl object.

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The number of players.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayer)
Next (GetPlayerOfItem)


Previous (GetPlayerCount)
Next (GetPlaylist)

Member
GetPlayerOfItem

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Returns the player object in which a specific item is loaded.

Source code
function GetPlayerOfItem ( iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to look for.

Return
Types | Description
INTEGER | The player object in which the item is loaded, or -1 if the item was not found.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerCount)
Next (GetPlaylist)


Previous (GetPlayerOfItem)
Next (MoveToHistory)

Member
GetPlaylist

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Returns the playlist data associated with this PlaybackControl object.

Source code
function GetPlaylist : IPlaylist

Parameters
Parameter Description

Return
Types | Description
IPlaylist | The playlist data.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlayerOfItem)
Next (MoveToHistory)


Previous (GetPlaylist)
Next (PFLOff)

Member
MoveToHistory

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure MoveToHistory ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaylist)
Next (PFLOff)


Previous (MoveToHistory)
Next (PFLOn)

Member
PFLOff

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Deactivates PFL of a player.

Source code
procedure PFLOff ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (MoveToHistory)
Next (PFLOn)


Previous (PFLOff)
Next (PlayerAutoLoad)

Member
PFLOn

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Activates PFL of a player.

Source code
procedure PFLOn ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PFLOff)
Next (PlayerAutoLoad)


Previous (PFLOn)
Next (PlayerClose)

Member
PlayerAutoLoad

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Loads a player with the next available, unused item. The player must be empty.

Source code
function PlayerAutoLoad ( iPlayer : integer ) : boolean

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Return
Types | Description
BOOLEAN | true if loading succeeded, false if player is not empty or no available item found

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PFLOn)
Next (PlayerClose)


Previous (PlayerAutoLoad)
Next (PlayerFadeOut)

Member
PlayerClose

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Closes (unloads) a player.

Source code
procedure PlayerClose ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerAutoLoad)
Next (PlayerFadeOut)


Previous (PlayerClose)
Next (PlayerLoad)

Member
PlayerFadeOut

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Fades out a player.

Source code
procedure PlayerFadeOut ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerClose)
Next (PlayerLoad)


Previous (PlayerFadeOut)
Next (PlayerPause)

Member
PlayerLoad

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Loads a player with a specific item. The player is unloaded if a different
item is loaded. If the player is playing, nothing will happen.

Source code
procedure PlayerLoad ( iPlayer : integer ; iItem : IPlaylistItem )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.
iItem : IPlaylistItem | The item, which must be from the current playlist.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerFadeOut)
Next (PlayerPause)


Previous (PlayerLoad)
Next (PlayerReset)

Member
PlayerPause

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Pauses a player.

Source code
procedure PlayerPause ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerLoad)
Next (PlayerReset)


Previous (PlayerPause)
Next (PlayerStart)

Member
PlayerReset

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Resets a player, causing it to go back to the cue in marker or beginning
of the file.

Source code
procedure PlayerReset ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerPause)
Next (PlayerStart)


Previous (PlayerReset)
Next (PlayerStop)

Member
PlayerStart

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Starts a player.

Source code
procedure PlayerStart ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerReset)
Next (PlayerStop)


Previous (PlayerStart)
Next (PlayItemDetached)

Member
PlayerStop

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Stops a player.

Source code
procedure PlayerStop ( iPlayer : integer )

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerStart)
Next (PlayItemDetached)


Previous (PlayerStop)
Next (RecycleFromHistory)

Member
PlayItemDetached

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Start playback of an item on the given device, without caring for it thereafter.
This function can be used to play items independent from the actual players.
To create a file playlist item on the fly, use the
CreatePlaylistItemFromFile method.
The audio device can be grabbed from one of the players, for example by
CurrentPlaybackControl.GetPlayer(0).GetOutputDevice, or you can use
the BuildAudioDevice to create one.

Source code
procedure PlayItemDetached ( iItem : IPlaylistItem ; iDevice : IAudioDevice )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to play.
iDevice : IAudioDevice | The audio device to play to.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayerStop)
Next (RecycleFromHistory)


Previous (PlayItemDetached)
Next (SetAutomation)

Member
RecycleFromHistory

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure RecycleFromHistory ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlayItemDetached)
Next (SetAutomation)


Previous (RecycleFromHistory)
Next (SetDefaultFadeDuration)

Member
SetAutomation

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Enables or disables automation mode.

Source code
procedure SetAutomation ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | true to activate, false to deactive.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (RecycleFromHistory)
Next (SetDefaultFadeDuration)


Previous (SetAutomation)
Next (SetMaxHistoryCount)

Member
SetDefaultFadeDuration

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure SetDefaultFadeDuration ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetAutomation)
Next (SetMaxHistoryCount)


Previous (SetDefaultFadeDuration)
Next (SetPlayerCount)

Member
SetMaxHistoryCount

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure SetMaxHistoryCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDefaultFadeDuration)
Next (SetPlayerCount)


Previous (SetMaxHistoryCount)
Next (SwapPlayers)

Member
SetPlayerCount

Visibility
PUBLIC

Related Class
IPlaybackControl

Source code
procedure SetPlayerCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetMaxHistoryCount)
Next (SwapPlayers)


Previous (SetPlayerCount)
Next

Member
SwapPlayers

Visibility
PUBLIC

Related Class
IPlaybackControl

Description

Swaps the items loaded in the specified players.
Neither player may be in state PS_PLAYING.

Source code
procedure SwapPlayers ( iPlayer1 , iPlayer2 : integer )

Parameters
Parameter | Description
iPlayer1 : INTEGER | The first player.
iPlayer2 : INTEGER | The second player.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetPlayerCount)
Next


Previous (IPlaybackControl)
Next (IPlaylist)

Class
IPlayerControl

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
CanOpen (+) |
Close (+) |
ExecuteCommand (+) |
ExecutePlayerCommand (+) |
FadeOut (+) |
GetAutoFadeOut (+) |
GetCaption (+) |
GetClients (+) |
GetColor (+) |
GetDefaultFadeDuration (+) |
GetEndMonDuration (+) |
GetEOFWarning (+) |
GetErrorMessage (+) |
GetIndex (+) |
GetIsNext (+) |
GetItem (+) |
GetOptions (+) |
GetOutputDevice (+) |
GetPFL (+) |
GetPFLOutputDevice (+) |
GetPFLSource (+) |
GetPlaybackControlIndex (+) |
GetPlaybackStartPos (+) |
GetPlaybackStartTime (+) |
GetPosition (+) |
GetSource (+) |
GetState (+) |
GetUpdateInterval (+) |
GetVolume (+) |
Open (+) |
OpenRequest (+) |
Pause (+) |
PFLOff (+) |
PFLOn (+) |
PFLOnPaused (+) |
ReleaseItem (+) |
Reset (+) |
SetAutoFadeOut (+) |
SetCaption (+) |
SetColor (+) |
SetDefaultFadeDuration (+) |
SetEndMonDuration (+) |
SetEOFWarning (+) |
SetIsNext (+) |
SetOptions (+) |
SetOutputDevice (+) |
SetPFL (+) |
SetPFLOutputDevice (+) |
SetUpdateInterval (+) |
SetVolume (+) |
Start (+) |
Stop (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IPlaybackControl)
Next (IPlaylist)


Previous
Next (Close)

Member
CanOpen

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure CanOpen ( iItem : IPlaylistItem ; var Accept : boolean )

Parameters
Parameter | Description
iItem : IPlaylistItem |
Accept : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Close)


Previous (CanOpen)
Next (ExecuteCommand)

Member
Close

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Close

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CanOpen)
Next (ExecuteCommand)


Previous (Close)
Next (ExecutePlayerCommand)

Member
ExecuteCommand

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Close)
Next (ExecutePlayerCommand)


Previous (ExecuteCommand)
Next (FadeOut)

Member
ExecutePlayerCommand

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure ExecutePlayerCommand ( iCommand : TPlayerCommand )

Parameters
Parameter | Description
iCommand : TPlayerCommand |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteCommand)
Next (FadeOut)


Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)

Member
FadeOut

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure FadeOut ( iManual : boolean = true )

Parameters
Parameter | Description
iManual : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)


Previous (FadeOut)
Next (GetCaption)

Member
GetAutoFadeOut

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetAutoFadeOut : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (FadeOut)
Next (GetCaption)


Previous (GetAutoFadeOut)
Next (GetClients)

Member
GetCaption

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetCaption : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetAutoFadeOut)
Next (GetClients)


Previous (GetCaption)
Next (GetColor)

Member
GetClients

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetClients : IInterfaceList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCaption)
Next (GetColor)


Previous (GetClients)
Next (GetDefaultFadeDuration)

Member
GetColor

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetColor : TColor

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetClients)
Next (GetDefaultFadeDuration)


Previous (GetColor)
Next (GetEndMonDuration)

Member
GetDefaultFadeDuration

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetDefaultFadeDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetColor)
Next (GetEndMonDuration)


Previous (GetDefaultFadeDuration)
Next (GetEOFWarning)

Member
GetEndMonDuration

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetEndMonDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDefaultFadeDuration)
Next (GetEOFWarning)


Previous (GetEndMonDuration)
Next (GetErrorMessage)

Member
GetEOFWarning

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetEOFWarning : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEndMonDuration)
Next (GetErrorMessage)


Previous (GetEOFWarning)
Next (GetIndex)

Member
GetErrorMessage

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetErrorMessage : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEOFWarning)
Next (GetIndex)


Previous (GetErrorMessage)
Next (GetIsNext)

Member
GetIndex

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetIndex : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetErrorMessage)
Next (GetIsNext)


Previous (GetIndex)
Next (GetItem)

Member
GetIsNext

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetIsNext : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetIndex)
Next (GetItem)


Previous (GetIsNext)
Next (GetOptions)

Member
GetItem

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetIsNext)
Next (GetOptions)


Previous (GetItem)
Next (GetOutputDevice)

Member
GetOptions

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetOptions : TPlayerControlOptions

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetItem)
Next (GetOutputDevice)


Previous (GetOptions)
Next (GetPFL)

Member
GetOutputDevice

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetOutputDevice : IAudioDevice

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOptions)
Next (GetPFL)


Previous (GetOutputDevice)
Next (GetPFLOutputDevice)

Member
GetPFL

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPFL : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOutputDevice)
Next (GetPFLOutputDevice)


Previous (GetPFL)
Next (GetPFLSource)

Member
GetPFLOutputDevice

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPFLOutputDevice : IAudioDevice

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPFL)
Next (GetPFLSource)


Previous (GetPFLOutputDevice)
Next (GetPlaybackControlIndex)

Member
GetPFLSource

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPFLSource : IAudioSource

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPFLOutputDevice)
Next (GetPlaybackControlIndex)


Previous (GetPFLSource)
Next (GetPlaybackStartPos)

Member
GetPlaybackControlIndex

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPlaybackControlIndex : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPFLSource)
Next (GetPlaybackStartPos)


Previous (GetPlaybackControlIndex)
Next (GetPlaybackStartTime)

Member
GetPlaybackStartPos

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPlaybackStartPos : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaybackControlIndex)
Next (GetPlaybackStartTime)


Previous (GetPlaybackStartPos)
Next (GetPosition)

Member
GetPlaybackStartTime

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPlaybackStartTime : TDateTime

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaybackStartPos)
Next (GetPosition)


Previous (GetPlaybackStartTime)
Next (GetSource)

Member
GetPosition

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetPosition : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPlaybackStartTime)
Next (GetSource)


Previous (GetPosition)
Next (GetState)

Member
GetSource

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPosition)
Next (GetState)


Previous (GetSource)
Next (GetUpdateInterval)

Member
GetState

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetState : TPlayerState

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetSource)
Next (GetUpdateInterval)


Previous (GetState)
Next (GetVolume)

Member
GetUpdateInterval

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetUpdateInterval : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetState)
Next (GetVolume)


Previous (GetUpdateInterval)
Next (Open)

Member
GetVolume

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
function GetVolume : byte

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetUpdateInterval)
Next (Open)


Previous (GetVolume)
Next (OpenRequest)

Member
Open

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Open ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetVolume)
Next (OpenRequest)


Previous (Open)
Next (Pause)

Member
OpenRequest

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure OpenRequest ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Open)
Next (Pause)


Previous (OpenRequest)
Next (PFLOff)

Member
Pause

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Pause

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (OpenRequest)
Next (PFLOff)


Previous (Pause)
Next (PFLOn)

Member
PFLOff

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure PFLOff

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Pause)
Next (PFLOn)


Previous (PFLOff)
Next (PFLOnPaused)

Member
PFLOn

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure PFLOn

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PFLOff)
Next (PFLOnPaused)


Previous (PFLOn)
Next (ReleaseItem)

Member
PFLOnPaused

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure PFLOnPaused

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PFLOn)
Next (ReleaseItem)


Previous (PFLOnPaused)
Next (Reset)

Member
ReleaseItem

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure ReleaseItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PFLOnPaused)
Next (Reset)


Previous (ReleaseItem)
Next (SetAutoFadeOut)

Member
Reset

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Reset

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ReleaseItem)
Next (SetAutoFadeOut)


Previous (Reset)
Next (SetCaption)

Member
SetAutoFadeOut

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetAutoFadeOut ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Reset)
Next (SetCaption)


Previous (SetAutoFadeOut)
Next (SetColor)

Member
SetCaption

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetCaption ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetAutoFadeOut)
Next (SetColor)


Previous (SetCaption)
Next (SetDefaultFadeDuration)

Member
SetColor

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter | Description
iValue : TColor |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetCaption)
Next (SetDefaultFadeDuration)


Previous (SetColor)
Next (SetEndMonDuration)

Member
SetDefaultFadeDuration

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetDefaultFadeDuration ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetColor)
Next (SetEndMonDuration)


Previous (SetDefaultFadeDuration)
Next (SetEOFWarning)

Member
SetEndMonDuration

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetEndMonDuration ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDefaultFadeDuration)
Next (SetEOFWarning)


Previous (SetEndMonDuration)
Next (SetIsNext)

Member
SetEOFWarning

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetEOFWarning ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetEndMonDuration)
Next (SetIsNext)


Previous (SetEOFWarning)
Next (SetOptions)

Member
SetIsNext

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetIsNext ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetEOFWarning)
Next (SetOptions)


Previous (SetIsNext)
Next (SetOutputDevice)

Member
SetOptions

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetOptions ( iValue : TPlayerControlOptions )

Parameters
Parameter | Description
iValue : TPlayerControlOptions |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetIsNext)
Next (SetOutputDevice)


Previous (SetOptions)
Next (SetPFL)

Member
SetOutputDevice

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetOutputDevice ( iValue : IAudioDevice )

Parameters
Parameter | Description
iValue : IAudioDevice |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetOptions)
Next (SetPFL)


Previous (SetOutputDevice)
Next (SetPFLOutputDevice)

Member
SetPFL

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetPFL ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetOutputDevice)
Next (SetPFLOutputDevice)


Previous (SetPFL)
Next (SetUpdateInterval)

Member
SetPFLOutputDevice

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetPFLOutputDevice ( iValue : IAudioDevice )

Parameters
Parameter | Description
iValue : IAudioDevice |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetPFL)
Next (SetUpdateInterval)


Previous (SetPFLOutputDevice)
Next (SetVolume)

Member
SetUpdateInterval

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetUpdateInterval ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetPFLOutputDevice)
Next (SetVolume)


Previous (SetUpdateInterval)
Next (Start)

Member
SetVolume

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure SetVolume ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetUpdateInterval)
Next (Start)


Previous (SetVolume)
Next (Stop)

Member
Start

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Start

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetVolume)
Next (Stop)


Previous (Start)
Next

Member
Stop

Visibility
PUBLIC

Related Class
IPlayerControl

Source code
procedure Stop

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Start)
Next


Previous (IPlayerControl)
Next (IPlaylistItem)

Class
IPlaylist

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
ADD (+) |
AppendPlaylist (+) |
Assign (+) |
Clear (+) |
Delete (+) |
ErrorCheck (+) |
GetActiveDuration (+) |
GetCount (+) |
GetDuration (+) |
GetHistoryCount (+) |
GetItem (+) |
GetNext (+) |
GetUpdateCount (+) |
IndexOf (+) |
Insert (+) |
InsertDirectory (+) |
InsertFile (+) |
InsertFiles (+) |
InsertPlaylist (+) |
LoadFromFile (+) |
LoadFromM3U (+) |
LoadFromM3UData (+) |
LoadFromMLD (+) |
LoadFromMLP (+) |
Move (+) |
SaveAsM3UData (+) |
SaveToM3U (+) |
SaveToMLP (+) |
SetItem (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IPlayerControl)
Next (IPlaylistItem)


Previous
Next (AppendPlaylist)

Member
ADD

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function Add ( const iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (AppendPlaylist)


Previous (ADD)
Next (Assign)

Member
AppendPlaylist

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure AppendPlaylist ( iPlaylist : IPlaylist )

Parameters
Parameter | Description
iPlaylist : IPlaylist |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ADD)
Next (Assign)


Previous (AppendPlaylist)
Next (Clear)

Member
Assign

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure Assign ( iPlaylist : IPlaylist )

Parameters
Parameter | Description
iPlaylist : IPlaylist |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (AppendPlaylist)
Next (Clear)


Previous (Assign)
Next (Delete)

Member
Clear

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure Clear

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Assign)
Next (Delete)


Previous (Clear)
Next (ErrorCheck)

Member
Delete

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clear)
Next (ErrorCheck)


Previous (Delete)
Next (GetActiveDuration)

Member
ErrorCheck

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Delete)
Next (GetActiveDuration)


Previous (ErrorCheck)
Next (GetCount)

Member
GetActiveDuration

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetActiveDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ErrorCheck)
Next (GetCount)


Previous (GetActiveDuration)
Next (GetDuration)

Member
GetCount

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetActiveDuration)
Next (GetDuration)


Previous (GetCount)
Next (GetHistoryCount)

Member
GetDuration

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCount)
Next (GetHistoryCount)


Previous (GetDuration)
Next (GetItem)

Member
GetHistoryCount

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetHistoryCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDuration)
Next (GetItem)


Previous (GetHistoryCount)
Next (GetNext)

Member
GetItem

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetHistoryCount)
Next (GetNext)


Previous (GetItem)
Next (GetUpdateCount)

Member
GetNext

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetNext ( iItem : IPlaylistItem ) : IPlaylistItem

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetItem)
Next (GetUpdateCount)


Previous (GetNext)
Next (IndexOf)

Member
GetUpdateCount

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function GetUpdateCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetNext)
Next (IndexOf)


Previous (GetUpdateCount)
Next (Insert)

Member
IndexOf

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function IndexOf ( iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetUpdateCount)
Next (Insert)


Previous (IndexOf)
Next (InsertDirectory)

Member
Insert

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure Insert ( iIndex : integer ; const iItem : IPlaylistItem )

Parameters
Parameter | Description
iIndex : INTEGER |
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IndexOf)
Next (InsertDirectory)


Previous (Insert)
Next (InsertFile)

Member
InsertDirectory

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function InsertDirectory ( iIndex : integer ; iDirectory : string ; iExpandAction : TExpandAction ) : integer

Parameters
Parameter | Description
iIndex : INTEGER |
iDirectory : STRING |
iExpandAction : TExpandAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Insert)
Next (InsertFile)


Previous (InsertDirectory)
Next (InsertFiles)

Member
InsertFile

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function InsertFile ( iIndex : integer ; iFilename : string ; iExpandAction : TExpandAction ) : integer

Parameters
Parameter | Description
iIndex : INTEGER |
iFilename : STRING |
iExpandAction : TExpandAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (InsertDirectory)
Next (InsertFiles)


Previous (InsertFile)
Next (InsertPlaylist)

Member
InsertFiles

Visibility
PUBLIC

Related Class
IPlaylist

Source code
function InsertFiles ( iIndex : integer ; iFiles : TStrings ; iExpandAction : TExpandAction ) : integer

Parameters
Parameter | Description
iIndex : INTEGER |
iFiles : TStrings |
iExpandAction : TExpandAction |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (InsertFile)
Next (InsertPlaylist)


Previous (InsertFiles)
Next (LoadFromFile)

Member
InsertPlaylist

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure InsertPlaylist ( iIndex : integer ; const iPlaylist : IPlaylist )

Parameters
Parameter | Description
iIndex : INTEGER |
iPlaylist : IPlaylist |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (InsertFiles)
Next (LoadFromFile)


Previous (InsertPlaylist)
Next (LoadFromM3U)

Member
LoadFromFile

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure LoadFromFile ( iFilename : string ; iAppend : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iAppend : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (InsertPlaylist)
Next (LoadFromM3U)


Previous (LoadFromFile)
Next (LoadFromM3UData)

Member
LoadFromM3U

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure LoadFromM3U ( iFilename : string ; iAppend : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iAppend : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromFile)
Next (LoadFromM3UData)


Previous (LoadFromM3U)
Next (LoadFromMLD)

Member
LoadFromM3UData

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure LoadFromM3UData ( iData : TStrings )

Parameters
Parameter | Description
iData : TStrings |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromM3U)
Next (LoadFromMLD)


Previous (LoadFromM3UData)
Next (LoadFromMLP)

Member
LoadFromMLD

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure LoadFromMLD ( iFilename : string ; iAppend : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iAppend : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromM3UData)
Next (LoadFromMLP)


Previous (LoadFromMLD)
Next (Move)

Member
LoadFromMLP

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure LoadFromMLP ( iFilename : string ; iAppend : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iAppend : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromMLD)
Next (Move)


Previous (LoadFromMLP)
Next (SaveAsM3UData)

Member
Move

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure Move ( oldIndex : integer ; newIndex : integer )

Parameters
Parameter | Description
oldIndex : INTEGER |
newIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadFromMLP)
Next (SaveAsM3UData)


Previous (Move)
Next (SaveToM3U)

Member
SaveAsM3UData

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure SaveAsM3UData ( iData : TStrings ; iIncludeHistory : boolean )

Parameters
Parameter | Description
iData : TStrings |
iIncludeHistory : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Move)
Next (SaveToM3U)


Previous (SaveAsM3UData)
Next (SaveToMLP)

Member
SaveToM3U

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure SaveToM3U ( iFilename : string ; iIncludeHistory : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iIncludeHistory : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveAsM3UData)
Next (SaveToMLP)


Previous (SaveToM3U)
Next (SetItem)

Member
SaveToMLP

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure SaveToMLP ( iFilename : string ; iIncludeHistory : boolean )

Parameters
Parameter | Description
iFilename : STRING |
iIncludeHistory : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveToM3U)
Next (SetItem)


Previous (SaveToMLP)
Next

Member
SetItem

Visibility
PUBLIC

Related Class
IPlaylist

Source code
procedure SetItem ( iIndex : Integer ; iValue : IPlaylistItem )

Parameters
Parameter | Description
iIndex : INTEGER |
iValue : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveToMLP)
Next


Previous (IPlaylist)
Next (IRemoteController)

Class
IPlaylistItem

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Assign (+) |
Clone (+) |
ErrorCheck (+) |
GetArtist (+) |
GetCapabilities (+) |
GetColor (+) |
GetColored (+) |
GetComment (+) |
GetCuePosition (+) |
GetDatabase (+) |
GetDatabaseID (+) |
GetDatabaseSubID (+) |
GetDisabled (+) |
GetDuration (+) |
GetEditableProperties (+) |
GetEffectiveDuration (+) |
GetEffectiveEnd (+) |
GetEndType (+) |
GetFadeDuration (+) |
GetHistoryFlag (+) |
GetInfo (+) |
GetOptions (+) |
GetPicture (+) |
GetPitch (+) |
GetProperty (+) |
GetStartActions (+) |
GetStartTime (+) |
GetStopActions (+) |
GetTempo (+) |
GetTitle (+) |
GetUserData (+) |
GetXML (+) |
GetXMLNodeName (+) |
LoadMMD (+) |
LoadTags (+) |
SaveMMD (+) |
SaveTags (+) |
SetArtist (+) |
SetColor (+) |
SetColored (+) |
SetComment (+) |
SetDatabaseID (+) |
SetDatabaseSubID (+) |
SetDisabled (+) |
SetDuration (+) |
SetEditableProperties (+) |
SetEndType (+) |
SetFadeDuration (+) |
SetHistoryFlag (+) |
SetOptions (+) |
SetPitch (+) |
SetProperty (+) |
SetStartTime (+) |
SetTempo (+) |
SetTitle (+) |
SetUserData (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IPlaylist)
Next (IRemoteController)


Previous
Next (Clone)

Member
Assign

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure Assign ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Clone)


Previous (Assign)
Next (ErrorCheck)

Member
Clone

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function Clone : IPlaylistItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Assign)
Next (ErrorCheck)


Previous (Clone)
Next (GetArtist)

Member
ErrorCheck

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Clone)
Next (GetArtist)


Previous (ErrorCheck)
Next (GetCapabilities)

Member
GetArtist

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetArtist : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ErrorCheck)
Next (GetCapabilities)


Previous (GetArtist)
Next (GetColor)

Member
GetCapabilities

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetCapabilities : TPlaylistItemCapabilities ; override

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetArtist)
Next (GetColor)


Previous (GetCapabilities)
Next (GetColored)

Member
GetColor

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetColor : TColor

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCapabilities)
Next (GetColored)


Previous (GetColor)
Next (GetComment)

Member
GetColored

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetColored : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetColor)
Next (GetComment)


Previous (GetColored)
Next (GetCuePosition)

Member
GetComment

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetComment : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetColored)
Next (GetCuePosition)


Previous (GetComment)
Next (GetDatabase)

Member
GetCuePosition

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetCuePosition ( iType : TCuePositionType ) : ICuePosition

Parameters
Parameter | Description
iType : TCuePositionType |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetComment)
Next (GetDatabase)


Previous (GetCuePosition)
Next (GetDatabaseID)

Member
GetDatabase

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetDatabase : IDatabase

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCuePosition)
Next (GetDatabaseID)


Previous (GetDatabase)
Next (GetDatabaseSubID)

Member
GetDatabaseID

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetDatabaseID : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDatabase)
Next (GetDatabaseSubID)


Previous (GetDatabaseID)
Next (GetDisabled)

Member
GetDatabaseSubID

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetDatabaseSubID : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDatabaseID)
Next (GetDisabled)


Previous (GetDatabaseSubID)
Next (GetDuration)

Member
GetDisabled

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetDisabled : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDatabaseSubID)
Next (GetDuration)


Previous (GetDisabled)
Next (GetEditableProperties)

Member
GetDuration

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDisabled)
Next (GetEditableProperties)


Previous (GetDuration)
Next (GetEffectiveDuration)

Member
GetEditableProperties

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetEditableProperties : TStrings

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetDuration)
Next (GetEffectiveDuration)


Previous (GetEditableProperties)
Next (GetEffectiveEnd)

Member
GetEffectiveDuration

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetEffectiveDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEditableProperties)
Next (GetEffectiveEnd)


Previous (GetEffectiveDuration)
Next (GetEndType)

Member
GetEffectiveEnd

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetEffectiveEnd : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEffectiveDuration)
Next (GetEndType)


Previous (GetEffectiveEnd)
Next (GetFadeDuration)

Member
GetEndType

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetEndType : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEffectiveEnd)
Next (GetFadeDuration)


Previous (GetEndType)
Next (GetHistoryFlag)

Member
GetFadeDuration

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetFadeDuration : int64

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetEndType)
Next (GetHistoryFlag)


Previous (GetFadeDuration)
Next (GetInfo)

Member
GetHistoryFlag

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetHistoryFlag : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetFadeDuration)
Next (GetInfo)


Previous (GetHistoryFlag)
Next (GetOptions)

Member
GetInfo

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetInfo : TStringList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetHistoryFlag)
Next (GetOptions)


Previous (GetInfo)
Next (GetPicture)

Member
GetOptions

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetOptions : TPlaylistItemOptions

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetInfo)
Next (GetPicture)


Previous (GetOptions)
Next (GetPitch)

Member
GetPicture

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetPicture : TPicture

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetOptions)
Next (GetPitch)


Previous (GetPicture)
Next (GetProperty)

Member
GetPitch

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetPitch : single

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPicture)
Next (GetProperty)


Previous (GetPitch)
Next (GetStartActions)

Member
GetProperty

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetProperty ( iName : string ) : string

Parameters
Parameter | Description
iName : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetPitch)
Next (GetStartActions)


Previous (GetProperty)
Next (GetStartTime)

Member
GetStartActions

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetStartActions : IActionList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetProperty)
Next (GetStartTime)


Previous (GetStartActions)
Next (GetStopActions)

Member
GetStartTime

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetStartTime ( iType : TStartTimeType ) : TDateTime

Parameters
Parameter | Description
iType : TStartTimeType |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStartActions)
Next (GetStopActions)


Previous (GetStartTime)
Next (GetTempo)

Member
GetStopActions

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetStopActions : IActionList

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStartTime)
Next (GetTempo)


Previous (GetStopActions)
Next (GetTitle)

Member
GetTempo

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetTempo : single

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetStopActions)
Next (GetTitle)


Previous (GetTempo)
Next (GetUserData)

Member
GetTitle

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetTitle : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetTempo)
Next (GetUserData)


Previous (GetTitle)
Next (GetXML)

Member
GetUserData

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetUserData : TStrings

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetTitle)
Next (GetXML)


Previous (GetUserData)
Next (GetXMLNodeName)

Member
GetXML

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetXML : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetUserData)
Next (GetXMLNodeName)


Previous (GetXML)
Next (LoadMMD)

Member
GetXMLNodeName

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function GetXMLNodeName : string

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetXML)
Next (LoadMMD)


Previous (GetXMLNodeName)
Next (LoadTags)

Member
LoadMMD

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function LoadMMD : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetXMLNodeName)
Next (LoadTags)


Previous (LoadMMD)
Next (SaveMMD)

Member
LoadTags

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
function LoadTags : boolean

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadMMD)
Next (SaveMMD)


Previous (LoadTags)
Next (SaveTags)

Member
SaveMMD

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SaveMMD

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (LoadTags)
Next (SaveTags)


Previous (SaveMMD)
Next (SetArtist)

Member
SaveTags

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SaveTags

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveMMD)
Next (SetArtist)


Previous (SaveTags)
Next (SetColor)

Member
SetArtist

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetArtist ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SaveTags)
Next (SetColor)


Previous (SetArtist)
Next (SetColored)

Member
SetColor

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter | Description
iValue : TColor |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetArtist)
Next (SetColored)


Previous (SetColor)
Next (SetComment)

Member
SetColored

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetColored ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetColor)
Next (SetComment)


Previous (SetColored)
Next (SetDatabaseID)

Member
SetComment

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetComment ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetColored)
Next (SetDatabaseID)


Previous (SetComment)
Next (SetDatabaseSubID)

Member
SetDatabaseID

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetDatabaseID ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetComment)
Next (SetDatabaseSubID)


Previous (SetDatabaseID)
Next (SetDisabled)

Member
SetDatabaseSubID

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetDatabaseSubID ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDatabaseID)
Next (SetDisabled)


Previous (SetDatabaseSubID)
Next (SetDuration)

Member
SetDisabled

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetDisabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDatabaseSubID)
Next (SetDuration)


Previous (SetDisabled)
Next (SetEditableProperties)

Member
SetDuration

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetDuration ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDisabled)
Next (SetEditableProperties)


Previous (SetDuration)
Next (SetEndType)

Member
SetEditableProperties

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetEditableProperties ( iValue : TStrings )

Parameters
Parameter | Description
iValue : TStrings |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetDuration)
Next (SetEndType)


Previous (SetEditableProperties)
Next (SetFadeDuration)

Member
SetEndType

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetEndType ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetEditableProperties)
Next (SetFadeDuration)


Previous (SetEndType)
Next (SetHistoryFlag)

Member
SetFadeDuration

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetFadeDuration ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetEndType)
Next (SetHistoryFlag)


Previous (SetFadeDuration)
Next (SetOptions)

Member
SetHistoryFlag

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetHistoryFlag ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetFadeDuration)
Next (SetOptions)


Previous (SetHistoryFlag)
Next (SetPitch)

Member
SetOptions

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetOptions ( iValue : TPlaylistItemOptions )

Parameters
Parameter | Description
iValue : TPlaylistItemOptions |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetHistoryFlag)
Next (SetPitch)


Previous (SetOptions)
Next (SetProperty)

Member
SetPitch

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetOptions)
Next (SetProperty)


Previous (SetPitch)
Next (SetStartTime)

Member
SetProperty

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetProperty ( iName : string ; iValue : string )

Parameters
Parameter | Description
iName : STRING |
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetPitch)
Next (SetStartTime)


Previous (SetProperty)
Next (SetTempo)

Member
SetStartTime

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetStartTime ( iType : TStartTimeType ; iValue : TDateTime )

Parameters
Parameter | Description
iType : TStartTimeType |
iValue : TDateTime |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetProperty)
Next (SetTempo)


Previous (SetStartTime)
Next (SetTitle)

Member
SetTempo

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetStartTime)
Next (SetTitle)


Previous (SetTempo)
Next (SetUserData)

Member
SetTitle

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetTempo)
Next (SetUserData)


Previous (SetTitle)
Next

Member
SetUserData

Visibility
PUBLIC

Related Class
IPlaylistItem

Source code
procedure SetUserData ( iValue : TStrings )

Parameters
Parameter | Description
iValue : TStrings |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetTitle)
Next


Previous (IPlaylistItem)
Next

Class
IRemoteController

Class Hierarchy
IInterface

Parent
mAirListScript

Members
Methods
Method | Description
Finalize (+) |
GetCount (+) |
GetItem (+) |

Properties
Property | Description
Count (+) |
Items (+) |

Legend
Symbol | Visibility
- | Private
# | Protected
+ | Public
* | Published
A | Automated
S | Strict

mAirListScript
Content
Index
Previous (IPlaylistItem)
Next


Previous
Next (Items)

Member
Count

Visibility
PUBLIC

Related Class
IRemoteController

Description

Source code
property Count : integer read GetCount

Read Access
GetCount

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (Items)


Previous (Count)
Next

Member
Items

Visibility
PUBLIC

Related Class
IRemoteController

Description

Source code
property Items [ iIndex : integer ] : IRemote read GetItem ; default

Read Access
GetItem

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Count)
Next


Previous
Next (GetCount)

Member
Finalize

Visibility
PUBLIC

Related Class
IRemoteController

Source code
procedure Finalize

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (GetCount)


Previous (Finalize)
Next (GetItem)

Member
GetCount

Visibility
PUBLIC

Related Class
IRemoteController

Source code
function GetCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Finalize)
Next (GetItem)


Previous (GetCount)
Next

Member
GetItem

Visibility
PUBLIC

Related Class
IRemoteController

Source code
function GetItem ( iIndex : integer ) : IRemote

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (GetCount)
Next


Previous
Next (TDatabaseCapabilities)

Member
TCuePositionType

Parent
mAirListScript

Source code
TCuePositionType = ( ptCueIn , ptRamp , ptOutro , ptStartNext , ptFadeOut , ptCueOut ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (TDatabaseCapabilities)


Previous (TCuePositionType)
Next (TDatabaseCapability)

Member
TDatabaseCapabilities

Parent
mAirListScript

Source code
TDatabaseCapabilities = set of TDatabaseCapability ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TCuePositionType)
Next (TDatabaseCapability)


Previous (TDatabaseCapabilities)
Next (TEngineOption)

Member
TDatabaseCapability

Parent
mAirListScript

Source code
TDatabaseCapability = ( dcUpdateItem , dcPersistentIDs ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TDatabaseCapabilities)
Next (TEngineOption)


Previous (TDatabaseCapability)
Next (TEngineOptions)

Member
TEngineOption

Parent
mAirListScript

Source code
TEngineOption = ( eoStartOnAir , eoNoLoggingOffAir ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TDatabaseCapability)
Next (TEngineOptions)


Previous (TEngineOption)
Next (TEventActionType)

Member
TEngineOptions

Parent
mAirListScript

Source code
TEngineOptions = set of TEngineOption ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TEngineOption)
Next (TEventActionType)


Previous (TEngineOptions)
Next (TExpandAction)

Member
TEventActionType

Parent
mAirListScript

Source code
TEventActionType = ( eatNone , eatPlayFile , eatInsertFile , eatPlaylistLoad , eatPlaylistLoadAndPlay , eatPlaylistInsert , eatPlaylistInsertAndPlay , eatPlaylistAppend , eatRunScript , eatExecuteCommand , eatPlayStream , eatInsertStream ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TEngineOptions)
Next (TExpandAction)


Previous (TEventActionType)
Next (TPlayerButton)

Member
TExpandAction

Parent
mAirListScript

Source code
TExpandAction = ( eaNone , eaContainer , eaFlat ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TEventActionType)
Next (TPlayerButton)


Previous (TExpandAction)
Next (TPlayerButtons)

Member
TPlayerButton

Parent
mAirListScript

Source code
TPlayerButton = ( btnPFL , btnStop , btnPause , btnStart , btnClose , btnNext ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TExpandAction)
Next (TPlayerButtons)


Previous (TPlayerButton)
Next (TPlayerCommand)

Member
TPlayerButtons

Parent
mAirListScript

Source code
TPlayerButtons = set of TPlayerButton ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlayerButton)
Next (TPlayerCommand)


Previous (TPlayerButtons)
Next (TPlayerState)

Member
TPlayerCommand

Parent
mAirListScript

Source code
TPlayerCommand = ( pcStart , pcPause , pcStop , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose , pcFadeOut ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlayerButtons)
Next (TPlayerState)


Previous (TPlayerCommand)
Next (TPlayerStates)

Member
TPlayerState

Parent
mAirListScript

Source code
TPlayerState = ( PS_EMPTY , PS_LOADED , PS_PLAYING , PS_FADING , PS_EOF , PS_ERROR , PS_PAUSED , PS_STOPPED , PS_X_PFL , PS_X_FLASHEOF , PS_X_NEXT ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlayerCommand)
Next (TPlayerStates)


Previous (TPlayerState)
Next (TPlaylistItemCapabilities)

Member
TPlayerStates

Parent
mAirListScript

Source code
TPlayerStates = set of TPlayerState ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlayerState)
Next (TPlaylistItemCapabilities)


Previous (TPlayerStates)
Next (TPlaylistItemCapability)

Member
TPlaylistItemCapabilities

Parent
mAirListScript

Source code
TPlaylistItemCapabilities = set of TPlaylistItemCapability ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlayerStates)
Next (TPlaylistItemCapability)


Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemOption)

Member
TPlaylistItemCapability

Parent
mAirListScript

Source code
TPlaylistItemCapability = ( picPlayable , picLoadTags , picSaveTags , picIsFile , picMMD , picDuration , picAutoPosition ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemOption)


Previous (TPlaylistItemCapability)
Next (TPlaylistItemOptions)

Member
TPlaylistItemOption

Parent
mAirListScript

Source code
TPlaylistItemOption = ( pioNoBacktiming , pioSoftFixedTime , pioSkipInAutomation , pioFadeOutAll , pioAdjustTime , pioFadeOnStop ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlaylistItemCapability)
Next (TPlaylistItemOptions)


Previous (TPlaylistItemOption)
Next (TSourceCapabilities)

Member
TPlaylistItemOptions

Parent
mAirListScript

Source code
TPlaylistItemOptions = set of TPlaylistItemOption ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlaylistItemOption)
Next (TSourceCapabilities)


Previous (TPlaylistItemOptions)
Next (TSourceCapability)

Member
TSourceCapabilities

Parent
mAirListScript

Source code
TSourceCapabilities = set of TSourceCapability ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TPlaylistItemOptions)
Next (TSourceCapability)


Previous (TSourceCapabilities)
Next (TStartTimeType)

Member
TSourceCapability

Parent
mAirListScript

Source code
TSourceCapability = ( scPositioning , scDuration , scDynamicTitle , scSync , scUserSync , scTempo , scPitch , scCueMode ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TSourceCapabilities)
Next (TStartTimeType)


Previous (TSourceCapability)
Next

Member
TStartTimeType

Parent
mAirListScript

Source code
TStartTimeType = ( sttFixed , sttPlanned , sttEstimated , sttReal , sttSinceLastBreak ) ;

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (TSourceCapability)
Next


Previous
Next (ComPort)

Member
BuildAudioDevice

Parent
mAirListScript

Description

Create an IAudioSource object, based on a description passed as a string.
The format of the description string corresponds to those used in mAirList.ini.
A description string consists of five parameters, delimited by a double colon
(::). The parameters are:
1. Driver, for example BASS, BASSMIX or BASSASIO.
2. ID of the device, encapsulated in double quotes.
For the BASS familiy of drivers, this is the number of the sound card.
3. Human-readable description of the device/sound card, in double quotes.
4. Speaker pair to use. 0 = default, 1 = front, 2 = back etc.
5. Sample rate.

Source code
function BuildAudioDevice ( iDevice : string ) : IAudioDevice

Parameters
Parameter | Description
iDevice : STRING | Device description string.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous
Next (ComPort)


Previous (BuildAudioDevice)
Next (CreateContainerPlaylistItem)

Member
ComPort

Parent
mAirListScript

Source code
function ComPort ( iIndex : integer ) : IComPort

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (BuildAudioDevice)
Next (CreateContainerPlaylistItem)


Previous (ComPort)
Next (CreateEmptyPlaylist)

Member
CreateContainerPlaylistItem

Parent
mAirListScript

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ComPort)
Next (CreateEmptyPlaylist)


Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)

Member
CreateEmptyPlaylist

Parent
mAirListScript

Source code
function CreateEmptyPlaylist : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)


Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)

Member
CreateFilePlaylistItem

Parent
mAirListScript

Source code
function CreateFilePlaylistItem ( iFilename : string ; iLoadData : boolean ) : IFilePlaylistItem

Parameters
Parameter | Description
iFilename : STRING |
iLoadData : BOOLEAN |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)


Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)

Member
CreatePlaylist

Parent
mAirListScript

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromFile)

Member
CreatePlaylistFromFile

Parent
mAirListScript

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)

Member
CreatePlaylistItemFromFile

Parent
mAirListScript

Description

Creates a playlist item from the given file.

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iLoadData : boolean ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | The name of the file to load.
iLoadData : BOOLEAN | If set to true, file tags and/or MMD will be loaded.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)

Member
CreatePlaylistItemFromXMLString

Parent
mAirListScript

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter | Description
iXML : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)


Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)

Member
CurrentDatabase

Parent
mAirListScript

Source code
function CurrentDatabase : IDatabase

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)


Previous (CurrentDatabase)
Next (CurrentPlaylist)

Member
CurrentPlaybackControl

Parent
mAirListScript

Source code
function CurrentPlaybackControl : IPlaybackControl

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CurrentDatabase)
Next (CurrentPlaylist)


Previous (CurrentPlaybackControl)
Next (Database)

Member
CurrentPlaylist

Parent
mAirListScript

Source code
function CurrentPlaylist : IPlaylist

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CurrentPlaybackControl)
Next (Database)


Previous (CurrentPlaylist)
Next (DatabaseCount)

Member
Database

Parent
mAirListScript

Source code
function Database ( iIndex : integer ) : IDatabase

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (CurrentPlaylist)
Next (DatabaseCount)


Previous (Database)
Next (Engine)

Member
DatabaseCount

Parent
mAirListScript

Source code
function DatabaseCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Database)
Next (Engine)


Previous (DatabaseCount)
Next (ExecuteCommand)

Member
Engine

Parent
mAirListScript

Source code
function Engine : IEngine

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (DatabaseCount)
Next (ExecuteCommand)


Previous (Engine)
Next (ExecuteCommandRPC)

Member
ExecuteCommand

Parent
mAirListScript

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Engine)
Next (ExecuteCommandRPC)


Previous (ExecuteCommand)
Next (HTTPGet)

Member
ExecuteCommandRPC

Parent
mAirListScript

Source code
procedure ExecuteCommandRPC ( iURL , iCommand : string )

Parameters
Parameter | Description
iURL : STRING |
iCommand : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteCommand)
Next (HTTPGet)


Previous (ExecuteCommandRPC)
Next (IOPort)

Member
HTTPGet

Parent
mAirListScript

Source code
function HTTPGet ( iURL : string ) : string

Parameters
Parameter | Description
iURL : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ExecuteCommandRPC)
Next (IOPort)


Previous (HTTPGet)
Next (IOWarrior)

Member
IOPort

Parent
mAirListScript

Source code
function IOPort ( iPort : word ) : IIOPort

Parameters
Parameter | Description
iPort : WORD |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (HTTPGet)
Next (IOWarrior)


Previous (IOPort)
Next (ISOWeek)

Member
IOWarrior

Parent
mAirListScript

Source code
function IOWarrior : IIOWarrior

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IOPort)
Next (ISOWeek)


Previous (IOWarrior)
Next (MidiOut)

Member
ISOWeek

Parent
mAirListScript

Description

Calculates the week number according to ISO 8601.

Source code
function ISOWeek ( DateTime : TDateTime ) : integer

Parameters
Parameter | Description
DateTime : TDateTime | The date for which the week number shall be calculated.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (IOWarrior)
Next (MidiOut)


Previous (ISOWeek)
Next (MidiOutGetNumDevs)

Member
MidiOut

Parent
mAirListScript

Source code
procedure MidiOut ( iDevice : integer ; iStatus , iData1 , iData2 : byte )

Parameters
Parameter | Description
iDevice : INTEGER |
iStatus : BYTE |
iData1 : BYTE |
iData2 : BYTE |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ISOWeek)
Next (MidiOutGetNumDevs)


Previous (MidiOut)
Next (MidiOutListDevices)

Member
MidiOutGetNumDevs

Parent
mAirListScript

Source code
function MidiOutGetNumDevs : cardinal

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (MidiOut)
Next (MidiOutListDevices)


Previous (MidiOutGetNumDevs)
Next (Mixer)

Member
MidiOutListDevices

Parent
mAirListScript

Source code
procedure MidiOutListDevices

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (MidiOutGetNumDevs)
Next (Mixer)


Previous (MidiOutListDevices)
Next (MixerCount)

Member
Mixer

Parent
mAirListScript

Source code
function Mixer ( iIndex : integer ) : IMixer

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (MidiOutListDevices)
Next (MixerCount)


Previous (Mixer)
Next (PlaybackControl)

Member
MixerCount

Parent
mAirListScript

Source code
function MixerCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Mixer)
Next (PlaybackControl)


Previous (MixerCount)
Next (Playlist)

Member
PlaybackControl

Parent
mAirListScript

Source code
function PlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (MixerCount)
Next (Playlist)


Previous (PlaybackControl)
Next (PlaylistCount)

Member
Playlist

Parent
mAirListScript

Source code
function Playlist ( iIndex : integer ) : IPlaylist

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlaybackControl)
Next (PlaylistCount)


Previous (Playlist)
Next (Random)

Member
PlaylistCount

Parent
mAirListScript

Source code
function PlaylistCount : integer

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Playlist)
Next (Random)


Previous (PlaylistCount)
Next (RunScript)

Member
Random

Parent
mAirListScript

Source code
function Random ( iRange : integer ) : integer

Parameters
Parameter | Description
iRange : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (PlaylistCount)
Next (RunScript)


Previous (Random)
Next (SASComPort)

Member
RunScript

Parent
mAirListScript

Source code
procedure RunScript ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (Random)
Next (SASComPort)


Previous (RunScript)
Next (SelectDatabase)

Member
SASComPort

Parent
mAirListScript

Source code
function SASComPort : IComPort

Parameters
Parameter Description

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (RunScript)
Next (SelectDatabase)


Previous (SASComPort)
Next (SelectPlaylist)

Member
SelectDatabase

Parent
mAirListScript

Source code
function SelectDatabase ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SASComPort)
Next (SelectPlaylist)


Previous (SelectDatabase)
Next (SetApplicationTitle)

Member
SelectPlaylist

Parent
mAirListScript

Source code
function SelectPlaylist ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SelectDatabase)
Next (SetApplicationTitle)


Previous (SelectPlaylist)
Next (ShellExecute)

Member
SetApplicationTitle

Parent
mAirListScript

Source code
procedure SetApplicationTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SelectPlaylist)
Next (ShellExecute)


Previous (SetApplicationTitle)
Next (ShellExecuteHidden)

Member
ShellExecute

Parent
mAirListScript

Source code
procedure ShellExecute ( iProgram , iParameters : string )

Parameters
Parameter | Description
iProgram : STRING |
iParameters : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SetApplicationTitle)
Next (ShellExecuteHidden)


Previous (ShellExecute)
Next (SystemLog)

Member
ShellExecuteHidden

Parent
mAirListScript

Source code
procedure ShellExecuteHidden ( iProgram , iParameters : string )

Parameters
Parameter | Description
iProgram : STRING |
iParameters : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ShellExecute)
Next (SystemLog)


Previous (ShellExecuteHidden)
Next (URLEncode)

Member
SystemLog

Parent
mAirListScript

Source code
procedure SystemLog ( iMessage : string )

Parameters
Parameter | Description
iMessage : STRING |

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (ShellExecuteHidden)
Next (URLEncode)


Previous (SystemLog)
Next

Member
URLEncode

Parent
mAirListScript

Description

Encode a string so that it can by safely used as a parameter inside an
HTTP request URL.

Source code
function URLEncode ( iString : string ) : string

Parameters
Parameter | Description
iString : STRING | The string to encode.

Links
#UnderConstruction#

mAirListScript
Content
Index
Previous (SystemLog)
Next