mAirListScript - The scripting interface to mAirList

mAirListScript

Class Tree
Index
Previous
Next

Name
mAirListScript

Description
The scripting interface to mAirList
The scripting interface to mAirList

The XML interface was extracted from the OmniXML package (www.omnixml.com).

Author
Torben Weibert

Units
Unit Description
CoreRemoteInterface
InpOut32Interface
mAirListInterfaces
mAirListScript
mAirListTypes
MidiInterface
NotificationScripts
SASInterface
WMClientInterface
ZDbcIntfs

mAirListScript
Class Tree
Index
Previous
Next

Copyright 2009 by Torben Weibert
Created with DelphiCodeToDoc. To obtain the latest revision, please visit http://dephicodetodoc.sourceforge.net/


Previous (mAirListScript)
Next

Name
_ClassHierarchy

Class Hierarchy

#ROOT#

TObject

IInterface

* IBaseMessage

* IFactoryClass

* IFileTypeHandlerClass

* IPlaylistStorageClass

* IXMLStorage

* IPlaylistItemPicture

* IMutex

* IStrings

* ImAirListStream

* IClientList

* ISharedMemory

* ISharedMemoryFile

* IDummyAction

* IDatabaseTree

* IDatabaseInlineLoader

* IEnvelope

* IPitchableAudioSource

* IAmplifyable

* IVolumeEnvelope

* IDynamicTitle

* ICueMode

* IAudioDevice

* IAudioDeviceConfig

* IMixdownEngine

* IFileTypeHandler

* IInlineFilePlaylistItem

* ICommandPlaylistItem

* IStubPlaylistItem

* ILogInterface

* IEngineInfo

* IMixer

* ISerialPortManager

* IFilePlaylistItemClass

* IFactory

* IConfiguration

* IPlaylistStorage

* IPlaylistImporter

* IPlaylistExporter

* IAutoCueEngine

* ILicenseManager

* IModuleList

* IFileManager

* INotifiedMessageReceiver

* ILogEntry

* IMessageDispatcher

* IInstanceData

* ImAirListInstance

* IGetCommandList

* INotifyItemStarted

* IDummyObject

* IDebugObject

* IRunnable

* ISASRemote

* ISerialSASRemote

* IIPSASRemote

* IMidiRemote

* IWMClientRemote

* IIOPort

* IBaseComPortRemote

No parent

* TDatabaseNodeData

* TMidiMessage

#OrphanClass#

* EMessage

* ELicenseError

* IObservable

* IUpdateObject

* IBaseList

* IPersistentList

* ICueData

* IActionList

* IPlaylist

* IPlaybackControl

* IEventList

* IDatabaseList

* IAudioDeviceList

* IRemoteController

* ILogEntryList

* ILogInterfaceList

* IPersistentListItem

* ICueDataItem

* IAddableCueDataItem

* ITrackCueDataItem

* IBaseMarkerCueDataItem

* IMarkerCueDataitem

* IAlternativeMarkerCueDataItem

* IEOFWarningCueDataItem

* IMetaCueDataItem

* IAction

* IEmergencyAction

* ISASAction

* ISASSourceAction

* ISASSourceLevelAction

* ISASSetFaderLevelAction

* ISASSetFaderInputGainAction

* ISASSetPFLOnAction

* ISASSetPFLOffAction

* ISASSetFaderStartOnAction

* ISASSetFaderStartOffAction

* ISASSetGPIAction

* ISASSetGPIOnAction

* ISASSetGPIOffAction

* IPlaylistItem

* IFilePlaylistItem

* IURLPlaylistItem

* IStreamPlaylistItem

* INetworkFilePlaylistItem

* IContainerPlaylistItem

* IRegionContainerPlaylistItem

* IDummyPlaylistItem

* IBreakPlaylistItem

* ISilencePlaylistItem

* IPlaylistFilePlaylistItem

* IInlinePlaylistItem

* IAudimarkPlaylistItem

* IAddablePlaylistItem

* IEventListItem

* IDatabase

* IAudioSource

* ICueableAudioSource

* ISourceControl

* IPlayerControl

* ICartPlayerControl

* ICartWallControl

* IRemote

* IEngine

* IModule

* ILogger

* IDatabaseSearchHandler

* IComPort

* EZSQLThrowable

* EZSQLException

* EZSQLWarning

* IZDriverManager

* IZDriver

* IZConnection

* IZDatabaseMetadata

* IZStatement

* IZPreparedStatement

* IZCallableStatement

* IZResultSet

* IZResultSetMetadata

* IZBlob

* IZNotification

* IZSequence

* TZDriverManager

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next


Previous
Next (InpOut32Interface)

Name
CoreRemoteInterface

Parent
mAirListScript

Classes
Class Description
IBaseComPortRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (InpOut32Interface)


Previous
Next

Name
IBaseComPortRemote

Parent
CoreRemoteInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (SetPort)

Name
GetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (CoreRemoteInterface)
Next (mAirListInterfaces)

Name
InpOut32Interface

Parent
mAirListScript

Classes
Class Description
IIOPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (CoreRemoteInterface)
Next (mAirListInterfaces)


Previous
Next

Name
IIOPort

Parent
InpOut32Interface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
READ (+)
WRITE (+)
WriteAND (+)
WriteOR (+)
WriteXOR (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (WRITE)

Name
READ

Parent
IIOPort

Visibility
PUBLIC

Source code
function Read : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (WRITE)


Previous (READ)
Next (WriteAND)

Name
WRITE

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure Write ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (READ)
Next (WriteAND)


Previous (WRITE)
Next (WriteOR)

Name
WriteAND

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteAND ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WRITE)
Next (WriteOR)


Previous (WriteAND)
Next (WriteXOR)

Name
WriteOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteOR ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WriteAND)
Next (WriteXOR)


Previous (WriteOR)
Next

Name
WriteXOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteXOR ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WriteOR)
Next


Previous (InpOut32Interface)
Next (mAirListScript)

Name
mAirListInterfaces

Parent
mAirListScript

Types
Type Description
IAudioSourceArray (+)
TMessageProc (+)

Classes
Class Description
IAction (+)
IActionList (+)
IAddableCueDataItem (+)
IAddablePlaylistItem (+)
IAlternativeMarkerCueDataItem (+)
IAmplifyable (+)
IAudimarkPlaylistItem (+)
IAudioDevice (+)
IAudioDeviceConfig (+)
IAudioDeviceList (+)
IAudioSource (+)
IAutoCueEngine (+)
IBaseList (+)
IBaseMarkerCueDataItem (+)
IBaseMessage (+)
IBreakPlaylistItem (+)
ICartPlayerControl (+)
ICartWallControl (+)
IClientList (+)
ICommandPlaylistItem (+)
IComPort (+)
IConfiguration (+)
IContainerPlaylistItem (+)
ICueableAudioSource (+)
ICueData (+)
ICueDataItem (+)
ICueMode (+)
IDatabase (+)
IDatabaseInlineLoader (+)
IDatabaseList (+)
IDatabaseSearchHandler (+)
IDatabaseTree (+)
IDebugObject (+)
IDummyAction (+)
IDummyObject (+)
IDummyPlaylistItem (+)
IDynamicTitle (+)
IEmergencyAction (+)
IEngine (+)
IEngineInfo (+)
IEnvelope (+)
IEOFWarningCueDataItem (+)
IEventList (+)
IEventListItem (+)
IFactory (+)
IFactoryClass (+)
IFileManager (+)
IFilePlaylistItem (+)
IFilePlaylistItemClass (+)
IFileTypeHandler (+)
IFileTypeHandlerClass (+)
IGetCommandList (+)
IInlineFilePlaylistItem (+)
IInlinePlaylistItem (+)
IInstanceData (+)
ILicenseManager (+)
ILogEntry (+)
ILogEntryList (+)
ILogger (+)
ILogInterface (+)
ILogInterfaceList (+)
ImAirListInstance (+)
ImAirListStream (+)
IMarkerCueDataitem (+)
IMessageDispatcher (+)
IMetaCueDataItem (+)
IMixdownEngine (+)
IMixer (+)
IModule (+)
IModuleList (+)
IMutex (+)
INetworkFilePlaylistItem (+)
INotifiedMessageReceiver (+)
INotifyItemStarted (+)
IObservable (+)
IPersistentList (+)
IPersistentListItem (+)
IPitchableAudioSource (+)
IPlaybackControl (+)
IPlayerControl (+)
IPlaylist (+)
IPlaylistExporter (+)
IPlaylistFilePlaylistItem (+)
IPlaylistImporter (+)
IPlaylistItem (+)
IPlaylistItemPicture (+)
IPlaylistStorage (+)
IPlaylistStorageClass (+)
IRegionContainerPlaylistItem (+)
IRemote (+)
IRemoteController (+)
IRunnable (+)
ISerialPortManager (+)
ISharedMemory (+)
ISharedMemoryFile (+)
ISilencePlaylistItem (+)
ISourceControl (+)
IStreamPlaylistItem (+)
IStrings (+)
IStubPlaylistItem (+)
ITrackCueDataItem (+)
IUpdateObject (+)
IURLPlaylistItem (+)
IVolumeEnvelope (+)
IXMLStorage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (InpOut32Interface)
Next (mAirListScript)


Previous
Next (IActionList)

Name
IAction

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
CloneAsAction (+)
Execute (+)
GetCaption (+)
GetPlaylist (+)
GetTimeOffset (+)
GetTitle (+)
GetUseVariables (+)
SetPlaylist (+)
SetTimeOffset (+)
SetTitle (+)
SetUseVariables (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IActionList)


Previous
Next (Execute)

Name
CloneAsAction

Parent
IAction

Visibility
PUBLIC

Source code
function CloneAsAction : IAction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Execute)


Previous (CloneAsAction)
Next (GetCaption)

Name
Execute

Parent
IAction

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous (CloneAsAction)
Next (GetCaption)


Previous (Execute)
Next (GetPlaylist)

Name
GetCaption

Parent
IAction

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetPlaylist)


Previous (GetCaption)
Next (GetTimeOffset)

Name
GetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
function GetPlaylist : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetTimeOffset)


Previous (GetPlaylist)
Next (GetTitle)

Name
GetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
function GetTimeOffset : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetTitle)


Previous (GetTimeOffset)
Next (GetUseVariables)

Name
GetTitle

Parent
IAction

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeOffset)
Next (GetUseVariables)


Previous (GetTitle)
Next (SetPlaylist)

Name
GetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
function GetUseVariables : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (SetPlaylist)


Previous (GetUseVariables)
Next (SetTimeOffset)

Name
SetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetPlaylist ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUseVariables)
Next (SetTimeOffset)


Previous (SetPlaylist)
Next (SetTitle)

Name
SetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTimeOffset ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPlaylist)
Next (SetTitle)


Previous (SetTimeOffset)
Next (SetUseVariables)

Name
SetTitle

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTimeOffset)
Next (SetUseVariables)


Previous (SetTitle)
Next

Name
SetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetUseVariables ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IAction)
Next (IAddableCueDataItem)

Name
IActionList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
Execute (+)
ExecuteAsync (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAction)
Next (IAddableCueDataItem)


Previous
Next (ExecuteAsync)

Name
Execute

Parent
IActionList

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (ExecuteAsync)


Previous (Execute)
Next (GetItem)

Name
ExecuteAsync

Parent
IActionList

Visibility
PUBLIC

Source code
procedure ExecuteAsync ( iDefaultPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iDefaultPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetItem)


Previous (ExecuteAsync)
Next

Name
GetItem

Parent
IActionList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IAction

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (ExecuteAsync)
Next


Previous (IActionList)
Next (IAddablePlaylistItem)

Name
IAddableCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActionList)
Next (IAddablePlaylistItem)


Previous (IAddableCueDataItem)
Next (IAlternativeMarkerCueDataItem)

Name
IAddablePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddableCueDataItem)
Next (IAlternativeMarkerCueDataItem)


Previous (IAddablePlaylistItem)
Next (IAmplifyable)

Name
IAlternativeMarkerCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
IBaseMarkerCueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddablePlaylistItem)
Next (IAmplifyable)


Previous (IAlternativeMarkerCueDataItem)
Next (IAudimarkPlaylistItem)

Name
IAmplifyable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetAmplification (+)
SetAmplification (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAlternativeMarkerCueDataItem)
Next (IAudimarkPlaylistItem)


Previous
Next (SetAmplification)

Name
GetAmplification

Parent
IAmplifyable

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetAmplification)


Previous (GetAmplification)
Next

Name
SetAmplification

Parent
IAmplifyable

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next


Previous (IAmplifyable)
Next (IAudioDevice)

Name
IAudimarkPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAmplifyable)
Next (IAudioDevice)


Previous (IAudimarkPlaylistItem)
Next (IAudioDeviceConfig)

Name
IAudioDevice

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BuildFileSource (+)
BuildNetworkFileSource (+)
BuildStreamSource (+)
BuildURLSource (+)
GetDisplayName (+)
GetID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudimarkPlaylistItem)
Next (IAudioDeviceConfig)


Previous
Next (BuildNetworkFileSource)

Name
BuildFileSource

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function BuildFileSource ( iItem : IPlaylistItem ; iFilename : string ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next (BuildNetworkFileSource)


Previous (BuildFileSource)
Next (BuildStreamSource)

Name
BuildNetworkFileSource

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function BuildNetworkFileSource ( iItem : IPlaylistItem ; iURL : string ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iURL : STRING

mAirListScript
Class Tree
Index
Previous (BuildFileSource)
Next (BuildStreamSource)


Previous (BuildNetworkFileSource)
Next (BuildURLSource)

Name
BuildStreamSource

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function BuildStreamSource ( iItem : IPlaylistItem ; iStream : ImAirListStream ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iStream : ImAirListStream

mAirListScript
Class Tree
Index
Previous (BuildNetworkFileSource)
Next (BuildURLSource)


Previous (BuildStreamSource)
Next (GetDisplayName)

Name
BuildURLSource

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function BuildURLSource ( iItem : IPlaylistItem ; iURL : string ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iURL : STRING

mAirListScript
Class Tree
Index
Previous (BuildStreamSource)
Next (GetDisplayName)


Previous (BuildURLSource)
Next (GetID)

Name
GetDisplayName

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetDisplayName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildURLSource)
Next (GetID)


Previous (GetDisplayName)
Next

Name
GetID

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisplayName)
Next


Previous (IAudioDevice)
Next (IAudioDeviceList)

Name
IAudioDeviceConfig

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BuildDevice (+)
BuildRegionDevices (+)
GetDevice (+)
LoadConfig (+)
SaveConfig (+)
SetDevice (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDevice)
Next (IAudioDeviceList)


Previous
Next (BuildRegionDevices)

Name
BuildDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function BuildDevice ( iPlayerType : TPlayerType ; iParentIndex , iIndex , iRegion : integer ; iPFL : boolean ) : IAudioDevice

Parameters
Parameter Description
iPlayerType : TPlayerType
iParentIndex : INTEGER
iIndex : INTEGER
iRegion : INTEGER
iPFL : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (BuildRegionDevices)


Previous (BuildDevice)
Next (GetDevice)

Name
BuildRegionDevices

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function BuildRegionDevices ( iPlayerType : TPlayerType ; iParentIndex , iIndex : integer ; iPFL : boolean ) : IAudioDeviceList

Parameters
Parameter Description
iPlayerType : TPlayerType
iParentIndex : INTEGER
iIndex : INTEGER
iPFL : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BuildDevice)
Next (GetDevice)


Previous (BuildRegionDevices)
Next (LoadConfig)

Name
GetDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetDevice ( iPlayerType : TPlayerType ; iParentIndex , iIndex , iRegion : integer ; iPFL : boolean ) : IAudioDevice

Parameters
Parameter Description
iPlayerType : TPlayerType
iParentIndex : INTEGER
iIndex : INTEGER
iRegion : INTEGER
iPFL : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BuildRegionDevices)
Next (LoadConfig)


Previous (GetDevice)
Next (SaveConfig)

Name
LoadConfig

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDevice)
Next (SaveConfig)


Previous (LoadConfig)
Next (SetDevice)

Name
SaveConfig

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SaveConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (SetDevice)


Previous (SaveConfig)
Next

Name
SetDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SetDevice ( iPlayerType : TPlayerType ; iParentIndex , iIndex , iRegion : integer ; iPFL : boolean ; iDevice : IAudioDevice )

Parameters
Parameter Description
iPlayerType : TPlayerType
iParentIndex : INTEGER
iIndex : INTEGER
iRegion : INTEGER
iPFL : BOOLEAN
iDevice : IAudioDevice

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next


Previous (IAudioDeviceConfig)
Next (IAudioSource)

Name
IAudioDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceConfig)
Next (IAudioSource)


Previous
Next

Name
GetItem

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IAudioDevice

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next


Previous (IAudioDeviceList)
Next (IAutoCueEngine)

Name
IAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanChangeDevice (+)
ChangeDevice (+)
FadeOut (+)
GetIsPlaying (+)
GetItem (+)
GetOptions (+)
GetVolume (+)
Pause (+)
SetOptions (+)
SetVolume (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceList)
Next (IAutoCueEngine)


Previous
Next (ChangeDevice)

Name
CanChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
function CanChangeDevice ( iDevice : IAudioDevice ) : boolean

Parameters
Parameter Description
iDevice : IAudioDevice

mAirListScript
Class Tree
Index
Previous
Next (ChangeDevice)


Previous (CanChangeDevice)
Next (FadeOut)

Name
ChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure ChangeDevice ( iDevice : IAudioDevice )

Parameters
Parameter Description
iDevice : IAudioDevice

mAirListScript
Class Tree
Index
Previous (CanChangeDevice)
Next (FadeOut)


Previous (ChangeDevice)
Next (GetIsPlaying)

Name
FadeOut

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure FadeOut ( iDuration : TTimeValue )

Parameters
Parameter Description
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (ChangeDevice)
Next (GetIsPlaying)


Previous (FadeOut)
Next (GetItem)

Name
GetIsPlaying

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetIsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetItem)


Previous (GetIsPlaying)
Next (GetOptions)

Name
GetItem

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsPlaying)
Next (GetOptions)


Previous (GetItem)
Next (GetVolume)

Name
GetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetOptions : TAudioSourceOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetVolume)


Previous (GetOptions)
Next (Pause)

Name
GetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetVolume : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (Pause)


Previous (GetVolume)
Next (SetOptions)

Name
Pause

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (SetOptions)


Previous (Pause)
Next (SetVolume)

Name
SetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TAudioSourceOptions )

Parameters
Parameter Description
iValue : TAudioSourceOptions

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetVolume)


Previous (SetOptions)
Next (Start)

Name
SetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (Start)


Previous (SetVolume)
Next (Stop)

Name
Start

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IAudioSource)
Next (IBaseList)

Name
IAutoCueEngine

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
PerformAutoCue (+)
PerformAutoCueSelective (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioSource)
Next (IBaseList)


Previous
Next (PerformAutoCueSelective)

Name
PerformAutoCue

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCue ( iItem : IFilePlaylistItem )

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous
Next (PerformAutoCueSelective)


Previous (PerformAutoCue)
Next

Name
PerformAutoCueSelective

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCueSelective ( iItem : IFilePlaylistItem ; iTypes : TCuePositionTypes )

Parameters
Parameter Description
iItem : IFilePlaylistItem
iTypes : TCuePositionTypes

mAirListScript
Class Tree
Index
Previous (PerformAutoCue)
Next


Previous (IAutoCueEngine)
Next (IBaseMarkerCueDataItem)

Name
IBaseList

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
Append (+)
Assign (+)
Clear (+)
CreateEmpty (+)
Delete (+)
FindItemByGUID (+)
GetCount (+)
GetListItem (+)
IndexOf (+)
Insert (+)
InsertList (+)
Move (+)
REMOVE (+)
Sync (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAutoCueEngine)
Next (IBaseMarkerCueDataItem)


Previous
Next (Append)

Name
ADD

Parent
IBaseList

Visibility
PUBLIC

Source code
function Add ( iItem : IUnknown ) : integer

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous
Next (Append)


Previous (ADD)
Next (Assign)

Name
Append

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Append ( iValue : IBaseList )

Parameters
Parameter Description
iValue : IBaseList

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Assign)


Previous (Append)
Next (Clear)

Name
Assign

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IBaseList )

Parameters
Parameter Description
iValue : IBaseList

mAirListScript
Class Tree
Index
Previous (Append)
Next (Clear)


Previous (Assign)
Next (CreateEmpty)

Name
Clear

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (CreateEmpty)


Previous (Clear)
Next (Delete)

Name
CreateEmpty

Parent
IBaseList

Visibility
PUBLIC

Source code
function CreateEmpty : IBaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (CreateEmpty)
Next (FindItemByGUID)

Name
Delete

Parent
IBaseList

Visibility
PUBLIC

Source code
function Delete ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateEmpty)
Next (FindItemByGUID)


Previous (Delete)
Next (GetCount)

Name
FindItemByGUID

Parent
IBaseList

Visibility
PUBLIC

Source code
function FindItemByGUID ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter Description
iGUID : TGUID
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Delete)
Next (GetCount)


Previous (FindItemByGUID)
Next (GetListItem)

Name
GetCount

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindItemByGUID)
Next (GetListItem)


Previous (GetCount)
Next (IndexOf)

Name
GetListItem

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetListItem ( iIndex : integer ) : IUnknown

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (IndexOf)


Previous (GetListItem)
Next (Insert)

Name
IndexOf

Parent
IBaseList

Visibility
PUBLIC

Source code
function IndexOf ( iItem : IUnknown ) : integer

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (GetListItem)
Next (Insert)


Previous (IndexOf)
Next (InsertList)

Name
Insert

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iItem : IUnknown )

Parameters
Parameter Description
iIndex : INTEGER
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (InsertList)


Previous (Insert)
Next (Move)

Name
InsertList

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure InsertList ( iIndex : integer ; iValue : IBaseList )

Parameters
Parameter Description
iIndex : INTEGER
iValue : IBaseList

mAirListScript
Class Tree
Index
Previous (Insert)
Next (Move)


Previous (InsertList)
Next (REMOVE)

Name
Move

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Move ( oldIndex : integer ; newIndex : integer )

Parameters
Parameter Description
oldIndex : INTEGER
newIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (InsertList)
Next (REMOVE)


Previous (Move)
Next (Sync)

Name
REMOVE

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Remove ( iItem : IUnknown )

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (Move)
Next (Sync)


Previous (REMOVE)
Next

Name
Sync

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Sync ( iValue : IBaseList )

Parameters
Parameter Description
iValue : IBaseList

mAirListScript
Class Tree
Index
Previous (REMOVE)
Next


Previous (IBaseList)
Next (IBaseMessage)

Name
IBaseMarkerCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPositionType (+)
SetPositionType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseList)
Next (IBaseMessage)


Previous
Next (SetPositionType)

Name
GetPositionType

Parent
IBaseMarkerCueDataItem

Visibility
PUBLIC

Source code
function GetPositionType : TCuePositionType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPositionType)


Previous (GetPositionType)
Next

Name
SetPositionType

Parent
IBaseMarkerCueDataItem

Visibility
PUBLIC

Source code
procedure SetPositionType ( iValue : TCuePositionType )

Parameters
Parameter Description
iValue : TCuePositionType

mAirListScript
Class Tree
Index
Previous (GetPositionType)
Next


Previous (IBaseMarkerCueDataItem)
Next (IBreakPlaylistItem)

Name
IBaseMessage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCreated (+)
GetData (+)
GetDataCount (+)
GetInfo (+)
GetMessageType (+)
GetSender (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseMarkerCueDataItem)
Next (IBreakPlaylistItem)


Previous
Next (GetData)

Name
GetCreated

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetCreated : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetData)


Previous (GetCreated)
Next (GetDataCount)

Name
GetData

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : Variant

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCreated)
Next (GetDataCount)


Previous (GetData)
Next (GetInfo)

Name
GetDataCount

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetDataCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetInfo)


Previous (GetDataCount)
Next (GetMessageType)

Name
GetInfo

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDataCount)
Next (GetMessageType)


Previous (GetInfo)
Next (GetSender)

Name
GetMessageType

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetMessageType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInfo)
Next (GetSender)


Previous (GetMessageType)
Next

Name
GetSender

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetSender : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageType)
Next


Previous (IBaseMessage)
Next (ICartPlayerControl)

Name
IBreakPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseMessage)
Next (ICartPlayerControl)


Previous (IBreakPlaylistItem)
Next (ICartWallControl)

Name
ICartPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IPlayerControl

Visibility
PUBLIC

Members
Methods
Method Description
GetFadeTrigger (+)
GetPFLMode (+)
GetStack (+)
GetStackIndex (+)
GetStartTrigger (+)
GetStopTrigger (+)
SetFadeTrigger (+)
SetPFLMode (+)
SetStackIndex (+)
SetStartTrigger (+)
SetStopTrigger (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBreakPlaylistItem)
Next (ICartWallControl)


Previous
Next (GetPFLMode)

Name
GetFadeTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetFadeTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetPFLMode)


Previous (GetFadeTrigger)
Next (GetStack)

Name
GetPFLMode

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeTrigger)
Next (GetStack)


Previous (GetPFLMode)
Next (GetStackIndex)

Name
GetStack

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStack : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLMode)
Next (GetStackIndex)


Previous (GetStack)
Next (GetStartTrigger)

Name
GetStackIndex

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStackIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStack)
Next (GetStartTrigger)


Previous (GetStackIndex)
Next (GetStopTrigger)

Name
GetStartTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStartTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStackIndex)
Next (GetStopTrigger)


Previous (GetStartTrigger)
Next (SetFadeTrigger)

Name
GetStopTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStopTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStartTrigger)
Next (SetFadeTrigger)


Previous (GetStopTrigger)
Next (SetPFLMode)

Name
SetFadeTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetFadeTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetStopTrigger)
Next (SetPFLMode)


Previous (SetFadeTrigger)
Next (SetStackIndex)

Name
SetPFLMode

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetFadeTrigger)
Next (SetStackIndex)


Previous (SetPFLMode)
Next (SetStartTrigger)

Name
SetStackIndex

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStackIndex ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPFLMode)
Next (SetStartTrigger)


Previous (SetStackIndex)
Next (SetStopTrigger)

Name
SetStartTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStartTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetStackIndex)
Next (SetStopTrigger)


Previous (SetStartTrigger)
Next

Name
SetStopTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStopTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetStartTrigger)
Next


Previous (ICartPlayerControl)
Next (IClientList)

Name
ICartWallControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CloseAll (+)
GetOptions (+)
GetPFLMode (+)
GetPlayerControl (+)
GetPlayerCount (+)
GetPlayerCountX (+)
GetPlayerCountY (+)
SetOptions (+)
SetPFLMode (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartPlayerControl)
Next (IClientList)


Previous
Next (GetOptions)

Name
CloseAll

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure CloseAll

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetOptions)


Previous (CloseAll)
Next (GetPFLMode)

Name
GetOptions

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetOptions : TCartwallControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CloseAll)
Next (GetPFLMode)


Previous (GetOptions)
Next (GetPlayerControl)

Name
GetPFLMode

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayerControl)


Previous (GetPFLMode)
Next (GetPlayerCount)

Name
GetPlayerControl

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerControl ( iIndex : integer ) : IPlayerControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPFLMode)
Next (GetPlayerCount)


Previous (GetPlayerControl)
Next (GetPlayerCountX)

Name
GetPlayerCount

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerControl)
Next (GetPlayerCountX)


Previous (GetPlayerCount)
Next (GetPlayerCountY)

Name
GetPlayerCountX

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCountX : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (GetPlayerCountY)


Previous (GetPlayerCountX)
Next (SetOptions)

Name
GetPlayerCountY

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCountY : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerCountX)
Next (SetOptions)


Previous (GetPlayerCountY)
Next (SetPFLMode)

Name
SetOptions

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TCartwallControlOptions )

Parameters
Parameter Description
iValue : TCartwallControlOptions

mAirListScript
Class Tree
Index
Previous (GetPlayerCountY)
Next (SetPFLMode)


Previous (SetOptions)
Next

Name
SetPFLMode

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (ICartWallControl)
Next (ICommandPlaylistItem)

Name
IClientList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddStrong (+)
Clone (+)
CloneStrong (+)
GetCount (+)
GetItem (+)
Insert (+)
REMOVE (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartWallControl)
Next (ICommandPlaylistItem)


Previous
Next (AddStrong)

Name
ADD

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Add ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous
Next (AddStrong)


Previous (ADD)
Next (Clone)

Name
AddStrong

Parent
IClientList

Visibility
PUBLIC

Source code
procedure AddStrong ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Clone)


Previous (AddStrong)
Next (CloneStrong)

Name
Clone

Parent
IClientList

Visibility
PUBLIC

Source code
function Clone : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddStrong)
Next (CloneStrong)


Previous (Clone)
Next (GetCount)

Name
CloneStrong

Parent
IClientList

Visibility
PUBLIC

Source code
function CloneStrong : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetCount)


Previous (CloneStrong)
Next (GetItem)

Name
GetCount

Parent
IClientList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CloneStrong)
Next (GetItem)


Previous (GetCount)
Next (Insert)

Name
GetItem

Parent
IClientList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IUnknown

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (Insert)


Previous (GetItem)
Next (REMOVE)

Name
Insert

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; intf : IUnknown )

Parameters
Parameter Description
iIndex : INTEGER
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (REMOVE)


Previous (Insert)
Next

Name
REMOVE

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Remove ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (Insert)
Next


Previous (IClientList)
Next (IComPort)

Name
ICommandPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCommand (+)
SetCommand (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IClientList)
Next (IComPort)


Previous
Next (SetCommand)

Name
GetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
function GetCommand : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetCommand)


Previous (GetCommand)
Next

Name
SetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCommand ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetCommand)
Next


Previous (ICommandPlaylistItem)
Next (IConfiguration)

Name
IComPort

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
Close (+)
GetPort (+)
Open (+)
ReceiveStr (+)
SendStr (+)
SetDTR (+)
SetParameters (+)
SetRxBuffer (+)
SetTxBuffer (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICommandPlaylistItem)
Next (IConfiguration)


Previous
Next (GetPort)

Name
Close

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (Close)
Next (Open)

Name
GetPort

Parent
IComPort

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Close)
Next (Open)


Previous (GetPort)
Next (ReceiveStr)

Name
Open

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Open

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (ReceiveStr)


Previous (Open)
Next (SendStr)

Name
ReceiveStr

Parent
IComPort

Visibility
PUBLIC

Source code
function ReceiveStr : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (SendStr)


Previous (ReceiveStr)
Next (SetDTR)

Name
SendStr

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SendStr ( const Tx : string )

Parameters
Parameter Description
Tx : STRING

mAirListScript
Class Tree
Index
Previous (ReceiveStr)
Next (SetDTR)


Previous (SendStr)
Next (SetParameters)

Name
SetDTR

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetDTR ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SendStr)
Next (SetParameters)


Previous (SetDTR)
Next (SetRxBuffer)

Name
SetParameters

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetParameters ( iBaudRate : integer ; iByteSize : byte ; iParity : char ; iStopBits : Single )

Parameters
Parameter Description
iBaudRate : INTEGER
iByteSize : BYTE
iParity : CHAR
iStopBits : SINGLE

mAirListScript
Class Tree
Index
Previous (SetDTR)
Next (SetRxBuffer)


Previous (SetParameters)
Next (SetTxBuffer)

Name
SetRxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetRxBuffer ( iSize : integer )

Parameters
Parameter Description
iSize : INTEGER

mAirListScript
Class Tree
Index
Previous (SetParameters)
Next (SetTxBuffer)


Previous (SetRxBuffer)
Next

Name
SetTxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetTxBuffer ( iSize : integer )

Parameters
Parameter Description
iSize : INTEGER

mAirListScript
Class Tree
Index
Previous (SetRxBuffer)
Next


Previous (IComPort)
Next (IContainerPlaylistItem)

Name
IConfiguration

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ConfigExists (+)
EraseSection (+)
GetInfo (+)
GetSections (+)
ReadColor (+)
ReadColorEx (+)
ReadFont (+)
ReadFontEx (+)
ReadInteger (+)
ReadIntegerEx (+)
ReadOnOff (+)
ReadOnOffEx (+)
ReadPassword (+)
ReadSectionValues (+)
ReadSectionValuesEx (+)
ReadString (+)
ReadStringEx (+)
ReadStringSafe (+)
ReadXML (+)
WriteColor (+)
WriteFont (+)
WriteInteger (+)
WriteOnOff (+)
WritePassword (+)
WriteSectionValues (+)
WriteString (+)
WriteXMLStorage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IComPort)
Next (IContainerPlaylistItem)


Previous
Next (EraseSection)

Name
ConfigExists

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ConfigExists ( iCategory : string ) : boolean

Parameters
Parameter Description
iCategory : STRING

mAirListScript
Class Tree
Index
Previous
Next (EraseSection)


Previous (ConfigExists)
Next (GetInfo)

Name
EraseSection

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure EraseSection ( iCategory : string ; iSection : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (ConfigExists)
Next (GetInfo)


Previous (EraseSection)
Next (GetSections)

Name
GetInfo

Parent
IConfiguration

Visibility
PUBLIC

Source code
function GetInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EraseSection)
Next (GetSections)


Previous (GetInfo)
Next (ReadColor)

Name
GetSections

Parent
IConfiguration

Visibility
PUBLIC

Source code
function GetSections ( iCategory : string ) : IStrings

Parameters
Parameter Description
iCategory : STRING

mAirListScript
Class Tree
Index
Previous (GetInfo)
Next (ReadColor)


Previous (GetSections)
Next (ReadColorEx)

Name
ReadColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColor ( iCategory : string ; iSection , iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : TColor

mAirListScript
Class Tree
Index
Previous (GetSections)
Next (ReadColorEx)


Previous (ReadColor)
Next (ReadFont)

Name
ReadColorEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColorEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : TColor

mAirListScript
Class Tree
Index
Previous (ReadColor)
Next (ReadFont)


Previous (ReadColorEx)
Next (ReadFontEx)

Name
ReadFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (ReadColorEx)
Next (ReadFontEx)


Previous (ReadFont)
Next (ReadInteger)

Name
ReadFontEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFontEx ( iCategory : string ; iSections : array of string ; iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (ReadFont)
Next (ReadInteger)


Previous (ReadFontEx)
Next (ReadIntegerEx)

Name
ReadInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadInteger ( iCategory : string ; iSection , iKey : string ; iDefault : integer ) : integer

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : INTEGER

mAirListScript
Class Tree
Index
Previous (ReadFontEx)
Next (ReadIntegerEx)


Previous (ReadInteger)
Next (ReadOnOff)

Name
ReadIntegerEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadIntegerEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : integer ) : integer

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : INTEGER

mAirListScript
Class Tree
Index
Previous (ReadInteger)
Next (ReadOnOff)


Previous (ReadIntegerEx)
Next (ReadOnOffEx)

Name
ReadOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOff ( iCategory : string ; iSection , iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : BOOLEAN

mAirListScript
Class Tree
Index
Previous (ReadIntegerEx)
Next (ReadOnOffEx)


Previous (ReadOnOff)
Next (ReadPassword)

Name
ReadOnOffEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOffEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : BOOLEAN

mAirListScript
Class Tree
Index
Previous (ReadOnOff)
Next (ReadPassword)


Previous (ReadOnOffEx)
Next (ReadSectionValues)

Name
ReadPassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadPassword ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadOnOffEx)
Next (ReadSectionValues)


Previous (ReadPassword)
Next (ReadSectionValuesEx)

Name
ReadSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValues ( iCategory : string ; iSection : string ) : IStrings

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (ReadPassword)
Next (ReadSectionValuesEx)


Previous (ReadSectionValues)
Next (ReadString)

Name
ReadSectionValuesEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValuesEx ( iCategory : string ; iSections : array of string ) : IStrings

Parameters
Parameter Description
iCategory : STRING
iSections : STRING

mAirListScript
Class Tree
Index
Previous (ReadSectionValues)
Next (ReadString)


Previous (ReadSectionValuesEx)
Next (ReadStringEx)

Name
ReadString

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadString ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadSectionValuesEx)
Next (ReadStringEx)


Previous (ReadString)
Next (ReadStringSafe)

Name
ReadStringEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadString)
Next (ReadStringSafe)


Previous (ReadStringEx)
Next (ReadXML)

Name
ReadStringSafe

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringSafe ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadStringEx)
Next (ReadXML)


Previous (ReadStringSafe)
Next (WriteColor)

Name
ReadXML

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadXML ( iCategory : string ; iSection , iKey , iDefault : string ) : IXMLNode

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadStringSafe)
Next (WriteColor)


Previous (ReadXML)
Next (WriteFont)

Name
WriteColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteColor ( iCategory : string ; iSection , iKey : string ; iValue : TColor )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : TColor

mAirListScript
Class Tree
Index
Previous (ReadXML)
Next (WriteFont)


Previous (WriteColor)
Next (WriteInteger)

Name
WriteFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (WriteColor)
Next (WriteInteger)


Previous (WriteFont)
Next (WriteOnOff)

Name
WriteInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteInteger ( iCategory : string ; iSection , iKey : string ; iValue : integer )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (WriteFont)
Next (WriteOnOff)


Previous (WriteInteger)
Next (WritePassword)

Name
WriteOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteOnOff ( iCategory : string ; iSection , iKey : string ; iValue : boolean )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (WriteInteger)
Next (WritePassword)


Previous (WriteOnOff)
Next (WriteSectionValues)

Name
WritePassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WritePassword ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (WriteOnOff)
Next (WriteSectionValues)


Previous (WritePassword)
Next (WriteString)

Name
WriteSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteSectionValues ( iCategory : string ; iSection : string ; iValues : IStrings )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iValues : IStrings

mAirListScript
Class Tree
Index
Previous (WritePassword)
Next (WriteString)


Previous (WriteSectionValues)
Next (WriteXMLStorage)

Name
WriteString

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteString ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (WriteSectionValues)
Next (WriteXMLStorage)


Previous (WriteString)
Next

Name
WriteXMLStorage

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteXMLStorage ( iCategory : string ; iSection , iKey : string ; iStorage : IXMLStorage )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iStorage : IXMLStorage

mAirListScript
Class Tree
Index
Previous (WriteString)
Next


Previous (IConfiguration)
Next (ICueableAudioSource)

Name
IContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetInnerFadeDuration (+)
GetPlaylist (+)
SetInnerFadeDuration (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfiguration)
Next (ICueableAudioSource)


Previous
Next (GetPlaylist)

Name
GetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetInnerFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaylist)


Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)

Name
GetPlaylist

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)


Previous (GetPlaylist)
Next

Name
SetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetInnerFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next


Previous (IContainerPlaylistItem)
Next (ICueData)

Name
ICueableAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IAudioSource

Visibility
PUBLIC

Members
Methods
Method Description
GetDuration (+)
GetPosition (+)
SetCueData (+)
SetPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IContainerPlaylistItem)
Next (ICueData)


Previous
Next (GetPosition)

Name
GetDuration

Parent
ICueableAudioSource

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPosition)


Previous (GetDuration)
Next (SetCueData)

Name
GetPosition

Parent
ICueableAudioSource

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (SetCueData)


Previous (GetPosition)
Next (SetPosition)

Name
SetCueData

Parent
ICueableAudioSource

Visibility
PUBLIC

Source code
procedure SetCueData ( iValue : ICueData )

Parameters
Parameter Description
iValue : ICueData

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (SetPosition)


Previous (SetCueData)
Next

Name
SetPosition

Parent
ICueableAudioSource

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetCueData)
Next


Previous (ICueableAudioSource)
Next (ICueDataItem)

Name
ICueData

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
LoadFromCueSheet (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueableAudioSource)
Next (ICueDataItem)


Previous
Next (LoadFromCueSheet)

Name
GetItem

Parent
ICueData

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : ICueDataItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (LoadFromCueSheet)


Previous (GetItem)
Next

Name
LoadFromCueSheet

Parent
ICueData

Visibility
PUBLIC

Source code
procedure LoadFromCueSheet ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (ICueData)
Next (ICueMode)

Name
ICueDataItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetDescription (+)
GetParameters (+)
GetPosition (+)
SetPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueData)
Next (ICueMode)


Previous
Next (GetParameters)

Name
GetDescription

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetParameters)


Previous (GetDescription)
Next (GetPosition)

Name
GetParameters

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetParameters : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetPosition)


Previous (GetParameters)
Next (SetPosition)

Name
GetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (SetPosition)


Previous (GetPosition)
Next

Name
SetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next


Previous (ICueDataItem)
Next (IDatabase)

Name
ICueMode

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CueModeOff (+)
CueModeOn (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueDataItem)
Next (IDatabase)


Previous
Next (CueModeOn)

Name
CueModeOff

Parent
ICueMode

Visibility
PUBLIC

Source code
procedure CueModeOff

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CueModeOn)


Previous (CueModeOff)
Next

Name
CueModeOn

Parent
ICueMode

Visibility
PUBLIC

Source code
procedure CueModeOn ( iPosition : TTimeValue )

Parameters
Parameter Description
iPosition : TTimeValue

mAirListScript
Class Tree
Index
Previous (CueModeOff)
Next


Previous (ICueMode)
Next (IDatabaseInlineLoader)

Name
IDatabase

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Connect (+)
ConnectAsync (+)
CreatePlaylistItem (+)
Disconnect (+)
ExecuteSQL (+)
FillDatabaseTree (+)
GetCapabilities (+)
GetCaption (+)
GetCurrentPlaylist (+)
GetCustomCaption (+)
GetErrorMessage (+)
GetID (+)
GetNextPlaylist (+)
GetPlaylist (+)
GetPlaylistByID (+)
GetState (+)
GetUniqueID (+)
LoadConfig (+)
ReverseLookup (+)
SaveConfig (+)
SavePlaylistItem (+)
SearchItems (+)
SetCustomCaption (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueMode)
Next (IDatabaseInlineLoader)


Previous
Next (ConnectAsync)

Name
Connect

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure Connect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ConnectAsync)


Previous (Connect)
Next (CreatePlaylistItem)

Name
ConnectAsync

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure ConnectAsync

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Connect)
Next (CreatePlaylistItem)


Previous (ConnectAsync)
Next (Disconnect)

Name
CreatePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
function CreatePlaylistItem ( iID : string ) : IPlaylistItem

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (ConnectAsync)
Next (Disconnect)


Previous (CreatePlaylistItem)
Next (ExecuteSQL)

Name
Disconnect

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure Disconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItem)
Next (ExecuteSQL)


Previous (Disconnect)
Next (FillDatabaseTree)

Name
ExecuteSQL

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure ExecuteSQL ( iSQL : string )

Parameters
Parameter Description
iSQL : STRING

mAirListScript
Class Tree
Index
Previous (Disconnect)
Next (FillDatabaseTree)


Previous (ExecuteSQL)
Next (GetCapabilities)

Name
FillDatabaseTree

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure FillDatabaseTree ( iTree : IDatabaseTree ; iParent : cardinal ; const iParentData : TDatabaseNodeData )

Parameters
Parameter Description
iTree : IDatabaseTree
iParent : CARDINAL
iParentData : TDatabaseNodeData

mAirListScript
Class Tree
Index
Previous (ExecuteSQL)
Next (GetCapabilities)


Previous (FillDatabaseTree)
Next (GetCaption)

Name
GetCapabilities

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCapabilities : TDatabaseCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FillDatabaseTree)
Next (GetCaption)


Previous (GetCapabilities)
Next (GetCurrentPlaylist)

Name
GetCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetCurrentPlaylist)


Previous (GetCaption)
Next (GetCustomCaption)

Name
GetCurrentPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCurrentPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCustomCaption)


Previous (GetCurrentPlaylist)
Next (GetErrorMessage)

Name
GetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCustomCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentPlaylist)
Next (GetErrorMessage)


Previous (GetCustomCaption)
Next (GetID)

Name
GetErrorMessage

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomCaption)
Next (GetID)


Previous (GetErrorMessage)
Next (GetNextPlaylist)

Name
GetID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetNextPlaylist)


Previous (GetID)
Next (GetPlaylist)

Name
GetNextPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetNextPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (GetPlaylist)


Previous (GetNextPlaylist)
Next (GetPlaylistByID)

Name
GetPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylist ( iSlot : TDateTime ) : IPlaylist

Parameters
Parameter Description
iSlot : TDateTime

mAirListScript
Class Tree
Index
Previous (GetNextPlaylist)
Next (GetPlaylistByID)


Previous (GetPlaylist)
Next (GetState)

Name
GetPlaylistByID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylistByID ( iID : string ) : IPlaylist

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetState)


Previous (GetPlaylistByID)
Next (GetUniqueID)

Name
GetState

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetState : TDatabaseState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylistByID)
Next (GetUniqueID)


Previous (GetState)
Next (LoadConfig)

Name
GetUniqueID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetUniqueID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (LoadConfig)


Previous (GetUniqueID)
Next (ReverseLookup)

Name
LoadConfig

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure LoadConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (GetUniqueID)
Next (ReverseLookup)


Previous (LoadConfig)
Next (SaveConfig)

Name
ReverseLookup

Parent
IDatabase

Visibility
PUBLIC

Source code
function ReverseLookup ( iFilename : string ) : IPlaylistItem

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (SaveConfig)


Previous (ReverseLookup)
Next (SavePlaylistItem)

Name
SaveConfig

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SaveConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (ReverseLookup)
Next (SavePlaylistItem)


Previous (SaveConfig)
Next (SearchItems)

Name
SavePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SavePlaylistItem ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next (SearchItems)


Previous (SavePlaylistItem)
Next (SetCustomCaption)

Name
SearchItems

Parent
IDatabase

Visibility
PUBLIC

Source code
function SearchItems ( iSearchString : string ; iResultPlaylist : IPlaylist ) : IDatabaseSearchHandler

Parameters
Parameter Description
iSearchString : STRING
iResultPlaylist : IPlaylist

mAirListScript
Class Tree
Index
Previous (SavePlaylistItem)
Next (SetCustomCaption)


Previous (SearchItems)
Next

Name
SetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SetCustomCaption ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SearchItems)
Next


Previous (IDatabase)
Next (IDatabaseList)

Name
IDatabaseInlineLoader

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
LoadInlineData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabase)
Next (IDatabaseList)


Previous
Next

Name
LoadInlineData

Parent
IDatabaseInlineLoader

Visibility
PUBLIC

Source code
procedure LoadInlineData ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)

Name
IDatabaseList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
ConnectAll (+)
DisconnectAll (+)
Finalize (+)
FindByUniqueID (+)
GetItem (+)
LoadConfig (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)


Previous
Next (DisconnectAll)

Name
ConnectAll

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure ConnectAll

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (DisconnectAll)


Previous (ConnectAll)
Next (Finalize)

Name
DisconnectAll

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure DisconnectAll

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ConnectAll)
Next (Finalize)


Previous (DisconnectAll)
Next (FindByUniqueID)

Name
Finalize

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DisconnectAll)
Next (FindByUniqueID)


Previous (Finalize)
Next (GetItem)

Name
FindByUniqueID

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function FindByUniqueID ( iUniqueID : string ) : IDatabase

Parameters
Parameter Description
iUniqueID : STRING

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetItem)


Previous (FindByUniqueID)
Next (LoadConfig)

Name
GetItem

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IDatabase

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (FindByUniqueID)
Next (LoadConfig)


Previous (GetItem)
Next

Name
LoadConfig

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (IDatabaseList)
Next (IDatabaseTree)

Name
IDatabaseSearchHandler

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
IsActive (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseList)
Next (IDatabaseTree)


Previous
Next

Name
IsActive

Parent
IDatabaseSearchHandler

Visibility
PUBLIC

Source code
function IsActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseSearchHandler)
Next (IDebugObject)

Name
IDatabaseTree

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddNode (+)
GetDataOfNode (+)
GetNodeCaption (+)
GetNodeDuration (+)
GetNodeExpectChildren (+)
GetNodeParent (+)
GetNodeType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseSearchHandler)
Next (IDebugObject)


Previous
Next (GetDataOfNode)

Name
AddNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
procedure AddNode ( iParent : cardinal ; iDatabase : IDatabase ; iNodeType : TDatabaseTreeNodeType ; iCaption : string ; iExpectChildren : boolean = true ; iDuration : TTimeValue = 0 ; iData : string = '' )

Parameters
Parameter Description
iParent : CARDINAL
iDatabase : IDatabase
iNodeType : TDatabaseTreeNodeType
iCaption : STRING
iExpectChildren : BOOLEAN
iDuration : TTimeValue
iData : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetDataOfNode)


Previous (AddNode)
Next (GetNodeCaption)

Name
GetDataOfNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetDataOfNode ( iNode : cardinal ) : TDatabaseNodeData

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (AddNode)
Next (GetNodeCaption)


Previous (GetDataOfNode)
Next (GetNodeDuration)

Name
GetNodeCaption

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetNodeCaption ( iNode : cardinal ) : string

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (GetDataOfNode)
Next (GetNodeDuration)


Previous (GetNodeCaption)
Next (GetNodeExpectChildren)

Name
GetNodeDuration

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetNodeDuration ( iNode : cardinal ) : TTimeValue

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (GetNodeCaption)
Next (GetNodeExpectChildren)


Previous (GetNodeDuration)
Next (GetNodeParent)

Name
GetNodeExpectChildren

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetNodeExpectChildren ( iNode : cardinal ) : boolean

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (GetNodeDuration)
Next (GetNodeParent)


Previous (GetNodeExpectChildren)
Next (GetNodeType)

Name
GetNodeParent

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetNodeParent ( iNode : cardinal ) : cardinal

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (GetNodeExpectChildren)
Next (GetNodeType)


Previous (GetNodeParent)
Next

Name
GetNodeType

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetNodeType ( iNode : cardinal ) : TDatabaseTreeNodeType

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (GetNodeParent)
Next


Previous (IDatabaseTree)
Next (IDummyAction)

Name
IDebugObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetObjectInfo (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseTree)
Next (IDummyAction)


Previous
Next

Name
GetObjectInfo

Parent
IDebugObject

Visibility
PUBLIC

Source code
function GetObjectInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDebugObject)
Next (IDummyObject)

Name
IDummyAction

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDebugObject)
Next (IDummyObject)


Previous (IDummyAction)
Next (IDummyPlaylistItem)

Name
IDummyObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyAction)
Next (IDummyPlaylistItem)


Previous (IDummyObject)
Next (IDynamicTitle)

Name
IDummyPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyObject)
Next (IDynamicTitle)


Previous (IDummyPlaylistItem)
Next (IEmergencyAction)

Name
IDynamicTitle

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDynamicTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyPlaylistItem)
Next (IEmergencyAction)


Previous
Next

Name
GetDynamicTitle

Parent
IDynamicTitle

Visibility
PUBLIC

Source code
function GetDynamicTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDynamicTitle)
Next (IEngine)

Name
IEmergencyAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDynamicTitle)
Next (IEngine)


Previous (IEmergencyAction)
Next (IEngineInfo)

Name
IEngine

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Finalize (+)
GetActivePlayers (+)
GetCartwallControl (+)
GetDesktopFilename (+)
GetModified (+)
GetPlaybackControl (+)
GetPlaybackControlCount (+)
Initialize (+)
LoadDesktop (+)
LoadFromXML (+)
NewDesktop (+)
SaveAsXML (+)
SaveDesktop (+)
SaveDesktopAs (+)
SetModified (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEmergencyAction)
Next (IEngineInfo)


Previous
Next (GetActivePlayers)

Name
Finalize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetActivePlayers)


Previous (Finalize)
Next (GetCartwallControl)

Name
GetActivePlayers

Parent
IEngine

Visibility
PUBLIC

Source code
function GetActivePlayers : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCartwallControl)


Previous (GetActivePlayers)
Next (GetDesktopFilename)

Name
GetCartwallControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePlayers)
Next (GetDesktopFilename)


Previous (GetCartwallControl)
Next (GetModified)

Name
GetDesktopFilename

Parent
IEngine

Visibility
PUBLIC

Source code
function GetDesktopFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartwallControl)
Next (GetModified)


Previous (GetDesktopFilename)
Next (GetPlaybackControl)

Name
GetModified

Parent
IEngine

Visibility
PUBLIC

Source code
function GetModified : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDesktopFilename)
Next (GetPlaybackControl)


Previous (GetModified)
Next (GetPlaybackControlCount)

Name
GetPlaybackControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetModified)
Next (GetPlaybackControlCount)


Previous (GetPlaybackControl)
Next (Initialize)

Name
GetPlaybackControlCount

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControl)
Next (Initialize)


Previous (GetPlaybackControlCount)
Next (LoadDesktop)

Name
Initialize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next (LoadDesktop)


Previous (Initialize)
Next (LoadFromXML)

Name
LoadDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadDesktop ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (LoadFromXML)


Previous (LoadDesktop)
Next (NewDesktop)

Name
LoadFromXML

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (LoadDesktop)
Next (NewDesktop)


Previous (LoadFromXML)
Next (SaveAsXML)

Name
NewDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure NewDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (NewDesktop)
Next (SaveDesktop)

Name
SaveAsXML

Parent
IEngine

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ; iAsTemplate : boolean ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument
iAsTemplate : BOOLEAN

mAirListScript
Class Tree
Index
Previous (NewDesktop)
Next (SaveDesktop)


Previous (SaveAsXML)
Next (SaveDesktopAs)

Name
SaveDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveDesktopAs)


Previous (SaveDesktop)
Next (SetModified)

Name
SaveDesktopAs

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktopAs ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (SaveDesktop)
Next (SetModified)


Previous (SaveDesktopAs)
Next

Name
SetModified

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SetModified ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveDesktopAs)
Next


Previous (IEngine)
Next (IEnvelope)

Name
IEngineInfo

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCartPlayerCount (+)
GetPlaybackControlCount (+)
GetPlayerCount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngine)
Next (IEnvelope)


Previous
Next (GetPlaybackControlCount)

Name
GetCartPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetCartPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaybackControlCount)


Previous (GetCartPlayerCount)
Next (GetPlayerCount)

Name
GetPlaybackControlCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartPlayerCount)
Next (GetPlayerCount)


Previous (GetPlaybackControlCount)
Next

Name
GetPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlayerCount ( iPlaybackControl : integer ) : integer

Parameters
Parameter Description
iPlaybackControl : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next


Previous (IEngineInfo)
Next (IEOFWarningCueDataItem)

Name
IEnvelope

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
Assign (+)
Clear (+)
Delete (+)
GetCount (+)
GetPosition (+)
GetValue (+)
GetValueAtPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngineInfo)
Next (IEOFWarningCueDataItem)


Previous
Next (Assign)

Name
ADD

Parent
IEnvelope

Visibility
PUBLIC

Source code
function Add ( iPosition : TTimeValue ; iValue : single ) : integer

Parameters
Parameter Description
iPosition : TTimeValue
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous
Next (Assign)


Previous (ADD)
Next (Clear)

Name
Assign

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IEnvelope )

Parameters
Parameter Description
iValue : IEnvelope

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Clear)


Previous (Assign)
Next (Delete)

Name
Clear

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (Delete)


Previous (Clear)
Next (GetCount)

Name
Delete

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetCount)


Previous (Delete)
Next (GetPosition)

Name
GetCount

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Delete)
Next (GetPosition)


Previous (GetCount)
Next (GetValue)

Name
GetPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetPosition ( iIndex : integer ) : TTimeValue

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetValue)


Previous (GetPosition)
Next (GetValueAtPosition)

Name
GetValue

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValue ( iIndex : integer ) : single

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetValueAtPosition)


Previous (GetValue)
Next

Name
GetValueAtPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValueAtPosition ( iPosition , iDuration : TTimeValue ) : single

Parameters
Parameter Description
iPosition : TTimeValue
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IEnvelope)
Next (IEventList)

Name
IEOFWarningCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEnvelope)
Next (IEventList)


Previous (IEOFWarningCueDataItem)
Next (IEventListItem)

Name
IEventList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetEnabled (+)
GetItem (+)
GetNextExecution (+)
GetNextItem (+)
GetNextItemAssist (+)
GetNextItemAutomation (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEOFWarningCueDataItem)
Next (IEventListItem)


Previous
Next (GetItem)

Name
GetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEnabled)
Next (GetNextExecution)

Name
GetItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IEventListItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetNextExecution)


Previous (GetItem)
Next (GetNextItem)

Name
GetNextExecution

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetNextItem)


Previous (GetNextExecution)
Next (GetNextItemAssist)

Name
GetNextItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetNextItemAssist)


Previous (GetNextItem)
Next (GetNextItemAutomation)

Name
GetNextItemAssist

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAssist : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItem)
Next (GetNextItemAutomation)


Previous (GetNextItemAssist)
Next (SetEnabled)

Name
GetNextItemAutomation

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAutomation : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItemAssist)
Next (SetEnabled)


Previous (GetNextItemAutomation)
Next

Name
SetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetNextItemAutomation)
Next


Previous (IEventList)
Next (IFactory)

Name
IEventListItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetActionList (+)
GetDay (+)
GetDescription (+)
GetExpiration (+)
GetExpires (+)
GetHour (+)
GetLastExecution (+)
GetMinute (+)
GetMonth (+)
GetNextExecution (+)
GetRunInAssist (+)
GetRunInAutomation (+)
GetSecond (+)
GetWeekday (+)
GetYear (+)
SetDay (+)
SetDescription (+)
SetExpiration (+)
SetExpires (+)
SetHour (+)
SetLastExecution (+)
SetMinute (+)
SetMonth (+)
SetRunInAssist (+)
SetRunInAutomation (+)
SetSecond (+)
SetWeekday (+)
SetYear (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventList)
Next (IFactory)


Previous
Next (GetDay)

Name
GetActionList

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetActionList : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDay)


Previous (GetActionList)
Next (GetDescription)

Name
GetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDay : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActionList)
Next (GetDescription)


Previous (GetDay)
Next (GetExpiration)

Name
GetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDay)
Next (GetExpiration)


Previous (GetDescription)
Next (GetExpires)

Name
GetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetExpiration : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetExpires)


Previous (GetExpiration)
Next (GetHour)

Name
GetExpires

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetExpires : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiration)
Next (GetHour)


Previous (GetExpires)
Next (GetLastExecution)

Name
GetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetHour : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpires)
Next (GetLastExecution)


Previous (GetHour)
Next (GetMinute)

Name
GetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetLastExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHour)
Next (GetMinute)


Previous (GetLastExecution)
Next (GetMonth)

Name
GetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMinute : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLastExecution)
Next (GetMonth)


Previous (GetMinute)
Next (GetNextExecution)

Name
GetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMonth : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMinute)
Next (GetNextExecution)


Previous (GetMonth)
Next (GetRunInAssist)

Name
GetNextExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMonth)
Next (GetRunInAssist)


Previous (GetNextExecution)
Next (GetRunInAutomation)

Name
GetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAssist : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetRunInAutomation)


Previous (GetRunInAssist)
Next (GetSecond)

Name
GetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAutomation : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAssist)
Next (GetSecond)


Previous (GetRunInAutomation)
Next (GetWeekday)

Name
GetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetSecond : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAutomation)
Next (GetWeekday)


Previous (GetSecond)
Next (GetYear)

Name
GetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetWeekday : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSecond)
Next (GetYear)


Previous (GetWeekday)
Next (SetDay)

Name
GetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetYear : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWeekday)
Next (SetDay)


Previous (GetYear)
Next (SetDescription)

Name
SetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDay ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (GetYear)
Next (SetDescription)


Previous (SetDay)
Next (SetExpiration)

Name
SetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDay)
Next (SetExpiration)


Previous (SetDescription)
Next (SetExpires)

Name
SetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetExpiration ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetExpires)


Previous (SetExpiration)
Next (SetHour)

Name
SetExpires

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetExpires ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetExpiration)
Next (SetHour)


Previous (SetExpires)
Next (SetLastExecution)

Name
SetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetHour ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetExpires)
Next (SetLastExecution)


Previous (SetHour)
Next (SetMinute)

Name
SetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetLastExecution ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetHour)
Next (SetMinute)


Previous (SetLastExecution)
Next (SetMonth)

Name
SetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMinute ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetLastExecution)
Next (SetMonth)


Previous (SetMinute)
Next (SetRunInAssist)

Name
SetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMonth ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetMinute)
Next (SetRunInAssist)


Previous (SetMonth)
Next (SetRunInAutomation)

Name
SetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAssist ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetMonth)
Next (SetRunInAutomation)


Previous (SetRunInAssist)
Next (SetSecond)

Name
SetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAutomation ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetRunInAssist)
Next (SetSecond)


Previous (SetRunInAutomation)
Next (SetWeekday)

Name
SetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetSecond ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetRunInAutomation)
Next (SetWeekday)


Previous (SetSecond)
Next (SetYear)

Name
SetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetWeekday ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetSecond)
Next (SetYear)


Previous (SetWeekday)
Next

Name
SetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetYear ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetWeekday)
Next


Previous (IEventListItem)
Next (IFactoryClass)

Name
IFactory

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateActionList (+)
CreateBreakPlaylistItem (+)
CreateCommandPlaylistItem (+)
CreateContainerPlaylistItem (+)
CreateDummyPlaylistItem (+)
CreateEventList (+)
CreateEventListItem (+)
CreateFilePlaylistItem (+)
CreateObject (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+)
CreatePlaylistItemFromXML (+)
CreatePlaylistItemFromXMLString (+)
CreateRegionContainerPlaylistItem (+)
CreateSilencePlaylistItem (+)
CreateStreamPlaylistItem (+)
CreateTemporaryPlaylist (+)
CreateXMLDocument (+)
GetClasses (+)
RegisterClass (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventListItem)
Next (IFactoryClass)


Previous
Next (CreateBreakPlaylistItem)

Name
CreateActionList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateActionList : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CreateBreakPlaylistItem)


Previous (CreateActionList)
Next (CreateCommandPlaylistItem)

Name
CreateBreakPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateBreakPlaylistItem : IBreakPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateActionList)
Next (CreateCommandPlaylistItem)


Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)

Name
CreateCommandPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateCommandPlaylistItem : ICommandPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)


Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)

Name
CreateContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)


Previous (CreateContainerPlaylistItem)
Next (CreateEventList)

Name
CreateDummyPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateDummyPlaylistItem : IDummyPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateEventList)


Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)

Name
CreateEventList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)


Previous (CreateEventList)
Next (CreateFilePlaylistItem)

Name
CreateEventListItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventListItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateEventList)
Next (CreateFilePlaylistItem)


Previous (CreateEventListItem)
Next (CreateObject)

Name
CreateFilePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iTasks : TFileImportTasks ) : IFilePlaylistItem

Parameters
Parameter Description
iFilename : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (CreateEventListItem)
Next (CreateObject)


Previous (CreateFilePlaylistItem)
Next (CreatePlaylist)

Name
CreateObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateObject ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter Description
iGUID : TGUID
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreatePlaylist)


Previous (CreateObject)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateObject)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXML)

Name
CreatePlaylistItemFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iTasks : TFileImportTasks ) : IPlaylistItem

Parameters
Parameter Description
iFilename : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXML)


Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromXML

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXML ( iNode : IXMLNode ) : IPlaylistItem

Parameters
Parameter Description
iNode : IXMLNode

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)

Name
CreatePlaylistItemFromXMLString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter Description
iXML : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)


Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)

Name
CreateRegionContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateRegionContainerPlaylistItem : IRegionContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)


Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)

Name
CreateSilencePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateSilencePlaylistItem : ISilencePlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)


Previous (CreateSilencePlaylistItem)
Next (CreateTemporaryPlaylist)

Name
CreateStreamPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateStreamPlaylistItem : IStreamPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateSilencePlaylistItem)
Next (CreateTemporaryPlaylist)


Previous (CreateStreamPlaylistItem)
Next (CreateXMLDocument)

Name
CreateTemporaryPlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateTemporaryPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStreamPlaylistItem)
Next (CreateXMLDocument)


Previous (CreateTemporaryPlaylist)
Next (GetClasses)

Name
CreateXMLDocument

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateXMLDocument : IXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateTemporaryPlaylist)
Next (GetClasses)


Previous (CreateXMLDocument)
Next (RegisterClass)

Name
GetClasses

Parent
IFactory

Visibility
PUBLIC

Source code
function GetClasses ( iGUID : TGUID ) : IInterfaceList

Parameters
Parameter Description
iGUID : TGUID

mAirListScript
Class Tree
Index
Previous (CreateXMLDocument)
Next (RegisterClass)


Previous (GetClasses)
Next

Name
RegisterClass

Parent
IFactory

Visibility
PUBLIC

Source code
procedure RegisterClass ( iGUID : TGUID ; iClass : IFactoryClass )

Parameters
Parameter Description
iGUID : TGUID
iClass : IFactoryClass

mAirListScript
Class Tree
Index
Previous (GetClasses)
Next


Previous (IFactory)
Next (IFileManager)

Name
IFactoryClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateInstance (+)
CreateInstanceWithParameters (+)
GetClassCategory (+)
GetClassDescription (+)
GetClassID (+)
InitializeClass (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactory)
Next (IFileManager)


Previous
Next (CreateInstanceWithParameters)

Name
CreateInstance

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstance ( iInstance : IInstanceData ) : IUnknown

Parameters
Parameter Description
iInstance : IInstanceData

mAirListScript
Class Tree
Index
Previous
Next (CreateInstanceWithParameters)


Previous (CreateInstance)
Next (GetClassCategory)

Name
CreateInstanceWithParameters

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstanceWithParameters ( iInstance : IInstanceData ; iParameters : array of Variant ) : IUnknown

Parameters
Parameter Description
iInstance : IInstanceData
iParameters : VARIANT

mAirListScript
Class Tree
Index
Previous (CreateInstance)
Next (GetClassCategory)


Previous (CreateInstanceWithParameters)
Next (GetClassDescription)

Name
GetClassCategory

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassCategory : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateInstanceWithParameters)
Next (GetClassDescription)


Previous (GetClassCategory)
Next (GetClassID)

Name
GetClassDescription

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassCategory)
Next (GetClassID)


Previous (GetClassDescription)
Next (InitializeClass)

Name
GetClassID

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassDescription)
Next (InitializeClass)


Previous (GetClassID)
Next

Name
InitializeClass

Parent
IFactoryClass

Visibility
PUBLIC

Source code
procedure InitializeClass ( iInstance : IInstanceData )

Parameters
Parameter Description
iInstance : IInstanceData

mAirListScript
Class Tree
Index
Previous (GetClassID)
Next


Previous (IFactoryClass)
Next (IFilePlaylistItem)

Name
IFileManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateFileStream (+)
GetOptions (+)
IsEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactoryClass)
Next (IFilePlaylistItem)


Previous
Next (GetOptions)

Name
CreateFileStream

Parent
IFileManager

Visibility
PUBLIC

Source code
function CreateFileStream ( iFilename : string ) : ImAirListStream

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetOptions)


Previous (CreateFileStream)
Next (IsEnabled)

Name
GetOptions

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetOptions : TFileManagementOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFileStream)
Next (IsEnabled)


Previous (GetOptions)
Next

Name
IsEnabled

Parent
IFileManager

Visibility
PUBLIC

Source code
function IsEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next


Previous (IFileManager)
Next (IFilePlaylistItemClass)

Name
IFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetEffectiveFilename (+)
GetFilename (+)
GetFileTagData (+)
GetFileTypeHandler (+)
LoadMMD (+)
SaveMMD (+)
SetFilename (+)
UpdateTilde (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileManager)
Next (IFilePlaylistItemClass)


Previous
Next (GetFilename)

Name
GetEffectiveFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetFilename)


Previous (GetEffectiveFilename)
Next (GetFileTagData)

Name
GetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveFilename)
Next (GetFileTagData)


Previous (GetFilename)
Next (GetFileTypeHandler)

Name
GetFileTagData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTagData ( iTag : string ) : string

Parameters
Parameter Description
iTag : STRING

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (GetFileTypeHandler)


Previous (GetFileTagData)
Next (LoadMMD)

Name
GetFileTypeHandler

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTypeHandler : IFileTypeHandler

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTagData)
Next (LoadMMD)


Previous (GetFileTypeHandler)
Next (SaveMMD)

Name
LoadMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function LoadMMD : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTypeHandler)
Next (SaveMMD)


Previous (LoadMMD)
Next (SetFilename)

Name
SaveMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveMMD

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadMMD)
Next (SetFilename)


Previous (SaveMMD)
Next (UpdateTilde)

Name
SetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SaveMMD)
Next (UpdateTilde)


Previous (SetFilename)
Next

Name
UpdateTilde

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure UpdateTilde

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetFilename)
Next


Previous (IFilePlaylistItem)
Next (IFileTypeHandler)

Name
IFilePlaylistItemClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItem)
Next (IFileTypeHandler)


Previous
Next

Name
SupportsExtension

Parent
IFilePlaylistItemClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter Description
iExtension : STRING

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFilePlaylistItemClass)
Next (IFileTypeHandlerClass)

Name
IFileTypeHandler

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCapabilities (+)
GetTagData (+)
ReadDuration (+)
ReadNativeTags (+)
ReadTags (+)
SetItem (+)
WriteTags (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItemClass)
Next (IFileTypeHandlerClass)


Previous
Next (GetTagData)

Name
GetCapabilities

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetCapabilities : TFileTypeHandlerCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTagData)


Previous (GetCapabilities)
Next (ReadDuration)

Name
GetTagData

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetTagData ( iTag : string ) : string

Parameters
Parameter Description
iTag : STRING

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (ReadDuration)


Previous (GetTagData)
Next (ReadNativeTags)

Name
ReadDuration

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadDuration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTagData)
Next (ReadNativeTags)


Previous (ReadDuration)
Next (ReadTags)

Name
ReadNativeTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadNativeTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadDuration)
Next (ReadTags)


Previous (ReadNativeTags)
Next (SetItem)

Name
ReadTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function ReadTags : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadNativeTags)
Next (SetItem)


Previous (ReadTags)
Next (WriteTags)

Name
SetItem

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure SetItem ( iItem : IFilePlaylistItem )

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous (ReadTags)
Next (WriteTags)


Previous (SetItem)
Next

Name
WriteTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure WriteTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetItem)
Next


Previous (IFileTypeHandler)
Next (IGetCommandList)

Name
IFileTypeHandlerClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
SupportsItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandler)
Next (IGetCommandList)


Previous
Next

Name
SupportsItem

Parent
IFileTypeHandlerClass

Visibility
PUBLIC

Source code
function SupportsItem ( iItem : IFilePlaylistItem ) : integer

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileTypeHandlerClass)
Next (IInlineFilePlaylistItem)

Name
IGetCommandList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCommandList (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandlerClass)
Next (IInlineFilePlaylistItem)


Previous
Next

Name
GetCommandList

Parent
IGetCommandList

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IGetCommandList)
Next (IInlinePlaylistItem)

Name
IInlineFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetOriginalFilename (+)
SaveToMIF (+)
SetOriginalFilename (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IGetCommandList)
Next (IInlinePlaylistItem)


Previous
Next (SaveToMIF)

Name
GetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
function GetOriginalFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SaveToMIF)


Previous (GetOriginalFilename)
Next (SetOriginalFilename)

Name
SaveToMIF

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveToMIF ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetOriginalFilename)
Next (SetOriginalFilename)


Previous (SaveToMIF)
Next

Name
SetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetOriginalFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SaveToMIF)
Next


Previous (IInlineFilePlaylistItem)
Next (IInstanceData)

Name
IInlinePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetData (+)
SetData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlineFilePlaylistItem)
Next (IInstanceData)


Previous
Next (SetData)

Name
GetData

Parent
IInlinePlaylistItem

Visibility
PUBLIC

Source code
function GetData : ISharedMemory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetData)


Previous (GetData)
Next

Name
SetData

Parent
IInlinePlaylistItem

Visibility
PUBLIC

Source code
procedure SetData ( iValue : ISharedMemory )

Parameters
Parameter Description
iValue : ISharedMemory

mAirListScript
Class Tree
Index
Previous (GetData)
Next


Previous (IInlinePlaylistItem)
Next (ILicenseManager)

Name
IInstanceData

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddModule (+)
FakeNow (+)
Finalize (+)
GetAudioDevices (+)
GetClients (+)
GetCommandList (+)
GetConfig (+)
GetDatabases (+)
GetDeviceConfig (+)
GetDisabledModules (+)
GetEngine (+)
GetEngineInfo (+)
GetFactory (+)
GetFeatures (+)
GetFileImportOptions (+)
GetFileManager (+)
GetLicenseManager (+)
GetLogger (+)
GetMessageDispatcher (+)
GetMMDFolder (+)
GetModules (+)
GetOnAir (+)
GetOptions (+)
GetRecycleBin (+)
GetRegions (+)
GetRemoteController (+)
GetRepositoryItem (+)
GetSerialPortManager (+)
GetSupportedFileExtensions (+)
GetTimeCorrection (+)
Initialize (+)
SetOnAir (+)
SetTimeCorrection (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlinePlaylistItem)
Next (ILicenseManager)


Previous
Next (FakeNow)

Name
AddModule

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure AddModule ( iModule : IModule )

Parameters
Parameter Description
iModule : IModule

mAirListScript
Class Tree
Index
Previous
Next (FakeNow)


Previous (AddModule)
Next (Finalize)

Name
FakeNow

Parent
IInstanceData

Visibility
PUBLIC

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddModule)
Next (Finalize)


Previous (FakeNow)
Next (GetAudioDevices)

Name
Finalize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (GetAudioDevices)


Previous (Finalize)
Next (GetClients)

Name
GetAudioDevices

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetAudioDevices : IAudioDeviceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetClients)


Previous (GetAudioDevices)
Next (GetCommandList)

Name
GetClients

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetClients : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAudioDevices)
Next (GetCommandList)


Previous (GetClients)
Next (GetConfig)

Name
GetCommandList

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClients)
Next (GetConfig)


Previous (GetCommandList)
Next (GetDatabases)

Name
GetConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetConfig : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandList)
Next (GetDatabases)


Previous (GetConfig)
Next (GetDeviceConfig)

Name
GetDatabases

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDatabases : IDatabaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConfig)
Next (GetDeviceConfig)


Previous (GetDatabases)
Next (GetDisabledModules)

Name
GetDeviceConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDeviceConfig : IAudioDeviceConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabases)
Next (GetDisabledModules)


Previous (GetDeviceConfig)
Next (GetEngine)

Name
GetDisabledModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDisabledModules : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceConfig)
Next (GetEngine)


Previous (GetDisabledModules)
Next (GetEngineInfo)

Name
GetEngine

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisabledModules)
Next (GetEngineInfo)


Previous (GetEngine)
Next (GetFactory)

Name
GetEngineInfo

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngineInfo : IEngineInfo

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngine)
Next (GetFactory)


Previous (GetEngineInfo)
Next (GetFeatures)

Name
GetFactory

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFactory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngineInfo)
Next (GetFeatures)


Previous (GetFactory)
Next (GetFileImportOptions)

Name
GetFeatures

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFeatures : TmAirListFeatures

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFactory)
Next (GetFileImportOptions)


Previous (GetFeatures)
Next (GetFileManager)

Name
GetFileImportOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFileImportOptions : TFileImportOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFeatures)
Next (GetFileManager)


Previous (GetFileImportOptions)
Next (GetLicenseManager)

Name
GetFileManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFileManager : IFileManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileImportOptions)
Next (GetLicenseManager)


Previous (GetFileManager)
Next (GetLogger)

Name
GetLicenseManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLicenseManager : ILicenseManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileManager)
Next (GetLogger)


Previous (GetLicenseManager)
Next (GetMessageDispatcher)

Name
GetLogger

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLogger : ILogger

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLicenseManager)
Next (GetMessageDispatcher)


Previous (GetLogger)
Next (GetMMDFolder)

Name
GetMessageDispatcher

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMessageDispatcher : IMessageDispatcher

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogger)
Next (GetMMDFolder)


Previous (GetMessageDispatcher)
Next (GetModules)

Name
GetMMDFolder

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMMDFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageDispatcher)
Next (GetModules)


Previous (GetMMDFolder)
Next (GetOnAir)

Name
GetModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetModules : IModuleList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMMDFolder)
Next (GetOnAir)


Previous (GetModules)
Next (GetOptions)

Name
GetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOnAir : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetModules)
Next (GetOptions)


Previous (GetOnAir)
Next (GetRecycleBin)

Name
GetOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOptions : TGlobalOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAir)
Next (GetRecycleBin)


Previous (GetOptions)
Next (GetRegions)

Name
GetRecycleBin

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRecycleBin : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetRegions)


Previous (GetRecycleBin)
Next (GetRemoteController)

Name
GetRegions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRegions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRecycleBin)
Next (GetRemoteController)


Previous (GetRegions)
Next (GetRepositoryItem)

Name
GetRemoteController

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRemoteController : IRemoteController

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetRepositoryItem)


Previous (GetRemoteController)
Next (GetSerialPortManager)

Name
GetRepositoryItem

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRepositoryItem ( iItem : TRepositoryItem ) : IPlaylistItem

Parameters
Parameter Description
iItem : TRepositoryItem

mAirListScript
Class Tree
Index
Previous (GetRemoteController)
Next (GetSerialPortManager)


Previous (GetRepositoryItem)
Next (GetSupportedFileExtensions)

Name
GetSerialPortManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSerialPortManager : ISerialPortManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRepositoryItem)
Next (GetSupportedFileExtensions)


Previous (GetSerialPortManager)
Next (GetTimeCorrection)

Name
GetSupportedFileExtensions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSupportedFileExtensions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerialPortManager)
Next (GetTimeCorrection)


Previous (GetSupportedFileExtensions)
Next (Initialize)

Name
GetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetTimeCorrection : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSupportedFileExtensions)
Next (Initialize)


Previous (GetTimeCorrection)
Next (SetOnAir)

Name
Initialize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeCorrection)
Next (SetOnAir)


Previous (Initialize)
Next (SetTimeCorrection)

Name
SetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetOnAir ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (SetTimeCorrection)


Previous (SetOnAir)
Next

Name
SetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetTimeCorrection ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetOnAir)
Next


Previous (IInstanceData)
Next (ILogEntry)

Name
ILicenseManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CheckModule (+)
GetEdition (+)
GetExpiresDateTime (+)
GetName (+)
GetSerial (+)
GetTimeLimit (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInstanceData)
Next (ILogEntry)


Previous
Next (GetEdition)

Name
CheckModule

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function CheckModule ( iName : string ) : boolean

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetEdition)


Previous (CheckModule)
Next (GetExpiresDateTime)

Name
GetEdition

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetEdition : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckModule)
Next (GetExpiresDateTime)


Previous (GetEdition)
Next (GetName)

Name
GetExpiresDateTime

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetExpiresDateTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEdition)
Next (GetName)


Previous (GetExpiresDateTime)
Next (GetSerial)

Name
GetName

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiresDateTime)
Next (GetSerial)


Previous (GetName)
Next (GetTimeLimit)

Name
GetSerial

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetSerial : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetTimeLimit)


Previous (GetSerial)
Next

Name
GetTimeLimit

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetTimeLimit : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILicenseManager)
Next (ILogEntryList)

Name
ILogEntry

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCategory (+)
GetMessage (+)
GetSender (+)
GetSerial (+)
GetTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILicenseManager)
Next (ILogEntryList)


Previous
Next (GetMessage)

Name
GetCategory

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetCategory : TLogCategory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetMessage)


Previous (GetCategory)
Next (GetSender)

Name
GetMessage

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCategory)
Next (GetSender)


Previous (GetMessage)
Next (GetSerial)

Name
GetSender

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSender : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessage)
Next (GetSerial)


Previous (GetSender)
Next (GetTime)

Name
GetSerial

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSerial : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSender)
Next (GetTime)


Previous (GetSerial)
Next

Name
GetTime

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILogEntry)
Next (ILogger)

Name
ILogEntryList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
GetEntryCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntry)
Next (ILogger)


Previous
Next (GetItem)

Name
GetEntryCount

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetEntryCount ( iCategory : TLogCategory ) : integer

Parameters
Parameter Description
iCategory : TLogCategory

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEntryCount)
Next

Name
GetItem

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogEntry

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEntryCount)
Next


Previous (ILogEntryList)
Next (ILogInterface)

Name
ILogger

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetEnabled (+)
GetEntries (+)
GetLogInterfaces (+)
LoadConfig (+)
SetEnabled (+)
StartLog (+)
StopLog (+)
SystemLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntryList)
Next (ILogInterface)


Previous
Next (GetEntries)

Name
GetEnabled

Parent
ILogger

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEntries)


Previous (GetEnabled)
Next (GetLogInterfaces)

Name
GetEntries

Parent
ILogger

Visibility
PUBLIC

Source code
function GetEntries : ILogEntryList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetLogInterfaces)


Previous (GetEntries)
Next (LoadConfig)

Name
GetLogInterfaces

Parent
ILogger

Visibility
PUBLIC

Source code
function GetLogInterfaces : ILogInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEntries)
Next (LoadConfig)


Previous (GetLogInterfaces)
Next (SetEnabled)

Name
LoadConfig

Parent
ILogger

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogInterfaces)
Next (SetEnabled)


Previous (LoadConfig)
Next (StartLog)

Name
SetEnabled

Parent
ILogger

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (StartLog)


Previous (SetEnabled)
Next (StopLog)

Name
StartLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (SetEnabled)
Next (StopLog)


Previous (StartLog)
Next (SystemLog)

Name
StopLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iDuration : TTimeValue )

Parameters
Parameter Description
iItem : IPlaylistItem
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (StartLog)
Next (SystemLog)


Previous (StopLog)
Next

Name
SystemLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure SystemLog ( iCategory : TLogCategory ; iMessage : string )

Parameters
Parameter Description
iCategory : TLogCategory
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (StopLog)
Next


Previous (ILogger)
Next (ILogInterfaceList)

Name
ILogInterface

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCaption (+)
GetID (+)
Initialize (+)
LoadConfig (+)
SaveConfig (+)
StartLog (+)
StopLog (+)
SystemLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogger)
Next (ILogInterfaceList)


Previous
Next (GetID)

Name
GetCaption

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetID)


Previous (GetCaption)
Next (Initialize)

Name
GetID

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (Initialize)


Previous (GetID)
Next (LoadConfig)

Name
Initialize

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (LoadConfig)


Previous (Initialize)
Next (SaveConfig)

Name
LoadConfig

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure LoadConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (SaveConfig)


Previous (LoadConfig)
Next (StartLog)

Name
SaveConfig

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SaveConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (StartLog)


Previous (SaveConfig)
Next (StopLog)

Name
StartLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next (StopLog)


Previous (StartLog)
Next (SystemLog)

Name
StopLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iDuration : TTimeValue )

Parameters
Parameter Description
iItem : IPlaylistItem
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (StartLog)
Next (SystemLog)


Previous (StopLog)
Next

Name
SystemLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SystemLog ( iCategory : TLogCategory ; iMessage : string )

Parameters
Parameter Description
iCategory : TLogCategory
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (StopLog)
Next


Previous (ILogInterface)
Next (ImAirListInstance)

Name
ILogInterfaceList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
LoadConfig (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterface)
Next (ImAirListInstance)


Previous
Next (LoadConfig)

Name
GetItem

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogInterface

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (LoadConfig)


Previous (GetItem)
Next

Name
LoadConfig

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (ILogInterfaceList)
Next (ImAirListStream)

Name
ImAirListInstance

Parent
mAirListInterfaces

Class Hierarchy
IInstanceData

Visibility
PUBLIC

Members
Methods
Method Description
GetConfigDir (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterfaceList)
Next (ImAirListStream)


Previous
Next

Name
GetConfigDir

Parent
ImAirListInstance

Visibility
PUBLIC

Source code
function GetConfigDir : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (ImAirListInstance)
Next (IMarkerCueDataitem)

Name
ImAirListStream

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetSize (+)
READ (+)
Seek (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ImAirListInstance)
Next (IMarkerCueDataitem)


Previous
Next (READ)

Name
GetSize

Parent
ImAirListStream

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (READ)


Previous (GetSize)
Next (Seek)

Name
READ

Parent
ImAirListStream

Visibility
PUBLIC

Source code
function Read ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter Description
Buffer : pointer
Count : INTEGER

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (Seek)


Previous (READ)
Next

Name
Seek

Parent
ImAirListStream

Visibility
PUBLIC

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64

Parameters
Parameter Description
OFFSET : INT64
Origin : TSeekOrigin

mAirListScript
Class Tree
Index
Previous (READ)
Next


Previous (ImAirListStream)
Next (IMessageDispatcher)

Name
IMarkerCueDataitem

Parent
mAirListInterfaces

Class Hierarchy
IBaseMarkerCueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ImAirListStream)
Next (IMessageDispatcher)


Previous (IMarkerCueDataitem)
Next (IMetaCueDataItem)

Name
IMessageDispatcher

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BroadcastMessage (+)
CreateQueue (+)
DeleteQueue (+)
PostMessage (+)
PostMessageDelayed (+)
SetCatchAll (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMarkerCueDataitem)
Next (IMetaCueDataItem)


Previous
Next (CreateQueue)

Name
BroadcastMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure BroadcastMessage ( iMessage : IBaseMessage )

Parameters
Parameter Description
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous
Next (CreateQueue)


Previous (BroadcastMessage)
Next (DeleteQueue)

Name
CreateQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
function CreateQueue ( iProc : TMessageProc ; iDirect : boolean ) : TMessageHandle

Parameters
Parameter Description
iProc : TMessageProc
iDirect : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BroadcastMessage)
Next (DeleteQueue)


Previous (CreateQueue)
Next (PostMessage)

Name
DeleteQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure DeleteQueue ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous (CreateQueue)
Next (PostMessage)


Previous (DeleteQueue)
Next (PostMessageDelayed)

Name
PostMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessage ( iHandle : TMessageHandle ; iMessage : IBaseMessage )

Parameters
Parameter Description
iHandle : TMessageHandle
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (DeleteQueue)
Next (PostMessageDelayed)


Previous (PostMessage)
Next (SetCatchAll)

Name
PostMessageDelayed

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessageDelayed ( iHandle : TMessageHandle ; iDelay : integer ; iMessage : IBaseMessage )

Parameters
Parameter Description
iHandle : TMessageHandle
iDelay : INTEGER
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (PostMessage)
Next (SetCatchAll)


Previous (PostMessageDelayed)
Next

Name
SetCatchAll

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure SetCatchAll ( iHandle : TMessageHandle ; iValue : boolean )

Parameters
Parameter Description
iHandle : TMessageHandle
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (PostMessageDelayed)
Next


Previous (IMessageDispatcher)
Next (IMixdownEngine)

Name
IMetaCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMessageDispatcher)
Next (IMixdownEngine)


Previous
Next

Name
GetItem

Parent
IMetaCueDataItem

Visibility
PUBLIC

Source code
function GetItem : ICueDataItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IMetaCueDataItem)
Next (IMixer)

Name
IMixdownEngine

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
PrepareMixdown (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMetaCueDataItem)
Next (IMixer)


Previous
Next

Name
PrepareMixdown

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
procedure PrepareMixdown ( iFilename , iEncoder : string )

Parameters
Parameter Description
iFilename : STRING
iEncoder : STRING

mAirListScript
Class Tree
Index
Previous
Next


Previous (IMixdownEngine)
Next (IModule)

Name
IMixer

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDestinationCount (+)
GetProductName (+)
GetVolume (+)
IsMuted (+)
Mute (+)
SetVolume (+)
Unmute (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixdownEngine)
Next (IModule)


Previous
Next (GetProductName)

Name
GetDestinationCount

Parent
IMixer

Visibility
PUBLIC

Source code
function GetDestinationCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetProductName)


Previous (GetDestinationCount)
Next (GetVolume)

Name
GetProductName

Parent
IMixer

Visibility
PUBLIC

Source code
function GetProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDestinationCount)
Next (GetVolume)


Previous (GetProductName)
Next (IsMuted)

Name
GetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure GetVolume ( iDestination , iConnection : integer ; var oLeft , oRight : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER
oLeft : INTEGER
oRight : INTEGER

mAirListScript
Class Tree
Index
Previous (GetProductName)
Next (IsMuted)


Previous (GetVolume)
Next (Mute)

Name
IsMuted

Parent
IMixer

Visibility
PUBLIC

Source code
function IsMuted ( iDestination , iConnection : integer ) : boolean

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Mute)


Previous (IsMuted)
Next (SetVolume)

Name
Mute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Mute ( iDestination , iConnection : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (IsMuted)
Next (SetVolume)


Previous (Mute)
Next (Unmute)

Name
SetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure SetVolume ( iDestination , iConnection : integer ; iLeft , iRight : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER
iLeft : INTEGER
iRight : INTEGER

mAirListScript
Class Tree
Index
Previous (Mute)
Next (Unmute)


Previous (SetVolume)
Next

Name
Unmute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Unmute ( iDestination , iConnection : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next


Previous (IMixer)
Next (IModuleList)

Name
IModule

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CheckLicense (+)
Finalize (+)
GetAuthor (+)
GetDescription (+)
GetID (+)
GetVersion (+)
Initialize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixer)
Next (IModuleList)


Previous
Next (Finalize)

Name
CheckLicense

Parent
IModule

Visibility
PUBLIC

Source code
function CheckLicense ( iLicenseManager : ILicenseManager ) : boolean

Parameters
Parameter Description
iLicenseManager : ILicenseManager

mAirListScript
Class Tree
Index
Previous
Next (Finalize)


Previous (CheckLicense)
Next (GetAuthor)

Name
Finalize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckLicense)
Next (GetAuthor)


Previous (Finalize)
Next (GetDescription)

Name
GetAuthor

Parent
IModule

Visibility
PUBLIC

Source code
function GetAuthor : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetDescription)


Previous (GetAuthor)
Next (GetID)

Name
GetDescription

Parent
IModule

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAuthor)
Next (GetID)


Previous (GetDescription)
Next (GetVersion)

Name
GetID

Parent
IModule

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetVersion)


Previous (GetID)
Next (Initialize)

Name
GetVersion

Parent
IModule

Visibility
PUBLIC

Source code
function GetVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (Initialize)


Previous (GetVersion)
Next

Name
Initialize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVersion)
Next


Previous (IModule)
Next (IMutex)

Name
IModuleList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModule)
Next (IMutex)


Previous
Next (GetCount)

Name
ADD

Parent
IModuleList

Visibility
PUBLIC

Source code
procedure Add ( iModule : IModule )

Parameters
Parameter Description
iModule : IModule

mAirListScript
Class Tree
Index
Previous
Next (GetCount)


Previous (ADD)
Next (GetItem)

Name
GetCount

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ADD)
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IModule

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous (IModuleList)
Next (INetworkFilePlaylistItem)

Name
IMutex

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginRead (+)
BeginWrite (+)
EndRead (+)
EndWrite (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModuleList)
Next (INetworkFilePlaylistItem)


Previous
Next (BeginWrite)

Name
BeginRead

Parent
IMutex

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeginWrite)


Previous (BeginRead)
Next (EndRead)

Name
BeginWrite

Parent
IMutex

Visibility
PUBLIC

Source code
function BeginWrite : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (EndRead)


Previous (BeginWrite)
Next (EndWrite)

Name
EndRead

Parent
IMutex

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginWrite)
Next (EndWrite)


Previous (EndRead)
Next

Name
EndWrite

Parent
IMutex

Visibility
PUBLIC

Source code
procedure EndWrite

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next


Previous (IMutex)
Next (INotifiedMessageReceiver)

Name
INetworkFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IURLPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMutex)
Next (INotifiedMessageReceiver)


Previous (INetworkFilePlaylistItem)
Next (INotifyItemStarted)

Name
INotifiedMessageReceiver

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginProcessMessages (+)
EndProcessMessages (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INetworkFilePlaylistItem)
Next (INotifyItemStarted)


Previous
Next (EndProcessMessages)

Name
BeginProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure BeginProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndProcessMessages)


Previous (BeginProcessMessages)
Next

Name
EndProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure EndProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginProcessMessages)
Next


Previous (INotifiedMessageReceiver)
Next (IObservable)

Name
INotifyItemStarted

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ItemStarted (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifiedMessageReceiver)
Next (IObservable)


Previous
Next

Name
ItemStarted

Parent
INotifyItemStarted

Visibility
PUBLIC

Source code
procedure ItemStarted ( iSource : IAudioSource )

Parameters
Parameter Description
iSource : IAudioSource

mAirListScript
Class Tree
Index
Previous
Next


Previous (INotifyItemStarted)
Next (IPersistentList)

Name
IObservable

Parent
mAirListInterfaces

Class Hierarchy
IUnknown

Visibility
PUBLIC

Members
Methods
Method Description
AddObserver (+)
RemoveObserver (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifyItemStarted)
Next (IPersistentList)


Previous
Next (RemoveObserver)

Name
AddObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure AddObserver ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous
Next (RemoveObserver)


Previous (AddObserver)
Next

Name
RemoveObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure RemoveObserver ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous (AddObserver)
Next


Previous (IObservable)
Next (IPersistentListItem)

Name
IPersistentList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
Clone (+)
Copy (+)
FindByID (+)
GetGUID (+)
GetPersistentListItem (+)
GetXML (+)
GetXMLNodeName (+)
LoadFromFile (+)
LoadFromXML (+)
SaveAsXML (+)
SaveAsXMLRenamed (+)
SaveToFile (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IObservable)
Next (IPersistentListItem)


Previous
Next (Copy)

Name
Clone

Parent
IPersistentList

Visibility
PUBLIC

Source code
function Clone : IPersistentList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Copy)


Previous (Clone)
Next (FindByID)

Name
Copy

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure Copy ( iValue : IPersistentList )

Parameters
Parameter Description
iValue : IPersistentList

mAirListScript
Class Tree
Index
Previous (Clone)
Next (FindByID)


Previous (Copy)
Next (GetGUID)

Name
FindByID

Parent
IPersistentList

Visibility
PUBLIC

Source code
function FindByID ( iID : TObjectID ) : IPersistentListItem

Parameters
Parameter Description
iID : TObjectID

mAirListScript
Class Tree
Index
Previous (Copy)
Next (GetGUID)


Previous (FindByID)
Next (GetPersistentListItem)

Name
GetGUID

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetGUID : TGUID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindByID)
Next (GetPersistentListItem)


Previous (GetGUID)
Next (GetXML)

Name
GetPersistentListItem

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetPersistentListItem ( iIndex : Integer ) : IPersistentListItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetGUID)
Next (GetXML)


Previous (GetPersistentListItem)
Next (GetXMLNodeName)

Name
GetXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetXML : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPersistentListItem)
Next (GetXMLNodeName)


Previous (GetXML)
Next (LoadFromFile)

Name
GetXMLNodeName

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetXMLNodeName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetXML)
Next (LoadFromFile)


Previous (GetXMLNodeName)
Next (LoadFromXML)

Name
LoadFromFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetXMLNodeName)
Next (LoadFromXML)


Previous (LoadFromFile)
Next (SaveAsXML)

Name
LoadFromXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (SaveAsXML)


Previous (LoadFromXML)
Next (SaveAsXMLRenamed)

Name
SaveAsXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXMLRenamed)


Previous (SaveAsXML)
Next (SaveToFile)

Name
SaveAsXMLRenamed

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXMLRenamed ( iDocument : IXMLDocument ; iNodeName : string ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument
iNodeName : STRING

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveToFile)


Previous (SaveAsXMLRenamed)
Next

Name
SaveToFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (SaveAsXMLRenamed)
Next


Previous (IPersistentList)
Next (IPitchableAudioSource)

Name
IPersistentListItem

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
Clone (+)
GetXML (+)
LoadFromXML (+)
SaveAsXML (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentList)
Next (IPitchableAudioSource)


Previous
Next (Clone)

Name
Assign

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
procedure Assign ( iItem : IPersistentListItem )

Parameters
Parameter Description
iItem : IPersistentListItem

mAirListScript
Class Tree
Index
Previous
Next (Clone)


Previous (Assign)
Next (GetXML)

Name
Clone

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function Clone : IPersistentListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (GetXML)


Previous (Clone)
Next (LoadFromXML)

Name
GetXML

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function GetXML : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (LoadFromXML)


Previous (GetXML)
Next (SaveAsXML)

Name
LoadFromXML

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (GetXML)
Next (SaveAsXML)


Previous (LoadFromXML)
Next

Name
SaveAsXML

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next


Previous (IPersistentListItem)
Next (IPlaybackControl)

Name
IPitchableAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPitch (+)
GetTempo (+)
SetPitch (+)
SetTempo (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentListItem)
Next (IPlaybackControl)


Previous
Next (GetTempo)

Name
GetPitch

Parent
IPitchableAudioSource

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTempo)


Previous (GetPitch)
Next (SetPitch)

Name
GetTempo

Parent
IPitchableAudioSource

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (SetPitch)


Previous (GetTempo)
Next (SetTempo)

Name
SetPitch

Parent
IPitchableAudioSource

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (SetTempo)


Previous (SetPitch)
Next

Name
SetTempo

Parent
IPitchableAudioSource

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next


Previous (IPitchableAudioSource)
Next (IPlayerControl)

Name
IPlaybackControl

Parent
mAirListInterfaces

Class Hierarchy
IPlaylist

Visibility
PUBLIC

Members
Methods
Method | Description
AssistNext (+) | Just like AutomationNext, but for assist mode: Fade out all active
AutomationBreak (+) | Stops automation after the current item.
AutomationJump (+) | Jumps to a specific item.
AutomationJumpSoft (+) | Marks all items before the specified one as played, so that iItem will
AutomationNext (+) | Makes the automation jump to the next item, or starts playback in case
AutomationPlay (+) | Starts automation playback. Automation must be activated with SetAutomation
AutomationStop (+) | Stops automation playback. The current item is faded out.
GetAutomation (+) | Determines whether automation mode is active or not.
GetAutomationPlaying (+)
GetDefaultFadeDuration (+)
GetEventList (+)
GetIndex (+) | Returns the index of this PlaybackControl object within the mAirList system.
GetMaxHistoryCount (+)
GetNextIndex (+) | Determines the index of the item which will be played next. If one of
GetOptions (+)
GetPlayer (+) | Returns a player control object.
GetPlayerCount (+) | Returns the number of players associated with this PlaybackControl object.
GetPlayerOfItem (+) | Returns the player control object in which a specific item is loaded.
GetRemainingDuration (+)
IsPlaying (+)
LoadFromXMLEx (+)
MoveToHistory (+) | Moves an item into history by unloading it from any player and setting
PlayerAutoLoad (+) | Loads a player with the next available, unused item. The player must be empty.
PlayItemDetached (+) | Start playback of an item on the given device, without caring for it thereafter.
RecycleFromHistory (+) | Recycles an item from history.
SaveAsXMLEx (+)
SetAutomation (+) | Enables or disables automation mode.
SetDefaultFadeDuration (+)
SetMaxHistoryCount (+)
SetOptions (+)
SwapPlayers (+) | Swaps the items loaded in the specified players.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPitchableAudioSource)
Next (IPlayerControl)


Previous
Next (AutomationBreak)

Name
AssistNext

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Just like AutomationNext, but for assist mode: Fade out all active
players and start the next item (which must be loaded already).

Source code
procedure AssistNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutomationBreak)


Previous (AssistNext)
Next (AutomationJump)

Name
AutomationBreak

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Stops automation after the current item.

Source code
procedure AutomationBreak

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AssistNext)
Next (AutomationJump)


Previous (AutomationBreak)
Next (AutomationJumpSoft)

Name
AutomationJump

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Jumps to a specific item.

Source code
procedure AutomationJump ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item, which must be inside the current playlist.

mAirListScript
Class Tree
Index
Previous (AutomationBreak)
Next (AutomationJumpSoft)


Previous (AutomationJump)
Next (AutomationNext)

Name
AutomationJumpSoft

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Marks all items before the specified one as played, so that iItem will
be played next.

Source code
procedure AutomationJumpSoft ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (AutomationJump)
Next (AutomationNext)


Previous (AutomationJumpSoft)
Next (AutomationPlay)

Name
AutomationNext

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Makes the automation jump to the next item, or starts playback in case
playback is stopped at the momemnt. Automation must be activated.

Source code
procedure AutomationNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationJumpSoft)
Next (AutomationPlay)


Previous (AutomationNext)
Next (AutomationStop)

Name
AutomationPlay

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Starts automation playback. Automation must be activated with SetAutomation
first.

Source code
procedure AutomationPlay

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationNext)
Next (AutomationStop)


Previous (AutomationPlay)
Next (GetAutomation)

Name
AutomationStop

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Stops automation playback. The current item is faded out.

Source code
procedure AutomationStop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationPlay)
Next (GetAutomation)


Previous (AutomationStop)
Next (GetAutomationPlaying)

Name
GetAutomation

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Determines whether automation mode is active or not.

Source code
function GetAutomation : boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | true if automation is active, false otherwise.

mAirListScript
Class Tree
Index
Previous (AutomationStop)
Next (GetAutomationPlaying)


Previous (GetAutomation)
Next (GetDefaultFadeDuration)

Name
GetAutomationPlaying

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetAutomationPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutomation)
Next (GetDefaultFadeDuration)


Previous (GetAutomationPlaying)
Next (GetEventList)

Name
GetDefaultFadeDuration

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetDefaultFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutomationPlaying)
Next (GetEventList)


Previous (GetDefaultFadeDuration)
Next (GetIndex)

Name
GetEventList

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultFadeDuration)
Next (GetIndex)


Previous (GetEventList)
Next (GetMaxHistoryCount)

Name
GetIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the index of this PlaybackControl object within the mAirList system.

Source code
function GetIndex : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The index, where 0 is the first PlaybackControl object.

mAirListScript
Class Tree
Index
Previous (GetEventList)
Next (GetMaxHistoryCount)


Previous (GetIndex)
Next (GetNextIndex)

Name
GetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetMaxHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetNextIndex)


Previous (GetMaxHistoryCount)
Next (GetOptions)

Name
GetNextIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Determines the index of the item which will be played next. If one of
the players is marked as IsNext, the result of this function corresponds
to the index of that player's items. If all players are active, the result
will be the index of the "downmost" player plus one. If no players are
loaded, the result will correspond to GetPlayer.GetHistoryCount.

Source code
function GetNextIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxHistoryCount)
Next (GetOptions)


Previous (GetNextIndex)
Next (GetPlayer)

Name
GetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetOptions : TPlaybackControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextIndex)
Next (GetPlayer)


Previous (GetOptions)
Next (GetPlayerCount)

Name
GetPlayer

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns a player control object.

Source code
function GetPlayer ( iIndex : integer ) : IPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER | The number of the player to retrieve.

Return
Types | Description
IPlayerControl | The player control object.

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayerCount)


Previous (GetPlayer)
Next (GetPlayerOfItem)

Name
GetPlayerCount

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the number of players associated with this PlaybackControl object.

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The number of players.

mAirListScript
Class Tree
Index
Previous (GetPlayer)
Next (GetPlayerOfItem)


Previous (GetPlayerCount)
Next (GetRemainingDuration)

Name
GetPlayerOfItem

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the player control object in which a specific item is loaded.

Source code
function GetPlayerOfItem ( iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to look for.

Return
Types Description
INTEGER The player object in which the item is loaded,
or -1 if the item was not found.

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (GetRemainingDuration)


Previous (GetPlayerOfItem)
Next (IsPlaying)

Name
GetRemainingDuration

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetRemainingDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerOfItem)
Next (IsPlaying)


Previous (GetRemainingDuration)
Next (LoadFromXMLEx)

Name
IsPlaying

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRemainingDuration)
Next (LoadFromXMLEx)


Previous (IsPlaying)
Next (MoveToHistory)

Name
LoadFromXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure LoadFromXMLEx ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (MoveToHistory)


Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)

Name
MoveToHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Moves an item into history by unloading it from any player and setting
its history flag.

Source code
procedure MoveToHistory ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)


Previous (MoveToHistory)
Next (PlayItemDetached)

Name
PlayerAutoLoad

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Loads a player with the next available, unused item. The player must be empty.

Source code
function PlayerAutoLoad ( iPlayer : integer ; iAsync : boolean ) : boolean

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.
iAsync : BOOLEAN If set to true, the function returns immediately, and
loading takes place in the background. GetStatus will
be psLoading until loading has finished.

Return
Types Description
BOOLEAN Returns false if loading was successful, false if not.
Note that when using asynchronous loading, the player might
still fail to load (GetState=psError), even if this function
returned true.

mAirListScript
Class Tree
Index
Previous (MoveToHistory)
Next (PlayItemDetached)


Previous (PlayerAutoLoad)
Next (RecycleFromHistory)

Name
PlayItemDetached

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Start playback of an item on the given device, without caring for it thereafter.
This function can be used to play items independent from the actual players.
To create a file playlist item on the fly, use the
CreatePlaylistItemFromFile method.
The audio device can be grabbed from one of the players, for example by
CurrentPlaybackControl.GetPlayer(0).GetOutputDevice, or you can use
the BuildAudioDevice function to create one.

Source code
procedure PlayItemDetached ( iItem : IPlaylistItem ; iDevice : IAudioDevice )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to play.
iDevice : IAudioDevice | The audio device to play to.

mAirListScript
Class Tree
Index
Previous (PlayerAutoLoad)
Next (RecycleFromHistory)


Previous (PlayItemDetached)
Next (SaveAsXMLEx)

Name
RecycleFromHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Recycles an item from history.

Source code
procedure RecycleFromHistory ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (PlayItemDetached)
Next (SaveAsXMLEx)


Previous (RecycleFromHistory)
Next (SetAutomation)

Name
SaveAsXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function SaveAsXMLEx ( iDocument : IXMLDocument ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (RecycleFromHistory)
Next (SetAutomation)


Previous (SaveAsXMLEx)
Next (SetDefaultFadeDuration)

Name
SetAutomation

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Enables or disables automation mode.

Source code
procedure SetAutomation ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | true to activate, false to deactive.

mAirListScript
Class Tree
Index
Previous (SaveAsXMLEx)
Next (SetDefaultFadeDuration)


Previous (SetAutomation)
Next (SetMaxHistoryCount)

Name
SetDefaultFadeDuration

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetDefaultFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetAutomation)
Next (SetMaxHistoryCount)


Previous (SetDefaultFadeDuration)
Next (SetOptions)

Name
SetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetMaxHistoryCount ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetDefaultFadeDuration)
Next (SetOptions)


Previous (SetMaxHistoryCount)
Next (SwapPlayers)

Name
SetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaybackControlOptions )

Parameters
Parameter Description
iValue : TPlaybackControlOptions

mAirListScript
Class Tree
Index
Previous (SetMaxHistoryCount)
Next (SwapPlayers)


Previous (SetOptions)
Next

Name
SwapPlayers

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Swaps the items loaded in the specified players.
Neither player may be in state PS_PLAYING.

Source code
procedure SwapPlayers ( iPlayer1 , iPlayer2 : integer )

Parameters
Parameter | Description
iPlayer1 : INTEGER | The first player.
iPlayer2 : INTEGER | The second player.

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (IPlaybackControl)
Next (IPlaylist)

Name
IPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanOpen (+)
Close (+)
ExecutePlayerCommand (+)
FadeOut (+)
GetAutoFadeOut (+)
GetCaption (+)
GetColor (+)
GetCommandID (+)
GetDefaultFadeDuration (+)
GetEndMonDuration (+)
GetEOFWarning (+)
GetErrorMessage (+)
GetHookMode (+)
GetIndex (+)
GetIsNext (+)
GetItem (+)
GetOptions (+)
GetPFL (+)
GetPFLSource (+)
GetPlaybackControlIndex (+)
GetPlaybackStartPos (+)
GetPlaybackStartTime (+)
GetPosition (+)
GetSource (+)
GetState (+)
GetVolume (+)
IsAfterStartNext (+)
Open (+)
Pause (+)
ReleaseItem (+)
Reset (+)
SetAutoFadeOut (+)
SetCaption (+)
SetColor (+)
SetDefaultFadeDuration (+)
SetEndMonDuration (+)
SetEOFWarning (+)
SetIsNext (+)
SetOptions (+)
SetPFL (+)
SetVolume (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackControl)
Next (IPlaylist)


Previous
Next (Close)

Name
CanOpen

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure CanOpen ( iItem : IPlaylistItem ; var Accept : boolean )

Parameters
Parameter Description
iItem : IPlaylistItem
Accept : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (Close)


Previous (CanOpen)
Next (ExecutePlayerCommand)

Name
Close

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CanOpen)
Next (ExecutePlayerCommand)


Previous (Close)
Next (FadeOut)

Name
ExecutePlayerCommand

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ExecutePlayerCommand ( iCommand : TPlayerCommand )

Parameters
Parameter Description
iCommand : TPlayerCommand

mAirListScript
Class Tree
Index
Previous (Close)
Next (FadeOut)


Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)

Name
FadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)


Previous (FadeOut)
Next (GetCaption)

Name
GetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetAutoFadeOut : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetCaption)


Previous (GetAutoFadeOut)
Next (GetColor)

Name
GetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutoFadeOut)
Next (GetColor)


Previous (GetCaption)
Next (GetCommandID)

Name
GetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCommandID)


Previous (GetColor)
Next (GetDefaultFadeDuration)

Name
GetCommandID

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCommandID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetDefaultFadeDuration)


Previous (GetCommandID)
Next (GetEndMonDuration)

Name
GetDefaultFadeDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetDefaultFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandID)
Next (GetEndMonDuration)


Previous (GetDefaultFadeDuration)
Next (GetEOFWarning)

Name
GetEndMonDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetEndMonDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultFadeDuration)
Next (GetEOFWarning)


Previous (GetEndMonDuration)
Next (GetErrorMessage)

Name
GetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetEOFWarning : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndMonDuration)
Next (GetErrorMessage)


Previous (GetEOFWarning)
Next (GetHookMode)

Name
GetErrorMessage

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEOFWarning)
Next (GetHookMode)


Previous (GetErrorMessage)
Next (GetIndex)

Name
GetHookMode

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetHookMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetIndex)


Previous (GetHookMode)
Next (GetIsNext)

Name
GetIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHookMode)
Next (GetIsNext)


Previous (GetIndex)
Next (GetItem)

Name
GetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIsNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetItem)


Previous (GetIsNext)
Next (GetOptions)

Name
GetItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsNext)
Next (GetOptions)


Previous (GetItem)
Next (GetPFL)

Name
GetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetOptions : TPlayerControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetPFL)


Previous (GetOptions)
Next (GetPFLSource)

Name
GetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFL : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPFLSource)


Previous (GetPFL)
Next (GetPlaybackControlIndex)

Name
GetPFLSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFLSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFL)
Next (GetPlaybackControlIndex)


Previous (GetPFLSource)
Next (GetPlaybackStartPos)

Name
GetPlaybackControlIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPlaybackControlIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLSource)
Next (GetPlaybackStartPos)


Previous (GetPlaybackControlIndex)
Next (GetPlaybackStartTime)

Name
GetPlaybackStartPos

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPlaybackStartPos : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlIndex)
Next (GetPlaybackStartTime)


Previous (GetPlaybackStartPos)
Next (GetPosition)

Name
GetPlaybackStartTime

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPlaybackStartTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackStartPos)
Next (GetPosition)


Previous (GetPlaybackStartTime)
Next (GetSource)

Name
GetPosition

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackStartTime)
Next (GetSource)


Previous (GetPosition)
Next (GetState)

Name
GetSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetState)


Previous (GetSource)
Next (GetVolume)

Name
GetState

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetState : TPlayerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (GetVolume)


Previous (GetState)
Next (IsAfterStartNext)

Name
GetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetVolume : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (IsAfterStartNext)


Previous (GetVolume)
Next (Open)

Name
IsAfterStartNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsAfterStartNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Open)


Previous (IsAfterStartNext)
Next (Pause)

Name
Open

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Open ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (IsAfterStartNext)
Next (Pause)


Previous (Open)
Next (ReleaseItem)

Name
Pause

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (ReleaseItem)


Previous (Pause)
Next (Reset)

Name
ReleaseItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ReleaseItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (Reset)


Previous (ReleaseItem)
Next (SetAutoFadeOut)

Name
Reset

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Reset

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReleaseItem)
Next (SetAutoFadeOut)


Previous (Reset)
Next (SetCaption)

Name
SetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetAutoFadeOut ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Reset)
Next (SetCaption)


Previous (SetAutoFadeOut)
Next (SetColor)

Name
SetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetCaption ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetAutoFadeOut)
Next (SetColor)


Previous (SetCaption)
Next (SetDefaultFadeDuration)

Name
SetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter Description
iValue : TColor

mAirListScript
Class Tree
Index
Previous (SetCaption)
Next (SetDefaultFadeDuration)


Previous (SetColor)
Next (SetEndMonDuration)

Name
SetDefaultFadeDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetDefaultFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetEndMonDuration)


Previous (SetDefaultFadeDuration)
Next (SetEOFWarning)

Name
SetEndMonDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetEndMonDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetDefaultFadeDuration)
Next (SetEOFWarning)


Previous (SetEndMonDuration)
Next (SetIsNext)

Name
SetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetEOFWarning ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetEndMonDuration)
Next (SetIsNext)


Previous (SetEOFWarning)
Next (SetOptions)

Name
SetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetIsNext ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetEOFWarning)
Next (SetOptions)


Previous (SetIsNext)
Next (SetPFL)

Name
SetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlayerControlOptions )

Parameters
Parameter Description
iValue : TPlayerControlOptions

mAirListScript
Class Tree
Index
Previous (SetIsNext)
Next (SetPFL)


Previous (SetOptions)
Next (SetVolume)

Name
SetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetPFL ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetVolume)


Previous (SetPFL)
Next (Start)

Name
SetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (SetPFL)
Next (Start)


Previous (SetVolume)
Next (Stop)

Name
Start

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IPlayerControl)
Next (IPlaylistExporter)

Name
IPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
ErrorCheck (+)
GetActiveDuration (+)
GetBacktiming (+)
GetBaseTime (+)
GetDuration (+)
GetHistoryCount (+)
GetItem (+)
GetNext (+)
InsertDirectory (+)
InsertFile (+)
InsertFiles (+)
SetBaseTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlayerControl)
Next (IPlaylistExporter)


Previous
Next (GetActiveDuration)

Name
ErrorCheck

Parent
IPlaylist

Visibility
PUBLIC

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetActiveDuration)


Previous (ErrorCheck)
Next (GetBacktiming)

Name
GetActiveDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetActiveDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetBacktiming)


Previous (GetActiveDuration)
Next (GetBaseTime)

Name
GetBacktiming

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBacktiming ( iIndex : integer ; iType : TBacktimingType ) : TDateTime

Parameters
Parameter Description
iIndex : INTEGER
iType : TBacktimingType

mAirListScript
Class Tree
Index
Previous (GetActiveDuration)
Next (GetBaseTime)


Previous (GetBacktiming)
Next (GetDuration)

Name
GetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBaseTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBacktiming)
Next (GetDuration)


Previous (GetBaseTime)
Next (GetHistoryCount)

Name
GetDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBaseTime)
Next (GetHistoryCount)


Previous (GetDuration)
Next (GetItem)

Name
GetHistoryCount

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetItem)


Previous (GetHistoryCount)
Next (GetNext)

Name
GetItem

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetHistoryCount)
Next (GetNext)


Previous (GetItem)
Next (InsertDirectory)

Name
GetNext

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetNext ( iItem : IPlaylistItem ) : IPlaylistItem

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (InsertDirectory)


Previous (GetNext)
Next (InsertFile)

Name
InsertDirectory

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertDirectory ( iIndex : integer ; iDirectory : string ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iDirectory : STRING

mAirListScript
Class Tree
Index
Previous (GetNext)
Next (InsertFile)


Previous (InsertDirectory)
Next (InsertFiles)

Name
InsertFile

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFile ( iIndex : integer ; iFilename : string ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (InsertDirectory)
Next (InsertFiles)


Previous (InsertFile)
Next (SetBaseTime)

Name
InsertFiles

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFiles ( iIndex : integer ; iFiles : IStrings ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iFiles : IStrings

mAirListScript
Class Tree
Index
Previous (InsertFile)
Next (SetBaseTime)


Previous (InsertFiles)
Next

Name
SetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetBaseTime ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (InsertFiles)
Next


Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)

Name
IPlaylistExporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
SavePlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)


Previous
Next

Name
SavePlaylist

Parent
IPlaylistExporter

Visibility
PUBLIC

Source code
procedure SavePlaylist ( iPlaylist : IPlaylist ; iFilename : string )

Parameters
Parameter Description
iPlaylist : IPlaylist
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaylistExporter)
Next (IPlaylistImporter)

Name
IPlaylistFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistExporter)
Next (IPlaylistImporter)


Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)

Name
IPlaylistImporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
LoadPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)


Previous
Next

Name
LoadPlaylist

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function LoadPlaylist ( iFilename : string ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaylistImporter)
Next (IPlaylistItemPicture)

Name
IPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
AutoSearchPosition (+)
BuildSource (+)
ErrorCheck (+)
GetAmplification (+)
GetArtists (+)
GetArtistsString (+)
GetAttributes (+)
GetCapabilities (+)
GetColor (+)
GetColored (+)
GetComment (+)
GetCueData (+)
GetCuePosition (+)
GetDatabase (+)
GetDatabaseID (+)
GetDisabled (+)
GetDuration (+)
GetEffectiveDisplayDuration (+)
GetEffectiveDisplayEnd (+)
GetEffectivePlaybackDuration (+)
GetEffectivePlaybackEnd (+)
GetEndType (+)
GetFadeDuration (+)
GetFilteredXML (+)
GetHistoryFlag (+)
GetItemType (+)
GetOptions (+)
GetPersistentDatabaseID (+)
GetPicture (+)
GetPitch (+)
GetStartActions (+)
GetStartTime (+)
GetStatus (+)
GetStopActions (+)
GetSummary (+)
GetTempo (+)
GetTitle (+)
GetVolumeEnvelope (+)
GetXMLNodeName (+)
IsCueable (+)
IsPlayable (+)
SaveAsFilteredXML (+)
SetAmplification (+)
SetColor (+)
SetColored (+)
SetComment (+)
SetCuePosition (+)
SetDatabase (+)
SetDatabaseID (+)
SetDisabled (+)
SetDuration (+)
SetEndType (+)
SetFadeDuration (+)
SetHistoryFlag (+)
SetItemType (+)
SetOptions (+)
SetPersistentDatabaseID (+)
SetPitch (+)
SetStartTime (+)
SetStatus (+)
SetTempo (+)
SetTitle (+)
SetVolumeEnvelope (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistImporter)
Next (IPlaylistItemPicture)


Previous
Next (BuildSource)

Name
AutoSearchPosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure AutoSearchPosition ( iType : TCuePositionType )

Parameters
Parameter Description
iType : TCuePositionType

mAirListScript
Class Tree
Index
Previous
Next (BuildSource)


Previous (AutoSearchPosition)
Next (ErrorCheck)

Name
BuildSource

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function BuildSource ( iDevice : IAudioDevice ; iRegionDevices : IAudioDeviceList ) : IAudioSource

Parameters
Parameter Description
iDevice : IAudioDevice
iRegionDevices : IAudioDeviceList

mAirListScript
Class Tree
Index
Previous (AutoSearchPosition)
Next (ErrorCheck)


Previous (BuildSource)
Next (GetAmplification)

Name
ErrorCheck

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildSource)
Next (GetAmplification)


Previous (ErrorCheck)
Next (GetArtists)

Name
GetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetArtists)


Previous (GetAmplification)
Next (GetArtistsString)

Name
GetArtists

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetArtists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next (GetArtistsString)


Previous (GetArtists)
Next (GetAttributes)

Name
GetArtistsString

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetArtistsString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtists)
Next (GetAttributes)


Previous (GetArtistsString)
Next (GetCapabilities)

Name
GetAttributes

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAttributes : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtistsString)
Next (GetCapabilities)


Previous (GetAttributes)
Next (GetColor)

Name
GetCapabilities

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCapabilities : TPlaylistItemCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAttributes)
Next (GetColor)


Previous (GetCapabilities)
Next (GetColored)

Name
GetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetColored)


Previous (GetColor)
Next (GetComment)

Name
GetColored

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetColored : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetComment)


Previous (GetColored)
Next (GetCueData)

Name
GetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetComment : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColored)
Next (GetCueData)


Previous (GetComment)
Next (GetCuePosition)

Name
GetCueData

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCueData : ICueData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetComment)
Next (GetCuePosition)


Previous (GetCueData)
Next (GetDatabase)

Name
GetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCuePosition ( iType : TCuePositionType ) : TTimeValue

Parameters
Parameter Description
iType : TCuePositionType

mAirListScript
Class Tree
Index
Previous (GetCueData)
Next (GetDatabase)


Previous (GetCuePosition)
Next (GetDatabaseID)

Name
GetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabase : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCuePosition)
Next (GetDatabaseID)


Previous (GetDatabase)
Next (GetDisabled)

Name
GetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabase)
Next (GetDisabled)


Previous (GetDatabaseID)
Next (GetDuration)

Name
GetDisabled

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDisabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (GetDuration)


Previous (GetDisabled)
Next (GetEffectiveDisplayDuration)

Name
GetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisabled)
Next (GetEffectiveDisplayDuration)


Previous (GetDuration)
Next (GetEffectiveDisplayEnd)

Name
GetEffectiveDisplayDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetEffectiveDisplayEnd)


Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)

Name
GetEffectiveDisplayEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)


Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)

Name
GetEffectivePlaybackDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)


Previous (GetEffectivePlaybackDuration)
Next (GetEndType)

Name
GetEffectivePlaybackEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackDuration)
Next (GetEndType)


Previous (GetEffectivePlaybackEnd)
Next (GetFadeDuration)

Name
GetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEndType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackEnd)
Next (GetFadeDuration)


Previous (GetEndType)
Next (GetFilteredXML)

Name
GetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndType)
Next (GetFilteredXML)


Previous (GetFadeDuration)
Next (GetHistoryFlag)

Name
GetFilteredXML

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFilteredXML ( iFilter : TPlaylistItemDataFilter ) : string

Parameters
Parameter Description
iFilter : TPlaylistItemDataFilter

mAirListScript
Class Tree
Index
Previous (GetFadeDuration)
Next (GetHistoryFlag)


Previous (GetFilteredXML)
Next (GetItemType)

Name
GetHistoryFlag

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetHistoryFlag : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilteredXML)
Next (GetItemType)


Previous (GetHistoryFlag)
Next (GetOptions)

Name
GetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetItemType : TPlaylistItemType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHistoryFlag)
Next (GetOptions)


Previous (GetItemType)
Next (GetPersistentDatabaseID)

Name
GetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetOptions : TPlaylistItemOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemType)
Next (GetPersistentDatabaseID)


Previous (GetOptions)
Next (GetPicture)

Name
GetPersistentDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPersistentDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPicture)


Previous (GetPersistentDatabaseID)
Next (GetPitch)

Name
GetPicture

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPicture : IPlaylistItemPicture

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPersistentDatabaseID)
Next (GetPitch)


Previous (GetPicture)
Next (GetStartActions)

Name
GetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPicture)
Next (GetStartActions)


Previous (GetPitch)
Next (GetStartTime)

Name
GetStartActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStartActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (GetStartTime)


Previous (GetStartActions)
Next (GetStatus)

Name
GetStartTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStartTime ( iType : TStartTimeType ) : TDateTime

Parameters
Parameter Description
iType : TStartTimeType

mAirListScript
Class Tree
Index
Previous (GetStartActions)
Next (GetStatus)


Previous (GetStartTime)
Next (GetStopActions)

Name
GetStatus

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStatus : TPlaylistItemStatus

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (GetStopActions)


Previous (GetStatus)
Next (GetSummary)

Name
GetStopActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStopActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStatus)
Next (GetSummary)


Previous (GetStopActions)
Next (GetTempo)

Name
GetSummary

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStopActions)
Next (GetTempo)


Previous (GetSummary)
Next (GetTitle)

Name
GetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSummary)
Next (GetTitle)


Previous (GetTempo)
Next (GetVolumeEnvelope)

Name
GetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (GetVolumeEnvelope)


Previous (GetTitle)
Next (GetXMLNodeName)

Name
GetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetVolumeEnvelope : IEnvelope

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (GetXMLNodeName)


Previous (GetVolumeEnvelope)
Next (IsCueable)

Name
GetXMLNodeName

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetXMLNodeName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolumeEnvelope)
Next (IsCueable)


Previous (GetXMLNodeName)
Next (IsPlayable)

Name
IsCueable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetXMLNodeName)
Next (IsPlayable)


Previous (IsCueable)
Next (SaveAsFilteredXML)

Name
IsPlayable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsPlayable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (SaveAsFilteredXML)


Previous (IsPlayable)
Next (SetAmplification)

Name
SaveAsFilteredXML

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function SaveAsFilteredXML ( iDocument : IXMLDocument ; iFilter : TPlaylistItemDataFilter ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument
iFilter : TPlaylistItemDataFilter

mAirListScript
Class Tree
Index
Previous (IsPlayable)
Next (SetAmplification)


Previous (SaveAsFilteredXML)
Next (SetColor)

Name
SetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SaveAsFilteredXML)
Next (SetColor)


Previous (SetAmplification)
Next (SetColored)

Name
SetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter Description
iValue : TColor

mAirListScript
Class Tree
Index
Previous (SetAmplification)
Next (SetColored)


Previous (SetColor)
Next (SetComment)

Name
SetColored

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetColored ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetComment)


Previous (SetColored)
Next (SetCuePosition)

Name
SetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetComment ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetColored)
Next (SetCuePosition)


Previous (SetComment)
Next (SetDatabase)

Name
SetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCuePosition ( iType : TCuePositionType ; iValue : TTimeValue )

Parameters
Parameter Description
iType : TCuePositionType
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetComment)
Next (SetDatabase)


Previous (SetCuePosition)
Next (SetDatabaseID)

Name
SetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabase ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetCuePosition)
Next (SetDatabaseID)


Previous (SetDatabase)
Next (SetDisabled)

Name
SetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDatabase)
Next (SetDisabled)


Previous (SetDatabaseID)
Next (SetDuration)

Name
SetDisabled

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDisabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next (SetDuration)


Previous (SetDisabled)
Next (SetEndType)

Name
SetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetDisabled)
Next (SetEndType)


Previous (SetDuration)
Next (SetFadeDuration)

Name
SetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetEndType ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDuration)
Next (SetFadeDuration)


Previous (SetEndType)
Next (SetHistoryFlag)

Name
SetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetEndType)
Next (SetHistoryFlag)


Previous (SetFadeDuration)
Next (SetItemType)

Name
SetHistoryFlag

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetHistoryFlag ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetFadeDuration)
Next (SetItemType)


Previous (SetHistoryFlag)
Next (SetOptions)

Name
SetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetItemType ( iValue : TPlaylistItemType )

Parameters
Parameter Description
iValue : TPlaylistItemType

mAirListScript
Class Tree
Index
Previous (SetHistoryFlag)
Next (SetOptions)


Previous (SetItemType)
Next (SetPersistentDatabaseID)

Name
SetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaylistItemOptions )

Parameters
Parameter Description
iValue : TPlaylistItemOptions

mAirListScript
Class Tree
Index
Previous (SetItemType)
Next (SetPersistentDatabaseID)


Previous (SetOptions)
Next (SetPitch)

Name
SetPersistentDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetPersistentDatabaseID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetPitch)


Previous (SetPersistentDatabaseID)
Next (SetStartTime)

Name
SetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPersistentDatabaseID)
Next (SetStartTime)


Previous (SetPitch)
Next (SetStatus)

Name
SetStartTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetStartTime ( iType : TStartTimeType ; iValue : TDateTime )

Parameters
Parameter Description
iType : TStartTimeType
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next (SetStatus)


Previous (SetStartTime)
Next (SetTempo)

Name
SetStatus

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetStatus ( iValue : TPlaylistItemStatus )

Parameters
Parameter Description
iValue : TPlaylistItemStatus

mAirListScript
Class Tree
Index
Previous (SetStartTime)
Next (SetTempo)


Previous (SetStatus)
Next (SetTitle)

Name
SetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetStatus)
Next (SetTitle)


Previous (SetTempo)
Next (SetVolumeEnvelope)

Name
SetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTempo)
Next (SetVolumeEnvelope)


Previous (SetTitle)
Next

Name
SetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter Description
iValue : IEnvelope

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IPlaylistItem)
Next (IPlaylistStorage)

Name
IPlaylistItemPicture

Parent
mAirListInterfaces

Class Hierarchy
IXMLStorage

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
Clear (+)
Draw (+)
GetData (+)
GetExtension (+)
GetFilename (+)
IsEmpty (+)
LoadFromFile (+)
SetFilename (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItem)
Next (IPlaylistStorage)


Previous
Next (Clear)

Name
Assign

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
procedure Assign ( iPicture : IPlaylistItemPicture )

Parameters
Parameter Description
iPicture : IPlaylistItemPicture

mAirListScript
Class Tree
Index
Previous
Next (Clear)


Previous (Assign)
Next (Draw)

Name
Clear

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (Draw)


Previous (Clear)
Next (GetData)

Name
Draw

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
procedure Draw ( iCanvas : TCanvas ; iRect : TRect )

Parameters
Parameter Description
iCanvas : TCanvas
iRect : TRect

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetData)


Previous (Draw)
Next (GetExtension)

Name
GetData

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
function GetData : ImAirListStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Draw)
Next (GetExtension)


Previous (GetData)
Next (GetFilename)

Name
GetExtension

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
function GetExtension : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetFilename)


Previous (GetExtension)
Next (IsEmpty)

Name
GetFilename

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExtension)
Next (IsEmpty)


Previous (GetFilename)
Next (LoadFromFile)

Name
IsEmpty

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
function IsEmpty : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (LoadFromFile)


Previous (IsEmpty)
Next (SetFilename)

Name
LoadFromFile

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (IsEmpty)
Next (SetFilename)


Previous (LoadFromFile)
Next

Name
SetFilename

Parent
IPlaylistItemPicture

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next


Previous (IPlaylistItemPicture)
Next (IPlaylistStorageClass)

Name
IPlaylistStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItemPicture)
Next (IPlaylistStorageClass)


Previous (IPlaylistStorage)
Next (IRegionContainerPlaylistItem)

Name
IPlaylistStorageClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
GetFileFilter (+)
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistStorage)
Next (IRegionContainerPlaylistItem)


Previous
Next (SupportsExtension)

Name
GetFileFilter

Parent
IPlaylistStorageClass

Visibility
PUBLIC

Source code
function GetFileFilter : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SupportsExtension)


Previous (GetFileFilter)
Next

Name
SupportsExtension

Parent
IPlaylistStorageClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter Description
iExtension : STRING

mAirListScript
Class Tree
Index
Previous (GetFileFilter)
Next


Previous (IPlaylistStorageClass)
Next (IRemote)

Name
IRegionContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistStorageClass)
Next (IRemote)


Previous
Next

Name
GetPlaylist

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetPlaylist ( iRegion : integer ) : IPlaylist

Parameters
Parameter Description
iRegion : INTEGER

mAirListScript
Class Tree
Index
Previous
Next


Previous (IRegionContainerPlaylistItem)
Next (IRemoteController)

Name
IRemote

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetCaption (+)
GetID (+)
LoadConfig (+)
SaveConfig (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRegionContainerPlaylistItem)
Next (IRemoteController)


Previous
Next (GetID)

Name
GetCaption

Parent
IRemote

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetID)


Previous (GetCaption)
Next (LoadConfig)

Name
GetID

Parent
IRemote

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (LoadConfig)


Previous (GetID)
Next (SaveConfig)

Name
LoadConfig

Parent
IRemote

Visibility
PUBLIC

Source code
procedure LoadConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (GetID)
Next (SaveConfig)


Previous (LoadConfig)
Next (Start)

Name
SaveConfig

Parent
IRemote

Visibility
PUBLIC

Source code
procedure SaveConfig ( iSection : string )

Parameters
Parameter Description
iSection : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (Start)


Previous (SaveConfig)
Next (Stop)

Name
Start

Parent
IRemote

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IRemote

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IRemote)
Next (IRunnable)

Name
IRemoteController

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
BeginPFL (+)
EndPFL (+)
ExecuteCommand (+)
Finalize (+)
GetEnabled (+)
GetItem (+)
GetPFLCount (+)
LoadConfig (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemote)
Next (IRunnable)


Previous
Next (EndPFL)

Name
BeginPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure BeginPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndPFL)


Previous (BeginPFL)
Next (ExecuteCommand)

Name
EndPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure EndPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginPFL)
Next (ExecuteCommand)


Previous (EndPFL)
Next (Finalize)

Name
ExecuteCommand

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter Description
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (EndPFL)
Next (Finalize)


Previous (ExecuteCommand)
Next (GetEnabled)

Name
Finalize

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (GetEnabled)


Previous (Finalize)
Next (GetItem)

Name
GetEnabled

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetItem)


Previous (GetEnabled)
Next (GetPFLCount)

Name
GetItem

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetPFLCount)


Previous (GetItem)
Next (LoadConfig)

Name
GetPFLCount

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (LoadConfig)


Previous (GetPFLCount)
Next (SetEnabled)

Name
LoadConfig

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLCount)
Next (SetEnabled)


Previous (LoadConfig)
Next

Name
SetEnabled

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next


Previous (IRemoteController)
Next (ISerialPortManager)

Name
IRunnable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Run (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteController)
Next (ISerialPortManager)


Previous
Next

Name
Run

Parent
IRunnable

Visibility
PUBLIC

Source code
procedure Run

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IRunnable)
Next (ISharedMemory)

Name
ISerialPortManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
GetPortList (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRunnable)
Next (ISharedMemory)


Previous
Next (GetPortList)

Name
GetPort

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPort ( iName : string ) : IComPort

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetPortList)


Previous (GetPort)
Next

Name
GetPortList

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPortList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (ISerialPortManager)
Next (ISharedMemoryFile)

Name
ISharedMemory

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetMD5 (+)
GetPointer (+)
GetSize (+)
GetStream (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISerialPortManager)
Next (ISharedMemoryFile)


Previous
Next (GetPointer)

Name
GetMD5

Parent
ISharedMemory

Visibility
PUBLIC

Source code
function GetMD5 : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPointer)


Previous (GetMD5)
Next (GetSize)

Name
GetPointer

Parent
ISharedMemory

Visibility
PUBLIC

Source code
function GetPointer : pointer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMD5)
Next (GetSize)


Previous (GetPointer)
Next (GetStream)

Name
GetSize

Parent
ISharedMemory

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPointer)
Next (GetStream)


Previous (GetSize)
Next

Name
GetStream

Parent
ISharedMemory

Visibility
PUBLIC

Source code
function GetStream : ImAirListStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next


Previous (ISharedMemory)
Next (ISilencePlaylistItem)

Name
ISharedMemoryFile

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetFilename (+)
GetPointer (+)
GetSize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISharedMemory)
Next (ISilencePlaylistItem)


Previous
Next (GetPointer)

Name
GetFilename

Parent
ISharedMemoryFile

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPointer)


Previous (GetFilename)
Next (GetSize)

Name
GetPointer

Parent
ISharedMemoryFile

Visibility
PUBLIC

Source code
function GetPointer : pointer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (GetSize)


Previous (GetPointer)
Next

Name
GetSize

Parent
ISharedMemoryFile

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPointer)
Next


Previous (ISharedMemoryFile)
Next (ISourceControl)

Name
ISilencePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISharedMemoryFile)
Next (ISourceControl)


Previous (ISilencePlaylistItem)
Next (IStreamPlaylistItem)

Name
ISourceControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
EndMon (+)
FadeOut (+)
GetDefaultFadeDuration (+)
GetDuration (+)
GetItem (+)
GetPosition (+)
GetSource (+)
IsCueable (+)
IsPlaying (+)
Pause (+)
Play (+)
SetDefaultFadeDuration (+)
SetPosition (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISilencePlaylistItem)
Next (IStreamPlaylistItem)


Previous
Next (FadeOut)

Name
EndMon

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure EndMon ( iDuration : TTimeValue )

Parameters
Parameter Description
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous
Next (FadeOut)


Previous (EndMon)
Next (GetDefaultFadeDuration)

Name
FadeOut

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndMon)
Next (GetDefaultFadeDuration)


Previous (FadeOut)
Next (GetDuration)

Name
GetDefaultFadeDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetDefaultFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetDuration)


Previous (GetDefaultFadeDuration)
Next (GetItem)

Name
GetDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultFadeDuration)
Next (GetItem)


Previous (GetDuration)
Next (GetPosition)

Name
GetItem

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetPosition)


Previous (GetItem)
Next (GetSource)

Name
GetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSource)


Previous (GetPosition)
Next (IsCueable)

Name
GetSource

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (IsCueable)


Previous (GetSource)
Next (IsPlaying)

Name
IsCueable

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (IsPlaying)


Previous (IsCueable)
Next (Pause)

Name
IsPlaying

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (Pause)


Previous (IsPlaying)
Next (Play)

Name
Pause

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (Play)


Previous (Pause)
Next (SetDefaultFadeDuration)

Name
Play

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Play

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetDefaultFadeDuration)


Previous (Play)
Next (SetPosition)

Name
SetDefaultFadeDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetDefaultFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (Play)
Next (SetPosition)


Previous (SetDefaultFadeDuration)
Next (Stop)

Name
SetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetDefaultFadeDuration)
Next (Stop)


Previous (SetPosition)
Next

Name
Stop

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next


Previous (ISourceControl)
Next (IStrings)

Name
IStreamPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IURLPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISourceControl)
Next (IStrings)


Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)

Name
IStrings

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddObject (+)
AddStrings (+)
Assign (+)
BeginRead (+)
BeginWrite (+)
Clear (+)
Clone (+)
Delete (+)
EndRead (+)
EndWrite (+)
GetCount (+)
GetData (+)
GetItem (+)
GetName (+)
GetSorted (+)
GetText (+)
GetValue (+)
GetValueFromIndex (+)
IndexOf (+)
IndexOfName (+)
Insert (+)
SetSorted (+)
SetText (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)


Previous
Next (AddObject)

Name
ADD

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Add ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous
Next (AddObject)


Previous (ADD)
Next (AddStrings)

Name
AddObject

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddObject ( iValue : string ; iData : cardinal )

Parameters
Parameter Description
iValue : STRING
iData : CARDINAL

mAirListScript
Class Tree
Index
Previous (ADD)
Next (AddStrings)


Previous (AddObject)
Next (Assign)

Name
AddStrings

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddStrings ( iValues : IStrings )

Parameters
Parameter Description
iValues : IStrings

mAirListScript
Class Tree
Index
Previous (AddObject)
Next (Assign)


Previous (AddStrings)
Next (BeginRead)

Name
Assign

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IStrings )

Parameters
Parameter Description
iValue : IStrings

mAirListScript
Class Tree
Index
Previous (AddStrings)
Next (BeginRead)


Previous (Assign)
Next (BeginWrite)

Name
BeginRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (BeginWrite)


Previous (BeginRead)
Next (Clear)

Name
BeginWrite

Parent
IStrings

Visibility
PUBLIC

Source code
function BeginWrite : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (Clear)


Previous (BeginWrite)
Next (Clone)

Name
Clear

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginWrite)
Next (Clone)


Previous (Clear)
Next (Delete)

Name
Clone

Parent
IStrings

Visibility
PUBLIC

Source code
function Clone : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (Clone)
Next (EndRead)

Name
Delete

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Clone)
Next (EndRead)


Previous (Delete)
Next (EndWrite)

Name
EndRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Delete)
Next (EndWrite)


Previous (EndRead)
Next (GetCount)

Name
EndWrite

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndWrite

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (GetCount)


Previous (EndWrite)
Next (GetData)

Name
GetCount

Parent
IStrings

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndWrite)
Next (GetData)


Previous (GetCount)
Next (GetItem)

Name
GetData

Parent
IStrings

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : cardinal

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetItem)


Previous (GetData)
Next (GetName)

Name
GetItem

Parent
IStrings

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetName)


Previous (GetItem)
Next (GetSorted)

Name
GetName

Parent
IStrings

Visibility
PUBLIC

Source code
function GetName ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSorted)


Previous (GetName)
Next (GetText)

Name
GetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
function GetSorted : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetText)


Previous (GetSorted)
Next (GetValue)

Name
GetText

Parent
IStrings

Visibility
PUBLIC

Source code
function GetText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSorted)
Next (GetValue)


Previous (GetText)
Next (GetValueFromIndex)

Name
GetValue

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValue ( iKey : string ) : string

Parameters
Parameter Description
iKey : STRING

mAirListScript
Class Tree
Index
Previous (GetText)
Next (GetValueFromIndex)


Previous (GetValue)
Next (IndexOf)

Name
GetValueFromIndex

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValueFromIndex ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (IndexOf)


Previous (GetValueFromIndex)
Next (IndexOfName)

Name
IndexOf

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOf ( iValue : string ) : integer

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetValueFromIndex)
Next (IndexOfName)


Previous (IndexOf)
Next (Insert)

Name
IndexOfName

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOfName ( iValue : string ) : integer

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (Insert)


Previous (IndexOfName)
Next (SetSorted)

Name
Insert

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (IndexOfName)
Next (SetSorted)


Previous (Insert)
Next (SetText)

Name
SetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetSorted ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Insert)
Next (SetText)


Previous (SetSorted)
Next (SetValue)

Name
SetText

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetText ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetSorted)
Next (SetValue)


Previous (SetText)
Next

Name
SetValue

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetValue ( iKey : string ; iValue : string )

Parameters
Parameter Description
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetText)
Next


Previous (IStrings)
Next (ITrackCueDataItem)

Name
IStubPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStrings)
Next (ITrackCueDataItem)


Previous (IStubPlaylistItem)
Next (IUpdateObject)

Name
ITrackCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetArtists (+)
GetArtistsString (+)
GetTitle (+)
SetTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStubPlaylistItem)
Next (IUpdateObject)


Previous
Next (GetArtistsString)

Name
GetArtists

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetArtists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetArtistsString)


Previous (GetArtists)
Next (GetTitle)

Name
GetArtistsString

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetArtistsString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtists)
Next (GetTitle)


Previous (GetArtistsString)
Next (SetTitle)

Name
GetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtistsString)
Next (SetTitle)


Previous (GetTitle)
Next

Name
SetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next


Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)

Name
IUpdateObject

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
BeginRead (+)
BeginUpdate (+)
EndRead (+)
EndUpdate (+)
ForceUpdate (+)
GetObjectClassID (+)
GetObjectID (+)
GetUpdateState (+)
SetSharedLock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)


Previous
Next (BeginUpdate)

Name
BeginRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeginUpdate)


Previous (BeginRead)
Next (EndRead)

Name
BeginUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (EndRead)


Previous (BeginUpdate)
Next (EndUpdate)

Name
EndRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginUpdate)
Next (EndUpdate)


Previous (EndRead)
Next (ForceUpdate)

Name
EndUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (ForceUpdate)


Previous (EndUpdate)
Next (GetObjectClassID)

Name
ForceUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure ForceUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndUpdate)
Next (GetObjectClassID)


Previous (ForceUpdate)
Next (GetObjectID)

Name
GetObjectClassID

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ForceUpdate)
Next (GetObjectID)


Previous (GetObjectClassID)
Next (GetUpdateState)

Name
GetObjectID

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectID : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassID)
Next (GetUpdateState)


Previous (GetObjectID)
Next (SetSharedLock)

Name
GetUpdateState

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetUpdateState : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectID)
Next (SetSharedLock)


Previous (GetUpdateState)
Next

Name
SetSharedLock

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure SetSharedLock ( iValue : IMutex )

Parameters
Parameter Description
iValue : IMutex

mAirListScript
Class Tree
Index
Previous (GetUpdateState)
Next


Previous (IUpdateObject)
Next (IVolumeEnvelope)

Name
IURLPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetURL (+)
SetURL (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IUpdateObject)
Next (IVolumeEnvelope)


Previous
Next (SetURL)

Name
GetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetURL)


Previous (GetURL)
Next

Name
SetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
procedure SetURL ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetURL)
Next


Previous (IURLPlaylistItem)
Next (IXMLStorage)

Name
IVolumeEnvelope

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
SetVolumeEnvelope (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IURLPlaylistItem)
Next (IXMLStorage)


Previous
Next

Name
SetVolumeEnvelope

Parent
IVolumeEnvelope

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter Description
iValue : IEnvelope

mAirListScript
Class Tree
Index
Previous
Next


Previous (IVolumeEnvelope)
Next

Name
IXMLStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
LoadFromXML (+)
SaveAsXML (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IVolumeEnvelope)
Next


Previous
Next (SaveAsXML)

Name
LoadFromXML

Parent
IXMLStorage

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous
Next (SaveAsXML)


Previous (LoadFromXML)
Next

Name
SaveAsXML

Parent
IXMLStorage

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ) : IXMLNode

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next


Previous
Next (TMessageProc)

Name
IAudioSourceArray

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
IAudioSourceArray = array of IAudioSource ;

mAirListScript
Class Tree
Index
Previous
Next (TMessageProc)


Previous (IAudioSourceArray)
Next

Name
TMessageProc

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
TMessageProc = procedure ( iMessage : IBaseMessage ) of object ;

Parameters
Parameter Description
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (IAudioSourceArray)
Next


Previous (mAirListInterfaces)
Next (mAirListTypes)

Name
mAirListScript

Parent
mAirListScript

Methods
Method | Description
ComPort (+)
Config (+) | Returns an IConfiguration interface representing the configuration
CreateContainerPlaylistItem (+)
CreateEmptyPlaylist (+)
CreateFilePlaylistItem (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+) | Creates a playlist item from the given file.
CreatePlaylistItemFromXMLString (+)
CurrentDatabase (+)
CurrentPlaybackControl (+)
CurrentPlaylist (+)
Database (+)
DatabaseCount (+)
Engine (+)
ExecuteCommand (+)
ExecuteCommandRPC (+)
Factory (+) | Return a reference to the Factory object which is used to create new
FakeNow (+) | Returns the (possibly faked) time of the internal mAirList clock.
HTTPGet (+)
HTTPGetAsync (+)
HTTPPost (+)
HTTPPostAsync (+)
Instance (+)
IOPort (+)
IOWarriorRemote (+)
ISOWeek (+) | Calculates the week number according to ISO 8601.
MidiOut (+)
MidiOutGetNumDevs (+)
MidiOutListDevices (+)
Mixer (+)
MixerCount (+)
NotifyConnect (+) | Notifies the GUI that the database connection has been established.
NotifyDisconnect (+) | Notifies the GUI that the database connection has been closed.
PlaybackControl (+)
Playlist (+)
PlaylistCount (+)
Random (+)
RunScript (+)
SASRemote (+)
SelectDatabase (+)
SelectPlaylist (+)
SetApplicationTitle (+)
SetWMClientOutput (+)
ShellExecute (+)
ShellExecuteHidden (+)
SystemLog (+)
URLEncode (+) | Encode a string so that it can by safely used as a parameter inside an

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListInterfaces)
Next (mAirListTypes)


Previous
Next (Config)

Name
ComPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function ComPort ( iPort : string ) : IComPort

Parameters
Parameter Description
iPort : STRING

mAirListScript
Class Tree
Index
Previous
Next (Config)


Previous (ComPort)
Next (CreateContainerPlaylistItem)

Name
Config

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns an IConfiguration interface representing the configuration
of this mAirList instance.

Source code
function Config : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ComPort)
Next (CreateContainerPlaylistItem)


Previous (Config)
Next (CreateEmptyPlaylist)

Name
CreateContainerPlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Config)
Next (CreateEmptyPlaylist)


Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)

Name
CreateEmptyPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateEmptyPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)


Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)

Name
CreateFilePlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iLoadData : boolean ) : IFilePlaylistItem

Parameters
Parameter Description
iFilename : STRING
iLoadData : BOOLEAN

mAirListScript
Class Tree
Index
Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)


Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromFile

Parent
mAirListScript

Visibility
PUBLIC

Description
Creates a playlist item from the given file.

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iLoadData : boolean ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | The name of the file to load.
iLoadData : BOOLEAN | If set to true, file tags and/or MMD will be loaded.

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)

Name
CreatePlaylistItemFromXMLString

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter Description
iXML : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)


Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)

Name
CurrentDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentDatabase : IDatabase

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)


Previous (CurrentDatabase)
Next (CurrentPlaylist)

Name
CurrentPlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaybackControl : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentDatabase)
Next (CurrentPlaylist)


Previous (CurrentPlaybackControl)
Next (Database)

Name
CurrentPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaylist : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentPlaybackControl)
Next (Database)


Previous (CurrentPlaylist)
Next (DatabaseCount)

Name
Database

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Database ( iIndex : integer ) : IDatabase

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CurrentPlaylist)
Next (DatabaseCount)


Previous (Database)
Next (Engine)

Name
DatabaseCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function DatabaseCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Database)
Next (Engine)


Previous (DatabaseCount)
Next (ExecuteCommand)

Name
Engine

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Engine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DatabaseCount)
Next (ExecuteCommand)


Previous (Engine)
Next (ExecuteCommandRPC)

Name
ExecuteCommand

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter Description
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (Engine)
Next (ExecuteCommandRPC)


Previous (ExecuteCommand)
Next (Factory)

Name
ExecuteCommandRPC

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommandRPC ( iURL , iCommand : string )

Parameters
Parameter Description
iURL : STRING
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (Factory)


Previous (ExecuteCommandRPC)
Next (FakeNow)

Name
Factory

Parent
mAirListScript

Visibility
PUBLIC

Description
Return a reference to the Factory object which is used to create new
playlist items etc. (see IFactory).

Source code
function Factory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteCommandRPC)
Next (FakeNow)


Previous (Factory)
Next (HTTPGet)

Name
FakeNow

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns the (possibly faked) time of the internal mAirList clock.

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Factory)
Next (HTTPGet)


Previous (FakeNow)
Next (HTTPGetAsync)

Name
HTTPGet

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPGet ( iURL : string ) : string

Parameters
Parameter Description
iURL : STRING

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (HTTPGetAsync)


Previous (HTTPGet)
Next (HTTPPost)

Name
HTTPGetAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPGetAsync ( iURL : string )

Parameters
Parameter Description
iURL : STRING

mAirListScript
Class Tree
Index
Previous (HTTPGet)
Next (HTTPPost)


Previous (HTTPGetAsync)
Next (HTTPPostAsync)

Name
HTTPPost

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPPost ( iURL : string ; iData : string ) : string

Parameters
Parameter Description
iURL : STRING
iData : STRING

mAirListScript
Class Tree
Index
Previous (HTTPGetAsync)
Next (HTTPPostAsync)


Previous (HTTPPost)
Next (Instance)

Name
HTTPPostAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPPostAsync ( iURL : string ; iData : string )

Parameters
Parameter Description
iURL : STRING
iData : STRING

mAirListScript
Class Tree
Index
Previous (HTTPPost)
Next (Instance)


Previous (HTTPPostAsync)
Next (IOPort)

Name
Instance

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Instance : IInstanceData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (HTTPPostAsync)
Next (IOPort)


Previous (Instance)
Next (IOWarriorRemote)

Name
IOPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOPort ( iPort : word ) : IIOPort

Parameters
Parameter Description
iPort : WORD

mAirListScript
Class Tree
Index
Previous (Instance)
Next (IOWarriorRemote)


Previous (IOPort)
Next (ISOWeek)

Name
IOWarriorRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOWarriorRemote ( iIndex : integer ) : IIOWarriorRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (IOPort)
Next (ISOWeek)


Previous (IOWarriorRemote)
Next (MidiOut)

Name
ISOWeek

Parent
mAirListScript

Visibility
PUBLIC

Description
Calculates the week number according to ISO 8601.

Source code
function ISOWeek ( DateTime : TDateTime ) : integer

Parameters
Parameter | Description
DateTime : TDateTime | The date for which the week number shall be calculated.

mAirListScript
Class Tree
Index
Previous (IOWarriorRemote)
Next (MidiOut)


Previous (ISOWeek)
Next (MidiOutGetNumDevs)

Name
MidiOut

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOut ( iDevice : integer ; iStatus , iData1 , iData2 : byte )

Parameters
Parameter Description
iDevice : INTEGER
iStatus : BYTE
iData1 : BYTE
iData2 : BYTE

mAirListScript
Class Tree
Index
Previous (ISOWeek)
Next (MidiOutGetNumDevs)


Previous (MidiOut)
Next (MidiOutListDevices)

Name
MidiOutGetNumDevs

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MidiOutGetNumDevs : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOut)
Next (MidiOutListDevices)


Previous (MidiOutGetNumDevs)
Next (Mixer)

Name
MidiOutListDevices

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOutListDevices

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOutGetNumDevs)
Next (Mixer)


Previous (MidiOutListDevices)
Next (MixerCount)

Name
Mixer

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Mixer ( iIndex : integer ) : IMixer

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (MidiOutListDevices)
Next (MixerCount)


Previous (Mixer)
Next (NotifyConnect)

Name
MixerCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MixerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Mixer)
Next (NotifyConnect)


Previous (MixerCount)
Next (NotifyDisconnect)

Name
NotifyConnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been established.
Only available in database scripts.

Source code
procedure NotifyConnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MixerCount)
Next (NotifyDisconnect)


Previous (NotifyConnect)
Next (PlaybackControl)

Name
NotifyDisconnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been closed.
Only available in database scripts.

Source code
procedure NotifyDisconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NotifyConnect)
Next (PlaybackControl)


Previous (NotifyDisconnect)
Next (Playlist)

Name
PlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (NotifyDisconnect)
Next (Playlist)


Previous (PlaybackControl)
Next (PlaylistCount)

Name
Playlist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Playlist ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (PlaybackControl)
Next (PlaylistCount)


Previous (Playlist)
Next (Random)

Name
PlaylistCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaylistCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Playlist)
Next (Random)


Previous (PlaylistCount)
Next (RunScript)

Name
Random

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Random ( iRange : integer ) : integer

Parameters
Parameter Description
iRange : INTEGER

mAirListScript
Class Tree
Index
Previous (PlaylistCount)
Next (RunScript)


Previous (Random)
Next (SASRemote)

Name
RunScript

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure RunScript ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Random)
Next (SASRemote)


Previous (RunScript)
Next (SelectDatabase)

Name
SASRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SASRemote ( iIndex : integer ) : ISASRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (RunScript)
Next (SelectDatabase)


Previous (SASRemote)
Next (SelectPlaylist)

Name
SelectDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectDatabase ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (SASRemote)
Next (SelectPlaylist)


Previous (SelectDatabase)
Next (SetApplicationTitle)

Name
SelectPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectPlaylist ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (SelectDatabase)
Next (SetApplicationTitle)


Previous (SelectPlaylist)
Next (SetWMClientOutput)

Name
SetApplicationTitle

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetApplicationTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SelectPlaylist)
Next (SetWMClientOutput)


Previous (SetApplicationTitle)
Next (ShellExecute)

Name
SetWMClientOutput

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetWMClientOutput ( iIndex , iNumber , iValue : integer )

Parameters
Parameter Description
iIndex : INTEGER
iNumber : INTEGER
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetApplicationTitle)
Next (ShellExecute)


Previous (SetWMClientOutput)
Next (ShellExecuteHidden)

Name
ShellExecute

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecute ( iProgram , iParameters : string )

Parameters
Parameter Description
iProgram : STRING
iParameters : STRING

mAirListScript
Class Tree
Index
Previous (SetWMClientOutput)
Next (ShellExecuteHidden)


Previous (ShellExecute)
Next (SystemLog)

Name
ShellExecuteHidden

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecuteHidden ( iProgram , iParameters : string )

Parameters
Parameter Description
iProgram : STRING
iParameters : STRING

mAirListScript
Class Tree
Index
Previous (ShellExecute)
Next (SystemLog)


Previous (ShellExecuteHidden)
Next (URLEncode)

Name
SystemLog

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SystemLog ( iMessage : string )

Parameters
Parameter Description
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (ShellExecuteHidden)
Next (URLEncode)


Previous (SystemLog)
Next

Name
URLEncode

Parent
mAirListScript

Visibility
PUBLIC

Description
Encode a string so that it can by safely used as a parameter inside an
HTTP request URL.

Source code
function URLEncode ( iString : string ) : string

Parameters
Parameter | Description
iString : STRING | The string to encode.

mAirListScript
Class Tree
Index
Previous (SystemLog)
Next


Previous (mAirListScript)
Next (MidiInterface)

Name
mAirListTypes

Parent
mAirListScript

Types
Type Description
TAudioSourceOption (+)
TAudioSourceOptions (+)
TBacktimingType (+)
TCartwallControlOption (+)
TCartwallControlOptions (+)
TCuePositionCategory (+)
TCuePositionChangedDetail (+)
TCuePositionChangedDetails (+)
TCuePositionType (+)
TCuePositionTypes (+)
TDatabaseCapabilities (+)
TDatabaseCapability (+)
TDatabaseState (+)
TDatabaseTreeNodeType (+)
TDatabaseTreeNodeTypes (+)
TEngineOption (+)
TEngineOptions (+)
TFileImportOption (+)
TFileImportOptions (+)
TFileImportTask (+)
TFileImportTasks (+)
TFileManagementOption (+)
TFileManagementOptions (+)
TFileTypeHandlerCapabilities (+)
TFileTypeHandlerCapability (+)
TGlobalOption (+)
TGlobalOptions (+)
TLogCategories (+)
TLogCategory (+)
TmAirListFeature (+)
TmAirListFeatures (+)
TMessageHandle (+)
TObjectID (+)
TPlaybackControlOption (+)
TPlaybackControlOptions (+)
TPlayerCommand (+)
TPlayerControlOption (+)
TPlayerControlOptions (+)
TPlayerState (+)
TPlayerStates (+)
TPlayerType (+)
TPlaylistItemCapabilities (+)
TPlaylistItemCapability (+)
TPlaylistItemCategory (+)
TPlaylistItemData (+)
TPlaylistItemDataFilter (+)
TPlaylistItemOption (+)
TPlaylistItemOptions (+)
TPlaylistItemStatus (+)
TPlaylistItemStatusFlags (+)
TPlaylistItemType (+)
TRepositoryItem (+)
TSetOfByte (+)
TSourceControlOption (+)
TSourceControlOptions (+)
TSourceControlState (+)
TStandardActionList (+)
TStartTimeType (+)
TTimeValue (+)

Constants
Constant Description
AllFileImportTasks (+)
AllLogCategories (+)
AllPlaylistItemChangedDetails (+)
CartPlayerCommands (+)
ccBASS (+)
ccCustom (+)
ccDatabase (+)
ccDefaultDirectories (+)
ccDemoLicense (+)
ccDevices (+)
ccEncoder (+)
ccGUI (+)
ccLayout (+)
ccLicense (+)
ccLogging (+)
ccMain (+)
ccMixdown (+)
ccPasswords (+)
ccPosition (+)
ccRemote (+)
ccScreenObjects (+)
ccSerial (+)
ccSkin (+)
cdPCAllowAutomation (+)
cdPCAutomation (+)
cdPCAutomationPlaying (+)
cdPCBacktiming (+)
cdPCOptions (+)
cdPCPlayerAssignment (+)
cdPCPlayers (+)
cdPIBacktimingStatus (+)
cdPIColor (+)
cdPIComment (+)
cdPIContent (+)
cdPICueData (+)
cdPIDuration (+)
cdPIHistoryFlag (+)
cdPIItemData (+)
cdPILinked (+)
cdPIPitch (+)
cdPIPositionAlternatives (+)
cdPIPositionValue (+)
cdPIStartTimes (+)
cdPIStatus (+)
cdPITempo (+)
cdPIUnknown (+)
ConfigTimePlaybackControlOptions (+)
DefaultCartPlayerControlOptions (+)
DefaultCartwallControlOptions (+)
DefaultEngineOptions (+)
DefaultFeatures (+)
DefaultFileImportOptions (+)
DefaultFileManagementOptions (+)
DefaultGlobalOptions (+)
DefaultPlaybackControlOptions (+)
DefaultPlayerControlOptions (+)
MIN_DB (+)
ntArtistRoot (+)
ntAttribute (+)
ntAttributeRoot (+)
ntAttributeValue (+)
ntCustom (+)
ntFolder (+)
ntFolderRoot (+)
ntItem (+)
ntPlaylist (+)
ntPlaylistRoot (+)
ntRoot (+)
ntText (+)
ntType (+)
ntTypeRoot (+)
OrdinaryPlayerCommands (+)
RuntimeCartPlayerControlOptions (+)
RuntimeOrdinaryPlayerControlOptions (+)

Classes
Class Description
ELicenseError (+)
EMessage (+)
TDatabaseNodeData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next (MidiInterface)


Previous
Next (EMessage)

Name
ELicenseError

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (EMessage)


Previous (ELicenseError)
Next (TDatabaseNodeData)

Name
EMessage

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ELicenseError)
Next (TDatabaseNodeData)


Previous (EMessage)
Next

Name
TDatabaseNodeData

Parent
mAirListTypes

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Caption (*)
Data (*)
Database (*)
Duration (*)
ExpectChildren (*)
NodeType (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EMessage)
Next


Previous
Next (Data)

Name
Caption

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Caption : string

mAirListScript
Class Tree
Index
Previous
Next (Data)


Previous (Caption)
Next (Database)

Name
Data

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Data : string

mAirListScript
Class Tree
Index
Previous (Caption)
Next (Database)


Previous (Data)
Next (Duration)

Name
Database

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Database : cardinal

mAirListScript
Class Tree
Index
Previous (Data)
Next (Duration)


Previous (Database)
Next (ExpectChildren)

Name
Duration

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Duration : TTimeValue

mAirListScript
Class Tree
Index
Previous (Database)
Next (ExpectChildren)


Previous (Duration)
Next (NodeType)

Name
ExpectChildren

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
ExpectChildren : boolean

mAirListScript
Class Tree
Index
Previous (Duration)
Next (NodeType)


Previous (ExpectChildren)
Next

Name
NodeType

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
NodeType : TDatabaseTreeNodeType

mAirListScript
Class Tree
Index
Previous (ExpectChildren)
Next


Previous
Next (TAudioSourceOptions)

Name
TAudioSourceOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOption = ( asoLogging , asoWorkActionLists ) ;

mAirListScript
Class Tree
Index
Previous
Next (TAudioSourceOptions)


Previous (TAudioSourceOption)
Next (TBacktimingType)

Name
TAudioSourceOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOptions = set of TAudioSourceOption ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOption)
Next (TBacktimingType)


Previous (TAudioSourceOptions)
Next (TCartwallControlOption)

Name
TBacktimingType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TBacktimingType = ( btEstimated , btReal , btSinceLastBreak , btEffectiveFixed ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOptions)
Next (TCartwallControlOption)


Previous (TBacktimingType)
Next (TCartwallControlOptions)

Name
TCartwallControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallControlOption = ( cwcoSaveWithDesktop , cwcoSaveWithTemplate , cwcoKeepOpen , cwcoLogging , cwcoIndependentPFL , cwcoIndependentPFLEndMon , cwcoAutoPFLOff , cwcoAutoFadeOut , cwcoResetLoop , cwcoResetHook ) ;

mAirListScript
Class Tree
Index
Previous (TBacktimingType)
Next (TCartwallControlOptions)


Previous (TCartwallControlOption)
Next (TCuePositionCategory)

Name
TCartwallControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallControlOptions = set of TCartwallControlOption ;

mAirListScript
Class Tree
Index
Previous (TCartwallControlOption)
Next (TCuePositionCategory)


Previous (TCartwallControlOptions)
Next (TCuePositionChangedDetail)

Name
TCuePositionCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionCategory = ( cpcCueIn , cpcRamp , cpcHook , cpcOutro , cpcStartNext , cpcFadeOut , cpcCueOut , cpcMisc ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallControlOptions)
Next (TCuePositionChangedDetail)


Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)

Name
TCuePositionChangedDetail

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetail = ( cdCPValue , cdCPAlternatives ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)


Previous (TCuePositionChangedDetail)
Next (TCuePositionType)

Name
TCuePositionChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetails = set of TCuePositionChangedDetail ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetail)
Next (TCuePositionType)


Previous (TCuePositionChangedDetails)
Next (TCuePositionTypes)

Name
TCuePositionType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionType = ( ptCueIn , ptRamp1 , ptRamp2 , ptRamp3 , ptHookIn , ptHookFade , ptHookOut , ptOutro , ptStartNext , ptFadeOut , ptCueOut , ptAnchor ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetails)
Next (TCuePositionTypes)


Previous (TCuePositionType)
Next (TDatabaseCapabilities)

Name
TCuePositionTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionTypes = set of TCuePositionType ;

mAirListScript
Class Tree
Index
Previous (TCuePositionType)
Next (TDatabaseCapabilities)


Previous (TCuePositionTypes)
Next (TDatabaseCapability)

Name
TDatabaseCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapabilities = set of TDatabaseCapability ;

mAirListScript
Class Tree
Index
Previous (TCuePositionTypes)
Next (TDatabaseCapability)


Previous (TDatabaseCapabilities)
Next (TDatabaseState)

Name
TDatabaseCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapability = ( dcUpdateItem , dcReverseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapabilities)
Next (TDatabaseState)


Previous (TDatabaseCapability)
Next (TDatabaseTreeNodeType)

Name
TDatabaseState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseState = ( dsDisconnected , dsConnecting , dsConnected ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapability)
Next (TDatabaseTreeNodeType)


Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)

Name
TDatabaseTreeNodeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeType = byte ;

mAirListScript
Class Tree
Index
Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)


Previous (TDatabaseTreeNodeType)
Next (TEngineOption)

Name
TDatabaseTreeNodeTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeTypes = set of TDatabaseTreeNodeType ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeType)
Next (TEngineOption)


Previous (TDatabaseTreeNodeTypes)
Next (TEngineOptions)

Name
TEngineOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOption = ( eoDummy ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeTypes)
Next (TEngineOptions)


Previous (TEngineOption)
Next (TFileImportOption)

Name
TEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOptions = set of TEngineOption ;

mAirListScript
Class Tree
Index
Previous (TEngineOption)
Next (TFileImportOption)


Previous (TEngineOptions)
Next (TFileImportOptions)

Name
TFileImportOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOption = ( fioImportComment , fioImportTags , fioMP2OutroAsFadeOut , fioTildeAsStartNext , fioTildeAsOutro , fioTildeAsFadeOut , fioStripWhitespace ) ;

mAirListScript
Class Tree
Index
Previous (TEngineOptions)
Next (TFileImportOptions)


Previous (TFileImportOption)
Next (TFileImportTask)

Name
TFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOptions = set of TFileImportOption ;

mAirListScript
Class Tree
Index
Previous (TFileImportOption)
Next (TFileImportTask)


Previous (TFileImportOptions)
Next (TFileImportTasks)

Name
TFileImportTask

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTask = ( fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitDatabaseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportOptions)
Next (TFileImportTasks)


Previous (TFileImportTask)
Next (TFileManagementOption)

Name
TFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTasks = set of TFileImportTask ;

mAirListScript
Class Tree
Index
Previous (TFileImportTask)
Next (TFileManagementOption)


Previous (TFileImportTasks)
Next (TFileManagementOptions)

Name
TFileManagementOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOption = ( fmoCacheNetworkFiles ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportTasks)
Next (TFileManagementOptions)


Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)

Name
TFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOptions = set of TFileManagementOption ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)


Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)

Name
TFileTypeHandlerCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapabilities = set of TFileTypeHandlerCapability ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)


Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)

Name
TFileTypeHandlerCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapability = ( fthcReadDuration , fthcReadTags , fthcWriteTags , fthcReadNativeTags , fthcGetTagData ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)


Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)

Name
TGlobalOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOption = ( goStartNextEffectiveEnd , goFadeOutEffectiveEnd , goFadeOutToCueOut , goOnlyOneInstance , goStartOnAir , goNoLoggingOffAir , goSplashScreen ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)


Previous (TGlobalOption)
Next (TLogCategories)

Name
TGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOptions = set of TGlobalOption ;

mAirListScript
Class Tree
Index
Previous (TGlobalOption)
Next (TLogCategories)


Previous (TGlobalOptions)
Next (TLogCategory)

Name
TLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategories = set of TLogCategory ;

mAirListScript
Class Tree
Index
Previous (TGlobalOptions)
Next (TLogCategory)


Previous (TLogCategories)
Next (TmAirListFeature)

Name
TLogCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategory = ( lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategories)
Next (TmAirListFeature)


Previous (TLogCategory)
Next (TmAirListFeatures)

Name
TmAirListFeature

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeature = ( mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfDirectoryContextMenu , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategory)
Next (TmAirListFeatures)


Previous (TmAirListFeature)
Next (TMessageHandle)

Name
TmAirListFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeatures = set of TmAirListFeature ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeature)
Next (TMessageHandle)


Previous (TmAirListFeatures)
Next (TObjectID)

Name
TMessageHandle

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TMessageHandle = cardinal ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeatures)
Next (TObjectID)


Previous (TMessageHandle)
Next (TPlaybackControlOption)

Name
TObjectID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TObjectID = int64 ;

mAirListScript
Class Tree
Index
Previous (TMessageHandle)
Next (TPlaybackControlOption)


Previous (TObjectID)
Next (TPlaybackControlOptions)

Name
TPlaybackControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOption = ( plcoAllowAutomation , plcoAutomationSinglePlayer , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoCleanUpNonPlayables , plcoSaveEvents , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime , plcoLiveBacktiming ) ;

mAirListScript
Class Tree
Index
Previous (TObjectID)
Next (TPlaybackControlOptions)


Previous (TPlaybackControlOption)
Next (TPlayerCommand)

Name
TPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOptions = set of TPlaybackControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOption)
Next (TPlayerCommand)


Previous (TPlaybackControlOptions)
Next (TPlayerControlOption)

Name
TPlayerCommand

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerCommand = ( pcNone , pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose , pcNext , pcPrevious ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOptions)
Next (TPlayerControlOption)


Previous (TPlayerCommand)
Next (TPlayerControlOptions)

Name
TPlayerControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOption = ( poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoLoadSpecial , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerCommand)
Next (TPlayerControlOptions)


Previous (TPlayerControlOption)
Next (TPlayerState)

Name
TPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOptions = set of TPlayerControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOption)
Next (TPlayerState)


Previous (TPlayerControlOptions)
Next (TPlayerStates)

Name
TPlayerState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerState = ( psEmpty , psLoading , psLoaded , psPlaying , psFading , psEOF , psError , psPaused , psStopped , psPFL , psFlashEOF , psNext ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOptions)
Next (TPlayerStates)


Previous (TPlayerState)
Next (TPlayerType)

Name
TPlayerStates

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerStates = set of TPlayerState ;

mAirListScript
Class Tree
Index
Previous (TPlayerState)
Next (TPlayerType)


Previous (TPlayerStates)
Next (TPlaylistItemCapabilities)

Name
TPlayerType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerType = ( ptOrdinaryPlayer , ptCartPlayer , ptPFLPlayer , ptErrorCheck ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerStates)
Next (TPlaylistItemCapabilities)


Previous (TPlayerType)
Next (TPlaylistItemCapability)

Name
TPlaylistItemCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapabilities = set of TPlaylistItemCapability ;

mAirListScript
Class Tree
Index
Previous (TPlayerType)
Next (TPlaylistItemCapability)


Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)

Name
TPlaylistItemCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapability = ( picPlayable , picCueable , picEditDuration , picAutoCue ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)


Previous (TPlaylistItemCapability)
Next (TPlaylistItemData)

Name
TPlaylistItemCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCategory = ( picFile , picStream , picBreak , picCommand , picContainer , picDummy , picOther ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapability)
Next (TPlaylistItemData)


Previous (TPlaylistItemCategory)
Next (TPlaylistItemDataFilter)

Name
TPlaylistItemData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemData = ( pidArtist , pidTitle , pidDuration , pidItemType , pidFilename , pidAttributes , pidInlineData , pidDatabaseLink , pidComment , pidCueData ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCategory)
Next (TPlaylistItemDataFilter)


Previous (TPlaylistItemData)
Next (TPlaylistItemOption)

Name
TPlaylistItemDataFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemDataFilter = set of TPlaylistItemData ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemData)
Next (TPlaylistItemOption)


Previous (TPlaylistItemDataFilter)
Next (TPlaylistItemOptions)

Name
TPlaylistItemOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOption = ( pioSpecialItem , pioNoBacktiming , pioNoLogging , pioSoftFixedTime , pioSkipInAutomation , pioFadeOutAll , pioAdjustTime , pioFadeOnStop , pioLinked , pioDontMoveToHistory ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemDataFilter)
Next (TPlaylistItemOptions)


Previous (TPlaylistItemOption)
Next (TPlaylistItemStatus)

Name
TPlaylistItemOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOptions = set of TPlaylistItemOption ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOption)
Next (TPlaylistItemStatus)


Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlags)

Name
TPlaylistItemStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatus = set of TPlaylistItemStatusFlags ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlags)


Previous (TPlaylistItemStatus)
Next (TPlaylistItemType)

Name
TPlaylistItemStatusFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatusFlags = ( pisInLinkChain ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatus)
Next (TPlaylistItemType)


Previous (TPlaylistItemStatusFlags)
Next (TRepositoryItem)

Name
TPlaylistItemType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemType = ( pitUnknown , pitMusic , pitVoice , pitNews , pitAdvertising , pitPackage , pitJingle , pitSound , pitEffect , pitTrailer , pitPromo , pitSponsorhip , pitSweeper , pitDrop , pitStationID , pitBed , pitInstrumental , pitShow , pitOther , pitCustom1 , pitCustom2 , pitCustom3 , pitCustom4 ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatusFlags)
Next (TRepositoryItem)


Previous (TPlaylistItemType)
Next (TSetOfByte)

Name
TRepositoryItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRepositoryItem = ( riHookOpener , riHookSweeper , riHookCloser ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemType)
Next (TSetOfByte)


Previous (TRepositoryItem)
Next (TSourceControlOption)

Name
TSetOfByte

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSetOfByte = set of byte ;

mAirListScript
Class Tree
Index
Previous (TRepositoryItem)
Next (TSourceControlOption)


Previous (TSetOfByte)
Next (TSourceControlOptions)

Name
TSourceControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOption = ( scoHookMode , scoLoop ) ;

mAirListScript
Class Tree
Index
Previous (TSetOfByte)
Next (TSourceControlOptions)


Previous (TSourceControlOption)
Next (TSourceControlState)

Name
TSourceControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOptions = set of TSourceControlOption ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOption)
Next (TSourceControlState)


Previous (TSourceControlOptions)
Next (TStandardActionList)

Name
TSourceControlState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlState = ( scsStopped , scsPlaying , scsPaused , scsFading , scsEOF ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOptions)
Next (TStandardActionList)


Previous (TSourceControlState)
Next (TStartTimeType)

Name
TStandardActionList

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStandardActionList = ( salMenu , salStartup , salShutdown ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlState)
Next (TStartTimeType)


Previous (TStandardActionList)
Next (TTimeValue)

Name
TStartTimeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStartTimeType = ( sttFixed , sttPlanned , sttReal ) ;

mAirListScript
Class Tree
Index
Previous (TStandardActionList)
Next (TTimeValue)


Previous (TStartTimeType)
Next

Name
TTimeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTimeValue = int64 ;

mAirListScript
Class Tree
Index
Previous (TStartTimeType)
Next


Previous
Next (AllLogCategories)

Name
AllFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllFileImportTasks = [ fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitDatabaseLookup ]

mAirListScript
Class Tree
Index
Previous
Next (AllLogCategories)


Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)

Name
AllLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllLogCategories = [ lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ]

mAirListScript
Class Tree
Index
Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)


Previous (AllLogCategories)
Next (CartPlayerCommands)

Name
AllPlaylistItemChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllPlaylistItemChangedDetails = $FFFFFFFF

mAirListScript
Class Tree
Index
Previous (AllLogCategories)
Next (CartPlayerCommands)


Previous (AllPlaylistItemChangedDetails)
Next (ccBASS)

Name
CartPlayerCommands

Parent
mAirListTypes

Visibility
PUBLIC

Source code
CartPlayerCommands = [ pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose , pcNext , pcPrevious ]

mAirListScript
Class Tree
Index
Previous (AllPlaylistItemChangedDetails)
Next (ccBASS)


Previous (CartPlayerCommands)
Next (ccCustom)

Name
ccBASS

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccBASS = 'bass'

mAirListScript
Class Tree
Index
Previous (CartPlayerCommands)
Next (ccCustom)


Previous (ccBASS)
Next (ccDatabase)

Name
ccCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccCustom = 'custom'

mAirListScript
Class Tree
Index
Previous (ccBASS)
Next (ccDatabase)


Previous (ccCustom)
Next (ccDefaultDirectories)

Name
ccDatabase

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDatabase = 'database'

mAirListScript
Class Tree
Index
Previous (ccCustom)
Next (ccDefaultDirectories)


Previous (ccDatabase)
Next (ccDemoLicense)

Name
ccDefaultDirectories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDefaultDirectories = 'defaultdirectories'

mAirListScript
Class Tree
Index
Previous (ccDatabase)
Next (ccDemoLicense)


Previous (ccDefaultDirectories)
Next (ccDevices)

Name
ccDemoLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDemoLicense = 'demolicense'

mAirListScript
Class Tree
Index
Previous (ccDefaultDirectories)
Next (ccDevices)


Previous (ccDemoLicense)
Next (ccEncoder)

Name
ccDevices

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDevices = 'devices'

mAirListScript
Class Tree
Index
Previous (ccDemoLicense)
Next (ccEncoder)


Previous (ccDevices)
Next (ccGUI)

Name
ccEncoder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccEncoder = 'encoder'

mAirListScript
Class Tree
Index
Previous (ccDevices)
Next (ccGUI)


Previous (ccEncoder)
Next (ccLayout)

Name
ccGUI

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccGUI = 'gui'

mAirListScript
Class Tree
Index
Previous (ccEncoder)
Next (ccLayout)


Previous (ccGUI)
Next (ccLicense)

Name
ccLayout

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLayout = 'layout'

mAirListScript
Class Tree
Index
Previous (ccGUI)
Next (ccLicense)


Previous (ccLayout)
Next (ccLogging)

Name
ccLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLicense = 'license'

mAirListScript
Class Tree
Index
Previous (ccLayout)
Next (ccLogging)


Previous (ccLicense)
Next (ccMain)

Name
ccLogging

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLogging = 'logging'

mAirListScript
Class Tree
Index
Previous (ccLicense)
Next (ccMain)


Previous (ccLogging)
Next (ccMixdown)

Name
ccMain

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMain = 'mAirList'

mAirListScript
Class Tree
Index
Previous (ccLogging)
Next (ccMixdown)


Previous (ccMain)
Next (ccPasswords)

Name
ccMixdown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMixdown = 'mixdown'

mAirListScript
Class Tree
Index
Previous (ccMain)
Next (ccPasswords)


Previous (ccMixdown)
Next (ccPosition)

Name
ccPasswords

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPasswords = 'passwords'

mAirListScript
Class Tree
Index
Previous (ccMixdown)
Next (ccPosition)


Previous (ccPasswords)
Next (ccRemote)

Name
ccPosition

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPosition = 'position'

mAirListScript
Class Tree
Index
Previous (ccPasswords)
Next (ccRemote)


Previous (ccPosition)
Next (ccScreenObjects)

Name
ccRemote

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccRemote = 'remote'

mAirListScript
Class Tree
Index
Previous (ccPosition)
Next (ccScreenObjects)


Previous (ccRemote)
Next (ccSerial)

Name
ccScreenObjects

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccScreenObjects = 'screenobjects'

mAirListScript
Class Tree
Index
Previous (ccRemote)
Next (ccSerial)


Previous (ccScreenObjects)
Next (ccSkin)

Name
ccSerial

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccSerial = 'serial'

mAirListScript
Class Tree
Index
Previous (ccScreenObjects)
Next (ccSkin)


Previous (ccSerial)
Next (cdPCAllowAutomation)

Name
ccSkin

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccSkin = 'skin'

mAirListScript
Class Tree
Index
Previous (ccSerial)
Next (cdPCAllowAutomation)


Previous (ccSkin)
Next (cdPCAutomation)

Name
cdPCAllowAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAllowAutomation = 4

mAirListScript
Class Tree
Index
Previous (ccSkin)
Next (cdPCAutomation)


Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)

Name
cdPCAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomation = 1

mAirListScript
Class Tree
Index
Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)


Previous (cdPCAutomation)
Next (cdPCBacktiming)

Name
cdPCAutomationPlaying

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomationPlaying = 2

mAirListScript
Class Tree
Index
Previous (cdPCAutomation)
Next (cdPCBacktiming)


Previous (cdPCAutomationPlaying)
Next (cdPCOptions)

Name
cdPCBacktiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCBacktiming = 8

mAirListScript
Class Tree
Index
Previous (cdPCAutomationPlaying)
Next (cdPCOptions)


Previous (cdPCBacktiming)
Next (cdPCPlayerAssignment)

Name
cdPCOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCOptions = 64

mAirListScript
Class Tree
Index
Previous (cdPCBacktiming)
Next (cdPCPlayerAssignment)


Previous (cdPCOptions)
Next (cdPCPlayers)

Name
cdPCPlayerAssignment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayerAssignment = 16

mAirListScript
Class Tree
Index
Previous (cdPCOptions)
Next (cdPCPlayers)


Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)

Name
cdPCPlayers

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayers = 32

mAirListScript
Class Tree
Index
Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)


Previous (cdPCPlayers)
Next (cdPIColor)

Name
cdPIBacktimingStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIBacktimingStatus = 64

mAirListScript
Class Tree
Index
Previous (cdPCPlayers)
Next (cdPIColor)


Previous (cdPIBacktimingStatus)
Next (cdPIComment)

Name
cdPIColor

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIColor = 4096

mAirListScript
Class Tree
Index
Previous (cdPIBacktimingStatus)
Next (cdPIComment)


Previous (cdPIColor)
Next (cdPIContent)

Name
cdPIComment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIComment = 1024

mAirListScript
Class Tree
Index
Previous (cdPIColor)
Next (cdPIContent)


Previous (cdPIComment)
Next (cdPICueData)

Name
cdPIContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIContent = 16384

mAirListScript
Class Tree
Index
Previous (cdPIComment)
Next (cdPICueData)


Previous (cdPIContent)
Next (cdPIDuration)

Name
cdPICueData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPICueData = 32768

mAirListScript
Class Tree
Index
Previous (cdPIContent)
Next (cdPIDuration)


Previous (cdPICueData)
Next (cdPIHistoryFlag)

Name
cdPIDuration

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIDuration = 1

mAirListScript
Class Tree
Index
Previous (cdPICueData)
Next (cdPIHistoryFlag)


Previous (cdPIDuration)
Next (cdPIItemData)

Name
cdPIHistoryFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIHistoryFlag = 2048

mAirListScript
Class Tree
Index
Previous (cdPIDuration)
Next (cdPIItemData)


Previous (cdPIHistoryFlag)
Next (cdPILinked)

Name
cdPIItemData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIItemData = 8

mAirListScript
Class Tree
Index
Previous (cdPIHistoryFlag)
Next (cdPILinked)


Previous (cdPIItemData)
Next (cdPIPitch)

Name
cdPILinked

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPILinked = 512

mAirListScript
Class Tree
Index
Previous (cdPIItemData)
Next (cdPIPitch)


Previous (cdPILinked)
Next (cdPIPositionAlternatives)

Name
cdPIPitch

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPitch = 256

mAirListScript
Class Tree
Index
Previous (cdPILinked)
Next (cdPIPositionAlternatives)


Previous (cdPIPitch)
Next (cdPIPositionValue)

Name
cdPIPositionAlternatives

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionAlternatives = 4

mAirListScript
Class Tree
Index
Previous (cdPIPitch)
Next (cdPIPositionValue)


Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)

Name
cdPIPositionValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionValue = 2

mAirListScript
Class Tree
Index
Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)


Previous (cdPIPositionValue)
Next (cdPIStatus)

Name
cdPIStartTimes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIStartTimes = 16

mAirListScript
Class Tree
Index
Previous (cdPIPositionValue)
Next (cdPIStatus)


Previous (cdPIStartTimes)
Next (cdPITempo)

Name
cdPIStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIStatus = 8192

mAirListScript
Class Tree
Index
Previous (cdPIStartTimes)
Next (cdPITempo)


Previous (cdPIStatus)
Next (cdPIUnknown)

Name
cdPITempo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPITempo = 128

mAirListScript
Class Tree
Index
Previous (cdPIStatus)
Next (cdPIUnknown)


Previous (cdPITempo)
Next (ConfigTimePlaybackControlOptions)

Name
cdPIUnknown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIUnknown = 32

mAirListScript
Class Tree
Index
Previous (cdPITempo)
Next (ConfigTimePlaybackControlOptions)


Previous (cdPIUnknown)
Next (DefaultCartPlayerControlOptions)

Name
ConfigTimePlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ConfigTimePlaybackControlOptions = [ plcoAllowAutomation ]

mAirListScript
Class Tree
Index
Previous (cdPIUnknown)
Next (DefaultCartPlayerControlOptions)


Previous (ConfigTimePlaybackControlOptions)
Next (DefaultCartwallControlOptions)

Name
DefaultCartPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultCartPlayerControlOptions = [ ]

mAirListScript
Class Tree
Index
Previous (ConfigTimePlaybackControlOptions)
Next (DefaultCartwallControlOptions)


Previous (DefaultCartPlayerControlOptions)
Next (DefaultEngineOptions)

Name
DefaultCartwallControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultCartwallControlOptions = [ cwcoSaveWithTemplate , cwcoKeepOpen , cwcoLogging ]

mAirListScript
Class Tree
Index
Previous (DefaultCartPlayerControlOptions)
Next (DefaultEngineOptions)


Previous (DefaultCartwallControlOptions)
Next (DefaultFeatures)

Name
DefaultEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultEngineOptions = [ ]

mAirListScript
Class Tree
Index
Previous (DefaultCartwallControlOptions)
Next (DefaultFeatures)


Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)

Name
DefaultFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFeatures = [ mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ]

mAirListScript
Class Tree
Index
Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)


Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)

Name
DefaultFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileImportOptions = [ fioImportComment , fioImportTags , fioTildeAsFadeOut , fioStripWhitespace ]

mAirListScript
Class Tree
Index
Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)


Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)

Name
DefaultFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileManagementOptions = [ fmoCacheNetworkFiles ]

mAirListScript
Class Tree
Index
Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)


Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)

Name
DefaultGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultGlobalOptions = [ goFadeOutEffectiveEnd , goStartOnAir , goNoLoggingOffAir , goSplashScreen ]

mAirListScript
Class Tree
Index
Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)


Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)

Name
DefaultPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlaybackControlOptions = [ plcoAllowAutomation , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime ]

mAirListScript
Class Tree
Index
Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)


Previous (DefaultPlaybackControlOptions)
Next (MIN_DB)

Name
DefaultPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlayerControlOptions = [ poAutoLoad , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poUseInAutomation , poHistoryOnClose , poLogging , poIndependentPFLEndMon ]

mAirListScript
Class Tree
Index
Previous (DefaultPlaybackControlOptions)
Next (MIN_DB)


Previous (DefaultPlayerControlOptions)
Next (ntArtistRoot)

Name
MIN_DB

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MIN_DB = - 999

mAirListScript
Class Tree
Index
Previous (DefaultPlayerControlOptions)
Next (ntArtistRoot)


Previous (MIN_DB)
Next (ntAttribute)

Name
ntArtistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntArtistRoot = 6

mAirListScript
Class Tree
Index
Previous (MIN_DB)
Next (ntAttribute)


Previous (ntArtistRoot)
Next (ntAttributeRoot)

Name
ntAttribute

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttribute = 9

mAirListScript
Class Tree
Index
Previous (ntArtistRoot)
Next (ntAttributeRoot)


Previous (ntAttribute)
Next (ntAttributeValue)

Name
ntAttributeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeRoot = 8

mAirListScript
Class Tree
Index
Previous (ntAttribute)
Next (ntAttributeValue)


Previous (ntAttributeRoot)
Next (ntCustom)

Name
ntAttributeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeValue = 10

mAirListScript
Class Tree
Index
Previous (ntAttributeRoot)
Next (ntCustom)


Previous (ntAttributeValue)
Next (ntFolder)

Name
ntCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntCustom = 128

mAirListScript
Class Tree
Index
Previous (ntAttributeValue)
Next (ntFolder)


Previous (ntCustom)
Next (ntFolderRoot)

Name
ntFolder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolder = 7

mAirListScript
Class Tree
Index
Previous (ntCustom)
Next (ntFolderRoot)


Previous (ntFolder)
Next (ntItem)

Name
ntFolderRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolderRoot = 5

mAirListScript
Class Tree
Index
Previous (ntFolder)
Next (ntItem)


Previous (ntFolderRoot)
Next (ntPlaylist)

Name
ntItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntItem = 1

mAirListScript
Class Tree
Index
Previous (ntFolderRoot)
Next (ntPlaylist)


Previous (ntItem)
Next (ntPlaylistRoot)

Name
ntPlaylist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylist = 3

mAirListScript
Class Tree
Index
Previous (ntItem)
Next (ntPlaylistRoot)


Previous (ntPlaylist)
Next (ntRoot)

Name
ntPlaylistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylistRoot = 2

mAirListScript
Class Tree
Index
Previous (ntPlaylist)
Next (ntRoot)


Previous (ntPlaylistRoot)
Next (ntText)

Name
ntRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntRoot = 0

mAirListScript
Class Tree
Index
Previous (ntPlaylistRoot)
Next (ntText)


Previous (ntRoot)
Next (ntType)

Name
ntText

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntText = 4

mAirListScript
Class Tree
Index
Previous (ntRoot)
Next (ntType)


Previous (ntText)
Next (ntTypeRoot)

Name
ntType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntType = 12

mAirListScript
Class Tree
Index
Previous (ntText)
Next (ntTypeRoot)


Previous (ntType)
Next (OrdinaryPlayerCommands)

Name
ntTypeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntTypeRoot = 11

mAirListScript
Class Tree
Index
Previous (ntType)
Next (OrdinaryPlayerCommands)


Previous (ntTypeRoot)
Next (RuntimeCartPlayerControlOptions)

Name
OrdinaryPlayerCommands

Parent
mAirListTypes

Visibility
PUBLIC

Source code
OrdinaryPlayerCommands = [ pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose ]

mAirListScript
Class Tree
Index
Previous (ntTypeRoot)
Next (RuntimeCartPlayerControlOptions)


Previous (OrdinaryPlayerCommands)
Next (RuntimeOrdinaryPlayerControlOptions)

Name
RuntimeCartPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
RuntimeCartPlayerControlOptions = [ poLoopAudio , poHookMode , poResetLoop , poResetHook ]

mAirListScript
Class Tree
Index
Previous (OrdinaryPlayerCommands)
Next (RuntimeOrdinaryPlayerControlOptions)


Previous (RuntimeCartPlayerControlOptions)
Next

Name
RuntimeOrdinaryPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
RuntimeOrdinaryPlayerControlOptions = [ poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoLoadSpecial , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ]

mAirListScript
Class Tree
Index
Previous (RuntimeCartPlayerControlOptions)
Next


Previous (mAirListTypes)
Next (NotificationScripts)

Name
MidiInterface

Parent
mAirListScript

Classes
Class Description
IMidiRemote (+)
TMidiMessage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListTypes)
Next (NotificationScripts)


Previous
Next (TMidiMessage)

Name
IMidiRemote

Parent
MidiInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDevice (+)
GetEvents (+)
SetDevice (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (TMidiMessage)


Previous
Next (GetEvents)

Name
GetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetDevice : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEvents)


Previous (GetDevice)
Next (SetDevice)

Name
GetEvents

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetEvents : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDevice)
Next (SetDevice)


Previous (GetEvents)
Next

Name
SetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
procedure SetDevice ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEvents)
Next


Previous (IMidiRemote)
Next

Name
TMidiMessage

Parent
MidiInterface

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Data1 (*)
Data2 (*)
Device (*)
MESSAGE (*)
Status (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMidiRemote)
Next


Previous
Next (Data2)

Name
Data1

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data1 : byte

mAirListScript
Class Tree
Index
Previous
Next (Data2)


Previous (Data1)
Next (Device)

Name
Data2

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data2 : byte

mAirListScript
Class Tree
Index
Previous (Data1)
Next (Device)


Previous (Data2)
Next (MESSAGE)

Name
Device

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Device : byte

mAirListScript
Class Tree
Index
Previous (Data2)
Next (MESSAGE)


Previous (Device)
Next (Status)

Name
MESSAGE

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
message : cardinal

mAirListScript
Class Tree
Index
Previous (Device)
Next (Status)


Previous (MESSAGE)
Next

Name
Status

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Status : byte

mAirListScript
Class Tree
Index
Previous (MESSAGE)
Next


Previous (MidiInterface)
Next (SASInterface)

Name
NotificationScripts

Parent
mAirListScript

Methods
Method | Description
DisableTimer (+)
EnableTimer (+)
OnAutomationOff (+) | Called when automation is switched off
OnAutomationOn (+) | Called when automation is switched on
OnCartPlayerEOFWarning (+) | Called when a cart player reaches the EOF warning point.
OnCartPlayerStart (+) | Called when a cart player is started.
OnCartPlayerStateChange (+) | Called when a cart player's state has changed
OnCartPlayerStop (+) | Called when a cart player is stopped.
OnCartwallHide (+) | Called when the cartwall window is hidden
OnCartwallShow (+) | Called when the cartwall window is made visible
OnExecuteCommand (+)
OnOffAir (+) | Called when Engine is switched off air
OnOnAir (+) | Called when Engine is switched on air
OnPFLOff (+) | Called when a player returns from PFL mode.
OnPFLOn (+) | Called when a player goes into PFL mode.
OnPlayerEOFWarning (+) | Called when a player reaches the EOF warning point.
OnPlayerStart (+) | Called when a player is started.
OnPlayerStateChange (+) | Called when a player's state has changed
OnPlayerStop (+) | Called when a player is stopped.
OnPlaylistEmpty (+) | Called when a playlist has run empty.
OnSASCommand (+) | Called when a data telegram is received through the SAS protocol
OnSASGPIOff (+) | Called when a GPI is switched off on an SAS mixer
OnSASGPIOn (+) | Called when a GPI is switched on on an SAS mixer
OnSASPFLOff (+) | Called when PFL is switched off on an SAS mixer
OnSASPFLOn (+) | Called when PFL is switched on on an SAS mixer
OnShutdown (+) | Called before mAirList shuts down
OnStartup (+) | Called after main window was initialized and standard.mlt was loaded.
OnTimer (+) | Called once in the timer interval specified by SetTimerInterval

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (MidiInterface)
Next (SASInterface)


Previous
Next (EnableTimer)

Name
DisableTimer

Parent
NotificationScripts

Visibility
PUBLIC

Source code
procedure DisableTimer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EnableTimer)


Previous (DisableTimer)
Next (OnAutomationOff)

Name
EnableTimer

Parent
NotificationScripts

Visibility
PUBLIC

Source code
procedure EnableTimer ( iInterval : integer )

Parameters
Parameter Description
iInterval : INTEGER

mAirListScript
Class Tree
Index
Previous (DisableTimer)
Next (OnAutomationOff)


Previous (EnableTimer)
Next (OnAutomationOn)

Name
OnAutomationOff

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when automation is switched off

Source code
procedure OnAutomationOff ( PlaylistIndex : integer )

Parameters
Parameter Description
PlaylistIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (EnableTimer)
Next (OnAutomationOn)


Previous (OnAutomationOff)
Next (OnCartPlayerEOFWarning)

Name
OnAutomationOn

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when automation is switched on

Source code
procedure OnAutomationOn ( PlaylistIndex : integer )

Parameters
Parameter Description
PlaylistIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnAutomationOff)
Next (OnCartPlayerEOFWarning)


Previous (OnAutomationOn)
Next (OnCartPlayerStart)

Name
OnCartPlayerEOFWarning

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a cart player reaches the EOF warning point.

Source code
procedure OnCartPlayerEOFWarning ( PlayerIndex : integer )

Parameters
Parameter Description
PlayerIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnAutomationOn)
Next (OnCartPlayerStart)


Previous (OnCartPlayerEOFWarning)
Next (OnCartPlayerStateChange)

Name
OnCartPlayerStart

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a cart player is started.

Source code
procedure OnCartPlayerStart ( PlayerIndex : integer )

Parameters
Parameter Description
PlayerIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnCartPlayerEOFWarning)
Next (OnCartPlayerStateChange)


Previous (OnCartPlayerStart)
Next (OnCartPlayerStop)

Name
OnCartPlayerStateChange

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a cart player's state has changed

Source code
procedure OnCartPlayerStateChange ( PlayerIndex : integer ; OldState : TPlayerState ; NewState : TPlayerState )

Parameters
Parameter Description
PlayerIndex : INTEGER
OldState : TPlayerState
NewState : TPlayerState

mAirListScript
Class Tree
Index
Previous (OnCartPlayerStart)
Next (OnCartPlayerStop)


Previous (OnCartPlayerStateChange)
Next (OnCartwallHide)

Name
OnCartPlayerStop

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a cart player is stopped.

Source code
procedure OnCartPlayerStop ( PlayerIndex : integer ; Duration : TTimeValue )

Parameters
Parameter Description
PlayerIndex : INTEGER
Duration : TTimeValue

mAirListScript
Class Tree
Index
Previous (OnCartPlayerStateChange)
Next (OnCartwallHide)


Previous (OnCartPlayerStop)
Next (OnCartwallShow)

Name
OnCartwallHide

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when the cartwall window is hidden

Source code
procedure OnCartwallHide

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnCartPlayerStop)
Next (OnCartwallShow)


Previous (OnCartwallHide)
Next (OnExecuteCommand)

Name
OnCartwallShow

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when the cartwall window is made visible

Source code
procedure OnCartwallShow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnCartwallHide)
Next (OnExecuteCommand)


Previous (OnCartwallShow)
Next (OnOffAir)

Name
OnExecuteCommand

Parent
NotificationScripts

Visibility
PUBLIC

Source code
procedure OnExecuteCommand ( Command : string )

Parameters
Parameter Description
Command : STRING

mAirListScript
Class Tree
Index
Previous (OnCartwallShow)
Next (OnOffAir)


Previous (OnExecuteCommand)
Next (OnOnAir)

Name
OnOffAir

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when Engine is switched off air

Source code
procedure OnOffAir

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnExecuteCommand)
Next (OnOnAir)


Previous (OnOffAir)
Next (OnPFLOff)

Name
OnOnAir

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when Engine is switched on air

Source code
procedure OnOnAir

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnOffAir)
Next (OnPFLOff)


Previous (OnOnAir)
Next (OnPFLOn)

Name
OnPFLOff

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player returns from PFL mode.

Source code
procedure OnPFLOff ( PlayerType : TPlayerType ; PlaylistIndex : integer ; PlayerIndex : integer ; PFLCount : integer )

Parameters
Parameter Description
PlayerType : TPlayerType
PlaylistIndex : INTEGER
PlayerIndex : INTEGER
PFLCount : INTEGER

mAirListScript
Class Tree
Index
Previous (OnOnAir)
Next (OnPFLOn)


Previous (OnPFLOff)
Next (OnPlayerEOFWarning)

Name
OnPFLOn

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player goes into PFL mode.

Source code
procedure OnPFLOn ( PlayerType : TPlayerType ; PlaylistIndex : integer ; PlayerIndex : integer ; PFLCount : integer )

Parameters
Parameter Description
PlayerType : TPlayerType
PlaylistIndex : INTEGER
PlayerIndex : INTEGER
PFLCount : INTEGER

mAirListScript
Class Tree
Index
Previous (OnPFLOff)
Next (OnPlayerEOFWarning)


Previous (OnPFLOn)
Next (OnPlayerStart)

Name
OnPlayerEOFWarning

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player reaches the EOF warning point.

Source code
procedure OnPlayerEOFWarning ( PlaylistIndex : integer ; PlayerIndex : integer )

Parameters
Parameter Description
PlaylistIndex : INTEGER
PlayerIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnPFLOn)
Next (OnPlayerStart)


Previous (OnPlayerEOFWarning)
Next (OnPlayerStateChange)

Name
OnPlayerStart

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player is started.

Source code
procedure OnPlayerStart ( PlaylistIndex : integer ; PlayerIndex : integer )

Parameters
Parameter Description
PlaylistIndex : INTEGER
PlayerIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnPlayerEOFWarning)
Next (OnPlayerStateChange)


Previous (OnPlayerStart)
Next (OnPlayerStop)

Name
OnPlayerStateChange

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player's state has changed

Source code
procedure OnPlayerStateChange ( PlaylistIndex : integer ; PlayerIndex : integer ; OldState : TPlayerState ; NewState : TPlayerState )

Parameters
Parameter Description
PlaylistIndex : INTEGER
PlayerIndex : INTEGER
OldState : TPlayerState
NewState : TPlayerState

mAirListScript
Class Tree
Index
Previous (OnPlayerStart)
Next (OnPlayerStop)


Previous (OnPlayerStateChange)
Next (OnPlaylistEmpty)

Name
OnPlayerStop

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a player is stopped.

Source code
procedure OnPlayerStop ( PlaylistIndex : integer ; PlayerIndex : integer ; Duration : TTimeValue )

Parameters
Parameter Description
PlaylistIndex : INTEGER
PlayerIndex : INTEGER
Duration : TTimeValue

mAirListScript
Class Tree
Index
Previous (OnPlayerStateChange)
Next (OnPlaylistEmpty)


Previous (OnPlayerStop)
Next (OnSASCommand)

Name
OnPlaylistEmpty

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a playlist has run empty.

Source code
procedure OnPlaylistEmpty ( PlaylistIndex : integer )

Parameters
Parameter Description
PlaylistIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (OnPlayerStop)
Next (OnSASCommand)


Previous (OnPlaylistEmpty)
Next (OnSASGPIOff)

Name
OnSASCommand

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a data telegram is received through the SAS protocol

Source code
procedure OnSASCommand ( Remote : ISASRemote ; Command : byte ; Data : string )

Parameters
Parameter Description
Remote : ISASRemote
Command : BYTE
Data : STRING

mAirListScript
Class Tree
Index
Previous (OnPlaylistEmpty)
Next (OnSASGPIOff)


Previous (OnSASCommand)
Next (OnSASGPIOn)

Name
OnSASGPIOff

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a GPI is switched off on an SAS mixer

Source code
procedure OnSASGPIOff ( Remote : ISASRemote ; GPI : byte )

Parameters
Parameter Description
Remote : ISASRemote
GPI : BYTE

mAirListScript
Class Tree
Index
Previous (OnSASCommand)
Next (OnSASGPIOn)


Previous (OnSASGPIOff)
Next (OnSASPFLOff)

Name
OnSASGPIOn

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when a GPI is switched on on an SAS mixer

Source code
procedure OnSASGPIOn ( Remote : ISASRemote ; GPI : byte )

Parameters
Parameter Description
Remote : ISASRemote
GPI : BYTE

mAirListScript
Class Tree
Index
Previous (OnSASGPIOff)
Next (OnSASPFLOff)


Previous (OnSASGPIOn)
Next (OnSASPFLOn)

Name
OnSASPFLOff

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when PFL is switched off on an SAS mixer

Source code
procedure OnSASPFLOff ( Remote : ISASRemote ; SourceName : string )

Parameters
Parameter Description
Remote : ISASRemote
SourceName : STRING

mAirListScript
Class Tree
Index
Previous (OnSASGPIOn)
Next (OnSASPFLOn)


Previous (OnSASPFLOff)
Next (OnShutdown)

Name
OnSASPFLOn

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called when PFL is switched on on an SAS mixer

Source code
procedure OnSASPFLOn ( Remote : ISASRemote ; SourceName : string )

Parameters
Parameter Description
Remote : ISASRemote
SourceName : STRING

mAirListScript
Class Tree
Index
Previous (OnSASPFLOff)
Next (OnShutdown)


Previous (OnSASPFLOn)
Next (OnStartup)

Name
OnShutdown

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called before mAirList shuts down

Source code
procedure OnShutdown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnSASPFLOn)
Next (OnStartup)


Previous (OnShutdown)
Next (OnTimer)

Name
OnStartup

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called after main window was initialized and standard.mlt was loaded.

Source code
procedure OnStartup

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnShutdown)
Next (OnTimer)


Previous (OnStartup)
Next

Name
OnTimer

Parent
NotificationScripts

Visibility
PUBLIC

Description
Called once in the timer interval specified by SetTimerInterval
Timer must be enabled with EnableTimer

Source code
procedure OnTimer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (OnStartup)
Next


Previous (NotificationScripts)
Next (WMClientInterface)

Name
SASInterface

Parent
mAirListScript

Classes
Class Description
IIPSASRemote (+)
ISASAction (+)
ISASRemote (+)
ISASSetFaderInputGainAction (+)
ISASSetFaderLevelAction (+)
ISASSetFaderStartOffAction (+)
ISASSetFaderStartOnAction (+)
ISASSetGPIAction (+)
ISASSetGPIOffAction (+)
ISASSetGPIOnAction (+)
ISASSetPFLOffAction (+)
ISASSetPFLOnAction (+)
ISASSourceAction (+)
ISASSourceLevelAction (+)
ISerialSASRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (NotificationScripts)
Next (WMClientInterface)


Previous
Next (ISASAction)

Name
IIPSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetHost (+)
GetPort (+)
SetHost (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (ISASAction)


Previous
Next (GetPort)

Name
GetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetHost : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (GetHost)
Next (SetHost)

Name
GetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHost)
Next (SetHost)


Previous (GetPort)
Next (SetPort)

Name
SetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetHost ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SetPort)


Previous (SetHost)
Next

Name
SetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetHost)
Next


Previous (IIPSASRemote)
Next (ISASRemote)

Name
ISASAction

Parent
SASInterface

Class Hierarchy
IAction

Visibility
PUBLIC

Members
Methods
Method Description
GetRemoteID (+)
SetRemoteID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIPSASRemote)
Next (ISASRemote)


Previous
Next (SetRemoteID)

Name
GetRemoteID

Parent
ISASAction

Visibility
PUBLIC

Source code
function GetRemoteID : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetRemoteID)


Previous (GetRemoteID)
Next

Name
SetRemoteID

Parent
ISASAction

Visibility
PUBLIC

Source code
procedure SetRemoteID ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetRemoteID)
Next


Previous (ISASAction)
Next (ISASSetFaderInputGainAction)

Name
ISASRemote

Parent
SASInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
FetchFaderLevel (+)
FetchFaderStatus (+)
GetAllSources (+)
GetFader (+)
GetFaderLevel (+)
GetFaderStatus (+)
GetGPIOffCommand (+)
GetGPIOnCommand (+)
GetOtherSources (+)
GetPlayerGPI (+)
GetPlayerOptions (+)
GetPlayerSourceName (+)
SendCommand (+)
SetFaderInputGain (+)
SetFaderLevel (+)
SetFaderStart (+)
SetGPI (+)
SetGPIOffCommand (+)
SetGPIOnCommand (+)
SetOtherSources (+)
SetPlayerGPI (+)
SetPlayerOptions (+)
SetPlayerSourceName (+)
SetPrelisten1Off (+)
SetPrelisten1On (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASAction)
Next (ISASSetFaderInputGainAction)


Previous
Next (FetchFaderStatus)

Name
FetchFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderLevel ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous
Next (FetchFaderStatus)


Previous (FetchFaderLevel)
Next (GetAllSources)

Name
FetchFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderStatus ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (FetchFaderLevel)
Next (GetAllSources)


Previous (FetchFaderStatus)
Next (GetFader)

Name
GetAllSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetAllSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FetchFaderStatus)
Next (GetFader)


Previous (GetAllSources)
Next (GetFaderLevel)

Name
GetFader

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFader ( iSourceName : string ) : byte

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetAllSources)
Next (GetFaderLevel)


Previous (GetFader)
Next (GetFaderStatus)

Name
GetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderLevel ( iSourceName : string ) : ShortInt

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetFader)
Next (GetFaderStatus)


Previous (GetFaderLevel)
Next (GetGPIOffCommand)

Name
GetFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderStatus ( iSourceName : string ) : byte

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetFaderLevel)
Next (GetGPIOffCommand)


Previous (GetFaderStatus)
Next (GetGPIOnCommand)

Name
GetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOffCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFaderStatus)
Next (GetGPIOnCommand)


Previous (GetGPIOffCommand)
Next (GetOtherSources)

Name
GetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOnCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetGPIOffCommand)
Next (GetOtherSources)


Previous (GetGPIOnCommand)
Next (GetPlayerGPI)

Name
GetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetOtherSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGPIOnCommand)
Next (GetPlayerGPI)


Previous (GetOtherSources)
Next (GetPlayerOptions)

Name
GetPlayerGPI

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerGPI ( iPlaylist , iPlayer : integer ) : byte

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER

mAirListScript
Class Tree
Index
Previous (GetOtherSources)
Next (GetPlayerOptions)


Previous (GetPlayerGPI)
Next (GetPlayerSourceName)

Name
GetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerOptions ( iPlaylist , iPlayer : integer ) : TSASPlayerOptions

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlayerGPI)
Next (GetPlayerSourceName)


Previous (GetPlayerOptions)
Next (SendCommand)

Name
GetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerSourceName ( iPlaylist , iPlayer : integer ) : string

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlayerOptions)
Next (SendCommand)


Previous (GetPlayerSourceName)
Next (SetFaderInputGain)

Name
SendCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SendCommand ( iCommand : byte ; iData : AnsiString )

Parameters
Parameter Description
iCommand : BYTE
iData : ANSISTRING

mAirListScript
Class Tree
Index
Previous (GetPlayerSourceName)
Next (SetFaderInputGain)


Previous (SendCommand)
Next (SetFaderLevel)

Name
SetFaderInputGain

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderInputGain ( iSourceName : string ; iLevel : ShortInt )

Parameters
Parameter Description
iSourceName : STRING
iLevel : SHORTINT

mAirListScript
Class Tree
Index
Previous (SendCommand)
Next (SetFaderLevel)


Previous (SetFaderInputGain)
Next (SetFaderStart)

Name
SetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderLevel ( iSourceName : string ; iLevel : ShortInt ; iFadeTime : word )

Parameters
Parameter Description
iSourceName : STRING
iLevel : SHORTINT
iFadeTime : WORD

mAirListScript
Class Tree
Index
Previous (SetFaderInputGain)
Next (SetFaderStart)


Previous (SetFaderLevel)
Next (SetGPI)

Name
SetFaderStart

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderStart ( iSourceName : string ; iStatus : byte )

Parameters
Parameter Description
iSourceName : STRING
iStatus : BYTE

mAirListScript
Class Tree
Index
Previous (SetFaderLevel)
Next (SetGPI)


Previous (SetFaderStart)
Next (SetGPIOffCommand)

Name
SetGPI

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPI ( iNumber , iValue : byte )

Parameters
Parameter Description
iNumber : BYTE
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (SetFaderStart)
Next (SetGPIOffCommand)


Previous (SetGPI)
Next (SetGPIOnCommand)

Name
SetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOffCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetGPI)
Next (SetGPIOnCommand)


Previous (SetGPIOffCommand)
Next (SetOtherSources)

Name
SetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOnCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetGPIOffCommand)
Next (SetOtherSources)


Previous (SetGPIOnCommand)
Next (SetPlayerGPI)

Name
SetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetOtherSources ( iValue : IStrings )

Parameters
Parameter Description
iValue : IStrings

mAirListScript
Class Tree
Index
Previous (SetGPIOnCommand)
Next (SetPlayerGPI)


Previous (SetOtherSources)
Next (SetPlayerOptions)

Name
SetPlayerGPI

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerGPI ( iPlaylist , iPlayer : integer ; iValue : byte )

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (SetOtherSources)
Next (SetPlayerOptions)


Previous (SetPlayerGPI)
Next (SetPlayerSourceName)

Name
SetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerOptions ( iPlaylist , iPlayer : integer ; iValue : TSASPlayerOptions )

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER
iValue : TSASPlayerOptions

mAirListScript
Class Tree
Index
Previous (SetPlayerGPI)
Next (SetPlayerSourceName)


Previous (SetPlayerOptions)
Next (SetPrelisten1Off)

Name
SetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerSourceName ( iPlaylist , iPlayer : integer ; iValue : string )

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPlayerOptions)
Next (SetPrelisten1Off)


Previous (SetPlayerSourceName)
Next (SetPrelisten1On)

Name
SetPrelisten1Off

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1Off ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (SetPlayerSourceName)
Next (SetPrelisten1On)


Previous (SetPrelisten1Off)
Next

Name
SetPrelisten1On

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1On ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (SetPrelisten1Off)
Next


Previous (ISASRemote)
Next (ISASSetFaderLevelAction)

Name
ISASSetFaderInputGainAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASRemote)
Next (ISASSetFaderLevelAction)


Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)

Name
ISASSetFaderLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Members
Methods
Method Description
GetFadeTime (+)
SetFadeTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)


Previous
Next (SetFadeTime)

Name
GetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
function GetFadeTime : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetFadeTime)


Previous (GetFadeTime)
Next

Name
SetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
procedure SetFadeTime ( iValue : word )

Parameters
Parameter Description
iValue : WORD

mAirListScript
Class Tree
Index
Previous (GetFadeTime)
Next


Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)

Name
ISASSetFaderStartOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)


Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)

Name
ISASSetFaderStartOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)


Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)

Name
ISASSetGPIAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetNumber (+)
SetNumber (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)


Previous
Next (SetNumber)

Name
GetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
function GetNumber : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetNumber)


Previous (GetNumber)
Next

Name
SetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
procedure SetNumber ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (GetNumber)
Next


Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)

Name
ISASSetGPIOffAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)


Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)

Name
ISASSetGPIOnAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)


Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)

Name
ISASSetPFLOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)


Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)

Name
ISASSetPFLOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)


Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)

Name
ISASSourceAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetSourceName (+)
SetSourceName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)


Previous
Next (SetSourceName)

Name
GetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
function GetSourceName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetSourceName)


Previous (GetSourceName)
Next

Name
SetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
procedure SetSourceName ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetSourceName)
Next


Previous (ISASSourceAction)
Next (ISerialSASRemote)

Name
ISASSourceLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Members
Methods
Method Description
GetLevel (+)
SetLevel (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceAction)
Next (ISerialSASRemote)


Previous
Next (SetLevel)

Name
GetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
function GetLevel : ShortInt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetLevel)


Previous (GetLevel)
Next

Name
SetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
procedure SetLevel ( iValue : ShortInt )

Parameters
Parameter Description
iValue : SHORTINT

mAirListScript
Class Tree
Index
Previous (GetLevel)
Next


Previous (ISASSourceLevelAction)
Next

Name
ISerialSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceLevelAction)
Next


Previous
Next (SetPort)

Name
GetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (SASInterface)
Next (ZDbcIntfs)

Name
WMClientInterface

Parent
mAirListScript

Classes
Class Description
IWMClientRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (SASInterface)
Next (ZDbcIntfs)


Previous
Next

Name
IWMClientRemote

Parent
WMClientInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetMessages (+)
GetRegisterMessage (+)
GetSetOutputMessage (+)
GetUnregisterMessage (+)
GetWindowName (+)
SetOutput (+)
SetRegisterMessage (+)
SetSetOutputMessage (+)
SetUnregisterMessage (+)
SetWindowName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (GetRegisterMessage)

Name
GetMessages

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetMessages : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetRegisterMessage)


Previous (GetMessages)
Next (GetSetOutputMessage)

Name
GetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetRegisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessages)
Next (GetSetOutputMessage)


Previous (GetRegisterMessage)
Next (GetUnregisterMessage)

Name
GetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetSetOutputMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegisterMessage)
Next (GetUnregisterMessage)


Previous (GetSetOutputMessage)
Next (GetWindowName)

Name
GetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetUnregisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSetOutputMessage)
Next (GetWindowName)


Previous (GetUnregisterMessage)
Next (SetOutput)

Name
GetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetWindowName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUnregisterMessage)
Next (SetOutput)


Previous (GetWindowName)
Next (SetRegisterMessage)

Name
SetOutput

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetOutput ( iNumber : integer ; iValue : integer )

Parameters
Parameter Description
iNumber : INTEGER
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetWindowName)
Next (SetRegisterMessage)


Previous (SetOutput)
Next (SetSetOutputMessage)

Name
SetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetRegisterMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetOutput)
Next (SetSetOutputMessage)


Previous (SetRegisterMessage)
Next (SetUnregisterMessage)

Name
SetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetSetOutputMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetRegisterMessage)
Next (SetUnregisterMessage)


Previous (SetSetOutputMessage)
Next (SetWindowName)

Name
SetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetUnregisterMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetSetOutputMessage)
Next (SetWindowName)


Previous (SetUnregisterMessage)
Next

Name
SetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetWindowName ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetUnregisterMessage)
Next


Previous (WMClientInterface)
Next

Name
ZDbcIntfs

Parent
mAirListScript

Types
Type Description
TZBestRowIdentifier (+)
TZColumnNullableType (+)
TZFetchDirection (+)
TZImportedKey (+)
TZLocateUpdatesMode (+)
TZPostUpdatesMode (+)
TZProcedureColumnType (+)
TZProcedureResultType (+)
TZResultSetConcurrency (+)
TZResultSetType (+)
TZScopeBestRowIdentifier (+)
TZSQLType (+)
TZTableIndex (+)
TZTransactIsolationLevel (+)
TZVersionColumn (+)

Constants
Constant Description
ProcedureReturnsResult (+)
TypeSearchable (+)

Variables
Variable Description
DriverManager (+)

Classes
Class Description
EZSQLException (+)
EZSQLThrowable (+)
EZSQLWarning (+)
IZBlob (+)
IZCallableStatement (+)
IZConnection (+)
IZDatabaseMetadata (+)
IZDriver (+)
IZDriverManager (+)
IZNotification (+)
IZPreparedStatement (+)
IZResultSet (+)
IZResultSetMetadata (+)
IZSequence (+)
IZStatement (+)
TZDriverManager (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (WMClientInterface)
Next


Previous
Next (EZSQLThrowable)

Name
EZSQLException

Parent
ZDbcIntfs

Class Hierarchy
EZSQLThrowable

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (EZSQLThrowable)


Previous (EZSQLException)
Next (EZSQLWarning)

Name
EZSQLThrowable

Parent
ZDbcIntfs

Class Hierarchy
Exception

Visibility
PUBLIC

Members
Fields
Field Description
FErrorCode (-)
FStatusCode (-)

Methods
Method | Description
Create (+)
CreateClone (+) | Creates an exception with message string.
CreateWithCode (+) | Creates an exception with message string.
CreateWithStatus (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLException)
Next (EZSQLWarning)


Previous
Next (FStatusCode)

Name
FErrorCode

Parent
EZSQLThrowable

Visibility
PRIVATE

Source code
FErrorCode : Integer

mAirListScript
Class Tree
Index
Previous
Next (FStatusCode)


Previous (FErrorCode)
Next

Name
FStatusCode

Parent
EZSQLThrowable

Visibility
PRIVATE

Source code
FStatusCode : String

mAirListScript
Class Tree
Index
Previous (FErrorCode)
Next


Previous
Next (CreateClone)

Name
Create

Parent
EZSQLThrowable

Visibility
PUBLIC

Source code
constructor Create ( const Msg : string )

Parameters
Parameter Description
Msg : STRING

mAirListScript
Class Tree
Index
Previous
Next (CreateClone)


Previous (Create)
Next (CreateWithCode)

Name
CreateClone

Parent
EZSQLThrowable

Visibility
PUBLIC

Description
Creates an exception with message string.

Source code
constructor CreateClone ( const E : EZSQLThrowable )

Parameters
Parameter Description
E : EZSQLThrowable

mAirListScript
Class Tree
Index
Previous (Create)
Next (CreateWithCode)


Previous (CreateClone)
Next (CreateWithStatus)

Name
CreateWithCode

Parent
EZSQLThrowable

Visibility
PUBLIC

Description
Creates an exception with message string.

Source code
constructor CreateWithCode ( const ErrorCode : Integer ; const Msg : string )

Parameters
Parameter | Description
ErrorCode : INTEGER | a native server error code.
Msg : STRING | a error description.

mAirListScript
Class Tree
Index
Previous (CreateClone)
Next (CreateWithStatus)


Previous (CreateWithCode)
Next

Name
CreateWithStatus

Parent
EZSQLThrowable

Visibility
PUBLIC

Source code
constructor CreateWithStatus ( const StatusCode : String ; const Msg : string )

Parameters
Parameter Description
StatusCode : STRING
Msg : STRING

mAirListScript
Class Tree
Index
Previous (CreateWithCode)
Next


Previous (EZSQLThrowable)
Next (IZBlob)

Name
EZSQLWarning

Parent
ZDbcIntfs

Class Hierarchy
EZSQLThrowable

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLThrowable)
Next (IZBlob)


Previous (EZSQLWarning)
Next (IZCallableStatement)

Name
IZBlob

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
Clear (+)
Clone (+)
GetBytes (+)
GetStream (+)
GetString (+)
GetUnicodeString (+)
IsEmpty (+)
IsUpdated (+)
Length (+)
SetBytes (+)
SetStream (+)
SetString (+)
SetUnicodeString (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLWarning)
Next (IZCallableStatement)


Previous
Next (Clone)

Name
Clear

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Clone)


Previous (Clear)
Next (GetBytes)

Name
Clone

Parent
IZBlob

Visibility
PUBLIC

Source code
function Clone : IZBlob

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetBytes)


Previous (Clone)
Next (GetStream)

Name
GetBytes

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetBytes : TByteDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetStream)


Previous (GetBytes)
Next (GetString)

Name
GetStream

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetStream : TStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetString)


Previous (GetStream)
Next (GetUnicodeString)

Name
GetString

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStream)
Next (GetUnicodeString)


Previous (GetString)
Next (IsEmpty)

Name
GetUnicodeString

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetUnicodeString : WideString

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetString)
Next (IsEmpty)


Previous (GetUnicodeString)
Next (IsUpdated)

Name
IsEmpty

Parent
IZBlob

Visibility
PUBLIC

Source code
function IsEmpty : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (IsUpdated)


Previous (IsEmpty)
Next (Length)

Name
IsUpdated

Parent
IZBlob

Visibility
PUBLIC

Source code
function IsUpdated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsEmpty)
Next (Length)


Previous (IsUpdated)
Next (SetBytes)

Name
Length

Parent
IZBlob

Visibility
PUBLIC

Source code
function Length : LongInt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsUpdated)
Next (SetBytes)


Previous (Length)
Next (SetStream)

Name
SetBytes

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetBytes ( const Value : TByteDynArray )

Parameters
Parameter Description
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (Length)
Next (SetStream)


Previous (SetBytes)
Next (SetString)

Name
SetStream

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetStream ( Value : TStream )

Parameters
Parameter Description
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetBytes)
Next (SetString)


Previous (SetStream)
Next (SetUnicodeString)

Name
SetString

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetString ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetStream)
Next (SetUnicodeString)


Previous (SetString)
Next

Name
SetUnicodeString

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetUnicodeString ( const Value : WideString )

Parameters
Parameter Description
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (SetString)
Next


Previous (IZBlob)
Next (IZConnection)

Name
IZCallableStatement

Parent
ZDbcIntfs

Class Hierarchy
IZPreparedStatement

Visibility
PUBLIC

Members
Methods
Method Description
GetBigDecimal (+)
GetBoolean (+)
GetByte (+)
GetBytes (+)
GetDate (+)
GetDouble (+)
GetFloat (+)
GetInt (+)
GetLong (+)
GetPChar (+)
GetShort (+)
GetString (+)
GetTime (+)
GetTimestamp (+)
GetUnicodeString (+)
GetValue (+)
IsNull (+)
RegisterOutParameter (+)
WasNull (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZBlob)
Next (IZConnection)


Previous
Next (GetBoolean)

Name
GetBigDecimal

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBigDecimal ( ParameterIndex : Integer ) : Extended

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetBoolean)


Previous (GetBigDecimal)
Next (GetByte)

Name
GetBoolean

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBoolean ( ParameterIndex : Integer ) : Boolean

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBigDecimal)
Next (GetByte)


Previous (GetBoolean)
Next (GetBytes)

Name
GetByte

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetByte ( ParameterIndex : Integer ) : ShortInt

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBoolean)
Next (GetBytes)


Previous (GetByte)
Next (GetDate)

Name
GetBytes

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBytes ( ParameterIndex : Integer ) : TByteDynArray

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetByte)
Next (GetDate)


Previous (GetBytes)
Next (GetDouble)

Name
GetDate

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetDate ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetDouble)


Previous (GetDate)
Next (GetFloat)

Name
GetDouble

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetDouble ( ParameterIndex : Integer ) : Double

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDate)
Next (GetFloat)


Previous (GetDouble)
Next (GetInt)

Name
GetFloat

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetFloat ( ParameterIndex : Integer ) : Single

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDouble)
Next (GetInt)


Previous (GetFloat)
Next (GetLong)

Name
GetInt

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetInt ( ParameterIndex : Integer ) : Integer

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFloat)
Next (GetLong)


Previous (GetInt)
Next (GetPChar)

Name
GetLong

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetLong ( ParameterIndex : Integer ) : Int64

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetInt)
Next (GetPChar)


Previous (GetLong)
Next (GetShort)

Name
GetPChar

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetPChar ( ParameterIndex : Integer ) : PChar

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetLong)
Next (GetShort)


Previous (GetPChar)
Next (GetString)

Name
GetShort

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetShort ( ParameterIndex : Integer ) : SmallInt

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPChar)
Next (GetString)


Previous (GetShort)
Next (GetTime)

Name
GetString

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetString ( ParameterIndex : Integer ) : string

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetShort)
Next (GetTime)


Previous (GetString)
Next (GetTimestamp)

Name
GetTime

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetTime ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetString)
Next (GetTimestamp)


Previous (GetTime)
Next (GetUnicodeString)

Name
GetTimestamp

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetTimestamp ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTime)
Next (GetUnicodeString)


Previous (GetTimestamp)
Next (GetValue)

Name
GetUnicodeString

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetUnicodeString ( ParameterIndex : Integer ) : WideString

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTimestamp)
Next (GetValue)


Previous (GetUnicodeString)
Next (IsNull)

Name
GetValue

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetValue ( ParameterIndex : Integer ) : TZVariant

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (IsNull)


Previous (GetValue)
Next (RegisterOutParameter)

Name
IsNull

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function IsNull ( ParameterIndex : Integer ) : Boolean

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (RegisterOutParameter)


Previous (IsNull)
Next (WasNull)

Name
RegisterOutParameter

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
procedure RegisterOutParameter ( ParameterIndex : Integer ; SQLType : Integer )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : INTEGER

mAirListScript
Class Tree
Index
Previous (IsNull)
Next (WasNull)


Previous (RegisterOutParameter)
Next

Name
WasNull

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function WasNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RegisterOutParameter)
Next


Previous (IZCallableStatement)
Next (IZDatabaseMetadata)

Name
IZConnection

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
ClearWarnings (+)
Close (+)
Commit (+)
CommitPrepared (+)
CreateNotification (+)
CreateSequence (+)
CreateStatement (+)
CreateStatementWithParams (+)
EscapeString (+)
GetAutoCommit (+)
GetCatalog (+)
GetClientVersion (+)
GetDriver (+)
GetHostVersion (+)
GetMetadata (+)
GetParameters (+)
GetTransactionIsolation (+)
GetWarnings (+)
IsClosed (+)
IsReadOnly (+)
NativeSQL (+)
Open (+)
PingServer (+)
PrepareCall (+)
PrepareCallWithParams (+)
PrepareStatement (+)
PrepareStatementWithParams (+)
PrepareTransaction (+)
Rollback (+)
RollbackPrepared (+)
SetAutoCommit (+)
SetCatalog (+)
SetReadOnly (+)
SetTransactionIsolation (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZCallableStatement)
Next (IZDatabaseMetadata)


Previous
Next (Close)

Name
ClearWarnings

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Close)


Previous (ClearWarnings)
Next (Commit)

Name
Close

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (Commit)


Previous (Close)
Next (CommitPrepared)

Name
Commit

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Commit

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Close)
Next (CommitPrepared)


Previous (Commit)
Next (CreateNotification)

Name
CommitPrepared

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure CommitPrepared ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (Commit)
Next (CreateNotification)


Previous (CommitPrepared)
Next (CreateSequence)

Name
CreateNotification

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateNotification ( const Event : string ) : IZNotification

Parameters
Parameter Description
Event : STRING

mAirListScript
Class Tree
Index
Previous (CommitPrepared)
Next (CreateSequence)


Previous (CreateNotification)
Next (CreateStatement)

Name
CreateSequence

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateSequence ( const Sequence : string ; BlockSize : Integer ) : IZSequence

Parameters
Parameter Description
Sequence : STRING
BlockSize : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateNotification)
Next (CreateStatement)


Previous (CreateSequence)
Next (CreateStatementWithParams)

Name
CreateStatement

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateStatement : IZStatement

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateSequence)
Next (CreateStatementWithParams)


Previous (CreateStatement)
Next (EscapeString)

Name
CreateStatementWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateStatementWithParams ( Info : TStrings ) : IZStatement

Parameters
Parameter Description
Info : TStrings

mAirListScript
Class Tree
Index
Previous (CreateStatement)
Next (EscapeString)


Previous (CreateStatementWithParams)
Next (GetAutoCommit)

Name
EscapeString

Parent
IZConnection

Visibility
PUBLIC

Source code
function EscapeString ( Value : String ) : String

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (CreateStatementWithParams)
Next (GetAutoCommit)


Previous (EscapeString)
Next (GetCatalog)

Name
GetAutoCommit

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetAutoCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EscapeString)
Next (GetCatalog)


Previous (GetAutoCommit)
Next (GetClientVersion)

Name
GetCatalog

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetCatalog : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutoCommit)
Next (GetClientVersion)


Previous (GetCatalog)
Next (GetDriver)

Name
GetClientVersion

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetClientVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalog)
Next (GetDriver)


Previous (GetClientVersion)
Next (GetHostVersion)

Name
GetDriver

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetDriver : IZDriver

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetHostVersion)


Previous (GetDriver)
Next (GetMetadata)

Name
GetHostVersion

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetHostVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetMetadata)


Previous (GetHostVersion)
Next (GetParameters)

Name
GetMetadata

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetMetadata : IZDatabaseMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHostVersion)
Next (GetParameters)


Previous (GetMetadata)
Next (GetTransactionIsolation)

Name
GetParameters

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetParameters : TStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetTransactionIsolation)


Previous (GetParameters)
Next (GetWarnings)

Name
GetTransactionIsolation

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetTransactionIsolation : TZTransactIsolationLevel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (GetWarnings)


Previous (GetTransactionIsolation)
Next (IsClosed)

Name
GetWarnings

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTransactionIsolation)
Next (IsClosed)


Previous (GetWarnings)
Next (IsReadOnly)

Name
IsClosed

Parent
IZConnection

Visibility
PUBLIC

Source code
function IsClosed : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (IsReadOnly)


Previous (IsClosed)
Next (NativeSQL)

Name
IsReadOnly

Parent
IZConnection

Visibility
PUBLIC

Source code
function IsReadOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsClosed)
Next (NativeSQL)


Previous (IsReadOnly)
Next (Open)

Name
NativeSQL

Parent
IZConnection

Visibility
PUBLIC

Source code
function NativeSQL ( const SQL : string ) : string

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (Open)


Previous (NativeSQL)
Next (PingServer)

Name
Open

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Open

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NativeSQL)
Next (PingServer)


Previous (Open)
Next (PrepareCall)

Name
PingServer

Parent
IZConnection

Visibility
PUBLIC

Source code
function PingServer : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (PrepareCall)


Previous (PingServer)
Next (PrepareCallWithParams)

Name
PrepareCall

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareCall ( const SQL : string ) : IZCallableStatement

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (PingServer)
Next (PrepareCallWithParams)


Previous (PrepareCall)
Next (PrepareStatement)

Name
PrepareCallWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareCallWithParams ( const SQL : string ; Info : TStrings ) : IZCallableStatement

Parameters
Parameter Description
SQL : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (PrepareCall)
Next (PrepareStatement)


Previous (PrepareCallWithParams)
Next (PrepareStatementWithParams)

Name
PrepareStatement

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareStatement ( const SQL : string ) : IZPreparedStatement

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (PrepareCallWithParams)
Next (PrepareStatementWithParams)


Previous (PrepareStatement)
Next (PrepareTransaction)

Name
PrepareStatementWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareStatementWithParams ( const SQL : string ; Info : TStrings ) : IZPreparedStatement

Parameters
Parameter Description
SQL : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (PrepareStatement)
Next (PrepareTransaction)


Previous (PrepareStatementWithParams)
Next (Rollback)

Name
PrepareTransaction

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure PrepareTransaction ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (PrepareStatementWithParams)
Next (Rollback)


Previous (PrepareTransaction)
Next (RollbackPrepared)

Name
Rollback

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Rollback

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (PrepareTransaction)
Next (RollbackPrepared)


Previous (Rollback)
Next (SetAutoCommit)

Name
RollbackPrepared

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure RollbackPrepared ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (Rollback)
Next (SetAutoCommit)


Previous (RollbackPrepared)
Next (SetCatalog)

Name
SetAutoCommit

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetAutoCommit ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (RollbackPrepared)
Next (SetCatalog)


Previous (SetAutoCommit)
Next (SetReadOnly)

Name
SetCatalog

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetCatalog ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetAutoCommit)
Next (SetReadOnly)


Previous (SetCatalog)
Next (SetTransactionIsolation)

Name
SetReadOnly

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetReadOnly ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetCatalog)
Next (SetTransactionIsolation)


Previous (SetReadOnly)
Next

Name
SetTransactionIsolation

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetTransactionIsolation ( Value : TZTransactIsolationLevel )

Parameters
Parameter Description
Value : TZTransactIsolationLevel

mAirListScript
Class Tree
Index
Previous (SetReadOnly)
Next


Previous (IZConnection)
Next (IZDriver)

Name
IZDatabaseMetadata

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddEscapeCharToWildcards (+)
AllProceduresAreCallable (+)
AllTablesAreSelectable (+)
ClearCache (+)
DataDefinitionCausesTransactionCommit (+)
DataDefinitionIgnoredInTransactions (+)
DoesMaxRowSizeIncludeBlobs (+)
GetBestRowIdentifier (+)
GetCatalogs (+)
GetCatalogSeparator (+)
GetCatalogTerm (+)
GetColumnPrivileges (+)
GetColumns (+)
GetConnection (+)
GetCrossReference (+)
GetDatabaseProductName (+)
GetDatabaseProductVersion (+)
GetDefaultTransactionIsolation (+)
GetDriverMajorVersion (+)
GetDriverMinorVersion (+)
GetDriverName (+)
GetDriverVersion (+)
GetExportedKeys (+)
GetExtraNameCharacters (+)
GetIdentifierConvertor (+)
GetIdentifierQuoteString (+)
GetImportedKeys (+)
GetIndexInfo (+)
GetMaxBinaryLiteralLength (+)
GetMaxCatalogNameLength (+)
GetMaxCharLiteralLength (+)
GetMaxColumnNameLength (+)
GetMaxColumnsInGroupBy (+)
GetMaxColumnsInIndex (+)
GetMaxColumnsInOrderBy (+)
GetMaxColumnsInSelect (+)
GetMaxColumnsInTable (+)
GetMaxConnections (+)
GetMaxCursorNameLength (+)
GetMaxIndexLength (+)
GetMaxProcedureNameLength (+)
GetMaxRowSize (+)
GetMaxSchemaNameLength (+)
GetMaxStatementLength (+)
GetMaxStatements (+)
GetMaxTableNameLength (+)
GetMaxTablesInSelect (+)
GetMaxUserNameLength (+)
GetNumericFunctions (+)
GetPrimaryKeys (+)
GetProcedureColumns (+)
GetProcedures (+)
GetProcedureTerm (+)
GetSchemas (+)
GetSchemaTerm (+)
GetSearchStringEscape (+)
GetSequences (+)
GetSQLKeywords (+)
GetStringFunctions (+)
GetSystemFunctions (+)
GetTablePrivileges (+)
GetTables (+)
GetTableTypes (+)
GetTimeDateFunctions (+)
GetTypeInfo (+)
GetUDTs (+)
GetURL (+)
GetUserName (+)
GetVersionColumns (+)
IsCatalogAtStart (+)
IsReadOnly (+)
NullPlusNonNullIsNull (+)
NullsAreSortedAtEnd (+)
NullsAreSortedAtStart (+)
NullsAreSortedHigh (+)
NullsAreSortedLow (+)
StoresLowerCaseIdentifiers (+)
StoresLowerCaseQuotedIdentifiers (+)
StoresMixedCaseIdentifiers (+)
StoresMixedCaseQuotedIdentifiers (+)
StoresUpperCaseIdentifiers (+)
StoresUpperCaseQuotedIdentifiers (+)
SupportsAlterTableWithAddColumn (+)
SupportsAlterTableWithDropColumn (+)
SupportsANSI92EntryLevelSQL (+)
SupportsANSI92FullSQL (+)
SupportsANSI92IntermediateSQL (+)
SupportsBatchUpdates (+)
SupportsCatalogsInDataManipulation (+)
SupportsCatalogsInIndexDefinitions (+)
SupportsCatalogsInPrivilegeDefinitions (+)
SupportsCatalogsInProcedureCalls (+)
SupportsCatalogsInTableDefinitions (+)
SupportsColumnAliasing (+)
SupportsConvert (+)
SupportsConvertForTypes (+)
SupportsCoreSQLGrammar (+)
SupportsCorrelatedSubqueries (+)
SupportsDataDefinitionAndDataManipulationTransactions (+)
SupportsDataManipulationTransactionsOnly (+)
SupportsDifferentTableCorrelationNames (+)
SupportsExpressionsInOrderBy (+)
SupportsExtendedSQLGrammar (+)
SupportsFullOuterJoins (+)
SupportsGroupBy (+)
SupportsGroupByBeyondSelect (+)
SupportsGroupByUnrelated (+)
SupportsIntegrityEnhancementFacility (+)
SupportsLikeEscapeClause (+)
SupportsLimitedOuterJoins (+)
SupportsMinimumSQLGrammar (+)
SupportsMixedCaseIdentifiers (+)
SupportsMixedCaseQuotedIdentifiers (+)
SupportsMultipleResultSets (+)
SupportsMultipleTransactions (+)
SupportsNonNullableColumns (+)
SupportsOpenCursorsAcrossCommit (+)
SupportsOpenCursorsAcrossRollback (+)
SupportsOpenStatementsAcrossCommit (+)
SupportsOpenStatementsAcrossRollback (+)
SupportsOrderByUnrelated (+)
SupportsOuterJoins (+)
SupportsPositionedDelete (+)
SupportsPositionedUpdate (+)
SupportsResultSetConcurrency (+)
SupportsResultSetType (+)
SupportsSchemasInDataManipulation (+)
SupportsSchemasInIndexDefinitions (+)
SupportsSchemasInPrivilegeDefinitions (+)
SupportsSchemasInProcedureCalls (+)
SupportsSchemasInTableDefinitions (+)
SupportsSelectForUpdate (+)
SupportsStoredProcedures (+)
SupportsSubqueriesInComparisons (+)
SupportsSubqueriesInExists (+)
SupportsSubqueriesInIns (+)
SupportsSubqueriesInQuantifieds (+)
SupportsTableCorrelationNames (+)
SupportsTransactionIsolationLevel (+)
SupportsTransactions (+)
SupportsUnion (+)
SupportsUnionAll (+)
UsesLocalFilePerTable (+)
UsesLocalFiles (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZConnection)
Next (IZDriver)


Previous
Next (AllProceduresAreCallable)

Name
AddEscapeCharToWildcards

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AddEscapeCharToWildcards ( const Pattern : string ) : string

Parameters
Parameter Description
Pattern : STRING

mAirListScript
Class Tree
Index
Previous
Next (AllProceduresAreCallable)


Previous (AddEscapeCharToWildcards)
Next (AllTablesAreSelectable)

Name
AllProceduresAreCallable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AllProceduresAreCallable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddEscapeCharToWildcards)
Next (AllTablesAreSelectable)


Previous (AllProceduresAreCallable)
Next (ClearCache)

Name
AllTablesAreSelectable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AllTablesAreSelectable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AllProceduresAreCallable)
Next (ClearCache)


Previous (AllTablesAreSelectable)
Next (DataDefinitionCausesTransactionCommit)

Name
ClearCache

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
procedure ClearCache

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AllTablesAreSelectable)
Next (DataDefinitionCausesTransactionCommit)


Previous (ClearCache)
Next (DataDefinitionIgnoredInTransactions)

Name
DataDefinitionCausesTransactionCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DataDefinitionCausesTransactionCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearCache)
Next (DataDefinitionIgnoredInTransactions)


Previous (DataDefinitionCausesTransactionCommit)
Next (DoesMaxRowSizeIncludeBlobs)

Name
DataDefinitionIgnoredInTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DataDefinitionIgnoredInTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DataDefinitionCausesTransactionCommit)
Next (DoesMaxRowSizeIncludeBlobs)


Previous (DataDefinitionIgnoredInTransactions)
Next (GetBestRowIdentifier)

Name
DoesMaxRowSizeIncludeBlobs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DoesMaxRowSizeIncludeBlobs : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DataDefinitionIgnoredInTransactions)
Next (GetBestRowIdentifier)


Previous (DoesMaxRowSizeIncludeBlobs)
Next (GetCatalogs)

Name
GetBestRowIdentifier

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetBestRowIdentifier ( const Catalog : string ; const Schema : string ; const Table : string ; Scope : Integer ; Nullable : Boolean ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
Scope : INTEGER
Nullable : BOOLEAN

mAirListScript
Class Tree
Index
Previous (DoesMaxRowSizeIncludeBlobs)
Next (GetCatalogs)


Previous (GetBestRowIdentifier)
Next (GetCatalogSeparator)

Name
GetCatalogs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogs : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBestRowIdentifier)
Next (GetCatalogSeparator)


Previous (GetCatalogs)
Next (GetCatalogTerm)

Name
GetCatalogSeparator

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogSeparator : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogs)
Next (GetCatalogTerm)


Previous (GetCatalogSeparator)
Next (GetColumnPrivileges)

Name
GetCatalogTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogSeparator)
Next (GetColumnPrivileges)


Previous (GetCatalogTerm)
Next (GetColumns)

Name
GetColumnPrivileges

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetColumnPrivileges ( const Catalog : string ; const Schema : string ; const Table : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetCatalogTerm)
Next (GetColumns)


Previous (GetColumnPrivileges)
Next (GetConnection)

Name
GetColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetColumns ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetColumnPrivileges)
Next (GetConnection)


Previous (GetColumns)
Next (GetCrossReference)

Name
GetConnection

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColumns)
Next (GetCrossReference)


Previous (GetConnection)
Next (GetDatabaseProductName)

Name
GetCrossReference

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCrossReference ( const PrimaryCatalog : string ; const PrimarySchema : string ; const PrimaryTable : string ; const ForeignCatalog : string ; const ForeignSchema : string ; const ForeignTable : string ) : IZResultSet

Parameters
Parameter Description
PrimaryCatalog : STRING
PrimarySchema : STRING
PrimaryTable : STRING
ForeignCatalog : STRING
ForeignSchema : STRING
ForeignTable : STRING

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetDatabaseProductName)


Previous (GetCrossReference)
Next (GetDatabaseProductVersion)

Name
GetDatabaseProductName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDatabaseProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCrossReference)
Next (GetDatabaseProductVersion)


Previous (GetDatabaseProductName)
Next (GetDefaultTransactionIsolation)

Name
GetDatabaseProductVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDatabaseProductVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseProductName)
Next (GetDefaultTransactionIsolation)


Previous (GetDatabaseProductVersion)
Next (GetDriverMajorVersion)

Name
GetDefaultTransactionIsolation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDefaultTransactionIsolation : TZTransactIsolationLevel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseProductVersion)
Next (GetDriverMajorVersion)


Previous (GetDefaultTransactionIsolation)
Next (GetDriverMinorVersion)

Name
GetDriverMajorVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverMajorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultTransactionIsolation)
Next (GetDriverMinorVersion)


Previous (GetDriverMajorVersion)
Next (GetDriverName)

Name
GetDriverMinorVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverMinorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverMajorVersion)
Next (GetDriverName)


Previous (GetDriverMinorVersion)
Next (GetDriverVersion)

Name
GetDriverName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverMinorVersion)
Next (GetDriverVersion)


Previous (GetDriverName)
Next (GetExportedKeys)

Name
GetDriverVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverName)
Next (GetExportedKeys)


Previous (GetDriverVersion)
Next (GetExtraNameCharacters)

Name
GetExportedKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetExportedKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetDriverVersion)
Next (GetExtraNameCharacters)


Previous (GetExportedKeys)
Next (GetIdentifierConvertor)

Name
GetExtraNameCharacters

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetExtraNameCharacters : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExportedKeys)
Next (GetIdentifierConvertor)


Previous (GetExtraNameCharacters)
Next (GetIdentifierQuoteString)

Name
GetIdentifierConvertor

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIdentifierConvertor : IZIdentifierConvertor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExtraNameCharacters)
Next (GetIdentifierQuoteString)


Previous (GetIdentifierConvertor)
Next (GetImportedKeys)

Name
GetIdentifierQuoteString

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIdentifierQuoteString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIdentifierConvertor)
Next (GetImportedKeys)


Previous (GetIdentifierQuoteString)
Next (GetIndexInfo)

Name
GetImportedKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetImportedKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetIdentifierQuoteString)
Next (GetIndexInfo)


Previous (GetImportedKeys)
Next (GetMaxBinaryLiteralLength)

Name
GetIndexInfo

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIndexInfo ( const Catalog : string ; const Schema : string ; const Table : string ; Unique : Boolean ; Approximate : Boolean ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
Unique : BOOLEAN
Approximate : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetImportedKeys)
Next (GetMaxBinaryLiteralLength)


Previous (GetIndexInfo)
Next (GetMaxCatalogNameLength)

Name
GetMaxBinaryLiteralLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxBinaryLiteralLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndexInfo)
Next (GetMaxCatalogNameLength)


Previous (GetMaxBinaryLiteralLength)
Next (GetMaxCharLiteralLength)

Name
GetMaxCatalogNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCatalogNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxBinaryLiteralLength)
Next (GetMaxCharLiteralLength)


Previous (GetMaxCatalogNameLength)
Next (GetMaxColumnNameLength)

Name
GetMaxCharLiteralLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCharLiteralLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCatalogNameLength)
Next (GetMaxColumnNameLength)


Previous (GetMaxCharLiteralLength)
Next (GetMaxColumnsInGroupBy)

Name
GetMaxColumnNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCharLiteralLength)
Next (GetMaxColumnsInGroupBy)


Previous (GetMaxColumnNameLength)
Next (GetMaxColumnsInIndex)

Name
GetMaxColumnsInGroupBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInGroupBy : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnNameLength)
Next (GetMaxColumnsInIndex)


Previous (GetMaxColumnsInGroupBy)
Next (GetMaxColumnsInOrderBy)

Name
GetMaxColumnsInIndex

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInIndex : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInGroupBy)
Next (GetMaxColumnsInOrderBy)


Previous (GetMaxColumnsInIndex)
Next (GetMaxColumnsInSelect)

Name
GetMaxColumnsInOrderBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInOrderBy : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInIndex)
Next (GetMaxColumnsInSelect)


Previous (GetMaxColumnsInOrderBy)
Next (GetMaxColumnsInTable)

Name
GetMaxColumnsInSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInSelect : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInOrderBy)
Next (GetMaxColumnsInTable)


Previous (GetMaxColumnsInSelect)
Next (GetMaxConnections)

Name
GetMaxColumnsInTable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInTable : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInSelect)
Next (GetMaxConnections)


Previous (GetMaxColumnsInTable)
Next (GetMaxCursorNameLength)

Name
GetMaxConnections

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxConnections : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInTable)
Next (GetMaxCursorNameLength)


Previous (GetMaxConnections)
Next (GetMaxIndexLength)

Name
GetMaxCursorNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCursorNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxConnections)
Next (GetMaxIndexLength)


Previous (GetMaxCursorNameLength)
Next (GetMaxProcedureNameLength)

Name
GetMaxIndexLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxIndexLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCursorNameLength)
Next (GetMaxProcedureNameLength)


Previous (GetMaxIndexLength)
Next (GetMaxRowSize)

Name
GetMaxProcedureNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxProcedureNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxIndexLength)
Next (GetMaxRowSize)


Previous (GetMaxProcedureNameLength)
Next (GetMaxSchemaNameLength)

Name
GetMaxRowSize

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxRowSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxProcedureNameLength)
Next (GetMaxSchemaNameLength)


Previous (GetMaxRowSize)
Next (GetMaxStatementLength)

Name
GetMaxSchemaNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxSchemaNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxRowSize)
Next (GetMaxStatementLength)


Previous (GetMaxSchemaNameLength)
Next (GetMaxStatements)

Name
GetMaxStatementLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxStatementLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxSchemaNameLength)
Next (GetMaxStatements)


Previous (GetMaxStatementLength)
Next (GetMaxTableNameLength)

Name
GetMaxStatements

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxStatements : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxStatementLength)
Next (GetMaxTableNameLength)


Previous (GetMaxStatements)
Next (GetMaxTablesInSelect)

Name
GetMaxTableNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxTableNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxStatements)
Next (GetMaxTablesInSelect)


Previous (GetMaxTableNameLength)
Next (GetMaxUserNameLength)

Name
GetMaxTablesInSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxTablesInSelect : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxTableNameLength)
Next (GetMaxUserNameLength)


Previous (GetMaxTablesInSelect)
Next (GetNumericFunctions)

Name
GetMaxUserNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxUserNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxTablesInSelect)
Next (GetNumericFunctions)


Previous (GetMaxUserNameLength)
Next (GetPrimaryKeys)

Name
GetNumericFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetNumericFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxUserNameLength)
Next (GetPrimaryKeys)


Previous (GetNumericFunctions)
Next (GetProcedureColumns)

Name
GetPrimaryKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetPrimaryKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetNumericFunctions)
Next (GetProcedureColumns)


Previous (GetPrimaryKeys)
Next (GetProcedures)

Name
GetProcedureColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedureColumns ( const Catalog : string ; const SchemaPattern : string ; const ProcedureNamePattern : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
ProcedureNamePattern : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetPrimaryKeys)
Next (GetProcedures)


Previous (GetProcedureColumns)
Next (GetProcedureTerm)

Name
GetProcedures

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedures ( const Catalog : string ; const SchemaPattern : string ; const ProcedureNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
ProcedureNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetProcedureColumns)
Next (GetProcedureTerm)


Previous (GetProcedures)
Next (GetSchemas)

Name
GetProcedureTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedureTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProcedures)
Next (GetSchemas)


Previous (GetProcedureTerm)
Next (GetSchemaTerm)

Name
GetSchemas

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSchemas : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProcedureTerm)
Next (GetSchemaTerm)


Previous (GetSchemas)
Next (GetSearchStringEscape)

Name
GetSchemaTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSchemaTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSchemas)
Next (GetSearchStringEscape)


Previous (GetSchemaTerm)
Next (GetSequences)

Name
GetSearchStringEscape

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSearchStringEscape : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSchemaTerm)
Next (GetSequences)


Previous (GetSearchStringEscape)
Next (GetSQLKeywords)

Name
GetSequences

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSequences ( const Catalog : string ; const SchemaPattern : string ; const SequenceNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
SequenceNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetSearchStringEscape)
Next (GetSQLKeywords)


Previous (GetSequences)
Next (GetStringFunctions)

Name
GetSQLKeywords

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSQLKeywords : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSequences)
Next (GetStringFunctions)


Previous (GetSQLKeywords)
Next (GetSystemFunctions)

Name
GetStringFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetStringFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSQLKeywords)
Next (GetSystemFunctions)


Previous (GetStringFunctions)
Next (GetTablePrivileges)

Name
GetSystemFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSystemFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStringFunctions)
Next (GetTablePrivileges)


Previous (GetSystemFunctions)
Next (GetTables)

Name
GetTablePrivileges

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTablePrivileges ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetSystemFunctions)
Next (GetTables)


Previous (GetTablePrivileges)
Next (GetTableTypes)

Name
GetTables

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTables ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ; const Types : TStringDynArray ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING
Types : TStringDynArray

mAirListScript
Class Tree
Index
Previous (GetTablePrivileges)
Next (GetTableTypes)


Previous (GetTables)
Next (GetTimeDateFunctions)

Name
GetTableTypes

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTableTypes : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTables)
Next (GetTimeDateFunctions)


Previous (GetTableTypes)
Next (GetTypeInfo)

Name
GetTimeDateFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTimeDateFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTableTypes)
Next (GetTypeInfo)


Previous (GetTimeDateFunctions)
Next (GetUDTs)

Name
GetTypeInfo

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTypeInfo : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeDateFunctions)
Next (GetUDTs)


Previous (GetTypeInfo)
Next (GetURL)

Name
GetUDTs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetUDTs ( const Catalog : string ; const SchemaPattern : string ; const TypeNamePattern : string ; const Types : TIntegerDynArray ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TypeNamePattern : STRING
Types : TIntegerDynArray

mAirListScript
Class Tree
Index
Previous (GetTypeInfo)
Next (GetURL)


Previous (GetUDTs)
Next (GetUserName)

Name
GetURL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUDTs)
Next (GetUserName)


Previous (GetURL)
Next (GetVersionColumns)

Name
GetUserName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetUserName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetURL)
Next (GetVersionColumns)


Previous (GetUserName)
Next (IsCatalogAtStart)

Name
GetVersionColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetVersionColumns ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetUserName)
Next (IsCatalogAtStart)


Previous (GetVersionColumns)
Next (IsReadOnly)

Name
IsCatalogAtStart

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function IsCatalogAtStart : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVersionColumns)
Next (IsReadOnly)


Previous (IsCatalogAtStart)
Next (NullPlusNonNullIsNull)

Name
IsReadOnly

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function IsReadOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCatalogAtStart)
Next (NullPlusNonNullIsNull)


Previous (IsReadOnly)
Next (NullsAreSortedAtEnd)

Name
NullPlusNonNullIsNull

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullPlusNonNullIsNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (NullsAreSortedAtEnd)


Previous (NullPlusNonNullIsNull)
Next (NullsAreSortedAtStart)

Name
NullsAreSortedAtEnd

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedAtEnd : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullPlusNonNullIsNull)
Next (NullsAreSortedAtStart)


Previous (NullsAreSortedAtEnd)
Next (NullsAreSortedHigh)

Name
NullsAreSortedAtStart

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedAtStart : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedAtEnd)
Next (NullsAreSortedHigh)


Previous (NullsAreSortedAtStart)
Next (NullsAreSortedLow)

Name
NullsAreSortedHigh

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedHigh : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedAtStart)
Next (NullsAreSortedLow)


Previous (NullsAreSortedHigh)
Next (StoresLowerCaseIdentifiers)

Name
NullsAreSortedLow

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedLow : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedHigh)
Next (StoresLowerCaseIdentifiers)


Previous (NullsAreSortedLow)
Next (StoresLowerCaseQuotedIdentifiers)

Name
StoresLowerCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresLowerCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedLow)
Next (StoresLowerCaseQuotedIdentifiers)


Previous (StoresLowerCaseIdentifiers)
Next (StoresMixedCaseIdentifiers)

Name
StoresLowerCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresLowerCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresLowerCaseIdentifiers)
Next (StoresMixedCaseIdentifiers)


Previous (StoresLowerCaseQuotedIdentifiers)
Next (StoresMixedCaseQuotedIdentifiers)

Name
StoresMixedCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresMixedCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresLowerCaseQuotedIdentifiers)
Next (StoresMixedCaseQuotedIdentifiers)


Previous (StoresMixedCaseIdentifiers)
Next (StoresUpperCaseIdentifiers)

Name
StoresMixedCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresMixedCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresMixedCaseIdentifiers)
Next (StoresUpperCaseIdentifiers)


Previous (StoresMixedCaseQuotedIdentifiers)
Next (StoresUpperCaseQuotedIdentifiers)

Name
StoresUpperCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresUpperCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresMixedCaseQuotedIdentifiers)
Next (StoresUpperCaseQuotedIdentifiers)


Previous (StoresUpperCaseIdentifiers)
Next (SupportsAlterTableWithAddColumn)

Name
StoresUpperCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresUpperCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresUpperCaseIdentifiers)
Next (SupportsAlterTableWithAddColumn)


Previous (StoresUpperCaseQuotedIdentifiers)
Next (SupportsAlterTableWithDropColumn)

Name
SupportsAlterTableWithAddColumn

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsAlterTableWithAddColumn : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresUpperCaseQuotedIdentifiers)
Next (SupportsAlterTableWithDropColumn)


Previous (SupportsAlterTableWithAddColumn)
Next (SupportsANSI92EntryLevelSQL)

Name
SupportsAlterTableWithDropColumn

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsAlterTableWithDropColumn : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsAlterTableWithAddColumn)
Next (SupportsANSI92EntryLevelSQL)


Previous (SupportsAlterTableWithDropColumn)
Next (SupportsANSI92FullSQL)

Name
SupportsANSI92EntryLevelSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92EntryLevelSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsAlterTableWithDropColumn)
Next (SupportsANSI92FullSQL)


Previous (SupportsANSI92EntryLevelSQL)
Next (SupportsANSI92IntermediateSQL)

Name
SupportsANSI92FullSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92FullSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92EntryLevelSQL)
Next (SupportsANSI92IntermediateSQL)


Previous (SupportsANSI92FullSQL)
Next (SupportsBatchUpdates)

Name
SupportsANSI92IntermediateSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92IntermediateSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92FullSQL)
Next (SupportsBatchUpdates)


Previous (SupportsANSI92IntermediateSQL)
Next (SupportsCatalogsInDataManipulation)

Name
SupportsBatchUpdates

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsBatchUpdates : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92IntermediateSQL)
Next (SupportsCatalogsInDataManipulation)


Previous (SupportsBatchUpdates)
Next (SupportsCatalogsInIndexDefinitions)

Name
SupportsCatalogsInDataManipulation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInDataManipulation : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsBatchUpdates)
Next (SupportsCatalogsInIndexDefinitions)


Previous (SupportsCatalogsInDataManipulation)
Next (SupportsCatalogsInPrivilegeDefinitions)

Name
SupportsCatalogsInIndexDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInIndexDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInDataManipulation)
Next (SupportsCatalogsInPrivilegeDefinitions)


Previous (SupportsCatalogsInIndexDefinitions)
Next (SupportsCatalogsInProcedureCalls)

Name
SupportsCatalogsInPrivilegeDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInPrivilegeDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInIndexDefinitions)
Next (SupportsCatalogsInProcedureCalls)


Previous (SupportsCatalogsInPrivilegeDefinitions)
Next (SupportsCatalogsInTableDefinitions)

Name
SupportsCatalogsInProcedureCalls

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInProcedureCalls : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInPrivilegeDefinitions)
Next (SupportsCatalogsInTableDefinitions)


Previous (SupportsCatalogsInProcedureCalls)
Next (SupportsColumnAliasing)

Name
SupportsCatalogsInTableDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInTableDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInProcedureCalls)
Next (SupportsColumnAliasing)


Previous (SupportsCatalogsInTableDefinitions)
Next (SupportsConvert)

Name
SupportsColumnAliasing

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsColumnAliasing : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInTableDefinitions)
Next (SupportsConvert)


Previous (SupportsColumnAliasing)
Next (SupportsConvertForTypes)

Name
SupportsConvert

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsConvert : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsColumnAliasing)
Next (SupportsConvertForTypes)


Previous (SupportsConvert)
Next (SupportsCoreSQLGrammar)

Name
SupportsConvertForTypes

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsConvertForTypes ( FromType : TZSQLType ; ToType : TZSQLType ) : Boolean

Parameters
Parameter Description
FromType : TZSQLType
ToType : TZSQLType

mAirListScript
Class Tree
Index
Previous (SupportsConvert)
Next (SupportsCoreSQLGrammar)


Previous (SupportsConvertForTypes)
Next (SupportsCorrelatedSubqueries)

Name
SupportsCoreSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCoreSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsConvertForTypes)
Next (SupportsCorrelatedSubqueries)


Previous (SupportsCoreSQLGrammar)
Next (SupportsDataDefinitionAndDataManipulationTransactions)

Name
SupportsCorrelatedSubqueries

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCorrelatedSubqueries : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCoreSQLGrammar)
Next (SupportsDataDefinitionAndDataManipulationTransactions)


Previous (SupportsCorrelatedSubqueries)
Next (SupportsDataManipulationTransactionsOnly)

Name
SupportsDataDefinitionAndDataManipulationTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDataDefinitionAndDataManipulationTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCorrelatedSubqueries)
Next (SupportsDataManipulationTransactionsOnly)


Previous (SupportsDataDefinitionAndDataManipulationTransactions)
Next (SupportsDifferentTableCorrelationNames)

Name
SupportsDataManipulationTransactionsOnly

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDataManipulationTransactionsOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDataDefinitionAndDataManipulationTransactions)
Next (SupportsDifferentTableCorrelationNames)


Previous (SupportsDataManipulationTransactionsOnly)
Next (SupportsExpressionsInOrderBy)

Name
SupportsDifferentTableCorrelationNames

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDifferentTableCorrelationNames : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDataManipulationTransactionsOnly)
Next (SupportsExpressionsInOrderBy)


Previous (SupportsDifferentTableCorrelationNames)
Next (SupportsExtendedSQLGrammar)

Name
SupportsExpressionsInOrderBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsExpressionsInOrderBy : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDifferentTableCorrelationNames)
Next (SupportsExtendedSQLGrammar)


Previous (SupportsExpressionsInOrderBy)
Next (SupportsFullOuterJoins)

Name
SupportsExtendedSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsExtendedSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsExpressionsInOrderBy)
Next (SupportsFullOuterJoins)


Previous (SupportsExtendedSQLGrammar)
Next (SupportsGroupBy)

Name
SupportsFullOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsFullOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsExtendedSQLGrammar)
Next (SupportsGroupBy)


Previous (SupportsFullOuterJoins)
Next (SupportsGroupByBeyondSelect)

Name
SupportsGroupBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupBy : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsFullOuterJoins)
Next (SupportsGroupByBeyondSelect)


Previous (SupportsGroupBy)
Next (SupportsGroupByUnrelated)

Name
SupportsGroupByBeyondSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupByBeyondSelect : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupBy)
Next (SupportsGroupByUnrelated)


Previous (SupportsGroupByBeyondSelect)
Next (SupportsIntegrityEnhancementFacility)

Name
SupportsGroupByUnrelated

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupByUnrelated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupByBeyondSelect)
Next (SupportsIntegrityEnhancementFacility)


Previous (SupportsGroupByUnrelated)
Next (SupportsLikeEscapeClause)

Name
SupportsIntegrityEnhancementFacility

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsIntegrityEnhancementFacility : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupByUnrelated)
Next (SupportsLikeEscapeClause)


Previous (SupportsIntegrityEnhancementFacility)
Next (SupportsLimitedOuterJoins)

Name
SupportsLikeEscapeClause

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsLikeEscapeClause : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsIntegrityEnhancementFacility)
Next (SupportsLimitedOuterJoins)


Previous (SupportsLikeEscapeClause)
Next (SupportsMinimumSQLGrammar)

Name
SupportsLimitedOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsLimitedOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsLikeEscapeClause)
Next (SupportsMinimumSQLGrammar)


Previous (SupportsLimitedOuterJoins)
Next (SupportsMixedCaseIdentifiers)

Name
SupportsMinimumSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMinimumSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsLimitedOuterJoins)
Next (SupportsMixedCaseIdentifiers)


Previous (SupportsMinimumSQLGrammar)
Next (SupportsMixedCaseQuotedIdentifiers)

Name
SupportsMixedCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMixedCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMinimumSQLGrammar)
Next (SupportsMixedCaseQuotedIdentifiers)


Previous (SupportsMixedCaseIdentifiers)
Next (SupportsMultipleResultSets)

Name
SupportsMixedCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMixedCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMixedCaseIdentifiers)
Next (SupportsMultipleResultSets)


Previous (SupportsMixedCaseQuotedIdentifiers)
Next (SupportsMultipleTransactions)

Name
SupportsMultipleResultSets

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMultipleResultSets : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMixedCaseQuotedIdentifiers)
Next (SupportsMultipleTransactions)


Previous (SupportsMultipleResultSets)
Next (SupportsNonNullableColumns)

Name
SupportsMultipleTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMultipleTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMultipleResultSets)
Next (SupportsNonNullableColumns)


Previous (SupportsMultipleTransactions)
Next (SupportsOpenCursorsAcrossCommit)

Name
SupportsNonNullableColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsNonNullableColumns : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMultipleTransactions)
Next (SupportsOpenCursorsAcrossCommit)


Previous (SupportsNonNullableColumns)
Next (SupportsOpenCursorsAcrossRollback)

Name
SupportsOpenCursorsAcrossCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenCursorsAcrossCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsNonNullableColumns)
Next (SupportsOpenCursorsAcrossRollback)


Previous (SupportsOpenCursorsAcrossCommit)
Next (SupportsOpenStatementsAcrossCommit)

Name
SupportsOpenCursorsAcrossRollback

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenCursorsAcrossRollback : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenCursorsAcrossCommit)
Next (SupportsOpenStatementsAcrossCommit)


Previous (SupportsOpenCursorsAcrossRollback)
Next (SupportsOpenStatementsAcrossRollback)

Name
SupportsOpenStatementsAcrossCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenStatementsAcrossCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenCursorsAcrossRollback)
Next (SupportsOpenStatementsAcrossRollback)


Previous (SupportsOpenStatementsAcrossCommit)
Next (SupportsOrderByUnrelated)

Name
SupportsOpenStatementsAcrossRollback

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenStatementsAcrossRollback : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenStatementsAcrossCommit)
Next (SupportsOrderByUnrelated)


Previous (SupportsOpenStatementsAcrossRollback)
Next (SupportsOuterJoins)

Name
SupportsOrderByUnrelated

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOrderByUnrelated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenStatementsAcrossRollback)
Next (SupportsOuterJoins)


Previous (SupportsOrderByUnrelated)
Next (SupportsPositionedDelete)

Name
SupportsOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOrderByUnrelated)
Next (SupportsPositionedDelete)


Previous (SupportsOuterJoins)
Next (SupportsPositionedUpdate)

Name
SupportsPositionedDelete

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsPositionedDelete : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOuterJoins)
Next (SupportsPositionedUpdate)


Previous (SupportsPositionedDelete)
Next (SupportsResultSetConcurrency)

Name
SupportsPositionedUpdate

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsPositionedUpdate : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsPositionedDelete)
Next (SupportsResultSetConcurrency)


Previous (SupportsPositionedUpdate)
Next (SupportsResultSetType)

Name
SupportsResultSetConcurrency

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsResultSetConcurrency ( _Type : TZResultSetType ; Concurrency : TZResultSetConcurrency ) : Boolean

Parameters
Parameter Description
_Type : TZResultSetType
Concurrency : TZResultSetConcurrency

mAirListScript
Class Tree
Index
Previous (SupportsPositionedUpdate)
Next (SupportsResultSetType)


Previous (SupportsResultSetConcurrency)
Next (SupportsSchemasInDataManipulation)

Name
SupportsResultSetType

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsResultSetType ( _Type : TZResultSetType ) : Boolean

Parameters
Parameter Description
_Type : TZResultSetType

mAirListScript
Class Tree
Index
Previous (SupportsResultSetConcurrency)
Next (SupportsSchemasInDataManipulation)


Previous (SupportsResultSetType)
Next (SupportsSchemasInIndexDefinitions)

Name
SupportsSchemasInDataManipulation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInDataManipulation : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsResultSetType)
Next (SupportsSchemasInIndexDefinitions)


Previous (SupportsSchemasInDataManipulation)
Next (SupportsSchemasInPrivilegeDefinitions)

Name
SupportsSchemasInIndexDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInIndexDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInDataManipulation)
Next (SupportsSchemasInPrivilegeDefinitions)


Previous (SupportsSchemasInIndexDefinitions)
Next (SupportsSchemasInProcedureCalls)

Name
SupportsSchemasInPrivilegeDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInPrivilegeDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInIndexDefinitions)
Next (SupportsSchemasInProcedureCalls)


Previous (SupportsSchemasInPrivilegeDefinitions)
Next (SupportsSchemasInTableDefinitions)

Name
SupportsSchemasInProcedureCalls

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInProcedureCalls : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInPrivilegeDefinitions)
Next (SupportsSchemasInTableDefinitions)


Previous (SupportsSchemasInProcedureCalls)
Next (SupportsSelectForUpdate)

Name
SupportsSchemasInTableDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInTableDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInProcedureCalls)
Next (SupportsSelectForUpdate)


Previous (SupportsSchemasInTableDefinitions)
Next (SupportsStoredProcedures)

Name
SupportsSelectForUpdate

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSelectForUpdate : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInTableDefinitions)
Next (SupportsStoredProcedures)


Previous (SupportsSelectForUpdate)
Next (SupportsSubqueriesInComparisons)

Name
SupportsStoredProcedures

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsStoredProcedures : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSelectForUpdate)
Next (SupportsSubqueriesInComparisons)


Previous (SupportsStoredProcedures)
Next (SupportsSubqueriesInExists)

Name
SupportsSubqueriesInComparisons

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInComparisons : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsStoredProcedures)
Next (SupportsSubqueriesInExists)


Previous (SupportsSubqueriesInComparisons)
Next (SupportsSubqueriesInIns)

Name
SupportsSubqueriesInExists

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInExists : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInComparisons)
Next (SupportsSubqueriesInIns)


Previous (SupportsSubqueriesInExists)
Next (SupportsSubqueriesInQuantifieds)

Name
SupportsSubqueriesInIns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInIns : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInExists)
Next (SupportsSubqueriesInQuantifieds)


Previous (SupportsSubqueriesInIns)
Next (SupportsTableCorrelationNames)

Name
SupportsSubqueriesInQuantifieds

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInQuantifieds : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInIns)
Next (SupportsTableCorrelationNames)


Previous (SupportsSubqueriesInQuantifieds)
Next (SupportsTransactionIsolationLevel)

Name
SupportsTableCorrelationNames

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTableCorrelationNames : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInQuantifieds)
Next (SupportsTransactionIsolationLevel)


Previous (SupportsTableCorrelationNames)
Next (SupportsTransactions)

Name
SupportsTransactionIsolationLevel

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTransactionIsolationLevel ( Level : TZTransactIsolationLevel ) : Boolean

Parameters
Parameter Description
Level : TZTransactIsolationLevel

mAirListScript
Class Tree
Index
Previous (SupportsTableCorrelationNames)
Next (SupportsTransactions)


Previous (SupportsTransactionIsolationLevel)
Next (SupportsUnion)

Name
SupportsTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsTransactionIsolationLevel)
Next (SupportsUnion)


Previous (SupportsTransactions)
Next (SupportsUnionAll)

Name
SupportsUnion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsUnion : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsTransactions)
Next (SupportsUnionAll)


Previous (SupportsUnion)
Next (UsesLocalFilePerTable)

Name
SupportsUnionAll

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsUnionAll : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsUnion)
Next (UsesLocalFilePerTable)


Previous (SupportsUnionAll)
Next (UsesLocalFiles)

Name
UsesLocalFilePerTable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function UsesLocalFilePerTable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsUnionAll)
Next (UsesLocalFiles)


Previous (UsesLocalFilePerTable)
Next

Name
UsesLocalFiles

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function UsesLocalFiles : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UsesLocalFilePerTable)
Next


Previous (IZDatabaseMetadata)
Next (IZDriverManager)

Name
IZDriver

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AcceptsURL (+)
Connect (+)
GetClientVersion (+)
GetMajorVersion (+)
GetMinorVersion (+)
GetPropertyInfo (+)
GetStatementAnalyser (+)
GetSubVersion (+)
GetSupportedProtocols (+)
GetTokenizer (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDatabaseMetadata)
Next (IZDriverManager)


Previous
Next (Connect)

Name
AcceptsURL

Parent
IZDriver

Visibility
PUBLIC

Source code
function AcceptsURL ( const Url : string ) : Boolean

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous
Next (Connect)


Previous (AcceptsURL)
Next (GetClientVersion)

Name
Connect

Parent
IZDriver

Visibility
PUBLIC

Source code
function Connect ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (AcceptsURL)
Next (GetClientVersion)


Previous (Connect)
Next (GetMajorVersion)

Name
GetClientVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (Connect)
Next (GetMajorVersion)


Previous (GetClientVersion)
Next (GetMinorVersion)

Name
GetMajorVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetMajorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetMinorVersion)


Previous (GetMajorVersion)
Next (GetPropertyInfo)

Name
GetMinorVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetMinorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMajorVersion)
Next (GetPropertyInfo)


Previous (GetMinorVersion)
Next (GetStatementAnalyser)

Name
GetPropertyInfo

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetPropertyInfo ( const Url : string ; Info : TStrings ) : TStrings

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (GetMinorVersion)
Next (GetStatementAnalyser)


Previous (GetPropertyInfo)
Next (GetSubVersion)

Name
GetStatementAnalyser

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetStatementAnalyser : IZStatementAnalyser

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPropertyInfo)
Next (GetSubVersion)


Previous (GetStatementAnalyser)
Next (GetSupportedProtocols)

Name
GetSubVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetSubVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStatementAnalyser)
Next (GetSupportedProtocols)


Previous (GetSubVersion)
Next (GetTokenizer)

Name
GetSupportedProtocols

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetSupportedProtocols : TStringDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSubVersion)
Next (GetTokenizer)


Previous (GetSupportedProtocols)
Next

Name
GetTokenizer

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetTokenizer : IZTokenizer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSupportedProtocols)
Next


Previous (IZDriver)
Next (IZNotification)

Name
IZDriverManager

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddLoggingListener (+)
DeregisterDriver (+)
GetClientVersion (+)
GetConnection (+)
GetConnectionWithLogin (+)
GetConnectionWithParams (+)
GetDriver (+)
GetDrivers (+)
GetLoginTimeout (+)
LogError (+)
LogMessage (+)
RegisterDriver (+)
RemoveLoggingListener (+)
SetLoginTimeout (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDriver)
Next (IZNotification)


Previous
Next (DeregisterDriver)

Name
AddLoggingListener

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure AddLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter Description
Listener : IZLoggingListener

mAirListScript
Class Tree
Index
Previous
Next (DeregisterDriver)


Previous (AddLoggingListener)
Next (GetClientVersion)

Name
DeregisterDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure DeregisterDriver ( Driver : IZDriver )

Parameters
Parameter Description
Driver : IZDriver

mAirListScript
Class Tree
Index
Previous (AddLoggingListener)
Next (GetClientVersion)


Previous (DeregisterDriver)
Next (GetConnection)

Name
GetClientVersion

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (DeregisterDriver)
Next (GetConnection)


Previous (GetClientVersion)
Next (GetConnectionWithLogin)

Name
GetConnection

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnection ( const Url : string ) : IZConnection

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetConnectionWithLogin)


Previous (GetConnection)
Next (GetConnectionWithParams)

Name
GetConnectionWithLogin

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnectionWithLogin ( const Url : string ; const User : string ; const Password : string ) : IZConnection

Parameters
Parameter Description
Url : STRING
User : STRING
Password : STRING

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetConnectionWithParams)


Previous (GetConnectionWithLogin)
Next (GetDriver)

Name
GetConnectionWithParams

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnectionWithParams ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (GetConnectionWithLogin)
Next (GetDriver)


Previous (GetConnectionWithParams)
Next (GetDrivers)

Name
GetDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetDriver ( const Url : string ) : IZDriver

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (GetConnectionWithParams)
Next (GetDrivers)


Previous (GetDriver)
Next (GetLoginTimeout)

Name
GetDrivers

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetDrivers : IZCollection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetLoginTimeout)


Previous (GetDrivers)
Next (LogError)

Name
GetLoginTimeout

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetLoginTimeout : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDrivers)
Next (LogError)


Previous (GetLoginTimeout)
Next (LogMessage)

Name
LogError

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure LogError ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string ; ErrorCode : Integer ; const Error : string )

Parameters
Parameter Description
Category : TZLoggingCategory
Protocol : STRING
Msg : STRING
ErrorCode : INTEGER
Error : STRING

mAirListScript
Class Tree
Index
Previous (GetLoginTimeout)
Next (LogMessage)


Previous (LogError)
Next (RegisterDriver)

Name
LogMessage

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure LogMessage ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string )

Parameters
Parameter Description
Category : TZLoggingCategory
Protocol : STRING
Msg : STRING

mAirListScript
Class Tree
Index
Previous (LogError)
Next (RegisterDriver)


Previous (LogMessage)
Next (RemoveLoggingListener)

Name
RegisterDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure RegisterDriver ( Driver : IZDriver )

Parameters
Parameter Description
Driver : IZDriver

mAirListScript
Class Tree
Index
Previous (LogMessage)
Next (RemoveLoggingListener)


Previous (RegisterDriver)
Next (SetLoginTimeout)

Name
RemoveLoggingListener

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure RemoveLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter Description
Listener : IZLoggingListener

mAirListScript
Class Tree
Index
Previous (RegisterDriver)
Next (SetLoginTimeout)


Previous (RemoveLoggingListener)
Next

Name
SetLoginTimeout

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure SetLoginTimeout ( Seconds : Integer )

Parameters
Parameter Description
Seconds : INTEGER

mAirListScript
Class Tree
Index
Previous (RemoveLoggingListener)
Next


Previous (IZDriverManager)
Next (IZPreparedStatement)

Name
IZNotification

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
CheckEvents (+)
DoNotify (+)
GetConnection (+)
GetEvent (+)
Listen (+)
Unlisten (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDriverManager)
Next (IZPreparedStatement)


Previous
Next (DoNotify)

Name
CheckEvents

Parent
IZNotification

Visibility
PUBLIC

Source code
function CheckEvents : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (DoNotify)


Previous (CheckEvents)
Next (GetConnection)

Name
DoNotify

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure DoNotify

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckEvents)
Next (GetConnection)


Previous (DoNotify)
Next (GetEvent)

Name
GetConnection

Parent
IZNotification

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DoNotify)
Next (GetEvent)


Previous (GetConnection)
Next (Listen)

Name
GetEvent

Parent
IZNotification

Visibility
PUBLIC

Source code
function GetEvent : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (Listen)


Previous (GetEvent)
Next (Unlisten)

Name
Listen

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure Listen

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEvent)
Next (Unlisten)


Previous (Listen)
Next

Name
Unlisten

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure Unlisten

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Listen)
Next


Previous (IZNotification)
Next (IZResultSet)

Name
IZPreparedStatement

Parent
ZDbcIntfs

Class Hierarchy
IZStatement

Visibility
PUBLIC

Members
Methods
Method Description
AddBatchPrepared (+)
ClearParameters (+)
ExecutePrepared (+)
ExecuteQueryPrepared (+)
ExecuteUpdatePrepared (+)
GetMetadata (+)
SetAsciiStream (+)
SetBigDecimal (+)
SetBinaryStream (+)
SetBlob (+)
SetBoolean (+)
SetByte (+)
SetBytes (+)
SetDate (+)
SetDefaultValue (+)
SetDouble (+)
SetFloat (+)
SetInt (+)
SetLong (+)
SetNull (+)
SetPChar (+)
SetShort (+)
SetString (+)
SetTime (+)
SetTimestamp (+)
SetUnicodeStream (+)
SetUnicodeString (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZNotification)
Next (IZResultSet)


Previous
Next (ClearParameters)

Name
AddBatchPrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure AddBatchPrepared

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ClearParameters)


Previous (AddBatchPrepared)
Next (ExecutePrepared)

Name
ClearParameters

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure ClearParameters

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddBatchPrepared)
Next (ExecutePrepared)


Previous (ClearParameters)
Next (ExecuteQueryPrepared)

Name
ExecutePrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecutePrepared : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearParameters)
Next (ExecuteQueryPrepared)


Previous (ExecutePrepared)
Next (ExecuteUpdatePrepared)

Name
ExecuteQueryPrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteQueryPrepared : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecutePrepared)
Next (ExecuteUpdatePrepared)


Previous (ExecuteQueryPrepared)
Next (GetMetadata)

Name
ExecuteUpdatePrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteUpdatePrepared : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteQueryPrepared)
Next (GetMetadata)


Previous (ExecuteUpdatePrepared)
Next (SetAsciiStream)

Name
GetMetadata

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function GetMetadata : IZResultSetMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteUpdatePrepared)
Next (SetAsciiStream)


Previous (GetMetadata)
Next (SetBigDecimal)

Name
SetAsciiStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetAsciiStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (SetBigDecimal)


Previous (SetAsciiStream)
Next (SetBinaryStream)

Name
SetBigDecimal

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBigDecimal ( ParameterIndex : Integer ; Value : Extended )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (SetAsciiStream)
Next (SetBinaryStream)


Previous (SetBigDecimal)
Next (SetBlob)

Name
SetBinaryStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBinaryStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetBigDecimal)
Next (SetBlob)


Previous (SetBinaryStream)
Next (SetBoolean)

Name
SetBlob

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBlob ( ParameterIndex : Integer ; SQLType : TZSQLType ; Value : IZBlob )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : TZSQLType
Value : IZBlob

mAirListScript
Class Tree
Index
Previous (SetBinaryStream)
Next (SetBoolean)


Previous (SetBlob)
Next (SetByte)

Name
SetBoolean

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBoolean ( ParameterIndex : Integer ; Value : Boolean )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetBlob)
Next (SetByte)


Previous (SetBoolean)
Next (SetBytes)

Name
SetByte

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetByte ( ParameterIndex : Integer ; Value : ShortInt )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (SetBoolean)
Next (SetBytes)


Previous (SetByte)
Next (SetDate)

Name
SetBytes

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBytes ( ParameterIndex : Integer ; const Value : TByteDynArray )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (SetByte)
Next (SetDate)


Previous (SetBytes)
Next (SetDefaultValue)

Name
SetDate

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDate ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetBytes)
Next (SetDefaultValue)


Previous (SetDate)
Next (SetDouble)

Name
SetDefaultValue

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDefaultValue ( ParameterIndex : Integer ; const Value : string )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetDate)
Next (SetDouble)


Previous (SetDefaultValue)
Next (SetFloat)

Name
SetDouble

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDouble ( ParameterIndex : Integer ; Value : Double )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (SetDefaultValue)
Next (SetFloat)


Previous (SetDouble)
Next (SetInt)

Name
SetFloat

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFloat ( ParameterIndex : Integer ; Value : Single )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (SetDouble)
Next (SetInt)


Previous (SetFloat)
Next (SetLong)

Name
SetInt

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetInt ( ParameterIndex : Integer ; Value : Integer )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFloat)
Next (SetLong)


Previous (SetInt)
Next (SetNull)

Name
SetLong

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetLong ( ParameterIndex : Integer ; Value : Int64 )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : INT64

mAirListScript
Class Tree
Index
Previous (SetInt)
Next (SetNull)


Previous (SetLong)
Next (SetPChar)

Name
SetNull

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetNull ( ParameterIndex : Integer ; SQLType : TZSQLType )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : TZSQLType

mAirListScript
Class Tree
Index
Previous (SetLong)
Next (SetPChar)


Previous (SetNull)
Next (SetShort)

Name
SetPChar

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetPChar ( ParameterIndex : Integer ; Value : PChar )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (SetNull)
Next (SetShort)


Previous (SetPChar)
Next (SetString)

Name
SetShort

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetShort ( ParameterIndex : Integer ; Value : SmallInt )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (SetPChar)
Next (SetString)


Previous (SetShort)
Next (SetTime)

Name
SetString

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetString ( ParameterIndex : Integer ; const Value : string )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetShort)
Next (SetTime)


Previous (SetString)
Next (SetTimestamp)

Name
SetTime

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTime ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetString)
Next (SetTimestamp)


Previous (SetTime)
Next (SetUnicodeStream)

Name
SetTimestamp

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTimestamp ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetTime)
Next (SetUnicodeStream)


Previous (SetTimestamp)
Next (SetUnicodeString)

Name
SetUnicodeStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetUnicodeStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetTimestamp)
Next (SetUnicodeString)


Previous (SetUnicodeStream)
Next (SetValue)

Name
SetUnicodeString

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetUnicodeString ( ParameterIndex : Integer ; const Value : WideString )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (SetUnicodeStream)
Next (SetValue)


Previous (SetUnicodeString)
Next

Name
SetValue

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetValue ( ParameterIndex : Integer ; const Value : TZVariant )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (SetUnicodeString)
Next


Previous (IZPreparedStatement)
Next (IZResultSetMetadata)

Name
IZResultSet

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AfterLast (+)
BeforeFirst (+)
CancelRowUpdates (+)
ClearWarnings (+)
Close (+)
CompareRows (+)
DeleteRow (+)
FindColumn (+)
First (+)
GetAsciiStream (+)
GetAsciiStreamByName (+)
GetBigDecimal (+)
GetBigDecimalByName (+)
GetBinaryStream (+)
GetBinaryStreamByName (+)
GetBlob (+)
GetBlobByName (+)
GetBoolean (+)
GetBooleanByName (+)
GetByte (+)
GetByteByName (+)
GetBytes (+)
GetBytesByName (+)
GetConcurrency (+)
GetCursorName (+)
GetDate (+)
GetDateByName (+)
GetDouble (+)
GetDoubleByName (+)
GetFetchDirection (+)
GetFetchSize (+)
GetFloat (+)
GetFloatByName (+)
GetInt (+)
GetIntByName (+)
GetLocateUpdates (+)
GetLong (+)
GetLongByName (+)
GetMetadata (+)
GetPChar (+)
GetPCharByName (+)
GetPostUpdates (+)
GetRow (+)
GetShort (+)
GetShortByName (+)
GetStatement (+)
GetString (+)
GetStringByName (+)
GetTime (+)
GetTimeByName (+)
GetTimestamp (+)
GetTimestampByName (+)
GetType (+)
GetUnicodeStream (+)
GetUnicodeStreamByName (+)
GetUnicodeString (+)
GetUnicodeStringByName (+)
GetValue (+)
GetValueByName (+)
GetWarnings (+)
InsertRow (+)
IsAfterLast (+)
IsBeforeFirst (+)
IsFirst (+)
IsLast (+)
IsNull (+)
IsNullByName (+)
Last (+)
MoveAbsolute (+)
MoveRelative (+)
MoveToCurrentRow (+)
MoveToInsertRow (+)
Next (+)
Previous (+)
RefreshRow (+)
RowDeleted (+)
RowInserted (+)
RowUpdated (+)
SetFetchDirection (+)
SetFetchSize (+)
UpdateAsciiStream (+)
UpdateAsciiStreamByName (+)
UpdateBigDecimal (+)
UpdateBigDecimalByName (+)
UpdateBinaryStream (+)
UpdateBinaryStreamByName (+)
UpdateBoolean (+)
UpdateBooleanByName (+)
UpdateByte (+)
UpdateByteByName (+)
UpdateBytes (+)
UpdateBytesByName (+)
UpdateDate (+)
UpdateDateByName (+)
UpdateDouble (+)
UpdateDoubleByName (+)
UpdateFloat (+)
UpdateFloatByName (+)
UpdateInt (+)
UpdateIntByName (+)
UpdateLong (+)
UpdateLongByName (+)
UpdateNull (+)
UpdateNullByName (+)
UpdatePChar (+)
UpdatePCharByName (+)
UpdateRow (+)
UpdateShort (+)
UpdateShortByName (+)
UpdateString (+)
UpdateStringByName (+)
UpdateTime (+)
UpdateTimeByName (+)
UpdateTimestamp (+)
UpdateTimestampByName (+)
UpdateUnicodeStream (+)
UpdateUnicodeStreamByName (+)
UpdateUnicodeString (+)
UpdateUnicodeStringByName (+)
UpdateValue (+)
UpdateValueByName (+)
WasNull (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZPreparedStatement)
Next (IZResultSetMetadata)


Previous
Next (BeforeFirst)

Name
AfterLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure AfterLast

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeforeFirst)


Previous (AfterLast)
Next (CancelRowUpdates)

Name
BeforeFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure BeforeFirst

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AfterLast)
Next (CancelRowUpdates)


Previous (BeforeFirst)
Next (ClearWarnings)

Name
CancelRowUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure CancelRowUpdates

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeforeFirst)
Next (ClearWarnings)


Previous (CancelRowUpdates)
Next (Close)

Name
ClearWarnings

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CancelRowUpdates)
Next (Close)


Previous (ClearWarnings)
Next (CompareRows)

Name
Close

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (CompareRows)


Previous (Close)
Next (DeleteRow)

Name
CompareRows

Parent
IZResultSet

Visibility
PUBLIC

Source code
function CompareRows ( Row1 , Row2 : Integer ; const ColumnIndices : TIntegerDynArray ; const ColumnDirs : TBooleanDynArray ) : Integer

Parameters
Parameter Description
Row1 : INTEGER
Row2 : INTEGER
ColumnIndices : TIntegerDynArray
ColumnDirs : TBooleanDynArray

mAirListScript
Class Tree
Index
Previous (Close)
Next (DeleteRow)


Previous (CompareRows)
Next (FindColumn)

Name
DeleteRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure DeleteRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CompareRows)
Next (FindColumn)


Previous (DeleteRow)
Next (First)

Name
FindColumn

Parent
IZResultSet

Visibility
PUBLIC

Source code
function FindColumn ( const ColumnName : string ) : Integer

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (DeleteRow)
Next (First)


Previous (FindColumn)
Next (GetAsciiStream)

Name
First

Parent
IZResultSet

Visibility
PUBLIC

Source code
function First : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindColumn)
Next (GetAsciiStream)


Previous (First)
Next (GetAsciiStreamByName)

Name
GetAsciiStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetAsciiStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (First)
Next (GetAsciiStreamByName)


Previous (GetAsciiStream)
Next (GetBigDecimal)

Name
GetAsciiStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetAsciiStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetAsciiStream)
Next (GetBigDecimal)


Previous (GetAsciiStreamByName)
Next (GetBigDecimalByName)

Name
GetBigDecimal

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBigDecimal ( ColumnIndex : Integer ) : Extended

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetAsciiStreamByName)
Next (GetBigDecimalByName)


Previous (GetBigDecimal)
Next (GetBinaryStream)

Name
GetBigDecimalByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBigDecimalByName ( const ColumnName : string ) : Extended

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBigDecimal)
Next (GetBinaryStream)


Previous (GetBigDecimalByName)
Next (GetBinaryStreamByName)

Name
GetBinaryStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBinaryStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBigDecimalByName)
Next (GetBinaryStreamByName)


Previous (GetBinaryStream)
Next (GetBlob)

Name
GetBinaryStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBinaryStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBinaryStream)
Next (GetBlob)


Previous (GetBinaryStreamByName)
Next (GetBlobByName)

Name
GetBlob

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBlob ( ColumnIndex : Integer ) : IZBlob

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBinaryStreamByName)
Next (GetBlobByName)


Previous (GetBlob)
Next (GetBoolean)

Name
GetBlobByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBlobByName ( const ColumnName : string ) : IZBlob

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBlob)
Next (GetBoolean)


Previous (GetBlobByName)
Next (GetBooleanByName)

Name
GetBoolean

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBoolean ( ColumnIndex : Integer ) : Boolean

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBlobByName)
Next (GetBooleanByName)


Previous (GetBoolean)
Next (GetByte)

Name
GetBooleanByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBooleanByName ( const ColumnName : string ) : Boolean

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBoolean)
Next (GetByte)


Previous (GetBooleanByName)
Next (GetByteByName)

Name
GetByte

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetByte ( ColumnIndex : Integer ) : ShortInt

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBooleanByName)
Next (GetByteByName)


Previous (GetByte)
Next (GetBytes)

Name
GetByteByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetByteByName ( const ColumnName : string ) : ShortInt

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetByte)
Next (GetBytes)


Previous (GetByteByName)
Next (GetBytesByName)

Name
GetBytes

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBytes ( ColumnIndex : Integer ) : TByteDynArray

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetByteByName)
Next (GetBytesByName)


Previous (GetBytes)
Next (GetConcurrency)

Name
GetBytesByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBytesByName ( const ColumnName : string ) : TByteDynArray

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetConcurrency)


Previous (GetBytesByName)
Next (GetCursorName)

Name
GetConcurrency

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetConcurrency : TZResultSetConcurrency

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBytesByName)
Next (GetCursorName)


Previous (GetConcurrency)
Next (GetDate)

Name
GetCursorName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetCursorName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConcurrency)
Next (GetDate)


Previous (GetCursorName)
Next (GetDateByName)

Name
GetDate

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDate ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCursorName)
Next (GetDateByName)


Previous (GetDate)
Next (GetDouble)

Name
GetDateByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDateByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetDate)
Next (GetDouble)


Previous (GetDateByName)
Next (GetDoubleByName)

Name
GetDouble

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDouble ( ColumnIndex : Integer ) : Double

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDateByName)
Next (GetDoubleByName)


Previous (GetDouble)
Next (GetFetchDirection)

Name
GetDoubleByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDoubleByName ( const ColumnName : string ) : Double

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetDouble)
Next (GetFetchDirection)


Previous (GetDoubleByName)
Next (GetFetchSize)

Name
GetFetchDirection

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFetchDirection : TZFetchDirection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDoubleByName)
Next (GetFetchSize)


Previous (GetFetchDirection)
Next (GetFloat)

Name
GetFetchSize

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFetchSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchDirection)
Next (GetFloat)


Previous (GetFetchSize)
Next (GetFloatByName)

Name
GetFloat

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFloat ( ColumnIndex : Integer ) : Single

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFetchSize)
Next (GetFloatByName)


Previous (GetFloat)
Next (GetInt)

Name
GetFloatByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFloatByName ( const ColumnName : string ) : Single

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetFloat)
Next (GetInt)


Previous (GetFloatByName)
Next (GetIntByName)

Name
GetInt

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetInt ( ColumnIndex : Integer ) : Integer

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFloatByName)
Next (GetIntByName)


Previous (GetInt)
Next (GetLocateUpdates)

Name
GetIntByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetIntByName ( const ColumnName : string ) : Integer

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetInt)
Next (GetLocateUpdates)


Previous (GetIntByName)
Next (GetLong)

Name
GetLocateUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLocateUpdates : TZLocateUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIntByName)
Next (GetLong)


Previous (GetLocateUpdates)
Next (GetLongByName)

Name
GetLong

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLong ( ColumnIndex : Integer ) : Int64

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetLocateUpdates)
Next (GetLongByName)


Previous (GetLong)
Next (GetMetadata)

Name
GetLongByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLongByName ( const ColumnName : string ) : Int64

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetLong)
Next (GetMetadata)


Previous (GetLongByName)
Next (GetPChar)

Name
GetMetadata

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetMetadata : IZResultSetMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLongByName)
Next (GetPChar)


Previous (GetMetadata)
Next (GetPCharByName)

Name
GetPChar

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPChar ( ColumnIndex : Integer ) : PChar

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetPCharByName)


Previous (GetPChar)
Next (GetPostUpdates)

Name
GetPCharByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPCharByName ( const ColumnName : string ) : PChar

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetPChar)
Next (GetPostUpdates)


Previous (GetPCharByName)
Next (GetRow)

Name
GetPostUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPostUpdates : TZPostUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPCharByName)
Next (GetRow)


Previous (GetPostUpdates)
Next (GetShort)

Name
GetRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetRow : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPostUpdates)
Next (GetShort)


Previous (GetRow)
Next (GetShortByName)

Name
GetShort

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetShort ( ColumnIndex : Integer ) : SmallInt

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetRow)
Next (GetShortByName)


Previous (GetShort)
Next (GetStatement)

Name
GetShortByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetShortByName ( const ColumnName : string ) : SmallInt

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetShort)
Next (GetStatement)


Previous (GetShortByName)
Next (GetString)

Name
GetStatement

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetStatement : IZStatement

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetShortByName)
Next (GetString)


Previous (GetStatement)
Next (GetStringByName)

Name
GetString

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetString ( ColumnIndex : Integer ) : string

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStatement)
Next (GetStringByName)


Previous (GetString)
Next (GetTime)

Name
GetStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetStringByName ( const ColumnName : string ) : string

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetString)
Next (GetTime)


Previous (GetStringByName)
Next (GetTimeByName)

Name
GetTime

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTime ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStringByName)
Next (GetTimeByName)


Previous (GetTime)
Next (GetTimestamp)

Name
GetTimeByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimeByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetTime)
Next (GetTimestamp)


Previous (GetTimeByName)
Next (GetTimestampByName)

Name
GetTimestamp

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimestamp ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTimeByName)
Next (GetTimestampByName)


Previous (GetTimestamp)
Next (GetType)

Name
GetTimestampByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimestampByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetTimestamp)
Next (GetType)


Previous (GetTimestampByName)
Next (GetUnicodeStream)

Name
GetType

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetType : TZResultSetType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimestampByName)
Next (GetUnicodeStream)


Previous (GetType)
Next (GetUnicodeStreamByName)

Name
GetUnicodeStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetType)
Next (GetUnicodeStreamByName)


Previous (GetUnicodeStream)
Next (GetUnicodeString)

Name
GetUnicodeStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetUnicodeStream)
Next (GetUnicodeString)


Previous (GetUnicodeStreamByName)
Next (GetUnicodeStringByName)

Name
GetUnicodeString

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeString ( ColumnIndex : Integer ) : WideString

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeStreamByName)
Next (GetUnicodeStringByName)


Previous (GetUnicodeString)
Next (GetValue)

Name
GetUnicodeStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStringByName ( const ColumnName : string ) : WideString

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (GetValue)


Previous (GetUnicodeStringByName)
Next (GetValueByName)

Name
GetValue

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetValue ( ColumnIndex : Integer ) : TZVariant

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeStringByName)
Next (GetValueByName)


Previous (GetValue)
Next (GetWarnings)

Name
GetValueByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetValueByName ( const ColumnName : string ) : TZVariant

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (GetWarnings)


Previous (GetValueByName)
Next (InsertRow)

Name
GetWarnings

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetValueByName)
Next (InsertRow)


Previous (GetWarnings)
Next (IsAfterLast)

Name
InsertRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure InsertRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (IsAfterLast)


Previous (InsertRow)
Next (IsBeforeFirst)

Name
IsAfterLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsAfterLast : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (InsertRow)
Next (IsBeforeFirst)


Previous (IsAfterLast)
Next (IsFirst)

Name
IsBeforeFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsBeforeFirst : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterLast)
Next (IsFirst)


Previous (IsBeforeFirst)
Next (IsLast)

Name
IsFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsFirst : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsBeforeFirst)
Next (IsLast)


Previous (IsFirst)
Next (IsNull)

Name
IsLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsLast : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsFirst)
Next (IsNull)


Previous (IsLast)
Next (IsNullByName)

Name
IsNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsNull ( ColumnIndex : Integer ) : Boolean

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (IsLast)
Next (IsNullByName)


Previous (IsNull)
Next (Last)

Name
IsNullByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsNullByName ( const ColumnName : string ) : Boolean

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (IsNull)
Next (Last)


Previous (IsNullByName)
Next (MoveAbsolute)

Name
Last

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Last : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsNullByName)
Next (MoveAbsolute)


Previous (Last)
Next (MoveRelative)

Name
MoveAbsolute

Parent
IZResultSet

Visibility
PUBLIC

Source code
function MoveAbsolute ( Row : Integer ) : Boolean

Parameters
Parameter Description
Row : INTEGER

mAirListScript
Class Tree
Index
Previous (Last)
Next (MoveRelative)


Previous (MoveAbsolute)
Next (MoveToCurrentRow)

Name
MoveRelative

Parent
IZResultSet

Visibility
PUBLIC

Source code
function MoveRelative ( Rows : Integer ) : Boolean

Parameters
Parameter Description
Rows : INTEGER

mAirListScript
Class Tree
Index
Previous (MoveAbsolute)
Next (MoveToCurrentRow)


Previous (MoveRelative)
Next (MoveToInsertRow)

Name
MoveToCurrentRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure MoveToCurrentRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveRelative)
Next (MoveToInsertRow)


Previous (MoveToCurrentRow)
Next (Next)

Name
MoveToInsertRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure MoveToInsertRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveToCurrentRow)
Next (Next)


Previous (MoveToInsertRow)
Next (Previous)

Name
Next

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Next : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveToInsertRow)
Next (Previous)


Previous (Next)
Next (RefreshRow)

Name
Previous

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Previous : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Next)
Next (RefreshRow)


Previous (Previous)
Next (RowDeleted)

Name
RefreshRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure RefreshRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Previous)
Next (RowDeleted)


Previous (RefreshRow)
Next (RowInserted)

Name
RowDeleted

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowDeleted : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RefreshRow)
Next (RowInserted)


Previous (RowDeleted)
Next (RowUpdated)

Name
RowInserted

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowInserted : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RowDeleted)
Next (RowUpdated)


Previous (RowInserted)
Next (SetFetchDirection)

Name
RowUpdated

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowUpdated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RowInserted)
Next (SetFetchDirection)


Previous (RowUpdated)
Next (SetFetchSize)

Name
SetFetchDirection

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure SetFetchDirection ( Value : TZFetchDirection )

Parameters
Parameter Description
Value : TZFetchDirection

mAirListScript
Class Tree
Index
Previous (RowUpdated)
Next (SetFetchSize)


Previous (SetFetchDirection)
Next (UpdateAsciiStream)

Name
SetFetchSize

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure SetFetchSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFetchDirection)
Next (UpdateAsciiStream)


Previous (SetFetchSize)
Next (UpdateAsciiStreamByName)

Name
UpdateAsciiStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateAsciiStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetFetchSize)
Next (UpdateAsciiStreamByName)


Previous (UpdateAsciiStream)
Next (UpdateBigDecimal)

Name
UpdateAsciiStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateAsciiStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateAsciiStream)
Next (UpdateBigDecimal)


Previous (UpdateAsciiStreamByName)
Next (UpdateBigDecimalByName)

Name
UpdateBigDecimal

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBigDecimal ( ColumnIndex : Integer ; Value : Extended )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (UpdateAsciiStreamByName)
Next (UpdateBigDecimalByName)


Previous (UpdateBigDecimal)
Next (UpdateBinaryStream)

Name
UpdateBigDecimalByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBigDecimalByName ( const ColumnName : string ; Value : Extended )

Parameters
Parameter Description
ColumnName : STRING
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (UpdateBigDecimal)
Next (UpdateBinaryStream)


Previous (UpdateBigDecimalByName)
Next (UpdateBinaryStreamByName)

Name
UpdateBinaryStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBinaryStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateBigDecimalByName)
Next (UpdateBinaryStreamByName)


Previous (UpdateBinaryStream)
Next (UpdateBoolean)

Name
UpdateBinaryStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBinaryStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateBinaryStream)
Next (UpdateBoolean)


Previous (UpdateBinaryStreamByName)
Next (UpdateBooleanByName)

Name
UpdateBoolean

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBoolean ( ColumnIndex : Integer ; Value : Boolean )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (UpdateBinaryStreamByName)
Next (UpdateBooleanByName)


Previous (UpdateBoolean)
Next (UpdateByte)

Name
UpdateBooleanByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBooleanByName ( const ColumnName : string ; Value : Boolean )

Parameters
Parameter Description
ColumnName : STRING
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (UpdateBoolean)
Next (UpdateByte)


Previous (UpdateBooleanByName)
Next (UpdateByteByName)

Name
UpdateByte

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateByte ( ColumnIndex : Integer ; Value : ShortInt )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (UpdateBooleanByName)
Next (UpdateByteByName)


Previous (UpdateByte)
Next (UpdateBytes)

Name
UpdateByteByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateByteByName ( const ColumnName : string ; Value : ShortInt )

Parameters
Parameter Description
ColumnName : STRING
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (UpdateByte)
Next (UpdateBytes)


Previous (UpdateByteByName)
Next (UpdateBytesByName)

Name
UpdateBytes

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBytes ( ColumnIndex : Integer ; const Value : TByteDynArray )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (UpdateByteByName)
Next (UpdateBytesByName)


Previous (UpdateBytes)
Next (UpdateDate)

Name
UpdateBytesByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBytesByName ( const ColumnName : string ; const Value : TByteDynArray )

Parameters
Parameter Description
ColumnName : STRING
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (UpdateBytes)
Next (UpdateDate)


Previous (UpdateBytesByName)
Next (UpdateDateByName)

Name
UpdateDate

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDate ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateBytesByName)
Next (UpdateDateByName)


Previous (UpdateDate)
Next (UpdateDouble)

Name
UpdateDateByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDateByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateDate)
Next (UpdateDouble)


Previous (UpdateDateByName)
Next (UpdateDoubleByName)

Name
UpdateDouble

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDouble ( ColumnIndex : Integer ; Value : Double )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (UpdateDateByName)
Next (UpdateDoubleByName)


Previous (UpdateDouble)
Next (UpdateFloat)

Name
UpdateDoubleByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDoubleByName ( const ColumnName : string ; Value : Double )

Parameters
Parameter Description
ColumnName : STRING
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (UpdateDouble)
Next (UpdateFloat)


Previous (UpdateDoubleByName)
Next (UpdateFloatByName)

Name
UpdateFloat

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateFloat ( ColumnIndex : Integer ; Value : Single )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (UpdateDoubleByName)
Next (UpdateFloatByName)


Previous (UpdateFloat)
Next (UpdateInt)

Name
UpdateFloatByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateFloatByName ( const ColumnName : string ; Value : Single )

Parameters
Parameter Description
ColumnName : STRING
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (UpdateFloat)
Next (UpdateInt)


Previous (UpdateFloatByName)
Next (UpdateIntByName)

Name
UpdateInt

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateInt ( ColumnIndex : Integer ; Value : Integer )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateFloatByName)
Next (UpdateIntByName)


Previous (UpdateInt)
Next (UpdateLong)

Name
UpdateIntByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateIntByName ( const ColumnName : string ; Value : Integer )

Parameters
Parameter Description
ColumnName : STRING
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateInt)
Next (UpdateLong)


Previous (UpdateIntByName)
Next (UpdateLongByName)

Name
UpdateLong

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateLong ( ColumnIndex : Integer ; Value : Int64 )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : INT64

mAirListScript
Class Tree
Index
Previous (UpdateIntByName)
Next (UpdateLongByName)


Previous (UpdateLong)
Next (UpdateNull)

Name
UpdateLongByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateLongByName ( const ColumnName : string ; Value : Int64 )

Parameters
Parameter Description
ColumnName : STRING
Value : INT64

mAirListScript
Class Tree
Index
Previous (UpdateLong)
Next (UpdateNull)


Previous (UpdateLongByName)
Next (UpdateNullByName)

Name
UpdateNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateNull ( ColumnIndex : Integer )

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateLongByName)
Next (UpdateNullByName)


Previous (UpdateNull)
Next (UpdatePChar)

Name
UpdateNullByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateNullByName ( const ColumnName : string )

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (UpdateNull)
Next (UpdatePChar)


Previous (UpdateNullByName)
Next (UpdatePCharByName)

Name
UpdatePChar

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdatePChar ( ColumnIndex : Integer ; Value : PChar )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (UpdateNullByName)
Next (UpdatePCharByName)


Previous (UpdatePChar)
Next (UpdateRow)

Name
UpdatePCharByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdatePCharByName ( const ColumnName : string ; Value : PChar )

Parameters
Parameter Description
ColumnName : STRING
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (UpdatePChar)
Next (UpdateRow)


Previous (UpdatePCharByName)
Next (UpdateShort)

Name
UpdateRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UpdatePCharByName)
Next (UpdateShort)


Previous (UpdateRow)
Next (UpdateShortByName)

Name
UpdateShort

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateShort ( ColumnIndex : Integer ; Value : SmallInt )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (UpdateRow)
Next (UpdateShortByName)


Previous (UpdateShort)
Next (UpdateString)

Name
UpdateShortByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateShortByName ( const ColumnName : string ; Value : SmallInt )

Parameters
Parameter Description
ColumnName : STRING
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (UpdateShort)
Next (UpdateString)


Previous (UpdateShortByName)
Next (UpdateStringByName)

Name
UpdateString

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateString ( ColumnIndex : Integer ; const Value : string )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (UpdateShortByName)
Next (UpdateStringByName)


Previous (UpdateString)
Next (UpdateTime)

Name
UpdateStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateStringByName ( const ColumnName : string ; const Value : string )

Parameters
Parameter Description
ColumnName : STRING
Value : STRING

mAirListScript
Class Tree
Index
Previous (UpdateString)
Next (UpdateTime)


Previous (UpdateStringByName)
Next (UpdateTimeByName)

Name
UpdateTime

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTime ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateStringByName)
Next (UpdateTimeByName)


Previous (UpdateTime)
Next (UpdateTimestamp)

Name
UpdateTimeByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimeByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTime)
Next (UpdateTimestamp)


Previous (UpdateTimeByName)
Next (UpdateTimestampByName)

Name
UpdateTimestamp

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimestamp ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTimeByName)
Next (UpdateTimestampByName)


Previous (UpdateTimestamp)
Next (UpdateUnicodeStream)

Name
UpdateTimestampByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimestampByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTimestamp)
Next (UpdateUnicodeStream)


Previous (UpdateTimestampByName)
Next (UpdateUnicodeStreamByName)

Name
UpdateUnicodeStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateTimestampByName)
Next (UpdateUnicodeStreamByName)


Previous (UpdateUnicodeStream)
Next (UpdateUnicodeString)

Name
UpdateUnicodeStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStream)
Next (UpdateUnicodeString)


Previous (UpdateUnicodeStreamByName)
Next (UpdateUnicodeStringByName)

Name
UpdateUnicodeString

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeString ( ColumnIndex : Integer ; const Value : WideString )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStreamByName)
Next (UpdateUnicodeStringByName)


Previous (UpdateUnicodeString)
Next (UpdateValue)

Name
UpdateUnicodeStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStringByName ( const ColumnName : string ; const Value : WideString )

Parameters
Parameter Description
ColumnName : STRING
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeString)
Next (UpdateValue)


Previous (UpdateUnicodeStringByName)
Next (UpdateValueByName)

Name
UpdateValue

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateValue ( ColumnIndex : Integer ; const Value : TZVariant )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStringByName)
Next (UpdateValueByName)


Previous (UpdateValue)
Next (WasNull)

Name
UpdateValueByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateValueByName ( const ColumnName : string ; const Value : TZVariant )

Parameters
Parameter Description
ColumnName : STRING
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (UpdateValue)
Next (WasNull)


Previous (UpdateValueByName)
Next

Name
WasNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
function WasNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UpdateValueByName)
Next


Previous (IZResultSet)
Next (IZSequence)

Name
IZResultSetMetadata

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCatalogName (+)
GetColumnCount (+)
GetColumnDisplaySize (+)
GetColumnLabel (+)
GetColumnName (+)
GetColumnType (+)
GetColumnTypeName (+)
GetDefaultValue (+)
GetPrecision (+)
GetScale (+)
GetSchemaName (+)
GetTableName (+)
HasDefaultValue (+)
IsAutoIncrement (+)
IsCaseSensitive (+)
IsCurrency (+)
IsDefinitelyWritable (+)
IsNullable (+)
IsReadOnly (+)
IsSearchable (+)
IsSigned (+)
IsWritable (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZResultSet)
Next (IZSequence)


Previous
Next (GetColumnCount)

Name
GetCatalogName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetCatalogName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetColumnCount)


Previous (GetCatalogName)
Next (GetColumnDisplaySize)

Name
GetColumnCount

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnCount : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogName)
Next (GetColumnDisplaySize)


Previous (GetColumnCount)
Next (GetColumnLabel)

Name
GetColumnDisplaySize

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnDisplaySize ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnCount)
Next (GetColumnLabel)


Previous (GetColumnDisplaySize)
Next (GetColumnName)

Name
GetColumnLabel

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnLabel ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnDisplaySize)
Next (GetColumnName)


Previous (GetColumnLabel)
Next (GetColumnType)

Name
GetColumnName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnLabel)
Next (GetColumnType)


Previous (GetColumnName)
Next (GetColumnTypeName)

Name
GetColumnType

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnType ( Column : Integer ) : TZSQLType

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnName)
Next (GetColumnTypeName)


Previous (GetColumnType)
Next (GetDefaultValue)

Name
GetColumnTypeName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnTypeName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnType)
Next (GetDefaultValue)


Previous (GetColumnTypeName)
Next (GetPrecision)

Name
GetDefaultValue

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetDefaultValue ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnTypeName)
Next (GetPrecision)


Previous (GetDefaultValue)
Next (GetScale)

Name
GetPrecision

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetPrecision ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDefaultValue)
Next (GetScale)


Previous (GetPrecision)
Next (GetSchemaName)

Name
GetScale

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetScale ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPrecision)
Next (GetSchemaName)


Previous (GetScale)
Next (GetTableName)

Name
GetSchemaName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetSchemaName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetScale)
Next (GetTableName)


Previous (GetSchemaName)
Next (HasDefaultValue)

Name
GetTableName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetTableName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetSchemaName)
Next (HasDefaultValue)


Previous (GetTableName)
Next (IsAutoIncrement)

Name
HasDefaultValue

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function HasDefaultValue ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTableName)
Next (IsAutoIncrement)


Previous (HasDefaultValue)
Next (IsCaseSensitive)

Name
IsAutoIncrement

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsAutoIncrement ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (HasDefaultValue)
Next (IsCaseSensitive)


Previous (IsAutoIncrement)
Next (IsCurrency)

Name
IsCaseSensitive

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsCaseSensitive ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsAutoIncrement)
Next (IsCurrency)


Previous (IsCaseSensitive)
Next (IsDefinitelyWritable)

Name
IsCurrency

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsCurrency ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsCaseSensitive)
Next (IsDefinitelyWritable)


Previous (IsCurrency)
Next (IsNullable)

Name
IsDefinitelyWritable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsDefinitelyWritable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsCurrency)
Next (IsNullable)


Previous (IsDefinitelyWritable)
Next (IsReadOnly)

Name
IsNullable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsNullable ( Column : Integer ) : TZColumnNullableType

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsDefinitelyWritable)
Next (IsReadOnly)


Previous (IsNullable)
Next (IsSearchable)

Name
IsReadOnly

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsReadOnly ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsNullable)
Next (IsSearchable)


Previous (IsReadOnly)
Next (IsSigned)

Name
IsSearchable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsSearchable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (IsSigned)


Previous (IsSearchable)
Next (IsWritable)

Name
IsSigned

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsSigned ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsSearchable)
Next (IsWritable)


Previous (IsSigned)
Next

Name
IsWritable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsWritable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsSigned)
Next


Previous (IZResultSetMetadata)
Next (IZStatement)

Name
IZSequence

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetBlockSize (+)
GetConnection (+)
GetCurrentValue (+)
GetCurrentValueSQL (+)
GetName (+)
GetNextValue (+)
GetNextValueSQL (+)
SetBlockSize (+)
SetName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZResultSetMetadata)
Next (IZStatement)


Previous
Next (GetConnection)

Name
GetBlockSize

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetBlockSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetConnection)


Previous (GetBlockSize)
Next (GetCurrentValue)

Name
GetConnection

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBlockSize)
Next (GetCurrentValue)


Previous (GetConnection)
Next (GetCurrentValueSQL)

Name
GetCurrentValue

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetCurrentValue : Int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetCurrentValueSQL)


Previous (GetCurrentValue)
Next (GetName)

Name
GetCurrentValueSQL

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetCurrentValueSQL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentValue)
Next (GetName)


Previous (GetCurrentValueSQL)
Next (GetNextValue)

Name
GetName

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentValueSQL)
Next (GetNextValue)


Previous (GetName)
Next (GetNextValueSQL)

Name
GetNextValue

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetNextValue : Int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetNextValueSQL)


Previous (GetNextValue)
Next (SetBlockSize)

Name
GetNextValueSQL

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetNextValueSQL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextValue)
Next (SetBlockSize)


Previous (GetNextValueSQL)
Next (SetName)

Name
SetBlockSize

Parent
IZSequence

Visibility
PUBLIC

Source code
procedure SetBlockSize ( const Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (GetNextValueSQL)
Next (SetName)


Previous (SetBlockSize)
Next

Name
SetName

Parent
IZSequence

Visibility
PUBLIC

Source code
procedure SetName ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetBlockSize)
Next


Previous (IZSequence)
Next (TZDriverManager)

Name
IZStatement

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddBatch (+)
Cancel (+)
ClearBatch (+)
ClearWarnings (+)
Close (+)
Execute (+)
ExecuteBatch (+)
ExecuteQuery (+)
ExecuteUpdate (+)
GetConnection (+)
GetFetchDirection (+)
GetFetchSize (+)
GetLocateUpdates (+)
GetMaxFieldSize (+)
GetMaxRows (+)
GetMoreResults (+)
GetParameters (+)
GetPostUpdates (+)
GetQueryTimeout (+)
GetResultSet (+)
GetResultSetConcurrency (+)
GetResultSetType (+)
GetUpdateCount (+)
GetWarnings (+)
SetCursorName (+)
SetEscapeProcessing (+)
SetFetchDirection (+)
SetFetchSize (+)
SetLocateUpdates (+)
SetMaxFieldSize (+)
SetMaxRows (+)
SetPostUpdates (+)
SetQueryTimeout (+)
SetResultSetConcurrency (+)
SetResultSetType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZSequence)
Next (TZDriverManager)


Previous
Next (Cancel)

Name
AddBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure AddBatch ( const SQL : string )

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous
Next (Cancel)


Previous (AddBatch)
Next (ClearBatch)

Name
Cancel

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure Cancel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddBatch)
Next (ClearBatch)


Previous (Cancel)
Next (ClearWarnings)

Name
ClearBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure ClearBatch

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Cancel)
Next (ClearWarnings)


Previous (ClearBatch)
Next (Close)

Name
ClearWarnings

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearBatch)
Next (Close)


Previous (ClearWarnings)
Next (Execute)

Name
Close

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (Execute)


Previous (Close)
Next (ExecuteBatch)

Name
Execute

Parent
IZStatement

Visibility
PUBLIC

Source code
function Execute ( const SQL : string ) : Boolean

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (Close)
Next (ExecuteBatch)


Previous (Execute)
Next (ExecuteQuery)

Name
ExecuteBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteBatch : TIntegerDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Execute)
Next (ExecuteQuery)


Previous (ExecuteBatch)
Next (ExecuteUpdate)

Name
ExecuteQuery

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteQuery ( const SQL : string ) : IZResultSet

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteBatch)
Next (ExecuteUpdate)


Previous (ExecuteQuery)
Next (GetConnection)

Name
ExecuteUpdate

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteUpdate ( const SQL : string ) : Integer

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteQuery)
Next (GetConnection)


Previous (ExecuteUpdate)
Next (GetFetchDirection)

Name
GetConnection

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteUpdate)
Next (GetFetchDirection)


Previous (GetConnection)
Next (GetFetchSize)

Name
GetFetchDirection

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetFetchDirection : TZFetchDirection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetFetchSize)


Previous (GetFetchDirection)
Next (GetLocateUpdates)

Name
GetFetchSize

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetFetchSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchDirection)
Next (GetLocateUpdates)


Previous (GetFetchSize)
Next (GetMaxFieldSize)

Name
GetLocateUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetLocateUpdates : TZLocateUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchSize)
Next (GetMaxFieldSize)


Previous (GetLocateUpdates)
Next (GetMaxRows)

Name
GetMaxFieldSize

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMaxFieldSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLocateUpdates)
Next (GetMaxRows)


Previous (GetMaxFieldSize)
Next (GetMoreResults)

Name
GetMaxRows

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMaxRows : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxFieldSize)
Next (GetMoreResults)


Previous (GetMaxRows)
Next (GetParameters)

Name
GetMoreResults

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMoreResults : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxRows)
Next (GetParameters)


Previous (GetMoreResults)
Next (GetPostUpdates)

Name
GetParameters

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetParameters : TStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMoreResults)
Next (GetPostUpdates)


Previous (GetParameters)
Next (GetQueryTimeout)

Name
GetPostUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetPostUpdates : TZPostUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (GetQueryTimeout)


Previous (GetPostUpdates)
Next (GetResultSet)

Name
GetQueryTimeout

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetQueryTimeout : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPostUpdates)
Next (GetResultSet)


Previous (GetQueryTimeout)
Next (GetResultSetConcurrency)

Name
GetResultSet

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSet : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetQueryTimeout)
Next (GetResultSetConcurrency)


Previous (GetResultSet)
Next (GetResultSetType)

Name
GetResultSetConcurrency

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSetConcurrency : TZResultSetConcurrency

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSet)
Next (GetResultSetType)


Previous (GetResultSetConcurrency)
Next (GetUpdateCount)

Name
GetResultSetType

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSetType : TZResultSetType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSetConcurrency)
Next (GetUpdateCount)


Previous (GetResultSetType)
Next (GetWarnings)

Name
GetUpdateCount

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetUpdateCount : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSetType)
Next (GetWarnings)


Previous (GetUpdateCount)
Next (SetCursorName)

Name
GetWarnings

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUpdateCount)
Next (SetCursorName)


Previous (GetWarnings)
Next (SetEscapeProcessing)

Name
SetCursorName

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetCursorName ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (SetEscapeProcessing)


Previous (SetCursorName)
Next (SetFetchDirection)

Name
SetEscapeProcessing

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetEscapeProcessing ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetCursorName)
Next (SetFetchDirection)


Previous (SetEscapeProcessing)
Next (SetFetchSize)

Name
SetFetchDirection

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetFetchDirection ( Value : TZFetchDirection )

Parameters
Parameter Description
Value : TZFetchDirection

mAirListScript
Class Tree
Index
Previous (SetEscapeProcessing)
Next (SetFetchSize)


Previous (SetFetchDirection)
Next (SetLocateUpdates)

Name
SetFetchSize

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetFetchSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFetchDirection)
Next (SetLocateUpdates)


Previous (SetFetchSize)
Next (SetMaxFieldSize)

Name
SetLocateUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetLocateUpdates ( Value : TZLocateUpdatesMode )

Parameters
Parameter Description
Value : TZLocateUpdatesMode

mAirListScript
Class Tree
Index
Previous (SetFetchSize)
Next (SetMaxFieldSize)


Previous (SetLocateUpdates)
Next (SetMaxRows)

Name
SetMaxFieldSize

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetMaxFieldSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetLocateUpdates)
Next (SetMaxRows)


Previous (SetMaxFieldSize)
Next (SetPostUpdates)

Name
SetMaxRows

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetMaxRows ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetMaxFieldSize)
Next (SetPostUpdates)


Previous (SetMaxRows)
Next (SetQueryTimeout)

Name
SetPostUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetPostUpdates ( Value : TZPostUpdatesMode )

Parameters
Parameter Description
Value : TZPostUpdatesMode

mAirListScript
Class Tree
Index
Previous (SetMaxRows)
Next (SetQueryTimeout)


Previous (SetPostUpdates)
Next (SetResultSetConcurrency)

Name
SetQueryTimeout

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetQueryTimeout ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPostUpdates)
Next (SetResultSetConcurrency)


Previous (SetQueryTimeout)
Next (SetResultSetType)

Name
SetResultSetConcurrency

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetResultSetConcurrency ( Value : TZResultSetConcurrency )

Parameters
Parameter Description
Value : TZResultSetConcurrency

mAirListScript
Class Tree
Index
Previous (SetQueryTimeout)
Next (SetResultSetType)


Previous (SetResultSetConcurrency)
Next

Name
SetResultSetType

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetResultSetType ( Value : TZResultSetType )

Parameters
Parameter Description
Value : TZResultSetType

mAirListScript
Class Tree
Index
Previous (SetResultSetConcurrency)
Next


Previous (IZStatement)
Next

Name
TZDriverManager

Parent
ZDbcIntfs

Class Hierarchy
TInterfacedObject,IZDriverManager

Visibility
PUBLIC

Members
Fields
Field Description
FDrivers (-)
FLoggingListeners (-)
FLoginTimeout (-)

Methods
Method | Description
AddLoggingListener (+) | Adds a logging listener to log SQL events.
Create (+) | Constructs this object with default properties.
DeregisterDriver (+) | Unregisters a driver for specific database.
Destroy (+) | Destroys this object and cleanups the memory.
GetClientVersion (+) | Locates a required driver and returns the client library version number.
GetConnection (+) | Locates a required driver and opens a connection to the specified database.
GetConnectionWithLogin (+) | Locates a required driver and opens a connection to the specified database.
GetConnectionWithParams (+) | Locates a required driver and opens a connection to the specified database.
GetDriver (+) | Gets a driver which accepts the specified url.
GetDrivers (+) | Gets a collection of registered drivers.
GetLoginTimeout (+) | Gets a login timeout value.
LogError (+) | Logs a message about event with error result code.
LogMessage (+) | Logs a message about event with normal result code.
RegisterDriver (+) | Registers a driver for specific database.
RemoveLoggingListener (+) | Removes a logging listener from the list.
SetLoginTimeout (+) | Sets a new login timeout value.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZStatement)
Next


Previous
Next (FLoggingListeners)

Name
FDrivers

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FDrivers : IZCollection

mAirListScript
Class Tree
Index
Previous
Next (FLoggingListeners)


Previous (FDrivers)
Next (FLoginTimeout)

Name
FLoggingListeners

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FLoggingListeners : IZCollection

mAirListScript
Class Tree
Index
Previous (FDrivers)
Next (FLoginTimeout)


Previous (FLoggingListeners)
Next

Name
FLoginTimeout

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FLoginTimeout : Integer

mAirListScript
Class Tree
Index
Previous (FLoggingListeners)
Next


Previous
Next (Create)

Name
AddLoggingListener

Parent
TZDriverManager

Visibility
PUBLIC

Description
Adds a logging listener to log SQL events.

Source code
procedure AddLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter | Description
Listener : IZLoggingListener | a logging interface to be added.

mAirListScript
Class Tree
Index
Previous
Next (Create)


Previous (AddLoggingListener)
Next (DeregisterDriver)

Name
Create

Parent
TZDriverManager

Visibility
PUBLIC

Description
Constructs this object with default properties.

Source code
constructor Create

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddLoggingListener)
Next (DeregisterDriver)


Previous (Create)
Next (Destroy)

Name
DeregisterDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Unregisters a driver for specific database.

Source code
procedure DeregisterDriver ( Driver : IZDriver )

Parameters
Parameter | Description
Driver : IZDriver | a driver to be unregistered.

mAirListScript
Class Tree
Index
Previous (Create)
Next (Destroy)


Previous (DeregisterDriver)
Next (GetClientVersion)

Name
Destroy

Parent
TZDriverManager

Visibility
PUBLIC

Description
Destroys this object and cleanups the memory.

Source code
destructor Destroy ; override

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DeregisterDriver)
Next (GetClientVersion)


Previous (Destroy)
Next (GetConnection)

Name
GetClientVersion

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and returns the client library version number.

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter | Description
Url : STRING | a database connection Url.

Return
Types | Description
INTEGER | client library version number.

mAirListScript
Class Tree
Index
Previous (Destroy)
Next (GetConnection)


Previous (GetClientVersion)
Next (GetConnectionWithLogin)

Name
GetConnection

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnection ( const Url : string ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetConnectionWithLogin)


Previous (GetConnection)
Next (GetConnectionWithParams)

Name
GetConnectionWithLogin

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnectionWithLogin ( const Url : string ; const User : string ; const Password : string ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.
User : STRING | a user's name.
Password : STRING | a user's password.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetConnectionWithParams)


Previous (GetConnectionWithLogin)
Next (GetDriver)

Name
GetConnectionWithParams

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnectionWithParams ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.
Info : TStrings | an extra connection parameters.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetConnectionWithLogin)
Next (GetDriver)


Previous (GetConnectionWithParams)
Next (GetDrivers)

Name
GetDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a driver which accepts the specified url.

Source code
function GetDriver ( const Url : string ) : IZDriver

Parameters
Parameter | Description
Url : STRING | a database connection url.

Return
Types | Description
IZDriver | a found driver or null otherwise.

mAirListScript
Class Tree
Index
Previous (GetConnectionWithParams)
Next (GetDrivers)


Previous (GetDriver)
Next (GetLoginTimeout)

Name
GetDrivers

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a collection of registered drivers.

Source code
function GetDrivers : IZCollection

Parameters
Parameter Description

Return
Types | Description
IZCollection | an unmodifiable collection with registered drivers.

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetLoginTimeout)


Previous (GetDrivers)
Next (LogError)

Name
GetLoginTimeout

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a login timeout value.

Source code
function GetLoginTimeout : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | a login timeout.

mAirListScript
Class Tree
Index
Previous (GetDrivers)
Next (LogError)


Previous (GetLoginTimeout)
Next (LogMessage)

Name
LogError

Parent
TZDriverManager

Visibility
PUBLIC

Description
Logs a message about event with error result code.

Source code
procedure LogError ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string ; ErrorCode : Integer ; const Error : string )

Parameters
Parameter | Description
Category : TZLoggingCategory | a category of the message.
Protocol : STRING | a name of the protocol.
Msg : STRING | a description message.
ErrorCode : INTEGER | an error code.
Error : STRING | an error message.

mAirListScript
Class Tree
Index
Previous (GetLoginTimeout)
Next (LogMessage)


Previous (LogError)
Next (RegisterDriver)

Name
LogMessage

Parent
TZDriverManager

Visibility
PUBLIC

Description
Logs a message about event with normal result code.

Source code
procedure LogMessage ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string )

Parameters
Parameter | Description
Category : TZLoggingCategory | a category of the message.
Protocol : STRING | a name of the protocol.
Msg : STRING | a description message.

mAirListScript
Class Tree
Index
Previous (LogError)
Next (RegisterDriver)


Previous (LogMessage)
Next (RemoveLoggingListener)

Name
RegisterDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Registers a driver for specific database.

Source code
procedure RegisterDriver ( Driver : IZDriver )

Parameters
Parameter | Description
Driver : IZDriver | a driver to be registered.

mAirListScript
Class Tree
Index
Previous (LogMessage)
Next (RemoveLoggingListener)


Previous (RegisterDriver)
Next (SetLoginTimeout)

Name
RemoveLoggingListener

Parent
TZDriverManager

Visibility
PUBLIC

Description
Removes a logging listener from the list.

Source code
procedure RemoveLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter | Description
Listener : IZLoggingListener | a logging interface to be removed.

mAirListScript
Class Tree
Index
Previous (RegisterDriver)
Next (SetLoginTimeout)


Previous (RemoveLoggingListener)
Next

Name
SetLoginTimeout

Parent
TZDriverManager

Visibility
PUBLIC

Description
Sets a new login timeout value.

Source code
procedure SetLoginTimeout ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (RemoveLoggingListener)
Next


Previous
Next (TZColumnNullableType)

Name
TZBestRowIdentifier

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZBestRowIdentifier = ( brUnknown , brNotPseudo , brPseudo ) ;

mAirListScript
Class Tree
Index
Previous
Next (TZColumnNullableType)


Previous (TZBestRowIdentifier)
Next (TZFetchDirection)

Name
TZColumnNullableType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZColumnNullableType = ( ntNoNulls , ntNullable , ntNullableUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TZBestRowIdentifier)
Next (TZFetchDirection)


Previous (TZColumnNullableType)
Next (TZImportedKey)

Name
TZFetchDirection

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZFetchDirection = ( fdForward , fdReverse , fdUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TZColumnNullableType)
Next (TZImportedKey)


Previous (TZFetchDirection)
Next (TZLocateUpdatesMode)

Name
TZImportedKey

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZImportedKey = ( ikCascade , ikRestrict , ikSetNull , ikNoAction , ikSetDefault , ikInitiallyDeferred , ikInitiallyImmediate , ikNotDeferrable ) ;

mAirListScript
Class Tree
Index
Previous (TZFetchDirection)
Next (TZLocateUpdatesMode)


Previous (TZImportedKey)
Next (TZPostUpdatesMode)

Name
TZLocateUpdatesMode

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZLocateUpdatesMode = ( loWhereAll , loWhereChanged , loWhereKeyOnly ) ;

mAirListScript
Class Tree
Index
Previous (TZImportedKey)
Next (TZPostUpdatesMode)


Previous (TZLocateUpdatesMode)
Next (TZProcedureColumnType)

Name
TZPostUpdatesMode

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZPostUpdatesMode = ( poColumnsAll , poColumnsChanged ) ;

mAirListScript
Class Tree
Index
Previous (TZLocateUpdatesMode)
Next (TZProcedureColumnType)


Previous (TZPostUpdatesMode)
Next (TZProcedureResultType)

Name
TZProcedureColumnType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZProcedureColumnType = ( pctUnknown , pctIn , pctInOut , pctOut , pctReturn , pctResultSet ) ;

mAirListScript
Class Tree
Index
Previous (TZPostUpdatesMode)
Next (TZProcedureResultType)


Previous (TZProcedureColumnType)
Next (TZResultSetConcurrency)

Name
TZProcedureResultType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZProcedureResultType = ( prtUnknown , prtNoResult , prtReturnsResult ) ;

mAirListScript
Class Tree
Index
Previous (TZProcedureColumnType)
Next (TZResultSetConcurrency)


Previous (TZProcedureResultType)
Next (TZResultSetType)

Name
TZResultSetConcurrency

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZResultSetConcurrency = ( rcReadOnly , rcUpdatable ) ;

mAirListScript
Class Tree
Index
Previous (TZProcedureResultType)
Next (TZResultSetType)


Previous (TZResultSetConcurrency)
Next (TZScopeBestRowIdentifier)

Name
TZResultSetType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZResultSetType = ( rtForwardOnly , rtScrollInsensitive , rtScrollSensitive ) ;

mAirListScript
Class Tree
Index
Previous (TZResultSetConcurrency)
Next (TZScopeBestRowIdentifier)


Previous (TZResultSetType)
Next (TZSQLType)

Name
TZScopeBestRowIdentifier

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZScopeBestRowIdentifier = ( sbrTemporary , sbrTransaction , sbrSession ) ;

mAirListScript
Class Tree
Index
Previous (TZResultSetType)
Next (TZSQLType)


Previous (TZScopeBestRowIdentifier)
Next (TZTableIndex)

Name
TZSQLType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZSQLType = ( stUnknown , stBoolean , stByte , stShort , stInteger , stLong , stFloat , stDouble , stBigDecimal , stString , stUnicodeString , stBytes , stDate , stTime , stTimestamp , stAsciiStream , stUnicodeStream , stBinaryStream ) ;

mAirListScript
Class Tree
Index
Previous (TZScopeBestRowIdentifier)
Next (TZTableIndex)


Previous (TZSQLType)
Next (TZTransactIsolationLevel)

Name
TZTableIndex

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZTableIndex = ( tiStatistic , tiClustered , tiHashed , tiOther ) ;

mAirListScript
Class Tree
Index
Previous (TZSQLType)
Next (TZTransactIsolationLevel)


Previous (TZTableIndex)
Next (TZVersionColumn)

Name
TZTransactIsolationLevel

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZTransactIsolationLevel = ( tiNone , tiReadUncommitted , tiReadCommitted , tiRepeatableRead , tiSerializable ) ;

mAirListScript
Class Tree
Index
Previous (TZTableIndex)
Next (TZVersionColumn)


Previous (TZTransactIsolationLevel)
Next

Name
TZVersionColumn

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZVersionColumn = ( vcUnknown , vcNotPseudo , vcPseudo ) ;

mAirListScript
Class Tree
Index
Previous (TZTransactIsolationLevel)
Next


Previous
Next (TypeSearchable)

Name
ProcedureReturnsResult

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
ProcedureReturnsResult = 2

mAirListScript
Class Tree
Index
Previous
Next (TypeSearchable)


Previous (ProcedureReturnsResult)
Next

Name
TypeSearchable

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TypeSearchable = 3

mAirListScript
Class Tree
Index
Previous (ProcedureReturnsResult)
Next


Previous
Next

Name
DriverManager

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
DriverManager : IZDriverManager

mAirListScript
Class Tree
Index
Previous
Next