mAirListScript - The scripting interface to mAirList

mAirListScript

Class Tree
Index
Previous
Next

Name
mAirListScript

Description
The scripting interface to mAirList
The scripting interface to mAirList

The XML interface was extracted from the OmniXML package (www.omnixml.com).

Author
Torben Weibert

Units
Unit Description
BassStreamingInterfaces
BassStreamingTypes
CoreRemoteInterface
DHDInterfaces
DHDTypes
InpOut32Interface
mAirListInterfaces
mAirListScript
mAirListTypes
MidiInterface
SASInterface
SimpleSQLInterface
SimpleXMLInterface
WMClientInterface

mAirListScript
Class Tree
Index
Previous
Next

Copyright mairlist GmbH 2014
Created with DelphiCodeToDoc. To obtain the latest revision, please visit http://dephicodetodoc.sourceforge.net/


Previous (mAirListScript)
Next

Name
_ClassHierarchy

Class Hierarchy

#ROOT#

TObject

IInterface

* IBaseMessage

* IFactoryClass

* IFileTypeHandlerClass

* IFileStorageClass

* IProgressIndicator

* IPersistentStorage

* IPersistentNull

* IPersistentNumber

* IPersistentString

* IPersistentBoolean

* IPersistentDateTime

* IPersistentArray

* IPersistentObject

* IPersistent

* IObservable

* IUpdateObject

* ISerializable

* IPersistentListItem

* IPersistentListItemMetadata

* IPersistentPlaylistItemMetadata

* IPlaylistItemMetadata

* IActivePlaylistItemMetadata

* IMultiPlaylistItemMetadata

* IConfigObject

* IDatabase

* IRemote

* IRM4200DRemote

* ISASRemote

* ISerialSASRemote

* IIPSASRemote

* ILogInterface

* IFileEncoderSettings

* IEncoderConnection

* IBassEncEncoderConnection

* IBaseShoutcastEncoderConnection

* IShoutcastEncoderConnection

* IIcecastEncoderConnection

* IInternalServerEncoderConnection

* IAircheckEncoderConnection

* ILocalAudioEncoderConnection

* ICueDataItem

* IAddableCueDataItem

* ITrackCueDataItem

* IEOFWarningCueDataItem

* IMetaCueDataItem

* IEnvelopePoint

* IAction

* IRemoteAction

* IRM4200DAction

* IRM4200DSetAllPFLOffAction

* IRM4200DChannelValueAction

* IRM4200DSetPFLAction

* IRM4200DSetFaderOnAction

* IRM4200DSetLogicAction

* ISASAction

* ISASSourceAction

* ISASSourceLevelAction

* ISASSetFaderLevelAction

* ISASSetFaderInputGainAction

* ISASSetPFLOnAction

* ISASSetPFLOffAction

* ISASSetFaderStartOnAction

* ISASSetFaderStartOffAction

* ISASSetGPIAction

* ISASSetGPIOnAction

* ISASSetGPIOffAction

* IEmergencyAction

* IDatabaseAction

* IPlaylistItem

* IFilePlaylistItem

* IInlineFilePlaylistItem

* IURLPlaylistItem

* IStreamPlaylistItem

* IContainerPlaylistItem

* IRegionContainerPlaylistItem

* IDummyPlaylistItem

* ICommandPlaylistItem

* IBreakPlaylistItem

* ISilencePlaylistItem

* IInfiniteSilencePlaylistItem

* IPlaylistFilePlaylistItem

* IAddablePlaylistItem

* IEventListItem

* IStandardAttribute

* ICartwallTrigger

* ICartwallItem

* IAudioCartwallItem

* ICartwallPageControl

* IBaseList

* IObservableList

* IPersistentList

* IConfigObjectList

* IDatabaseList

* IRemoteList

* IRemoteController

* ILogInterfaceList

* IEncoderConnectionList

* ICueData

* IEnvelope

* IActionList

* IPlaylist

* IActivePlaylist

* IPlaybackControl

* IRecycleBinPlaylist

* IMultiPlaylist

* IEventList

* IStandardAttributeList

* ICartwallTriggerList

* ICartwallItemList

* ICartwallPageControlList

* IAudioDeviceList

* IPlaybackDeviceList

* IRecordDeviceList

* ILogEntryList

* IInlineData

* IAudioSource

* IMultiAudioSource

* IAudioDevice

* IPlaybackDevice

* IRecordDevice

* INoAudioDevice

* IAudioDeviceConfig

* IMixdownEngine

* ISourceControl

* IPlayerControl

* IPlaylistPlayerControl

* IEngine

* IModule

* IHiddenModule

* IEventsModule

* IMultiInstanceModule

* IPlayoutModule

* ICartwallModule

* IBassStreamingModule

* IFileManager

* ILogger

* IPeakAnalyzer

* IFileEncoder

* ICartPlayerControl

* ICartwallControl

* IBassStreamingEncoder

* IDatabaseSearchHandler

* IComPort

* ILevelInfo

* IMutex

* IStrings

* IConfigValues

* IFileData

* IWritableFileData

* IStream

* IWritableStream

* IIncompleteStream

* IClientList

* IDummyAction

* IDatabaseTree

* IDatabaseInlineLoader

* IFileDataRecorder

* IMixdownEngine2

* IFileTypeHandler

* IStubPlaylistItem

* IBaseComPortRemote

* IEngineDesktopPlugin

* IEngineInfo

* IMixer

* ISerialPortManager

* IFilePlaylistItemClass

* IFactory

* IConfiguration

* IFileStorage

* IPlaylistStorage

* IPlaylistImporter

* IPlaylistExporter

* IAutoCueEngine

* ILicenseData

* IModuleList

* INotifiedMessageReceiver

* ILogEntry

* IMessageDispatcher

* IInstanceData

* ImAirListInstance

* INotifyItemStarted

* IDummyObject

* IDebugObject

* IRunnable

* IBassStreamingConfigPage

* IMidiRemote

* IWMClientRemote

* IIOPort

* ISQLResultSet

* ISQLPreparedStatement

* ISQLConnection

* ISXMLNode

* ISXMLNodeList

* ISXMLDocument

No parent

* TDatabaseNodeData

* TMidiMessage

#OrphanClass#

* EMessage

* ELicenseError

* IConfigValuesList

* IBassEncoderPlaybackDevice

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next


Previous
Next (BassStreamingTypes)

Name
BassStreamingInterfaces

Parent
mAirListScript

Classes
Class Description
IAircheckEncoderConnection (+)
IBaseShoutcastEncoderConnection (+)
IBassEncEncoderConnection (+)
IBassEncoderPlaybackDevice (+)
IBassStreamingConfigPage (+)
IBassStreamingEncoder (+)
IBassStreamingModule (+)
IEncoderConnection (+)
IEncoderConnectionList (+)
IIcecastEncoderConnection (+)
IInternalServerEncoderConnection (+)
ILocalAudioEncoderConnection (+)
IShoutcastEncoderConnection (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (BassStreamingTypes)


Previous
Next (IBaseShoutcastEncoderConnection)

Name
IAircheckEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetDirectory (+)
GetEncoderSettings (+)
GetFilenameFormat (+)
GetSplitDuration (+)
SetDirectory (+)
SetFilenameFormat (+)
SetSplitDuration (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IBaseShoutcastEncoderConnection)


Previous
Next (GetEncoderSettings)

Name
GetDirectory

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetDirectory : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEncoderSettings)


Previous (GetDirectory)
Next (GetFilenameFormat)

Name
GetEncoderSettings

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderSettings : IFileEncoderSettings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDirectory)
Next (GetFilenameFormat)


Previous (GetEncoderSettings)
Next (GetSplitDuration)

Name
GetFilenameFormat

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetFilenameFormat : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderSettings)
Next (GetSplitDuration)


Previous (GetFilenameFormat)
Next (SetDirectory)

Name
GetSplitDuration

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetSplitDuration : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilenameFormat)
Next (SetDirectory)


Previous (GetSplitDuration)
Next (SetFilenameFormat)

Name
SetDirectory

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetDirectory ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSplitDuration)
Next (SetFilenameFormat)


Previous (SetDirectory)
Next (SetSplitDuration)

Name
SetFilenameFormat

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetFilenameFormat ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDirectory)
Next (SetSplitDuration)


Previous (SetFilenameFormat)
Next

Name
SetSplitDuration

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetSplitDuration ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFilenameFormat)
Next


Previous (IAircheckEncoderConnection)
Next (IBassEncEncoderConnection)

Name
IBaseShoutcastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBassEncEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetAIM (+)
GetConnectDelay (+)
GetDescription (+)
GetFetchListenersInterval (+)
GetGenre (+)
GetICQ (+)
GetIncludeItemTypes (+)
GetIRC (+)
GetLogFormat (+)
GetNoStreaming (+)
GetPassword (+)
GetPublic (+)
GetReconnectDelay (+)
GetTitle (+)
GetTitleUpdateDelay (+)
GetURL (+)
GetUser (+)
SetAIM (+)
SetConnectDelay (+)
SetDescription (+)
SetFetchListenersInterval (+)
SetGenre (+)
SetICQ (+)
SetIncludeItemTypes (+)
SetIRC (+)
SetLogFormat (+)
SetNoStreaming (+)
SetPassword (+)
SetPublic (+)
SetReconnectDelay (+)
SetTitle (+)
SetTitleUpdateDelay (+)
SetURL (+)
SetUser (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAircheckEncoderConnection)
Next (IBassEncEncoderConnection)


Previous
Next (GetConnectDelay)

Name
GetAIM

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetAIM : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetConnectDelay)


Previous (GetAIM)
Next (GetDescription)

Name
GetConnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetConnectDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAIM)
Next (GetDescription)


Previous (GetConnectDelay)
Next (GetFetchListenersInterval)

Name
GetDescription

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnectDelay)
Next (GetFetchListenersInterval)


Previous (GetDescription)
Next (GetGenre)

Name
GetFetchListenersInterval

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetFetchListenersInterval : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetGenre)


Previous (GetFetchListenersInterval)
Next (GetICQ)

Name
GetGenre

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetGenre : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchListenersInterval)
Next (GetICQ)


Previous (GetGenre)
Next (GetIncludeItemTypes)

Name
GetICQ

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetICQ : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGenre)
Next (GetIncludeItemTypes)


Previous (GetICQ)
Next (GetIRC)

Name
GetIncludeItemTypes

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetIncludeItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetICQ)
Next (GetIRC)


Previous (GetIncludeItemTypes)
Next (GetLogFormat)

Name
GetIRC

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetIRC : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIncludeItemTypes)
Next (GetLogFormat)


Previous (GetIRC)
Next (GetNoStreaming)

Name
GetLogFormat

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetLogFormat : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIRC)
Next (GetNoStreaming)


Previous (GetLogFormat)
Next (GetPassword)

Name
GetNoStreaming

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetNoStreaming : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogFormat)
Next (GetPassword)


Previous (GetNoStreaming)
Next (GetPublic)

Name
GetPassword

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetPassword : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNoStreaming)
Next (GetPublic)


Previous (GetPassword)
Next (GetReconnectDelay)

Name
GetPublic

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetPublic : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPassword)
Next (GetReconnectDelay)


Previous (GetPublic)
Next (GetTitle)

Name
GetReconnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetReconnectDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPublic)
Next (GetTitle)


Previous (GetReconnectDelay)
Next (GetTitleUpdateDelay)

Name
GetTitle

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetReconnectDelay)
Next (GetTitleUpdateDelay)


Previous (GetTitle)
Next (GetURL)

Name
GetTitleUpdateDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetTitleUpdateDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (GetURL)


Previous (GetTitleUpdateDelay)
Next (GetUser)

Name
GetURL

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitleUpdateDelay)
Next (GetUser)


Previous (GetURL)
Next (SetAIM)

Name
GetUser

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetUser : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetURL)
Next (SetAIM)


Previous (GetUser)
Next (SetConnectDelay)

Name
SetAIM

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetAIM ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetUser)
Next (SetConnectDelay)


Previous (SetAIM)
Next (SetDescription)

Name
SetConnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetConnectDelay ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAIM)
Next (SetDescription)


Previous (SetConnectDelay)
Next (SetFetchListenersInterval)

Name
SetDescription

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetConnectDelay)
Next (SetFetchListenersInterval)


Previous (SetDescription)
Next (SetGenre)

Name
SetFetchListenersInterval

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetFetchListenersInterval ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetGenre)


Previous (SetFetchListenersInterval)
Next (SetICQ)

Name
SetGenre

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetGenre ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFetchListenersInterval)
Next (SetICQ)


Previous (SetGenre)
Next (SetIncludeItemTypes)

Name
SetICQ

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetICQ ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetGenre)
Next (SetIncludeItemTypes)


Previous (SetICQ)
Next (SetIRC)

Name
SetIncludeItemTypes

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetIncludeItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter | Description
iValue : TPlaylistItemTypes | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetICQ)
Next (SetIRC)


Previous (SetIncludeItemTypes)
Next (SetLogFormat)

Name
SetIRC

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetIRC ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIncludeItemTypes)
Next (SetLogFormat)


Previous (SetIRC)
Next (SetNoStreaming)

Name
SetLogFormat

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetLogFormat ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIRC)
Next (SetNoStreaming)


Previous (SetLogFormat)
Next (SetPassword)

Name
SetNoStreaming

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetNoStreaming ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLogFormat)
Next (SetPassword)


Previous (SetNoStreaming)
Next (SetPublic)

Name
SetPassword

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPassword ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNoStreaming)
Next (SetPublic)


Previous (SetPassword)
Next (SetReconnectDelay)

Name
SetPublic

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPublic ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPassword)
Next (SetReconnectDelay)


Previous (SetPublic)
Next (SetTitle)

Name
SetReconnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetReconnectDelay ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPublic)
Next (SetTitle)


Previous (SetReconnectDelay)
Next (SetTitleUpdateDelay)

Name
SetTitle

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetReconnectDelay)
Next (SetTitleUpdateDelay)


Previous (SetTitle)
Next (SetURL)

Name
SetTitleUpdateDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetTitleUpdateDelay ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next (SetURL)


Previous (SetTitleUpdateDelay)
Next (SetUser)

Name
SetURL

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetURL ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitleUpdateDelay)
Next (SetUser)


Previous (SetURL)
Next

Name
SetUser

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetUser ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetURL)
Next


Previous (IBaseShoutcastEncoderConnection)
Next (IBassEncoderPlaybackDevice)

Name
IBassEncEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetAllowedAudioFormats (+)
GetAudioFormat (+)
GetBitrate (+)
GetCountListeners (+)
GetEncoderOptions (+)
GetHostname (+)
GetMimeType (+)
GetMode (+)
GetPort (+)
SetAudioFormat (+)
SetBitrate (+)
SetCountListeners (+)
SetEncoderOptions (+)
SetHostname (+)
SetMimeType (+)
SetMode (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseShoutcastEncoderConnection)
Next (IBassEncoderPlaybackDevice)


Previous
Next (GetAudioFormat)

Name
GetAllowedAudioFormats

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetAllowedAudioFormats : TBassStreamingFormats

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetAudioFormat)


Previous (GetAllowedAudioFormats)
Next (GetBitrate)

Name
GetAudioFormat

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetAudioFormat : TBassStreamingFormat

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAllowedAudioFormats)
Next (GetBitrate)


Previous (GetAudioFormat)
Next (GetCountListeners)

Name
GetBitrate

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetBitrate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAudioFormat)
Next (GetCountListeners)


Previous (GetBitrate)
Next (GetEncoderOptions)

Name
GetCountListeners

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetCountListeners : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBitrate)
Next (GetEncoderOptions)


Previous (GetCountListeners)
Next (GetHostname)

Name
GetEncoderOptions

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderOptions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCountListeners)
Next (GetHostname)


Previous (GetEncoderOptions)
Next (GetMimeType)

Name
GetHostname

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetHostname : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderOptions)
Next (GetMimeType)


Previous (GetHostname)
Next (GetMode)

Name
GetMimeType

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetMimeType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHostname)
Next (GetMode)


Previous (GetMimeType)
Next (GetPort)

Name
GetMode

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetMode : TAudioMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMimeType)
Next (GetPort)


Previous (GetMode)
Next (SetAudioFormat)

Name
GetPort

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMode)
Next (SetAudioFormat)


Previous (GetPort)
Next (SetBitrate)

Name
SetAudioFormat

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetAudioFormat ( iValue : TBassStreamingFormat )

Parameters
Parameter | Description
iValue : TBassStreamingFormat | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SetBitrate)


Previous (SetAudioFormat)
Next (SetCountListeners)

Name
SetBitrate

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetBitrate ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAudioFormat)
Next (SetCountListeners)


Previous (SetBitrate)
Next (SetEncoderOptions)

Name
SetCountListeners

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetCountListeners ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBitrate)
Next (SetEncoderOptions)


Previous (SetCountListeners)
Next (SetHostname)

Name
SetEncoderOptions

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetEncoderOptions ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCountListeners)
Next (SetHostname)


Previous (SetEncoderOptions)
Next (SetMimeType)

Name
SetHostname

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetHostname ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEncoderOptions)
Next (SetMimeType)


Previous (SetHostname)
Next (SetMode)

Name
SetMimeType

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetMimeType ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetHostname)
Next (SetMode)


Previous (SetMimeType)
Next (SetPort)

Name
SetMode

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetMode ( iValue : TAudioMode )

Parameters
Parameter | Description
iValue : TAudioMode | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMimeType)
Next (SetPort)


Previous (SetMode)
Next

Name
SetPort

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMode)
Next


Previous (IBassEncEncoderConnection)
Next (IBassStreamingConfigPage)

Name
IBassEncoderPlaybackDevice

Parent
BassStreamingInterfaces

Class Hierarchy
IBassMixPlaybackDevice

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassEncEncoderConnection)
Next (IBassStreamingConfigPage)


Previous (IBassEncoderPlaybackDevice)
Next (IBassStreamingEncoder)

Name
IBassStreamingConfigPage

Parent
BassStreamingInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassEncoderPlaybackDevice)
Next (IBassStreamingEncoder)


Previous (IBassStreamingConfigPage)
Next (IBassStreamingModule)

Name
IBassStreamingEncoder

Parent
BassStreamingInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Connect (+)
Disconnect (+)
GetConnections (+)
GetDSPPlugins (+)
GetDuckLevel (+)
GetDuckSpeed (+)
GetEffectiveChannelCount (+)
GetEffectiveRegionCount (+)
GetLineInputEnabled (+)
GetListeners (+)
GetLocalOutputEnabled (+)
GetMicInputEnabled (+)
GetMixerInterface (+)
GetOptions (+)
GetSamplerate (+)
GetState (+)
SetDuckLevel (+)
SetDuckSpeed (+)
SetLineInputEnabled (+)
SetLocalOutputEnabled (+)
SetMicInputEnabled (+)
SetOptions (+)
SetSamplerate (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingConfigPage)
Next (IBassStreamingModule)


Previous
Next (Disconnect)

Name
Connect

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure Connect ( iAsync : boolean )

Parameters
Parameter | Description
iAsync : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Disconnect)


Previous (Connect)
Next (GetConnections)

Name
Disconnect

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure Disconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Connect)
Next (GetConnections)


Previous (Disconnect)
Next (GetDSPPlugins)

Name
GetConnections

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetConnections : IEncoderConnectionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Disconnect)
Next (GetDSPPlugins)


Previous (GetConnections)
Next (GetDuckLevel)

Name
GetDSPPlugins

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetDSPPlugins ( iHook : TEncoderDSPHook ) : IBassDSPPluginList

Parameters
Parameter | Description
iHook : TEncoderDSPHook | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetConnections)
Next (GetDuckLevel)


Previous (GetDSPPlugins)
Next (GetDuckSpeed)

Name
GetDuckLevel

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetDuckLevel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDSPPlugins)
Next (GetDuckSpeed)


Previous (GetDuckLevel)
Next (GetEffectiveChannelCount)

Name
GetDuckSpeed

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetDuckSpeed : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuckLevel)
Next (GetEffectiveChannelCount)


Previous (GetDuckSpeed)
Next (GetEffectiveRegionCount)

Name
GetEffectiveChannelCount

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetEffectiveChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuckSpeed)
Next (GetEffectiveRegionCount)


Previous (GetEffectiveChannelCount)
Next (GetLineInputEnabled)

Name
GetEffectiveRegionCount

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetEffectiveRegionCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveChannelCount)
Next (GetLineInputEnabled)


Previous (GetEffectiveRegionCount)
Next (GetListeners)

Name
GetLineInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetLineInputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveRegionCount)
Next (GetListeners)


Previous (GetLineInputEnabled)
Next (GetLocalOutputEnabled)

Name
GetListeners

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetListeners : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLineInputEnabled)
Next (GetLocalOutputEnabled)


Previous (GetListeners)
Next (GetMicInputEnabled)

Name
GetLocalOutputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetLocalOutputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetListeners)
Next (GetMicInputEnabled)


Previous (GetLocalOutputEnabled)
Next (GetMixerInterface)

Name
GetMicInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetMicInputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLocalOutputEnabled)
Next (GetMixerInterface)


Previous (GetMicInputEnabled)
Next (GetOptions)

Name
GetMixerInterface

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetMixerInterface ( iMixer : TBassStreamingMixer ) : IBassMixer

Parameters
Parameter | Description
iMixer : TBassStreamingMixer | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMicInputEnabled)
Next (GetOptions)


Previous (GetMixerInterface)
Next (GetSamplerate)

Name
GetOptions

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetOptions : TEncoderOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMixerInterface)
Next (GetSamplerate)


Previous (GetOptions)
Next (GetState)

Name
GetSamplerate

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetSamplerate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetState)


Previous (GetSamplerate)
Next (SetDuckLevel)

Name
GetState

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetState : TEncoderState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSamplerate)
Next (SetDuckLevel)


Previous (GetState)
Next (SetDuckSpeed)

Name
SetDuckLevel

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetDuckLevel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetDuckSpeed)


Previous (SetDuckLevel)
Next (SetLineInputEnabled)

Name
SetDuckSpeed

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetDuckSpeed ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDuckLevel)
Next (SetLineInputEnabled)


Previous (SetDuckSpeed)
Next (SetLocalOutputEnabled)

Name
SetLineInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetLineInputEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDuckSpeed)
Next (SetLocalOutputEnabled)


Previous (SetLineInputEnabled)
Next (SetMicInputEnabled)

Name
SetLocalOutputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetLocalOutputEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLineInputEnabled)
Next (SetMicInputEnabled)


Previous (SetLocalOutputEnabled)
Next (SetOptions)

Name
SetMicInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetMicInputEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLocalOutputEnabled)
Next (SetOptions)


Previous (SetMicInputEnabled)
Next (SetSamplerate)

Name
SetOptions

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TEncoderOptions )

Parameters
Parameter | Description
iValue : TEncoderOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMicInputEnabled)
Next (SetSamplerate)


Previous (SetOptions)
Next

Name
SetSamplerate

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetSamplerate ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (IBassStreamingEncoder)
Next (IEncoderConnection)

Name
IBassStreamingModule

Parent
BassStreamingInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Members
Methods
Method Description
GetEncoder (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingEncoder)
Next (IEncoderConnection)


Previous
Next

Name
GetEncoder

Parent
IBassStreamingModule

Visibility
PUBLIC

Source code
function GetEncoder : IBassStreamingEncoder

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IBassStreamingModule)
Next (IEncoderConnectionList)

Name
IEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
GetCustomCaption (+)
GetDSPPlugins (+)
GetEncoderStream (+)
GetListeners (+)
GetRegions (+)
GetState (+)
ItemStarted (+)
SetCustomCaption (+)
SetEncoderStream (+)
SetRegions (+)
SetStreamTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingModule)
Next (IEncoderConnectionList)


Previous
Next (GetDSPPlugins)

Name
GetCustomCaption

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetCustomCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDSPPlugins)


Previous (GetCustomCaption)
Next (GetEncoderStream)

Name
GetDSPPlugins

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetDSPPlugins : IBassDSPPluginList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomCaption)
Next (GetEncoderStream)


Previous (GetDSPPlugins)
Next (GetListeners)

Name
GetEncoderStream

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderStream : IBassMixer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDSPPlugins)
Next (GetListeners)


Previous (GetEncoderStream)
Next (GetRegions)

Name
GetListeners

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetListeners : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderStream)
Next (GetRegions)


Previous (GetListeners)
Next (GetState)

Name
GetRegions

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetRegions : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetListeners)
Next (GetState)


Previous (GetRegions)
Next (ItemStarted)

Name
GetState

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetState : TEncoderConnectionState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (ItemStarted)


Previous (GetState)
Next (SetCustomCaption)

Name
ItemStarted

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure ItemStarted ( iItem : IPlaylistItem ; iRegion : byte )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetCustomCaption)


Previous (ItemStarted)
Next (SetEncoderStream)

Name
SetCustomCaption

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetCustomCaption ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ItemStarted)
Next (SetEncoderStream)


Previous (SetCustomCaption)
Next (SetRegions)

Name
SetEncoderStream

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetEncoderStream ( iValue : IBassMixer )

Parameters
Parameter | Description
iValue : IBassMixer | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCustomCaption)
Next (SetRegions)


Previous (SetEncoderStream)
Next (SetStreamTitle)

Name
SetRegions

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetRegions ( iValue : TSetOfByte )

Parameters
Parameter | Description
iValue : TSetOfByte | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEncoderStream)
Next (SetStreamTitle)


Previous (SetRegions)
Next

Name
SetStreamTitle

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetStreamTitle ( iTitle : string ; iImmediately : boolean )

Parameters
Parameter | Description
iTitle : STRING | &nbsp;
iImmediately : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRegions)
Next


Previous (IEncoderConnection)
Next (IIcecastEncoderConnection)

Name
IEncoderConnectionList

Parent
BassStreamingInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetEncoderStream (+)
GetItem (+)
ItemStarted (+)
SetEncoderStream (+)
SetStreamTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEncoderConnection)
Next (IIcecastEncoderConnection)


Previous
Next (GetItem)

Name
GetEncoderStream

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
function GetEncoderStream : IBassMixer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEncoderStream)
Next (ItemStarted)

Name
GetItem

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IEncoderConnection

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetEncoderStream)
Next (ItemStarted)


Previous (GetItem)
Next (SetEncoderStream)

Name
ItemStarted

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure ItemStarted ( iItem : IPlaylistItem ; iRegion : byte )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (SetEncoderStream)


Previous (ItemStarted)
Next (SetStreamTitle)

Name
SetEncoderStream

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure SetEncoderStream ( iValue : IBassMixer )

Parameters
Parameter | Description
iValue : IBassMixer | &nbsp;

mAirListScript
Class Tree
Index
Previous (ItemStarted)
Next (SetStreamTitle)


Previous (SetEncoderStream)
Next

Name
SetStreamTitle

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure SetStreamTitle ( iTitle : string ; iImmediately : boolean )

Parameters
Parameter | Description
iTitle : STRING | &nbsp;
iImmediately : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEncoderStream)
Next


Previous (IEncoderConnectionList)
Next (IInternalServerEncoderConnection)

Name
IIcecastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetMount (+)
SetMount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEncoderConnectionList)
Next (IInternalServerEncoderConnection)


Previous
Next (SetMount)

Name
GetMount

Parent
IIcecastEncoderConnection

Visibility
PUBLIC

Source code
function GetMount : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetMount)


Previous (GetMount)
Next

Name
SetMount

Parent
IIcecastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetMount ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMount)
Next


Previous (IIcecastEncoderConnection)
Next (ILocalAudioEncoderConnection)

Name
IInternalServerEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBassEncEncoderConnection

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIcecastEncoderConnection)
Next (ILocalAudioEncoderConnection)


Previous (IInternalServerEncoderConnection)
Next (IShoutcastEncoderConnection)

Name
ILocalAudioEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetPlaybackDevice (+)
SetPlaybackDevice (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInternalServerEncoderConnection)
Next (IShoutcastEncoderConnection)


Previous
Next (SetPlaybackDevice)

Name
GetPlaybackDevice

Parent
ILocalAudioEncoderConnection

Visibility
PUBLIC

Source code
function GetPlaybackDevice : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPlaybackDevice)


Previous (GetPlaybackDevice)
Next

Name
SetPlaybackDevice

Parent
ILocalAudioEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPlaybackDevice ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlaybackDevice)
Next


Previous (ILocalAudioEncoderConnection)
Next

Name
IShoutcastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetStreamID (+)
SetStreamID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILocalAudioEncoderConnection)
Next


Previous
Next (SetStreamID)

Name
GetStreamID

Parent
IShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetStreamID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetStreamID)


Previous (GetStreamID)
Next

Name
SetStreamID

Parent
IShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetStreamID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetStreamID)
Next


Previous (BassStreamingInterfaces)
Next (CoreRemoteInterface)

Name
BassStreamingTypes

Parent
mAirListScript

Types
Type Description
TBassStreamingFormat (+)
TBassStreamingFormats (+)
TBassStreamingMixer (+)
TEncoderConnectionState (+)
TEncoderDSPHook (+)
TEncoderOption (+)
TEncoderOptions (+)
TEncoderState (+)

Constants
Constant Description
AllBassStreamingFormats (+)
DefaultEncoderOptions (+)
STREAMING_MIXER_MASTER (+)
STREAMING_MIXER_MASTERPREDSP (+)
STREAMING_MIXER_PLAYER (+)
STREAMING_MIXER_PLAYERLINE (+)
STREAMING_MIXER_PLAYERNODSP (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (BassStreamingInterfaces)
Next (CoreRemoteInterface)


Previous
Next (TBassStreamingFormats)

Name
TBassStreamingFormat

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TBassStreamingFormat = ( sfMP3 , sfOggVorbis , sfOpus , sfCustom ) ;

mAirListScript
Class Tree
Index
Previous
Next (TBassStreamingFormats)


Previous (TBassStreamingFormat)
Next (TBassStreamingMixer)

Name
TBassStreamingFormats

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TBassStreamingFormats = set of TBassStreamingFormat ;

mAirListScript
Class Tree
Index
Previous (TBassStreamingFormat)
Next (TBassStreamingMixer)


Previous (TBassStreamingFormats)
Next (TEncoderConnectionState)

Name
TBassStreamingMixer

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TBassStreamingMixer = ( smPlayer , smPlayerNoDSP , smPlayerLine , smMasterPreDSP , smMaster ) ;

mAirListScript
Class Tree
Index
Previous (TBassStreamingFormats)
Next (TEncoderConnectionState)


Previous (TBassStreamingMixer)
Next (TEncoderDSPHook)

Name
TEncoderConnectionState

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderConnectionState = ( ecsConnected , ecsConnecting , ecsDisconnected , ecsError ) ;

mAirListScript
Class Tree
Index
Previous (TBassStreamingMixer)
Next (TEncoderDSPHook)


Previous (TEncoderConnectionState)
Next (TEncoderOption)

Name
TEncoderDSPHook

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderDSPHook = ( dspMaster , dspPlayer , dspMic , dspLine ) ;

mAirListScript
Class Tree
Index
Previous (TEncoderConnectionState)
Next (TEncoderOption)


Previous (TEncoderDSPHook)
Next (TEncoderOptions)

Name
TEncoderOption

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderOption = ( eoLinkOnAir , eoLinkOnAirReverse , eoDuckPlayerVolumeMic , eoNoMicPlayback , eoPreDSPPlayback ) ;

mAirListScript
Class Tree
Index
Previous (TEncoderDSPHook)
Next (TEncoderOptions)


Previous (TEncoderOption)
Next (TEncoderState)

Name
TEncoderOptions

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderOptions = set of TEncoderOption ;

mAirListScript
Class Tree
Index
Previous (TEncoderOption)
Next (TEncoderState)


Previous (TEncoderOptions)
Next

Name
TEncoderState

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderState = ( esConnected , esDisconnected ) ;

mAirListScript
Class Tree
Index
Previous (TEncoderOptions)
Next


Previous
Next (DefaultEncoderOptions)

Name
AllBassStreamingFormats

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
AllBassStreamingFormats = [ sfMP3 , sfOggVorbis , sfOpus , sfCustom ]

mAirListScript
Class Tree
Index
Previous
Next (DefaultEncoderOptions)


Previous (AllBassStreamingFormats)
Next (STREAMING_MIXER_MASTER)

Name
DefaultEncoderOptions

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
DefaultEncoderOptions = [ ]

mAirListScript
Class Tree
Index
Previous (AllBassStreamingFormats)
Next (STREAMING_MIXER_MASTER)


Previous (DefaultEncoderOptions)
Next (STREAMING_MIXER_MASTERPREDSP)

Name
STREAMING_MIXER_MASTER

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
STREAMING_MIXER_MASTER = 4

mAirListScript
Class Tree
Index
Previous (DefaultEncoderOptions)
Next (STREAMING_MIXER_MASTERPREDSP)


Previous (STREAMING_MIXER_MASTER)
Next (STREAMING_MIXER_PLAYER)

Name
STREAMING_MIXER_MASTERPREDSP

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
STREAMING_MIXER_MASTERPREDSP = 3

mAirListScript
Class Tree
Index
Previous (STREAMING_MIXER_MASTER)
Next (STREAMING_MIXER_PLAYER)


Previous (STREAMING_MIXER_MASTERPREDSP)
Next (STREAMING_MIXER_PLAYERLINE)

Name
STREAMING_MIXER_PLAYER

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
STREAMING_MIXER_PLAYER = 0

mAirListScript
Class Tree
Index
Previous (STREAMING_MIXER_MASTERPREDSP)
Next (STREAMING_MIXER_PLAYERLINE)


Previous (STREAMING_MIXER_PLAYER)
Next (STREAMING_MIXER_PLAYERNODSP)

Name
STREAMING_MIXER_PLAYERLINE

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
STREAMING_MIXER_PLAYERLINE = 2

mAirListScript
Class Tree
Index
Previous (STREAMING_MIXER_PLAYER)
Next (STREAMING_MIXER_PLAYERNODSP)


Previous (STREAMING_MIXER_PLAYERLINE)
Next

Name
STREAMING_MIXER_PLAYERNODSP

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
STREAMING_MIXER_PLAYERNODSP = 1

mAirListScript
Class Tree
Index
Previous (STREAMING_MIXER_PLAYERLINE)
Next


Previous (BassStreamingTypes)
Next (DHDInterfaces)

Name
CoreRemoteInterface

Parent
mAirListScript

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (BassStreamingTypes)
Next (DHDInterfaces)


Previous (CoreRemoteInterface)
Next (DHDTypes)

Name
DHDInterfaces

Parent
mAirListScript

Classes
Class Description
IRM4200DAction (+)
IRM4200DChannelValueAction (+)
IRM4200DRemote (+)
IRM4200DSetAllPFLOffAction (+)
IRM4200DSetFaderOnAction (+)
IRM4200DSetLogicAction (+)
IRM4200DSetPFLAction (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (CoreRemoteInterface)
Next (DHDTypes)


Previous
Next (IRM4200DChannelValueAction)

Name
IRM4200DAction

Parent
DHDInterfaces

Class Hierarchy
IRemoteAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IRM4200DChannelValueAction)


Previous (IRM4200DAction)
Next (IRM4200DRemote)

Name
IRM4200DChannelValueAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Members
Methods
Method Description
GetChannel (+)
GetValue (+)
SetChannel (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DAction)
Next (IRM4200DRemote)


Previous
Next (GetValue)

Name
GetChannel

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
function GetChannel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetValue)


Previous (GetChannel)
Next (SetChannel)

Name
GetValue

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChannel)
Next (SetChannel)


Previous (GetValue)
Next (SetValue)

Name
SetChannel

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
procedure SetChannel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetValue)


Previous (SetChannel)
Next

Name
SetValue

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetChannel)
Next


Previous (IRM4200DChannelValueAction)
Next (IRM4200DSetAllPFLOffAction)

Name
IRM4200DRemote

Parent
DHDInterfaces

Class Hierarchy
IRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetCommunicationMode (+)
GetHostname (+)
GetLogicOffCommand (+)
GetLogicOnCommand (+)
GetSerialPort (+)
GetTCPPort (+)
GetVTMicChannel (+)
GetVTPlayerAChannel (+)
GetVTPlayerBChannel (+)
RequestLogic (+)
SendPacket (+)
SendPacketRaw (+)
SetAllPFLOff (+)
SetCommunicationMode (+)
SetFaderOn (+)
SetHostname (+)
SetLogic (+)
SetLogicOffCommand (+)
SetLogicOnCommand (+)
SetMonitorChannel (+)
SetPFL (+)
SetSerialPort (+)
SetTCPPort (+)
SetVTMicChannel (+)
SetVTPlayerAChannel (+)
SetVTPlayerBChannel (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DChannelValueAction)
Next (IRM4200DSetAllPFLOffAction)


Previous
Next (GetHostname)

Name
GetCommunicationMode

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetCommunicationMode : TCommunicationMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetHostname)


Previous (GetCommunicationMode)
Next (GetLogicOffCommand)

Name
GetHostname

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetHostname : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommunicationMode)
Next (GetLogicOffCommand)


Previous (GetHostname)
Next (GetLogicOnCommand)

Name
GetLogicOffCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetLogicOffCommand ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetHostname)
Next (GetLogicOnCommand)


Previous (GetLogicOffCommand)
Next (GetSerialPort)

Name
GetLogicOnCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetLogicOnCommand ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetLogicOffCommand)
Next (GetSerialPort)


Previous (GetLogicOnCommand)
Next (GetTCPPort)

Name
GetSerialPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetSerialPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogicOnCommand)
Next (GetTCPPort)


Previous (GetSerialPort)
Next (GetVTMicChannel)

Name
GetTCPPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetTCPPort : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerialPort)
Next (GetVTMicChannel)


Previous (GetTCPPort)
Next (GetVTPlayerAChannel)

Name
GetVTMicChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetVTMicChannel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTCPPort)
Next (GetVTPlayerAChannel)


Previous (GetVTMicChannel)
Next (GetVTPlayerBChannel)

Name
GetVTPlayerAChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetVTPlayerAChannel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTMicChannel)
Next (GetVTPlayerBChannel)


Previous (GetVTPlayerAChannel)
Next (RequestLogic)

Name
GetVTPlayerBChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetVTPlayerBChannel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTPlayerAChannel)
Next (RequestLogic)


Previous (GetVTPlayerBChannel)
Next (SendPacket)

Name
RequestLogic

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure RequestLogic ( iAddress : word )

Parameters
Parameter | Description
iAddress : WORD | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetVTPlayerBChannel)
Next (SendPacket)


Previous (RequestLogic)
Next (SendPacketRaw)

Name
SendPacket

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SendPacket ( iID : cardinal ; iData : AnsiString )

Parameters
Parameter | Description
iID : CARDINAL | &nbsp;
iData : ANSISTRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (RequestLogic)
Next (SendPacketRaw)


Previous (SendPacket)
Next (SetAllPFLOff)

Name
SendPacketRaw

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SendPacketRaw ( iID : cardinal ; iLength : integer = 0 ; iData0 : byte = 0 ; iData1 : byte = 0 ; iData2 : byte = 0 ; iData3 : byte = 0 ; iData4 : byte = 0 ; iData5 : byte = 0 ; iData6 : byte = 0 ; iData7 : byte = 0 )

Parameters
Parameter | Description
iID : CARDINAL | &nbsp;
iLength : INTEGER | &nbsp;
iData0 : BYTE | &nbsp;
iData1 : BYTE | &nbsp;
iData2 : BYTE | &nbsp;
iData3 : BYTE | &nbsp;
iData4 : BYTE | &nbsp;
iData5 : BYTE | &nbsp;
iData6 : BYTE | &nbsp;
iData7 : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SendPacket)
Next (SetAllPFLOff)


Previous (SendPacketRaw)
Next (SetCommunicationMode)

Name
SetAllPFLOff

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetAllPFLOff

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SendPacketRaw)
Next (SetCommunicationMode)


Previous (SetAllPFLOff)
Next (SetFaderOn)

Name
SetCommunicationMode

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetCommunicationMode ( iValue : TCommunicationMode )

Parameters
Parameter | Description
iValue : TCommunicationMode | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAllPFLOff)
Next (SetFaderOn)


Previous (SetCommunicationMode)
Next (SetHostname)

Name
SetFaderOn

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetFaderOn ( iChannel : word ; iValue : boolean )

Parameters
Parameter | Description
iChannel : WORD | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCommunicationMode)
Next (SetHostname)


Previous (SetFaderOn)
Next (SetLogic)

Name
SetHostname

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetHostname ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFaderOn)
Next (SetLogic)


Previous (SetHostname)
Next (SetLogicOffCommand)

Name
SetLogic

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogic ( iAddress : word ; iValue : boolean )

Parameters
Parameter | Description
iAddress : WORD | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetHostname)
Next (SetLogicOffCommand)


Previous (SetLogic)
Next (SetLogicOnCommand)

Name
SetLogicOffCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogicOffCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLogic)
Next (SetLogicOnCommand)


Previous (SetLogicOffCommand)
Next (SetMonitorChannel)

Name
SetLogicOnCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogicOnCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLogicOffCommand)
Next (SetMonitorChannel)


Previous (SetLogicOnCommand)
Next (SetPFL)

Name
SetMonitorChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetMonitorChannel ( iNumber : byte ; iLeft , iRight : word )

Parameters
Parameter | Description
iNumber : BYTE | &nbsp;
iLeft : WORD | &nbsp;
iRight : WORD | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLogicOnCommand)
Next (SetPFL)


Previous (SetMonitorChannel)
Next (SetSerialPort)

Name
SetPFL

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetPFL ( iChannel : word ; iValue , iAutoMute : boolean )

Parameters
Parameter | Description
iChannel : WORD | &nbsp;
iValue : BOOLEAN | &nbsp;
iAutoMute : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMonitorChannel)
Next (SetSerialPort)


Previous (SetPFL)
Next (SetTCPPort)

Name
SetSerialPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetSerialPort ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPFL)
Next (SetTCPPort)


Previous (SetSerialPort)
Next (SetVTMicChannel)

Name
SetTCPPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetTCPPort ( iValue : word )

Parameters
Parameter | Description
iValue : WORD | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetSerialPort)
Next (SetVTMicChannel)


Previous (SetTCPPort)
Next (SetVTPlayerAChannel)

Name
SetVTMicChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetVTMicChannel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTCPPort)
Next (SetVTPlayerAChannel)


Previous (SetVTMicChannel)
Next (SetVTPlayerBChannel)

Name
SetVTPlayerAChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerAChannel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVTMicChannel)
Next (SetVTPlayerBChannel)


Previous (SetVTPlayerAChannel)
Next

Name
SetVTPlayerBChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerBChannel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVTPlayerAChannel)
Next


Previous (IRM4200DRemote)
Next (IRM4200DSetFaderOnAction)

Name
IRM4200DSetAllPFLOffAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DRemote)
Next (IRM4200DSetFaderOnAction)


Previous (IRM4200DSetAllPFLOffAction)
Next (IRM4200DSetLogicAction)

Name
IRM4200DSetFaderOnAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DChannelValueAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetAllPFLOffAction)
Next (IRM4200DSetLogicAction)


Previous (IRM4200DSetFaderOnAction)
Next (IRM4200DSetPFLAction)

Name
IRM4200DSetLogicAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Members
Methods
Method Description
GetAddress (+)
GetValue (+)
SetAddress (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetFaderOnAction)
Next (IRM4200DSetPFLAction)


Previous
Next (GetValue)

Name
GetAddress

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
function GetAddress : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetValue)


Previous (GetAddress)
Next (SetAddress)

Name
GetValue

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAddress)
Next (SetAddress)


Previous (GetValue)
Next (SetValue)

Name
SetAddress

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
procedure SetAddress ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetValue)


Previous (SetAddress)
Next

Name
SetValue

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAddress)
Next


Previous (IRM4200DSetLogicAction)
Next

Name
IRM4200DSetPFLAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DChannelValueAction

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoMute (+)
SetAutoMute (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetLogicAction)
Next


Previous
Next (SetAutoMute)

Name
GetAutoMute

Parent
IRM4200DSetPFLAction

Visibility
PUBLIC

Source code
function GetAutoMute : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetAutoMute)


Previous (GetAutoMute)
Next

Name
SetAutoMute

Parent
IRM4200DSetPFLAction

Visibility
PUBLIC

Source code
procedure SetAutoMute ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAutoMute)
Next


Previous (DHDInterfaces)
Next (InpOut32Interface)

Name
DHDTypes

Parent
mAirListScript

Types
Type Description
TCommunicationMode (+)

Constants
Constant Description
MAX_RM4200D_ADDRESS (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (DHDInterfaces)
Next (InpOut32Interface)


Previous
Next

Name
TCommunicationMode

Parent
DHDTypes

Visibility
PUBLIC

Source code
TCommunicationMode = ( cmSerial , cmTCP ) ;

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next

Name
MAX_RM4200D_ADDRESS

Parent
DHDTypes

Visibility
PUBLIC

Source code
MAX_RM4200D_ADDRESS = 4095

mAirListScript
Class Tree
Index
Previous
Next


Previous (DHDTypes)
Next (mAirListInterfaces)

Name
InpOut32Interface

Parent
mAirListScript

Classes
Class Description
IIOPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (DHDTypes)
Next (mAirListInterfaces)


Previous
Next

Name
IIOPort

Parent
InpOut32Interface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
READ (+)
WRITE (+)
WriteAND (+)
WriteOR (+)
WriteXOR (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (WRITE)

Name
READ

Parent
IIOPort

Visibility
PUBLIC

Source code
function Read : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (WRITE)


Previous (READ)
Next (WriteAND)

Name
WRITE

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure Write ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (READ)
Next (WriteAND)


Previous (WRITE)
Next (WriteOR)

Name
WriteAND

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteAND ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (WRITE)
Next (WriteOR)


Previous (WriteAND)
Next (WriteXOR)

Name
WriteOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteOR ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteAND)
Next (WriteXOR)


Previous (WriteOR)
Next

Name
WriteXOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteXOR ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteOR)
Next


Previous (InpOut32Interface)
Next (mAirListScript)

Name
mAirListInterfaces

Parent
mAirListScript

Types
Type Description
IAudioSourceArray (+)
TMessageProc (+)

Classes
Class Description
IAction (+)
IActionList (+)
IActivePlaylist (+)
IActivePlaylistItemMetadata (+)
IAddableCueDataItem (+)
IAddablePlaylistItem (+)
IAudioCartwallItem (+)
IAudioDevice (+)
IAudioDeviceConfig (+)
IAudioDeviceList (+)
IAudioSource (+)
IAutoCueEngine (+)
IBaseComPortRemote (+)
IBaseList (+)
IBaseMessage (+)
IBreakPlaylistItem (+)
ICartPlayerControl (+)
ICartwallControl (+)
ICartwallItem (+)
ICartwallItemList (+)
ICartwallModule (+)
ICartwallPageControl (+)
ICartwallPageControlList (+)
ICartwallTrigger (+)
ICartwallTriggerList (+)
IClientList (+)
ICommandPlaylistItem (+)
IComPort (+)
IConfigObject (+)
IConfigObjectList (+)
IConfiguration (+)
IConfigValues (+)
IConfigValuesList (+)
IContainerPlaylistItem (+)
ICueData (+)
ICueDataItem (+)
IDatabase (+)
IDatabaseAction (+)
IDatabaseInlineLoader (+)
IDatabaseList (+)
IDatabaseSearchHandler (+)
IDatabaseTree (+)
IDebugObject (+)
IDummyAction (+)
IDummyObject (+)
IDummyPlaylistItem (+)
IEmergencyAction (+)
IEngine (+)
IEngineDesktopPlugin (+)
IEngineInfo (+)
IEnvelope (+)
IEnvelopePoint (+)
IEOFWarningCueDataItem (+)
IEventList (+)
IEventListItem (+)
IEventsModule (+)
IFactory (+)
IFactoryClass (+)
IFileData (+)
IFileDataRecorder (+)
IFileEncoder (+)
IFileEncoderSettings (+)
IFileManager (+)
IFilePlaylistItem (+)
IFilePlaylistItemClass (+)
IFileStorage (+)
IFileStorageClass (+)
IFileTypeHandler (+)
IFileTypeHandlerClass (+)
IHiddenModule (+)
IIncompleteStream (+)
IInfiniteSilencePlaylistItem (+)
IInlineData (+)
IInlineFilePlaylistItem (+)
IInstanceData (+)
ILevelInfo (+)
ILicenseData (+)
ILogEntry (+)
ILogEntryList (+)
ILogger (+)
ILogInterface (+)
ILogInterfaceList (+)
ImAirListInstance (+)
IMessageDispatcher (+)
IMetaCueDataItem (+)
IMixdownEngine (+)
IMixdownEngine2 (+)
IMixer (+)
IModule (+)
IModuleList (+)
IMultiAudioSource (+)
IMultiInstanceModule (+)
IMultiPlaylist (+)
IMultiPlaylistItemMetadata (+)
IMutex (+)
INoAudioDevice (+)
INotifiedMessageReceiver (+)
INotifyItemStarted (+)
IObservable (+)
IObservableList (+)
IPeakAnalyzer (+)
IPersistent (+)
IPersistentArray (+)
IPersistentBoolean (+)
IPersistentDateTime (+)
IPersistentList (+)
IPersistentListItem (+)
IPersistentListItemMetadata (+)
IPersistentNull (+)
IPersistentNumber (+)
IPersistentObject (+)
IPersistentPlaylistItemMetadata (+)
IPersistentStorage (+)
IPersistentString (+)
IPlaybackControl (+)
IPlaybackDevice (+)
IPlaybackDeviceList (+)
IPlayerControl (+)
IPlaylist (+)
IPlaylistExporter (+)
IPlaylistFilePlaylistItem (+)
IPlaylistImporter (+)
IPlaylistItem (+)
IPlaylistItemMetadata (+)
IPlaylistPlayerControl (+)
IPlaylistStorage (+)
IPlayoutModule (+)
IProgressIndicator (+)
IRecordDevice (+)
IRecordDeviceList (+)
IRecycleBinPlaylist (+)
IRegionContainerPlaylistItem (+)
IRemote (+)
IRemoteAction (+)
IRemoteController (+)
IRemoteList (+)
IRunnable (+)
ISerializable (+)
ISerialPortManager (+)
ISilencePlaylistItem (+)
ISourceControl (+)
IStandardAttribute (+)
IStandardAttributeList (+)
IStream (+)
IStreamPlaylistItem (+)
IStrings (+)
IStubPlaylistItem (+)
ITrackCueDataItem (+)
IUpdateObject (+)
IURLPlaylistItem (+)
IWritableFileData (+)
IWritableStream (+)
TDatabaseNodeData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (InpOut32Interface)
Next (mAirListScript)


Previous
Next (IActionList)

Name
IAction

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
CloneAsAction (+)
Execute (+)
GetCaption (+)
GetPlaylist (+)
GetTimeOffset (+)
GetTitle (+)
GetUseVariables (+)
SetPlaylist (+)
SetTimeOffset (+)
SetTitle (+)
SetUseVariables (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IActionList)


Previous
Next (Execute)

Name
CloneAsAction

Parent
IAction

Visibility
PUBLIC

Source code
function CloneAsAction : IAction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Execute)


Previous (CloneAsAction)
Next (GetCaption)

Name
Execute

Parent
IAction

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iTimeOffset : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (CloneAsAction)
Next (GetCaption)


Previous (Execute)
Next (GetPlaylist)

Name
GetCaption

Parent
IAction

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetPlaylist)


Previous (GetCaption)
Next (GetTimeOffset)

Name
GetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
function GetPlaylist : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetTimeOffset)


Previous (GetPlaylist)
Next (GetTitle)

Name
GetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
function GetTimeOffset : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetTitle)


Previous (GetTimeOffset)
Next (GetUseVariables)

Name
GetTitle

Parent
IAction

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeOffset)
Next (GetUseVariables)


Previous (GetTitle)
Next (SetPlaylist)

Name
GetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
function GetUseVariables : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (SetPlaylist)


Previous (GetUseVariables)
Next (SetTimeOffset)

Name
SetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetPlaylist ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetUseVariables)
Next (SetTimeOffset)


Previous (SetPlaylist)
Next (SetTitle)

Name
SetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTimeOffset ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPlaylist)
Next (SetTitle)


Previous (SetTimeOffset)
Next (SetUseVariables)

Name
SetTitle

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTimeOffset)
Next (SetUseVariables)


Previous (SetTitle)
Next

Name
SetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetUseVariables ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IAction)
Next (IActivePlaylist)

Name
IActionList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
Execute (+)
ExecuteAsync (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAction)
Next (IActivePlaylist)


Previous
Next (ExecuteAsync)

Name
Execute

Parent
IActionList

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iTimeOffset : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (ExecuteAsync)


Previous (Execute)
Next (GetItem)

Name
ExecuteAsync

Parent
IActionList

Visibility
PUBLIC

Source code
procedure ExecuteAsync ( iDefaultPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter | Description
iDefaultPlaylist : INTEGER | &nbsp;
iTimeOffset : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetItem)


Previous (ExecuteAsync)
Next

Name
GetItem

Parent
IActionList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IAction

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (ExecuteAsync)
Next


Previous (IActionList)
Next (IActivePlaylistItemMetadata)

Name
IActivePlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPlaylist

Visibility
PUBLIC

Members
Methods
Method Description
AutomationForceNext (+)
AutomationNext (+)
AutomationPlay (+)
AutomationStop (+)
GetActivePlaylistItemMetadata (+)
GetAutomation (+)
GetAutomationPlaying (+)
GetItemPlaybackState (+)
GetSourceControl (+)
SetAutomation (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActionList)
Next (IActivePlaylistItemMetadata)


Previous
Next (AutomationNext)

Name
AutomationForceNext

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationForceNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutomationNext)


Previous (AutomationForceNext)
Next (AutomationPlay)

Name
AutomationNext

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationForceNext)
Next (AutomationPlay)


Previous (AutomationNext)
Next (AutomationStop)

Name
AutomationPlay

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationPlay

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationNext)
Next (AutomationStop)


Previous (AutomationPlay)
Next (GetActivePlaylistItemMetadata)

Name
AutomationStop

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationStop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationPlay)
Next (GetActivePlaylistItemMetadata)


Previous (AutomationStop)
Next (GetAutomation)

Name
GetActivePlaylistItemMetadata

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetActivePlaylistItemMetadata ( iIndex : integer ) : IActivePlaylistItemMetadata

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (AutomationStop)
Next (GetAutomation)


Previous (GetActivePlaylistItemMetadata)
Next (GetAutomationPlaying)

Name
GetAutomation

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetAutomation : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePlaylistItemMetadata)
Next (GetAutomationPlaying)


Previous (GetAutomation)
Next (GetItemPlaybackState)

Name
GetAutomationPlaying

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetAutomationPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutomation)
Next (GetItemPlaybackState)


Previous (GetAutomationPlaying)
Next (GetSourceControl)

Name
GetItemPlaybackState

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure GetItemPlaybackState ( iIndex : integer ; var oState : TPlaybackState ; var oPlayerIndex : integer ; var oPosition : TTimeValue )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
oState : TPlaybackState | &nbsp;
oPlayerIndex : INTEGER | &nbsp;
oPosition : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAutomationPlaying)
Next (GetSourceControl)


Previous (GetItemPlaybackState)
Next (SetAutomation)

Name
GetSourceControl

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetSourceControl ( iIndex : integer ) : ISourceControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItemPlaybackState)
Next (SetAutomation)


Previous (GetSourceControl)
Next

Name
SetAutomation

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure SetAutomation ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSourceControl)
Next


Previous (IActivePlaylist)
Next (IAddableCueDataItem)

Name
IActivePlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetSourceControl (+)
SetSourceControl (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActivePlaylist)
Next (IAddableCueDataItem)


Previous
Next (SetSourceControl)

Name
GetSourceControl

Parent
IActivePlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetSourceControl)


Previous (GetSourceControl)
Next

Name
SetSourceControl

Parent
IActivePlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetSourceControl ( iValue : ISourceControl )

Parameters
Parameter | Description
iValue : ISourceControl | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSourceControl)
Next


Previous (IActivePlaylistItemMetadata)
Next (IAddablePlaylistItem)

Name
IAddableCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActivePlaylistItemMetadata)
Next (IAddablePlaylistItem)


Previous (IAddableCueDataItem)
Next (IAudioCartwallItem)

Name
IAddablePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddableCueDataItem)
Next (IAudioCartwallItem)


Previous (IAddablePlaylistItem)
Next (IAudioDevice)

Name
IAudioCartwallItem

Parent
mAirListInterfaces

Class Hierarchy
ICartwallItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPlaylistItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddablePlaylistItem)
Next (IAudioDevice)


Previous
Next

Name
GetPlaylistItem

Parent
IAudioCartwallItem

Visibility
PUBLIC

Source code
function GetPlaylistItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IAudioCartwallItem)
Next (IAudioDeviceConfig)

Name
IAudioDevice

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetDeviceClass (+)
GetDisplayName (+)
GetID (+)
GetLocker (+)
GetSummary (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioCartwallItem)
Next (IAudioDeviceConfig)


Previous
Next (GetDisplayName)

Name
GetDeviceClass

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetDeviceClass : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDisplayName)


Previous (GetDeviceClass)
Next (GetID)

Name
GetDisplayName

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetDisplayName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceClass)
Next (GetID)


Previous (GetDisplayName)
Next (GetLocker)

Name
GetID

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisplayName)
Next (GetLocker)


Previous (GetID)
Next (GetSummary)

Name
GetLocker

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetLocker : IUnknown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (GetSummary)


Previous (GetLocker)
Next

Name
GetSummary

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLocker)
Next


Previous (IAudioDevice)
Next (IAudioDeviceList)

Name
IAudioDeviceConfig

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
AddNode (+)
DeleteNodesByPrefix (+)
GetAssignment (+)
GetAudioDevice (+)
GetDefaultDevice (+)
GetNoAudioDevice (+)
GetNode (+)
GetNodeCount (+)
GetPlaybackDevice (+)
GetRecordDevice (+)
GetRegionDevices (+)
SetAssignment (+)
SetSingleAssignment (+)
UpdateDevices (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDevice)
Next (IAudioDeviceList)


Previous
Next (DeleteNodesByPrefix)

Name
AddNode

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure AddNode ( iDeviceType : TAudioDeviceType ; iID , iDefaultID , iReadablePath : string ; iFilterGUID : TGUID ; iAutoAddRegions : boolean )

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;
iID : STRING | &nbsp;
iDefaultID : STRING | &nbsp;
iReadablePath : STRING | &nbsp;
iFilterGUID : TGUID | &nbsp;
iAutoAddRegions : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (DeleteNodesByPrefix)


Previous (AddNode)
Next (GetAssignment)

Name
DeleteNodesByPrefix

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure DeleteNodesByPrefix ( iDeviceType : TAudioDeviceType ; iPrefix : string )

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;
iPrefix : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddNode)
Next (GetAssignment)


Previous (DeleteNodesByPrefix)
Next (GetAudioDevice)

Name
GetAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetAssignment ( iDeviceType : TAudioDeviceType ) : IStrings

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteNodesByPrefix)
Next (GetAudioDevice)


Previous (GetAssignment)
Next (GetDefaultDevice)

Name
GetAudioDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetAudioDevice ( iDeviceType : TAudioDeviceType ; iID : string ) : IAudioDevice

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAssignment)
Next (GetDefaultDevice)


Previous (GetAudioDevice)
Next (GetNoAudioDevice)

Name
GetDefaultDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetDefaultDevice ( iDeviceType : TAudioDeviceType ) : IAudioDevice

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAudioDevice)
Next (GetNoAudioDevice)


Previous (GetDefaultDevice)
Next (GetNode)

Name
GetNoAudioDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetNoAudioDevice ( iDeviceType : TAudioDeviceType ) : INoAudioDevice

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetDefaultDevice)
Next (GetNode)


Previous (GetNoAudioDevice)
Next (GetNodeCount)

Name
GetNode

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure GetNode ( iIndex : integer ; out oDeviceType : TAudioDeviceType ; out oID , oDefaultID , oReadablePath : string ; out oFilterGUID : TGUID )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
oDeviceType : TAudioDeviceType | &nbsp;
oID : STRING | &nbsp;
oDefaultID : STRING | &nbsp;
oReadablePath : STRING | &nbsp;
oFilterGUID : TGUID | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNoAudioDevice)
Next (GetNodeCount)


Previous (GetNode)
Next (GetPlaybackDevice)

Name
GetNodeCount

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetNodeCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNode)
Next (GetPlaybackDevice)


Previous (GetNodeCount)
Next (GetRecordDevice)

Name
GetPlaybackDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetPlaybackDevice ( iID : string ) : IPlaybackDevice

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNodeCount)
Next (GetRecordDevice)


Previous (GetPlaybackDevice)
Next (GetRegionDevices)

Name
GetRecordDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetRecordDevice ( iID : string ) : IRecordDevice

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlaybackDevice)
Next (GetRegionDevices)


Previous (GetRecordDevice)
Next (SetAssignment)

Name
GetRegionDevices

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetRegionDevices ( iID : string ) : IPlaybackDeviceList

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRecordDevice)
Next (SetAssignment)


Previous (GetRegionDevices)
Next (SetSingleAssignment)

Name
SetAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SetAssignment ( iDeviceType : TAudioDeviceType ; iValue : IStrings )

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;
iValue : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRegionDevices)
Next (SetSingleAssignment)


Previous (SetAssignment)
Next (UpdateDevices)

Name
SetSingleAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SetSingleAssignment ( iDeviceType : TAudioDeviceType ; iID : string ; iDevice : string )

Parameters
Parameter | Description
iDeviceType : TAudioDeviceType | &nbsp;
iID : STRING | &nbsp;
iDevice : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAssignment)
Next (UpdateDevices)


Previous (SetSingleAssignment)
Next

Name
UpdateDevices

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure UpdateDevices

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetSingleAssignment)
Next


Previous (IAudioDeviceConfig)
Next (IAudioSource)

Name
IAudioDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
DeleteByDeviceClass (+)
Equals (+)
GetAudioDevice (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceConfig)
Next (IAudioSource)


Previous
Next (Equals)

Name
DeleteByDeviceClass

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
procedure DeleteByDeviceClass ( iClass : string )

Parameters
Parameter | Description
iClass : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Equals)


Previous (DeleteByDeviceClass)
Next (GetAudioDevice)

Name
Equals

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function Equals ( iValue : IAudioDeviceList ) : boolean

Parameters
Parameter | Description
iValue : IAudioDeviceList | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteByDeviceClass)
Next (GetAudioDevice)


Previous (Equals)
Next (IndexOfID)

Name
GetAudioDevice

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function GetAudioDevice ( iIndex : integer ) : IAudioDevice

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Equals)
Next (IndexOfID)


Previous (GetAudioDevice)
Next

Name
IndexOfID

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : string ) : integer

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAudioDevice)
Next


Previous (IAudioDeviceList)
Next (IAutoCueEngine)

Name
IAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanChangeDevice (+)
ChangeDevice (+)
CueModeOff (+)
CueModeOn (+)
FadeOut (+)
GetAmplification (+)
GetCapabilities (+)
GetDuration (+)
GetDynamicTitle (+)
GetIsPlaying (+)
GetItem (+)
GetOptions (+)
GetPitch (+)
GetPosition (+)
GetRegion (+)
GetTempo (+)
GetVolume (+)
IsCueable (+)
Pause (+)
Reset (+)
SetAmplification (+)
SetCueData (+)
SetOptions (+)
SetPitch (+)
SetPosition (+)
SetRegion (+)
SetTempo (+)
SetVolume (+)
SetVolumeEnvelope (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceList)
Next (IAutoCueEngine)


Previous
Next (ChangeDevice)

Name
CanChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
function CanChangeDevice ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList ) : boolean

Parameters
Parameter | Description
iDevice : IPlaybackDevice | &nbsp;
iRegionDevices : IPlaybackDeviceList | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (ChangeDevice)


Previous (CanChangeDevice)
Next (CueModeOff)

Name
ChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure ChangeDevice ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList )

Parameters
Parameter | Description
iDevice : IPlaybackDevice | &nbsp;
iRegionDevices : IPlaybackDeviceList | &nbsp;

mAirListScript
Class Tree
Index
Previous (CanChangeDevice)
Next (CueModeOff)


Previous (ChangeDevice)
Next (CueModeOn)

Name
CueModeOff

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure CueModeOff

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ChangeDevice)
Next (CueModeOn)


Previous (CueModeOff)
Next (FadeOut)

Name
CueModeOn

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure CueModeOn ( iPosition : TTimeValue )

Parameters
Parameter | Description
iPosition : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (CueModeOff)
Next (FadeOut)


Previous (CueModeOn)
Next (GetAmplification)

Name
FadeOut

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure FadeOut ( iDuration : TTimeValue )

Parameters
Parameter | Description
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (CueModeOn)
Next (GetAmplification)


Previous (FadeOut)
Next (GetCapabilities)

Name
GetAmplification

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetCapabilities)


Previous (GetAmplification)
Next (GetDuration)

Name
GetCapabilities

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetCapabilities : TAudioSourceCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next (GetDuration)


Previous (GetCapabilities)
Next (GetDynamicTitle)

Name
GetDuration

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetDynamicTitle)


Previous (GetDuration)
Next (GetIsPlaying)

Name
GetDynamicTitle

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetDynamicTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetIsPlaying)


Previous (GetDynamicTitle)
Next (GetItem)

Name
GetIsPlaying

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetIsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDynamicTitle)
Next (GetItem)


Previous (GetIsPlaying)
Next (GetOptions)

Name
GetItem

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsPlaying)
Next (GetOptions)


Previous (GetItem)
Next (GetPitch)

Name
GetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetOptions : TAudioSourceOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetPitch)


Previous (GetOptions)
Next (GetPosition)

Name
GetPitch

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPosition)


Previous (GetPitch)
Next (GetRegion)

Name
GetPosition

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (GetRegion)


Previous (GetPosition)
Next (GetTempo)

Name
GetRegion

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetRegion : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetTempo)


Previous (GetRegion)
Next (GetVolume)

Name
GetTempo

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegion)
Next (GetVolume)


Previous (GetTempo)
Next (IsCueable)

Name
GetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (IsCueable)


Previous (GetVolume)
Next (Pause)

Name
IsCueable

Parent
IAudioSource

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Pause)


Previous (IsCueable)
Next (Reset)

Name
Pause

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (Reset)


Previous (Pause)
Next (SetAmplification)

Name
Reset

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Reset ( iHookMode : boolean )

Parameters
Parameter | Description
iHookMode : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetAmplification)


Previous (Reset)
Next (SetCueData)

Name
SetAmplification

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (Reset)
Next (SetCueData)


Previous (SetAmplification)
Next (SetOptions)

Name
SetCueData

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetCueData ( iValue : ICueData )

Parameters
Parameter | Description
iValue : ICueData | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAmplification)
Next (SetOptions)


Previous (SetCueData)
Next (SetPitch)

Name
SetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TAudioSourceOptions )

Parameters
Parameter | Description
iValue : TAudioSourceOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCueData)
Next (SetPitch)


Previous (SetOptions)
Next (SetPosition)

Name
SetPitch

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetPosition)


Previous (SetPitch)
Next (SetRegion)

Name
SetPosition

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next (SetRegion)


Previous (SetPosition)
Next (SetTempo)

Name
SetRegion

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetRegion ( iValue : byte )

Parameters
Parameter | Description
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SetTempo)


Previous (SetRegion)
Next (SetVolume)

Name
SetTempo

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRegion)
Next (SetVolume)


Previous (SetTempo)
Next (SetVolumeEnvelope)

Name
SetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTempo)
Next (SetVolumeEnvelope)


Previous (SetVolume)
Next (Start)

Name
SetVolumeEnvelope

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter | Description
iValue : IEnvelope | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Start)


Previous (SetVolumeEnvelope)
Next (Stop)

Name
Start

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolumeEnvelope)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IAudioSource)
Next (IBaseComPortRemote)

Name
IAutoCueEngine

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPeakLevel (+)
NormalizeFile (+)
NormalizeFiles (+)
PerformAutoCue (+)
PerformAutoCueSelective (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioSource)
Next (IBaseComPortRemote)


Previous
Next (NormalizeFile)

Name
GetPeakLevel

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
function GetPeakLevel ( iFileData : IFileData ; iPIndicator : IProgressIndicator ) : double

Parameters
Parameter | Description
iFileData : IFileData | &nbsp;
iPIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (NormalizeFile)


Previous (GetPeakLevel)
Next (NormalizeFiles)

Name
NormalizeFile

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure NormalizeFile ( iItem : IPlaylistItem ; iPIndicator : IProgressIndicator )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iPIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPeakLevel)
Next (NormalizeFiles)


Previous (NormalizeFile)
Next (PerformAutoCue)

Name
NormalizeFiles

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure NormalizeFiles ( iItems : IPlaylist ; iPIndicator : IProgressIndicator )

Parameters
Parameter | Description
iItems : IPlaylist | &nbsp;
iPIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (NormalizeFile)
Next (PerformAutoCue)


Previous (NormalizeFiles)
Next (PerformAutoCueSelective)

Name
PerformAutoCue

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCue ( iItem : IFilePlaylistItem )

Parameters
Parameter | Description
iItem : IFilePlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (NormalizeFiles)
Next (PerformAutoCueSelective)


Previous (PerformAutoCue)
Next

Name
PerformAutoCueSelective

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCueSelective ( iItem : IFilePlaylistItem ; iTypes : TCuePositionTypes )

Parameters
Parameter | Description
iItem : IFilePlaylistItem | &nbsp;
iTypes : TCuePositionTypes | &nbsp;

mAirListScript
Class Tree
Index
Previous (PerformAutoCue)
Next


Previous (IAutoCueEngine)
Next (IBaseList)

Name
IBaseComPortRemote

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAutoCueEngine)
Next (IBaseList)


Previous
Next (SetPort)

Name
GetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (IBaseComPortRemote)
Next (IBaseMessage)

Name
IBaseList

Parent
mAirListInterfaces

Class Hierarchy
ISerializable

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddWithMetadata (+)
Append (+)
Clear (+)
CreateEmpty (+)
Delete (+)
FindItemByGUID (+)
GetCount (+)
GetListItem (+)
GetListItemMetadata (+)
IndexOf (+)
Insert (+)
InsertList (+)
InsertWithMetadata (+)
Move (+)
REMOVE (+)
Shuffle (+)
Sync (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseComPortRemote)
Next (IBaseMessage)


Previous
Next (AddWithMetadata)

Name
ADD

Parent
IBaseList

Visibility
PUBLIC

Source code
function Add ( iItem : IUnknown ) : integer

Parameters
Parameter | Description
iItem : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AddWithMetadata)


Previous (ADD)
Next (Append)

Name
AddWithMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
function AddWithMetadata ( iItem : IUnknown ; iMetadata : IUnknown ) : integer

Parameters
Parameter | Description
iItem : IUnknown | &nbsp;
iMetadata : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Append)


Previous (AddWithMetadata)
Next (Clear)

Name
Append

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Append ( iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter | Description
iValue : IBaseList | &nbsp;
iWithMetadata : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddWithMetadata)
Next (Clear)


Previous (Append)
Next (CreateEmpty)

Name
Clear

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Append)
Next (CreateEmpty)


Previous (Clear)
Next (Delete)

Name
CreateEmpty

Parent
IBaseList

Visibility
PUBLIC

Source code
function CreateEmpty : IBaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (CreateEmpty)
Next (FindItemByGUID)

Name
Delete

Parent
IBaseList

Visibility
PUBLIC

Source code
function Delete ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateEmpty)
Next (FindItemByGUID)


Previous (Delete)
Next (GetCount)

Name
FindItemByGUID

Parent
IBaseList

Visibility
PUBLIC

Source code
function FindItemByGUID ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter | Description
iGUID : TGUID | &nbsp;
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Delete)
Next (GetCount)


Previous (FindItemByGUID)
Next (GetListItem)

Name
GetCount

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindItemByGUID)
Next (GetListItem)


Previous (GetCount)
Next (GetListItemMetadata)

Name
GetListItem

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetListItem ( iIndex : integer ) : IUnknown

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetListItemMetadata)


Previous (GetListItem)
Next (IndexOf)

Name
GetListItemMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetListItemMetadata ( iIndex : integer ) : IUnknown

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetListItem)
Next (IndexOf)


Previous (GetListItemMetadata)
Next (Insert)

Name
IndexOf

Parent
IBaseList

Visibility
PUBLIC

Source code
function IndexOf ( iItem : IUnknown ) : integer

Parameters
Parameter | Description
iItem : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetListItemMetadata)
Next (Insert)


Previous (IndexOf)
Next (InsertList)

Name
Insert

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iItem : IUnknown )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iItem : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (InsertList)


Previous (Insert)
Next (InsertWithMetadata)

Name
InsertList

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure InsertList ( iIndex : integer ; iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : IBaseList | &nbsp;
iWithMetadata : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (Insert)
Next (InsertWithMetadata)


Previous (InsertList)
Next (Move)

Name
InsertWithMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure InsertWithMetadata ( iIndex : integer ; iItem : IUnknown ; iMetadata : IUnknown )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iItem : IUnknown | &nbsp;
iMetadata : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertList)
Next (Move)


Previous (InsertWithMetadata)
Next (REMOVE)

Name
Move

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Move ( oldIndex : integer ; newIndex : integer )

Parameters
Parameter | Description
oldIndex : INTEGER | &nbsp;
newIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertWithMetadata)
Next (REMOVE)


Previous (Move)
Next (Shuffle)

Name
REMOVE

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Remove ( iItem : IUnknown )

Parameters
Parameter | Description
iItem : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (Move)
Next (Shuffle)


Previous (REMOVE)
Next (Sync)

Name
Shuffle

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Shuffle

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (REMOVE)
Next (Sync)


Previous (Shuffle)
Next

Name
Sync

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Sync ( iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter | Description
iValue : IBaseList | &nbsp;
iWithMetadata : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (Shuffle)
Next


Previous (IBaseList)
Next (IBreakPlaylistItem)

Name
IBaseMessage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCreated (+)
GetData (+)
GetDataCount (+)
GetInfo (+)
GetMessageType (+)
GetSender (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseList)
Next (IBreakPlaylistItem)


Previous
Next (GetData)

Name
GetCreated

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetCreated : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetData)


Previous (GetCreated)
Next (GetDataCount)

Name
GetData

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : Variant

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCreated)
Next (GetDataCount)


Previous (GetData)
Next (GetInfo)

Name
GetDataCount

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetDataCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetInfo)


Previous (GetDataCount)
Next (GetMessageType)

Name
GetInfo

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDataCount)
Next (GetMessageType)


Previous (GetInfo)
Next (GetSender)

Name
GetMessageType

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetMessageType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInfo)
Next (GetSender)


Previous (GetMessageType)
Next

Name
GetSender

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetSender : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageType)
Next


Previous (IBaseMessage)
Next (ICartPlayerControl)

Name
IBreakPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseMessage)
Next (ICartPlayerControl)


Previous (IBreakPlaylistItem)
Next (ICartwallControl)

Name
ICartPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Click (+)
ExecuteCommand (+)
ExecuteItemCommand (+)
FadeOut (+)
GetCurrentSourceControl (+)
GetErrorMessage (+)
GetItem (+)
GetState (+)
Pause (+)
Play (+)
Stop (+)
StopOrFadeOut (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBreakPlaylistItem)
Next (ICartwallControl)


Previous
Next (ExecuteCommand)

Name
Click

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure Click

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ExecuteCommand)


Previous (Click)
Next (ExecuteItemCommand)

Name
ExecuteCommand

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Click)
Next (ExecuteItemCommand)


Previous (ExecuteCommand)
Next (FadeOut)

Name
ExecuteItemCommand

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure ExecuteItemCommand ( iCommand : TCartwallItemCommand )

Parameters
Parameter | Description
iCommand : TCartwallItemCommand | &nbsp;

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (FadeOut)


Previous (ExecuteItemCommand)
Next (GetCurrentSourceControl)

Name
FadeOut

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteItemCommand)
Next (GetCurrentSourceControl)


Previous (FadeOut)
Next (GetErrorMessage)

Name
GetCurrentSourceControl

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetCurrentSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetErrorMessage)


Previous (GetCurrentSourceControl)
Next (GetItem)

Name
GetErrorMessage

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentSourceControl)
Next (GetItem)


Previous (GetErrorMessage)
Next (GetState)

Name
GetItem

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetItem : IAudioCartwallItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetState)


Previous (GetItem)
Next (Pause)

Name
GetState

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetState : TPlayerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (Pause)


Previous (GetState)
Next (Play)

Name
Pause

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (Play)


Previous (Pause)
Next (Stop)

Name
Play

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure Play

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (Stop)


Previous (Play)
Next (StopOrFadeOut)

Name
Stop

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Play)
Next (StopOrFadeOut)


Previous (Stop)
Next

Name
StopOrFadeOut

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure StopOrFadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Stop)
Next


Previous (ICartPlayerControl)
Next (ICartwallItem)

Name
ICartwallControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CreatePage (+)
GetActivePage (+)
GetActivePagePlayerStates (+)
GetCrippleMode (+)
GetDefaultHeight (+)
GetDefaultWidth (+)
GetGridHeight (+)
GetGridWidth (+)
GetNumbering (+)
GetOnAirMode (+)
GetOptions (+)
GetPadding (+)
GetPages (+)
GetPlayerCount (+)
LoadPageListFromXML (+)
SavePageListAsXML (+)
SetActivePage (+)
SetDefaultHeight (+)
SetDefaultWidth (+)
SetNumbering (+)
SetOnAirMode (+)
SetOptions (+)
SetPadding (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartPlayerControl)
Next (ICartwallItem)


Previous
Next (GetActivePage)

Name
CreatePage

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function CreatePage : ICartwallPageControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetActivePage)


Previous (CreatePage)
Next (GetActivePagePlayerStates)

Name
GetActivePage

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetActivePage : ICartwallPageControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePage)
Next (GetActivePagePlayerStates)


Previous (GetActivePage)
Next (GetCrippleMode)

Name
GetActivePagePlayerStates

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure GetActivePagePlayerStates ( var oStates : TPlayerStateArray )

Parameters
Parameter | Description
oStates : TPlayerStateArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetActivePage)
Next (GetCrippleMode)


Previous (GetActivePagePlayerStates)
Next (GetDefaultHeight)

Name
GetCrippleMode

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetCrippleMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePagePlayerStates)
Next (GetDefaultHeight)


Previous (GetCrippleMode)
Next (GetDefaultWidth)

Name
GetDefaultHeight

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetDefaultHeight : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCrippleMode)
Next (GetDefaultWidth)


Previous (GetDefaultHeight)
Next (GetGridHeight)

Name
GetDefaultWidth

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetDefaultWidth : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultHeight)
Next (GetGridHeight)


Previous (GetDefaultWidth)
Next (GetGridWidth)

Name
GetGridHeight

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetGridHeight : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultWidth)
Next (GetGridWidth)


Previous (GetGridHeight)
Next (GetNumbering)

Name
GetGridWidth

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetGridWidth : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGridHeight)
Next (GetNumbering)


Previous (GetGridWidth)
Next (GetOnAirMode)

Name
GetNumbering

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetNumbering : TCartwallNumbering

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGridWidth)
Next (GetOnAirMode)


Previous (GetNumbering)
Next (GetOptions)

Name
GetOnAirMode

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetOnAirMode : TCartwallOnAirMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNumbering)
Next (GetOptions)


Previous (GetOnAirMode)
Next (GetPadding)

Name
GetOptions

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetOptions : TCartwallOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAirMode)
Next (GetPadding)


Previous (GetOptions)
Next (GetPages)

Name
GetPadding

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetPadding : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPages)


Previous (GetPadding)
Next (GetPlayerCount)

Name
GetPages

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetPages : ICartwallPageControlList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPadding)
Next (GetPlayerCount)


Previous (GetPages)
Next (LoadPageListFromXML)

Name
GetPlayerCount

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPages)
Next (LoadPageListFromXML)


Previous (GetPlayerCount)
Next (SavePageListAsXML)

Name
LoadPageListFromXML

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure LoadPageListFromXML ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (SavePageListAsXML)


Previous (LoadPageListFromXML)
Next (SetActivePage)

Name
SavePageListAsXML

Parent
ICartwallControl

Visibility
PUBLIC

Source code
function SavePageListAsXML ( iDocument : ISXMLDocument ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadPageListFromXML)
Next (SetActivePage)


Previous (SavePageListAsXML)
Next (SetDefaultHeight)

Name
SetActivePage

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetActivePage ( iValue : ICartwallPageControl )

Parameters
Parameter | Description
iValue : ICartwallPageControl | &nbsp;

mAirListScript
Class Tree
Index
Previous (SavePageListAsXML)
Next (SetDefaultHeight)


Previous (SetActivePage)
Next (SetDefaultWidth)

Name
SetDefaultHeight

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetDefaultHeight ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetActivePage)
Next (SetDefaultWidth)


Previous (SetDefaultHeight)
Next (SetNumbering)

Name
SetDefaultWidth

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetDefaultWidth ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDefaultHeight)
Next (SetNumbering)


Previous (SetDefaultWidth)
Next (SetOnAirMode)

Name
SetNumbering

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetNumbering ( iValue : TCartwallNumbering )

Parameters
Parameter | Description
iValue : TCartwallNumbering | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDefaultWidth)
Next (SetOnAirMode)


Previous (SetNumbering)
Next (SetOptions)

Name
SetOnAirMode

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetOnAirMode ( iValue : TCartwallOnAirMode )

Parameters
Parameter | Description
iValue : TCartwallOnAirMode | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNumbering)
Next (SetOptions)


Previous (SetOnAirMode)
Next (SetPadding)

Name
SetOptions

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TCartwallOptions )

Parameters
Parameter | Description
iValue : TCartwallOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOnAirMode)
Next (SetPadding)


Previous (SetOptions)
Next

Name
SetPadding

Parent
ICartwallControl

Visibility
PUBLIC

Source code
procedure SetPadding ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (ICartwallControl)
Next (ICartwallItemList)

Name
ICartwallItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetCaption (+)
GetHeight (+)
GetIndex (+)
GetLeft (+)
GetOptions (+)
GetRect (+)
GetTop (+)
GetTriggers (+)
GetWidth (+)
SetHeight (+)
SetIndex (+)
SetLeft (+)
SetOptions (+)
SetRect (+)
SetTop (+)
SetWidth (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallControl)
Next (ICartwallItemList)


Previous
Next (GetHeight)

Name
GetCaption

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetHeight)


Previous (GetCaption)
Next (GetIndex)

Name
GetHeight

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetHeight : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetIndex)


Previous (GetHeight)
Next (GetLeft)

Name
GetIndex

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHeight)
Next (GetLeft)


Previous (GetIndex)
Next (GetOptions)

Name
GetLeft

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetLeft : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetOptions)


Previous (GetLeft)
Next (GetRect)

Name
GetOptions

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetOptions : TCartwallItemOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLeft)
Next (GetRect)


Previous (GetOptions)
Next (GetTop)

Name
GetRect

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetRect : TRect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetTop)


Previous (GetRect)
Next (GetTriggers)

Name
GetTop

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetTop : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRect)
Next (GetTriggers)


Previous (GetTop)
Next (GetWidth)

Name
GetTriggers

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetTriggers : ICartwallTriggerList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTop)
Next (GetWidth)


Previous (GetTriggers)
Next (SetHeight)

Name
GetWidth

Parent
ICartwallItem

Visibility
PUBLIC

Source code
function GetWidth : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTriggers)
Next (SetHeight)


Previous (GetWidth)
Next (SetIndex)

Name
SetHeight

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetHeight ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetWidth)
Next (SetIndex)


Previous (SetHeight)
Next (SetLeft)

Name
SetIndex

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetIndex ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetHeight)
Next (SetLeft)


Previous (SetIndex)
Next (SetOptions)

Name
SetLeft

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetLeft ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIndex)
Next (SetOptions)


Previous (SetLeft)
Next (SetRect)

Name
SetOptions

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TCartwallItemOptions )

Parameters
Parameter | Description
iValue : TCartwallItemOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLeft)
Next (SetRect)


Previous (SetOptions)
Next (SetTop)

Name
SetRect

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetRect ( iValue : TRect )

Parameters
Parameter | Description
iValue : TRect | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetTop)


Previous (SetRect)
Next (SetWidth)

Name
SetTop

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetTop ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRect)
Next (SetWidth)


Previous (SetTop)
Next

Name
SetWidth

Parent
ICartwallItem

Visibility
PUBLIC

Source code
procedure SetWidth ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTop)
Next


Previous (ICartwallItem)
Next (ICartwallModule)

Name
ICartwallItemList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
FindByIndex (+)
FindByUniqueID (+)
GetItem (+)
GetOtherItems (+)
IndexOfUniqueID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallItem)
Next (ICartwallModule)


Previous
Next (FindByUniqueID)

Name
FindByIndex

Parent
ICartwallItemList

Visibility
PUBLIC

Source code
function FindByIndex ( iIndex : integer ) : ICartwallItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (FindByUniqueID)


Previous (FindByIndex)
Next (GetItem)

Name
FindByUniqueID

Parent
ICartwallItemList

Visibility
PUBLIC

Source code
function FindByUniqueID ( iID : string ) : ICartwallItem

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByIndex)
Next (GetItem)


Previous (FindByUniqueID)
Next (GetOtherItems)

Name
GetItem

Parent
ICartwallItemList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ICartwallItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByUniqueID)
Next (GetOtherItems)


Previous (GetItem)
Next (IndexOfUniqueID)

Name
GetOtherItems

Parent
ICartwallItemList

Visibility
PUBLIC

Source code
function GetOtherItems ( iThisItem : ICartwallItem ) : ICartwallItemList

Parameters
Parameter | Description
iThisItem : ICartwallItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (IndexOfUniqueID)


Previous (GetOtherItems)
Next

Name
IndexOfUniqueID

Parent
ICartwallItemList

Visibility
PUBLIC

Source code
function IndexOfUniqueID ( iID : string ) : integer

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOtherItems)
Next


Previous (ICartwallItemList)
Next (ICartwallPageControl)

Name
ICartwallModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Members
Methods
Method Description
GetCartwallControl (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallItemList)
Next (ICartwallPageControl)


Previous
Next

Name
GetCartwallControl

Parent
ICartwallModule

Visibility
PUBLIC

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (ICartwallModule)
Next (ICartwallPageControlList)

Name
ICartwallPageControl

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
AddPlaylistItems (+)
CanCloseItem (+)
GetActiveItemCount (+)
GetCaption (+)
GetCartwallControl (+)
GetCurrentInSequence (+)
GetCurrentItem (+)
GetCurrentItemEx (+)
GetFilename (+)
GetFirstFreeSpot (+)
GetItemAtPos (+)
GetItems (+)
GetModified (+)
GetNextInSequence (+)
GetPlayerControl (+)
GetPlayerControlOfItem (+)
GetSequence (+)
LoadFromFile (+)
LoadFromV4XML (+)
PositionItem (+)
SetCaption (+)
SetFilename (+)
SetModified (+)
SetSequence (+)
StartNext (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallModule)
Next (ICartwallPageControlList)


Previous
Next (CanCloseItem)

Name
AddPlaylistItems

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function AddPlaylistItems ( iItems : IPlaylist ; iPoint : TPoint ; iAllowReplaceForFirst : boolean ) : boolean

Parameters
Parameter | Description
iItems : IPlaylist | &nbsp;
iPoint : TPoint | &nbsp;
iAllowReplaceForFirst : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (CanCloseItem)


Previous (AddPlaylistItems)
Next (GetActiveItemCount)

Name
CanCloseItem

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function CanCloseItem ( iItem : ICartwallItem ) : boolean

Parameters
Parameter | Description
iItem : ICartwallItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddPlaylistItems)
Next (GetActiveItemCount)


Previous (CanCloseItem)
Next (GetCaption)

Name
GetActiveItemCount

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetActiveItemCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CanCloseItem)
Next (GetCaption)


Previous (GetActiveItemCount)
Next (GetCartwallControl)

Name
GetCaption

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActiveItemCount)
Next (GetCartwallControl)


Previous (GetCaption)
Next (GetCurrentInSequence)

Name
GetCartwallControl

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCurrentInSequence)


Previous (GetCartwallControl)
Next (GetCurrentItem)

Name
GetCurrentInSequence

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetCurrentInSequence : ICartwallItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartwallControl)
Next (GetCurrentItem)


Previous (GetCurrentInSequence)
Next (GetCurrentItemEx)

Name
GetCurrentItem

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetCurrentItem : ICartwallItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentInSequence)
Next (GetCurrentItemEx)


Previous (GetCurrentItem)
Next (GetFilename)

Name
GetCurrentItemEx

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure GetCurrentItemEx ( out oItem : ICartwallItem ; out oStartTickCount : int64 )

Parameters
Parameter | Description
oItem : ICartwallItem | &nbsp;
oStartTickCount : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCurrentItem)
Next (GetFilename)


Previous (GetCurrentItemEx)
Next (GetFirstFreeSpot)

Name
GetFilename

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentItemEx)
Next (GetFirstFreeSpot)


Previous (GetFilename)
Next (GetItemAtPos)

Name
GetFirstFreeSpot

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetFirstFreeSpot ( iFrom : TPoint ; out oResult : TPoint ) : boolean

Parameters
Parameter | Description
iFrom : TPoint | &nbsp;
oResult : TPoint | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (GetItemAtPos)


Previous (GetFirstFreeSpot)
Next (GetItems)

Name
GetItemAtPos

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetItemAtPos ( iPosition : TPoint ) : ICartwallItem

Parameters
Parameter | Description
iPosition : TPoint | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFirstFreeSpot)
Next (GetItems)


Previous (GetItemAtPos)
Next (GetModified)

Name
GetItems

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetItems : ICartwallItemList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemAtPos)
Next (GetModified)


Previous (GetItems)
Next (GetNextInSequence)

Name
GetModified

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetModified : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItems)
Next (GetNextInSequence)


Previous (GetModified)
Next (GetPlayerControl)

Name
GetNextInSequence

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetNextInSequence : ICartwallItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetModified)
Next (GetPlayerControl)


Previous (GetNextInSequence)
Next (GetPlayerControlOfItem)

Name
GetPlayerControl

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetPlayerControl ( iIndex : integer ) : ICartPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNextInSequence)
Next (GetPlayerControlOfItem)


Previous (GetPlayerControl)
Next (GetSequence)

Name
GetPlayerControlOfItem

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetPlayerControlOfItem ( iItem : ICartwallItem ) : ICartPlayerControl

Parameters
Parameter | Description
iItem : ICartwallItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlayerControl)
Next (GetSequence)


Previous (GetPlayerControlOfItem)
Next (LoadFromFile)

Name
GetSequence

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function GetSequence : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerControlOfItem)
Next (LoadFromFile)


Previous (GetSequence)
Next (LoadFromV4XML)

Name
LoadFromFile

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSequence)
Next (LoadFromV4XML)


Previous (LoadFromFile)
Next (PositionItem)

Name
LoadFromV4XML

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure LoadFromV4XML ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (PositionItem)


Previous (LoadFromV4XML)
Next (SetCaption)

Name
PositionItem

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
function PositionItem ( iItem : ICartwallItem ; iNewRect : TRect ) : boolean

Parameters
Parameter | Description
iItem : ICartwallItem | &nbsp;
iNewRect : TRect | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromV4XML)
Next (SetCaption)


Previous (PositionItem)
Next (SetFilename)

Name
SetCaption

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure SetCaption ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (PositionItem)
Next (SetFilename)


Previous (SetCaption)
Next (SetModified)

Name
SetFilename

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCaption)
Next (SetModified)


Previous (SetFilename)
Next (SetSequence)

Name
SetModified

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure SetModified ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFilename)
Next (SetSequence)


Previous (SetModified)
Next (StartNext)

Name
SetSequence

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure SetSequence ( iValue : IStrings )

Parameters
Parameter | Description
iValue : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetModified)
Next (StartNext)


Previous (SetSequence)
Next

Name
StartNext

Parent
ICartwallPageControl

Visibility
PUBLIC

Source code
procedure StartNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetSequence)
Next


Previous (ICartwallPageControl)
Next (ICartwallTrigger)

Name
ICartwallPageControlList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallPageControl)
Next (ICartwallTrigger)


Previous
Next

Name
GetItem

Parent
ICartwallPageControlList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ICartwallPageControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (ICartwallPageControlList)
Next (ICartwallTriggerList)

Name
ICartwallTrigger

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallPageControlList)
Next (ICartwallTriggerList)


Previous (ICartwallTrigger)
Next (IClientList)

Name
ICartwallTriggerList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallTrigger)
Next (IClientList)


Previous
Next

Name
GetItem

Parent
ICartwallTriggerList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ICartwallTrigger

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (ICartwallTriggerList)
Next (ICommandPlaylistItem)

Name
IClientList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddStrong (+)
Clone (+)
CloneStrong (+)
GetCount (+)
GetItem (+)
Insert (+)
REMOVE (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartwallTriggerList)
Next (ICommandPlaylistItem)


Previous
Next (AddStrong)

Name
ADD

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Add ( intf : IUnknown )

Parameters
Parameter | Description
intf : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AddStrong)


Previous (ADD)
Next (Clone)

Name
AddStrong

Parent
IClientList

Visibility
PUBLIC

Source code
procedure AddStrong ( intf : IUnknown )

Parameters
Parameter | Description
intf : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Clone)


Previous (AddStrong)
Next (CloneStrong)

Name
Clone

Parent
IClientList

Visibility
PUBLIC

Source code
function Clone : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddStrong)
Next (CloneStrong)


Previous (Clone)
Next (GetCount)

Name
CloneStrong

Parent
IClientList

Visibility
PUBLIC

Source code
function CloneStrong : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetCount)


Previous (CloneStrong)
Next (GetItem)

Name
GetCount

Parent
IClientList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CloneStrong)
Next (GetItem)


Previous (GetCount)
Next (Insert)

Name
GetItem

Parent
IClientList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IUnknown

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (Insert)


Previous (GetItem)
Next (REMOVE)

Name
Insert

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; intf : IUnknown )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
intf : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (REMOVE)


Previous (Insert)
Next

Name
REMOVE

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Remove ( intf : IUnknown )

Parameters
Parameter | Description
intf : IUnknown | &nbsp;

mAirListScript
Class Tree
Index
Previous (Insert)
Next


Previous (IClientList)
Next (IComPort)

Name
ICommandPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetCommand (+)
SetCommand (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IClientList)
Next (IComPort)


Previous
Next (SetCommand)

Name
GetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
function GetCommand : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetCommand)


Previous (GetCommand)
Next

Name
SetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCommand ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCommand)
Next


Previous (ICommandPlaylistItem)
Next (IConfigObject)

Name
IComPort

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
Close (+)
GetPort (+)
Open (+)
SendStr (+)
SetDTR (+)
SetParameters (+)
SetRxBuffer (+)
SetTxBuffer (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICommandPlaylistItem)
Next (IConfigObject)


Previous
Next (GetPort)

Name
Close

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (Close)
Next (Open)

Name
GetPort

Parent
IComPort

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Close)
Next (Open)


Previous (GetPort)
Next (SendStr)

Name
Open

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Open

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SendStr)


Previous (Open)
Next (SetDTR)

Name
SendStr

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SendStr ( const Tx : AnsiString )

Parameters
Parameter | Description
Tx : ANSISTRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Open)
Next (SetDTR)


Previous (SendStr)
Next (SetParameters)

Name
SetDTR

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetDTR ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SendStr)
Next (SetParameters)


Previous (SetDTR)
Next (SetRxBuffer)

Name
SetParameters

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetParameters ( iBaudRate : integer ; iByteSize : byte ; iParity : char ; iStopBits : Single )

Parameters
Parameter | Description
iBaudRate : INTEGER | &nbsp;
iByteSize : BYTE | &nbsp;
iParity : CHAR | &nbsp;
iStopBits : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDTR)
Next (SetRxBuffer)


Previous (SetParameters)
Next (SetTxBuffer)

Name
SetRxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetRxBuffer ( iSize : integer )

Parameters
Parameter | Description
iSize : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetParameters)
Next (SetTxBuffer)


Previous (SetRxBuffer)
Next

Name
SetTxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetTxBuffer ( iSize : integer )

Parameters
Parameter | Description
iSize : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRxBuffer)
Next


Previous (IComPort)
Next (IConfigObjectList)

Name
IConfigObject

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetActive (+)
GetCaption (+)
GetConfig (+)
GetEnabled (+)
SetActive (+)
SetConfig (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IComPort)
Next (IConfigObjectList)


Previous
Next (GetCaption)

Name
GetActive

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetCaption)


Previous (GetActive)
Next (GetConfig)

Name
GetCaption

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActive)
Next (GetConfig)


Previous (GetCaption)
Next (GetEnabled)

Name
GetConfig

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetConfig : IConfigValues

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetEnabled)


Previous (GetConfig)
Next (SetActive)

Name
GetEnabled

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConfig)
Next (SetActive)


Previous (GetEnabled)
Next (SetConfig)

Name
SetActive

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SetActive ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (SetConfig)


Previous (SetActive)
Next (SetEnabled)

Name
SetConfig

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SetConfig ( iConfig : IConfigValues )

Parameters
Parameter | Description
iConfig : IConfigValues | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetActive)
Next (SetEnabled)


Previous (SetConfig)
Next

Name
SetEnabled

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetConfig)
Next


Previous (IConfigObject)
Next (IConfiguration)

Name
IConfigObjectList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetActive (+)
GetConfig (+)
SetActive (+)
SetConfig (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigObject)
Next (IConfiguration)


Previous
Next (GetConfig)

Name
GetActive

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
function GetActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetConfig)


Previous (GetActive)
Next (SetActive)

Name
GetConfig

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
function GetConfig : IConfigValuesList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActive)
Next (SetActive)


Previous (GetConfig)
Next (SetConfig)

Name
SetActive

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
procedure SetActive ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetConfig)
Next (SetConfig)


Previous (SetActive)
Next

Name
SetConfig

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
procedure SetConfig ( iConfig : IConfigValuesList )

Parameters
Parameter | Description
iConfig : IConfigValuesList | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetActive)
Next


Previous (IConfigObjectList)
Next (IConfigValues)

Name
IConfiguration

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AppendSectionValues (+)
ConfigExists (+)
DeleteKey (+)
EraseCategory (+)
EraseSection (+)
Flush (+)
GetSections (+)
ReadColor (+)
ReadColorEx (+)
ReadFloat (+)
ReadFloatEx (+)
ReadFont (+)
ReadFontEx (+)
ReadInteger (+)
ReadIntegerEx (+)
ReadMultiSectionValues (+)
ReadOnOff (+)
ReadOnOffEx (+)
ReadPassword (+)
ReadSectionItems (+)
ReadSectionValues (+)
ReadSectionValuesEx (+)
ReadString (+)
ReadStringEx (+)
ReadStringSafe (+)
ReleaseAllFiles (+)
SectionExists (+)
WriteColor (+)
WriteFloat (+)
WriteFont (+)
WriteInteger (+)
WriteMultiSectionValues (+)
WriteOnOff (+)
WritePassword (+)
WriteSectionItems (+)
WriteSectionValues (+)
WriteString (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigObjectList)
Next (IConfigValues)


Previous
Next (ConfigExists)

Name
AppendSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure AppendSectionValues ( iCategory : string ; iSection : string ; iValues : IStrings )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iValues : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (ConfigExists)


Previous (AppendSectionValues)
Next (DeleteKey)

Name
ConfigExists

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ConfigExists ( iCategory : string ) : boolean

Parameters
Parameter | Description
iCategory : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (AppendSectionValues)
Next (DeleteKey)


Previous (ConfigExists)
Next (EraseCategory)

Name
DeleteKey

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure DeleteKey ( iCategory : string ; iSection : string ; iKey : string )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ConfigExists)
Next (EraseCategory)


Previous (DeleteKey)
Next (EraseSection)

Name
EraseCategory

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure EraseCategory ( iCategory : string )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteKey)
Next (EraseSection)


Previous (EraseCategory)
Next (Flush)

Name
EraseSection

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure EraseSection ( iCategory : string ; iSection : string )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (EraseCategory)
Next (Flush)


Previous (EraseSection)
Next (GetSections)

Name
Flush

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure Flush

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EraseSection)
Next (GetSections)


Previous (Flush)
Next (ReadColor)

Name
GetSections

Parent
IConfiguration

Visibility
PUBLIC

Source code
function GetSections ( iCategory : string ) : IStrings

Parameters
Parameter | Description
iCategory : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Flush)
Next (ReadColor)


Previous (GetSections)
Next (ReadColorEx)

Name
ReadColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColor ( iCategory : string ; iSection , iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSections)
Next (ReadColorEx)


Previous (ReadColor)
Next (ReadFloat)

Name
ReadColorEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColorEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadColor)
Next (ReadFloat)


Previous (ReadColorEx)
Next (ReadFloatEx)

Name
ReadFloat

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadFloat ( iCategory : string ; iSection , iKey : string ; iDefault : single ) : single

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadColorEx)
Next (ReadFloatEx)


Previous (ReadFloat)
Next (ReadFont)

Name
ReadFloatEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadFloatEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : single ) : single

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFloat)
Next (ReadFont)


Previous (ReadFloatEx)
Next (ReadFontEx)

Name
ReadFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iFontID : STRING | &nbsp;
iFont : TFont | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFloatEx)
Next (ReadFontEx)


Previous (ReadFont)
Next (ReadInteger)

Name
ReadFontEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFontEx ( iCategory : string ; iSections : array of string ; iFontID : string ; iFont : TFont )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iFontID : STRING | &nbsp;
iFont : TFont | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFont)
Next (ReadInteger)


Previous (ReadFontEx)
Next (ReadIntegerEx)

Name
ReadInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadInteger ( iCategory : string ; iSection , iKey : string ; iDefault : integer ) : integer

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFontEx)
Next (ReadIntegerEx)


Previous (ReadInteger)
Next (ReadMultiSectionValues)

Name
ReadIntegerEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadIntegerEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : integer ) : integer

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadInteger)
Next (ReadMultiSectionValues)


Previous (ReadIntegerEx)
Next (ReadOnOff)

Name
ReadMultiSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadMultiSectionValues ( iCategory : string ; iPrefix : string ) : IConfigValuesList

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iPrefix : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadIntegerEx)
Next (ReadOnOff)


Previous (ReadMultiSectionValues)
Next (ReadOnOffEx)

Name
ReadOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOff ( iCategory : string ; iSection , iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadMultiSectionValues)
Next (ReadOnOffEx)


Previous (ReadOnOff)
Next (ReadPassword)

Name
ReadOnOffEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOffEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadOnOff)
Next (ReadPassword)


Previous (ReadOnOffEx)
Next (ReadSectionItems)

Name
ReadPassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadPassword ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadOnOffEx)
Next (ReadSectionItems)


Previous (ReadPassword)
Next (ReadSectionValues)

Name
ReadSectionItems

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionItems ( iCategory : string ; iSection : string ) : IStrings

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadPassword)
Next (ReadSectionValues)


Previous (ReadSectionItems)
Next (ReadSectionValuesEx)

Name
ReadSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValues ( iCategory : string ; iSection : string ) : IConfigValues

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadSectionItems)
Next (ReadSectionValuesEx)


Previous (ReadSectionValues)
Next (ReadString)

Name
ReadSectionValuesEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValuesEx ( iCategory : string ; iSections : array of string ) : IStrings

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadSectionValues)
Next (ReadString)


Previous (ReadSectionValuesEx)
Next (ReadStringEx)

Name
ReadString

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadString ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadSectionValuesEx)
Next (ReadStringEx)


Previous (ReadString)
Next (ReadStringSafe)

Name
ReadStringEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : string ) : string

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSections : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadString)
Next (ReadStringSafe)


Previous (ReadStringEx)
Next (ReleaseAllFiles)

Name
ReadStringSafe

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringSafe ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadStringEx)
Next (ReleaseAllFiles)


Previous (ReadStringSafe)
Next (SectionExists)

Name
ReleaseAllFiles

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReleaseAllFiles

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadStringSafe)
Next (SectionExists)


Previous (ReleaseAllFiles)
Next (WriteColor)

Name
SectionExists

Parent
IConfiguration

Visibility
PUBLIC

Source code
function SectionExists ( iCategory , iSection : string ) : boolean

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReleaseAllFiles)
Next (WriteColor)


Previous (SectionExists)
Next (WriteFloat)

Name
WriteColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteColor ( iCategory : string ; iSection , iKey : string ; iValue : TColor )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (SectionExists)
Next (WriteFloat)


Previous (WriteColor)
Next (WriteFont)

Name
WriteFloat

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteFloat ( iCategory : string ; iSection , iKey : string ; iValue : single )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteColor)
Next (WriteFont)


Previous (WriteFloat)
Next (WriteInteger)

Name
WriteFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iFontID : STRING | &nbsp;
iFont : TFont | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteFloat)
Next (WriteInteger)


Previous (WriteFont)
Next (WriteMultiSectionValues)

Name
WriteInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteInteger ( iCategory : string ; iSection , iKey : string ; iValue : integer )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteFont)
Next (WriteMultiSectionValues)


Previous (WriteInteger)
Next (WriteOnOff)

Name
WriteMultiSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteMultiSectionValues ( iCategory : string ; iPrefix : string ; iValues : IConfigValuesList )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iPrefix : STRING | &nbsp;
iValues : IConfigValuesList | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteInteger)
Next (WriteOnOff)


Previous (WriteMultiSectionValues)
Next (WritePassword)

Name
WriteOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteOnOff ( iCategory : string ; iSection , iKey : string ; iValue : boolean )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteMultiSectionValues)
Next (WritePassword)


Previous (WriteOnOff)
Next (WriteSectionItems)

Name
WritePassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WritePassword ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteOnOff)
Next (WriteSectionItems)


Previous (WritePassword)
Next (WriteSectionValues)

Name
WriteSectionItems

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteSectionItems ( iCategory : string ; iSection : string ; iValues : IStrings )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iValues : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (WritePassword)
Next (WriteSectionValues)


Previous (WriteSectionItems)
Next (WriteString)

Name
WriteSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteSectionValues ( iCategory : string ; iSection : string ; iValues : IStrings )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iValues : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteSectionItems)
Next (WriteString)


Previous (WriteSectionValues)
Next

Name
WriteString

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteString ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter | Description
iCategory : STRING | &nbsp;
iSection : STRING | &nbsp;
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteSectionValues)
Next


Previous (IConfiguration)
Next (IConfigValuesList)

Name
IConfigValues

Parent
mAirListInterfaces

Class Hierarchy
IStrings

Visibility
PUBLIC

Members
Methods
Method Description
DeleteKey (+)
ReadColor (+)
ReadFloat (+)
ReadFont (+)
ReadInteger (+)
ReadList (+)
ReadNameValueList (+)
ReadOnOff (+)
ReadPassword (+)
ReadString (+)
ReadSubSection (+)
WriteColor (+)
WriteFloat (+)
WriteFont (+)
WriteInteger (+)
WriteList (+)
WriteNameValueList (+)
WriteOnOff (+)
WritePassword (+)
WriteString (+)
WriteSubSection (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfiguration)
Next (IConfigValuesList)


Previous
Next (ReadColor)

Name
DeleteKey

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure DeleteKey ( iKey : string )

Parameters
Parameter | Description
iKey : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (ReadColor)


Previous (DeleteKey)
Next (ReadFloat)

Name
ReadColor

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadColor ( iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteKey)
Next (ReadFloat)


Previous (ReadColor)
Next (ReadFont)

Name
ReadFloat

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadFloat ( iKey : string ; iDefault : single = 0 ) : single

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadColor)
Next (ReadFont)


Previous (ReadFloat)
Next (ReadInteger)

Name
ReadFont

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure ReadFont ( iFontID : string ; iFont : TFont )

Parameters
Parameter | Description
iFontID : STRING | &nbsp;
iFont : TFont | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFloat)
Next (ReadInteger)


Previous (ReadFont)
Next (ReadList)

Name
ReadInteger

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadInteger ( iKey : string ; iDefault : integer = 0 ) : integer

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadFont)
Next (ReadList)


Previous (ReadInteger)
Next (ReadNameValueList)

Name
ReadList

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadList ( iKey : string ) : IStrings

Parameters
Parameter | Description
iKey : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadInteger)
Next (ReadNameValueList)


Previous (ReadList)
Next (ReadOnOff)

Name
ReadNameValueList

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadNameValueList ( iKey1 , iKey2 : string ) : IStrings

Parameters
Parameter | Description
iKey1 : STRING | &nbsp;
iKey2 : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadList)
Next (ReadOnOff)


Previous (ReadNameValueList)
Next (ReadPassword)

Name
ReadOnOff

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadOnOff ( iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadNameValueList)
Next (ReadPassword)


Previous (ReadOnOff)
Next (ReadString)

Name
ReadPassword

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadPassword ( iKey : string ; iDefault : string = '' ) : string

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadOnOff)
Next (ReadString)


Previous (ReadPassword)
Next (ReadSubSection)

Name
ReadString

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadString ( iKey : string ; iDefault : string = '' ) : string

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadPassword)
Next (ReadSubSection)


Previous (ReadString)
Next (WriteColor)

Name
ReadSubSection

Parent
IConfigValues

Visibility
PUBLIC

Source code
function ReadSubSection ( iPrefix : string ) : IConfigValuesList

Parameters
Parameter | Description
iPrefix : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadString)
Next (WriteColor)


Previous (ReadSubSection)
Next (WriteFloat)

Name
WriteColor

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteColor ( iKey : string ; iValue : TColor )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadSubSection)
Next (WriteFloat)


Previous (WriteColor)
Next (WriteFont)

Name
WriteFloat

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteFloat ( iKey : string ; iValue : single )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteColor)
Next (WriteFont)


Previous (WriteFloat)
Next (WriteInteger)

Name
WriteFont

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteFont ( iFontID : string ; iFont : TFont )

Parameters
Parameter | Description
iFontID : STRING | &nbsp;
iFont : TFont | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteFloat)
Next (WriteInteger)


Previous (WriteFont)
Next (WriteList)

Name
WriteInteger

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteInteger ( iKey : string ; iValue : integer )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteFont)
Next (WriteList)


Previous (WriteInteger)
Next (WriteNameValueList)

Name
WriteList

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteList ( iKey : string ; iList : IStrings )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iList : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteInteger)
Next (WriteNameValueList)


Previous (WriteList)
Next (WriteOnOff)

Name
WriteNameValueList

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteNameValueList ( iKey1 , iKey2 : string ; iList : IStrings )

Parameters
Parameter | Description
iKey1 : STRING | &nbsp;
iKey2 : STRING | &nbsp;
iList : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteList)
Next (WriteOnOff)


Previous (WriteNameValueList)
Next (WritePassword)

Name
WriteOnOff

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteOnOff ( iKey : string ; iValue : boolean )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteNameValueList)
Next (WritePassword)


Previous (WriteOnOff)
Next (WriteString)

Name
WritePassword

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WritePassword ( iKey : string ; iValue : string )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteOnOff)
Next (WriteString)


Previous (WritePassword)
Next (WriteSubSection)

Name
WriteString

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteString ( iKey : string ; iValue : string )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (WritePassword)
Next (WriteSubSection)


Previous (WriteString)
Next

Name
WriteSubSection

Parent
IConfigValues

Visibility
PUBLIC

Source code
procedure WriteSubSection ( iPrefix : string ; iValues : IConfigValuesList )

Parameters
Parameter | Description
iPrefix : STRING | &nbsp;
iValues : IConfigValuesList | &nbsp;

mAirListScript
Class Tree
Index
Previous (WriteString)
Next


Previous (IConfigValues)
Next (IContainerPlaylistItem)

Name
IConfigValuesList

Parent
mAirListInterfaces

Class Hierarchy
IInterfaceList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigValues)
Next (IContainerPlaylistItem)


Previous
Next

Name
GetItem

Parent
IConfigValuesList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IConfigValues

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IConfigValuesList)
Next (ICueData)

Name
IContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetInnerFadeDuration (+)
GetPlaylist (+)
SetInnerFadeDuration (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigValuesList)
Next (ICueData)


Previous
Next (GetPlaylist)

Name
GetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetInnerFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaylist)


Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)

Name
GetPlaylist

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)


Previous (GetPlaylist)
Next

Name
SetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetInnerFadeDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next


Previous (IContainerPlaylistItem)
Next (ICueDataItem)

Name
ICueData

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
LoadFromCueSheet (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IContainerPlaylistItem)
Next (ICueDataItem)


Previous
Next (LoadFromCueSheet)

Name
GetItem

Parent
ICueData

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : ICueDataItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (LoadFromCueSheet)


Previous (GetItem)
Next

Name
LoadFromCueSheet

Parent
ICueData

Visibility
PUBLIC

Source code
procedure LoadFromCueSheet ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (ICueData)
Next (IDatabase)

Name
ICueDataItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetDescription (+)
GetParameters (+)
GetPosition (+)
SetPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueData)
Next (IDatabase)


Previous
Next (GetParameters)

Name
GetDescription

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetParameters)


Previous (GetDescription)
Next (GetPosition)

Name
GetParameters

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetParameters : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetPosition)


Previous (GetParameters)
Next (SetPosition)

Name
GetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (SetPosition)


Previous (GetPosition)
Next

Name
SetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next


Previous (ICueDataItem)
Next (IDatabaseAction)

Name
IDatabase

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
CreatePlaylistItem (+)
ExecuteSQL (+)
FillDatabaseTree (+)
GetCapabilities (+)
GetCaption (+)
GetCurrentPlaylist (+)
GetCustomCaption (+)
GetErrorMessage (+)
GetID (+)
GetNextPlaylist (+)
GetPlaylist (+)
GetPlaylistByID (+)
GetStandardAttributes (+)
GetState (+)
GetSubPlaylists (+)
GetUniqueID (+)
ReverseLookup (+)
SavePlaylistItem (+)
SearchItems (+)
SetActiveSync (+)
SetCustomCaption (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueDataItem)
Next (IDatabaseAction)


Previous
Next (ExecuteSQL)

Name
CreatePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
function CreatePlaylistItem ( iID : string ) : IPlaylistItem

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (ExecuteSQL)


Previous (CreatePlaylistItem)
Next (FillDatabaseTree)

Name
ExecuteSQL

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure ExecuteSQL ( iSQL : string )

Parameters
Parameter | Description
iSQL : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItem)
Next (FillDatabaseTree)


Previous (ExecuteSQL)
Next (GetCapabilities)

Name
FillDatabaseTree

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure FillDatabaseTree ( iTree : IDatabaseTree ; iParent : cardinal ; const iParentData : TDatabaseNodeData )

Parameters
Parameter | Description
iTree : IDatabaseTree | &nbsp;
iParent : CARDINAL | &nbsp;
iParentData : TDatabaseNodeData | &nbsp;

mAirListScript
Class Tree
Index
Previous (ExecuteSQL)
Next (GetCapabilities)


Previous (FillDatabaseTree)
Next (GetCaption)

Name
GetCapabilities

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCapabilities : TDatabaseCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FillDatabaseTree)
Next (GetCaption)


Previous (GetCapabilities)
Next (GetCurrentPlaylist)

Name
GetCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetCurrentPlaylist)


Previous (GetCaption)
Next (GetCustomCaption)

Name
GetCurrentPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCurrentPlaylist ( iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter | Description
iSubPlaylist : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCustomCaption)


Previous (GetCurrentPlaylist)
Next (GetErrorMessage)

Name
GetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCustomCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentPlaylist)
Next (GetErrorMessage)


Previous (GetCustomCaption)
Next (GetID)

Name
GetErrorMessage

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomCaption)
Next (GetID)


Previous (GetErrorMessage)
Next (GetNextPlaylist)

Name
GetID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetNextPlaylist)


Previous (GetID)
Next (GetPlaylist)

Name
GetNextPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetNextPlaylist ( iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter | Description
iSubPlaylist : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetID)
Next (GetPlaylist)


Previous (GetNextPlaylist)
Next (GetPlaylistByID)

Name
GetPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylist ( iSlot : TDateTime ; iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter | Description
iSlot : TDateTime | &nbsp;
iSubPlaylist : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNextPlaylist)
Next (GetPlaylistByID)


Previous (GetPlaylist)
Next (GetStandardAttributes)

Name
GetPlaylistByID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylistByID ( iID : string ) : IPlaylist

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetStandardAttributes)


Previous (GetPlaylistByID)
Next (GetState)

Name
GetStandardAttributes

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetStandardAttributes : IStandardAttributeList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylistByID)
Next (GetState)


Previous (GetStandardAttributes)
Next (GetSubPlaylists)

Name
GetState

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetState : TDatabaseState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStandardAttributes)
Next (GetSubPlaylists)


Previous (GetState)
Next (GetUniqueID)

Name
GetSubPlaylists

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetSubPlaylists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (GetUniqueID)


Previous (GetSubPlaylists)
Next (ReverseLookup)

Name
GetUniqueID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetUniqueID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSubPlaylists)
Next (ReverseLookup)


Previous (GetUniqueID)
Next (SavePlaylistItem)

Name
ReverseLookup

Parent
IDatabase

Visibility
PUBLIC

Source code
function ReverseLookup ( iFilename : string ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetUniqueID)
Next (SavePlaylistItem)


Previous (ReverseLookup)
Next (SearchItems)

Name
SavePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SavePlaylistItem ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReverseLookup)
Next (SearchItems)


Previous (SavePlaylistItem)
Next (SetActiveSync)

Name
SearchItems

Parent
IDatabase

Visibility
PUBLIC

Source code
function SearchItems ( iSearchString : string ; iFields : TDatabaseSearchFields ; iResultPlaylist : IPlaylist ) : IDatabaseSearchHandler

Parameters
Parameter | Description
iSearchString : STRING | &nbsp;
iFields : TDatabaseSearchFields | &nbsp;
iResultPlaylist : IPlaylist | &nbsp;

mAirListScript
Class Tree
Index
Previous (SavePlaylistItem)
Next (SetActiveSync)


Previous (SearchItems)
Next (SetCustomCaption)

Name
SetActiveSync

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SetActiveSync

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SearchItems)
Next (SetCustomCaption)


Previous (SetActiveSync)
Next

Name
SetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SetCustomCaption ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetActiveSync)
Next


Previous (IDatabase)
Next (IDatabaseInlineLoader)

Name
IDatabaseAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Members
Methods
Method Description
GetDatabaseID (+)
GetSubPlaylist (+)
SetDatabaseID (+)
SetSubPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabase)
Next (IDatabaseInlineLoader)


Previous
Next (GetSubPlaylist)

Name
GetDatabaseID

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetSubPlaylist)


Previous (GetDatabaseID)
Next (SetDatabaseID)

Name
GetSubPlaylist

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
function GetSubPlaylist : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (SetDatabaseID)


Previous (GetSubPlaylist)
Next (SetSubPlaylist)

Name
SetDatabaseID

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSubPlaylist)
Next (SetSubPlaylist)


Previous (SetDatabaseID)
Next

Name
SetSubPlaylist

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
procedure SetSubPlaylist ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next


Previous (IDatabaseAction)
Next (IDatabaseList)

Name
IDatabaseInlineLoader

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
LoadInlineData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseAction)
Next (IDatabaseList)


Previous
Next

Name
LoadInlineData

Parent
IDatabaseInlineLoader

Visibility
PUBLIC

Source code
procedure LoadInlineData ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)

Name
IDatabaseList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
ConnectAllSync (+)
FindByUniqueID (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)


Previous
Next (FindByUniqueID)

Name
ConnectAllSync

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure ConnectAllSync

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (FindByUniqueID)


Previous (ConnectAllSync)
Next (GetItem)

Name
FindByUniqueID

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function FindByUniqueID ( iUniqueID : string ) : IDatabase

Parameters
Parameter | Description
iUniqueID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ConnectAllSync)
Next (GetItem)


Previous (FindByUniqueID)
Next

Name
GetItem

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IDatabase

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByUniqueID)
Next


Previous (IDatabaseList)
Next (IDatabaseTree)

Name
IDatabaseSearchHandler

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
IsActive (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseList)
Next (IDatabaseTree)


Previous
Next

Name
IsActive

Parent
IDatabaseSearchHandler

Visibility
PUBLIC

Source code
function IsActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseSearchHandler)
Next (IDebugObject)

Name
IDatabaseTree

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddNode (+)
GetCaptionOfNode (+)
GetDataOfNode (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseSearchHandler)
Next (IDebugObject)


Previous
Next (GetCaptionOfNode)

Name
AddNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
procedure AddNode ( iParent : cardinal ; iDatabase : IDatabase ; iNodeType : TDatabaseTreeNodeType ; iCaption : string ; iExpectChildren : boolean = true ; iDuration : TTimeValue = 0 ; iData : string = '' ; iData2 : string = '' ; iSubType : integer = 0 )

Parameters
Parameter | Description
iParent : CARDINAL | &nbsp;
iDatabase : IDatabase | &nbsp;
iNodeType : TDatabaseTreeNodeType | &nbsp;
iCaption : STRING | &nbsp;
iExpectChildren : BOOLEAN | &nbsp;
iDuration : TTimeValue | &nbsp;
iData : STRING | &nbsp;
iData2 : STRING | &nbsp;
iSubType : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetCaptionOfNode)


Previous (AddNode)
Next (GetDataOfNode)

Name
GetCaptionOfNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetCaptionOfNode ( iNode : cardinal ) : string

Parameters
Parameter | Description
iNode : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddNode)
Next (GetDataOfNode)


Previous (GetCaptionOfNode)
Next

Name
GetDataOfNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetDataOfNode ( iNode : cardinal ) : TDatabaseNodeData

Parameters
Parameter | Description
iNode : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCaptionOfNode)
Next


Previous (IDatabaseTree)
Next (IDummyAction)

Name
IDebugObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetObjectInfo (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseTree)
Next (IDummyAction)


Previous
Next

Name
GetObjectInfo

Parent
IDebugObject

Visibility
PUBLIC

Source code
function GetObjectInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDebugObject)
Next (IDummyObject)

Name
IDummyAction

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDebugObject)
Next (IDummyObject)


Previous (IDummyAction)
Next (IDummyPlaylistItem)

Name
IDummyObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyAction)
Next (IDummyPlaylistItem)


Previous (IDummyObject)
Next (IEmergencyAction)

Name
IDummyPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyObject)
Next (IEmergencyAction)


Previous (IDummyPlaylistItem)
Next (IEngine)

Name
IEmergencyAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyPlaylistItem)
Next (IEngine)


Previous (IEmergencyAction)
Next (IEngineDesktopPlugin)

Name
IEngine

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
AddDesktopPlugin (+)
Finalize (+)
GetActivePlayers (+)
GetCartwallControl (+)
GetDesktopFilename (+)
GetModified (+)
GetPlaybackControl (+)
GetPlaybackControlCount (+)
Initialize (+)
LoadDesktop (+)
LoadFromXML (+)
NewDesktop (+)
RemoveDesktopPlugin (+)
SaveAsXML (+)
SaveDesktop (+)
SaveDesktopAs (+)
SetModified (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEmergencyAction)
Next (IEngineDesktopPlugin)


Previous
Next (Finalize)

Name
AddDesktopPlugin

Parent
IEngine

Visibility
PUBLIC

Source code
procedure AddDesktopPlugin ( iPlugin : IEngineDesktopPlugin )

Parameters
Parameter | Description
iPlugin : IEngineDesktopPlugin | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Finalize)


Previous (AddDesktopPlugin)
Next (GetActivePlayers)

Name
Finalize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddDesktopPlugin)
Next (GetActivePlayers)


Previous (Finalize)
Next (GetCartwallControl)

Name
GetActivePlayers

Parent
IEngine

Visibility
PUBLIC

Source code
function GetActivePlayers : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCartwallControl)


Previous (GetActivePlayers)
Next (GetDesktopFilename)

Name
GetCartwallControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePlayers)
Next (GetDesktopFilename)


Previous (GetCartwallControl)
Next (GetModified)

Name
GetDesktopFilename

Parent
IEngine

Visibility
PUBLIC

Source code
function GetDesktopFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartwallControl)
Next (GetModified)


Previous (GetDesktopFilename)
Next (GetPlaybackControl)

Name
GetModified

Parent
IEngine

Visibility
PUBLIC

Source code
function GetModified : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDesktopFilename)
Next (GetPlaybackControl)


Previous (GetModified)
Next (GetPlaybackControlCount)

Name
GetPlaybackControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetModified)
Next (GetPlaybackControlCount)


Previous (GetPlaybackControl)
Next (Initialize)

Name
GetPlaybackControlCount

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControl)
Next (Initialize)


Previous (GetPlaybackControlCount)
Next (LoadDesktop)

Name
Initialize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next (LoadDesktop)


Previous (Initialize)
Next (LoadFromXML)

Name
LoadDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadDesktop ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (LoadFromXML)


Previous (LoadDesktop)
Next (NewDesktop)

Name
LoadFromXML

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadDesktop)
Next (NewDesktop)


Previous (LoadFromXML)
Next (RemoveDesktopPlugin)

Name
NewDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure NewDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (RemoveDesktopPlugin)


Previous (NewDesktop)
Next (SaveAsXML)

Name
RemoveDesktopPlugin

Parent
IEngine

Visibility
PUBLIC

Source code
procedure RemoveDesktopPlugin ( iPlugin : IEngineDesktopPlugin )

Parameters
Parameter | Description
iPlugin : IEngineDesktopPlugin | &nbsp;

mAirListScript
Class Tree
Index
Previous (NewDesktop)
Next (SaveAsXML)


Previous (RemoveDesktopPlugin)
Next (SaveDesktop)

Name
SaveAsXML

Parent
IEngine

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : ISXMLDocument ; iAsTemplate : boolean ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iAsTemplate : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (RemoveDesktopPlugin)
Next (SaveDesktop)


Previous (SaveAsXML)
Next (SaveDesktopAs)

Name
SaveDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveDesktopAs)


Previous (SaveDesktop)
Next (SetModified)

Name
SaveDesktopAs

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktopAs ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveDesktop)
Next (SetModified)


Previous (SaveDesktopAs)
Next

Name
SetModified

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SetModified ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveDesktopAs)
Next


Previous (IEngine)
Next (IEngineInfo)

Name
IEngineDesktopPlugin

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ClearDesktopContents (+)
LoadDesktopContents (+)
SaveDesktopContents (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngine)
Next (IEngineInfo)


Previous
Next (LoadDesktopContents)

Name
ClearDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure ClearDesktopContents

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (LoadDesktopContents)


Previous (ClearDesktopContents)
Next (SaveDesktopContents)

Name
LoadDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure LoadDesktopContents ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (ClearDesktopContents)
Next (SaveDesktopContents)


Previous (LoadDesktopContents)
Next

Name
SaveDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure SaveDesktopContents ( iDocument : ISXMLDocument ; iParentNode : ISXMLNode ; iAsTemplate : boolean )

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iParentNode : ISXMLNode | &nbsp;
iAsTemplate : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadDesktopContents)
Next


Previous (IEngineDesktopPlugin)
Next (IEnvelope)

Name
IEngineInfo

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCartPlayerCount (+)
GetPlaybackControlCount (+)
GetPlayerCount (+)
SetCartPlayerCount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngineDesktopPlugin)
Next (IEnvelope)


Previous
Next (GetPlaybackControlCount)

Name
GetCartPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetCartPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaybackControlCount)


Previous (GetCartPlayerCount)
Next (GetPlayerCount)

Name
GetPlaybackControlCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartPlayerCount)
Next (GetPlayerCount)


Previous (GetPlaybackControlCount)
Next (SetCartPlayerCount)

Name
GetPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlayerCount ( iPlaybackControl : integer ) : integer

Parameters
Parameter | Description
iPlaybackControl : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next (SetCartPlayerCount)


Previous (GetPlayerCount)
Next

Name
SetCartPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
procedure SetCartPlayerCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next


Previous (IEngineInfo)
Next (IEnvelopePoint)

Name
IEnvelope

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
AddPoint (+)
GetItem (+)
GetPosition (+)
GetSortedPoints (+)
GetValue (+)
GetValueAtPosition (+)
Merge (+)
RemoveByTag (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngineInfo)
Next (IEnvelopePoint)


Previous
Next (GetItem)

Name
AddPoint

Parent
IEnvelope

Visibility
PUBLIC

Source code
function AddPoint ( iPosition : TTimeValue ; iValue : single ; iTag : string = '' ) : IEnvelopePoint

Parameters
Parameter | Description
iPosition : TTimeValue | &nbsp;
iValue : SINGLE | &nbsp;
iTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (AddPoint)
Next (GetPosition)

Name
GetItem

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IEnvelopePoint

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddPoint)
Next (GetPosition)


Previous (GetItem)
Next (GetSortedPoints)

Name
GetPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetPosition ( iIndex : integer ) : TTimeValue

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSortedPoints)


Previous (GetPosition)
Next (GetValue)

Name
GetSortedPoints

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure GetSortedPoints ( var oPositions : TTimeValueArray ; var oValues : TSingleArray )

Parameters
Parameter | Description
oPositions : TTimeValueArray | &nbsp;
oValues : TSingleArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetValue)


Previous (GetSortedPoints)
Next (GetValueAtPosition)

Name
GetValue

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValue ( iIndex : integer ) : single

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSortedPoints)
Next (GetValueAtPosition)


Previous (GetValue)
Next (Merge)

Name
GetValueAtPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValueAtPosition ( iPosition , iDuration : TTimeValue ) : single

Parameters
Parameter | Description
iPosition : TTimeValue | &nbsp;
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (Merge)


Previous (GetValueAtPosition)
Next (RemoveByTag)

Name
Merge

Parent
IEnvelope

Visibility
PUBLIC

Source code
function Merge ( iValue : IEnvelope ; iDuration : TTimeValue ) : IEnvelope

Parameters
Parameter | Description
iValue : IEnvelope | &nbsp;
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValueAtPosition)
Next (RemoveByTag)


Previous (Merge)
Next

Name
RemoveByTag

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure RemoveByTag ( iTag : string )

Parameters
Parameter | Description
iTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Merge)
Next


Previous (IEnvelope)
Next (IEOFWarningCueDataItem)

Name
IEnvelopePoint

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPosition (+)
GetTag (+)
GetValue (+)
SetPosition (+)
SetTag (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEnvelope)
Next (IEOFWarningCueDataItem)


Previous
Next (GetTag)

Name
GetPosition

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTag)


Previous (GetPosition)
Next (GetValue)

Name
GetTag

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetTag : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetValue)


Previous (GetTag)
Next (SetPosition)

Name
GetValue

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetValue : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (SetPosition)


Previous (GetValue)
Next (SetTag)

Name
SetPosition

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetTag)


Previous (SetPosition)
Next (SetValue)

Name
SetTag

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SetValue)


Previous (SetTag)
Next

Name
SetValue

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTag)
Next


Previous (IEnvelopePoint)
Next (IEventList)

Name
IEOFWarningCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEnvelopePoint)
Next (IEventList)


Previous (IEOFWarningCueDataItem)
Next (IEventListItem)

Name
IEventList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetEnabled (+)
GetItem (+)
GetNextExecution (+)
GetNextItem (+)
GetNextItemAssist (+)
GetNextItemAutomation (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEOFWarningCueDataItem)
Next (IEventListItem)


Previous
Next (GetItem)

Name
GetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEnabled)
Next (GetNextExecution)

Name
GetItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IEventListItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetNextExecution)


Previous (GetItem)
Next (GetNextItem)

Name
GetNextExecution

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetNextItem)


Previous (GetNextExecution)
Next (GetNextItemAssist)

Name
GetNextItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetNextItemAssist)


Previous (GetNextItem)
Next (GetNextItemAutomation)

Name
GetNextItemAssist

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAssist : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItem)
Next (GetNextItemAutomation)


Previous (GetNextItemAssist)
Next (SetEnabled)

Name
GetNextItemAutomation

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAutomation : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItemAssist)
Next (SetEnabled)


Previous (GetNextItemAutomation)
Next

Name
SetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNextItemAutomation)
Next


Previous (IEventList)
Next (IEventsModule)

Name
IEventListItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetActions (+)
GetDay (+)
GetDescription (+)
GetEnabled (+)
GetExpiration (+)
GetHour (+)
GetLastExecution (+)
GetMinute (+)
GetMonth (+)
GetNextExecution (+)
GetRunInAssist (+)
GetRunInAutomation (+)
GetSecond (+)
GetWeekday (+)
GetYear (+)
SetDay (+)
SetDescription (+)
SetEnabled (+)
SetExpiration (+)
SetHour (+)
SetLastExecution (+)
SetMinute (+)
SetMonth (+)
SetRunInAssist (+)
SetRunInAutomation (+)
SetSecond (+)
SetWeekday (+)
SetYear (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventList)
Next (IEventsModule)


Previous
Next (GetDay)

Name
GetActions

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDay)


Previous (GetActions)
Next (GetDescription)

Name
GetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDay : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActions)
Next (GetDescription)


Previous (GetDay)
Next (GetEnabled)

Name
GetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDay)
Next (GetEnabled)


Previous (GetDescription)
Next (GetExpiration)

Name
GetEnabled

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetExpiration)


Previous (GetEnabled)
Next (GetHour)

Name
GetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetExpiration : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetHour)


Previous (GetExpiration)
Next (GetLastExecution)

Name
GetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetHour : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiration)
Next (GetLastExecution)


Previous (GetHour)
Next (GetMinute)

Name
GetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetLastExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHour)
Next (GetMinute)


Previous (GetLastExecution)
Next (GetMonth)

Name
GetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMinute : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLastExecution)
Next (GetMonth)


Previous (GetMinute)
Next (GetNextExecution)

Name
GetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMonth : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMinute)
Next (GetNextExecution)


Previous (GetMonth)
Next (GetRunInAssist)

Name
GetNextExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMonth)
Next (GetRunInAssist)


Previous (GetNextExecution)
Next (GetRunInAutomation)

Name
GetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAssist : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetRunInAutomation)


Previous (GetRunInAssist)
Next (GetSecond)

Name
GetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAutomation : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAssist)
Next (GetSecond)


Previous (GetRunInAutomation)
Next (GetWeekday)

Name
GetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetSecond : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAutomation)
Next (GetWeekday)


Previous (GetSecond)
Next (GetYear)

Name
GetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetWeekday : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSecond)
Next (GetYear)


Previous (GetWeekday)
Next (SetDay)

Name
GetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetYear : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWeekday)
Next (SetDay)


Previous (GetYear)
Next (SetDescription)

Name
SetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDay ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetYear)
Next (SetDescription)


Previous (SetDay)
Next (SetEnabled)

Name
SetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDay)
Next (SetEnabled)


Previous (SetDescription)
Next (SetExpiration)

Name
SetEnabled

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetExpiration)


Previous (SetEnabled)
Next (SetHour)

Name
SetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetExpiration ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEnabled)
Next (SetHour)


Previous (SetExpiration)
Next (SetLastExecution)

Name
SetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetHour ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetExpiration)
Next (SetLastExecution)


Previous (SetHour)
Next (SetMinute)

Name
SetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetLastExecution ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetHour)
Next (SetMinute)


Previous (SetLastExecution)
Next (SetMonth)

Name
SetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMinute ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLastExecution)
Next (SetMonth)


Previous (SetMinute)
Next (SetRunInAssist)

Name
SetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMonth ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMinute)
Next (SetRunInAssist)


Previous (SetMonth)
Next (SetRunInAutomation)

Name
SetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAssist ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMonth)
Next (SetRunInAutomation)


Previous (SetRunInAssist)
Next (SetSecond)

Name
SetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAutomation ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRunInAssist)
Next (SetSecond)


Previous (SetRunInAutomation)
Next (SetWeekday)

Name
SetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetSecond ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRunInAutomation)
Next (SetWeekday)


Previous (SetSecond)
Next (SetYear)

Name
SetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetWeekday ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetSecond)
Next (SetYear)


Previous (SetWeekday)
Next

Name
SetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetYear ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetWeekday)
Next


Previous (IEventListItem)
Next (IFactory)

Name
IEventsModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventListItem)
Next (IFactory)


Previous (IEventsModule)
Next (IFactoryClass)

Name
IFactory

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateActionList (+)
CreateBreakPlaylistItem (+)
CreateCommandPlaylistItem (+)
CreateContainerPlaylistItem (+)
CreateDummyPlaylistItem (+)
CreateEventList (+)
CreateEventListItem (+)
CreateFilePlaylistItem (+)
CreateHookContainer (+)
CreateMultiPlaylist (+)
CreateObject (+)
CreatePersistentArray (+)
CreatePersistentBoolean (+)
CreatePersistentNull (+)
CreatePersistentNumber (+)
CreatePersistentObject (+)
CreatePersistentString (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+)
CreatePlaylistItemFromPersistentObject (+)
CreatePlaylistItemFromXML (+)
CreatePlaylistItemFromXMLString (+)
CreateRegionContainerPlaylistItem (+)
CreateSilencePlaylistItem (+)
CreateStreamPlaylistItem (+)
CreateStrings (+)
CreateTemporaryPlaylist (+)
CreateXMLDocument (+)
CreateXMLDocumentFromString (+)
GetClasses (+)
GetDefaultItemType (+)
GetFileImportOptions (+)
GetMMDFolder (+)
RegisterClass (+)
SetDefaultItemType (+)
SetFileImportOptions (+)
SetMMDFolder (+)
TryCreateObject (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventsModule)
Next (IFactoryClass)


Previous
Next (CreateBreakPlaylistItem)

Name
CreateActionList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateActionList : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CreateBreakPlaylistItem)


Previous (CreateActionList)
Next (CreateCommandPlaylistItem)

Name
CreateBreakPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateBreakPlaylistItem : IBreakPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateActionList)
Next (CreateCommandPlaylistItem)


Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)

Name
CreateCommandPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateCommandPlaylistItem : ICommandPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)


Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)

Name
CreateContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)


Previous (CreateContainerPlaylistItem)
Next (CreateEventList)

Name
CreateDummyPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateDummyPlaylistItem : IDummyPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateEventList)


Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)

Name
CreateEventList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)


Previous (CreateEventList)
Next (CreateFilePlaylistItem)

Name
CreateEventListItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventListItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateEventList)
Next (CreateFilePlaylistItem)


Previous (CreateEventListItem)
Next (CreateHookContainer)

Name
CreateFilePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iTasks : TFileImportTasks ) : IFilePlaylistItem

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iTasks : TFileImportTasks | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateEventListItem)
Next (CreateHookContainer)


Previous (CreateFilePlaylistItem)
Next (CreateMultiPlaylist)

Name
CreateHookContainer

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateHookContainer ( iItems : IPlaylist ) : IContainerPlaylistItem

Parameters
Parameter | Description
iItems : IPlaylist | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreateMultiPlaylist)


Previous (CreateHookContainer)
Next (CreateObject)

Name
CreateMultiPlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateMultiPlaylist : IMultiPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateHookContainer)
Next (CreateObject)


Previous (CreateMultiPlaylist)
Next (CreatePersistentArray)

Name
CreateObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateObject ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter | Description
iGUID : TGUID | &nbsp;
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateMultiPlaylist)
Next (CreatePersistentArray)


Previous (CreateObject)
Next (CreatePersistentBoolean)

Name
CreatePersistentArray

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentArray : IPersistentArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateObject)
Next (CreatePersistentBoolean)


Previous (CreatePersistentArray)
Next (CreatePersistentNull)

Name
CreatePersistentBoolean

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentBoolean ( iValue : boolean ) : IPersistentBoolean

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePersistentArray)
Next (CreatePersistentNull)


Previous (CreatePersistentBoolean)
Next (CreatePersistentNumber)

Name
CreatePersistentNull

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentNull : IPersistentNull

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentBoolean)
Next (CreatePersistentNumber)


Previous (CreatePersistentNull)
Next (CreatePersistentObject)

Name
CreatePersistentNumber

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentNumber ( iValue : double ) : IPersistentNumber

Parameters
Parameter | Description
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePersistentNull)
Next (CreatePersistentObject)


Previous (CreatePersistentNumber)
Next (CreatePersistentString)

Name
CreatePersistentObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentNumber)
Next (CreatePersistentString)


Previous (CreatePersistentObject)
Next (CreatePlaylist)

Name
CreatePersistentString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentString ( iValue : string ) : IPersistentString

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePersistentObject)
Next (CreatePlaylist)


Previous (CreatePersistentString)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentString)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromPersistentObject)

Name
CreatePlaylistItemFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iTasks : TFileImportTasks ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iTasks : TFileImportTasks | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromPersistentObject)


Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXML)

Name
CreatePlaylistItemFromPersistentObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromPersistentObject ( iValue : IPersistentObject ) : IPlaylistItem

Parameters
Parameter | Description
iValue : IPersistentObject | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXML)


Previous (CreatePlaylistItemFromPersistentObject)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromXML

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXML ( iNode : ISXMLNode ) : IPlaylistItem

Parameters
Parameter | Description
iNode : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromPersistentObject)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)

Name
CreatePlaylistItemFromXMLString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter | Description
iXML : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)


Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)

Name
CreateRegionContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateRegionContainerPlaylistItem : IRegionContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)


Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)

Name
CreateSilencePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateSilencePlaylistItem : ISilencePlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)


Previous (CreateSilencePlaylistItem)
Next (CreateStrings)

Name
CreateStreamPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateStreamPlaylistItem : IStreamPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateSilencePlaylistItem)
Next (CreateStrings)


Previous (CreateStreamPlaylistItem)
Next (CreateTemporaryPlaylist)

Name
CreateStrings

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateStrings : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStreamPlaylistItem)
Next (CreateTemporaryPlaylist)


Previous (CreateStrings)
Next (CreateXMLDocument)

Name
CreateTemporaryPlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateTemporaryPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStrings)
Next (CreateXMLDocument)


Previous (CreateTemporaryPlaylist)
Next (CreateXMLDocumentFromString)

Name
CreateXMLDocument

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateXMLDocument : ISXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateTemporaryPlaylist)
Next (CreateXMLDocumentFromString)


Previous (CreateXMLDocument)
Next (GetClasses)

Name
CreateXMLDocumentFromString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateXMLDocumentFromString ( iString : string ) : ISXMLDocument

Parameters
Parameter | Description
iString : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateXMLDocument)
Next (GetClasses)


Previous (CreateXMLDocumentFromString)
Next (GetDefaultItemType)

Name
GetClasses

Parent
IFactory

Visibility
PUBLIC

Source code
function GetClasses ( iGUID : TGUID ) : IInterfaceList

Parameters
Parameter | Description
iGUID : TGUID | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateXMLDocumentFromString)
Next (GetDefaultItemType)


Previous (GetClasses)
Next (GetFileImportOptions)

Name
GetDefaultItemType

Parent
IFactory

Visibility
PUBLIC

Source code
function GetDefaultItemType : TPlaylistItemType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClasses)
Next (GetFileImportOptions)


Previous (GetDefaultItemType)
Next (GetMMDFolder)

Name
GetFileImportOptions

Parent
IFactory

Visibility
PUBLIC

Source code
function GetFileImportOptions : TFileImportOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultItemType)
Next (GetMMDFolder)


Previous (GetFileImportOptions)
Next (RegisterClass)

Name
GetMMDFolder

Parent
IFactory

Visibility
PUBLIC

Source code
function GetMMDFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileImportOptions)
Next (RegisterClass)


Previous (GetMMDFolder)
Next (SetDefaultItemType)

Name
RegisterClass

Parent
IFactory

Visibility
PUBLIC

Source code
procedure RegisterClass ( iGUID : TGUID ; iClass : IFactoryClass ; iPriority : integer = 0 )

Parameters
Parameter | Description
iGUID : TGUID | &nbsp;
iClass : IFactoryClass | &nbsp;
iPriority : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMMDFolder)
Next (SetDefaultItemType)


Previous (RegisterClass)
Next (SetFileImportOptions)

Name
SetDefaultItemType

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetDefaultItemType ( iValue : TPlaylistItemType )

Parameters
Parameter | Description
iValue : TPlaylistItemType | &nbsp;

mAirListScript
Class Tree
Index
Previous (RegisterClass)
Next (SetFileImportOptions)


Previous (SetDefaultItemType)
Next (SetMMDFolder)

Name
SetFileImportOptions

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetFileImportOptions ( iValue : TFileImportOptions )

Parameters
Parameter | Description
iValue : TFileImportOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDefaultItemType)
Next (SetMMDFolder)


Previous (SetFileImportOptions)
Next (TryCreateObject)

Name
SetMMDFolder

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetMMDFolder ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFileImportOptions)
Next (TryCreateObject)


Previous (SetMMDFolder)
Next

Name
TryCreateObject

Parent
IFactory

Visibility
PUBLIC

Source code
function TryCreateObject ( iGUID : TGUID ; iIndex : integer = 0 ) : IInterface

Parameters
Parameter | Description
iGUID : TGUID | &nbsp;
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMMDFolder)
Next


Previous (IFactory)
Next (IFileData)

Name
IFactoryClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateInstance (+)
CreateInstanceWithParameters (+)
GetClassCategory (+)
GetClassColor (+)
GetClassDescription (+)
GetClassID (+)
GetClassPriority (+)
GetClassTypeDescription (+)
InitializeClass (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactory)
Next (IFileData)


Previous
Next (CreateInstanceWithParameters)

Name
CreateInstance

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstance ( iInstance : IInstanceData ) : IUnknown

Parameters
Parameter | Description
iInstance : IInstanceData | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (CreateInstanceWithParameters)


Previous (CreateInstance)
Next (GetClassCategory)

Name
CreateInstanceWithParameters

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstanceWithParameters ( iInstance : IInstanceData ; iParameters : array of Variant ) : IUnknown

Parameters
Parameter | Description
iInstance : IInstanceData | &nbsp;
iParameters : VARIANT | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateInstance)
Next (GetClassCategory)


Previous (CreateInstanceWithParameters)
Next (GetClassColor)

Name
GetClassCategory

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassCategory : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateInstanceWithParameters)
Next (GetClassColor)


Previous (GetClassCategory)
Next (GetClassDescription)

Name
GetClassColor

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassCategory)
Next (GetClassDescription)


Previous (GetClassColor)
Next (GetClassID)

Name
GetClassDescription

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassColor)
Next (GetClassID)


Previous (GetClassDescription)
Next (GetClassPriority)

Name
GetClassID

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassDescription)
Next (GetClassPriority)


Previous (GetClassID)
Next (GetClassTypeDescription)

Name
GetClassPriority

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassPriority : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassID)
Next (GetClassTypeDescription)


Previous (GetClassPriority)
Next (InitializeClass)

Name
GetClassTypeDescription

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassTypeDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassPriority)
Next (InitializeClass)


Previous (GetClassTypeDescription)
Next

Name
InitializeClass

Parent
IFactoryClass

Visibility
PUBLIC

Source code
procedure InitializeClass ( iInstance : IInstanceData )

Parameters
Parameter | Description
iInstance : IInstanceData | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetClassTypeDescription)
Next


Previous (IFactoryClass)
Next (IFileDataRecorder)

Name
IFileData

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDownloadPosition (+)
GetSize (+)
IsIncomplete (+)
READ (+)
WaitForPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactoryClass)
Next (IFileDataRecorder)


Previous
Next (GetSize)

Name
GetDownloadPosition

Parent
IFileData

Visibility
PUBLIC

Source code
function GetDownloadPosition : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetSize)


Previous (GetDownloadPosition)
Next (IsIncomplete)

Name
GetSize

Parent
IFileData

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDownloadPosition)
Next (IsIncomplete)


Previous (GetSize)
Next (READ)

Name
IsIncomplete

Parent
IFileData

Visibility
PUBLIC

Source code
function IsIncomplete : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (READ)


Previous (IsIncomplete)
Next (WaitForPosition)

Name
READ

Parent
IFileData

Visibility
PUBLIC

Source code
function Read ( iOffset : int64 ; iBuffer : pointer ; iCount : integer ) : integer

Parameters
Parameter | Description
iOffset : INT64 | &nbsp;
iBuffer : pointer | &nbsp;
iCount : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsIncomplete)
Next (WaitForPosition)


Previous (READ)
Next

Name
WaitForPosition

Parent
IFileData

Visibility
PUBLIC

Source code
procedure WaitForPosition ( iPosition : int64 )

Parameters
Parameter | Description
iPosition : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous (READ)
Next


Previous (IFileData)
Next (IFileEncoder)

Name
IFileDataRecorder

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetBytesWritten (+)
GetChannelCount (+)
GetDuration (+)
GetSampleFormat (+)
GetSamplerate (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileData)
Next (IFileEncoder)


Previous
Next (GetChannelCount)

Name
GetBytesWritten

Parent
IFileDataRecorder

Visibility
PUBLIC

Source code
function GetBytesWritten : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetChannelCount)


Previous (GetBytesWritten)
Next (GetDuration)

Name
GetChannelCount

Parent
IFileDataRecorder

Visibility
PUBLIC

Source code
function GetChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBytesWritten)
Next (GetDuration)


Previous (GetChannelCount)
Next (GetSampleFormat)

Name
GetDuration

Parent
IFileDataRecorder

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChannelCount)
Next (GetSampleFormat)


Previous (GetDuration)
Next (GetSamplerate)

Name
GetSampleFormat

Parent
IFileDataRecorder

Visibility
PUBLIC

Source code
function GetSampleFormat : TSampleFormat

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetSamplerate)


Previous (GetSampleFormat)
Next

Name
GetSamplerate

Parent
IFileDataRecorder

Visibility
PUBLIC

Source code
function GetSamplerate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSampleFormat)
Next


Previous (IFileDataRecorder)
Next (IFileEncoderSettings)

Name
IFileEncoder

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
EncodeFileData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileDataRecorder)
Next (IFileEncoderSettings)


Previous
Next

Name
EncodeFileData

Parent
IFileEncoder

Visibility
PUBLIC

Source code
procedure EncodeFileData ( iSettings : IFileEncoderSettings ; iData : IFileData ; var oFilename : string ; iProgressIndicator : IProgressIndicator = nil )

Parameters
Parameter | Description
iSettings : IFileEncoderSettings | &nbsp;
iData : IFileData | &nbsp;
oFilename : STRING | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileEncoder)
Next (IFileManager)

Name
IFileEncoderSettings

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
GetExtension (+)
GetSummary (+)
PreferLinear (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileEncoder)
Next (IFileManager)


Previous
Next (GetSummary)

Name
GetExtension

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
function GetExtension : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetSummary)


Previous (GetExtension)
Next (PreferLinear)

Name
GetSummary

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExtension)
Next (PreferLinear)


Previous (GetSummary)
Next

Name
PreferLinear

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
procedure PreferLinear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSummary)
Next


Previous (IFileEncoderSettings)
Next (IFilePlaylistItem)

Name
IFileManager

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CreateStreamDataForFile (+)
GetEnabled (+)
GetMemoryFileLimit (+)
GetOptions (+)
SetEnabled (+)
SetMemoryFileLimit (+)
SetOptions (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileEncoderSettings)
Next (IFilePlaylistItem)


Previous
Next (GetEnabled)

Name
CreateStreamDataForFile

Parent
IFileManager

Visibility
PUBLIC

Source code
function CreateStreamDataForFile ( iFilename : string ) : IFileData

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetEnabled)


Previous (CreateStreamDataForFile)
Next (GetMemoryFileLimit)

Name
GetEnabled

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStreamDataForFile)
Next (GetMemoryFileLimit)


Previous (GetEnabled)
Next (GetOptions)

Name
GetMemoryFileLimit

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetMemoryFileLimit : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetOptions)


Previous (GetMemoryFileLimit)
Next (SetEnabled)

Name
GetOptions

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetOptions : TFileManagementOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMemoryFileLimit)
Next (SetEnabled)


Previous (GetOptions)
Next (SetMemoryFileLimit)

Name
SetEnabled

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (SetMemoryFileLimit)


Previous (SetEnabled)
Next (SetOptions)

Name
SetMemoryFileLimit

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetMemoryFileLimit ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEnabled)
Next (SetOptions)


Previous (SetMemoryFileLimit)
Next

Name
SetOptions

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TFileManagementOptions )

Parameters
Parameter | Description
iValue : TFileManagementOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMemoryFileLimit)
Next


Previous (IFileManager)
Next (IFilePlaylistItemClass)

Name
IFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
CreateFileData (+)
GetBackupFilename (+)
GetFilename (+)
GetFileTagData (+)
GetFileTypeHandler (+)
GetRAMFileData (+)
LoadMMD (+)
SaveMMD (+)
SetBackupFilename (+)
SetFilename (+)
SetRAMFileData (+)
UpdateTilde (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileManager)
Next (IFilePlaylistItemClass)


Previous
Next (GetBackupFilename)

Name
CreateFileData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function CreateFileData : IFileData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetBackupFilename)


Previous (CreateFileData)
Next (GetFilename)

Name
GetBackupFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetBackupFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFileData)
Next (GetFilename)


Previous (GetBackupFilename)
Next (GetFileTagData)

Name
GetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBackupFilename)
Next (GetFileTagData)


Previous (GetFilename)
Next (GetFileTypeHandler)

Name
GetFileTagData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTagData ( iTag : string ) : string

Parameters
Parameter | Description
iTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (GetFileTypeHandler)


Previous (GetFileTagData)
Next (GetRAMFileData)

Name
GetFileTypeHandler

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTypeHandler : IFileTypeHandler

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTagData)
Next (GetRAMFileData)


Previous (GetFileTypeHandler)
Next (LoadMMD)

Name
GetRAMFileData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetRAMFileData : IFileData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTypeHandler)
Next (LoadMMD)


Previous (GetRAMFileData)
Next (SaveMMD)

Name
LoadMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function LoadMMD : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRAMFileData)
Next (SaveMMD)


Previous (LoadMMD)
Next (SetBackupFilename)

Name
SaveMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveMMD

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadMMD)
Next (SetBackupFilename)


Previous (SaveMMD)
Next (SetFilename)

Name
SetBackupFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetBackupFilename ( iValue : String )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveMMD)
Next (SetFilename)


Previous (SetBackupFilename)
Next (SetRAMFileData)

Name
SetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBackupFilename)
Next (SetRAMFileData)


Previous (SetFilename)
Next (UpdateTilde)

Name
SetRAMFileData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetRAMFileData ( iValue : IFileData )

Parameters
Parameter | Description
iValue : IFileData | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFilename)
Next (UpdateTilde)


Previous (SetRAMFileData)
Next

Name
UpdateTilde

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function UpdateTilde : TCuePositionTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetRAMFileData)
Next


Previous (IFilePlaylistItem)
Next (IFileStorage)

Name
IFilePlaylistItemClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItem)
Next (IFileStorage)


Previous
Next

Name
SupportsExtension

Parent
IFilePlaylistItemClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter | Description
iExtension : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFilePlaylistItemClass)
Next (IFileStorageClass)

Name
IFileStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetWarnings (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItemClass)
Next (IFileStorageClass)


Previous
Next

Name
GetWarnings

Parent
IFileStorage

Visibility
PUBLIC

Source code
function GetWarnings : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileStorage)
Next (IFileTypeHandler)

Name
IFileStorageClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
GetDefaultExtension (+)
GetFileFilter (+)
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileStorage)
Next (IFileTypeHandler)


Previous
Next (GetFileFilter)

Name
GetDefaultExtension

Parent
IFileStorageClass

Visibility
PUBLIC

Source code
function GetDefaultExtension : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetFileFilter)


Previous (GetDefaultExtension)
Next (SupportsExtension)

Name
GetFileFilter

Parent
IFileStorageClass

Visibility
PUBLIC

Source code
function GetFileFilter : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultExtension)
Next (SupportsExtension)


Previous (GetFileFilter)
Next

Name
SupportsExtension

Parent
IFileStorageClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter | Description
iExtension : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFileFilter)
Next


Previous (IFileStorageClass)
Next (IFileTypeHandlerClass)

Name
IFileTypeHandler

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCapabilities (+)
GetTagData (+)
ReadDuration (+)
ReadNativeTags (+)
ReadNativeTagsEx (+)
ReadTags (+)
SetItem (+)
WriteTags (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileStorageClass)
Next (IFileTypeHandlerClass)


Previous
Next (GetTagData)

Name
GetCapabilities

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetCapabilities : TFileTypeHandlerCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTagData)


Previous (GetCapabilities)
Next (ReadDuration)

Name
GetTagData

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetTagData ( iTag : string ) : string

Parameters
Parameter | Description
iTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (ReadDuration)


Previous (GetTagData)
Next (ReadNativeTags)

Name
ReadDuration

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadDuration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTagData)
Next (ReadNativeTags)


Previous (ReadDuration)
Next (ReadNativeTagsEx)

Name
ReadNativeTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadNativeTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadDuration)
Next (ReadNativeTagsEx)


Previous (ReadNativeTags)
Next (ReadTags)

Name
ReadNativeTagsEx

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadNativeTagsEx ( out oCueMarkersFound : boolean ; out oAmplificationFound : boolean )

Parameters
Parameter | Description
oCueMarkersFound : BOOLEAN | &nbsp;
oAmplificationFound : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadNativeTags)
Next (ReadTags)


Previous (ReadNativeTagsEx)
Next (SetItem)

Name
ReadTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function ReadTags : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadNativeTagsEx)
Next (SetItem)


Previous (ReadTags)
Next (WriteTags)

Name
SetItem

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure SetItem ( iItem : IFilePlaylistItem )

Parameters
Parameter | Description
iItem : IFilePlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReadTags)
Next (WriteTags)


Previous (SetItem)
Next

Name
WriteTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure WriteTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetItem)
Next


Previous (IFileTypeHandler)
Next (IHiddenModule)

Name
IFileTypeHandlerClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
SupportsItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandler)
Next (IHiddenModule)


Previous
Next

Name
SupportsItem

Parent
IFileTypeHandlerClass

Visibility
PUBLIC

Source code
function SupportsItem ( iItem : IFilePlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IFilePlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileTypeHandlerClass)
Next (IIncompleteStream)

Name
IHiddenModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandlerClass)
Next (IIncompleteStream)


Previous (IHiddenModule)
Next (IInfiniteSilencePlaylistItem)

Name
IIncompleteStream

Parent
mAirListInterfaces

Class Hierarchy
IStream

Visibility
PUBLIC

Members
Methods
Method Description
WaitForPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IHiddenModule)
Next (IInfiniteSilencePlaylistItem)


Previous
Next

Name
WaitForPosition

Parent
IIncompleteStream

Visibility
PUBLIC

Source code
procedure WaitForPosition ( iPosition : int64 )

Parameters
Parameter | Description
iPosition : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IIncompleteStream)
Next (IInlineData)

Name
IInfiniteSilencePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIncompleteStream)
Next (IInlineData)


Previous (IInfiniteSilencePlaylistItem)
Next (IInlineFilePlaylistItem)

Name
IInlineData

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
AsString (+)
Clear (+)
GetBase64String (+)
GetHash (+)
GetSize (+)
HasData (+)
LoadFromFile (+)
LoadFromStream (+)
LoadFromStreamPersist (+)
SetBase64String (+)
WRITE (+)
WriteToStream (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInfiniteSilencePlaylistItem)
Next (IInlineFilePlaylistItem)


Previous
Next (AsString)

Name
Assign

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IInlineData )

Parameters
Parameter | Description
iValue : IInlineData | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AsString)


Previous (Assign)
Next (Clear)

Name
AsString

Parent
IInlineData

Visibility
PUBLIC

Source code
function AsString : AnsiString

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (Clear)


Previous (AsString)
Next (GetBase64String)

Name
Clear

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsString)
Next (GetBase64String)


Previous (Clear)
Next (GetHash)

Name
GetBase64String

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetBase64String : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetHash)


Previous (GetBase64String)
Next (GetSize)

Name
GetHash

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetHash : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBase64String)
Next (GetSize)


Previous (GetHash)
Next (HasData)

Name
GetSize

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHash)
Next (HasData)


Previous (GetSize)
Next (LoadFromFile)

Name
HasData

Parent
IInlineData

Visibility
PUBLIC

Source code
function HasData : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (LoadFromFile)


Previous (HasData)
Next (LoadFromStream)

Name
LoadFromFile

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (HasData)
Next (LoadFromStream)


Previous (LoadFromFile)
Next (LoadFromStreamPersist)

Name
LoadFromStream

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromStream ( iStream : TStream )

Parameters
Parameter | Description
iStream : TStream | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (LoadFromStreamPersist)


Previous (LoadFromStream)
Next (SetBase64String)

Name
LoadFromStreamPersist

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromStreamPersist ( iPersist : IStreamPersist )

Parameters
Parameter | Description
iPersist : IStreamPersist | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromStream)
Next (SetBase64String)


Previous (LoadFromStreamPersist)
Next (WRITE)

Name
SetBase64String

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure SetBase64String ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromStreamPersist)
Next (WRITE)


Previous (SetBase64String)
Next (WriteToStream)

Name
WRITE

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure Write ( const iFrom : pointer ; iCount : integer )

Parameters
Parameter | Description
iFrom : pointer | &nbsp;
iCount : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBase64String)
Next (WriteToStream)


Previous (WRITE)
Next

Name
WriteToStream

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure WriteToStream ( iStream : TStream )

Parameters
Parameter | Description
iStream : TStream | &nbsp;

mAirListScript
Class Tree
Index
Previous (WRITE)
Next


Previous (IInlineData)
Next (IInstanceData)

Name
IInlineFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetOriginalFilename (+)
SaveToMIF (+)
SetOriginalFilename (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlineData)
Next (IInstanceData)


Previous
Next (SaveToMIF)

Name
GetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
function GetOriginalFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SaveToMIF)


Previous (GetOriginalFilename)
Next (SetOriginalFilename)

Name
SaveToMIF

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveToMIF ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOriginalFilename)
Next (SetOriginalFilename)


Previous (SaveToMIF)
Next

Name
SetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetOriginalFilename ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveToMIF)
Next


Previous (IInlineFilePlaylistItem)
Next (ILevelInfo)

Name
IInstanceData

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddModule (+)
DecExtPFLCount (+)
DecPFLCount (+)
ExecuteAsync (+)
FakeNow (+)
Finalize (+)
GetClients (+)
GetCommandList (+)
GetConfig (+)
GetDatabases (+)
GetDefaultFadeDuration (+)
GetDescription (+)
GetDeviceConfig (+)
GetDisabledModules (+)
GetEndMonDuration (+)
GetEngine (+)
GetEngineInfo (+)
GetFactory (+)
GetFeatures (+)
GetFileManager (+)
GetLicenseData (+)
GetLogger (+)
GetMessageDispatcher (+)
GetMMDFolder (+)
GetModules (+)
GetName (+)
GetOnAir (+)
GetOptions (+)
GetPlaybackDevices (+)
GetProductName (+)
GetProductVersion (+)
GetRecordDevices (+)
GetRecycleBin (+)
GetRegions (+)
GetRemoteController (+)
GetRepositoryItem (+)
GetRootFolder (+)
GetRunMode (+)
GetRuntimeData (+)
GetSerialPortManager (+)
GetStandardAttributes (+)
GetSupportedFileExtensions (+)
GetTimeCorrection (+)
IncExtPFLCount (+)
IncPFLCount (+)
Initialize (+)
SetDefaultFadeDuration (+)
SetDescription (+)
SetEndMonDuration (+)
SetName (+)
SetOnAir (+)
SetOptions (+)
SetRuntimeData (+)
SetTimeCorrection (+)
Shutdown (+)
Startup (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlineFilePlaylistItem)
Next (ILevelInfo)


Previous
Next (DecExtPFLCount)

Name
AddModule

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure AddModule ( iModule : IModule )

Parameters
Parameter | Description
iModule : IModule | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (DecExtPFLCount)


Previous (AddModule)
Next (DecPFLCount)

Name
DecExtPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function DecExtPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddModule)
Next (DecPFLCount)


Previous (DecExtPFLCount)
Next (ExecuteAsync)

Name
DecPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function DecPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DecExtPFLCount)
Next (ExecuteAsync)


Previous (DecPFLCount)
Next (FakeNow)

Name
ExecuteAsync

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure ExecuteAsync ( iCode : IRunnable )

Parameters
Parameter | Description
iCode : IRunnable | &nbsp;

mAirListScript
Class Tree
Index
Previous (DecPFLCount)
Next (FakeNow)


Previous (ExecuteAsync)
Next (Finalize)

Name
FakeNow

Parent
IInstanceData

Visibility
PUBLIC

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteAsync)
Next (Finalize)


Previous (FakeNow)
Next (GetClients)

Name
Finalize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (GetClients)


Previous (Finalize)
Next (GetCommandList)

Name
GetClients

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetClients : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCommandList)


Previous (GetClients)
Next (GetConfig)

Name
GetCommandList

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClients)
Next (GetConfig)


Previous (GetCommandList)
Next (GetDatabases)

Name
GetConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetConfig : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandList)
Next (GetDatabases)


Previous (GetConfig)
Next (GetDefaultFadeDuration)

Name
GetDatabases

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDatabases : IDatabaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConfig)
Next (GetDefaultFadeDuration)


Previous (GetDatabases)
Next (GetDescription)

Name
GetDefaultFadeDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDefaultFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabases)
Next (GetDescription)


Previous (GetDefaultFadeDuration)
Next (GetDeviceConfig)

Name
GetDescription

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultFadeDuration)
Next (GetDeviceConfig)


Previous (GetDescription)
Next (GetDisabledModules)

Name
GetDeviceConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDeviceConfig : IAudioDeviceConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetDisabledModules)


Previous (GetDeviceConfig)
Next (GetEndMonDuration)

Name
GetDisabledModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDisabledModules : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceConfig)
Next (GetEndMonDuration)


Previous (GetDisabledModules)
Next (GetEngine)

Name
GetEndMonDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEndMonDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisabledModules)
Next (GetEngine)


Previous (GetEndMonDuration)
Next (GetEngineInfo)

Name
GetEngine

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndMonDuration)
Next (GetEngineInfo)


Previous (GetEngine)
Next (GetFactory)

Name
GetEngineInfo

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngineInfo : IEngineInfo

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngine)
Next (GetFactory)


Previous (GetEngineInfo)
Next (GetFeatures)

Name
GetFactory

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFactory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngineInfo)
Next (GetFeatures)


Previous (GetFactory)
Next (GetFileManager)

Name
GetFeatures

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFeatures : TmAirListFeatures

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFactory)
Next (GetFileManager)


Previous (GetFeatures)
Next (GetLicenseData)

Name
GetFileManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFileManager : IFileManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFeatures)
Next (GetLicenseData)


Previous (GetFileManager)
Next (GetLogger)

Name
GetLicenseData

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLicenseData : ILicenseData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileManager)
Next (GetLogger)


Previous (GetLicenseData)
Next (GetMessageDispatcher)

Name
GetLogger

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLogger : ILogger

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLicenseData)
Next (GetMessageDispatcher)


Previous (GetLogger)
Next (GetMMDFolder)

Name
GetMessageDispatcher

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMessageDispatcher : IMessageDispatcher

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogger)
Next (GetMMDFolder)


Previous (GetMessageDispatcher)
Next (GetModules)

Name
GetMMDFolder

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMMDFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageDispatcher)
Next (GetModules)


Previous (GetMMDFolder)
Next (GetName)

Name
GetModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetModules : IModuleList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMMDFolder)
Next (GetName)


Previous (GetModules)
Next (GetOnAir)

Name
GetName

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetModules)
Next (GetOnAir)


Previous (GetName)
Next (GetOptions)

Name
GetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOnAir : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetOptions)


Previous (GetOnAir)
Next (GetPlaybackDevices)

Name
GetOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOptions : TGlobalOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAir)
Next (GetPlaybackDevices)


Previous (GetOptions)
Next (GetProductName)

Name
GetPlaybackDevices

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetPlaybackDevices : IPlaybackDeviceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetProductName)


Previous (GetPlaybackDevices)
Next (GetProductVersion)

Name
GetProductName

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackDevices)
Next (GetProductVersion)


Previous (GetProductName)
Next (GetRecordDevices)

Name
GetProductVersion

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure GetProductVersion ( out oMajor , oMinor , oRelease , oBuild : integer ; var oBetaname : string )

Parameters
Parameter | Description
oMajor : INTEGER | &nbsp;
oMinor : INTEGER | &nbsp;
oRelease : INTEGER | &nbsp;
oBuild : INTEGER | &nbsp;
oBetaname : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetProductName)
Next (GetRecordDevices)


Previous (GetProductVersion)
Next (GetRecycleBin)

Name
GetRecordDevices

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRecordDevices : IRecordDeviceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProductVersion)
Next (GetRecycleBin)


Previous (GetRecordDevices)
Next (GetRegions)

Name
GetRecycleBin

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRecycleBin : IRecycleBinPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRecordDevices)
Next (GetRegions)


Previous (GetRecycleBin)
Next (GetRemoteController)

Name
GetRegions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRegions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRecycleBin)
Next (GetRemoteController)


Previous (GetRegions)
Next (GetRepositoryItem)

Name
GetRemoteController

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRemoteController : IRemoteController

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetRepositoryItem)


Previous (GetRemoteController)
Next (GetRootFolder)

Name
GetRepositoryItem

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRepositoryItem ( iItem : TRepositoryItem ) : IPlaylistItem

Parameters
Parameter | Description
iItem : TRepositoryItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRemoteController)
Next (GetRootFolder)


Previous (GetRepositoryItem)
Next (GetRunMode)

Name
GetRootFolder

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRootFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRepositoryItem)
Next (GetRunMode)


Previous (GetRootFolder)
Next (GetRuntimeData)

Name
GetRunMode

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRunMode : TRunMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRootFolder)
Next (GetRuntimeData)


Previous (GetRunMode)
Next (GetSerialPortManager)

Name
GetRuntimeData

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRuntimeData ( iKey : string ) : string

Parameters
Parameter | Description
iKey : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRunMode)
Next (GetSerialPortManager)


Previous (GetRuntimeData)
Next (GetStandardAttributes)

Name
GetSerialPortManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSerialPortManager : ISerialPortManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRuntimeData)
Next (GetStandardAttributes)


Previous (GetSerialPortManager)
Next (GetSupportedFileExtensions)

Name
GetStandardAttributes

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetStandardAttributes : IStandardAttributeList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerialPortManager)
Next (GetSupportedFileExtensions)


Previous (GetStandardAttributes)
Next (GetTimeCorrection)

Name
GetSupportedFileExtensions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSupportedFileExtensions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStandardAttributes)
Next (GetTimeCorrection)


Previous (GetSupportedFileExtensions)
Next (IncExtPFLCount)

Name
GetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetTimeCorrection : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSupportedFileExtensions)
Next (IncExtPFLCount)


Previous (GetTimeCorrection)
Next (IncPFLCount)

Name
IncExtPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function IncExtPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeCorrection)
Next (IncPFLCount)


Previous (IncExtPFLCount)
Next (Initialize)

Name
IncPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function IncPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IncExtPFLCount)
Next (Initialize)


Previous (IncPFLCount)
Next (SetDefaultFadeDuration)

Name
Initialize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IncPFLCount)
Next (SetDefaultFadeDuration)


Previous (Initialize)
Next (SetDescription)

Name
SetDefaultFadeDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetDefaultFadeDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (SetDescription)


Previous (SetDefaultFadeDuration)
Next (SetEndMonDuration)

Name
SetDescription

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDefaultFadeDuration)
Next (SetEndMonDuration)


Previous (SetDescription)
Next (SetName)

Name
SetEndMonDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetEndMonDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetName)


Previous (SetEndMonDuration)
Next (SetOnAir)

Name
SetName

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetName ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEndMonDuration)
Next (SetOnAir)


Previous (SetName)
Next (SetOptions)

Name
SetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetOnAir ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetName)
Next (SetOptions)


Previous (SetOnAir)
Next (SetRuntimeData)

Name
SetOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TGlobalOptions )

Parameters
Parameter | Description
iValue : TGlobalOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOnAir)
Next (SetRuntimeData)


Previous (SetOptions)
Next (SetTimeCorrection)

Name
SetRuntimeData

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetRuntimeData ( iKey : string ; iValue : string )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetTimeCorrection)


Previous (SetRuntimeData)
Next (Shutdown)

Name
SetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetTimeCorrection ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRuntimeData)
Next (Shutdown)


Previous (SetTimeCorrection)
Next (Startup)

Name
Shutdown

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Shutdown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetTimeCorrection)
Next (Startup)


Previous (Shutdown)
Next

Name
Startup

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Startup

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Shutdown)
Next


Previous (IInstanceData)
Next (ILicenseData)

Name
ILevelInfo

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
GetLevelChannelCount (+)
GetLevels (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInstanceData)
Next (ILicenseData)


Previous
Next (GetLevels)

Name
GetLevelChannelCount

Parent
ILevelInfo

Visibility
PUBLIC

Source code
function GetLevelChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLevels)


Previous (GetLevelChannelCount)
Next

Name
GetLevels

Parent
ILevelInfo

Visibility
PUBLIC

Source code
function GetLevels ( var oLevels : TLevelArray ) : boolean

Parameters
Parameter | Description
oLevels : TLevelArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetLevelChannelCount)
Next


Previous (ILevelInfo)
Next (ILogEntry)

Name
ILicenseData

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CheckHardware (+)
CheckModule (+)
GetEdition (+)
GetExpiresDateTime (+)
GetHardwareID (+)
GetHash (+)
GetName (+)
GetSerial (+)
GetTimeLimit (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILevelInfo)
Next (ILogEntry)


Previous
Next (CheckModule)

Name
CheckHardware

Parent
ILicenseData

Visibility
PUBLIC

Source code
function CheckHardware : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CheckModule)


Previous (CheckHardware)
Next (GetEdition)

Name
CheckModule

Parent
ILicenseData

Visibility
PUBLIC

Source code
function CheckModule ( iName : string ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CheckHardware)
Next (GetEdition)


Previous (CheckModule)
Next (GetExpiresDateTime)

Name
GetEdition

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetEdition : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckModule)
Next (GetExpiresDateTime)


Previous (GetEdition)
Next (GetHardwareID)

Name
GetExpiresDateTime

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetExpiresDateTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEdition)
Next (GetHardwareID)


Previous (GetExpiresDateTime)
Next (GetHash)

Name
GetHardwareID

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetHardwareID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiresDateTime)
Next (GetHash)


Previous (GetHardwareID)
Next (GetName)

Name
GetHash

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetHash ( i : integer ) : string

Parameters
Parameter | Description
i : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetHardwareID)
Next (GetName)


Previous (GetHash)
Next (GetSerial)

Name
GetName

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHash)
Next (GetSerial)


Previous (GetName)
Next (GetTimeLimit)

Name
GetSerial

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetSerial : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetTimeLimit)


Previous (GetSerial)
Next

Name
GetTimeLimit

Parent
ILicenseData

Visibility
PUBLIC

Source code
function GetTimeLimit : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILicenseData)
Next (ILogEntryList)

Name
ILogEntry

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCategory (+)
GetMessage (+)
GetSender (+)
GetSerial (+)
GetTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILicenseData)
Next (ILogEntryList)


Previous
Next (GetMessage)

Name
GetCategory

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetCategory : TLogCategory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetMessage)


Previous (GetCategory)
Next (GetSender)

Name
GetMessage

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCategory)
Next (GetSender)


Previous (GetMessage)
Next (GetSerial)

Name
GetSender

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSender : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessage)
Next (GetSerial)


Previous (GetSender)
Next (GetTime)

Name
GetSerial

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSerial : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSender)
Next (GetTime)


Previous (GetSerial)
Next

Name
GetTime

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILogEntry)
Next (ILogger)

Name
ILogEntryList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
GetEntryCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntry)
Next (ILogger)


Previous
Next (GetItem)

Name
GetEntryCount

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetEntryCount ( iCategory : TLogCategory ) : integer

Parameters
Parameter | Description
iCategory : TLogCategory | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEntryCount)
Next

Name
GetItem

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogEntry

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetEntryCount)
Next


Previous (ILogEntryList)
Next (ILogInterface)

Name
ILogger

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetEntries (+)
GetLogInterfaces (+)
LoadConfig (+)
StartLog (+)
StopLog (+)
SystemLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntryList)
Next (ILogInterface)


Previous
Next (GetLogInterfaces)

Name
GetEntries

Parent
ILogger

Visibility
PUBLIC

Source code
function GetEntries : ILogEntryList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLogInterfaces)


Previous (GetEntries)
Next (LoadConfig)

Name
GetLogInterfaces

Parent
ILogger

Visibility
PUBLIC

Source code
function GetLogInterfaces : ILogInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEntries)
Next (LoadConfig)


Previous (GetLogInterfaces)
Next (StartLog)

Name
LoadConfig

Parent
ILogger

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogInterfaces)
Next (StartLog)


Previous (LoadConfig)
Next (StopLog)

Name
StartLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (StopLog)


Previous (StartLog)
Next (SystemLog)

Name
StopLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (StartLog)
Next (SystemLog)


Previous (StopLog)
Next

Name
SystemLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure SystemLog ( iCategory : TLogCategory ; iMessage : string )

Parameters
Parameter | Description
iCategory : TLogCategory | &nbsp;
iMessage : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (StopLog)
Next


Previous (ILogger)
Next (ILogInterfaceList)

Name
ILogInterface

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
GetIncludeItemTypes (+)
GetRegions (+)
SetIncludeItemTypes (+)
SetRegions (+)
StartLog (+)
StopLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogger)
Next (ILogInterfaceList)


Previous
Next (GetRegions)

Name
GetIncludeItemTypes

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetIncludeItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetRegions)


Previous (GetIncludeItemTypes)
Next (SetIncludeItemTypes)

Name
GetRegions

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetRegions : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIncludeItemTypes)
Next (SetIncludeItemTypes)


Previous (GetRegions)
Next (SetRegions)

Name
SetIncludeItemTypes

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SetIncludeItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter | Description
iValue : TPlaylistItemTypes | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (SetRegions)


Previous (SetIncludeItemTypes)
Next (StartLog)

Name
SetRegions

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SetRegions ( iValue : TSetOfByte )

Parameters
Parameter | Description
iValue : TSetOfByte | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIncludeItemTypes)
Next (StartLog)


Previous (SetRegions)
Next (StopLog)

Name
StartLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRegions)
Next (StopLog)


Previous (StartLog)
Next

Name
StopLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (StartLog)
Next


Previous (ILogInterface)
Next (ImAirListInstance)

Name
ILogInterfaceList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
StartLog (+)
StopLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterface)
Next (ImAirListInstance)


Previous
Next (StartLog)

Name
GetItem

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogInterface

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (StartLog)


Previous (GetItem)
Next (StopLog)

Name
StartLog

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (StopLog)


Previous (StartLog)
Next

Name
StopLog

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : byte ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iRegion : BYTE | &nbsp;
iUniqueID : STRING | &nbsp;
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (StartLog)
Next


Previous (ILogInterfaceList)
Next (IMessageDispatcher)

Name
ImAirListInstance

Parent
mAirListInterfaces

Class Hierarchy
IInstanceData

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterfaceList)
Next (IMessageDispatcher)


Previous (ImAirListInstance)
Next (IMetaCueDataItem)

Name
IMessageDispatcher

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BroadcastMessage (+)
CreateQueue (+)
DeleteQueue (+)
PostMessage (+)
PostMessageDelayed (+)
SetCatchAll (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ImAirListInstance)
Next (IMetaCueDataItem)


Previous
Next (CreateQueue)

Name
BroadcastMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure BroadcastMessage ( iMessage : IBaseMessage )

Parameters
Parameter | Description
iMessage : IBaseMessage | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (CreateQueue)


Previous (BroadcastMessage)
Next (DeleteQueue)

Name
CreateQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
function CreateQueue ( iProc : TMessageProc ; iDirect : boolean ) : TMessageHandle

Parameters
Parameter | Description
iProc : TMessageProc | &nbsp;
iDirect : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (BroadcastMessage)
Next (DeleteQueue)


Previous (CreateQueue)
Next (PostMessage)

Name
DeleteQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure DeleteQueue ( iHandle : TMessageHandle )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateQueue)
Next (PostMessage)


Previous (DeleteQueue)
Next (PostMessageDelayed)

Name
PostMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessage ( iHandle : TMessageHandle ; iMessage : IBaseMessage )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;
iMessage : IBaseMessage | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteQueue)
Next (PostMessageDelayed)


Previous (PostMessage)
Next (SetCatchAll)

Name
PostMessageDelayed

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessageDelayed ( iHandle : TMessageHandle ; iDelay : integer ; iMessage : IBaseMessage )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;
iDelay : INTEGER | &nbsp;
iMessage : IBaseMessage | &nbsp;

mAirListScript
Class Tree
Index
Previous (PostMessage)
Next (SetCatchAll)


Previous (PostMessageDelayed)
Next

Name
SetCatchAll

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure SetCatchAll ( iHandle : TMessageHandle ; iValue : boolean )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (PostMessageDelayed)
Next


Previous (IMessageDispatcher)
Next (IMixdownEngine)

Name
IMetaCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMessageDispatcher)
Next (IMixdownEngine)


Previous
Next

Name
GetItem

Parent
IMetaCueDataItem

Visibility
PUBLIC

Source code
function GetItem : ICueDataItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IMetaCueDataItem)
Next (IMixdownEngine2)

Name
IMixdownEngine

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetPosition (+)
PrepareMixdown (+)
StartMixdown (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMetaCueDataItem)
Next (IMixdownEngine2)


Previous
Next (PrepareMixdown)

Name
GetPosition

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (PrepareMixdown)


Previous (GetPosition)
Next (StartMixdown)

Name
PrepareMixdown

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
procedure PrepareMixdown ( iItems : IMultiPlaylist ; iFilename , iEncoder : string )

Parameters
Parameter | Description
iItems : IMultiPlaylist | &nbsp;
iFilename : STRING | &nbsp;
iEncoder : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (StartMixdown)


Previous (PrepareMixdown)
Next

Name
StartMixdown

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
procedure StartMixdown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (PrepareMixdown)
Next


Previous (IMixdownEngine)
Next (IMixer)

Name
IMixdownEngine2

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixdownEngine)
Next (IMixer)


Previous (IMixdownEngine2)
Next (IModule)

Name
IMixer

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDestinationCount (+)
GetProductName (+)
GetVolume (+)
IsMuted (+)
Mute (+)
SetVolume (+)
Unmute (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixdownEngine2)
Next (IModule)


Previous
Next (GetProductName)

Name
GetDestinationCount

Parent
IMixer

Visibility
PUBLIC

Source code
function GetDestinationCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetProductName)


Previous (GetDestinationCount)
Next (GetVolume)

Name
GetProductName

Parent
IMixer

Visibility
PUBLIC

Source code
function GetProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDestinationCount)
Next (GetVolume)


Previous (GetProductName)
Next (IsMuted)

Name
GetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure GetVolume ( iDestination , iConnection : integer ; var oLeft , oRight : integer )

Parameters
Parameter | Description
iDestination : INTEGER | &nbsp;
iConnection : INTEGER | &nbsp;
oLeft : INTEGER | &nbsp;
oRight : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetProductName)
Next (IsMuted)


Previous (GetVolume)
Next (Mute)

Name
IsMuted

Parent
IMixer

Visibility
PUBLIC

Source code
function IsMuted ( iDestination , iConnection : integer ) : boolean

Parameters
Parameter | Description
iDestination : INTEGER | &nbsp;
iConnection : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Mute)


Previous (IsMuted)
Next (SetVolume)

Name
Mute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Mute ( iDestination , iConnection : integer )

Parameters
Parameter | Description
iDestination : INTEGER | &nbsp;
iConnection : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsMuted)
Next (SetVolume)


Previous (Mute)
Next (Unmute)

Name
SetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure SetVolume ( iDestination , iConnection : integer ; iLeft , iRight : integer )

Parameters
Parameter | Description
iDestination : INTEGER | &nbsp;
iConnection : INTEGER | &nbsp;
iLeft : INTEGER | &nbsp;
iRight : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Mute)
Next (Unmute)


Previous (SetVolume)
Next

Name
Unmute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Unmute ( iDestination , iConnection : integer )

Parameters
Parameter | Description
iDestination : INTEGER | &nbsp;
iConnection : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next


Previous (IMixer)
Next (IModuleList)

Name
IModule

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CheckLicense (+)
Finalize (+)
GetAuthor (+)
GetCommandList (+)
GetDescription (+)
GetID (+)
GetVersion (+)
Initialize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixer)
Next (IModuleList)


Previous
Next (Finalize)

Name
CheckLicense

Parent
IModule

Visibility
PUBLIC

Source code
function CheckLicense ( iLicenseManager : ILicenseData ) : boolean

Parameters
Parameter | Description
iLicenseManager : ILicenseData | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Finalize)


Previous (CheckLicense)
Next (GetAuthor)

Name
Finalize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckLicense)
Next (GetAuthor)


Previous (Finalize)
Next (GetCommandList)

Name
GetAuthor

Parent
IModule

Visibility
PUBLIC

Source code
function GetAuthor : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCommandList)


Previous (GetAuthor)
Next (GetDescription)

Name
GetCommandList

Parent
IModule

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAuthor)
Next (GetDescription)


Previous (GetCommandList)
Next (GetID)

Name
GetDescription

Parent
IModule

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandList)
Next (GetID)


Previous (GetDescription)
Next (GetVersion)

Name
GetID

Parent
IModule

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetVersion)


Previous (GetID)
Next (Initialize)

Name
GetVersion

Parent
IModule

Visibility
PUBLIC

Source code
function GetVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (Initialize)


Previous (GetVersion)
Next

Name
Initialize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVersion)
Next


Previous (IModule)
Next (IMultiAudioSource)

Name
IModuleList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModule)
Next (IMultiAudioSource)


Previous
Next (GetCount)

Name
ADD

Parent
IModuleList

Visibility
PUBLIC

Source code
procedure Add ( iModule : IModule )

Parameters
Parameter | Description
iModule : IModule | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetCount)


Previous (ADD)
Next (GetItem)

Name
GetCount

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ADD)
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IModule

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous (IModuleList)
Next (IMultiInstanceModule)

Name
IMultiAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IAudioSource

Visibility
PUBLIC

Members
Methods
Method Description
FindNextOffset (+)
FindPreviousOffset (+)
GetItemOffset (+)
GetMinCueIn (+)
SyncPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModuleList)
Next (IMultiInstanceModule)


Previous
Next (FindPreviousOffset)

Name
FindNextOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function FindNextOffset ( iFrom , iBefore : TTimeValue ) : TTimeValue

Parameters
Parameter | Description
iFrom : TTimeValue | &nbsp;
iBefore : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (FindPreviousOffset)


Previous (FindNextOffset)
Next (GetItemOffset)

Name
FindPreviousOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function FindPreviousOffset ( iFrom , iBefore : TTimeValue ) : TTimeValue

Parameters
Parameter | Description
iFrom : TTimeValue | &nbsp;
iBefore : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindNextOffset)
Next (GetItemOffset)


Previous (FindPreviousOffset)
Next (GetMinCueIn)

Name
GetItemOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function GetItemOffset ( iIndex : integer ) : TTimeValue

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindPreviousOffset)
Next (GetMinCueIn)


Previous (GetItemOffset)
Next (SyncPlaylist)

Name
GetMinCueIn

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function GetMinCueIn : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemOffset)
Next (SyncPlaylist)


Previous (GetMinCueIn)
Next

Name
SyncPlaylist

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
procedure SyncPlaylist ( iPlaylist : IMultiPlaylist )

Parameters
Parameter | Description
iPlaylist : IMultiPlaylist | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMinCueIn)
Next


Previous (IMultiAudioSource)
Next (IMultiPlaylist)

Name
IMultiInstanceModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiAudioSource)
Next (IMultiPlaylist)


Previous (IMultiInstanceModule)
Next (IMultiPlaylistItemMetadata)

Name
IMultiPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
AddItem (+)
AddPlaylist (+)
CreateCueSheet (+)
GetDuration (+)
GetItem (+)
GetMetadata (+)
GetRegions (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiInstanceModule)
Next (IMultiPlaylistItemMetadata)


Previous
Next (AddPlaylist)

Name
AddItem

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
procedure AddItem ( iItem : IPlaylistItem ; iOffset : TTimeValue ; iExpand : boolean ; iRegion : byte = 0 ; iLevel : integer = 0 )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iOffset : TTimeValue | &nbsp;
iExpand : BOOLEAN | &nbsp;
iRegion : BYTE | &nbsp;
iLevel : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AddPlaylist)


Previous (AddItem)
Next (CreateCueSheet)

Name
AddPlaylist

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
procedure AddPlaylist ( iList : IPlaylist ; iOffset : TTimeValue ; iExpand : boolean ; iRegion : byte = 0 ; iLevel : integer = 0 ; iExtraOffset : TTimeValue = 0 )

Parameters
Parameter | Description
iList : IPlaylist | &nbsp;
iOffset : TTimeValue | &nbsp;
iExpand : BOOLEAN | &nbsp;
iRegion : BYTE | &nbsp;
iLevel : INTEGER | &nbsp;
iExtraOffset : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddItem)
Next (CreateCueSheet)


Previous (AddPlaylist)
Next (GetDuration)

Name
CreateCueSheet

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function CreateCueSheet ( iFilename : string ; iMinCueIn : TTimeValue ; iRegions : TSetOfByte ; iItemTypes : TPlaylistItemTypes ) : IStrings

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iMinCueIn : TTimeValue | &nbsp;
iRegions : TSetOfByte | &nbsp;
iItemTypes : TPlaylistItemTypes | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddPlaylist)
Next (GetDuration)


Previous (CreateCueSheet)
Next (GetItem)

Name
GetDuration

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateCueSheet)
Next (GetItem)


Previous (GetDuration)
Next (GetMetadata)

Name
GetItem

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetMetadata)


Previous (GetItem)
Next (GetRegions)

Name
GetMetadata

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetMetadata ( iIndex : integer ) : IMultiPlaylistItemMetadata

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetRegions)


Previous (GetMetadata)
Next

Name
GetRegions

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetRegions : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next


Previous (IMultiPlaylist)
Next (IMutex)

Name
IMultiPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetExpanded (+)
GetLevel (+)
GetOffset (+)
GetRegion (+)
SetExpanded (+)
SetLevel (+)
SetOffset (+)
SetRegion (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiPlaylist)
Next (IMutex)


Previous
Next (GetLevel)

Name
GetExpanded

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetExpanded : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLevel)


Previous (GetExpanded)
Next (GetOffset)

Name
GetLevel

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetLevel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpanded)
Next (GetOffset)


Previous (GetLevel)
Next (GetRegion)

Name
GetOffset

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetOffset : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLevel)
Next (GetRegion)


Previous (GetOffset)
Next (SetExpanded)

Name
GetRegion

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetRegion : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOffset)
Next (SetExpanded)


Previous (GetRegion)
Next (SetLevel)

Name
SetExpanded

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetExpanded ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRegion)
Next (SetLevel)


Previous (SetExpanded)
Next (SetOffset)

Name
SetLevel

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetLevel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetExpanded)
Next (SetOffset)


Previous (SetLevel)
Next (SetRegion)

Name
SetOffset

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetOffset ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetLevel)
Next (SetRegion)


Previous (SetOffset)
Next

Name
SetRegion

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetRegion ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOffset)
Next


Previous (IMultiPlaylistItemMetadata)
Next (INoAudioDevice)

Name
IMutex

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Lock (+)
LockWithTimeout (+)
TryLock (+)
Unlock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiPlaylistItemMetadata)
Next (INoAudioDevice)


Previous
Next (LockWithTimeout)

Name
Lock

Parent
IMutex

Visibility
PUBLIC

Source code
procedure Lock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (LockWithTimeout)


Previous (Lock)
Next (TryLock)

Name
LockWithTimeout

Parent
IMutex

Visibility
PUBLIC

Source code
function LockWithTimeout ( iTimeout : cardinal ) : boolean

Parameters
Parameter | Description
iTimeout : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (Lock)
Next (TryLock)


Previous (LockWithTimeout)
Next (Unlock)

Name
TryLock

Parent
IMutex

Visibility
PUBLIC

Source code
function TryLock : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LockWithTimeout)
Next (Unlock)


Previous (TryLock)
Next

Name
Unlock

Parent
IMutex

Visibility
PUBLIC

Source code
procedure Unlock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (TryLock)
Next


Previous (IMutex)
Next (INotifiedMessageReceiver)

Name
INoAudioDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMutex)
Next (INotifiedMessageReceiver)


Previous (INoAudioDevice)
Next (INotifyItemStarted)

Name
INotifiedMessageReceiver

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginProcessMessages (+)
EndProcessMessages (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INoAudioDevice)
Next (INotifyItemStarted)


Previous
Next (EndProcessMessages)

Name
BeginProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure BeginProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndProcessMessages)


Previous (BeginProcessMessages)
Next

Name
EndProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure EndProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginProcessMessages)
Next


Previous (INotifiedMessageReceiver)
Next (IObservable)

Name
INotifyItemStarted

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ItemStarted (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifiedMessageReceiver)
Next (IObservable)


Previous
Next

Name
ItemStarted

Parent
INotifyItemStarted

Visibility
PUBLIC

Source code
procedure ItemStarted ( iSource : IAudioSource )

Parameters
Parameter | Description
iSource : IAudioSource | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (INotifyItemStarted)
Next (IObservableList)

Name
IObservable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddObserver (+)
GetObjectID (+)
RemoveObserver (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifyItemStarted)
Next (IObservableList)


Previous
Next (GetObjectID)

Name
AddObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure AddObserver ( iHandle : TMessageHandle )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetObjectID)


Previous (AddObserver)
Next (RemoveObserver)

Name
GetObjectID

Parent
IObservable

Visibility
PUBLIC

Source code
function GetObjectID : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddObserver)
Next (RemoveObserver)


Previous (GetObjectID)
Next

Name
RemoveObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure RemoveObserver ( iHandle : TMessageHandle )

Parameters
Parameter | Description
iHandle : TMessageHandle | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetObjectID)
Next


Previous (IObservable)
Next (IPeakAnalyzer)

Name
IObservableList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
FindByID (+)
FindByMetadataID (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IObservable)
Next (IPeakAnalyzer)


Previous
Next (FindByMetadataID)

Name
FindByID

Parent
IObservableList

Visibility
PUBLIC

Source code
function FindByID ( iID : TObjectID ) : IObservable

Parameters
Parameter | Description
iID : TObjectID | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (FindByMetadataID)


Previous (FindByID)
Next (IndexOfID)

Name
FindByMetadataID

Parent
IObservableList

Visibility
PUBLIC

Source code
function FindByMetadataID ( iID : TObjectID ) : IObservable

Parameters
Parameter | Description
iID : TObjectID | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByID)
Next (IndexOfID)


Previous (FindByMetadataID)
Next

Name
IndexOfID

Parent
IObservableList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : TObjectID ) : integer

Parameters
Parameter | Description
iID : TObjectID | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByMetadataID)
Next


Previous (IObservableList)
Next (IPersistent)

Name
IPeakAnalyzer

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
ClearCache (+)
GetData (+)
GetState (+)
Initialize (+)
SetCacheData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IObservableList)
Next (IPersistent)


Previous
Next (GetData)

Name
ClearCache

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure ClearCache

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetData)


Previous (ClearCache)
Next (GetState)

Name
GetData

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
function GetData ( iOffset : TTimeValue ; iResolution : Extended ; var oData : TSingleArray ) : boolean

Parameters
Parameter | Description
iOffset : TTimeValue | &nbsp;
iResolution : EXTENDED | &nbsp;
oData : TSingleArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (ClearCache)
Next (GetState)


Previous (GetData)
Next (Initialize)

Name
GetState

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
function GetState : TPeakAnalyzerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (Initialize)


Previous (GetState)
Next (SetCacheData)

Name
Initialize

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure Initialize ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetCacheData)


Previous (Initialize)
Next

Name
SetCacheData

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure SetCacheData ( iLevel , iIndex : integer ; iData : TPeakData )

Parameters
Parameter | Description
iLevel : INTEGER | &nbsp;
iIndex : INTEGER | &nbsp;
iData : TPeakData | &nbsp;

mAirListScript
Class Tree
Index
Previous (Initialize)
Next


Previous (IPeakAnalyzer)
Next (IPersistentArray)

Name
IPersistent

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Load (+)
Save (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPeakAnalyzer)
Next (IPersistentArray)


Previous
Next (Save)

Name
Load

Parent
IPersistent

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter | Description
iSource : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Save)


Previous (Load)
Next

Name
Save

Parent
IPersistent

Visibility
PUBLIC

Source code
function Save : IPersistentStorage

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Load)
Next


Previous (IPersistent)
Next (IPersistentBoolean)

Name
IPersistentArray

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddBoolean (+)
AddNumber (+)
AddObject (+)
AddString (+)
Clear (+)
Delete (+)
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistent)
Next (IPersistentBoolean)


Previous
Next (AddBoolean)

Name
ADD

Parent
IPersistentArray

Visibility
PUBLIC

Source code
procedure Add ( iItem : IPersistentStorage )

Parameters
Parameter | Description
iItem : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AddBoolean)


Previous (ADD)
Next (AddNumber)

Name
AddBoolean

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddBoolean ( iValue : boolean ) : IPersistentBoolean

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (ADD)
Next (AddNumber)


Previous (AddBoolean)
Next (AddObject)

Name
AddNumber

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddNumber ( iValue : double ) : IPersistentNumber

Parameters
Parameter | Description
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddBoolean)
Next (AddObject)


Previous (AddNumber)
Next (AddString)

Name
AddObject

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddNumber)
Next (AddString)


Previous (AddObject)
Next (Clear)

Name
AddString

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddString ( iValue : string ) : IPersistentString

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddObject)
Next (Clear)


Previous (AddString)
Next (Delete)

Name
Clear

Parent
IPersistentArray

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddString)
Next (Delete)


Previous (Clear)
Next (GetCount)

Name
Delete

Parent
IPersistentArray

Visibility
PUBLIC

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetCount)


Previous (Delete)
Next (GetItem)

Name
GetCount

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Delete)
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IPersistentStorage

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous (IPersistentArray)
Next (IPersistentDateTime)

Name
IPersistentBoolean

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentArray)
Next (IPersistentDateTime)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentBoolean

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentBoolean

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentBoolean)
Next (IPersistentList)

Name
IPersistentDateTime

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentBoolean)
Next (IPersistentList)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentDateTime

Visibility
PUBLIC

Source code
function GetValue : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentDateTime

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentDateTime)
Next (IPersistentListItem)

Name
IPersistentList

Parent
mAirListInterfaces

Class Hierarchy
IObservableList

Visibility
PUBLIC

Members
Methods
Method Description
Clone (+)
Copy (+)
GetClipboardFormatName (+)
GetGUID (+)
GetItemGUID (+)
GetPersistentListItem (+)
GetPersistentListItemMetadata (+)
Load (+)
LoadFromFile (+)
LoadFromXML (+)
Save (+)
SaveAsXML (+)
SaveAsXMLRenamed (+)
SaveToFile (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentDateTime)
Next (IPersistentListItem)


Previous
Next (Copy)

Name
Clone

Parent
IPersistentList

Visibility
PUBLIC

Source code
function Clone : IPersistentList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Copy)


Previous (Clone)
Next (GetClipboardFormatName)

Name
Copy

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure Copy ( iValue : IPersistentList )

Parameters
Parameter | Description
iValue : IPersistentList | &nbsp;

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetClipboardFormatName)


Previous (Copy)
Next (GetGUID)

Name
GetClipboardFormatName

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetClipboardFormatName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Copy)
Next (GetGUID)


Previous (GetClipboardFormatName)
Next (GetItemGUID)

Name
GetGUID

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetGUID : TGUID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClipboardFormatName)
Next (GetItemGUID)


Previous (GetGUID)
Next (GetPersistentListItem)

Name
GetItemGUID

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetItemGUID : TGUID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGUID)
Next (GetPersistentListItem)


Previous (GetItemGUID)
Next (GetPersistentListItemMetadata)

Name
GetPersistentListItem

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetPersistentListItem ( iIndex : Integer ) : IPersistentListItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItemGUID)
Next (GetPersistentListItemMetadata)


Previous (GetPersistentListItem)
Next (Load)

Name
GetPersistentListItemMetadata

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetPersistentListItemMetadata ( iIndex : integer ) : IPersistentListItemMetadata

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPersistentListItem)
Next (Load)


Previous (GetPersistentListItemMetadata)
Next (LoadFromFile)

Name
Load

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter | Description
iSource : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPersistentListItemMetadata)
Next (LoadFromFile)


Previous (Load)
Next (LoadFromXML)

Name
LoadFromFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Load)
Next (LoadFromXML)


Previous (LoadFromFile)
Next (Save)

Name
LoadFromXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (Save)


Previous (LoadFromXML)
Next (SaveAsXML)

Name
Save

Parent
IPersistentList

Visibility
PUBLIC

Source code
function Save ( iFilter : cardinal = 0 ) : IPersistentStorage

Parameters
Parameter | Description
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (Save)
Next (SaveAsXMLRenamed)

Name
SaveAsXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : ISXMLDocument ; iFilter : cardinal = 0 ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (Save)
Next (SaveAsXMLRenamed)


Previous (SaveAsXML)
Next (SaveToFile)

Name
SaveAsXMLRenamed

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXMLRenamed ( iDocument : ISXMLDocument ; iTagName : string ; iFilter : cardinal = 0 ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iTagName : STRING | &nbsp;
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveToFile)


Previous (SaveAsXMLRenamed)
Next

Name
SaveToFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveAsXMLRenamed)
Next


Previous (IPersistentList)
Next (IPersistentListItemMetadata)

Name
IPersistentListItem

Parent
mAirListInterfaces

Class Hierarchy
ISerializable

Visibility
PUBLIC

Members
Methods
Method Description
GetHash (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentList)
Next (IPersistentListItemMetadata)


Previous
Next

Name
GetHash

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function GetHash : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPersistentListItem)
Next (IPersistentNull)

Name
IPersistentListItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetTag (+)
ReleaseOwner (+)
SetTag (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentListItem)
Next (IPersistentNull)


Previous
Next (ReleaseOwner)

Name
GetTag

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
function GetTag : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ReleaseOwner)


Previous (GetTag)
Next (SetTag)

Name
ReleaseOwner

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
procedure ReleaseOwner

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (SetTag)


Previous (ReleaseOwner)
Next

Name
SetTag

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReleaseOwner)
Next


Previous (IPersistentListItemMetadata)
Next (IPersistentNumber)

Name
IPersistentNull

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentListItemMetadata)
Next (IPersistentNumber)


Previous (IPersistentNull)
Next (IPersistentObject)

Name
IPersistentNumber

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetIntValue (+)
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentNull)
Next (IPersistentObject)


Previous
Next (GetValue)

Name
GetIntValue

Parent
IPersistentNumber

Visibility
PUBLIC

Source code
function GetIntValue : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetValue)


Previous (GetIntValue)
Next (SetValue)

Name
GetValue

Parent
IPersistentNumber

Visibility
PUBLIC

Source code
function GetValue : double

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIntValue)
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentNumber

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : double )

Parameters
Parameter | Description
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentNumber)
Next (IPersistentPlaylistItemMetadata)

Name
IPersistentObject

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
CreateArray (+)
CreateObject (+)
DeleteValue (+)
FindArray (+)
FindBoolean (+)
FindInteger (+)
FindNumber (+)
FindObject (+)
FindString (+)
FindValue (+)
GetCount (+)
GetNames (+)
GetValue (+)
GetValues (+)
Merge (+)
SetArray (+)
SetBoolean (+)
SetNull (+)
SetNumber (+)
SetObject (+)
SetString (+)
SetValue (+)
TryGetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentNumber)
Next (IPersistentPlaylistItemMetadata)


Previous
Next (CreateArray)

Name
ADD

Parent
IPersistentObject

Visibility
PUBLIC

Source code
procedure Add ( iName : string ; iItem : IPersistentStorage )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iItem : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (CreateArray)


Previous (ADD)
Next (CreateObject)

Name
CreateArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function CreateArray ( iName : string ) : IPersistentArray

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ADD)
Next (CreateObject)


Previous (CreateArray)
Next (DeleteValue)

Name
CreateObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function CreateObject ( iName : string ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateArray)
Next (DeleteValue)


Previous (CreateObject)
Next (FindArray)

Name
DeleteValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
procedure DeleteValue ( iName : string )

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateObject)
Next (FindArray)


Previous (DeleteValue)
Next (FindBoolean)

Name
FindArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindArray ( iName : string ; out oResult : IPersistentArray ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;
oResult : IPersistentArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (DeleteValue)
Next (FindBoolean)


Previous (FindArray)
Next (FindInteger)

Name
FindBoolean

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindBoolean ( iName : string ; iDefault : boolean = false ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;
iDefault : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindArray)
Next (FindInteger)


Previous (FindBoolean)
Next (FindNumber)

Name
FindInteger

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindInteger ( iName : string ; iDefault : int64 = 0 ) : int64

Parameters
Parameter | Description
iName : STRING | &nbsp;
iDefault : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindBoolean)
Next (FindNumber)


Previous (FindInteger)
Next (FindObject)

Name
FindNumber

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindNumber ( iName : string ; iDefault : double = 0 ) : double

Parameters
Parameter | Description
iName : STRING | &nbsp;
iDefault : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindInteger)
Next (FindObject)


Previous (FindNumber)
Next (FindString)

Name
FindObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindObject ( iName : string ; out oResult : IPersistentObject ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;
oResult : IPersistentObject | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindNumber)
Next (FindString)


Previous (FindObject)
Next (FindValue)

Name
FindString

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindString ( iName : string ; iDefault : string = '' ) : string

Parameters
Parameter | Description
iName : STRING | &nbsp;
iDefault : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindObject)
Next (FindValue)


Previous (FindString)
Next (GetCount)

Name
FindValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindValue ( iName : string ) : IPersistentStorage

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindString)
Next (GetCount)


Previous (FindValue)
Next (GetNames)

Name
GetCount

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindValue)
Next (GetNames)


Previous (GetCount)
Next (GetValue)

Name
GetNames

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetNames : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetValue)


Previous (GetNames)
Next (GetValues)

Name
GetValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetValue ( iName : string ) : IPersistentStorage

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNames)
Next (GetValues)


Previous (GetValue)
Next (Merge)

Name
GetValues

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetValues : IPersistentArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (Merge)


Previous (GetValues)
Next (SetArray)

Name
Merge

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function Merge ( iValue : IPersistentObject ) : IPersistentObject

Parameters
Parameter | Description
iValue : IPersistentObject | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValues)
Next (SetArray)


Previous (Merge)
Next (SetBoolean)

Name
SetArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetArray ( iName : string ; iValue : IPersistentArray ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : IPersistentArray | &nbsp;

mAirListScript
Class Tree
Index
Previous (Merge)
Next (SetBoolean)


Previous (SetArray)
Next (SetNull)

Name
SetBoolean

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetBoolean ( iName : string ; iValue : boolean ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetArray)
Next (SetNull)


Previous (SetBoolean)
Next (SetNumber)

Name
SetNull

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetNull ( iName : string ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBoolean)
Next (SetNumber)


Previous (SetNull)
Next (SetObject)

Name
SetNumber

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetNumber ( iName : string ; iValue : double ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNull)
Next (SetObject)


Previous (SetNumber)
Next (SetString)

Name
SetObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetObject ( iName : string ; iValue : IPersistentObject ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : IPersistentObject | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNumber)
Next (SetString)


Previous (SetObject)
Next (SetValue)

Name
SetString

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetString ( iName : string ; iValue : string ) : IPersistentObject

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetObject)
Next (SetValue)


Previous (SetString)
Next (TryGetValue)

Name
SetValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
procedure SetValue ( iName : string ; iItem : IPersistentStorage )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iItem : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetString)
Next (TryGetValue)


Previous (SetValue)
Next

Name
TryGetValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function TryGetValue ( iName : string ; out oValue : IPersistentStorage ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;
oValue : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetValue)
Next


Previous (IPersistentObject)
Next (IPersistentStorage)

Name
IPersistentPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetFlags (+)
GetState (+)
GetUniqueID (+)
SetFlags (+)
SetState (+)
SetUniqueID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentObject)
Next (IPersistentStorage)


Previous
Next (GetState)

Name
GetFlags

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetFlags : TPlaylistItemFlags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetState)


Previous (GetFlags)
Next (GetUniqueID)

Name
GetState

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetState : TPlaylistItemState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFlags)
Next (GetUniqueID)


Previous (GetState)
Next (SetFlags)

Name
GetUniqueID

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetUniqueID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetFlags)


Previous (GetUniqueID)
Next (SetState)

Name
SetFlags

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetFlags ( iValue : TPlaylistItemFlags )

Parameters
Parameter | Description
iValue : TPlaylistItemFlags | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetUniqueID)
Next (SetState)


Previous (SetFlags)
Next (SetUniqueID)

Name
SetState

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetState ( iValue : TPlaylistItemState )

Parameters
Parameter | Description
iValue : TPlaylistItemState | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFlags)
Next (SetUniqueID)


Previous (SetState)
Next

Name
SetUniqueID

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetUniqueID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetState)
Next


Previous (IPersistentPlaylistItemMetadata)
Next (IPersistentString)

Name
IPersistentStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AsArray (+)
AsBoolean (+)
AsJSon (+)
AsNull (+)
AsNumber (+)
AsObject (+)
AsString (+)
GetType (+)
Save (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentPlaylistItemMetadata)
Next (IPersistentString)


Previous
Next (AsBoolean)

Name
AsArray

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsArray : IPersistentArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AsBoolean)


Previous (AsArray)
Next (AsJSon)

Name
AsBoolean

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsBoolean : IPersistentBoolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsArray)
Next (AsJSon)


Previous (AsBoolean)
Next (AsNull)

Name
AsJSon

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsJSon ( iIndent : boolean = false ; iEscape : boolean = true ) : string

Parameters
Parameter | Description
iIndent : BOOLEAN | &nbsp;
iEscape : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (AsBoolean)
Next (AsNull)


Previous (AsJSon)
Next (AsNumber)

Name
AsNull

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsNull : IPersistentNull

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsJSon)
Next (AsNumber)


Previous (AsNull)
Next (AsObject)

Name
AsNumber

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsNumber : IPersistentNumber

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsNull)
Next (AsObject)


Previous (AsNumber)
Next (AsString)

Name
AsObject

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsNumber)
Next (AsString)


Previous (AsObject)
Next (GetType)

Name
AsString

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsString : IPersistentString

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsObject)
Next (GetType)


Previous (AsString)
Next (Save)

Name
GetType

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function GetType : TPersistentType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsString)
Next (Save)


Previous (GetType)
Next

Name
Save

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
procedure Save ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetType)
Next


Previous (IPersistentStorage)
Next (IPlaybackControl)

Name
IPersistentString

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentStorage)
Next (IPlaybackControl)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentString

Visibility
PUBLIC

Source code
function GetValue : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentString

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentString)
Next (IPlaybackDevice)

Name
IPlaybackControl

Parent
mAirListInterfaces

Class Hierarchy
IActivePlaylist

Visibility
PUBLIC

Members
Methods
Method | Description
AssistNext (+) | Just like AutomationNext, but for assist mode: Fade out all active
AutomationBreak (+) | Stops automation after the current item.
AutomationJump (+) | Jumps to a specific item.
AutomationJumpSoft (+) | Marks all items before the specified one as played, so that iItem will
GetEventList (+)
GetIndex (+) | Returns the index of this PlaybackControl object within the mAirList system.
GetMaxHistoryCount (+)
GetNextIndex (+) | Determines the index of the item which will be played next. If one of
GetOptions (+)
GetPlayer (+) | Returns a player control object.
GetPlayerCount (+) | Returns the number of players associated with this PlaybackControl object.
GetPlayerOfItem (+) | Returns the player control object in which a specific item is loaded.
GetRemainingDuration (+)
IsPlaying (+)
LoadFromXMLEx (+)
MoveToHistory (+) | Moves an item into history by unloading it from any player and setting
PlayerAutoLoad (+) | Loads a player with the next available, unused item. The player must be empty.
PlayItemDetached (+) | Start playback of an item on the given device, without caring for it thereafter.
RecycleFromHistory (+) | Recycles an item from history.
ReleaseBackgroundSources (+)
SaveAsXMLEx (+)
SetMaxHistoryCount (+)
SetOptions (+)
SetPlayerCount (+) | Sets the number of players players associated with this PlaybackControl object.
SkipTo (+)
SwapPlayers (+) | Swaps the items loaded in the specified players.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentString)
Next (IPlaybackDevice)


Previous
Next (AutomationBreak)

Name
AssistNext

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Just like AutomationNext, but for assist mode: Fade out all active
players and start the next item (which must be loaded already).

Source code
procedure AssistNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutomationBreak)


Previous (AssistNext)
Next (AutomationJump)

Name
AutomationBreak

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Stops automation after the current item.

Source code
procedure AutomationBreak

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AssistNext)
Next (AutomationJump)


Previous (AutomationBreak)
Next (AutomationJumpSoft)

Name
AutomationJump

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Jumps to a specific item.

Source code
procedure AutomationJump ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item, which must be inside the current playlist.

mAirListScript
Class Tree
Index
Previous (AutomationBreak)
Next (AutomationJumpSoft)


Previous (AutomationJump)
Next (GetEventList)

Name
AutomationJumpSoft

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Marks all items before the specified one as played, so that iItem will
be played next.

Source code
procedure AutomationJumpSoft ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (AutomationJump)
Next (GetEventList)


Previous (AutomationJumpSoft)
Next (GetIndex)

Name
GetEventList

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationJumpSoft)
Next (GetIndex)


Previous (GetEventList)
Next (GetMaxHistoryCount)

Name
GetIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the index of this PlaybackControl object within the mAirList system.

Source code
function GetIndex : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The index, where 0 is the first PlaybackControl object.

mAirListScript
Class Tree
Index
Previous (GetEventList)
Next (GetMaxHistoryCount)


Previous (GetIndex)
Next (GetNextIndex)

Name
GetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetMaxHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetNextIndex)


Previous (GetMaxHistoryCount)
Next (GetOptions)

Name
GetNextIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Determines the index of the item which will be played next. If one of
the players is marked as IsNext, the result of this function corresponds
to the index of that player's items. If all players are active, the result
will be the index of the "downmost" player plus one. If no players are
loaded, the result will correspond to GetPlayer.GetHistoryCount.

Source code
function GetNextIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxHistoryCount)
Next (GetOptions)


Previous (GetNextIndex)
Next (GetPlayer)

Name
GetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetOptions : TPlaybackControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextIndex)
Next (GetPlayer)


Previous (GetOptions)
Next (GetPlayerCount)

Name
GetPlayer

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns a player control object.

Source code
function GetPlayer ( iIndex : integer ) : IPlaylistPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER | The number of the player to retrieve.

Return
Types | Description
IPlaylistPlayerControl | The player control object.

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayerCount)


Previous (GetPlayer)
Next (GetPlayerOfItem)

Name
GetPlayerCount

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the number of players associated with this PlaybackControl object.

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The number of players.

mAirListScript
Class Tree
Index
Previous (GetPlayer)
Next (GetPlayerOfItem)


Previous (GetPlayerCount)
Next (GetRemainingDuration)

Name
GetPlayerOfItem

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the player control object in which a specific item is loaded.

Source code
function GetPlayerOfItem ( iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to look for.

Return
Types Description
INTEGER The player object in which the item is loaded,
or -1 if the item was not found.

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (GetRemainingDuration)


Previous (GetPlayerOfItem)
Next (IsPlaying)

Name
GetRemainingDuration

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetRemainingDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerOfItem)
Next (IsPlaying)


Previous (GetRemainingDuration)
Next (LoadFromXMLEx)

Name
IsPlaying

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRemainingDuration)
Next (LoadFromXMLEx)


Previous (IsPlaying)
Next (MoveToHistory)

Name
LoadFromXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure LoadFromXMLEx ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (MoveToHistory)


Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)

Name
MoveToHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Moves an item into history by unloading it from any player and setting
its history flag.

Source code
procedure MoveToHistory ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)


Previous (MoveToHistory)
Next (PlayItemDetached)

Name
PlayerAutoLoad

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Loads a player with the next available, unused item. The player must be empty.

Source code
function PlayerAutoLoad ( iPlayer : integer ; iAsync : boolean ) : boolean

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.
iAsync : BOOLEAN If set to true, the function returns immediately, and
loading takes place in the background. GetStatus will
be psLoading until loading has finished.

Return
Types Description
BOOLEAN Returns false if loading was successful, false if not.
Note that when using asynchronous loading, the player might
still fail to load (GetState=psError), even if this function
returned true.

mAirListScript
Class Tree
Index
Previous (MoveToHistory)
Next (PlayItemDetached)


Previous (PlayerAutoLoad)
Next (RecycleFromHistory)

Name
PlayItemDetached

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Start playback of an item on the given device, without caring for it thereafter.
This function can be used to play items independent from the actual players.
To create a file playlist item on the fly, use the
CreatePlaylistItemFromFile method.
The audio device can be grabbed from one of the players, for example by
CurrentPlaybackControl.GetPlayer(0).GetOutputDevice, or you can use
the BuildAudioDevice function to create one.

Source code
procedure PlayItemDetached ( iItem : IPlaylistItem ; iDevice : IPlaybackDevice )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to play.
iDevice : IPlaybackDevice | The audio device to play to.

mAirListScript
Class Tree
Index
Previous (PlayerAutoLoad)
Next (RecycleFromHistory)


Previous (PlayItemDetached)
Next (ReleaseBackgroundSources)

Name
RecycleFromHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Recycles an item from history.

Source code
procedure RecycleFromHistory ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (PlayItemDetached)
Next (ReleaseBackgroundSources)


Previous (RecycleFromHistory)
Next (SaveAsXMLEx)

Name
ReleaseBackgroundSources

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure ReleaseBackgroundSources

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RecycleFromHistory)
Next (SaveAsXMLEx)


Previous (ReleaseBackgroundSources)
Next (SetMaxHistoryCount)

Name
SaveAsXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function SaveAsXMLEx ( iDocument : ISXMLDocument ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;

mAirListScript
Class Tree
Index
Previous (ReleaseBackgroundSources)
Next (SetMaxHistoryCount)


Previous (SaveAsXMLEx)
Next (SetOptions)

Name
SetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetMaxHistoryCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveAsXMLEx)
Next (SetOptions)


Previous (SetMaxHistoryCount)
Next (SetPlayerCount)

Name
SetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaybackControlOptions )

Parameters
Parameter | Description
iValue : TPlaybackControlOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMaxHistoryCount)
Next (SetPlayerCount)


Previous (SetOptions)
Next (SkipTo)

Name
SetPlayerCount

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Sets the number of players players associated with this PlaybackControl object.

Source code
procedure SetPlayerCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | the new number of players

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SkipTo)


Previous (SetPlayerCount)
Next (SwapPlayers)

Name
SkipTo

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SkipTo ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPlayerCount)
Next (SwapPlayers)


Previous (SkipTo)
Next

Name
SwapPlayers

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Swaps the items loaded in the specified players.
Neither player may be in state PS_PLAYING.

Source code
procedure SwapPlayers ( iPlayer1 , iPlayer2 : integer )

Parameters
Parameter | Description
iPlayer1 : INTEGER | The first player.
iPlayer2 : INTEGER | The second player.

mAirListScript
Class Tree
Index
Previous (SkipTo)
Next


Previous (IPlaybackControl)
Next (IPlaybackDeviceList)

Name
IPlaybackDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Members
Methods
Method Description
BuildFileDataSource (+)
BuildFileSource (+)
BuildMultiRegionSource (+)
BuildMultiSource (+)
BuildNetworkStreamSource (+)
BuildRecordDeviceSource (+)
GetCapabilities (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackControl)
Next (IPlaybackDeviceList)


Previous
Next (BuildFileSource)

Name
BuildFileDataSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildFileDataSource ( iItem : IPlaylistItem ; iData : IFileData ) : IAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iData : IFileData | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (BuildFileSource)


Previous (BuildFileDataSource)
Next (BuildMultiRegionSource)

Name
BuildFileSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildFileSource ( iItem : IPlaylistItem ; iURL : string ) : IAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iURL : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (BuildFileDataSource)
Next (BuildMultiRegionSource)


Previous (BuildFileSource)
Next (BuildMultiSource)

Name
BuildMultiRegionSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildMultiRegionSource ( iItem : IPlaylistItem ; iItems : IMultiPlaylist ; iFailsafe : boolean = false ) : IMultiAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iItems : IMultiPlaylist | &nbsp;
iFailsafe : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (BuildFileSource)
Next (BuildMultiSource)


Previous (BuildMultiRegionSource)
Next (BuildNetworkStreamSource)

Name
BuildMultiSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildMultiSource ( iItem : IPlaylistItem ; iItems : IMultiPlaylist ; iRegions : TSetOfByte ; iFailsafe : boolean = false ) : IMultiAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iItems : IMultiPlaylist | &nbsp;
iRegions : TSetOfByte | &nbsp;
iFailsafe : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (BuildMultiRegionSource)
Next (BuildNetworkStreamSource)


Previous (BuildMultiSource)
Next (BuildRecordDeviceSource)

Name
BuildNetworkStreamSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildNetworkStreamSource ( iItem : IPlaylistItem ; iURL : string ; iDelay : TTimeValue ; iTimeout : integer ) : IAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iURL : STRING | &nbsp;
iDelay : TTimeValue | &nbsp;
iTimeout : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (BuildMultiSource)
Next (BuildRecordDeviceSource)


Previous (BuildNetworkStreamSource)
Next (GetCapabilities)

Name
BuildRecordDeviceSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildRecordDeviceSource ( iItem : IPlaylistItem ; iDevice : IRecordDevice ; iDelay : TTimeValue ) : IAudioSource

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iDevice : IRecordDevice | &nbsp;
iDelay : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (BuildNetworkStreamSource)
Next (GetCapabilities)


Previous (BuildRecordDeviceSource)
Next

Name
GetCapabilities

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function GetCapabilities : TPlaybackDeviceCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildRecordDeviceSource)
Next


Previous (IPlaybackDevice)
Next (IPlayerControl)

Name
IPlaybackDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IAudioDeviceList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackDevice)
Next (IPlayerControl)


Previous
Next

Name
GetItem

Parent
IPlaybackDeviceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IPlaybackDevice

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaybackDeviceList)
Next (IPlaylist)

Name
IPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanOpen (+)
Close (+)
ExecutePlayerCommand (+)
FadeOut (+)
GetAutoFadeOut (+)
GetCaption (+)
GetColor (+)
GetCommandID (+)
GetDeviceConfigID (+)
GetEOFWarning (+)
GetErrorMessage (+)
GetFadeDuration (+)
GetHookMode (+)
GetIndex (+)
GetIsNext (+)
GetItem (+)
GetOnAirSourceControl (+)
GetOptions (+)
GetPFL (+)
GetPFLSource (+)
GetPFLSourceControl (+)
GetPlaybackControlIndex (+)
GetPosition (+)
GetSource (+)
GetState (+)
GetVolume (+)
IsActive (+)
IsAfterEOFWarning (+)
IsAfterStartNext (+)
Open (+)
Pause (+)
ReleaseItem (+)
Reset (+)
SetAutoFadeOut (+)
SetCaption (+)
SetColor (+)
SetEOFWarning (+)
SetFadeDuration (+)
SetIsNext (+)
SetOptions (+)
SetPFL (+)
SetVolume (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackDeviceList)
Next (IPlaylist)


Previous
Next (Close)

Name
CanOpen

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure CanOpen ( iItem : IPlaylistItem ; var Accept : boolean )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
Accept : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Close)


Previous (CanOpen)
Next (ExecutePlayerCommand)

Name
Close

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CanOpen)
Next (ExecutePlayerCommand)


Previous (Close)
Next (FadeOut)

Name
ExecutePlayerCommand

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ExecutePlayerCommand ( iCommand : TPlayerCommand )

Parameters
Parameter | Description
iCommand : TPlayerCommand | &nbsp;

mAirListScript
Class Tree
Index
Previous (Close)
Next (FadeOut)


Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)

Name
FadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)


Previous (FadeOut)
Next (GetCaption)

Name
GetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetAutoFadeOut : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetCaption)


Previous (GetAutoFadeOut)
Next (GetColor)

Name
GetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutoFadeOut)
Next (GetColor)


Previous (GetCaption)
Next (GetCommandID)

Name
GetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCommandID)


Previous (GetColor)
Next (GetDeviceConfigID)

Name
GetCommandID

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCommandID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetDeviceConfigID)


Previous (GetCommandID)
Next (GetEOFWarning)

Name
GetDeviceConfigID

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetDeviceConfigID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandID)
Next (GetEOFWarning)


Previous (GetDeviceConfigID)
Next (GetErrorMessage)

Name
GetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetEOFWarning : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceConfigID)
Next (GetErrorMessage)


Previous (GetEOFWarning)
Next (GetFadeDuration)

Name
GetErrorMessage

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEOFWarning)
Next (GetFadeDuration)


Previous (GetErrorMessage)
Next (GetHookMode)

Name
GetFadeDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetHookMode)


Previous (GetFadeDuration)
Next (GetIndex)

Name
GetHookMode

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetHookMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeDuration)
Next (GetIndex)


Previous (GetHookMode)
Next (GetIsNext)

Name
GetIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHookMode)
Next (GetIsNext)


Previous (GetIndex)
Next (GetItem)

Name
GetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIsNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetItem)


Previous (GetIsNext)
Next (GetOnAirSourceControl)

Name
GetItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsNext)
Next (GetOnAirSourceControl)


Previous (GetItem)
Next (GetOptions)

Name
GetOnAirSourceControl

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetOnAirSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetOptions)


Previous (GetOnAirSourceControl)
Next (GetPFL)

Name
GetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetOptions : TPlayerControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAirSourceControl)
Next (GetPFL)


Previous (GetOptions)
Next (GetPFLSource)

Name
GetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFL : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPFLSource)


Previous (GetPFL)
Next (GetPFLSourceControl)

Name
GetPFLSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFLSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFL)
Next (GetPFLSourceControl)


Previous (GetPFLSource)
Next (GetPlaybackControlIndex)

Name
GetPFLSourceControl

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFLSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLSource)
Next (GetPlaybackControlIndex)


Previous (GetPFLSourceControl)
Next (GetPosition)

Name
GetPlaybackControlIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPlaybackControlIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLSourceControl)
Next (GetPosition)


Previous (GetPlaybackControlIndex)
Next (GetSource)

Name
GetPosition

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlIndex)
Next (GetSource)


Previous (GetPosition)
Next (GetState)

Name
GetSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetState)


Previous (GetSource)
Next (GetVolume)

Name
GetState

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetState : TPlayerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (GetVolume)


Previous (GetState)
Next (IsActive)

Name
GetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (IsActive)


Previous (GetVolume)
Next (IsAfterEOFWarning)

Name
IsActive

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (IsAfterEOFWarning)


Previous (IsActive)
Next (IsAfterStartNext)

Name
IsAfterEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsAfterEOFWarning : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsActive)
Next (IsAfterStartNext)


Previous (IsAfterEOFWarning)
Next (Open)

Name
IsAfterStartNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsAfterStartNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterEOFWarning)
Next (Open)


Previous (IsAfterStartNext)
Next (Pause)

Name
Open

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Open ( iItem : IPlaylistItem ; iSourceControl : ISourceControl = nil )

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;
iSourceControl : ISourceControl | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsAfterStartNext)
Next (Pause)


Previous (Open)
Next (ReleaseItem)

Name
Pause

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (ReleaseItem)


Previous (Pause)
Next (Reset)

Name
ReleaseItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ReleaseItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (Reset)


Previous (ReleaseItem)
Next (SetAutoFadeOut)

Name
Reset

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Reset

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReleaseItem)
Next (SetAutoFadeOut)


Previous (Reset)
Next (SetCaption)

Name
SetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetAutoFadeOut ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (Reset)
Next (SetCaption)


Previous (SetAutoFadeOut)
Next (SetColor)

Name
SetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetCaption ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAutoFadeOut)
Next (SetColor)


Previous (SetCaption)
Next (SetEOFWarning)

Name
SetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter | Description
iValue : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCaption)
Next (SetEOFWarning)


Previous (SetColor)
Next (SetFadeDuration)

Name
SetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetEOFWarning ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetFadeDuration)


Previous (SetEOFWarning)
Next (SetIsNext)

Name
SetFadeDuration

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetFadeDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEOFWarning)
Next (SetIsNext)


Previous (SetFadeDuration)
Next (SetOptions)

Name
SetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetIsNext ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFadeDuration)
Next (SetOptions)


Previous (SetIsNext)
Next (SetPFL)

Name
SetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlayerControlOptions )

Parameters
Parameter | Description
iValue : TPlayerControlOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIsNext)
Next (SetPFL)


Previous (SetOptions)
Next (SetVolume)

Name
SetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetPFL ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetVolume)


Previous (SetPFL)
Next (Start)

Name
SetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPFL)
Next (Start)


Previous (SetVolume)
Next (Stop)

Name
Start

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IPlayerControl)
Next (IPlaylistExporter)

Name
IPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
BalanceFixTimes (+)
ErrorCheck (+)
GetActiveDuration (+)
GetBacktimingBaseTime (+)
GetBaseTime (+)
GetDuration (+)
GetEffectiveDuration (+)
GetEndTime (+)
GetHistoryCount (+)
GetItem (+)
GetMetadata (+)
GetMetadataOfItem (+)
GetNext (+)
GetRegions (+)
GetRemainingCount (+)
GetStartTime (+)
GetTag (+)
GetTitle (+)
InsertDirectory (+)
InsertFile (+)
InsertFiles (+)
InsertFilesEx (+)
LoadFromFileEx (+)
SetBaseTime (+)
SetTag (+)
SetTitle (+)
SkipToTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlayerControl)
Next (IPlaylistExporter)


Previous
Next (ErrorCheck)

Name
BalanceFixTimes

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure BalanceFixTimes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ErrorCheck)


Previous (BalanceFixTimes)
Next (GetActiveDuration)

Name
ErrorCheck

Parent
IPlaylist

Visibility
PUBLIC

Source code
function ErrorCheck ( iMessages : IStrings = nil ; iProgressIndicator : IProgressIndicator = nil ) : integer

Parameters
Parameter | Description
iMessages : IStrings | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (BalanceFixTimes)
Next (GetActiveDuration)


Previous (ErrorCheck)
Next (GetBacktimingBaseTime)

Name
GetActiveDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetActiveDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetBacktimingBaseTime)


Previous (GetActiveDuration)
Next (GetBaseTime)

Name
GetBacktimingBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBacktimingBaseTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActiveDuration)
Next (GetBaseTime)


Previous (GetBacktimingBaseTime)
Next (GetDuration)

Name
GetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBaseTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBacktimingBaseTime)
Next (GetDuration)


Previous (GetBaseTime)
Next (GetEffectiveDuration)

Name
GetDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBaseTime)
Next (GetEffectiveDuration)


Previous (GetDuration)
Next (GetEndTime)

Name
GetEffectiveDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetEffectiveDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetEndTime)


Previous (GetEffectiveDuration)
Next (GetHistoryCount)

Name
GetEndTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetEndTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDuration)
Next (GetHistoryCount)


Previous (GetEndTime)
Next (GetItem)

Name
GetHistoryCount

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndTime)
Next (GetItem)


Previous (GetHistoryCount)
Next (GetMetadata)

Name
GetItem

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetHistoryCount)
Next (GetMetadata)


Previous (GetItem)
Next (GetMetadataOfItem)

Name
GetMetadata

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetMetadata ( iIndex : integer ) : IPlaylistItemMetadata

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetMetadataOfItem)


Previous (GetMetadata)
Next (GetNext)

Name
GetMetadataOfItem

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetMetadataOfItem ( iItem : iPlaylistItem ) : IPlaylistItemMetadata

Parameters
Parameter | Description
iItem : iPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetNext)


Previous (GetMetadataOfItem)
Next (GetRegions)

Name
GetNext

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetNext ( iItem : IPlaylistItem ) : IPlaylistItem

Parameters
Parameter | Description
iItem : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMetadataOfItem)
Next (GetRegions)


Previous (GetNext)
Next (GetRemainingCount)

Name
GetRegions

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetRegions ( iDefault : byte ) : TSetOfByte

Parameters
Parameter | Description
iDefault : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNext)
Next (GetRemainingCount)


Previous (GetRegions)
Next (GetStartTime)

Name
GetRemainingCount

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetRemainingCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetStartTime)


Previous (GetRemainingCount)
Next (GetTag)

Name
GetStartTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetStartTime ( iIndex : integer ; iType : TStartTimeType ) : TDateTime

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iType : TStartTimeType | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRemainingCount)
Next (GetTag)


Previous (GetStartTime)
Next (GetTitle)

Name
GetTag

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetTag : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (GetTitle)


Previous (GetTag)
Next (InsertDirectory)

Name
GetTitle

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (InsertDirectory)


Previous (GetTitle)
Next (InsertFile)

Name
InsertDirectory

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertDirectory ( iIndex : integer ; iDirectory : string ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iDirectory : STRING | &nbsp;
iTasks : TFileImportTasks | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (InsertFile)


Previous (InsertDirectory)
Next (InsertFiles)

Name
InsertFile

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFile ( iIndex : integer ; iFilename : string ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iFilename : STRING | &nbsp;
iTasks : TFileImportTasks | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertDirectory)
Next (InsertFiles)


Previous (InsertFile)
Next (InsertFilesEx)

Name
InsertFiles

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFiles ( iIndex : integer ; iFiles : IStrings ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iFiles : IStrings | &nbsp;
iTasks : TFileImportTasks | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertFile)
Next (InsertFilesEx)


Previous (InsertFiles)
Next (LoadFromFileEx)

Name
InsertFilesEx

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFilesEx ( iIndex : integer ; iFiles : IStrings ; iTasks : TFileImportTasks ; iProgressIndicator : IProgressIndicator ) : integer

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iFiles : IStrings | &nbsp;
iTasks : TFileImportTasks | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertFiles)
Next (LoadFromFileEx)


Previous (InsertFilesEx)
Next (SetBaseTime)

Name
LoadFromFileEx

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure LoadFromFileEx ( iFilename : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iReferenceDatabase : IDatabase | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (InsertFilesEx)
Next (SetBaseTime)


Previous (LoadFromFileEx)
Next (SetTag)

Name
SetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetBaseTime ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFileEx)
Next (SetTag)


Previous (SetBaseTime)
Next (SetTitle)

Name
SetTag

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBaseTime)
Next (SetTitle)


Previous (SetTag)
Next (SkipToTime)

Name
SetTitle

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTag)
Next (SkipToTime)


Previous (SetTitle)
Next

Name
SkipToTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SkipToTime ( iTime : TDateTime )

Parameters
Parameter | Description
iTime : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)

Name
IPlaylistExporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
SavePlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)


Previous
Next

Name
SavePlaylist

Parent
IPlaylistExporter

Visibility
PUBLIC

Source code
procedure SavePlaylist ( iPlaylist : IPlaylist ; iFilename : string ; iProgressIndicator : IProgressIndicator )

Parameters
Parameter | Description
iPlaylist : IPlaylist | &nbsp;
iFilename : STRING | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaylistExporter)
Next (IPlaylistImporter)

Name
IPlaylistFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistExporter)
Next (IPlaylistImporter)


Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)

Name
IPlaylistImporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
FilenameToSlot (+)
LoadPlaylist (+)
LoadPlaylistBlock (+)
LoadPlaylistHour (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)


Previous
Next (LoadPlaylist)

Name
FilenameToSlot

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function FilenameToSlot ( iFilename : string ; iStyle : TPlaylistImportStyle ; out oSlot : TDateTime ; out oBlock : integer ) : boolean

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iStyle : TPlaylistImportStyle | &nbsp;
oSlot : TDateTime | &nbsp;
oBlock : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (LoadPlaylist)


Previous (FilenameToSlot)
Next (LoadPlaylistBlock)

Name
LoadPlaylist

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function LoadPlaylist ( iFilename : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iReferenceDatabase : IDatabase | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (FilenameToSlot)
Next (LoadPlaylistBlock)


Previous (LoadPlaylist)
Next (LoadPlaylistHour)

Name
LoadPlaylistBlock

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function LoadPlaylistBlock ( iFilename : string ; iHour , iBlock : integer ; iHourSplitMode : TPlaylistSplitMode ; iHourSplitParameter : string ; iBlockSplitMode : TPlaylistSplitMode ; iBlockSplitParameter : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iHour : INTEGER | &nbsp;
iBlock : INTEGER | &nbsp;
iHourSplitMode : TPlaylistSplitMode | &nbsp;
iHourSplitParameter : STRING | &nbsp;
iBlockSplitMode : TPlaylistSplitMode | &nbsp;
iBlockSplitParameter : STRING | &nbsp;
iReferenceDatabase : IDatabase | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadPlaylist)
Next (LoadPlaylistHour)


Previous (LoadPlaylistBlock)
Next

Name
LoadPlaylistHour

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function LoadPlaylistHour ( iFilename : string ; iHour : integer ; iHourSplitMode : TPlaylistSplitMode ; iHourSplitParameter : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iHour : INTEGER | &nbsp;
iHourSplitMode : TPlaylistSplitMode | &nbsp;
iHourSplitParameter : STRING | &nbsp;
iReferenceDatabase : IDatabase | &nbsp;
iProgressIndicator : IProgressIndicator | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadPlaylistBlock)
Next


Previous (IPlaylistImporter)
Next (IPlaylistItemMetadata)

Name
IPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
AsFile (+)
AutoSearchPosition (+)
BuildSource (+)
ConsistencyCheck (+)
ErrorCheck (+)
GetAmplification (+)
GetArtist (+)
GetAttributes (+)
GetCapabilities (+)
GetColor (+)
GetComment (+)
GetCueData (+)
GetCuePosition (+)
GetCustomized (+)
GetDatabase (+)
GetDatabaseID (+)
GetDuration (+)
GetEffectiveDisplayDuration (+)
GetEffectiveDisplayEnd (+)
GetEffectivePlaybackDuration (+)
GetEffectivePlaybackEnd (+)
GetEndType (+)
GetExternalID (+)
GetFadeDuration (+)
GetFadeEnd (+)
GetFilteredXML (+)
GetFixTime (+)
GetFixTimeFrame (+)
GetHearableDuration (+)
GetIconData (+)
GetIconFilename (+)
GetItemType (+)
GetOptions (+)
GetPitch (+)
GetRegions (+)
GetStartActions (+)
GetStopActions (+)
GetSummary (+)
GetTempo (+)
GetTimeout (+)
GetTiming (+)
GetTitle (+)
GetVolumeEnvelope (+)
IsCueable (+)
IsFile (+)
IsPlayable (+)
SetAmplification (+)
SetArtist (+)
SetColor (+)
SetComment (+)
SetCuePosition (+)
SetCustomized (+)
SetDatabase (+)
SetDatabaseID (+)
SetDuration (+)
SetEndType (+)
SetExternalID (+)
SetFadeDuration (+)
SetFixTime (+)
SetFixTimeFrame (+)
SetIconFilename (+)
SetItemType (+)
SetOptions (+)
SetPitch (+)
SetTempo (+)
SetTiming (+)
SetTitle (+)
SetVolumeEnvelope (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistImporter)
Next (IPlaylistItemMetadata)


Previous
Next (AutoSearchPosition)

Name
AsFile

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function AsFile : IFilePlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutoSearchPosition)


Previous (AsFile)
Next (BuildSource)

Name
AutoSearchPosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure AutoSearchPosition ( iType : TCuePositionType )

Parameters
Parameter | Description
iType : TCuePositionType | &nbsp;

mAirListScript
Class Tree
Index
Previous (AsFile)
Next (BuildSource)


Previous (AutoSearchPosition)
Next (ConsistencyCheck)

Name
BuildSource

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function BuildSource ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList ) : IAudioSource

Parameters
Parameter | Description
iDevice : IPlaybackDevice | &nbsp;
iRegionDevices : IPlaybackDeviceList | &nbsp;

mAirListScript
Class Tree
Index
Previous (AutoSearchPosition)
Next (ConsistencyCheck)


Previous (BuildSource)
Next (ErrorCheck)

Name
ConsistencyCheck

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function ConsistencyCheck : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildSource)
Next (ErrorCheck)


Previous (ConsistencyCheck)
Next (GetAmplification)

Name
ErrorCheck

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function ErrorCheck : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ConsistencyCheck)
Next (GetAmplification)


Previous (ErrorCheck)
Next (GetArtist)

Name
GetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetArtist)


Previous (GetAmplification)
Next (GetAttributes)

Name
GetArtist

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetArtist : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next (GetAttributes)


Previous (GetArtist)
Next (GetCapabilities)

Name
GetAttributes

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAttributes : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtist)
Next (GetCapabilities)


Previous (GetAttributes)
Next (GetColor)

Name
GetCapabilities

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCapabilities : TPlaylistItemCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAttributes)
Next (GetColor)


Previous (GetCapabilities)
Next (GetComment)

Name
GetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetComment)


Previous (GetColor)
Next (GetCueData)

Name
GetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetComment : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetCueData)


Previous (GetComment)
Next (GetCuePosition)

Name
GetCueData

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCueData : ICueData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetComment)
Next (GetCuePosition)


Previous (GetCueData)
Next (GetCustomized)

Name
GetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCuePosition ( iType : TCuePositionType ) : TTimeValue

Parameters
Parameter | Description
iType : TCuePositionType | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCueData)
Next (GetCustomized)


Previous (GetCuePosition)
Next (GetDatabase)

Name
GetCustomized

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCustomized : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCuePosition)
Next (GetDatabase)


Previous (GetCustomized)
Next (GetDatabaseID)

Name
GetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabase : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomized)
Next (GetDatabaseID)


Previous (GetDatabase)
Next (GetDuration)

Name
GetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabase)
Next (GetDuration)


Previous (GetDatabaseID)
Next (GetEffectiveDisplayDuration)

Name
GetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (GetEffectiveDisplayDuration)


Previous (GetDuration)
Next (GetEffectiveDisplayEnd)

Name
GetEffectiveDisplayDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetEffectiveDisplayEnd)


Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)

Name
GetEffectiveDisplayEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)


Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)

Name
GetEffectivePlaybackDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)


Previous (GetEffectivePlaybackDuration)
Next (GetEndType)

Name
GetEffectivePlaybackEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackDuration)
Next (GetEndType)


Previous (GetEffectivePlaybackEnd)
Next (GetExternalID)

Name
GetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEndType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackEnd)
Next (GetExternalID)


Previous (GetEndType)
Next (GetFadeDuration)

Name
GetExternalID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetExternalID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndType)
Next (GetFadeDuration)


Previous (GetExternalID)
Next (GetFadeEnd)

Name
GetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExternalID)
Next (GetFadeEnd)


Previous (GetFadeDuration)
Next (GetFilteredXML)

Name
GetFadeEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFadeEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeDuration)
Next (GetFilteredXML)


Previous (GetFadeEnd)
Next (GetFixTime)

Name
GetFilteredXML

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFilteredXML ( iFilter : cardinal ) : string

Parameters
Parameter | Description
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFadeEnd)
Next (GetFixTime)


Previous (GetFilteredXML)
Next (GetFixTimeFrame)

Name
GetFixTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFixTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilteredXML)
Next (GetFixTimeFrame)


Previous (GetFixTime)
Next (GetHearableDuration)

Name
GetFixTimeFrame

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFixTimeFrame : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFixTime)
Next (GetHearableDuration)


Previous (GetFixTimeFrame)
Next (GetIconData)

Name
GetHearableDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetHearableDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFixTimeFrame)
Next (GetIconData)


Previous (GetHearableDuration)
Next (GetIconFilename)

Name
GetIconData

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetIconData : IInlineData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHearableDuration)
Next (GetIconFilename)


Previous (GetIconData)
Next (GetItemType)

Name
GetIconFilename

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetIconFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIconData)
Next (GetItemType)


Previous (GetIconFilename)
Next (GetOptions)

Name
GetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetItemType : TPlaylistItemType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIconFilename)
Next (GetOptions)


Previous (GetItemType)
Next (GetPitch)

Name
GetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetOptions : TPlaylistItemOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemType)
Next (GetPitch)


Previous (GetOptions)
Next (GetRegions)

Name
GetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetRegions)


Previous (GetPitch)
Next (GetStartActions)

Name
GetRegions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetRegions ( iDefault : byte ) : TSetOfByte

Parameters
Parameter | Description
iDefault : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (GetStartActions)


Previous (GetRegions)
Next (GetStopActions)

Name
GetStartActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStartActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetStopActions)


Previous (GetStartActions)
Next (GetSummary)

Name
GetStopActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStopActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartActions)
Next (GetSummary)


Previous (GetStopActions)
Next (GetTempo)

Name
GetSummary

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStopActions)
Next (GetTempo)


Previous (GetSummary)
Next (GetTimeout)

Name
GetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSummary)
Next (GetTimeout)


Previous (GetTempo)
Next (GetTiming)

Name
GetTimeout

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTimeout : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (GetTiming)


Previous (GetTimeout)
Next (GetTitle)

Name
GetTiming

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTiming : TTiming

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeout)
Next (GetTitle)


Previous (GetTiming)
Next (GetVolumeEnvelope)

Name
GetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTiming)
Next (GetVolumeEnvelope)


Previous (GetTitle)
Next (IsCueable)

Name
GetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetVolumeEnvelope : IEnvelope

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (IsCueable)


Previous (GetVolumeEnvelope)
Next (IsFile)

Name
IsCueable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolumeEnvelope)
Next (IsFile)


Previous (IsCueable)
Next (IsPlayable)

Name
IsFile

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsFile : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (IsPlayable)


Previous (IsFile)
Next (SetAmplification)

Name
IsPlayable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsPlayable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsFile)
Next (SetAmplification)


Previous (IsPlayable)
Next (SetArtist)

Name
SetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsPlayable)
Next (SetArtist)


Previous (SetAmplification)
Next (SetColor)

Name
SetArtist

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetArtist ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAmplification)
Next (SetColor)


Previous (SetArtist)
Next (SetComment)

Name
SetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter | Description
iValue : TColor | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetArtist)
Next (SetComment)


Previous (SetColor)
Next (SetCuePosition)

Name
SetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetComment ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetCuePosition)


Previous (SetComment)
Next (SetCustomized)

Name
SetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCuePosition ( iType : TCuePositionType ; iValue : TTimeValue )

Parameters
Parameter | Description
iType : TCuePositionType | &nbsp;
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetComment)
Next (SetCustomized)


Previous (SetCuePosition)
Next (SetDatabase)

Name
SetCustomized

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCustomized ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCuePosition)
Next (SetDatabase)


Previous (SetCustomized)
Next (SetDatabaseID)

Name
SetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabase ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCustomized)
Next (SetDatabaseID)


Previous (SetDatabase)
Next (SetDuration)

Name
SetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDatabase)
Next (SetDuration)


Previous (SetDatabaseID)
Next (SetEndType)

Name
SetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next (SetEndType)


Previous (SetDuration)
Next (SetExternalID)

Name
SetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetEndType ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDuration)
Next (SetExternalID)


Previous (SetEndType)
Next (SetFadeDuration)

Name
SetExternalID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetExternalID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEndType)
Next (SetFadeDuration)


Previous (SetExternalID)
Next (SetFixTime)

Name
SetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFadeDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetExternalID)
Next (SetFixTime)


Previous (SetFadeDuration)
Next (SetFixTimeFrame)

Name
SetFixTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFixTime ( iValue : TDateTime )

Parameters
Parameter | Description
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFadeDuration)
Next (SetFixTimeFrame)


Previous (SetFixTime)
Next (SetIconFilename)

Name
SetFixTimeFrame

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFixTimeFrame ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFixTime)
Next (SetIconFilename)


Previous (SetFixTimeFrame)
Next (SetItemType)

Name
SetIconFilename

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetIconFilename ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFixTimeFrame)
Next (SetItemType)


Previous (SetIconFilename)
Next (SetOptions)

Name
SetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetItemType ( iValue : TPlaylistItemType )

Parameters
Parameter | Description
iValue : TPlaylistItemType | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIconFilename)
Next (SetOptions)


Previous (SetItemType)
Next (SetPitch)

Name
SetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaylistItemOptions )

Parameters
Parameter | Description
iValue : TPlaylistItemOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetItemType)
Next (SetPitch)


Previous (SetOptions)
Next (SetTempo)

Name
SetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetTempo)


Previous (SetPitch)
Next (SetTiming)

Name
SetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next (SetTiming)


Previous (SetTempo)
Next (SetTitle)

Name
SetTiming

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTiming ( iValue : TTiming )

Parameters
Parameter | Description
iValue : TTiming | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTempo)
Next (SetTitle)


Previous (SetTiming)
Next (SetVolumeEnvelope)

Name
SetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTiming)
Next (SetVolumeEnvelope)


Previous (SetTitle)
Next

Name
SetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter | Description
iValue : IEnvelope | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IPlaylistItem)
Next (IPlaylistPlayerControl)

Name
IPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetCalculatedDuration (+)
GetOffset (+)
GetStartTime (+)
GetStatusFlags (+)
SetCalculatedDuration (+)
SetOffset (+)
SetStartTime (+)
SetStatusFlags (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItem)
Next (IPlaylistPlayerControl)


Previous
Next (GetOffset)

Name
GetCalculatedDuration

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetCalculatedDuration ( iType : TCalculatedDurationType ) : TTimeValue

Parameters
Parameter | Description
iType : TCalculatedDurationType | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetOffset)


Previous (GetCalculatedDuration)
Next (GetStartTime)

Name
GetOffset

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetOffset : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCalculatedDuration)
Next (GetStartTime)


Previous (GetOffset)
Next (GetStatusFlags)

Name
GetStartTime

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetStartTime ( iType : TStartTimeType ) : TDateTime

Parameters
Parameter | Description
iType : TStartTimeType | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOffset)
Next (GetStatusFlags)


Previous (GetStartTime)
Next (SetCalculatedDuration)

Name
GetStatusFlags

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetStatusFlags : TPlaylistItemStatusFlags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (SetCalculatedDuration)


Previous (GetStatusFlags)
Next (SetOffset)

Name
SetCalculatedDuration

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetCalculatedDuration ( iType : TCalculatedDurationType ; iValue : TTimeValue )

Parameters
Parameter | Description
iType : TCalculatedDurationType | &nbsp;
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetStatusFlags)
Next (SetOffset)


Previous (SetCalculatedDuration)
Next (SetStartTime)

Name
SetOffset

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetOffset ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCalculatedDuration)
Next (SetStartTime)


Previous (SetOffset)
Next (SetStatusFlags)

Name
SetStartTime

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetStartTime ( iType : TStartTimeType ; iValue : TDateTime )

Parameters
Parameter | Description
iType : TStartTimeType | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOffset)
Next (SetStatusFlags)


Previous (SetStartTime)
Next

Name
SetStatusFlags

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetStatusFlags ( iValue : TPlaylistItemStatusFlags )

Parameters
Parameter | Description
iValue : TPlaylistItemStatusFlags | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetStartTime)
Next


Previous (IPlaylistItemMetadata)
Next (IPlaylistStorage)

Name
IPlaylistPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IPlayerControl

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoLoadItemTypes (+)
SetAutoLoadItemTypes (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItemMetadata)
Next (IPlaylistStorage)


Previous
Next (SetAutoLoadItemTypes)

Name
GetAutoLoadItemTypes

Parent
IPlaylistPlayerControl

Visibility
PUBLIC

Source code
function GetAutoLoadItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetAutoLoadItemTypes)


Previous (GetAutoLoadItemTypes)
Next

Name
SetAutoLoadItemTypes

Parent
IPlaylistPlayerControl

Visibility
PUBLIC

Source code
procedure SetAutoLoadItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter | Description
iValue : TPlaylistItemTypes | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAutoLoadItemTypes)
Next


Previous (IPlaylistPlayerControl)
Next (IPlayoutModule)

Name
IPlaylistStorage

Parent
mAirListInterfaces

Class Hierarchy
IFileStorage

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistPlayerControl)
Next (IPlayoutModule)


Previous (IPlaylistStorage)
Next (IProgressIndicator)

Name
IPlayoutModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistStorage)
Next (IProgressIndicator)


Previous (IPlayoutModule)
Next (IRecordDevice)

Name
IProgressIndicator

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddMessage (+)
Cancel (+)
CreateSubIndicator (+)
SetCurrentItem (+)
SetMax (+)
SetPosition (+)
SetRateMode (+)
SetTitle (+)
SkipRetryAbort (+)
StartProgress (+)
StepIt (+)
StopProgress (+)
WasCanceled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlayoutModule)
Next (IRecordDevice)


Previous
Next (Cancel)

Name
AddMessage

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure AddMessage ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Cancel)


Previous (AddMessage)
Next (CreateSubIndicator)

Name
Cancel

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure Cancel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddMessage)
Next (CreateSubIndicator)


Previous (Cancel)
Next (SetCurrentItem)

Name
CreateSubIndicator

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function CreateSubIndicator : IProgressIndicator

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Cancel)
Next (SetCurrentItem)


Previous (CreateSubIndicator)
Next (SetMax)

Name
SetCurrentItem

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetCurrentItem ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateSubIndicator)
Next (SetMax)


Previous (SetCurrentItem)
Next (SetPosition)

Name
SetMax

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetMax ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCurrentItem)
Next (SetPosition)


Previous (SetMax)
Next (SetRateMode)

Name
SetPosition

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : int64 )

Parameters
Parameter | Description
iValue : INT64 | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMax)
Next (SetRateMode)


Previous (SetPosition)
Next (SetTitle)

Name
SetRateMode

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetRateMode ( iValue : TProgressRateMode )

Parameters
Parameter | Description
iValue : TProgressRateMode | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SetTitle)


Previous (SetRateMode)
Next (SkipRetryAbort)

Name
SetTitle

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRateMode)
Next (SkipRetryAbort)


Previous (SetTitle)
Next (StartProgress)

Name
SkipRetryAbort

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function SkipRetryAbort ( iMessage : string ) : TSkipRetryAbort

Parameters
Parameter | Description
iMessage : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next (StartProgress)


Previous (SkipRetryAbort)
Next (StepIt)

Name
StartProgress

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StartProgress

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SkipRetryAbort)
Next (StepIt)


Previous (StartProgress)
Next (StopProgress)

Name
StepIt

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StepIt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StartProgress)
Next (StopProgress)


Previous (StepIt)
Next (WasCanceled)

Name
StopProgress

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StopProgress

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StepIt)
Next (WasCanceled)


Previous (StopProgress)
Next

Name
WasCanceled

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function WasCanceled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StopProgress)
Next


Previous (IProgressIndicator)
Next (IRecordDeviceList)

Name
IRecordDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Members
Methods
Method Description
Acquire (+)
GetChannelCount (+)
GetSampleFormat (+)
GetSamplerate (+)
RecordToFileData (+)
Release (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IProgressIndicator)
Next (IRecordDeviceList)


Previous
Next (GetChannelCount)

Name
Acquire

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure Acquire

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetChannelCount)


Previous (Acquire)
Next (GetSampleFormat)

Name
GetChannelCount

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Acquire)
Next (GetSampleFormat)


Previous (GetChannelCount)
Next (GetSamplerate)

Name
GetSampleFormat

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetSampleFormat : TSampleFormat

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChannelCount)
Next (GetSamplerate)


Previous (GetSampleFormat)
Next (RecordToFileData)

Name
GetSamplerate

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetSamplerate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSampleFormat)
Next (RecordToFileData)


Previous (GetSamplerate)
Next (Release)

Name
RecordToFileData

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function RecordToFileData ( iFileData : IWritableFileData ) : IFileDataRecorder

Parameters
Parameter | Description
iFileData : IWritableFileData | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSamplerate)
Next (Release)


Previous (RecordToFileData)
Next

Name
Release

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure Release

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RecordToFileData)
Next


Previous (IRecordDevice)
Next (IRecycleBinPlaylist)

Name
IRecordDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IAudioDeviceList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecordDevice)
Next (IRecycleBinPlaylist)


Previous
Next (IndexOfID)

Name
GetItem

Parent
IRecordDeviceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IRecordDevice

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (IndexOfID)


Previous (GetItem)
Next

Name
IndexOfID

Parent
IRecordDeviceList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : string ) : integer

Parameters
Parameter | Description
iID : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (IRecordDeviceList)
Next (IRegionContainerPlaylistItem)

Name
IRecycleBinPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPlaylist

Visibility
PUBLIC

Members
Methods
Method Description
GetMaxSize (+)
SetMaxSize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecordDeviceList)
Next (IRegionContainerPlaylistItem)


Previous
Next (SetMaxSize)

Name
GetMaxSize

Parent
IRecycleBinPlaylist

Visibility
PUBLIC

Source code
function GetMaxSize : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetMaxSize)


Previous (GetMaxSize)
Next

Name
SetMaxSize

Parent
IRecycleBinPlaylist

Visibility
PUBLIC

Source code
procedure SetMaxSize ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMaxSize)
Next


Previous (IRecycleBinPlaylist)
Next (IRemote)

Name
IRegionContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoFillMethod (+)
GetContent (+)
GetFiller (+)
HasContent (+)
SetAutoFillMethod (+)
SetFiller (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecycleBinPlaylist)
Next (IRemote)


Previous
Next (GetContent)

Name
GetAutoFillMethod

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetAutoFillMethod : TAutoFillMethod

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetContent)


Previous (GetAutoFillMethod)
Next (GetFiller)

Name
GetContent

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetContent ( iRegion : byte ) : IPlaylist

Parameters
Parameter | Description
iRegion : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAutoFillMethod)
Next (GetFiller)


Previous (GetContent)
Next (HasContent)

Name
GetFiller

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetFiller : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetContent)
Next (HasContent)


Previous (GetFiller)
Next (SetAutoFillMethod)

Name
HasContent

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function HasContent ( iRegion : byte ) : boolean

Parameters
Parameter | Description
iRegion : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFiller)
Next (SetAutoFillMethod)


Previous (HasContent)
Next (SetFiller)

Name
SetAutoFillMethod

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetAutoFillMethod ( iValue : TAutoFillMethod )

Parameters
Parameter | Description
iValue : TAutoFillMethod | &nbsp;

mAirListScript
Class Tree
Index
Previous (HasContent)
Next (SetFiller)


Previous (SetAutoFillMethod)
Next

Name
SetFiller

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFiller ( iValue : IPlaylistItem )

Parameters
Parameter | Description
iValue : IPlaylistItem | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAutoFillMethod)
Next


Previous (IRegionContainerPlaylistItem)
Next (IRemoteAction)

Name
IRemote

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRegionContainerPlaylistItem)
Next (IRemoteAction)


Previous (IRemote)
Next (IRemoteController)

Name
IRemoteAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Members
Methods
Method Description
GetRemoteID (+)
SetRemoteID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemote)
Next (IRemoteController)


Previous
Next (SetRemoteID)

Name
GetRemoteID

Parent
IRemoteAction

Visibility
PUBLIC

Source code
function GetRemoteID : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetRemoteID)


Previous (GetRemoteID)
Next

Name
SetRemoteID

Parent
IRemoteAction

Visibility
PUBLIC

Source code
procedure SetRemoteID ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetRemoteID)
Next


Previous (IRemoteAction)
Next (IRemoteList)

Name
IRemoteController

Parent
mAirListInterfaces

Class Hierarchy
IRemoteList

Visibility
PUBLIC

Members
Methods
Method Description
BeginPFL (+)
EndPFL (+)
ExecuteCommand (+)
GetPFLCount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteAction)
Next (IRemoteList)


Previous
Next (EndPFL)

Name
BeginPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure BeginPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndPFL)


Previous (BeginPFL)
Next (ExecuteCommand)

Name
EndPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure EndPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginPFL)
Next (ExecuteCommand)


Previous (EndPFL)
Next (GetPFLCount)

Name
ExecuteCommand

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (EndPFL)
Next (GetPFLCount)


Previous (ExecuteCommand)
Next

Name
GetPFLCount

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next


Previous (IRemoteController)
Next (IRunnable)

Name
IRemoteList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteController)
Next (IRunnable)


Previous
Next

Name
GetItem

Parent
IRemoteList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IRemote

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (IRemoteList)
Next (ISerializable)

Name
IRunnable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Run (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteList)
Next (ISerializable)


Previous
Next

Name
Run

Parent
IRunnable

Visibility
PUBLIC

Source code
procedure Run

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IRunnable)
Next (ISerialPortManager)

Name
ISerializable

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
AssignCopy (+)
Clear (+)
Clone (+)
GetField (+)
GetImplementor (+)
GetXML (+)
GetXMLDoc (+)
IsEmpty (+)
Load (+)
LoadFromXML (+)
Save (+)
SaveAsXML (+)
SaveAsXMLRenamed (+)
SaveXMLData (+)
SetField (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRunnable)
Next (ISerialPortManager)


Previous
Next (AssignCopy)

Name
Assign

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure Assign ( iItem : ISerializable )

Parameters
Parameter | Description
iItem : ISerializable | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AssignCopy)


Previous (Assign)
Next (Clear)

Name
AssignCopy

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure AssignCopy ( iSource : ISerializable )

Parameters
Parameter | Description
iSource : ISerializable | &nbsp;

mAirListScript
Class Tree
Index
Previous (Assign)
Next (Clear)


Previous (AssignCopy)
Next (Clone)

Name
Clear

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AssignCopy)
Next (Clone)


Previous (Clear)
Next (GetField)

Name
Clone

Parent
ISerializable

Visibility
PUBLIC

Source code
function Clone : ISerializable

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetField)


Previous (Clone)
Next (GetImplementor)

Name
GetField

Parent
ISerializable

Visibility
PUBLIC

Source code
function GetField ( iName : string ) : Variant

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetImplementor)


Previous (GetField)
Next (GetXML)

Name
GetImplementor

Parent
ISerializable

Visibility
PUBLIC

Source code
function GetImplementor : TObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetField)
Next (GetXML)


Previous (GetImplementor)
Next (GetXMLDoc)

Name
GetXML

Parent
ISerializable

Visibility
PUBLIC

Source code
function GetXML ( iIndent : boolean ) : string

Parameters
Parameter | Description
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetImplementor)
Next (GetXMLDoc)


Previous (GetXML)
Next (IsEmpty)

Name
GetXMLDoc

Parent
ISerializable

Visibility
PUBLIC

Source code
function GetXMLDoc : ISXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetXML)
Next (IsEmpty)


Previous (GetXMLDoc)
Next (Load)

Name
IsEmpty

Parent
ISerializable

Visibility
PUBLIC

Source code
function IsEmpty : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetXMLDoc)
Next (Load)


Previous (IsEmpty)
Next (LoadFromXML)

Name
Load

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter | Description
iSource : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (IsEmpty)
Next (LoadFromXML)


Previous (Load)
Next (Save)

Name
LoadFromXML

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : ISXMLNode )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (Load)
Next (Save)


Previous (LoadFromXML)
Next (SaveAsXML)

Name
Save

Parent
ISerializable

Visibility
PUBLIC

Source code
function Save ( iFilter : cardinal = 0 ) : IPersistentStorage

Parameters
Parameter | Description
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (Save)
Next (SaveAsXMLRenamed)

Name
SaveAsXML

Parent
ISerializable

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : ISXMLDocument ; iFilter : cardinal = 0 ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (Save)
Next (SaveAsXMLRenamed)


Previous (SaveAsXML)
Next (SaveXMLData)

Name
SaveAsXMLRenamed

Parent
ISerializable

Visibility
PUBLIC

Source code
function SaveAsXMLRenamed ( iDocument : ISXMLDocument ; iTagName : string ; iFilter : cardinal = 0 ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iTagName : STRING | &nbsp;
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveXMLData)


Previous (SaveAsXMLRenamed)
Next (SetField)

Name
SaveXMLData

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure SaveXMLData ( iParent : ISXMLNode ; iFilter : cardinal = 0 )

Parameters
Parameter | Description
iParent : ISXMLNode | &nbsp;
iFilter : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveAsXMLRenamed)
Next (SetField)


Previous (SaveXMLData)
Next

Name
SetField

Parent
ISerializable

Visibility
PUBLIC

Source code
procedure SetField ( iName : string ; iValue : Variant )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : VARIANT | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveXMLData)
Next


Previous (ISerializable)
Next (ISilencePlaylistItem)

Name
ISerialPortManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
GetPortList (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISerializable)
Next (ISilencePlaylistItem)


Previous
Next (GetPortList)

Name
GetPort

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPort ( iName : string ) : IComPort

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetPortList)


Previous (GetPort)
Next

Name
GetPortList

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPortList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (ISerialPortManager)
Next (ISourceControl)

Name
ISilencePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISerialPortManager)
Next (ISourceControl)


Previous (ISilencePlaylistItem)
Next (IStandardAttribute)

Name
ISourceControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
EndMon (+)
FadeOut (+)
GetDuration (+)
GetEOFWarning (+)
GetFadeDuration (+)
GetItem (+)
GetOptions (+)
GetPlaybackDuration (+)
GetPosition (+)
GetSource (+)
GetStartPosition (+)
GetStartTickCount (+)
GetStartTime (+)
GetState (+)
GetVolume (+)
IsAfterStartNext (+)
IsCueable (+)
IsPlaying (+)
Pause (+)
Play (+)
SetEOFWarning (+)
SetFadeDuration (+)
SetOptions (+)
SetPosition (+)
SetVolume (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISilencePlaylistItem)
Next (IStandardAttribute)


Previous
Next (FadeOut)

Name
EndMon

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure EndMon ( iDuration : TTimeValue = - 1 )

Parameters
Parameter | Description
iDuration : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (FadeOut)


Previous (EndMon)
Next (GetDuration)

Name
FadeOut

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndMon)
Next (GetDuration)


Previous (FadeOut)
Next (GetEOFWarning)

Name
GetDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetEOFWarning)


Previous (GetDuration)
Next (GetFadeDuration)

Name
GetEOFWarning

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetEOFWarning : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetFadeDuration)


Previous (GetEOFWarning)
Next (GetItem)

Name
GetFadeDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEOFWarning)
Next (GetItem)


Previous (GetFadeDuration)
Next (GetOptions)

Name
GetItem

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeDuration)
Next (GetOptions)


Previous (GetItem)
Next (GetPlaybackDuration)

Name
GetOptions

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetOptions : TSourceControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetPlaybackDuration)


Previous (GetOptions)
Next (GetPosition)

Name
GetPlaybackDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetPlaybackDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPosition)


Previous (GetPlaybackDuration)
Next (GetSource)

Name
GetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackDuration)
Next (GetSource)


Previous (GetPosition)
Next (GetStartPosition)

Name
GetSource

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetStartPosition)


Previous (GetSource)
Next (GetStartTickCount)

Name
GetStartPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetStartPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (GetStartTickCount)


Previous (GetStartPosition)
Next (GetStartTime)

Name
GetStartTickCount

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetStartTickCount : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartPosition)
Next (GetStartTime)


Previous (GetStartTickCount)
Next (GetState)

Name
GetStartTime

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetStartTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTickCount)
Next (GetState)


Previous (GetStartTime)
Next (GetVolume)

Name
GetState

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetState : TSourceControlState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (GetVolume)


Previous (GetState)
Next (IsAfterStartNext)

Name
GetVolume

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (IsAfterStartNext)


Previous (GetVolume)
Next (IsCueable)

Name
IsAfterStartNext

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsAfterStartNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (IsCueable)


Previous (IsAfterStartNext)
Next (IsPlaying)

Name
IsCueable

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterStartNext)
Next (IsPlaying)


Previous (IsCueable)
Next (Pause)

Name
IsPlaying

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (Pause)


Previous (IsPlaying)
Next (Play)

Name
Pause

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (Play)


Previous (Pause)
Next (SetEOFWarning)

Name
Play

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Play

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetEOFWarning)


Previous (Play)
Next (SetFadeDuration)

Name
SetEOFWarning

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetEOFWarning ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (Play)
Next (SetFadeDuration)


Previous (SetEOFWarning)
Next (SetOptions)

Name
SetFadeDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetFadeDuration ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetEOFWarning)
Next (SetOptions)


Previous (SetFadeDuration)
Next (SetPosition)

Name
SetOptions

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TSourceControlOptions )

Parameters
Parameter | Description
iValue : TSourceControlOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFadeDuration)
Next (SetPosition)


Previous (SetOptions)
Next (SetVolume)

Name
SetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter | Description
iValue : TTimeValue | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetVolume)


Previous (SetPosition)
Next (Stop)

Name
SetVolume

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter | Description
iValue : SINGLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (Stop)


Previous (SetVolume)
Next

Name
Stop

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next


Previous (ISourceControl)
Next (IStandardAttributeList)

Name
IStandardAttribute

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetKind (+)
GetName (+)
GetValues (+)
SetKind (+)
SetName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISourceControl)
Next (IStandardAttributeList)


Previous
Next (GetName)

Name
GetKind

Parent
IStandardAttribute

Visibility
PUBLIC

Source code
function GetKind : TAttributeKind

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetName)


Previous (GetKind)
Next (GetValues)

Name
GetName

Parent
IStandardAttribute

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetKind)
Next (GetValues)


Previous (GetName)
Next (SetKind)

Name
GetValues

Parent
IStandardAttribute

Visibility
PUBLIC

Source code
function GetValues : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (SetKind)


Previous (GetValues)
Next (SetName)

Name
SetKind

Parent
IStandardAttribute

Visibility
PUBLIC

Source code
procedure SetKind ( iValue : TAttributeKind )

Parameters
Parameter | Description
iValue : TAttributeKind | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValues)
Next (SetName)


Previous (SetKind)
Next

Name
SetName

Parent
IStandardAttribute

Visibility
PUBLIC

Source code
procedure SetName ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetKind)
Next


Previous (IStandardAttribute)
Next (IStream)

Name
IStandardAttributeList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
FindByName (+)
GetItem (+)
GetNames (+)
Merge (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStandardAttribute)
Next (IStream)


Previous
Next (GetItem)

Name
FindByName

Parent
IStandardAttributeList

Visibility
PUBLIC

Source code
function FindByName ( iName : string ) : IStandardAttribute

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (FindByName)
Next (GetNames)

Name
GetItem

Parent
IStandardAttributeList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IStandardAttribute

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (FindByName)
Next (GetNames)


Previous (GetItem)
Next (Merge)

Name
GetNames

Parent
IStandardAttributeList

Visibility
PUBLIC

Source code
function GetNames : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (Merge)


Previous (GetNames)
Next

Name
Merge

Parent
IStandardAttributeList

Visibility
PUBLIC

Source code
procedure Merge ( iOtherList : IStandardAttributeList )

Parameters
Parameter | Description
iOtherList : IStandardAttributeList | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNames)
Next


Previous (IStandardAttributeList)
Next (IStreamPlaylistItem)

Name
IStream

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetSize (+)
Lock (+)
READ (+)
Seek (+)
Unlock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStandardAttributeList)
Next (IStreamPlaylistItem)


Previous
Next (Lock)

Name
GetSize

Parent
IStream

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Lock)


Previous (GetSize)
Next (READ)

Name
Lock

Parent
IStream

Visibility
PUBLIC

Source code
procedure Lock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (READ)


Previous (Lock)
Next (Seek)

Name
READ

Parent
IStream

Visibility
PUBLIC

Source code
function Read ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter | Description
Buffer : pointer | &nbsp;
Count : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Lock)
Next (Seek)


Previous (READ)
Next (Unlock)

Name
Seek

Parent
IStream

Visibility
PUBLIC

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64

Parameters
Parameter | Description
OFFSET : INT64 | &nbsp;
Origin : TSeekOrigin | &nbsp;

mAirListScript
Class Tree
Index
Previous (READ)
Next (Unlock)


Previous (Seek)
Next

Name
Unlock

Parent
IStream

Visibility
PUBLIC

Source code
procedure Unlock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Seek)
Next


Previous (IStream)
Next (IStrings)

Name
IStreamPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IURLPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetTimeout (+)
SetTimeout (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStream)
Next (IStrings)


Previous
Next (SetTimeout)

Name
GetTimeout

Parent
IStreamPlaylistItem

Visibility
PUBLIC

Source code
function GetTimeout : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetTimeout)


Previous (GetTimeout)
Next

Name
SetTimeout

Parent
IStreamPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTimeout ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetTimeout)
Next


Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)

Name
IStrings

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddObject (+)
AddStrings (+)
AddValue (+)
Assign (+)
BeginRead (+)
BeginWrite (+)
Clear (+)
Clone (+)
Delete (+)
EndRead (+)
EndWrite (+)
GetCommaText (+)
GetCount (+)
GetData (+)
GetItem (+)
GetName (+)
GetSorted (+)
GetText (+)
GetValue (+)
GetValueFromIndex (+)
IndexOf (+)
IndexOfName (+)
Insert (+)
Join (+)
Load (+)
LoadFromFile (+)
LoadFromXML (+)
LoadMap (+)
LoadMapFromXML (+)
Save (+)
SaveMap (+)
SaveMapAsXML (+)
SaveToFile (+)
SaveToXML (+)
SetCommaText (+)
SetItem (+)
SetSorted (+)
SetText (+)
SetValue (+)
Shuffle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)


Previous
Next (AddObject)

Name
ADD

Parent
IStrings

Visibility
PUBLIC

Source code
function Add ( iValue : string ) : IStrings

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AddObject)


Previous (ADD)
Next (AddStrings)

Name
AddObject

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddObject ( iValue : string ; iData : cardinal )

Parameters
Parameter | Description
iValue : STRING | &nbsp;
iData : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (ADD)
Next (AddStrings)


Previous (AddObject)
Next (AddValue)

Name
AddStrings

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddStrings ( iValues : IStrings )

Parameters
Parameter | Description
iValues : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddObject)
Next (AddValue)


Previous (AddStrings)
Next (Assign)

Name
AddValue

Parent
IStrings

Visibility
PUBLIC

Source code
function AddValue ( iName , iValue : string ) : IStrings

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddStrings)
Next (Assign)


Previous (AddValue)
Next (BeginRead)

Name
Assign

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IStrings )

Parameters
Parameter | Description
iValue : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddValue)
Next (BeginRead)


Previous (Assign)
Next (BeginWrite)

Name
BeginRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (BeginWrite)


Previous (BeginRead)
Next (Clear)

Name
BeginWrite

Parent
IStrings

Visibility
PUBLIC

Source code
function BeginWrite : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (Clear)


Previous (BeginWrite)
Next (Clone)

Name
Clear

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginWrite)
Next (Clone)


Previous (Clear)
Next (Delete)

Name
Clone

Parent
IStrings

Visibility
PUBLIC

Source code
function Clone : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (Clone)
Next (EndRead)

Name
Delete

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (Clone)
Next (EndRead)


Previous (Delete)
Next (EndWrite)

Name
EndRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Delete)
Next (EndWrite)


Previous (EndRead)
Next (GetCommaText)

Name
EndWrite

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndWrite

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (GetCommaText)


Previous (EndWrite)
Next (GetCount)

Name
GetCommaText

Parent
IStrings

Visibility
PUBLIC

Source code
function GetCommaText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndWrite)
Next (GetCount)


Previous (GetCommaText)
Next (GetData)

Name
GetCount

Parent
IStrings

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommaText)
Next (GetData)


Previous (GetCount)
Next (GetItem)

Name
GetData

Parent
IStrings

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : cardinal

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetItem)


Previous (GetData)
Next (GetName)

Name
GetItem

Parent
IStrings

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetName)


Previous (GetItem)
Next (GetSorted)

Name
GetName

Parent
IStrings

Visibility
PUBLIC

Source code
function GetName ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSorted)


Previous (GetName)
Next (GetText)

Name
GetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
function GetSorted : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetText)


Previous (GetSorted)
Next (GetValue)

Name
GetText

Parent
IStrings

Visibility
PUBLIC

Source code
function GetText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSorted)
Next (GetValue)


Previous (GetText)
Next (GetValueFromIndex)

Name
GetValue

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValue ( iKey : string ) : string

Parameters
Parameter | Description
iKey : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetText)
Next (GetValueFromIndex)


Previous (GetValue)
Next (IndexOf)

Name
GetValueFromIndex

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValueFromIndex ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (IndexOf)


Previous (GetValueFromIndex)
Next (IndexOfName)

Name
IndexOf

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOf ( iValue : string ) : integer

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValueFromIndex)
Next (IndexOfName)


Previous (IndexOf)
Next (Insert)

Name
IndexOfName

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOfName ( iValue : string ) : integer

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (Insert)


Previous (IndexOfName)
Next (Join)

Name
Insert

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (IndexOfName)
Next (Join)


Previous (Insert)
Next (Load)

Name
Join

Parent
IStrings

Visibility
PUBLIC

Source code
function Join ( iDelimiter : string ) : string

Parameters
Parameter | Description
iDelimiter : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Insert)
Next (Load)


Previous (Join)
Next (LoadFromFile)

Name
Load

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter | Description
iSource : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (Join)
Next (LoadFromFile)


Previous (Load)
Next (LoadFromXML)

Name
LoadFromFile

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Load)
Next (LoadFromXML)


Previous (LoadFromFile)
Next (LoadMap)

Name
LoadFromXML

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : ISXMLNode ; iItemTag : string = '' )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;
iItemTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (LoadMap)


Previous (LoadFromXML)
Next (LoadMapFromXML)

Name
LoadMap

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadMap ( iSource : IPersistentStorage )

Parameters
Parameter | Description
iSource : IPersistentStorage | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (LoadMapFromXML)


Previous (LoadMap)
Next (Save)

Name
LoadMapFromXML

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadMapFromXML ( iXML : ISXMLNode ; iItemTag : string = 'Item' ; iNameTag : string = 'Item' ; iValueTag : string = 'Value' ; iUseAttributes : boolean = false )

Parameters
Parameter | Description
iXML : ISXMLNode | &nbsp;
iItemTag : STRING | &nbsp;
iNameTag : STRING | &nbsp;
iValueTag : STRING | &nbsp;
iUseAttributes : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadMap)
Next (Save)


Previous (LoadMapFromXML)
Next (SaveMap)

Name
Save

Parent
IStrings

Visibility
PUBLIC

Source code
function Save : IPersistentStorage

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadMapFromXML)
Next (SaveMap)


Previous (Save)
Next (SaveMapAsXML)

Name
SaveMap

Parent
IStrings

Visibility
PUBLIC

Source code
function SaveMap : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Save)
Next (SaveMapAsXML)


Previous (SaveMap)
Next (SaveToFile)

Name
SaveMapAsXML

Parent
IStrings

Visibility
PUBLIC

Source code
function SaveMapAsXML ( iDocument : ISXMLDocument ; iNodeName : string ; iItemTag : string = 'Item' ; iNameTag : string = 'Item' ; iValueTag : string = 'Value' ; iUseAttributes : boolean = false ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iNodeName : STRING | &nbsp;
iItemTag : STRING | &nbsp;
iNameTag : STRING | &nbsp;
iValueTag : STRING | &nbsp;
iUseAttributes : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveMap)
Next (SaveToFile)


Previous (SaveMapAsXML)
Next (SaveToXML)

Name
SaveToFile

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveMapAsXML)
Next (SaveToXML)


Previous (SaveToFile)
Next (SetCommaText)

Name
SaveToXML

Parent
IStrings

Visibility
PUBLIC

Source code
function SaveToXML ( iDocument : ISXMLDocument ; iElementName , iItemTag : string ) : ISXMLNode

Parameters
Parameter | Description
iDocument : ISXMLDocument | &nbsp;
iElementName : STRING | &nbsp;
iItemTag : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveToFile)
Next (SetCommaText)


Previous (SaveToXML)
Next (SetItem)

Name
SetCommaText

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetCommaText ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveToXML)
Next (SetItem)


Previous (SetCommaText)
Next (SetSorted)

Name
SetItem

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetItem ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetCommaText)
Next (SetSorted)


Previous (SetItem)
Next (SetText)

Name
SetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetSorted ( iValue : boolean )

Parameters
Parameter | Description
iValue : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetItem)
Next (SetText)


Previous (SetSorted)
Next (SetValue)

Name
SetText

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetText ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetSorted)
Next (SetValue)


Previous (SetText)
Next (Shuffle)

Name
SetValue

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetValue ( iKey : string ; iValue : string )

Parameters
Parameter | Description
iKey : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetText)
Next (Shuffle)


Previous (SetValue)
Next

Name
Shuffle

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Shuffle

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetValue)
Next


Previous (IStrings)
Next (ITrackCueDataItem)

Name
IStubPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStrings)
Next (ITrackCueDataItem)


Previous (IStubPlaylistItem)
Next (IUpdateObject)

Name
ITrackCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetArtist (+)
GetDatabaseID (+)
GetFilename (+)
GetTitle (+)
SetArtist (+)
SetDatabaseID (+)
SetFilename (+)
SetTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStubPlaylistItem)
Next (IUpdateObject)


Previous
Next (GetDatabaseID)

Name
GetArtist

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetArtist : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDatabaseID)


Previous (GetArtist)
Next (GetFilename)

Name
GetDatabaseID

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtist)
Next (GetFilename)


Previous (GetDatabaseID)
Next (GetTitle)

Name
GetFilename

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (GetTitle)


Previous (GetFilename)
Next (SetArtist)

Name
GetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (SetArtist)


Previous (GetTitle)
Next (SetDatabaseID)

Name
SetArtist

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetArtist ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (SetDatabaseID)


Previous (SetArtist)
Next (SetFilename)

Name
SetDatabaseID

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetArtist)
Next (SetFilename)


Previous (SetDatabaseID)
Next (SetTitle)

Name
SetFilename

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next (SetTitle)


Previous (SetFilename)
Next

Name
SetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFilename)
Next


Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)

Name
IUpdateObject

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
BeginRead (+)
BeginUpdate (+)
BeginUpdateWithTimeout (+)
EndRead (+)
EndUpdate (+)
GetMessageHandle (+)
GetObjectClassColor (+)
GetObjectClassDescription (+)
GetObjectClassID (+)
GetOwner (+)
GetTempData (+)
GetUpdateState (+)
Invalidate (+)
SetOwner (+)
SetSharedLock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)


Previous
Next (BeginUpdate)

Name
BeginRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeginUpdate)


Previous (BeginRead)
Next (BeginUpdateWithTimeout)

Name
BeginUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (BeginUpdateWithTimeout)


Previous (BeginUpdate)
Next (EndRead)

Name
BeginUpdateWithTimeout

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function BeginUpdateWithTimeout ( iTimeout : cardinal ) : boolean

Parameters
Parameter | Description
iTimeout : CARDINAL | &nbsp;

mAirListScript
Class Tree
Index
Previous (BeginUpdate)
Next (EndRead)


Previous (BeginUpdateWithTimeout)
Next (EndUpdate)

Name
EndRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginUpdateWithTimeout)
Next (EndUpdate)


Previous (EndRead)
Next (GetMessageHandle)

Name
EndUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (GetMessageHandle)


Previous (EndUpdate)
Next (GetObjectClassColor)

Name
GetMessageHandle

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetMessageHandle : TMessageHandle

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndUpdate)
Next (GetObjectClassColor)


Previous (GetMessageHandle)
Next (GetObjectClassDescription)

Name
GetObjectClassColor

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageHandle)
Next (GetObjectClassDescription)


Previous (GetObjectClassColor)
Next (GetObjectClassID)

Name
GetObjectClassDescription

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassColor)
Next (GetObjectClassID)


Previous (GetObjectClassDescription)
Next (GetOwner)

Name
GetObjectClassID

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassDescription)
Next (GetOwner)


Previous (GetObjectClassID)
Next (GetTempData)

Name
GetOwner

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetOwner : IInterface

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassID)
Next (GetTempData)


Previous (GetOwner)
Next (GetUpdateState)

Name
GetTempData

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetTempData : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOwner)
Next (GetUpdateState)


Previous (GetTempData)
Next (Invalidate)

Name
GetUpdateState

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetUpdateState : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempData)
Next (Invalidate)


Previous (GetUpdateState)
Next (SetOwner)

Name
Invalidate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure Invalidate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUpdateState)
Next (SetOwner)


Previous (Invalidate)
Next (SetSharedLock)

Name
SetOwner

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure SetOwner ( iValue : IInterface )

Parameters
Parameter | Description
iValue : IInterface | &nbsp;

mAirListScript
Class Tree
Index
Previous (Invalidate)
Next (SetSharedLock)


Previous (SetOwner)
Next

Name
SetSharedLock

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure SetSharedLock ( iValue : IMutex )

Parameters
Parameter | Description
iValue : IMutex | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOwner)
Next


Previous (IUpdateObject)
Next (IWritableFileData)

Name
IURLPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetURL (+)
SetURL (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IUpdateObject)
Next (IWritableFileData)


Previous
Next (SetURL)

Name
GetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetURL)


Previous (GetURL)
Next

Name
SetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
procedure SetURL ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetURL)
Next


Previous (IURLPlaylistItem)
Next (IWritableStream)

Name
IWritableFileData

Parent
mAirListInterfaces

Class Hierarchy
IFileData

Visibility
PUBLIC

Members
Methods
Method Description
Append (+)
AppendFrom (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IURLPlaylistItem)
Next (IWritableStream)


Previous
Next (AppendFrom)

Name
Append

Parent
IWritableFileData

Visibility
PUBLIC

Source code
function Append ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter | Description
Buffer : pointer | &nbsp;
Count : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AppendFrom)


Previous (Append)
Next

Name
AppendFrom

Parent
IWritableFileData

Visibility
PUBLIC

Source code
procedure AppendFrom ( Source : IStream )

Parameters
Parameter | Description
Source : IStream | &nbsp;

mAirListScript
Class Tree
Index
Previous (Append)
Next


Previous (IWritableFileData)
Next (TDatabaseNodeData)

Name
IWritableStream

Parent
mAirListInterfaces

Class Hierarchy
IStream

Visibility
PUBLIC

Members
Methods
Method Description
Append (+)
CopyFrom (+)
WRITE (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IWritableFileData)
Next (TDatabaseNodeData)


Previous
Next (CopyFrom)

Name
Append

Parent
IWritableStream

Visibility
PUBLIC

Source code
function Append ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter | Description
Buffer : pointer | &nbsp;
Count : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (CopyFrom)


Previous (Append)
Next (WRITE)

Name
CopyFrom

Parent
IWritableStream

Visibility
PUBLIC

Source code
procedure CopyFrom ( Source : IStream )

Parameters
Parameter | Description
Source : IStream | &nbsp;

mAirListScript
Class Tree
Index
Previous (Append)
Next (WRITE)


Previous (CopyFrom)
Next

Name
WRITE

Parent
IWritableStream

Visibility
PUBLIC

Source code
function Write ( Buffer : pointer ; Count : Longint ) : Longint

Parameters
Parameter | Description
Buffer : pointer | &nbsp;
Count : LONGINT | &nbsp;

mAirListScript
Class Tree
Index
Previous (CopyFrom)
Next


Previous (IWritableStream)
Next

Name
TDatabaseNodeData

Parent
mAirListInterfaces

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Caption (*)
Data (*)
Data2 (*)
Database (*)
Duration (*)
ExpectChildren (*)
NodeType (*)
SubType (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IWritableStream)
Next


Previous
Next (Data)

Name
Caption

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Caption : string

mAirListScript
Class Tree
Index
Previous
Next (Data)


Previous (Caption)
Next (Data2)

Name
Data

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Data : string

mAirListScript
Class Tree
Index
Previous (Caption)
Next (Data2)


Previous (Data)
Next (Database)

Name
Data2

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Data2 : string

mAirListScript
Class Tree
Index
Previous (Data)
Next (Database)


Previous (Data2)
Next (Duration)

Name
Database

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Database : IDatabase

mAirListScript
Class Tree
Index
Previous (Data2)
Next (Duration)


Previous (Database)
Next (ExpectChildren)

Name
Duration

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Duration : TTimeValue

mAirListScript
Class Tree
Index
Previous (Database)
Next (ExpectChildren)


Previous (Duration)
Next (NodeType)

Name
ExpectChildren

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
ExpectChildren : boolean

mAirListScript
Class Tree
Index
Previous (Duration)
Next (NodeType)


Previous (ExpectChildren)
Next (SubType)

Name
NodeType

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
NodeType : TDatabaseTreeNodeType

mAirListScript
Class Tree
Index
Previous (ExpectChildren)
Next (SubType)


Previous (NodeType)
Next

Name
SubType

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
SubType : integer

mAirListScript
Class Tree
Index
Previous (NodeType)
Next


Previous
Next (TMessageProc)

Name
IAudioSourceArray

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
IAudioSourceArray = array of IAudioSource ;

mAirListScript
Class Tree
Index
Previous
Next (TMessageProc)


Previous (IAudioSourceArray)
Next

Name
TMessageProc

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
TMessageProc = procedure ( iMessage : IBaseMessage ) of object ;

Parameters
Parameter | Description
iMessage : IBaseMessage | &nbsp;

mAirListScript
Class Tree
Index
Previous (IAudioSourceArray)
Next


Previous (mAirListInterfaces)
Next (mAirListTypes)

Name
mAirListScript

Parent
mAirListScript

Methods
Method | Description
ComPort (+)
Config (+) | Returns an IConfiguration interface representing the configuration
CreateContainerPlaylistItem (+)
CreateEmptyPlaylist (+)
CreateFilePlaylistItem (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+) | Creates a playlist item from the given file.
CreatePlaylistItemFromXMLString (+)
CurrentDatabase (+)
CurrentPlaybackControl (+)
CurrentPlaylist (+)
Database (+)
DatabaseCount (+)
Encoder (+)
Engine (+)
ExecuteCommand (+)
ExecuteCommandRPC (+)
Factory (+) | Return a reference to the Factory object which is used to create new
FakeNow (+) | Returns the (possibly faked) time of the internal mAirList clock.
HTTPGet (+)
HTTPGetAsync (+)
HTTPPost (+)
HTTPPostAsync (+)
Instance (+)
IOPort (+)
IOWarriorRemote (+)
ISOWeek (+) | Calculates the week number according to ISO 8601.
MidiOut (+)
MidiOutGetNumDevs (+)
MidiOutListDevices (+)
Mixer (+)
MixerCount (+)
NotifyConnect (+) | Notifies the GUI that the database connection has been established.
NotifyDisconnect (+) | Notifies the GUI that the database connection has been closed.
PlaybackControl (+)
Playlist (+)
PlaylistCount (+)
Random (+)
RunScript (+)
SASRemote (+)
SelectDatabase (+)
SelectPlaylist (+)
SetApplicationTitle (+)
SetWMClientOutput (+)
ShellExecute (+)
ShellExecuteHidden (+)
SystemLog (+)
URLEncode (+) | Encode a string so that it can by safely used as a parameter inside an
_FindFiles (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListInterfaces)
Next (mAirListTypes)


Previous
Next (Config)

Name
ComPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function ComPort ( iPort : string ) : IComPort

Parameters
Parameter | Description
iPort : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (Config)


Previous (ComPort)
Next (CreateContainerPlaylistItem)

Name
Config

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns an IConfiguration interface representing the configuration
of this mAirList instance.

Source code
function Config : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ComPort)
Next (CreateContainerPlaylistItem)


Previous (Config)
Next (CreateEmptyPlaylist)

Name
CreateContainerPlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Config)
Next (CreateEmptyPlaylist)


Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)

Name
CreateEmptyPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateEmptyPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)


Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)

Name
CreateFilePlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iLoadData : boolean ) : IFilePlaylistItem

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iLoadData : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)


Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromFile

Parent
mAirListScript

Visibility
PUBLIC

Description
Creates a playlist item from the given file.

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iLoadData : boolean ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | The name of the file to load.
iLoadData : BOOLEAN | If set to true, file tags and/or MMD will be loaded.

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)

Name
CreatePlaylistItemFromXMLString

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter | Description
iXML : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)


Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)

Name
CurrentDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentDatabase : IDatabase

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)


Previous (CurrentDatabase)
Next (CurrentPlaylist)

Name
CurrentPlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaybackControl : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentDatabase)
Next (CurrentPlaylist)


Previous (CurrentPlaybackControl)
Next (Database)

Name
CurrentPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaylist : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentPlaybackControl)
Next (Database)


Previous (CurrentPlaylist)
Next (DatabaseCount)

Name
Database

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Database ( iIndex : integer ) : IDatabase

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (CurrentPlaylist)
Next (DatabaseCount)


Previous (Database)
Next (Encoder)

Name
DatabaseCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function DatabaseCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Database)
Next (Encoder)


Previous (DatabaseCount)
Next (Engine)

Name
Encoder

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Encoder : IBassStreamingEncoder

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DatabaseCount)
Next (Engine)


Previous (Encoder)
Next (ExecuteCommand)

Name
Engine

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Engine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Encoder)
Next (ExecuteCommand)


Previous (Engine)
Next (ExecuteCommandRPC)

Name
ExecuteCommand

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter | Description
iCommand : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Engine)
Next (ExecuteCommandRPC)


Previous (ExecuteCommand)
Next (Factory)

Name
ExecuteCommandRPC

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommandRPC ( iURL , iCommand : string )

Parameters
Parameter | Description
iURL : STRING | &nbsp;
iCommand : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (Factory)


Previous (ExecuteCommandRPC)
Next (FakeNow)

Name
Factory

Parent
mAirListScript

Visibility
PUBLIC

Description
Return a reference to the Factory object which is used to create new
playlist items etc. (see IFactory).

Source code
function Factory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteCommandRPC)
Next (FakeNow)


Previous (Factory)
Next (HTTPGet)

Name
FakeNow

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns the (possibly faked) time of the internal mAirList clock.

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Factory)
Next (HTTPGet)


Previous (FakeNow)
Next (HTTPGetAsync)

Name
HTTPGet

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPGet ( iURL : string ) : string

Parameters
Parameter | Description
iURL : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (HTTPGetAsync)


Previous (HTTPGet)
Next (HTTPPost)

Name
HTTPGetAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPGetAsync ( iURL : string )

Parameters
Parameter | Description
iURL : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (HTTPGet)
Next (HTTPPost)


Previous (HTTPGetAsync)
Next (HTTPPostAsync)

Name
HTTPPost

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPPost ( iURL : string ; iData : string ) : string

Parameters
Parameter | Description
iURL : STRING | &nbsp;
iData : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (HTTPGetAsync)
Next (HTTPPostAsync)


Previous (HTTPPost)
Next (Instance)

Name
HTTPPostAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPPostAsync ( iURL : string ; iData : string )

Parameters
Parameter | Description
iURL : STRING | &nbsp;
iData : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (HTTPPost)
Next (Instance)


Previous (HTTPPostAsync)
Next (IOPort)

Name
Instance

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Instance : IInstanceData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (HTTPPostAsync)
Next (IOPort)


Previous (Instance)
Next (IOWarriorRemote)

Name
IOPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOPort ( iPort : word ) : IIOPort

Parameters
Parameter | Description
iPort : WORD | &nbsp;

mAirListScript
Class Tree
Index
Previous (Instance)
Next (IOWarriorRemote)


Previous (IOPort)
Next (ISOWeek)

Name
IOWarriorRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOWarriorRemote ( iIndex : integer ) : IIOWarriorRemote

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (IOPort)
Next (ISOWeek)


Previous (IOWarriorRemote)
Next (MidiOut)

Name
ISOWeek

Parent
mAirListScript

Visibility
PUBLIC

Description
Calculates the week number according to ISO 8601.

Source code
function ISOWeek ( DateTime : TDateTime ) : integer

Parameters
Parameter | Description
DateTime : TDateTime | The date for which the week number shall be calculated.

mAirListScript
Class Tree
Index
Previous (IOWarriorRemote)
Next (MidiOut)


Previous (ISOWeek)
Next (MidiOutGetNumDevs)

Name
MidiOut

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOut ( iDevice : integer ; iStatus , iData1 , iData2 : byte )

Parameters
Parameter | Description
iDevice : INTEGER | &nbsp;
iStatus : BYTE | &nbsp;
iData1 : BYTE | &nbsp;
iData2 : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (ISOWeek)
Next (MidiOutGetNumDevs)


Previous (MidiOut)
Next (MidiOutListDevices)

Name
MidiOutGetNumDevs

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MidiOutGetNumDevs : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOut)
Next (MidiOutListDevices)


Previous (MidiOutGetNumDevs)
Next (Mixer)

Name
MidiOutListDevices

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOutListDevices

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOutGetNumDevs)
Next (Mixer)


Previous (MidiOutListDevices)
Next (MixerCount)

Name
Mixer

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Mixer ( iIndex : integer ) : IMixer

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (MidiOutListDevices)
Next (MixerCount)


Previous (Mixer)
Next (NotifyConnect)

Name
MixerCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MixerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Mixer)
Next (NotifyConnect)


Previous (MixerCount)
Next (NotifyDisconnect)

Name
NotifyConnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been established.
Only available in database scripts.

Source code
procedure NotifyConnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MixerCount)
Next (NotifyDisconnect)


Previous (NotifyConnect)
Next (PlaybackControl)

Name
NotifyDisconnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been closed.
Only available in database scripts.

Source code
procedure NotifyDisconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NotifyConnect)
Next (PlaybackControl)


Previous (NotifyDisconnect)
Next (Playlist)

Name
PlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (NotifyDisconnect)
Next (Playlist)


Previous (PlaybackControl)
Next (PlaylistCount)

Name
Playlist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Playlist ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (PlaybackControl)
Next (PlaylistCount)


Previous (Playlist)
Next (Random)

Name
PlaylistCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaylistCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Playlist)
Next (Random)


Previous (PlaylistCount)
Next (RunScript)

Name
Random

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Random ( iRange : integer ) : integer

Parameters
Parameter | Description
iRange : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (PlaylistCount)
Next (RunScript)


Previous (Random)
Next (SASRemote)

Name
RunScript

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure RunScript ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (Random)
Next (SASRemote)


Previous (RunScript)
Next (SelectDatabase)

Name
SASRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SASRemote ( iIndex : integer ) : ISASRemote

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (RunScript)
Next (SelectDatabase)


Previous (SASRemote)
Next (SelectPlaylist)

Name
SelectDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectDatabase ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SASRemote)
Next (SelectPlaylist)


Previous (SelectDatabase)
Next (SetApplicationTitle)

Name
SelectPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectPlaylist ( iIndex : integer ) : boolean

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SelectDatabase)
Next (SetApplicationTitle)


Previous (SelectPlaylist)
Next (SetWMClientOutput)

Name
SetApplicationTitle

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetApplicationTitle ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SelectPlaylist)
Next (SetWMClientOutput)


Previous (SetApplicationTitle)
Next (ShellExecute)

Name
SetWMClientOutput

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetWMClientOutput ( iIndex , iNumber , iValue : integer )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iNumber : INTEGER | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetApplicationTitle)
Next (ShellExecute)


Previous (SetWMClientOutput)
Next (ShellExecuteHidden)

Name
ShellExecute

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecute ( iProgram , iParameters : string )

Parameters
Parameter | Description
iProgram : STRING | &nbsp;
iParameters : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetWMClientOutput)
Next (ShellExecuteHidden)


Previous (ShellExecute)
Next (SystemLog)

Name
ShellExecuteHidden

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecuteHidden ( iProgram , iParameters : string )

Parameters
Parameter | Description
iProgram : STRING | &nbsp;
iParameters : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ShellExecute)
Next (SystemLog)


Previous (ShellExecuteHidden)
Next (URLEncode)

Name
SystemLog

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SystemLog ( iMessage : string )

Parameters
Parameter | Description
iMessage : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (ShellExecuteHidden)
Next (URLEncode)


Previous (SystemLog)
Next (_FindFiles)

Name
URLEncode

Parent
mAirListScript

Visibility
PUBLIC

Description
Encode a string so that it can by safely used as a parameter inside an
HTTP request URL.

Source code
function URLEncode ( iString : string ) : string

Parameters
Parameter | Description
iString : STRING | The string to encode.

mAirListScript
Class Tree
Index
Previous (SystemLog)
Next (_FindFiles)


Previous (URLEncode)
Next

Name
_FindFiles

Parent
mAirListScript

Visibility
PUBLIC

Source code
function _FindFiles ( iPattern : string ; iRecursive : boolean ) : IStrings

Parameters
Parameter | Description
iPattern : STRING | &nbsp;
iRecursive : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (URLEncode)
Next


Previous (mAirListScript)
Next (MidiInterface)

Name
mAirListTypes

Parent
mAirListScript

Types
Type Description
TAttributeKind (+)
TAudioDeviceType (+)
TAudioSourceCapabilities (+)
TAudioSourceCapability (+)
TAudioSourceOption (+)
TAudioSourceOptions (+)
TAutoFillMethod (+)
TCalculatedDurationType (+)
TCartwallColor (+)
TCartwallItemCommand (+)
TCartwallItemOption (+)
TCartwallItemOptions (+)
TCartwallNumbering (+)
TCartwallNumberings (+)
TCartwallOnAirMode (+)
TCartwallOnAirModes (+)
TCartwallOption (+)
TCartwallOptions (+)
TCartwallTriggerAction (+)
TCartwallTriggerActions (+)
TCartwallTriggerCondition (+)
TCartwallTriggerConditions (+)
TCuePositionCategory (+)
TCuePositionChangedDetail (+)
TCuePositionChangedDetails (+)
TCuePositions (+)
TCuePositionType (+)
TCuePositionTypes (+)
TDatabaseCapabilities (+)
TDatabaseCapability (+)
TDatabaseSearchField (+)
TDatabaseSearchFields (+)
TDatabaseState (+)
TDatabaseTreeNodeType (+)
TDatabaseTreeNodeTypes (+)
TDefaultDirectory (+)
TEngineOption (+)
TEngineOptions (+)
TFileImportOption (+)
TFileImportOptions (+)
TFileImportTask (+)
TFileImportTasks (+)
TFileLocationType (+)
TFileManagementOption (+)
TFileManagementOptions (+)
TFileTypeHandlerCapabilities (+)
TFileTypeHandlerCapability (+)
TGlobalOption (+)
TGlobalOptions (+)
THourFilter (+)
TIntegerArray (+)
TLevelArray (+)
TLogCategories (+)
TLogCategory (+)
TmAirListFeature (+)
TmAirListFeatures (+)
TMessageHandle (+)
TObjectID (+)
TPeakAnalyzerState (+)
TPeakData (+)
TPersistentType (+)
TPlaybackControlOption (+)
TPlaybackControlOptions (+)
TPlaybackDeviceCapabilities (+)
TPlaybackDeviceCapability (+)
TPlaybackState (+)
TPlayerCommand (+)
TPlayerControlOption (+)
TPlayerControlOptions (+)
TPlayerState (+)
TPlayerStateArray (+)
TPlayerStates (+)
TPlayerType (+)
TPlaylistImportStyle (+)
TPlaylistImportStyles (+)
TPlaylistItemCapabilities (+)
TPlaylistItemCapability (+)
TPlaylistItemCategory (+)
TPlaylistItemFlag (+)
TPlaylistItemFlags (+)
TPlaylistItemOption (+)
TPlaylistItemOptions (+)
TPlaylistItemState (+)
TPlaylistItemStatusFlag (+)
TPlaylistItemStatusFlags (+)
TPlaylistItemType (+)
TPlaylistItemTypes (+)
TPlaylistSplitMode (+)
TPlaylistSplitModes (+)
TProgressRateMode (+)
TRepositoryItem (+)
TRunMode (+)
TSampleFormat (+)
TSetOfByte (+)
TSingleArray (+)
TSkipRetryAbort (+)
TSourceControlOption (+)
TSourceControlOptions (+)
TSourceControlState (+)
TStandardActionList (+)
TStartTimeType (+)
TTimeValue (+)
TTimeValueArray (+)
TTiming (+)
TWeekdayHourFilter (+)

Constants
Constant Description
AllCuePositionTypes (+)
AllDatabaseSearchFields (+)
AllFileImportTasks (+)
AllLogCategories (+)
AllPlaylistItemChangedDetails (+)
AllPlaylistItemTypes (+)
AutoCuePositions (+)
CartwallTriggerActionsWithOtherItem (+)
ccBASS (+)
ccCustom (+)
ccDatabase (+)
ccDefaultDirectories (+)
ccDemoLicense (+)
ccDevices (+)
ccEncoder (+)
ccGUI (+)
ccLayout (+)
ccLicense (+)
ccLogging (+)
ccMain (+)
ccMixdown (+)
ccPasswords (+)
ccPosition (+)
ccPreferences (+)
ccRemote (+)
ccScreenObjects (+)
ccSerial (+)
cdADCAssignment (+)
cdADCNodes (+)
cdBLContent (+)
cdCNumbering (+)
cdCOGeneral (+)
cdCOnAirMode (+)
cdCOptions (+)
cdCORestartCritical (+)
cdCOStatus (+)
cdCOther (+)
cdDBConnectionDetails (+)
cdDBOther (+)
cdDBState (+)
cdForceUpdate (+)
cdLCIIndex (+)
cdLCIItem (+)
cdLCIRect (+)
cdLCIState (+)
cdLCPItems (+)
cdLCPItemsItem (+)
cdLCPPlayer (+)
cdMDBacktiming (+)
cdMDFlags (+)
cdMDGeneral (+)
cdMDLink (+)
cdMDState (+)
cdMDStatus (+)
cdMDTiming (+)
cdOwner (+)
cdPCAllowAutomation (+)
cdPCAutomation (+)
cdPCAutomationPlaying (+)
cdPCOptions (+)
cdPCPlayerAssignment (+)
cdPCPlayerCount (+)
cdPIBacktimingStatus (+)
cdPIColor (+)
cdPIComment (+)
cdPIContent (+)
cdPICueData (+)
cdPIDuration (+)
cdPIHistoryFlag (+)
cdPIIcon (+)
cdPIItemData (+)
cdPILinked (+)
cdPIMetadata (+)
cdPIOther (+)
cdPIPitch (+)
cdPIPositionAlternatives (+)
cdPIPositionValue (+)
cdPIStartTimes (+)
cdPItem (+)
cdPITempo (+)
cdPIUnknown (+)
cdPIVolumeEnvelope (+)
cdPLBacktiming (+)
cdPLevelInfo (+)
cdPOptions (+)
cdPOther (+)
cdPVolume (+)
cdSCVolume (+)
ConfigTimePlaybackControlOptions (+)
DefaultCartwallOptions (+)
DefaultEngineOptions (+)
DefaultFeatures (+)
DefaultFileImportOptions (+)
DefaultFileManagementOptions (+)
DefaultGlobalOptions (+)
DefaultPlaybackControlOptions (+)
DefaultPlayerControlOptions (+)
MAX_REGION (+)
MIN_DB (+)
MIN_REGION (+)
NoObjectID (+)
ntAdvertisingAll (+)
ntAdvertisingCurrent (+)
ntAdvertisingRoot (+)
ntArtist (+)
ntArtistRoot (+)
ntAttribute (+)
ntAttributeRange (+)
ntAttributeRoot (+)
ntAttributeValue (+)
ntCustom (+)
ntFolder (+)
ntFolderRoot (+)
ntItem (+)
ntPlaylist (+)
ntPlaylistRoot (+)
ntRoot (+)
ntText (+)
ntType (+)
ntTypeRoot (+)
OrdinaryPlayerCommands (+)
PEAKDATA_LENGTH (+)
pidAmplification (+)
pidArtist (+)
pidAttributes (+)
pidColor (+)
pidComment (+)
pidContainerContent (+)
pidCueData (+)
pidCueMarkers (+)
pidCustomizationFlag (+)
pidDatabaseLink (+)
pidDuration (+)
pidEndType (+)
pidExternalID (+)
pidFadeDuration (+)
pidFilename (+)
pidIcon (+)
pidInlineData (+)
pidItemType (+)
pidPitch (+)
pidTempo (+)
pidTiming (+)
pidTitle (+)
RuntimeOrdinaryPlayerControlOptions (+)

Variables
Variable Description
ceh_task (+)

Classes
Class Description
ELicenseError (+)
EMessage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next (MidiInterface)


Previous
Next (EMessage)

Name
ELicenseError

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (EMessage)


Previous (ELicenseError)
Next

Name
EMessage

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ELicenseError)
Next


Previous
Next (TAudioDeviceType)

Name
TAttributeKind

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAttributeKind = ( akSingleLine , akDropDown , akDropDownList , akMultiLine , akCheck , akDate , akTime , akDateTime ) ;

mAirListScript
Class Tree
Index
Previous
Next (TAudioDeviceType)


Previous (TAttributeKind)
Next (TAudioSourceCapabilities)

Name
TAudioDeviceType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioDeviceType = ( adtPlayback , adtRecording ) ;

mAirListScript
Class Tree
Index
Previous (TAttributeKind)
Next (TAudioSourceCapabilities)


Previous (TAudioDeviceType)
Next (TAudioSourceCapability)

Name
TAudioSourceCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceCapabilities = set of TAudioSourceCapability ;

mAirListScript
Class Tree
Index
Previous (TAudioDeviceType)
Next (TAudioSourceCapability)


Previous (TAudioSourceCapabilities)
Next (TAudioSourceOption)

Name
TAudioSourceCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceCapability = ( ascCueable , ascDynamicTitle , ascCueMode , ascLoop ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceCapabilities)
Next (TAudioSourceOption)


Previous (TAudioSourceCapability)
Next (TAudioSourceOptions)

Name
TAudioSourceOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOption = ( asoLogging , asoWorkActionLists , asoLoop ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceCapability)
Next (TAudioSourceOptions)


Previous (TAudioSourceOption)
Next (TAutoFillMethod)

Name
TAudioSourceOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOptions = set of TAudioSourceOption ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOption)
Next (TAutoFillMethod)


Previous (TAudioSourceOptions)
Next (TCalculatedDurationType)

Name
TAutoFillMethod

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAutoFillMethod = ( afmNone , afmSilence , afmFillerFadeOut , afmFillerFadeIn ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOptions)
Next (TCalculatedDurationType)


Previous (TAutoFillMethod)
Next (TCartwallColor)

Name
TCalculatedDurationType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCalculatedDurationType = ( cdtTotal , cdtRemaining , cdtUnderrun ) ;

mAirListScript
Class Tree
Index
Previous (TAutoFillMethod)
Next (TCartwallColor)


Previous (TCalculatedDurationType)
Next (TCartwallItemCommand)

Name
TCartwallColor

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallColor = ( ccBackground , ccEditGrid ) ;

mAirListScript
Class Tree
Index
Previous (TCalculatedDurationType)
Next (TCartwallItemCommand)


Previous (TCartwallColor)
Next (TCartwallItemOption)

Name
TCartwallItemCommand

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallItemCommand = ( cicClick , cicStart , cicPause , cicStop , cicFadeOut , cicStartPause , cicPauseStop , cicStartPauseStop , cicStartStop , cicStartFadeOut , cicReset , cicClose ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallColor)
Next (TCartwallItemOption)


Previous (TCartwallItemCommand)
Next (TCartwallItemOptions)

Name
TCartwallItemOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallItemOption = ( cioLoop , cioExitLoop , cioFadeOnStopCommand , cioNoIcon ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallItemCommand)
Next (TCartwallItemOptions)


Previous (TCartwallItemOption)
Next (TCartwallNumbering)

Name
TCartwallItemOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallItemOptions = set of TCartwallItemOption ;

mAirListScript
Class Tree
Index
Previous (TCartwallItemOption)
Next (TCartwallNumbering)


Previous (TCartwallItemOptions)
Next (TCartwallNumberings)

Name
TCartwallNumbering

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallNumbering = ( cnNone , cnLeftToRight , cnLeftToRightOccupied , cnTopToBottom , cnTopToBottomOccupied ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallItemOptions)
Next (TCartwallNumberings)


Previous (TCartwallNumbering)
Next (TCartwallOnAirMode)

Name
TCartwallNumberings

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallNumberings = set of TCartwallNumbering ;

mAirListScript
Class Tree
Index
Previous (TCartwallNumbering)
Next (TCartwallOnAirMode)


Previous (TCartwallNumberings)
Next (TCartwallOnAirModes)

Name
TCartwallOnAirMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallOnAirMode = ( oamOnAir , oamOffAir , oamPFL ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallNumberings)
Next (TCartwallOnAirModes)


Previous (TCartwallOnAirMode)
Next (TCartwallOption)

Name
TCartwallOnAirModes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallOnAirModes = set of TCartwallOnAirMode ;

mAirListScript
Class Tree
Index
Previous (TCartwallOnAirMode)
Next (TCartwallOption)


Previous (TCartwallOnAirModes)
Next (TCartwallOptions)

Name
TCartwallOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallOption = ( coSaveWithDesktop , coSaveWithTemplate , coLogging , coAlwaysShowGrid , coAlwaysShowGridNumbers , coShowArtist , coShowIcons , coPageCloseConfirmation ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallOnAirModes)
Next (TCartwallOptions)


Previous (TCartwallOption)
Next (TCartwallTriggerAction)

Name
TCartwallOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallOptions = set of TCartwallOption ;

mAirListScript
Class Tree
Index
Previous (TCartwallOption)
Next (TCartwallTriggerAction)


Previous (TCartwallOptions)
Next (TCartwallTriggerActions)

Name
TCartwallTriggerAction

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallTriggerAction = ( taStartItem , taStopItem , taFadeOutItem , taStopAllOnThisPage , taFadeOutAllOnThisPage , taNothing ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallOptions)
Next (TCartwallTriggerActions)


Previous (TCartwallTriggerAction)
Next (TCartwallTriggerCondition)

Name
TCartwallTriggerActions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallTriggerActions = set of TCartwallTriggerAction ;

mAirListScript
Class Tree
Index
Previous (TCartwallTriggerAction)
Next (TCartwallTriggerCondition)


Previous (TCartwallTriggerActions)
Next (TCartwallTriggerConditions)

Name
TCartwallTriggerCondition

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallTriggerCondition = ( tcOnStart , tcOnStop , tcOnStartNext ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallTriggerActions)
Next (TCartwallTriggerConditions)


Previous (TCartwallTriggerCondition)
Next (TCuePositionCategory)

Name
TCartwallTriggerConditions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallTriggerConditions = set of TCartwallTriggerCondition ;

mAirListScript
Class Tree
Index
Previous (TCartwallTriggerCondition)
Next (TCuePositionCategory)


Previous (TCartwallTriggerConditions)
Next (TCuePositionChangedDetail)

Name
TCuePositionCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionCategory = ( cpcCueIn , cpcRamp , cpcHook , cpcLoop , cpcOutro , cpcStartNext , cpcFade , cpcCueOut , cpcMisc ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallTriggerConditions)
Next (TCuePositionChangedDetail)


Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)

Name
TCuePositionChangedDetail

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetail = ( cdCPValue , cdCPAlternatives ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)


Previous (TCuePositionChangedDetail)
Next (TCuePositions)

Name
TCuePositionChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetails = set of TCuePositionChangedDetail ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetail)
Next (TCuePositions)


Previous (TCuePositionChangedDetails)
Next (TCuePositionType)

Name
TCuePositions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositions = array [ TCuePositionType ] of TTimeValue ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetails)
Next (TCuePositionType)


Previous (TCuePositions)
Next (TCuePositionTypes)

Name
TCuePositionType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionType = ( ptCueIn , ptFadeIn , ptRamp1 , ptRamp2 , ptRamp3 , ptHookIn , ptHookFade , ptHookOut , ptLoopIn , ptLoopOut , ptOutro , ptStartNext , ptFadeOut , ptCueOut , ptAnchor ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositions)
Next (TCuePositionTypes)


Previous (TCuePositionType)
Next (TDatabaseCapabilities)

Name
TCuePositionTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionTypes = set of TCuePositionType ;

mAirListScript
Class Tree
Index
Previous (TCuePositionType)
Next (TDatabaseCapabilities)


Previous (TCuePositionTypes)
Next (TDatabaseCapability)

Name
TDatabaseCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapabilities = set of TDatabaseCapability ;

mAirListScript
Class Tree
Index
Previous (TCuePositionTypes)
Next (TDatabaseCapability)


Previous (TDatabaseCapabilities)
Next (TDatabaseSearchField)

Name
TDatabaseCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapability = ( dcUpdateItem , dcReverseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapabilities)
Next (TDatabaseSearchField)


Previous (TDatabaseCapability)
Next (TDatabaseSearchFields)

Name
TDatabaseSearchField

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseSearchField = ( dbsfArtist , dbsfTitle , dbsfComment , dbsfDuration , dbsfID , dbsfExternalID , dbsfStandardAttributes , dbsfAllAttributes ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapability)
Next (TDatabaseSearchFields)


Previous (TDatabaseSearchField)
Next (TDatabaseState)

Name
TDatabaseSearchFields

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseSearchFields = set of TDatabaseSearchField ;

mAirListScript
Class Tree
Index
Previous (TDatabaseSearchField)
Next (TDatabaseState)


Previous (TDatabaseSearchFields)
Next (TDatabaseTreeNodeType)

Name
TDatabaseState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseState = ( dsDisconnected , dsConnecting , dsConnected ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseSearchFields)
Next (TDatabaseTreeNodeType)


Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)

Name
TDatabaseTreeNodeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeType = byte ;

mAirListScript
Class Tree
Index
Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)


Previous (TDatabaseTreeNodeType)
Next (TDefaultDirectory)

Name
TDatabaseTreeNodeTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeTypes = set of TDatabaseTreeNodeType ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeType)
Next (TDefaultDirectory)


Previous (TDatabaseTreeNodeTypes)
Next (TEngineOption)

Name
TDefaultDirectory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDefaultDirectory = ( ddAddDirectoryBrowser , ddAddPlaylistBrowser , ddCartwallLoad , ddCartwallSave , ddExportDatabase , ddImportDatabase , ddInsertFiles , ddLoadHourTemplate , ddOpenPlaylist , ddOpenDesktop , ddRunScript , ddSaveDesktop , ddSaveHourTemplate , ddSavePlaylist , ddSelectIcon , ddSchedulerLoadList , ddSchedulerSaveList , ddArchiveDBFiles , ddImportCueSheet ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeTypes)
Next (TEngineOption)


Previous (TDefaultDirectory)
Next (TEngineOptions)

Name
TEngineOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOption = ( eoDummy ) ;

mAirListScript
Class Tree
Index
Previous (TDefaultDirectory)
Next (TEngineOptions)


Previous (TEngineOption)
Next (TFileImportOption)

Name
TEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOptions = set of TEngineOption ;

mAirListScript
Class Tree
Index
Previous (TEngineOption)
Next (TFileImportOption)


Previous (TEngineOptions)
Next (TFileImportOptions)

Name
TFileImportOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOption = ( fioImportComment , fioImportTags , fioImportArtwork , fioVorbisDateAsYear , fioMP2OutroAsFadeOut , fioTildeAsStartNext , fioTildeAsOutro , fioTildeAsFadeOut , fioStripWhitespace , fioImportReplayGain , fioReplayGainAlbum , fioReplayGainPreventClipping , fioArtistTitleFromFilename , fioFilenameAsExternalID , fioNormalize ) ;

mAirListScript
Class Tree
Index
Previous (TEngineOptions)
Next (TFileImportOptions)


Previous (TFileImportOption)
Next (TFileImportTask)

Name
TFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOptions = set of TFileImportOption ;

mAirListScript
Class Tree
Index
Previous (TFileImportOption)
Next (TFileImportTask)


Previous (TFileImportOptions)
Next (TFileImportTasks)

Name
TFileImportTask

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTask = ( fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitNormalize , fitDatabaseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportOptions)
Next (TFileImportTasks)


Previous (TFileImportTask)
Next (TFileLocationType)

Name
TFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTasks = set of TFileImportTask ;

mAirListScript
Class Tree
Index
Previous (TFileImportTask)
Next (TFileLocationType)


Previous (TFileImportTasks)
Next (TFileManagementOption)

Name
TFileLocationType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileLocationType = ( fltLocal , fltNetwork , fltDatabase , fltRAM , fltEmpty ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportTasks)
Next (TFileManagementOption)


Previous (TFileLocationType)
Next (TFileManagementOptions)

Name
TFileManagementOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOption = ( fmoCacheNetworkFiles , fmoCacheAllFiles , fmoLockFiles ) ;

mAirListScript
Class Tree
Index
Previous (TFileLocationType)
Next (TFileManagementOptions)


Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)

Name
TFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOptions = set of TFileManagementOption ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)


Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)

Name
TFileTypeHandlerCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapabilities = set of TFileTypeHandlerCapability ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)


Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)

Name
TFileTypeHandlerCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapability = ( fthcReadDuration , fthcReadTags , fthcWriteTags , fthcReadNativeTags , fthcGetTagData ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)


Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)

Name
TGlobalOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOption = ( goStartNextEffectiveEnd , goFadeOutEffectiveEnd , goFadeOutToCueOut , goOutroEOFWarning , goOnlyOneInstance , goStartOnAir , goNoLoggingOffAir , goSplashScreen , goRemotesForTagging , goDebugMode , goCompat3x , goFailsafeContainers , goReverseHookContainers , goControlPanelAutoSave , goSinglePropertiesDialog ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)


Previous (TGlobalOption)
Next (THourFilter)

Name
TGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOptions = set of TGlobalOption ;

mAirListScript
Class Tree
Index
Previous (TGlobalOption)
Next (THourFilter)


Previous (TGlobalOptions)
Next (TIntegerArray)

Name
THourFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
THourFilter = array [ 0 .. 23 ] of boolean ;

mAirListScript
Class Tree
Index
Previous (TGlobalOptions)
Next (TIntegerArray)


Previous (THourFilter)
Next (TLevelArray)

Name
TIntegerArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TIntegerArray = array of integer ;

mAirListScript
Class Tree
Index
Previous (THourFilter)
Next (TLevelArray)


Previous (TIntegerArray)
Next (TLogCategories)

Name
TLevelArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLevelArray = array of single ;

mAirListScript
Class Tree
Index
Previous (TIntegerArray)
Next (TLogCategories)


Previous (TLevelArray)
Next (TLogCategory)

Name
TLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategories = set of TLogCategory ;

mAirListScript
Class Tree
Index
Previous (TLevelArray)
Next (TLogCategory)


Previous (TLogCategories)
Next (TmAirListFeature)

Name
TLogCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategory = ( lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategories)
Next (TmAirListFeature)


Previous (TLogCategory)
Next (TmAirListFeatures)

Name
TmAirListFeature

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeature = ( mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfDirectoryContextMenu , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategory)
Next (TmAirListFeatures)


Previous (TmAirListFeature)
Next (TMessageHandle)

Name
TmAirListFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeatures = set of TmAirListFeature ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeature)
Next (TMessageHandle)


Previous (TmAirListFeatures)
Next (TObjectID)

Name
TMessageHandle

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TMessageHandle = cardinal ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeatures)
Next (TObjectID)


Previous (TMessageHandle)
Next (TPeakAnalyzerState)

Name
TObjectID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TObjectID = int64 ;

mAirListScript
Class Tree
Index
Previous (TMessageHandle)
Next (TPeakAnalyzerState)


Previous (TObjectID)
Next (TPeakData)

Name
TPeakAnalyzerState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPeakAnalyzerState = ( pasUninitialized , pasReady , pasError ) ;

mAirListScript
Class Tree
Index
Previous (TObjectID)
Next (TPeakData)


Previous (TPeakAnalyzerState)
Next (TPersistentType)

Name
TPeakData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPeakData = array [ 0 .. PEAKDATA_LENGTH - 1 ] of single ;

mAirListScript
Class Tree
Index
Previous (TPeakAnalyzerState)
Next (TPersistentType)


Previous (TPeakData)
Next (TPlaybackControlOption)

Name
TPersistentType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPersistentType = ( ptNull , ptNumber , ptString , ptBoolean , ptDateTime , ptArray , ptObject ) ;

mAirListScript
Class Tree
Index
Previous (TPeakData)
Next (TPlaybackControlOption)


Previous (TPersistentType)
Next (TPlaybackControlOptions)

Name
TPlaybackControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOption = ( plcoAllowAutomation , plcoAutomationSinglePlayer , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoCleanUpNonPlayables , plcoSaveEvents , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime , plcoFixedTimeWaitHard , plcoFixedTimeWaitSoft , plcoLiveBacktiming ) ;

mAirListScript
Class Tree
Index
Previous (TPersistentType)
Next (TPlaybackControlOptions)


Previous (TPlaybackControlOption)
Next (TPlaybackDeviceCapabilities)

Name
TPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOptions = set of TPlaybackControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOption)
Next (TPlaybackDeviceCapabilities)


Previous (TPlaybackControlOptions)
Next (TPlaybackDeviceCapability)

Name
TPlaybackDeviceCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackDeviceCapabilities = set of TPlaybackDeviceCapability ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOptions)
Next (TPlaybackDeviceCapability)


Previous (TPlaybackDeviceCapabilities)
Next (TPlaybackState)

Name
TPlaybackDeviceCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackDeviceCapability = ( pdcMultiRegion ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackDeviceCapabilities)
Next (TPlaybackState)


Previous (TPlaybackDeviceCapability)
Next (TPlayerCommand)

Name
TPlaybackState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackState = ( pbsNone , pbsBuffered , pbsPlaying , pbsPaused , pbsFading , pbsEOF , pbsError ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackDeviceCapability)
Next (TPlayerCommand)


Previous (TPlaybackState)
Next (TPlayerControlOption)

Name
TPlayerCommand

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerCommand = ( pcNone , pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackState)
Next (TPlayerControlOption)


Previous (TPlayerCommand)
Next (TPlayerControlOptions)

Name
TPlayerControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOption = ( poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerCommand)
Next (TPlayerControlOptions)


Previous (TPlayerControlOption)
Next (TPlayerState)

Name
TPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOptions = set of TPlayerControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOption)
Next (TPlayerState)


Previous (TPlayerControlOptions)
Next (TPlayerStateArray)

Name
TPlayerState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerState = ( psEmpty , psLoading , psLoaded , psPlaying , psFading , psEOF , psError , psPaused , psStopped , psPFL , psFlashEOF , psNext , psHistory , psOverflow , psUnderrun , psRegion , psOffAir ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOptions)
Next (TPlayerStateArray)


Previous (TPlayerState)
Next (TPlayerStates)

Name
TPlayerStateArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerStateArray = array of TPlayerState ;

mAirListScript
Class Tree
Index
Previous (TPlayerState)
Next (TPlayerStates)


Previous (TPlayerStateArray)
Next (TPlayerType)

Name
TPlayerStates

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerStates = set of TPlayerState ;

mAirListScript
Class Tree
Index
Previous (TPlayerStateArray)
Next (TPlayerType)


Previous (TPlayerStates)
Next (TPlaylistImportStyle)

Name
TPlayerType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerType = ( ptOrdinaryPlayer , ptPFLPlayer , ptErrorCheck ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerStates)
Next (TPlaylistImportStyle)


Previous (TPlayerType)
Next (TPlaylistImportStyles)

Name
TPlaylistImportStyle

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistImportStyle = ( isDay , isHour , isBlock ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerType)
Next (TPlaylistImportStyles)


Previous (TPlaylistImportStyle)
Next (TPlaylistItemCapabilities)

Name
TPlaylistImportStyles

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistImportStyles = set of TPlaylistImportStyle ;

mAirListScript
Class Tree
Index
Previous (TPlaylistImportStyle)
Next (TPlaylistItemCapabilities)


Previous (TPlaylistImportStyles)
Next (TPlaylistItemCapability)

Name
TPlaylistItemCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapabilities = set of TPlaylistItemCapability ;

mAirListScript
Class Tree
Index
Previous (TPlaylistImportStyles)
Next (TPlaylistItemCapability)


Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)

Name
TPlaylistItemCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapability = ( picPlayable , picCueable , picEditDuration , picAutoCue ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)


Previous (TPlaylistItemCapability)
Next (TPlaylistItemFlag)

Name
TPlaylistItemCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCategory = ( picFile , picStream , picBreak , picCommand , picContainer , picDummy , picOther ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapability)
Next (TPlaylistItemFlag)


Previous (TPlaylistItemCategory)
Next (TPlaylistItemFlags)

Name
TPlaylistItemFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemFlag = ( pifDummy ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCategory)
Next (TPlaylistItemFlags)


Previous (TPlaylistItemFlag)
Next (TPlaylistItemOption)

Name
TPlaylistItemFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemFlags = set of TPlaylistItemFlag ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemFlag)
Next (TPlaylistItemOption)


Previous (TPlaylistItemFlags)
Next (TPlaylistItemOptions)

Name
TPlaylistItemOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOption = ( pioNoLogging , pioSkipInAutomation , pioFadeOutAll , pioNoFadeOut , pioNoFadeOutAfterStartNext , pioNoOverlap , pioAdjustTime , pioFadeOnStop , pioLinked , pioDontMoveToHistory , pioHourlyFixTime , pioNoPrebuffering , pioNoFileManager , pioVBR , pioExpandVariables , pioDontUpdateDuration , pioErrorCheckIgnore , pioErrorCheckError ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemFlags)
Next (TPlaylistItemOptions)


Previous (TPlaylistItemOption)
Next (TPlaylistItemState)

Name
TPlaylistItemOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOptions = set of TPlaylistItemOption ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOption)
Next (TPlaylistItemState)


Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlag)

Name
TPlaylistItemState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemState = ( pisNormal , pisPlaying , pisHistory ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlag)


Previous (TPlaylistItemState)
Next (TPlaylistItemStatusFlags)

Name
TPlaylistItemStatusFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatusFlag = ( pisfInLinkChain , pisfError , pisfPrebufferError , pisfFixedStart , pisfFixedStartWait , pisfOverflow , pisfWasStarted , pisfPrebuffering , pisfRealtime ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemState)
Next (TPlaylistItemStatusFlags)


Previous (TPlaylistItemStatusFlag)
Next (TPlaylistItemType)

Name
TPlaylistItemStatusFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatusFlags = set of TPlaylistItemStatusFlag ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatusFlag)
Next (TPlaylistItemType)


Previous (TPlaylistItemStatusFlags)
Next (TPlaylistItemTypes)

Name
TPlaylistItemType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemType = ( pitUnknown , pitMusic , pitVoice , pitNews , pitWeather , pitTraffic , pitAdvertising , pitPackage , pitJingle , pitSound , pitEffect , pitTrailer , pitPromo , pitSponsorship , pitSweeper , pitDrop , pitStationID , pitBed , pitInstrumental , pitShow , pitStream , pitContainer , pitCommand , pitBreak , pitDummy , pitSilence , pitOther , pitCustom1 , pitCustom2 , pitCustom3 , pitCustom4 ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatusFlags)
Next (TPlaylistItemTypes)


Previous (TPlaylistItemType)
Next (TPlaylistSplitMode)

Name
TPlaylistItemTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemTypes = set of TPlaylistItemType ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemType)
Next (TPlaylistSplitMode)


Previous (TPlaylistItemTypes)
Next (TPlaylistSplitModes)

Name
TPlaylistSplitMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistSplitMode = ( smAutomatic , smNone , smFixedTime , smDuration , smTitle , smExactTitle ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemTypes)
Next (TPlaylistSplitModes)


Previous (TPlaylistSplitMode)
Next (TProgressRateMode)

Name
TPlaylistSplitModes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistSplitModes = set of TPlaylistSplitMode ;

mAirListScript
Class Tree
Index
Previous (TPlaylistSplitMode)
Next (TProgressRateMode)


Previous (TPlaylistSplitModes)
Next (TRepositoryItem)

Name
TProgressRateMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TProgressRateMode = ( rmNone , rmNormal , rmPercent , rmNumber , rmBytes ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistSplitModes)
Next (TRepositoryItem)


Previous (TProgressRateMode)
Next (TRunMode)

Name
TRepositoryItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRepositoryItem = ( riHookOpener , riHookSweeper , riHookCloser ) ;

mAirListScript
Class Tree
Index
Previous (TProgressRateMode)
Next (TRunMode)


Previous (TRepositoryItem)
Next (TSampleFormat)

Name
TRunMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRunMode = ( rmUnknown , rmPlayout , rmConfig , rmTagging , rmDatabase , rmDBServer ) ;

mAirListScript
Class Tree
Index
Previous (TRepositoryItem)
Next (TSampleFormat)


Previous (TRunMode)
Next (TSetOfByte)

Name
TSampleFormat

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSampleFormat = ( sfFloat , sf16bit ) ;

mAirListScript
Class Tree
Index
Previous (TRunMode)
Next (TSetOfByte)


Previous (TSampleFormat)
Next (TSingleArray)

Name
TSetOfByte

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSetOfByte = set of byte ;

mAirListScript
Class Tree
Index
Previous (TSampleFormat)
Next (TSingleArray)


Previous (TSetOfByte)
Next (TSkipRetryAbort)

Name
TSingleArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSingleArray = array of single ;

mAirListScript
Class Tree
Index
Previous (TSetOfByte)
Next (TSkipRetryAbort)


Previous (TSingleArray)
Next (TSourceControlOption)

Name
TSkipRetryAbort

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSkipRetryAbort = ( srtSkip , srtRetry , srtAbort ) ;

mAirListScript
Class Tree
Index
Previous (TSingleArray)
Next (TSourceControlOption)


Previous (TSkipRetryAbort)
Next (TSourceControlOptions)

Name
TSourceControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOption = ( scoAutoFadeOut , scoAutoCueOut , scoAutoRewind , scoHookMode , scoLoop , scoLogging , scoWorkActionLists ) ;

mAirListScript
Class Tree
Index
Previous (TSkipRetryAbort)
Next (TSourceControlOptions)


Previous (TSourceControlOption)
Next (TSourceControlState)

Name
TSourceControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOptions = set of TSourceControlOption ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOption)
Next (TSourceControlState)


Previous (TSourceControlOptions)
Next (TStandardActionList)

Name
TSourceControlState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlState = ( scsStopped , scsPlaying , scsPaused , scsFading , scsEOF ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOptions)
Next (TStandardActionList)


Previous (TSourceControlState)
Next (TStartTimeType)

Name
TStandardActionList

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStandardActionList = ( salMenu , salStartup , salShutdown , salPlaylistEmpty , salOnAir , salOffAir , salPFLOn , salPFLOff ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlState)
Next (TStartTimeType)


Previous (TStandardActionList)
Next (TTimeValue)

Name
TStartTimeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStartTimeType = ( sttStarted , sttCalculated , sttReal , sttSinceLastBreak ) ;

mAirListScript
Class Tree
Index
Previous (TStandardActionList)
Next (TTimeValue)


Previous (TStartTimeType)
Next (TTimeValueArray)

Name
TTimeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTimeValue = double ;

mAirListScript
Class Tree
Index
Previous (TStartTimeType)
Next (TTimeValueArray)


Previous (TTimeValue)
Next (TTiming)

Name
TTimeValueArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTimeValueArray = array of TTimeValue ;

mAirListScript
Class Tree
Index
Previous (TTimeValue)
Next (TTiming)


Previous (TTimeValueArray)
Next (TWeekdayHourFilter)

Name
TTiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTiming = ( timNormal , timHard , timSoft , timBacktimed , timExcluded ) ;

mAirListScript
Class Tree
Index
Previous (TTimeValueArray)
Next (TWeekdayHourFilter)


Previous (TTiming)
Next

Name
TWeekdayHourFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TWeekdayHourFilter = array [ 1 .. 7 ] of THourFilter ;

mAirListScript
Class Tree
Index
Previous (TTiming)
Next


Previous
Next (AllDatabaseSearchFields)

Name
AllCuePositionTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllCuePositionTypes = [ ptCueIn , ptFadeIn , ptRamp1 , ptRamp2 , ptRamp3 , ptHookIn , ptHookFade , ptHookOut , ptLoopIn , ptLoopOut , ptOutro , ptStartNext , ptFadeOut , ptCueOut , ptAnchor ]

mAirListScript
Class Tree
Index
Previous
Next (AllDatabaseSearchFields)


Previous (AllCuePositionTypes)
Next (AllFileImportTasks)

Name
AllDatabaseSearchFields

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllDatabaseSearchFields = [ dbsfArtist , dbsfTitle , dbsfComment , dbsfDuration , dbsfID , dbsfExternalID , dbsfStandardAttributes , dbsfAllAttributes ]

mAirListScript
Class Tree
Index
Previous (AllCuePositionTypes)
Next (AllFileImportTasks)


Previous (AllDatabaseSearchFields)
Next (AllLogCategories)

Name
AllFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllFileImportTasks = [ fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitNormalize , fitDatabaseLookup ]

mAirListScript
Class Tree
Index
Previous (AllDatabaseSearchFields)
Next (AllLogCategories)


Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)

Name
AllLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllLogCategories = [ lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ]

mAirListScript
Class Tree
Index
Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)


Previous (AllLogCategories)
Next (AllPlaylistItemTypes)

Name
AllPlaylistItemChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllPlaylistItemChangedDetails = $FFFFFFFF

mAirListScript
Class Tree
Index
Previous (AllLogCategories)
Next (AllPlaylistItemTypes)


Previous (AllPlaylistItemChangedDetails)
Next (AutoCuePositions)

Name
AllPlaylistItemTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllPlaylistItemTypes = [ pitUnknown , pitMusic , pitVoice , pitNews , pitWeather , pitTraffic , pitAdvertising , pitPackage , pitJingle , pitSound , pitEffect , pitTrailer , pitPromo , pitSponsorship , pitSweeper , pitDrop , pitStationID , pitBed , pitInstrumental , pitShow , pitStream , pitContainer , pitCommand , pitBreak , pitDummy , pitSilence , pitOther , pitCustom1 , pitCustom2 , pitCustom3 , pitCustom4 ]

mAirListScript
Class Tree
Index
Previous (AllPlaylistItemChangedDetails)
Next (AutoCuePositions)


Previous (AllPlaylistItemTypes)
Next (CartwallTriggerActionsWithOtherItem)

Name
AutoCuePositions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AutoCuePositions = [ ptCueIn , ptFadeOut , ptCueOut ]

mAirListScript
Class Tree
Index
Previous (AllPlaylistItemTypes)
Next (CartwallTriggerActionsWithOtherItem)


Previous (AutoCuePositions)
Next (ccBASS)

Name
CartwallTriggerActionsWithOtherItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
CartwallTriggerActionsWithOtherItem = [ taStartItem , taStopItem , taFadeOutItem ]

mAirListScript
Class Tree
Index
Previous (AutoCuePositions)
Next (ccBASS)


Previous (CartwallTriggerActionsWithOtherItem)
Next (ccCustom)

Name
ccBASS

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccBASS = 'bass'

mAirListScript
Class Tree
Index
Previous (CartwallTriggerActionsWithOtherItem)
Next (ccCustom)


Previous (ccBASS)
Next (ccDatabase)

Name
ccCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccCustom = 'custom'

mAirListScript
Class Tree
Index
Previous (ccBASS)
Next (ccDatabase)


Previous (ccCustom)
Next (ccDefaultDirectories)

Name
ccDatabase

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDatabase = 'database'

mAirListScript
Class Tree
Index
Previous (ccCustom)
Next (ccDefaultDirectories)


Previous (ccDatabase)
Next (ccDemoLicense)

Name
ccDefaultDirectories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDefaultDirectories = 'defaultdirectories'

mAirListScript
Class Tree
Index
Previous (ccDatabase)
Next (ccDemoLicense)


Previous (ccDefaultDirectories)
Next (ccDevices)

Name
ccDemoLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDemoLicense = 'demolicense'

mAirListScript
Class Tree
Index
Previous (ccDefaultDirectories)
Next (ccDevices)


Previous (ccDemoLicense)
Next (ccEncoder)

Name
ccDevices

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDevices = 'devices'

mAirListScript
Class Tree
Index
Previous (ccDemoLicense)
Next (ccEncoder)


Previous (ccDevices)
Next (ccGUI)

Name
ccEncoder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccEncoder = 'encoder'

mAirListScript
Class Tree
Index
Previous (ccDevices)
Next (ccGUI)


Previous (ccEncoder)
Next (ccLayout)

Name
ccGUI

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccGUI = 'gui'

mAirListScript
Class Tree
Index
Previous (ccEncoder)
Next (ccLayout)


Previous (ccGUI)
Next (ccLicense)

Name
ccLayout

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLayout = 'layout'

mAirListScript
Class Tree
Index
Previous (ccGUI)
Next (ccLicense)


Previous (ccLayout)
Next (ccLogging)

Name
ccLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLicense = 'license'

mAirListScript
Class Tree
Index
Previous (ccLayout)
Next (ccLogging)


Previous (ccLicense)
Next (ccMain)

Name
ccLogging

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLogging = 'logging'

mAirListScript
Class Tree
Index
Previous (ccLicense)
Next (ccMain)


Previous (ccLogging)
Next (ccMixdown)

Name
ccMain

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMain = 'mAirList'

mAirListScript
Class Tree
Index
Previous (ccLogging)
Next (ccMixdown)


Previous (ccMain)
Next (ccPasswords)

Name
ccMixdown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMixdown = 'mixdown'

mAirListScript
Class Tree
Index
Previous (ccMain)
Next (ccPasswords)


Previous (ccMixdown)
Next (ccPosition)

Name
ccPasswords

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPasswords = 'passwords'

mAirListScript
Class Tree
Index
Previous (ccMixdown)
Next (ccPosition)


Previous (ccPasswords)
Next (ccPreferences)

Name
ccPosition

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPosition = 'position'

mAirListScript
Class Tree
Index
Previous (ccPasswords)
Next (ccPreferences)


Previous (ccPosition)
Next (ccRemote)

Name
ccPreferences

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPreferences = 'preferences'

mAirListScript
Class Tree
Index
Previous (ccPosition)
Next (ccRemote)


Previous (ccPreferences)
Next (ccScreenObjects)

Name
ccRemote

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccRemote = 'remote'

mAirListScript
Class Tree
Index
Previous (ccPreferences)
Next (ccScreenObjects)


Previous (ccRemote)
Next (ccSerial)

Name
ccScreenObjects

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccScreenObjects = 'screenobjects'

mAirListScript
Class Tree
Index
Previous (ccRemote)
Next (ccSerial)


Previous (ccScreenObjects)
Next (cdADCAssignment)

Name
ccSerial

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccSerial = 'serial'

mAirListScript
Class Tree
Index
Previous (ccScreenObjects)
Next (cdADCAssignment)


Previous (ccSerial)
Next (cdADCNodes)

Name
cdADCAssignment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdADCAssignment = 2

mAirListScript
Class Tree
Index
Previous (ccSerial)
Next (cdADCNodes)


Previous (cdADCAssignment)
Next (cdBLContent)

Name
cdADCNodes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdADCNodes = 1

mAirListScript
Class Tree
Index
Previous (cdADCAssignment)
Next (cdBLContent)


Previous (cdADCNodes)
Next (cdCNumbering)

Name
cdBLContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdBLContent = 1

mAirListScript
Class Tree
Index
Previous (cdADCNodes)
Next (cdCNumbering)


Previous (cdBLContent)
Next (cdCOGeneral)

Name
cdCNumbering

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCNumbering = 2

mAirListScript
Class Tree
Index
Previous (cdBLContent)
Next (cdCOGeneral)


Previous (cdCNumbering)
Next (cdCOnAirMode)

Name
cdCOGeneral

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOGeneral = 1

mAirListScript
Class Tree
Index
Previous (cdCNumbering)
Next (cdCOnAirMode)


Previous (cdCOGeneral)
Next (cdCOptions)

Name
cdCOnAirMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOnAirMode = 1

mAirListScript
Class Tree
Index
Previous (cdCOGeneral)
Next (cdCOptions)


Previous (cdCOnAirMode)
Next (cdCORestartCritical)

Name
cdCOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOptions = 4

mAirListScript
Class Tree
Index
Previous (cdCOnAirMode)
Next (cdCORestartCritical)


Previous (cdCOptions)
Next (cdCOStatus)

Name
cdCORestartCritical

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCORestartCritical = 4

mAirListScript
Class Tree
Index
Previous (cdCOptions)
Next (cdCOStatus)


Previous (cdCORestartCritical)
Next (cdCOther)

Name
cdCOStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOStatus = 2

mAirListScript
Class Tree
Index
Previous (cdCORestartCritical)
Next (cdCOther)


Previous (cdCOStatus)
Next (cdDBConnectionDetails)

Name
cdCOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOther = 8

mAirListScript
Class Tree
Index
Previous (cdCOStatus)
Next (cdDBConnectionDetails)


Previous (cdCOther)
Next (cdDBOther)

Name
cdDBConnectionDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBConnectionDetails = $10004

mAirListScript
Class Tree
Index
Previous (cdCOther)
Next (cdDBOther)


Previous (cdDBConnectionDetails)
Next (cdDBState)

Name
cdDBOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBOther = $40000

mAirListScript
Class Tree
Index
Previous (cdDBConnectionDetails)
Next (cdDBState)


Previous (cdDBOther)
Next (cdForceUpdate)

Name
cdDBState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBState = $20000

mAirListScript
Class Tree
Index
Previous (cdDBOther)
Next (cdForceUpdate)


Previous (cdDBState)
Next (cdLCIIndex)

Name
cdForceUpdate

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdForceUpdate = $8000000

mAirListScript
Class Tree
Index
Previous (cdDBState)
Next (cdLCIIndex)


Previous (cdForceUpdate)
Next (cdLCIItem)

Name
cdLCIIndex

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCIIndex = 8

mAirListScript
Class Tree
Index
Previous (cdForceUpdate)
Next (cdLCIItem)


Previous (cdLCIIndex)
Next (cdLCIRect)

Name
cdLCIItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCIItem = 2

mAirListScript
Class Tree
Index
Previous (cdLCIIndex)
Next (cdLCIRect)


Previous (cdLCIItem)
Next (cdLCIState)

Name
cdLCIRect

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCIRect = 4

mAirListScript
Class Tree
Index
Previous (cdLCIItem)
Next (cdLCIState)


Previous (cdLCIRect)
Next (cdLCPItems)

Name
cdLCIState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCIState = 1

mAirListScript
Class Tree
Index
Previous (cdLCIRect)
Next (cdLCPItems)


Previous (cdLCIState)
Next (cdLCPItemsItem)

Name
cdLCPItems

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCPItems = 1

mAirListScript
Class Tree
Index
Previous (cdLCIState)
Next (cdLCPItemsItem)


Previous (cdLCPItems)
Next (cdLCPPlayer)

Name
cdLCPItemsItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCPItemsItem = 2

mAirListScript
Class Tree
Index
Previous (cdLCPItems)
Next (cdLCPPlayer)


Previous (cdLCPItemsItem)
Next (cdMDBacktiming)

Name
cdLCPPlayer

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdLCPPlayer = 4

mAirListScript
Class Tree
Index
Previous (cdLCPItemsItem)
Next (cdMDBacktiming)


Previous (cdLCPPlayer)
Next (cdMDFlags)

Name
cdMDBacktiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDBacktiming = $0002

mAirListScript
Class Tree
Index
Previous (cdLCPPlayer)
Next (cdMDFlags)


Previous (cdMDBacktiming)
Next (cdMDGeneral)

Name
cdMDFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDFlags = $0010

mAirListScript
Class Tree
Index
Previous (cdMDBacktiming)
Next (cdMDGeneral)


Previous (cdMDFlags)
Next (cdMDLink)

Name
cdMDGeneral

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDGeneral = $0001

mAirListScript
Class Tree
Index
Previous (cdMDFlags)
Next (cdMDLink)


Previous (cdMDGeneral)
Next (cdMDState)

Name
cdMDLink

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDLink = $0008

mAirListScript
Class Tree
Index
Previous (cdMDGeneral)
Next (cdMDState)


Previous (cdMDLink)
Next (cdMDStatus)

Name
cdMDState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDState = $0004

mAirListScript
Class Tree
Index
Previous (cdMDLink)
Next (cdMDStatus)


Previous (cdMDState)
Next (cdMDTiming)

Name
cdMDStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDStatus = $0040

mAirListScript
Class Tree
Index
Previous (cdMDState)
Next (cdMDTiming)


Previous (cdMDStatus)
Next (cdOwner)

Name
cdMDTiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDTiming = $0020

mAirListScript
Class Tree
Index
Previous (cdMDStatus)
Next (cdOwner)


Previous (cdMDTiming)
Next (cdPCAllowAutomation)

Name
cdOwner

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdOwner = $4000000

mAirListScript
Class Tree
Index
Previous (cdMDTiming)
Next (cdPCAllowAutomation)


Previous (cdOwner)
Next (cdPCAutomation)

Name
cdPCAllowAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAllowAutomation = 4

mAirListScript
Class Tree
Index
Previous (cdOwner)
Next (cdPCAutomation)


Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)

Name
cdPCAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomation = 1

mAirListScript
Class Tree
Index
Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)


Previous (cdPCAutomation)
Next (cdPCOptions)

Name
cdPCAutomationPlaying

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomationPlaying = 2

mAirListScript
Class Tree
Index
Previous (cdPCAutomation)
Next (cdPCOptions)


Previous (cdPCAutomationPlaying)
Next (cdPCPlayerAssignment)

Name
cdPCOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCOptions = 64

mAirListScript
Class Tree
Index
Previous (cdPCAutomationPlaying)
Next (cdPCPlayerAssignment)


Previous (cdPCOptions)
Next (cdPCPlayerCount)

Name
cdPCPlayerAssignment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayerAssignment = 16

mAirListScript
Class Tree
Index
Previous (cdPCOptions)
Next (cdPCPlayerCount)


Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)

Name
cdPCPlayerCount

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayerCount = 32

mAirListScript
Class Tree
Index
Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)


Previous (cdPCPlayerCount)
Next (cdPIColor)

Name
cdPIBacktimingStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIBacktimingStatus = $40

mAirListScript
Class Tree
Index
Previous (cdPCPlayerCount)
Next (cdPIColor)


Previous (cdPIBacktimingStatus)
Next (cdPIComment)

Name
cdPIColor

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIColor = $1000

mAirListScript
Class Tree
Index
Previous (cdPIBacktimingStatus)
Next (cdPIComment)


Previous (cdPIColor)
Next (cdPIContent)

Name
cdPIComment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIComment = $400

mAirListScript
Class Tree
Index
Previous (cdPIColor)
Next (cdPIContent)


Previous (cdPIComment)
Next (cdPICueData)

Name
cdPIContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIContent = $2000

mAirListScript
Class Tree
Index
Previous (cdPIComment)
Next (cdPICueData)


Previous (cdPIContent)
Next (cdPIDuration)

Name
cdPICueData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPICueData = $4000

mAirListScript
Class Tree
Index
Previous (cdPIContent)
Next (cdPIDuration)


Previous (cdPICueData)
Next (cdPIHistoryFlag)

Name
cdPIDuration

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIDuration = $1

mAirListScript
Class Tree
Index
Previous (cdPICueData)
Next (cdPIHistoryFlag)


Previous (cdPIDuration)
Next (cdPIIcon)

Name
cdPIHistoryFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIHistoryFlag = $800

mAirListScript
Class Tree
Index
Previous (cdPIDuration)
Next (cdPIIcon)


Previous (cdPIHistoryFlag)
Next (cdPIItemData)

Name
cdPIIcon

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIIcon = $10000

mAirListScript
Class Tree
Index
Previous (cdPIHistoryFlag)
Next (cdPIItemData)


Previous (cdPIIcon)
Next (cdPILinked)

Name
cdPIItemData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIItemData = $8

mAirListScript
Class Tree
Index
Previous (cdPIIcon)
Next (cdPILinked)


Previous (cdPIItemData)
Next (cdPIMetadata)

Name
cdPILinked

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPILinked = $200

mAirListScript
Class Tree
Index
Previous (cdPIItemData)
Next (cdPIMetadata)


Previous (cdPILinked)
Next (cdPIOther)

Name
cdPIMetadata

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIMetadata = $8000

mAirListScript
Class Tree
Index
Previous (cdPILinked)
Next (cdPIOther)


Previous (cdPIMetadata)
Next (cdPIPitch)

Name
cdPIOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIOther = $40000

mAirListScript
Class Tree
Index
Previous (cdPIMetadata)
Next (cdPIPitch)


Previous (cdPIOther)
Next (cdPIPositionAlternatives)

Name
cdPIPitch

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPitch = $100

mAirListScript
Class Tree
Index
Previous (cdPIOther)
Next (cdPIPositionAlternatives)


Previous (cdPIPitch)
Next (cdPIPositionValue)

Name
cdPIPositionAlternatives

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionAlternatives = $4

mAirListScript
Class Tree
Index
Previous (cdPIPitch)
Next (cdPIPositionValue)


Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)

Name
cdPIPositionValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionValue = $2

mAirListScript
Class Tree
Index
Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)


Previous (cdPIPositionValue)
Next (cdPItem)

Name
cdPIStartTimes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIStartTimes = $10

mAirListScript
Class Tree
Index
Previous (cdPIPositionValue)
Next (cdPItem)


Previous (cdPIStartTimes)
Next (cdPITempo)

Name
cdPItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPItem = 4

mAirListScript
Class Tree
Index
Previous (cdPIStartTimes)
Next (cdPITempo)


Previous (cdPItem)
Next (cdPIUnknown)

Name
cdPITempo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPITempo = $80

mAirListScript
Class Tree
Index
Previous (cdPItem)
Next (cdPIUnknown)


Previous (cdPITempo)
Next (cdPIVolumeEnvelope)

Name
cdPIUnknown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIUnknown = $20

mAirListScript
Class Tree
Index
Previous (cdPITempo)
Next (cdPIVolumeEnvelope)


Previous (cdPIUnknown)
Next (cdPLBacktiming)

Name
cdPIVolumeEnvelope

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIVolumeEnvelope = $20000

mAirListScript
Class Tree
Index
Previous (cdPIUnknown)
Next (cdPLBacktiming)


Previous (cdPIVolumeEnvelope)
Next (cdPLevelInfo)

Name
cdPLBacktiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPLBacktiming = 2

mAirListScript
Class Tree
Index
Previous (cdPIVolumeEnvelope)
Next (cdPLevelInfo)


Previous (cdPLBacktiming)
Next (cdPOptions)

Name
cdPLevelInfo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPLevelInfo = 16

mAirListScript
Class Tree
Index
Previous (cdPLBacktiming)
Next (cdPOptions)


Previous (cdPLevelInfo)
Next (cdPOther)

Name
cdPOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPOptions = 8

mAirListScript
Class Tree
Index
Previous (cdPLevelInfo)
Next (cdPOther)


Previous (cdPOptions)
Next (cdPVolume)

Name
cdPOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPOther = 1

mAirListScript
Class Tree
Index
Previous (cdPOptions)
Next (cdPVolume)


Previous (cdPOther)
Next (cdSCVolume)

Name
cdPVolume

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPVolume = 2

mAirListScript
Class Tree
Index
Previous (cdPOther)
Next (cdSCVolume)


Previous (cdPVolume)
Next (ConfigTimePlaybackControlOptions)

Name
cdSCVolume

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdSCVolume = 1

mAirListScript
Class Tree
Index
Previous (cdPVolume)
Next (ConfigTimePlaybackControlOptions)


Previous (cdSCVolume)
Next (DefaultCartwallOptions)

Name
ConfigTimePlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ConfigTimePlaybackControlOptions = [ plcoAllowAutomation ]

mAirListScript
Class Tree
Index
Previous (cdSCVolume)
Next (DefaultCartwallOptions)


Previous (ConfigTimePlaybackControlOptions)
Next (DefaultEngineOptions)

Name
DefaultCartwallOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultCartwallOptions = [ coSaveWithTemplate , coLogging , coAlwaysShowGrid , coAlwaysShowGridNumbers , coShowIcons ]

mAirListScript
Class Tree
Index
Previous (ConfigTimePlaybackControlOptions)
Next (DefaultEngineOptions)


Previous (DefaultCartwallOptions)
Next (DefaultFeatures)

Name
DefaultEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultEngineOptions = [ ]

mAirListScript
Class Tree
Index
Previous (DefaultCartwallOptions)
Next (DefaultFeatures)


Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)

Name
DefaultFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFeatures = [ mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ]

mAirListScript
Class Tree
Index
Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)


Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)

Name
DefaultFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileImportOptions = [ fioImportComment , fioImportTags , fioTildeAsFadeOut , fioStripWhitespace , fioImportReplayGain , fioReplayGainPreventClipping , fioArtistTitleFromFilename ]

mAirListScript
Class Tree
Index
Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)


Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)

Name
DefaultFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileManagementOptions = [ fmoCacheNetworkFiles ]

mAirListScript
Class Tree
Index
Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)


Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)

Name
DefaultGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultGlobalOptions = [ goFadeOutEffectiveEnd , goOutroEOFWarning , goStartOnAir , goNoLoggingOffAir , goSplashScreen , goControlPanelAutoSave ]

mAirListScript
Class Tree
Index
Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)


Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)

Name
DefaultPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlaybackControlOptions = [ plcoAllowAutomation , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime , plcoFixedTimeWaitHard ]

mAirListScript
Class Tree
Index
Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)


Previous (DefaultPlaybackControlOptions)
Next (MAX_REGION)

Name
DefaultPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlayerControlOptions = [ poAutoLoad , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poUseInAutomation , poHistoryOnClose , poLogging , poIndependentPFLEndMon ]

mAirListScript
Class Tree
Index
Previous (DefaultPlaybackControlOptions)
Next (MAX_REGION)


Previous (DefaultPlayerControlOptions)
Next (MIN_DB)

Name
MAX_REGION

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MAX_REGION = 255

mAirListScript
Class Tree
Index
Previous (DefaultPlayerControlOptions)
Next (MIN_DB)


Previous (MAX_REGION)
Next (MIN_REGION)

Name
MIN_DB

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MIN_DB = - 999

mAirListScript
Class Tree
Index
Previous (MAX_REGION)
Next (MIN_REGION)


Previous (MIN_DB)
Next (NoObjectID)

Name
MIN_REGION

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MIN_REGION = 1

mAirListScript
Class Tree
Index
Previous (MIN_DB)
Next (NoObjectID)


Previous (MIN_REGION)
Next (ntAdvertisingAll)

Name
NoObjectID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
NoObjectID = 0

mAirListScript
Class Tree
Index
Previous (MIN_REGION)
Next (ntAdvertisingAll)


Previous (NoObjectID)
Next (ntAdvertisingCurrent)

Name
ntAdvertisingAll

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAdvertisingAll = 17

mAirListScript
Class Tree
Index
Previous (NoObjectID)
Next (ntAdvertisingCurrent)


Previous (ntAdvertisingAll)
Next (ntAdvertisingRoot)

Name
ntAdvertisingCurrent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAdvertisingCurrent = 16

mAirListScript
Class Tree
Index
Previous (ntAdvertisingAll)
Next (ntAdvertisingRoot)


Previous (ntAdvertisingCurrent)
Next (ntArtist)

Name
ntAdvertisingRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAdvertisingRoot = 15

mAirListScript
Class Tree
Index
Previous (ntAdvertisingCurrent)
Next (ntArtist)


Previous (ntAdvertisingRoot)
Next (ntArtistRoot)

Name
ntArtist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntArtist = 14

mAirListScript
Class Tree
Index
Previous (ntAdvertisingRoot)
Next (ntArtistRoot)


Previous (ntArtist)
Next (ntAttribute)

Name
ntArtistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntArtistRoot = 6

mAirListScript
Class Tree
Index
Previous (ntArtist)
Next (ntAttribute)


Previous (ntArtistRoot)
Next (ntAttributeRange)

Name
ntAttribute

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttribute = 9

mAirListScript
Class Tree
Index
Previous (ntArtistRoot)
Next (ntAttributeRange)


Previous (ntAttribute)
Next (ntAttributeRoot)

Name
ntAttributeRange

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeRange = 11

mAirListScript
Class Tree
Index
Previous (ntAttribute)
Next (ntAttributeRoot)


Previous (ntAttributeRange)
Next (ntAttributeValue)

Name
ntAttributeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeRoot = 8

mAirListScript
Class Tree
Index
Previous (ntAttributeRange)
Next (ntAttributeValue)


Previous (ntAttributeRoot)
Next (ntCustom)

Name
ntAttributeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeValue = 10

mAirListScript
Class Tree
Index
Previous (ntAttributeRoot)
Next (ntCustom)


Previous (ntAttributeValue)
Next (ntFolder)

Name
ntCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntCustom = 128

mAirListScript
Class Tree
Index
Previous (ntAttributeValue)
Next (ntFolder)


Previous (ntCustom)
Next (ntFolderRoot)

Name
ntFolder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolder = 7

mAirListScript
Class Tree
Index
Previous (ntCustom)
Next (ntFolderRoot)


Previous (ntFolder)
Next (ntItem)

Name
ntFolderRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolderRoot = 5

mAirListScript
Class Tree
Index
Previous (ntFolder)
Next (ntItem)


Previous (ntFolderRoot)
Next (ntPlaylist)

Name
ntItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntItem = 1

mAirListScript
Class Tree
Index
Previous (ntFolderRoot)
Next (ntPlaylist)


Previous (ntItem)
Next (ntPlaylistRoot)

Name
ntPlaylist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylist = 3

mAirListScript
Class Tree
Index
Previous (ntItem)
Next (ntPlaylistRoot)


Previous (ntPlaylist)
Next (ntRoot)

Name
ntPlaylistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylistRoot = 2

mAirListScript
Class Tree
Index
Previous (ntPlaylist)
Next (ntRoot)


Previous (ntPlaylistRoot)
Next (ntText)

Name
ntRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntRoot = 0

mAirListScript
Class Tree
Index
Previous (ntPlaylistRoot)
Next (ntText)


Previous (ntRoot)
Next (ntType)

Name
ntText

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntText = 4

mAirListScript
Class Tree
Index
Previous (ntRoot)
Next (ntType)


Previous (ntText)
Next (ntTypeRoot)

Name
ntType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntType = 13

mAirListScript
Class Tree
Index
Previous (ntText)
Next (ntTypeRoot)


Previous (ntType)
Next (OrdinaryPlayerCommands)

Name
ntTypeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntTypeRoot = 12

mAirListScript
Class Tree
Index
Previous (ntType)
Next (OrdinaryPlayerCommands)


Previous (ntTypeRoot)
Next (PEAKDATA_LENGTH)

Name
OrdinaryPlayerCommands

Parent
mAirListTypes

Visibility
PUBLIC

Source code
OrdinaryPlayerCommands = [ pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose ]

mAirListScript
Class Tree
Index
Previous (ntTypeRoot)
Next (PEAKDATA_LENGTH)


Previous (OrdinaryPlayerCommands)
Next (pidAmplification)

Name
PEAKDATA_LENGTH

Parent
mAirListTypes

Visibility
PUBLIC

Source code
PEAKDATA_LENGTH = 4096

mAirListScript
Class Tree
Index
Previous (OrdinaryPlayerCommands)
Next (pidAmplification)


Previous (PEAKDATA_LENGTH)
Next (pidArtist)

Name
pidAmplification

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidAmplification = $00001000

mAirListScript
Class Tree
Index
Previous (PEAKDATA_LENGTH)
Next (pidArtist)


Previous (pidAmplification)
Next (pidAttributes)

Name
pidArtist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidArtist = $00000001

mAirListScript
Class Tree
Index
Previous (pidAmplification)
Next (pidAttributes)


Previous (pidArtist)
Next (pidColor)

Name
pidAttributes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidAttributes = $00000020

mAirListScript
Class Tree
Index
Previous (pidArtist)
Next (pidColor)


Previous (pidAttributes)
Next (pidComment)

Name
pidColor

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidColor = $00004000

mAirListScript
Class Tree
Index
Previous (pidAttributes)
Next (pidComment)


Previous (pidColor)
Next (pidContainerContent)

Name
pidComment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidComment = $00000100

mAirListScript
Class Tree
Index
Previous (pidColor)
Next (pidContainerContent)


Previous (pidComment)
Next (pidCueData)

Name
pidContainerContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidContainerContent = $00200000

mAirListScript
Class Tree
Index
Previous (pidComment)
Next (pidCueData)


Previous (pidContainerContent)
Next (pidCueMarkers)

Name
pidCueData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidCueData = $00000200

mAirListScript
Class Tree
Index
Previous (pidContainerContent)
Next (pidCueMarkers)


Previous (pidCueData)
Next (pidCustomizationFlag)

Name
pidCueMarkers

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidCueMarkers = $00000400

mAirListScript
Class Tree
Index
Previous (pidCueData)
Next (pidCustomizationFlag)


Previous (pidCueMarkers)
Next (pidDatabaseLink)

Name
pidCustomizationFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidCustomizationFlag = $00100000

mAirListScript
Class Tree
Index
Previous (pidCueMarkers)
Next (pidDatabaseLink)


Previous (pidCustomizationFlag)
Next (pidDuration)

Name
pidDatabaseLink

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidDatabaseLink = $00000080

mAirListScript
Class Tree
Index
Previous (pidCustomizationFlag)
Next (pidDuration)


Previous (pidDatabaseLink)
Next (pidEndType)

Name
pidDuration

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidDuration = $00000004

mAirListScript
Class Tree
Index
Previous (pidDatabaseLink)
Next (pidEndType)


Previous (pidDuration)
Next (pidExternalID)

Name
pidEndType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidEndType = $00002000

mAirListScript
Class Tree
Index
Previous (pidDuration)
Next (pidExternalID)


Previous (pidEndType)
Next (pidFadeDuration)

Name
pidExternalID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidExternalID = $00040000

mAirListScript
Class Tree
Index
Previous (pidEndType)
Next (pidFadeDuration)


Previous (pidExternalID)
Next (pidFilename)

Name
pidFadeDuration

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidFadeDuration = $00000800

mAirListScript
Class Tree
Index
Previous (pidExternalID)
Next (pidFilename)


Previous (pidFadeDuration)
Next (pidIcon)

Name
pidFilename

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidFilename = $00000010

mAirListScript
Class Tree
Index
Previous (pidFadeDuration)
Next (pidIcon)


Previous (pidFilename)
Next (pidInlineData)

Name
pidIcon

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidIcon = $00008000

mAirListScript
Class Tree
Index
Previous (pidFilename)
Next (pidInlineData)


Previous (pidIcon)
Next (pidItemType)

Name
pidInlineData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidInlineData = $00000040

mAirListScript
Class Tree
Index
Previous (pidIcon)
Next (pidItemType)


Previous (pidInlineData)
Next (pidPitch)

Name
pidItemType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidItemType = $00000008

mAirListScript
Class Tree
Index
Previous (pidInlineData)
Next (pidPitch)


Previous (pidItemType)
Next (pidTempo)

Name
pidPitch

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidPitch = $00010000

mAirListScript
Class Tree
Index
Previous (pidItemType)
Next (pidTempo)


Previous (pidPitch)
Next (pidTiming)

Name
pidTempo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidTempo = $00020000

mAirListScript
Class Tree
Index
Previous (pidPitch)
Next (pidTiming)


Previous (pidTempo)
Next (pidTitle)

Name
pidTiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidTiming = $00080000

mAirListScript
Class Tree
Index
Previous (pidTempo)
Next (pidTitle)


Previous (pidTiming)
Next (RuntimeOrdinaryPlayerControlOptions)

Name
pidTitle

Parent
mAirListTypes

Visibility
PUBLIC

Source code
pidTitle = $00000002

mAirListScript
Class Tree
Index
Previous (pidTiming)
Next (RuntimeOrdinaryPlayerControlOptions)


Previous (pidTitle)
Next

Name
RuntimeOrdinaryPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
RuntimeOrdinaryPlayerControlOptions = [ poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ]

mAirListScript
Class Tree
Index
Previous (pidTitle)
Next


Previous
Next

Name
ceh_task

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ceh_task : cardinal

mAirListScript
Class Tree
Index
Previous
Next


Previous (mAirListTypes)
Next (SASInterface)

Name
MidiInterface

Parent
mAirListScript

Classes
Class Description
IMidiRemote (+)
TMidiMessage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListTypes)
Next (SASInterface)


Previous
Next (TMidiMessage)

Name
IMidiRemote

Parent
MidiInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDevice (+)
GetEvents (+)
SetDevice (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (TMidiMessage)


Previous
Next (GetEvents)

Name
GetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetDevice : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEvents)


Previous (GetDevice)
Next (SetDevice)

Name
GetEvents

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetEvents : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDevice)
Next (SetDevice)


Previous (GetEvents)
Next

Name
SetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
procedure SetDevice ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetEvents)
Next


Previous (IMidiRemote)
Next

Name
TMidiMessage

Parent
MidiInterface

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Data1 (*)
Data2 (*)
Device (*)
MESSAGE (*)
Status (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMidiRemote)
Next


Previous
Next (Data2)

Name
Data1

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data1 : byte

mAirListScript
Class Tree
Index
Previous
Next (Data2)


Previous (Data1)
Next (Device)

Name
Data2

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data2 : byte

mAirListScript
Class Tree
Index
Previous (Data1)
Next (Device)


Previous (Data2)
Next (MESSAGE)

Name
Device

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Device : byte

mAirListScript
Class Tree
Index
Previous (Data2)
Next (MESSAGE)


Previous (Device)
Next (Status)

Name
MESSAGE

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
message : cardinal

mAirListScript
Class Tree
Index
Previous (Device)
Next (Status)


Previous (MESSAGE)
Next

Name
Status

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Status : byte

mAirListScript
Class Tree
Index
Previous (MESSAGE)
Next


Previous (MidiInterface)
Next (SimpleSQLInterface)

Name
SASInterface

Parent
mAirListScript

Classes
Class Description
IIPSASRemote (+)
ISASAction (+)
ISASRemote (+)
ISASSetFaderInputGainAction (+)
ISASSetFaderLevelAction (+)
ISASSetFaderStartOffAction (+)
ISASSetFaderStartOnAction (+)
ISASSetGPIAction (+)
ISASSetGPIOffAction (+)
ISASSetGPIOnAction (+)
ISASSetPFLOffAction (+)
ISASSetPFLOnAction (+)
ISASSourceAction (+)
ISASSourceLevelAction (+)
ISerialSASRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (MidiInterface)
Next (SimpleSQLInterface)


Previous
Next (ISASAction)

Name
IIPSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetHost (+)
GetPort (+)
SetHost (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (ISASAction)


Previous
Next (GetPort)

Name
GetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetHost : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (GetHost)
Next (SetHost)

Name
GetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHost)
Next (SetHost)


Previous (GetPort)
Next (SetPort)

Name
SetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetHost ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SetPort)


Previous (SetHost)
Next

Name
SetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetHost)
Next


Previous (IIPSASRemote)
Next (ISASRemote)

Name
ISASAction

Parent
SASInterface

Class Hierarchy
IRemoteAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIPSASRemote)
Next (ISASRemote)


Previous (ISASAction)
Next (ISASSetFaderInputGainAction)

Name
ISASRemote

Parent
SASInterface

Class Hierarchy
IRemote

Visibility
PUBLIC

Members
Methods
Method Description
FetchFaderLevel (+)
FetchFaderStatus (+)
GetAllSources (+)
GetFader (+)
GetFaderLevel (+)
GetFaderStatus (+)
GetGPIOffCommand (+)
GetGPIOnCommand (+)
GetOtherSources (+)
GetPlayerOptions (+)
GetPlayerSourceName (+)
GetVTMicSource (+)
GetVTPlayerASource (+)
GetVTPlayerBSource (+)
SendCommand (+)
SetFaderInputGain (+)
SetFaderLevel (+)
SetFaderStart (+)
SetGPI (+)
SetGPIOffCommand (+)
SetGPIOnCommand (+)
SetOtherSources (+)
SetPlayerOptions (+)
SetPlayerSourceName (+)
SetPrelisten1Off (+)
SetPrelisten1On (+)
SetVTMicSource (+)
SetVTPlayerASource (+)
SetVTPlayerBSource (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASAction)
Next (ISASSetFaderInputGainAction)


Previous
Next (FetchFaderStatus)

Name
FetchFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderLevel ( iSourceName : string )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (FetchFaderStatus)


Previous (FetchFaderLevel)
Next (GetAllSources)

Name
FetchFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderStatus ( iSourceName : string )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (FetchFaderLevel)
Next (GetAllSources)


Previous (FetchFaderStatus)
Next (GetFader)

Name
GetAllSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetAllSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FetchFaderStatus)
Next (GetFader)


Previous (GetAllSources)
Next (GetFaderLevel)

Name
GetFader

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFader ( iSourceName : string ) : byte

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetAllSources)
Next (GetFaderLevel)


Previous (GetFader)
Next (GetFaderStatus)

Name
GetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderLevel ( iSourceName : string ) : ShortInt

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFader)
Next (GetFaderStatus)


Previous (GetFaderLevel)
Next (GetGPIOffCommand)

Name
GetFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderStatus ( iSourceName : string ) : byte

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFaderLevel)
Next (GetGPIOffCommand)


Previous (GetFaderStatus)
Next (GetGPIOnCommand)

Name
GetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOffCommand ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFaderStatus)
Next (GetGPIOnCommand)


Previous (GetGPIOffCommand)
Next (GetOtherSources)

Name
GetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOnCommand ( iIndex : integer ) : string

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetGPIOffCommand)
Next (GetOtherSources)


Previous (GetGPIOnCommand)
Next (GetPlayerOptions)

Name
GetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetOtherSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGPIOnCommand)
Next (GetPlayerOptions)


Previous (GetOtherSources)
Next (GetPlayerSourceName)

Name
GetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerOptions ( iPlaylist , iPlayer : integer ) : TSASPlayerOptions

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iPlayer : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOtherSources)
Next (GetPlayerSourceName)


Previous (GetPlayerOptions)
Next (GetVTMicSource)

Name
GetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerSourceName ( iPlaylist , iPlayer : integer ) : string

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iPlayer : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPlayerOptions)
Next (GetVTMicSource)


Previous (GetPlayerSourceName)
Next (GetVTPlayerASource)

Name
GetVTMicSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTMicSource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerSourceName)
Next (GetVTPlayerASource)


Previous (GetVTMicSource)
Next (GetVTPlayerBSource)

Name
GetVTPlayerASource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTPlayerASource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTMicSource)
Next (GetVTPlayerBSource)


Previous (GetVTPlayerASource)
Next (SendCommand)

Name
GetVTPlayerBSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTPlayerBSource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTPlayerASource)
Next (SendCommand)


Previous (GetVTPlayerBSource)
Next (SetFaderInputGain)

Name
SendCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SendCommand ( iCommand : byte ; iData : RawByteString )

Parameters
Parameter | Description
iCommand : BYTE | &nbsp;
iData : RawByteString | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetVTPlayerBSource)
Next (SetFaderInputGain)


Previous (SendCommand)
Next (SetFaderLevel)

Name
SetFaderInputGain

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderInputGain ( iSourceName : string ; iLevel : ShortInt )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;
iLevel : SHORTINT | &nbsp;

mAirListScript
Class Tree
Index
Previous (SendCommand)
Next (SetFaderLevel)


Previous (SetFaderInputGain)
Next (SetFaderStart)

Name
SetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderLevel ( iSourceName : string ; iLevel : ShortInt ; iFadeTime : word )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;
iLevel : SHORTINT | &nbsp;
iFadeTime : WORD | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFaderInputGain)
Next (SetFaderStart)


Previous (SetFaderLevel)
Next (SetGPI)

Name
SetFaderStart

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderStart ( iSourceName : string ; iStatus : byte )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;
iStatus : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFaderLevel)
Next (SetGPI)


Previous (SetFaderStart)
Next (SetGPIOffCommand)

Name
SetGPI

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPI ( iNumber , iValue : byte )

Parameters
Parameter | Description
iNumber : BYTE | &nbsp;
iValue : BYTE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFaderStart)
Next (SetGPIOffCommand)


Previous (SetGPI)
Next (SetGPIOnCommand)

Name
SetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOffCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetGPI)
Next (SetGPIOnCommand)


Previous (SetGPIOffCommand)
Next (SetOtherSources)

Name
SetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOnCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetGPIOffCommand)
Next (SetOtherSources)


Previous (SetGPIOnCommand)
Next (SetPlayerOptions)

Name
SetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetOtherSources ( iValue : IStrings )

Parameters
Parameter | Description
iValue : IStrings | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetGPIOnCommand)
Next (SetPlayerOptions)


Previous (SetOtherSources)
Next (SetPlayerSourceName)

Name
SetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerOptions ( iPlaylist , iPlayer : integer ; iValue : TSASPlayerOptions )

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iPlayer : INTEGER | &nbsp;
iValue : TSASPlayerOptions | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOtherSources)
Next (SetPlayerSourceName)


Previous (SetPlayerOptions)
Next (SetPrelisten1Off)

Name
SetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerSourceName ( iPlaylist , iPlayer : integer ; iValue : string )

Parameters
Parameter | Description
iPlaylist : INTEGER | &nbsp;
iPlayer : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPlayerOptions)
Next (SetPrelisten1Off)


Previous (SetPlayerSourceName)
Next (SetPrelisten1On)

Name
SetPrelisten1Off

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1Off ( iSourceName : string )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPlayerSourceName)
Next (SetPrelisten1On)


Previous (SetPrelisten1Off)
Next (SetVTMicSource)

Name
SetPrelisten1On

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1On ( iSourceName : string )

Parameters
Parameter | Description
iSourceName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPrelisten1Off)
Next (SetVTMicSource)


Previous (SetPrelisten1On)
Next (SetVTPlayerASource)

Name
SetVTMicSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTMicSource ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetPrelisten1On)
Next (SetVTPlayerASource)


Previous (SetVTMicSource)
Next (SetVTPlayerBSource)

Name
SetVTPlayerASource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerASource ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVTMicSource)
Next (SetVTPlayerBSource)


Previous (SetVTPlayerASource)
Next

Name
SetVTPlayerBSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerBSource ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetVTPlayerASource)
Next


Previous (ISASRemote)
Next (ISASSetFaderLevelAction)

Name
ISASSetFaderInputGainAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASRemote)
Next (ISASSetFaderLevelAction)


Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)

Name
ISASSetFaderLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Members
Methods
Method Description
GetFadeTime (+)
SetFadeTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)


Previous
Next (SetFadeTime)

Name
GetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
function GetFadeTime : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetFadeTime)


Previous (GetFadeTime)
Next

Name
SetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
procedure SetFadeTime ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFadeTime)
Next


Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)

Name
ISASSetFaderStartOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)


Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)

Name
ISASSetFaderStartOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)


Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)

Name
ISASSetGPIAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetNumber (+)
SetNumber (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)


Previous
Next (SetNumber)

Name
GetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
function GetNumber : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetNumber)


Previous (GetNumber)
Next

Name
SetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
procedure SetNumber ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetNumber)
Next


Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)

Name
ISASSetGPIOffAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)


Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)

Name
ISASSetGPIOnAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)


Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)

Name
ISASSetPFLOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)


Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)

Name
ISASSetPFLOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)


Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)

Name
ISASSourceAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetSourceName (+)
SetSourceName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)


Previous
Next (SetSourceName)

Name
GetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
function GetSourceName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetSourceName)


Previous (GetSourceName)
Next

Name
SetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
procedure SetSourceName ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetSourceName)
Next


Previous (ISASSourceAction)
Next (ISerialSASRemote)

Name
ISASSourceLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Members
Methods
Method Description
GetLevel (+)
SetLevel (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceAction)
Next (ISerialSASRemote)


Previous
Next (SetLevel)

Name
GetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
function GetLevel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetLevel)


Previous (GetLevel)
Next

Name
SetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
procedure SetLevel ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetLevel)
Next


Previous (ISASSourceLevelAction)
Next

Name
ISerialSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceLevelAction)
Next


Previous
Next (SetPort)

Name
GetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (SASInterface)
Next (SimpleXMLInterface)

Name
SimpleSQLInterface

Parent
mAirListScript

Types
Type Description
TSQLIsolationLevel (+)

Methods
Method Description
CreateSQLConnection (+)

Classes
Class Description
ISQLConnection (+)
ISQLPreparedStatement (+)
ISQLResultSet (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (SASInterface)
Next (SimpleXMLInterface)


Previous
Next (ISQLPreparedStatement)

Name
ISQLConnection

Parent
SimpleSQLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginTransaction (+)
CommitTransaction (+)
PingServer (+)
PrepareStatement (+)
RollbackTransaction (+)
SetIsolationLevel (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (ISQLPreparedStatement)


Previous
Next (CommitTransaction)

Name
BeginTransaction

Parent
ISQLConnection

Visibility
PUBLIC

Source code
procedure BeginTransaction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CommitTransaction)


Previous (BeginTransaction)
Next (PingServer)

Name
CommitTransaction

Parent
ISQLConnection

Visibility
PUBLIC

Source code
procedure CommitTransaction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginTransaction)
Next (PingServer)


Previous (CommitTransaction)
Next (PrepareStatement)

Name
PingServer

Parent
ISQLConnection

Visibility
PUBLIC

Source code
function PingServer : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CommitTransaction)
Next (PrepareStatement)


Previous (PingServer)
Next (RollbackTransaction)

Name
PrepareStatement

Parent
ISQLConnection

Visibility
PUBLIC

Source code
function PrepareStatement ( iSQL : string ) : ISQLPreparedStatement

Parameters
Parameter | Description
iSQL : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (PingServer)
Next (RollbackTransaction)


Previous (PrepareStatement)
Next (SetIsolationLevel)

Name
RollbackTransaction

Parent
ISQLConnection

Visibility
PUBLIC

Source code
procedure RollbackTransaction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (PrepareStatement)
Next (SetIsolationLevel)


Previous (RollbackTransaction)
Next

Name
SetIsolationLevel

Parent
ISQLConnection

Visibility
PUBLIC

Source code
procedure SetIsolationLevel ( iLevel : TSQLIsolationLevel )

Parameters
Parameter | Description
iLevel : TSQLIsolationLevel | &nbsp;

mAirListScript
Class Tree
Index
Previous (RollbackTransaction)
Next


Previous (ISQLConnection)
Next (ISQLResultSet)

Name
ISQLPreparedStatement

Parent
SimpleSQLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ExecuteQueryPrepared (+)
ExecuteUpdatePrepared (+)
SetBinaryStream (+)
SetBinaryStreamByName (+)
SetDate (+)
SetDateByName (+)
SetFieldType (+)
SetFieldTypeByName (+)
SetFloat (+)
SetFloatByName (+)
SetInt (+)
SetIntByName (+)
SetMemo (+)
SetMemoByName (+)
SetNull (+)
SetNullByName (+)
SetParamSize (+)
SetParamSizeByName (+)
SetString (+)
SetStringByName (+)
SetTime (+)
SetTimeByName (+)
SetTimestamp (+)
SetTimestampByName (+)
SetValue (+)
SetValueByName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISQLConnection)
Next (ISQLResultSet)


Previous
Next (ExecuteUpdatePrepared)

Name
ExecuteQueryPrepared

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteQueryPrepared : ISQLResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ExecuteUpdatePrepared)


Previous (ExecuteQueryPrepared)
Next (SetBinaryStream)

Name
ExecuteUpdatePrepared

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteUpdatePrepared : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteQueryPrepared)
Next (SetBinaryStream)


Previous (ExecuteUpdatePrepared)
Next (SetBinaryStreamByName)

Name
SetBinaryStream

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBinaryStream ( iIndex : integer ; iValue : RawByteString )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : RawByteString | &nbsp;

mAirListScript
Class Tree
Index
Previous (ExecuteUpdatePrepared)
Next (SetBinaryStreamByName)


Previous (SetBinaryStream)
Next (SetDate)

Name
SetBinaryStreamByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBinaryStreamByName ( iName : string ; iValue : RawByteString )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : RawByteString | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBinaryStream)
Next (SetDate)


Previous (SetBinaryStreamByName)
Next (SetDateByName)

Name
SetDate

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDate ( iIndex : integer ; iValue : TDateTime )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetBinaryStreamByName)
Next (SetDateByName)


Previous (SetDate)
Next (SetFieldType)

Name
SetDateByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDateByName ( iName : string ; iValue : TDateTime )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDate)
Next (SetFieldType)


Previous (SetDateByName)
Next (SetFieldTypeByName)

Name
SetFieldType

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFieldType ( iIndex : integer ; iType : TFieldType )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iType : TFieldType | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDateByName)
Next (SetFieldTypeByName)


Previous (SetFieldType)
Next (SetFloat)

Name
SetFieldTypeByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFieldTypeByName ( iName : string ; iType : TFieldType )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iType : TFieldType | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFieldType)
Next (SetFloat)


Previous (SetFieldTypeByName)
Next (SetFloatByName)

Name
SetFloat

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFloat ( iIndex : integer ; iValue : double )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFieldTypeByName)
Next (SetFloatByName)


Previous (SetFloat)
Next (SetInt)

Name
SetFloatByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFloatByName ( iName : string ; iValue : double )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : DOUBLE | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFloat)
Next (SetInt)


Previous (SetFloatByName)
Next (SetIntByName)

Name
SetInt

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetInt ( iIndex : integer ; iValue : integer )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetFloatByName)
Next (SetIntByName)


Previous (SetInt)
Next (SetMemo)

Name
SetIntByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetIntByName ( iName : string ; iValue : integer )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetInt)
Next (SetMemo)


Previous (SetIntByName)
Next (SetMemoByName)

Name
SetMemo

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetMemo ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetIntByName)
Next (SetMemoByName)


Previous (SetMemo)
Next (SetNull)

Name
SetMemoByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetMemoByName ( iName : string ; iValue : string )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMemo)
Next (SetNull)


Previous (SetMemoByName)
Next (SetNullByName)

Name
SetNull

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetNull ( iIndex : integer ; iFieldType : TFieldType )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iFieldType : TFieldType | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetMemoByName)
Next (SetNullByName)


Previous (SetNull)
Next (SetParamSize)

Name
SetNullByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetNullByName ( iName : string ; iFieldType : TFieldType )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iFieldType : TFieldType | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNull)
Next (SetParamSize)


Previous (SetNullByName)
Next (SetParamSizeByName)

Name
SetParamSize

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetParamSize ( iIndex : integer ; iSize : integer )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iSize : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetNullByName)
Next (SetParamSizeByName)


Previous (SetParamSize)
Next (SetString)

Name
SetParamSizeByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetParamSizeByName ( iName : string ; iSize : integer )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iSize : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetParamSize)
Next (SetString)


Previous (SetParamSizeByName)
Next (SetStringByName)

Name
SetString

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetString ( iIndex : integer ; iValue : string )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetParamSizeByName)
Next (SetStringByName)


Previous (SetString)
Next (SetTime)

Name
SetStringByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetStringByName ( iName : string ; iValue : string )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetString)
Next (SetTime)


Previous (SetStringByName)
Next (SetTimeByName)

Name
SetTime

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTime ( iIndex : integer ; iValue : TDateTime )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetStringByName)
Next (SetTimeByName)


Previous (SetTime)
Next (SetTimestamp)

Name
SetTimeByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTimeByName ( iName : string ; iValue : TDateTime )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTime)
Next (SetTimestamp)


Previous (SetTimeByName)
Next (SetTimestampByName)

Name
SetTimestamp

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTimestamp ( iIndex : integer ; iValue : TDateTime )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTimeByName)
Next (SetTimestampByName)


Previous (SetTimestamp)
Next (SetValue)

Name
SetTimestampByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTimestampByName ( iName : string ; iValue : TDateTime )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : TDateTime | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTimestamp)
Next (SetValue)


Previous (SetTimestampByName)
Next (SetValueByName)

Name
SetValue

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetValue ( iIndex : integer ; iValue : Variant )

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;
iValue : VARIANT | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetTimestampByName)
Next (SetValueByName)


Previous (SetValue)
Next

Name
SetValueByName

Parent
ISQLPreparedStatement

Visibility
PUBLIC

Source code
procedure SetValueByName ( iName : string ; iValue : Variant )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : VARIANT | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetValue)
Next


Previous (ISQLPreparedStatement)
Next

Name
ISQLResultSet

Parent
SimpleSQLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
First (+)
GetBinaryStream (+)
GetColumnCount (+)
GetColumnFieldType (+)
GetColumnName (+)
GetDate (+)
GetFloat (+)
GetInt (+)
GetMemo (+)
GetString (+)
GetTime (+)
GetTimestamp (+)
GetValue (+)
IsNull (+)
Next (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISQLPreparedStatement)
Next


Previous
Next (GetBinaryStream)

Name
First

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function First : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetBinaryStream)


Previous (First)
Next (GetColumnCount)

Name
GetBinaryStream

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetBinaryStream ( const iColumn : integer ) : RawByteString

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (First)
Next (GetColumnCount)


Previous (GetBinaryStream)
Next (GetColumnFieldType)

Name
GetColumnCount

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetColumnCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBinaryStream)
Next (GetColumnFieldType)


Previous (GetColumnCount)
Next (GetColumnName)

Name
GetColumnFieldType

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetColumnFieldType ( const iColumn : integer ) : TFieldType

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetColumnCount)
Next (GetColumnName)


Previous (GetColumnFieldType)
Next (GetDate)

Name
GetColumnName

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetColumnName ( const iColumn : integer ) : string

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetColumnFieldType)
Next (GetDate)


Previous (GetColumnName)
Next (GetFloat)

Name
GetDate

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetDate ( const iColumn : integer ) : TDateTime

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetColumnName)
Next (GetFloat)


Previous (GetDate)
Next (GetInt)

Name
GetFloat

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetFloat ( const iColumn : integer ) : double

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetDate)
Next (GetInt)


Previous (GetFloat)
Next (GetMemo)

Name
GetInt

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetInt ( const iColumn : integer ) : integer

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetFloat)
Next (GetMemo)


Previous (GetInt)
Next (GetString)

Name
GetMemo

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetMemo ( const iColumn : integer ) : string

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetInt)
Next (GetString)


Previous (GetMemo)
Next (GetTime)

Name
GetString

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetString ( const iColumn : integer ) : string

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetMemo)
Next (GetTime)


Previous (GetString)
Next (GetTimestamp)

Name
GetTime

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetTime ( const iColumn : integer ) : TDateTime

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetString)
Next (GetTimestamp)


Previous (GetTime)
Next (GetValue)

Name
GetTimestamp

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetTimestamp ( const iColumn : integer ) : TDateTime

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetTime)
Next (GetValue)


Previous (GetTimestamp)
Next (IsNull)

Name
GetValue

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function GetValue ( const iColumn : integer ) : Variant

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetTimestamp)
Next (IsNull)


Previous (GetValue)
Next (Next)

Name
IsNull

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function IsNull ( const iColumn : integer ) : boolean

Parameters
Parameter | Description
iColumn : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (Next)


Previous (IsNull)
Next

Name
Next

Parent
ISQLResultSet

Visibility
PUBLIC

Source code
function Next : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsNull)
Next


Previous
Next

Name
TSQLIsolationLevel

Parent
SimpleSQLInterface

Visibility
PUBLIC

Source code
TSQLIsolationLevel = ( ilUnspecified , ilDirtyRead , ilReadCommitted , ilRepeatableRead , ilSnapshot , ilSerializable ) ;

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next

Name
CreateSQLConnection

Parent
SimpleSQLInterface

Visibility
PUBLIC

Source code
function CreateSQLConnection ( iConnectionString : string ) : ISQLConnection

Parameters
Parameter | Description
iConnectionString : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next


Previous (SimpleSQLInterface)
Next (WMClientInterface)

Name
SimpleXMLInterface

Parent
mAirListScript

Methods
Method Description
CreateXMLDoc (+)
CreateXMLDocFromFile (+)
CreateXMLDocFromXML (+)

Classes
Class Description
ISXMLDocument (+)
ISXMLNode (+)
ISXMLNodeList (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (SimpleSQLInterface)
Next (WMClientInterface)


Previous
Next (ISXMLNode)

Name
ISXMLDocument

Parent
SimpleXMLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateElement (+)
GetDocumentElement (+)
GetXML (+)
GetXMLUTF8 (+)
LoadFromFile (+)
LoadFromStream (+)
SaveToFile (+)
SaveToStream (+)
SetDocumentElement (+)
SetXML (+)
SetXMLUTF8 (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (ISXMLNode)


Previous
Next (GetDocumentElement)

Name
CreateElement

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
function CreateElement ( iTagName : string ) : ISXMLNode

Parameters
Parameter | Description
iTagName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (GetDocumentElement)


Previous (CreateElement)
Next (GetXML)

Name
GetDocumentElement

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
function GetDocumentElement : ISXMLNode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateElement)
Next (GetXML)


Previous (GetDocumentElement)
Next (GetXMLUTF8)

Name
GetXML

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
function GetXML ( iIndent : boolean ) : string

Parameters
Parameter | Description
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetDocumentElement)
Next (GetXMLUTF8)


Previous (GetXML)
Next (LoadFromFile)

Name
GetXMLUTF8

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
function GetXMLUTF8 ( iIndent : boolean ) : UTF8String

Parameters
Parameter | Description
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetXML)
Next (LoadFromFile)


Previous (GetXMLUTF8)
Next (LoadFromStream)

Name
LoadFromFile

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetXMLUTF8)
Next (LoadFromStream)


Previous (LoadFromFile)
Next (SaveToFile)

Name
LoadFromStream

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure LoadFromStream ( iStream : TStream )

Parameters
Parameter | Description
iStream : TStream | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (SaveToFile)


Previous (LoadFromStream)
Next (SaveToStream)

Name
SaveToFile

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string ; iIndent : boolean = true )

Parameters
Parameter | Description
iFilename : STRING | &nbsp;
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (LoadFromStream)
Next (SaveToStream)


Previous (SaveToFile)
Next (SetDocumentElement)

Name
SaveToStream

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure SaveToStream ( iStream : TStream ; iIndent : boolean = true )

Parameters
Parameter | Description
iStream : TStream | &nbsp;
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveToFile)
Next (SetDocumentElement)


Previous (SaveToStream)
Next (SetXML)

Name
SetDocumentElement

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure SetDocumentElement ( iNode : ISXMLNode )

Parameters
Parameter | Description
iNode : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (SaveToStream)
Next (SetXML)


Previous (SetDocumentElement)
Next (SetXMLUTF8)

Name
SetXML

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure SetXML ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetDocumentElement)
Next (SetXMLUTF8)


Previous (SetXML)
Next

Name
SetXMLUTF8

Parent
ISXMLDocument

Visibility
PUBLIC

Source code
procedure SetXMLUTF8 ( iValue : UTF8String )

Parameters
Parameter | Description
iValue : UTF8String | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetXML)
Next


Previous (ISXMLDocument)
Next (ISXMLNodeList)

Name
ISXMLNode

Parent
SimpleXMLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddChild (+)
AppendChild (+)
GetAttribute (+)
GetChildNodes (+)
GetNodeName (+)
GetNodeText (+)
GetOwnerDocument (+)
GetXML (+)
HasAttribute (+)
SelectNode (+)
SelectNodes (+)
SetAttribute (+)
SetNodeText (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISXMLDocument)
Next (ISXMLNodeList)


Previous
Next (AppendChild)

Name
AddChild

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function AddChild ( iName : string ; iValue : string = '' ) : ISXMLNode

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous
Next (AppendChild)


Previous (AddChild)
Next (GetAttribute)

Name
AppendChild

Parent
ISXMLNode

Visibility
PUBLIC

Source code
procedure AppendChild ( iNode : ISXMLNode )

Parameters
Parameter | Description
iNode : ISXMLNode | &nbsp;

mAirListScript
Class Tree
Index
Previous (AddChild)
Next (GetAttribute)


Previous (AppendChild)
Next (GetChildNodes)

Name
GetAttribute

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetAttribute ( iName : string ) : string

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (AppendChild)
Next (GetChildNodes)


Previous (GetAttribute)
Next (GetNodeName)

Name
GetChildNodes

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetChildNodes : ISXMLNodeList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAttribute)
Next (GetNodeName)


Previous (GetChildNodes)
Next (GetNodeText)

Name
GetNodeName

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetNodeName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChildNodes)
Next (GetNodeText)


Previous (GetNodeName)
Next (GetOwnerDocument)

Name
GetNodeText

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetNodeText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNodeName)
Next (GetOwnerDocument)


Previous (GetNodeText)
Next (GetXML)

Name
GetOwnerDocument

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetOwnerDocument : ISXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNodeText)
Next (GetXML)


Previous (GetOwnerDocument)
Next (HasAttribute)

Name
GetXML

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function GetXML ( iIndent : boolean ) : string

Parameters
Parameter | Description
iIndent : BOOLEAN | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetOwnerDocument)
Next (HasAttribute)


Previous (GetXML)
Next (SelectNode)

Name
HasAttribute

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function HasAttribute ( iName : string ) : boolean

Parameters
Parameter | Description
iName : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetXML)
Next (SelectNode)


Previous (HasAttribute)
Next (SelectNodes)

Name
SelectNode

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function SelectNode ( iPath : string ) : ISXMLNode

Parameters
Parameter | Description
iPath : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (HasAttribute)
Next (SelectNodes)


Previous (SelectNode)
Next (SetAttribute)

Name
SelectNodes

Parent
ISXMLNode

Visibility
PUBLIC

Source code
function SelectNodes ( iPath : string ) : ISXMLNodeList

Parameters
Parameter | Description
iPath : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SelectNode)
Next (SetAttribute)


Previous (SelectNodes)
Next (SetNodeText)

Name
SetAttribute

Parent
ISXMLNode

Visibility
PUBLIC

Source code
procedure SetAttribute ( iName , iValue : string )

Parameters
Parameter | Description
iName : STRING | &nbsp;
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SelectNodes)
Next (SetNodeText)


Previous (SetAttribute)
Next

Name
SetNodeText

Parent
ISXMLNode

Visibility
PUBLIC

Source code
procedure SetNodeText ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetAttribute)
Next


Previous (ISXMLNode)
Next

Name
ISXMLNodeList

Parent
SimpleXMLInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISXMLNode)
Next


Previous
Next (GetItem)

Name
GetCount

Parent
ISXMLNodeList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
ISXMLNodeList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ISXMLNode

Parameters
Parameter | Description
iIndex : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous
Next (CreateXMLDocFromFile)

Name
CreateXMLDoc

Parent
SimpleXMLInterface

Visibility
PUBLIC

Source code
function CreateXMLDoc : ISXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CreateXMLDocFromFile)


Previous (CreateXMLDoc)
Next (CreateXMLDocFromXML)

Name
CreateXMLDocFromFile

Parent
SimpleXMLInterface

Visibility
PUBLIC

Source code
function CreateXMLDocFromFile ( iFilename : string ) : ISXMLDocument

Parameters
Parameter | Description
iFilename : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateXMLDoc)
Next (CreateXMLDocFromXML)


Previous (CreateXMLDocFromFile)
Next

Name
CreateXMLDocFromXML

Parent
SimpleXMLInterface

Visibility
PUBLIC

Source code
function CreateXMLDocFromXML ( iXML : string ) : ISXMLDocument

Parameters
Parameter | Description
iXML : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (CreateXMLDocFromFile)
Next


Previous (SimpleXMLInterface)
Next

Name
WMClientInterface

Parent
mAirListScript

Classes
Class Description
IWMClientRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (SimpleXMLInterface)
Next


Previous
Next

Name
IWMClientRemote

Parent
WMClientInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetMessages (+)
GetRegisterMessage (+)
GetSetOutputMessage (+)
GetUnregisterMessage (+)
GetWindowName (+)
SetOutput (+)
SetRegisterMessage (+)
SetSetOutputMessage (+)
SetUnregisterMessage (+)
SetWindowName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (GetRegisterMessage)

Name
GetMessages

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetMessages : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetRegisterMessage)


Previous (GetMessages)
Next (GetSetOutputMessage)

Name
GetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetRegisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessages)
Next (GetSetOutputMessage)


Previous (GetRegisterMessage)
Next (GetUnregisterMessage)

Name
GetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetSetOutputMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegisterMessage)
Next (GetUnregisterMessage)


Previous (GetSetOutputMessage)
Next (GetWindowName)

Name
GetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetUnregisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSetOutputMessage)
Next (GetWindowName)


Previous (GetUnregisterMessage)
Next (SetOutput)

Name
GetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetWindowName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUnregisterMessage)
Next (SetOutput)


Previous (GetWindowName)
Next (SetRegisterMessage)

Name
SetOutput

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetOutput ( iNumber : integer ; iValue : integer )

Parameters
Parameter | Description
iNumber : INTEGER | &nbsp;
iValue : INTEGER | &nbsp;

mAirListScript
Class Tree
Index
Previous (GetWindowName)
Next (SetRegisterMessage)


Previous (SetOutput)
Next (SetSetOutputMessage)

Name
SetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetRegisterMessage ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetOutput)
Next (SetSetOutputMessage)


Previous (SetRegisterMessage)
Next (SetUnregisterMessage)

Name
SetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetSetOutputMessage ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetRegisterMessage)
Next (SetUnregisterMessage)


Previous (SetSetOutputMessage)
Next (SetWindowName)

Name
SetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetUnregisterMessage ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetSetOutputMessage)
Next (SetWindowName)


Previous (SetUnregisterMessage)
Next

Name
SetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetWindowName ( iValue : string )

Parameters
Parameter | Description
iValue : STRING | &nbsp;

mAirListScript
Class Tree
Index
Previous (SetUnregisterMessage)
Next