mAirListScript - The scripting interface to mAirList

mAirListScript

Class Tree
Index
Previous
Next

Name
mAirListScript

Description
The scripting interface to mAirList
The scripting interface to mAirList

The XML interface was extracted from the OmniXML package (www.omnixml.com).

Author
Torben Weibert

Units
Unit Description
BassStreamingInterfaces
BassStreamingTypes
CoreRemoteInterface
DHDInterfaces
DHDTypes
InpOut32Interface
mAirListInterfaces
mAirListScript
mAirListTypes
MidiInterface
SASInterface
WMClientInterface
ZDbcIntfs

mAirListScript
Class Tree
Index
Previous
Next

Copyright mairlist GmbH 211
Created with DelphiCodeToDoc. To obtain the latest revision, please visit http://dephicodetodoc.sourceforge.net/


Previous (mAirListScript)
Next

Name
_ClassHierarchy

Class Hierarchy

#ROOT#

TObject

IInterface

* IBaseMessage

* IFactoryClass

* IFileTypeHandlerClass

* IFileStorageClass

* IProgressIndicator

* IPersistentStorage

* IPersistentNull

* IPersistentNumber

* IPersistentInteger

* IPersistentString

* IPersistentBoolean

* IPersistentDateTime

* IPersistentArray

* IPersistentObject

* IPersistent

* IObservable

* IUpdateObject

* IConfigObject

* IDatabase

* IRemote

* IRM4200DRemote

* ILogInterface

* IFileEncoderSettings

* IAudioEffect

* IEncoderConnection

* IBassEncEncoderConnection

* IBaseShoutcastEncoderConnection

* IShoutcastEncoderConnection

* IIcecastEncoderConnection

* IInternalServerEncoderConnection

* IAircheckEncoderConnection

* IPersistentListItem

* IPersistentListItemMetadata

* IPersistentPlaylistItemMetadata

* IPlaylistItemMetadata

* IActivePlaylistItemMetadata

* IMultiPlaylistItemMetadata

* ICueDataItem

* IAddableCueDataItem

* ITrackCueDataItem

* IBaseMarkerCueDataItem

* IMarkerCueDataitem

* IAlternativeMarkerCueDataItem

* IEOFWarningCueDataItem

* IMetaCueDataItem

* IEnvelopePoint

* IAction

* IRemoteAction

* IRM4200DAction

* IRM4200DSetAllPFLOffAction

* IRM4200DChannelValueAction

* IRM4200DSetPFLAction

* IRM4200DSetFaderOnAction

* IRM4200DSetLogicAction

* ISASAction

* ISASSourceAction

* ISASSourceLevelAction

* ISASSetFaderLevelAction

* ISASSetFaderInputGainAction

* ISASSetPFLOnAction

* ISASSetPFLOffAction

* ISASSetFaderStartOnAction

* ISASSetFaderStartOffAction

* ISASSetGPIAction

* ISASSetGPIOnAction

* ISASSetGPIOffAction

* IEmergencyAction

* IDatabaseAction

* IPlaylistItem

* IFilePlaylistItem

* IInlineFilePlaylistItem

* IURLPlaylistItem

* IStreamPlaylistItem

* IContainerPlaylistItem

* IRegionContainerPlaylistItem

* IDummyPlaylistItem

* ICommandPlaylistItem

* IBreakPlaylistItem

* ISilencePlaylistItem

* IInfiniteSilencePlaylistItem

* IPlaylistFilePlaylistItem

* IAddablePlaylistItem

* IEventListItem

* IBaseList

* IObservableList

* IFactoryObjectList

* IConfigObjectList

* IDatabaseList

* IRemoteController

* ILogInterfaceList

* IAudioEffectList

* IEncoderConnectionList

* IPersistentList

* ICueData

* IEnvelope

* IActionList

* IPlaylist

* IActivePlaylist

* IPlaybackControl

* IRecycleBinPlaylist

* IMultiPlaylist

* IEventList

* IAudioDeviceList

* IPlaybackDeviceList

* IRecordDeviceList

* ILogEntryList

* IInlineData

* IAudioSource

* IMultiAudioSource

* IAudioDevice

* IPlaybackDevice

* IRecordDevice

* INoAudioDevice

* IAudioDeviceConfig

* IMixdownEngine

* ISourceControl

* IPlayerControl

* IPlaylistPlayerControl

* ICartPlayerControl

* ICartWallControl

* IEngine

* IModule

* IHiddenModule

* IEventsModule

* IMultiInstanceModule

* IBassStreamingModule

* IFileManager

* ILogger

* IPeakAnalyzer

* IFileEncoder

* IDatabaseSearchHandler

* IComPort

* ILevelInfo

* IMutex

* IStrings

* IStream

* IWritableStream

* IClientList

* IDummyAction

* IDatabaseTree

* IDatabaseInlineLoader

* IMixdownEngine2

* IFileTypeHandler

* IStubPlaylistItem

* IBaseComPortRemote

* IEngineDesktopPlugin

* IEngineInfo

* IMixer

* ISerialPortManager

* IFilePlaylistItemClass

* IFactory

* IConfiguration

* IPlaylistStorage

* IPlaylistImporter

* IPlaylistExporter

* IAutoCueEngine

* ILicenseManager

* IModuleList

* INotifiedMessageReceiver

* ILogEntry

* IMessageDispatcher

* IInstanceData

* ImAirListInstance

* INotifyItemStarted

* IDummyObject

* IDebugObject

* IRunnable

* IBassStreamingConfigPage

* ISASRemote

* ISerialSASRemote

* IIPSASRemote

* IMidiRemote

* IWMClientRemote

* IIOPort

No parent

* TDatabaseNodeData

* TMidiMessage

#OrphanClass#

* EMessage

* ELicenseError

* IBassStreamingEncoder

* EZSQLThrowable

* EZSQLException

* EZSQLWarning

* IZDriverManager

* IZDriver

* IZConnection

* IZDatabaseMetadata

* IZStatement

* IZPreparedStatement

* IZCallableStatement

* IZResultSet

* IZResultSetMetadata

* IZBlob

* IZNotification

* IZSequence

* TZDriverManager

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next


Previous
Next (BassStreamingTypes)

Name
BassStreamingInterfaces

Parent
mAirListScript

Classes
Class Description
IAircheckEncoderConnection (+)
IBaseShoutcastEncoderConnection (+)
IBassEncEncoderConnection (+)
IBassStreamingConfigPage (+)
IBassStreamingEncoder (+)
IBassStreamingModule (+)
IEncoderConnection (+)
IEncoderConnectionList (+)
IIcecastEncoderConnection (+)
IInternalServerEncoderConnection (+)
IShoutcastEncoderConnection (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (BassStreamingTypes)


Previous
Next (IBaseShoutcastEncoderConnection)

Name
IAircheckEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetDirectory (+)
GetEncoderSettings (+)
GetFilenameFormat (+)
GetSplitDuration (+)
SetDirectory (+)
SetFilenameFormat (+)
SetSplitDuration (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IBaseShoutcastEncoderConnection)


Previous
Next (GetEncoderSettings)

Name
GetDirectory

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetDirectory : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEncoderSettings)


Previous (GetDirectory)
Next (GetFilenameFormat)

Name
GetEncoderSettings

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderSettings : IFileEncoderSettings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDirectory)
Next (GetFilenameFormat)


Previous (GetEncoderSettings)
Next (GetSplitDuration)

Name
GetFilenameFormat

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetFilenameFormat : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderSettings)
Next (GetSplitDuration)


Previous (GetFilenameFormat)
Next (SetDirectory)

Name
GetSplitDuration

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
function GetSplitDuration : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilenameFormat)
Next (SetDirectory)


Previous (GetSplitDuration)
Next (SetFilenameFormat)

Name
SetDirectory

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetDirectory ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetSplitDuration)
Next (SetFilenameFormat)


Previous (SetDirectory)
Next (SetSplitDuration)

Name
SetFilenameFormat

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetFilenameFormat ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDirectory)
Next (SetSplitDuration)


Previous (SetFilenameFormat)
Next

Name
SetSplitDuration

Parent
IAircheckEncoderConnection

Visibility
PUBLIC

Source code
procedure SetSplitDuration ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFilenameFormat)
Next


Previous (IAircheckEncoderConnection)
Next (IBassEncEncoderConnection)

Name
IBaseShoutcastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBassEncEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetAIM (+)
GetConnectDelay (+)
GetDescription (+)
GetGenre (+)
GetICQ (+)
GetIncludeItemTypes (+)
GetIRC (+)
GetLogFormat (+)
GetNoStreaming (+)
GetPassword (+)
GetPublic (+)
GetReconnectDelay (+)
GetTitle (+)
GetTitleUpdateDelay (+)
GetURL (+)
SetAIM (+)
SetConnectDelay (+)
SetDescription (+)
SetGenre (+)
SetICQ (+)
SetIncludeItemTypes (+)
SetIRC (+)
SetLogFormat (+)
SetNoStreaming (+)
SetPassword (+)
SetPublic (+)
SetReconnectDelay (+)
SetTitle (+)
SetTitleUpdateDelay (+)
SetURL (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAircheckEncoderConnection)
Next (IBassEncEncoderConnection)


Previous
Next (GetConnectDelay)

Name
GetAIM

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetAIM : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetConnectDelay)


Previous (GetAIM)
Next (GetDescription)

Name
GetConnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetConnectDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAIM)
Next (GetDescription)


Previous (GetConnectDelay)
Next (GetGenre)

Name
GetDescription

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnectDelay)
Next (GetGenre)


Previous (GetDescription)
Next (GetICQ)

Name
GetGenre

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetGenre : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetICQ)


Previous (GetGenre)
Next (GetIncludeItemTypes)

Name
GetICQ

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetICQ : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGenre)
Next (GetIncludeItemTypes)


Previous (GetICQ)
Next (GetIRC)

Name
GetIncludeItemTypes

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetIncludeItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetICQ)
Next (GetIRC)


Previous (GetIncludeItemTypes)
Next (GetLogFormat)

Name
GetIRC

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetIRC : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIncludeItemTypes)
Next (GetLogFormat)


Previous (GetIRC)
Next (GetNoStreaming)

Name
GetLogFormat

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetLogFormat : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIRC)
Next (GetNoStreaming)


Previous (GetLogFormat)
Next (GetPassword)

Name
GetNoStreaming

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetNoStreaming : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogFormat)
Next (GetPassword)


Previous (GetNoStreaming)
Next (GetPublic)

Name
GetPassword

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetPassword : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNoStreaming)
Next (GetPublic)


Previous (GetPassword)
Next (GetReconnectDelay)

Name
GetPublic

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetPublic : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPassword)
Next (GetReconnectDelay)


Previous (GetPublic)
Next (GetTitle)

Name
GetReconnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetReconnectDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPublic)
Next (GetTitle)


Previous (GetReconnectDelay)
Next (GetTitleUpdateDelay)

Name
GetTitle

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetReconnectDelay)
Next (GetTitleUpdateDelay)


Previous (GetTitle)
Next (GetURL)

Name
GetTitleUpdateDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetTitleUpdateDelay : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (GetURL)


Previous (GetTitleUpdateDelay)
Next (SetAIM)

Name
GetURL

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitleUpdateDelay)
Next (SetAIM)


Previous (GetURL)
Next (SetConnectDelay)

Name
SetAIM

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetAIM ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetURL)
Next (SetConnectDelay)


Previous (SetAIM)
Next (SetDescription)

Name
SetConnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetConnectDelay ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetAIM)
Next (SetDescription)


Previous (SetConnectDelay)
Next (SetGenre)

Name
SetDescription

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetConnectDelay)
Next (SetGenre)


Previous (SetDescription)
Next (SetICQ)

Name
SetGenre

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetGenre ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetICQ)


Previous (SetGenre)
Next (SetIncludeItemTypes)

Name
SetICQ

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetICQ ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetGenre)
Next (SetIncludeItemTypes)


Previous (SetICQ)
Next (SetIRC)

Name
SetIncludeItemTypes

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetIncludeItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter Description
iValue : TPlaylistItemTypes

mAirListScript
Class Tree
Index
Previous (SetICQ)
Next (SetIRC)


Previous (SetIncludeItemTypes)
Next (SetLogFormat)

Name
SetIRC

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetIRC ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetIncludeItemTypes)
Next (SetLogFormat)


Previous (SetIRC)
Next (SetNoStreaming)

Name
SetLogFormat

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetLogFormat ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetIRC)
Next (SetNoStreaming)


Previous (SetLogFormat)
Next (SetPassword)

Name
SetNoStreaming

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetNoStreaming ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetLogFormat)
Next (SetPassword)


Previous (SetNoStreaming)
Next (SetPublic)

Name
SetPassword

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPassword ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetNoStreaming)
Next (SetPublic)


Previous (SetPassword)
Next (SetReconnectDelay)

Name
SetPublic

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPublic ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetPassword)
Next (SetReconnectDelay)


Previous (SetPublic)
Next (SetTitle)

Name
SetReconnectDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetReconnectDelay ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPublic)
Next (SetTitle)


Previous (SetReconnectDelay)
Next (SetTitleUpdateDelay)

Name
SetTitle

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetReconnectDelay)
Next (SetTitleUpdateDelay)


Previous (SetTitle)
Next (SetURL)

Name
SetTitleUpdateDelay

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetTitleUpdateDelay ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next (SetURL)


Previous (SetTitleUpdateDelay)
Next

Name
SetURL

Parent
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetURL ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTitleUpdateDelay)
Next


Previous (IBaseShoutcastEncoderConnection)
Next (IBassStreamingConfigPage)

Name
IBassEncEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetAllowedAudioFormats (+)
GetAudioFormat (+)
GetBitrate (+)
GetCountListeners (+)
GetEncoderOptions (+)
GetHostname (+)
GetMode (+)
GetPort (+)
SetAudioFormat (+)
SetBitrate (+)
SetCountListeners (+)
SetEncoderOptions (+)
SetHostname (+)
SetMode (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseShoutcastEncoderConnection)
Next (IBassStreamingConfigPage)


Previous
Next (GetAudioFormat)

Name
GetAllowedAudioFormats

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetAllowedAudioFormats : TBassStreamingFormats

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetAudioFormat)


Previous (GetAllowedAudioFormats)
Next (GetBitrate)

Name
GetAudioFormat

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetAudioFormat : TBassStreamingFormat

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAllowedAudioFormats)
Next (GetBitrate)


Previous (GetAudioFormat)
Next (GetCountListeners)

Name
GetBitrate

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetBitrate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAudioFormat)
Next (GetCountListeners)


Previous (GetBitrate)
Next (GetEncoderOptions)

Name
GetCountListeners

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetCountListeners : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBitrate)
Next (GetEncoderOptions)


Previous (GetCountListeners)
Next (GetHostname)

Name
GetEncoderOptions

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderOptions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCountListeners)
Next (GetHostname)


Previous (GetEncoderOptions)
Next (GetMode)

Name
GetHostname

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetHostname : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderOptions)
Next (GetMode)


Previous (GetHostname)
Next (GetPort)

Name
GetMode

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetMode : TAudioMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHostname)
Next (GetPort)


Previous (GetMode)
Next (SetAudioFormat)

Name
GetPort

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMode)
Next (SetAudioFormat)


Previous (GetPort)
Next (SetBitrate)

Name
SetAudioFormat

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetAudioFormat ( iValue : TBassStreamingFormat )

Parameters
Parameter Description
iValue : TBassStreamingFormat

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SetBitrate)


Previous (SetAudioFormat)
Next (SetCountListeners)

Name
SetBitrate

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetBitrate ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetAudioFormat)
Next (SetCountListeners)


Previous (SetBitrate)
Next (SetEncoderOptions)

Name
SetCountListeners

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetCountListeners ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetBitrate)
Next (SetEncoderOptions)


Previous (SetCountListeners)
Next (SetHostname)

Name
SetEncoderOptions

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetEncoderOptions ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetCountListeners)
Next (SetHostname)


Previous (SetEncoderOptions)
Next (SetMode)

Name
SetHostname

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetHostname ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetEncoderOptions)
Next (SetMode)


Previous (SetHostname)
Next (SetPort)

Name
SetMode

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetMode ( iValue : TAudioMode )

Parameters
Parameter Description
iValue : TAudioMode

mAirListScript
Class Tree
Index
Previous (SetHostname)
Next (SetPort)


Previous (SetMode)
Next

Name
SetPort

Parent
IBassEncEncoderConnection

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetMode)
Next


Previous (IBassEncEncoderConnection)
Next (IBassStreamingEncoder)

Name
IBassStreamingConfigPage

Parent
BassStreamingInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassEncEncoderConnection)
Next (IBassStreamingEncoder)


Previous (IBassStreamingConfigPage)
Next (IBassStreamingModule)

Name
IBassStreamingEncoder

Parent
BassStreamingInterfaces

Class Hierarchy
IBassMixPlaybackDevice

Visibility
PUBLIC

Members
Methods
Method Description
Connect (+)
Disconnect (+)
GetConnections (+)
GetDSPPlugins (+)
GetLineInputEnabled (+)
GetListeners (+)
GetLocalOutputEnabled (+)
GetMicInputEnabled (+)
GetOptions (+)
GetSamplerate (+)
GetState (+)
SetLineInputEnabled (+)
SetLocalOutputEnabled (+)
SetMicInputEnabled (+)
SetOptions (+)
SetSamplerate (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingConfigPage)
Next (IBassStreamingModule)


Previous
Next (Disconnect)

Name
Connect

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure Connect ( iAsync : boolean )

Parameters
Parameter Description
iAsync : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (Disconnect)


Previous (Connect)
Next (GetConnections)

Name
Disconnect

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure Disconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Connect)
Next (GetConnections)


Previous (Disconnect)
Next (GetDSPPlugins)

Name
GetConnections

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetConnections : IEncoderConnectionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Disconnect)
Next (GetDSPPlugins)


Previous (GetConnections)
Next (GetLineInputEnabled)

Name
GetDSPPlugins

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetDSPPlugins : IBassDSPPluginList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnections)
Next (GetLineInputEnabled)


Previous (GetDSPPlugins)
Next (GetListeners)

Name
GetLineInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetLineInputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDSPPlugins)
Next (GetListeners)


Previous (GetLineInputEnabled)
Next (GetLocalOutputEnabled)

Name
GetListeners

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetListeners : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLineInputEnabled)
Next (GetLocalOutputEnabled)


Previous (GetListeners)
Next (GetMicInputEnabled)

Name
GetLocalOutputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetLocalOutputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetListeners)
Next (GetMicInputEnabled)


Previous (GetLocalOutputEnabled)
Next (GetOptions)

Name
GetMicInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetMicInputEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLocalOutputEnabled)
Next (GetOptions)


Previous (GetMicInputEnabled)
Next (GetSamplerate)

Name
GetOptions

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetOptions : TEncoderOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMicInputEnabled)
Next (GetSamplerate)


Previous (GetOptions)
Next (GetState)

Name
GetSamplerate

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetSamplerate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetState)


Previous (GetSamplerate)
Next (SetLineInputEnabled)

Name
GetState

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
function GetState : TEncoderState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSamplerate)
Next (SetLineInputEnabled)


Previous (GetState)
Next (SetLocalOutputEnabled)

Name
SetLineInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetLineInputEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetLocalOutputEnabled)


Previous (SetLineInputEnabled)
Next (SetMicInputEnabled)

Name
SetLocalOutputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetLocalOutputEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetLineInputEnabled)
Next (SetMicInputEnabled)


Previous (SetLocalOutputEnabled)
Next (SetOptions)

Name
SetMicInputEnabled

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetMicInputEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetLocalOutputEnabled)
Next (SetOptions)


Previous (SetMicInputEnabled)
Next (SetSamplerate)

Name
SetOptions

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TEncoderOptions )

Parameters
Parameter Description
iValue : TEncoderOptions

mAirListScript
Class Tree
Index
Previous (SetMicInputEnabled)
Next (SetSamplerate)


Previous (SetOptions)
Next

Name
SetSamplerate

Parent
IBassStreamingEncoder

Visibility
PUBLIC

Source code
procedure SetSamplerate ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (IBassStreamingEncoder)
Next (IEncoderConnection)

Name
IBassStreamingModule

Parent
BassStreamingInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Members
Methods
Method Description
GetEncoder (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingEncoder)
Next (IEncoderConnection)


Previous
Next

Name
GetEncoder

Parent
IBassStreamingModule

Visibility
PUBLIC

Source code
function GetEncoder : IBassStreamingEncoder

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IBassStreamingModule)
Next (IEncoderConnectionList)

Name
IEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
GetCustomCaption (+)
GetDSPPlugins (+)
GetEncoderStream (+)
GetListeners (+)
GetRegions (+)
GetState (+)
ItemStarted (+)
SetCustomCaption (+)
SetEncoderStream (+)
SetRegions (+)
SetStreamTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBassStreamingModule)
Next (IEncoderConnectionList)


Previous
Next (GetDSPPlugins)

Name
GetCustomCaption

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetCustomCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDSPPlugins)


Previous (GetCustomCaption)
Next (GetEncoderStream)

Name
GetDSPPlugins

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetDSPPlugins : IBassDSPPluginList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomCaption)
Next (GetEncoderStream)


Previous (GetDSPPlugins)
Next (GetListeners)

Name
GetEncoderStream

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetEncoderStream : HSTREAM

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDSPPlugins)
Next (GetListeners)


Previous (GetEncoderStream)
Next (GetRegions)

Name
GetListeners

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetListeners : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEncoderStream)
Next (GetRegions)


Previous (GetListeners)
Next (GetState)

Name
GetRegions

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetRegions : TRegions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetListeners)
Next (GetState)


Previous (GetRegions)
Next (ItemStarted)

Name
GetState

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
function GetState : TEncoderConnectionState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (ItemStarted)


Previous (GetState)
Next (SetCustomCaption)

Name
ItemStarted

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure ItemStarted ( iItem : IPlaylistItem ; iRegion : TRegion )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetCustomCaption)


Previous (ItemStarted)
Next (SetEncoderStream)

Name
SetCustomCaption

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetCustomCaption ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (ItemStarted)
Next (SetEncoderStream)


Previous (SetCustomCaption)
Next (SetRegions)

Name
SetEncoderStream

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetEncoderStream ( iValue : HSTREAM )

Parameters
Parameter Description
iValue : HSTREAM

mAirListScript
Class Tree
Index
Previous (SetCustomCaption)
Next (SetRegions)


Previous (SetEncoderStream)
Next (SetStreamTitle)

Name
SetRegions

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetRegions ( iValue : TRegions )

Parameters
Parameter Description
iValue : TRegions

mAirListScript
Class Tree
Index
Previous (SetEncoderStream)
Next (SetStreamTitle)


Previous (SetRegions)
Next

Name
SetStreamTitle

Parent
IEncoderConnection

Visibility
PUBLIC

Source code
procedure SetStreamTitle ( iTitle : string ; iImmediately : boolean )

Parameters
Parameter Description
iTitle : STRING
iImmediately : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetRegions)
Next


Previous (IEncoderConnection)
Next (IIcecastEncoderConnection)

Name
IEncoderConnectionList

Parent
BassStreamingInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetEncoderStream (+)
GetItem (+)
ItemStarted (+)
SetEncoderStream (+)
SetStreamTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEncoderConnection)
Next (IIcecastEncoderConnection)


Previous
Next (GetItem)

Name
GetEncoderStream

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
function GetEncoderStream : HSTREAM

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEncoderStream)
Next (ItemStarted)

Name
GetItem

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IEncoderConnection

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEncoderStream)
Next (ItemStarted)


Previous (GetItem)
Next (SetEncoderStream)

Name
ItemStarted

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure ItemStarted ( iItem : IPlaylistItem ; iRegion : TRegion )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (SetEncoderStream)


Previous (ItemStarted)
Next (SetStreamTitle)

Name
SetEncoderStream

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure SetEncoderStream ( iValue : HSTREAM )

Parameters
Parameter Description
iValue : HSTREAM

mAirListScript
Class Tree
Index
Previous (ItemStarted)
Next (SetStreamTitle)


Previous (SetEncoderStream)
Next

Name
SetStreamTitle

Parent
IEncoderConnectionList

Visibility
PUBLIC

Source code
procedure SetStreamTitle ( iTitle : string ; iImmediately : boolean )

Parameters
Parameter Description
iTitle : STRING
iImmediately : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetEncoderStream)
Next


Previous (IEncoderConnectionList)
Next (IInternalServerEncoderConnection)

Name
IIcecastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetMount (+)
SetMount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEncoderConnectionList)
Next (IInternalServerEncoderConnection)


Previous
Next (SetMount)

Name
GetMount

Parent
IIcecastEncoderConnection

Visibility
PUBLIC

Source code
function GetMount : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetMount)


Previous (GetMount)
Next

Name
SetMount

Parent
IIcecastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetMount ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetMount)
Next


Previous (IIcecastEncoderConnection)
Next (IShoutcastEncoderConnection)

Name
IInternalServerEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBassEncEncoderConnection

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIcecastEncoderConnection)
Next (IShoutcastEncoderConnection)


Previous (IInternalServerEncoderConnection)
Next

Name
IShoutcastEncoderConnection

Parent
BassStreamingInterfaces

Class Hierarchy
IBaseShoutcastEncoderConnection

Visibility
PUBLIC

Members
Methods
Method Description
GetStreamID (+)
SetStreamID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInternalServerEncoderConnection)
Next


Previous
Next (SetStreamID)

Name
GetStreamID

Parent
IShoutcastEncoderConnection

Visibility
PUBLIC

Source code
function GetStreamID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetStreamID)


Previous (GetStreamID)
Next

Name
SetStreamID

Parent
IShoutcastEncoderConnection

Visibility
PUBLIC

Source code
procedure SetStreamID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetStreamID)
Next


Previous (BassStreamingInterfaces)
Next (CoreRemoteInterface)

Name
BassStreamingTypes

Parent
mAirListScript

Types
Type Description
TBassStreamingFormat (+)
TBassStreamingFormats (+)
TEncoderConnectionState (+)
TEncoderOption (+)
TEncoderOptions (+)
TEncoderState (+)

Constants
Constant Description
AllBassStreamingFormats (+)
DefaultEncoderOptions (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (BassStreamingInterfaces)
Next (CoreRemoteInterface)


Previous
Next (TBassStreamingFormats)

Name
TBassStreamingFormat

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TBassStreamingFormat = ( sfMP3 , sfOggVorbis ) ;

mAirListScript
Class Tree
Index
Previous
Next (TBassStreamingFormats)


Previous (TBassStreamingFormat)
Next (TEncoderConnectionState)

Name
TBassStreamingFormats

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TBassStreamingFormats = set of TBassStreamingFormat ;

mAirListScript
Class Tree
Index
Previous (TBassStreamingFormat)
Next (TEncoderConnectionState)


Previous (TBassStreamingFormats)
Next (TEncoderOption)

Name
TEncoderConnectionState

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderConnectionState = ( ecsConnected , ecsConnecting , ecsDisconnected , ecsError ) ;

mAirListScript
Class Tree
Index
Previous (TBassStreamingFormats)
Next (TEncoderOption)


Previous (TEncoderConnectionState)
Next (TEncoderOptions)

Name
TEncoderOption

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderOption = ( eoLinkOnAir ) ;

mAirListScript
Class Tree
Index
Previous (TEncoderConnectionState)
Next (TEncoderOptions)


Previous (TEncoderOption)
Next (TEncoderState)

Name
TEncoderOptions

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderOptions = set of TEncoderOption ;

mAirListScript
Class Tree
Index
Previous (TEncoderOption)
Next (TEncoderState)


Previous (TEncoderOptions)
Next

Name
TEncoderState

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
TEncoderState = ( esConnected , esDisconnected ) ;

mAirListScript
Class Tree
Index
Previous (TEncoderOptions)
Next


Previous
Next (DefaultEncoderOptions)

Name
AllBassStreamingFormats

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
AllBassStreamingFormats = [ sfMP3 , sfOggVorbis ]

mAirListScript
Class Tree
Index
Previous
Next (DefaultEncoderOptions)


Previous (AllBassStreamingFormats)
Next

Name
DefaultEncoderOptions

Parent
BassStreamingTypes

Visibility
PUBLIC

Source code
DefaultEncoderOptions = [ ]

mAirListScript
Class Tree
Index
Previous (AllBassStreamingFormats)
Next


Previous (BassStreamingTypes)
Next (DHDInterfaces)

Name
CoreRemoteInterface

Parent
mAirListScript

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (BassStreamingTypes)
Next (DHDInterfaces)


Previous (CoreRemoteInterface)
Next (DHDTypes)

Name
DHDInterfaces

Parent
mAirListScript

Classes
Class Description
IRM4200DAction (+)
IRM4200DChannelValueAction (+)
IRM4200DRemote (+)
IRM4200DSetAllPFLOffAction (+)
IRM4200DSetFaderOnAction (+)
IRM4200DSetLogicAction (+)
IRM4200DSetPFLAction (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (CoreRemoteInterface)
Next (DHDTypes)


Previous
Next (IRM4200DChannelValueAction)

Name
IRM4200DAction

Parent
DHDInterfaces

Class Hierarchy
IRemoteAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IRM4200DChannelValueAction)


Previous (IRM4200DAction)
Next (IRM4200DRemote)

Name
IRM4200DChannelValueAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Members
Methods
Method Description
GetChannel (+)
GetValue (+)
SetChannel (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DAction)
Next (IRM4200DRemote)


Previous
Next (GetValue)

Name
GetChannel

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
function GetChannel : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetValue)


Previous (GetChannel)
Next (SetChannel)

Name
GetValue

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChannel)
Next (SetChannel)


Previous (GetValue)
Next (SetValue)

Name
SetChannel

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
procedure SetChannel ( iValue : word )

Parameters
Parameter Description
iValue : WORD

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetValue)


Previous (SetChannel)
Next

Name
SetValue

Parent
IRM4200DChannelValueAction

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetChannel)
Next


Previous (IRM4200DChannelValueAction)
Next (IRM4200DSetAllPFLOffAction)

Name
IRM4200DRemote

Parent
DHDInterfaces

Class Hierarchy
IRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetCommunicationMode (+)
GetHostname (+)
GetLogicOffCommand (+)
GetLogicOnCommand (+)
GetSerialPort (+)
GetTCPPort (+)
SendPacket (+)
SetAllPFLOff (+)
SetCommunicationMode (+)
SetFaderOn (+)
SetHostname (+)
SetLogic (+)
SetLogicOffCommand (+)
SetLogicOnCommand (+)
SetMonitorChannel (+)
SetPFL (+)
SetSerialPort (+)
SetTCPPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DChannelValueAction)
Next (IRM4200DSetAllPFLOffAction)


Previous
Next (GetHostname)

Name
GetCommunicationMode

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetCommunicationMode : TCommunicationMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetHostname)


Previous (GetCommunicationMode)
Next (GetLogicOffCommand)

Name
GetHostname

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetHostname : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommunicationMode)
Next (GetLogicOffCommand)


Previous (GetHostname)
Next (GetLogicOnCommand)

Name
GetLogicOffCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetLogicOffCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetHostname)
Next (GetLogicOnCommand)


Previous (GetLogicOffCommand)
Next (GetSerialPort)

Name
GetLogicOnCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetLogicOnCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetLogicOffCommand)
Next (GetSerialPort)


Previous (GetLogicOnCommand)
Next (GetTCPPort)

Name
GetSerialPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetSerialPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogicOnCommand)
Next (GetTCPPort)


Previous (GetSerialPort)
Next (SendPacket)

Name
GetTCPPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
function GetTCPPort : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerialPort)
Next (SendPacket)


Previous (GetTCPPort)
Next (SetAllPFLOff)

Name
SendPacket

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SendPacket ( iID : cardinal ; iData : AnsiString )

Parameters
Parameter Description
iID : CARDINAL
iData : ANSISTRING

mAirListScript
Class Tree
Index
Previous (GetTCPPort)
Next (SetAllPFLOff)


Previous (SendPacket)
Next (SetCommunicationMode)

Name
SetAllPFLOff

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetAllPFLOff

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SendPacket)
Next (SetCommunicationMode)


Previous (SetAllPFLOff)
Next (SetFaderOn)

Name
SetCommunicationMode

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetCommunicationMode ( iValue : TCommunicationMode )

Parameters
Parameter Description
iValue : TCommunicationMode

mAirListScript
Class Tree
Index
Previous (SetAllPFLOff)
Next (SetFaderOn)


Previous (SetCommunicationMode)
Next (SetHostname)

Name
SetFaderOn

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetFaderOn ( iChannel : word ; iValue : boolean )

Parameters
Parameter Description
iChannel : WORD
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetCommunicationMode)
Next (SetHostname)


Previous (SetFaderOn)
Next (SetLogic)

Name
SetHostname

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetHostname ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetFaderOn)
Next (SetLogic)


Previous (SetHostname)
Next (SetLogicOffCommand)

Name
SetLogic

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogic ( iAddress : word ; iValue : boolean )

Parameters
Parameter Description
iAddress : WORD
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetHostname)
Next (SetLogicOffCommand)


Previous (SetLogic)
Next (SetLogicOnCommand)

Name
SetLogicOffCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogicOffCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetLogic)
Next (SetLogicOnCommand)


Previous (SetLogicOffCommand)
Next (SetMonitorChannel)

Name
SetLogicOnCommand

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetLogicOnCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetLogicOffCommand)
Next (SetMonitorChannel)


Previous (SetLogicOnCommand)
Next (SetPFL)

Name
SetMonitorChannel

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetMonitorChannel ( iNumber : byte ; iLeft , iRight : word )

Parameters
Parameter Description
iNumber : BYTE
iLeft : WORD
iRight : WORD

mAirListScript
Class Tree
Index
Previous (SetLogicOnCommand)
Next (SetPFL)


Previous (SetMonitorChannel)
Next (SetSerialPort)

Name
SetPFL

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetPFL ( iChannel : word ; iValue , iAutoMute : boolean )

Parameters
Parameter Description
iChannel : WORD
iValue : BOOLEAN
iAutoMute : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetMonitorChannel)
Next (SetSerialPort)


Previous (SetPFL)
Next (SetTCPPort)

Name
SetSerialPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetSerialPort ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPFL)
Next (SetTCPPort)


Previous (SetSerialPort)
Next

Name
SetTCPPort

Parent
IRM4200DRemote

Visibility
PUBLIC

Source code
procedure SetTCPPort ( iValue : word )

Parameters
Parameter Description
iValue : WORD

mAirListScript
Class Tree
Index
Previous (SetSerialPort)
Next


Previous (IRM4200DRemote)
Next (IRM4200DSetFaderOnAction)

Name
IRM4200DSetAllPFLOffAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DRemote)
Next (IRM4200DSetFaderOnAction)


Previous (IRM4200DSetAllPFLOffAction)
Next (IRM4200DSetLogicAction)

Name
IRM4200DSetFaderOnAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DChannelValueAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetAllPFLOffAction)
Next (IRM4200DSetLogicAction)


Previous (IRM4200DSetFaderOnAction)
Next (IRM4200DSetPFLAction)

Name
IRM4200DSetLogicAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DAction

Visibility
PUBLIC

Members
Methods
Method Description
GetAddress (+)
GetValue (+)
SetAddress (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetFaderOnAction)
Next (IRM4200DSetPFLAction)


Previous
Next (GetValue)

Name
GetAddress

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
function GetAddress : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetValue)


Previous (GetAddress)
Next (SetAddress)

Name
GetValue

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAddress)
Next (SetAddress)


Previous (GetValue)
Next (SetValue)

Name
SetAddress

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
procedure SetAddress ( iValue : word )

Parameters
Parameter Description
iValue : WORD

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetValue)


Previous (SetAddress)
Next

Name
SetValue

Parent
IRM4200DSetLogicAction

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetAddress)
Next


Previous (IRM4200DSetLogicAction)
Next

Name
IRM4200DSetPFLAction

Parent
DHDInterfaces

Class Hierarchy
IRM4200DChannelValueAction

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoMute (+)
SetAutoMute (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRM4200DSetLogicAction)
Next


Previous
Next (SetAutoMute)

Name
GetAutoMute

Parent
IRM4200DSetPFLAction

Visibility
PUBLIC

Source code
function GetAutoMute : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetAutoMute)


Previous (GetAutoMute)
Next

Name
SetAutoMute

Parent
IRM4200DSetPFLAction

Visibility
PUBLIC

Source code
procedure SetAutoMute ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetAutoMute)
Next


Previous (DHDInterfaces)
Next (InpOut32Interface)

Name
DHDTypes

Parent
mAirListScript

Types
Type Description
TCommunicationMode (+)

Constants
Constant Description
MAX_RM4200D_ADDRESS (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (DHDInterfaces)
Next (InpOut32Interface)


Previous
Next

Name
TCommunicationMode

Parent
DHDTypes

Visibility
PUBLIC

Source code
TCommunicationMode = ( cmSerial , cmTCP ) ;

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next

Name
MAX_RM4200D_ADDRESS

Parent
DHDTypes

Visibility
PUBLIC

Source code
MAX_RM4200D_ADDRESS = 4095

mAirListScript
Class Tree
Index
Previous
Next


Previous (DHDTypes)
Next (mAirListInterfaces)

Name
InpOut32Interface

Parent
mAirListScript

Classes
Class Description
IIOPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (DHDTypes)
Next (mAirListInterfaces)


Previous
Next

Name
IIOPort

Parent
InpOut32Interface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
READ (+)
WRITE (+)
WriteAND (+)
WriteOR (+)
WriteXOR (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (WRITE)

Name
READ

Parent
IIOPort

Visibility
PUBLIC

Source code
function Read : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (WRITE)


Previous (READ)
Next (WriteAND)

Name
WRITE

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure Write ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (READ)
Next (WriteAND)


Previous (WRITE)
Next (WriteOR)

Name
WriteAND

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteAND ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WRITE)
Next (WriteOR)


Previous (WriteAND)
Next (WriteXOR)

Name
WriteOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteOR ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WriteAND)
Next (WriteXOR)


Previous (WriteOR)
Next

Name
WriteXOR

Parent
IIOPort

Visibility
PUBLIC

Source code
procedure WriteXOR ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (WriteOR)
Next


Previous (InpOut32Interface)
Next (mAirListScript)

Name
mAirListInterfaces

Parent
mAirListScript

Types
Type Description
IAudioSourceArray (+)
TMessageProc (+)

Classes
Class Description
IAction (+)
IActionList (+)
IActivePlaylist (+)
IActivePlaylistItemMetadata (+)
IAddableCueDataItem (+)
IAddablePlaylistItem (+)
IAlternativeMarkerCueDataItem (+)
IAudioDevice (+)
IAudioDeviceConfig (+)
IAudioDeviceList (+)
IAudioEffect (+)
IAudioEffectList (+)
IAudioSource (+)
IAutoCueEngine (+)
IBaseComPortRemote (+)
IBaseList (+)
IBaseMarkerCueDataItem (+)
IBaseMessage (+)
IBreakPlaylistItem (+)
ICartPlayerControl (+)
ICartWallControl (+)
IClientList (+)
ICommandPlaylistItem (+)
IComPort (+)
IConfigObject (+)
IConfigObjectList (+)
IConfiguration (+)
IContainerPlaylistItem (+)
ICueData (+)
ICueDataItem (+)
IDatabase (+)
IDatabaseAction (+)
IDatabaseInlineLoader (+)
IDatabaseList (+)
IDatabaseSearchHandler (+)
IDatabaseTree (+)
IDebugObject (+)
IDummyAction (+)
IDummyObject (+)
IDummyPlaylistItem (+)
IEmergencyAction (+)
IEngine (+)
IEngineDesktopPlugin (+)
IEngineInfo (+)
IEnvelope (+)
IEnvelopePoint (+)
IEOFWarningCueDataItem (+)
IEventList (+)
IEventListItem (+)
IEventsModule (+)
IFactory (+)
IFactoryClass (+)
IFactoryObjectList (+)
IFileEncoder (+)
IFileEncoderSettings (+)
IFileManager (+)
IFilePlaylistItem (+)
IFilePlaylistItemClass (+)
IFileStorageClass (+)
IFileTypeHandler (+)
IFileTypeHandlerClass (+)
IHiddenModule (+)
IInfiniteSilencePlaylistItem (+)
IInlineData (+)
IInlineFilePlaylistItem (+)
IInstanceData (+)
ILevelInfo (+)
ILicenseManager (+)
ILogEntry (+)
ILogEntryList (+)
ILogger (+)
ILogInterface (+)
ILogInterfaceList (+)
ImAirListInstance (+)
IMarkerCueDataitem (+)
IMessageDispatcher (+)
IMetaCueDataItem (+)
IMixdownEngine (+)
IMixdownEngine2 (+)
IMixer (+)
IModule (+)
IModuleList (+)
IMultiAudioSource (+)
IMultiInstanceModule (+)
IMultiPlaylist (+)
IMultiPlaylistItemMetadata (+)
IMutex (+)
INoAudioDevice (+)
INotifiedMessageReceiver (+)
INotifyItemStarted (+)
IObservable (+)
IObservableList (+)
IPeakAnalyzer (+)
IPersistent (+)
IPersistentArray (+)
IPersistentBoolean (+)
IPersistentDateTime (+)
IPersistentInteger (+)
IPersistentList (+)
IPersistentListItem (+)
IPersistentListItemMetadata (+)
IPersistentNull (+)
IPersistentNumber (+)
IPersistentObject (+)
IPersistentPlaylistItemMetadata (+)
IPersistentStorage (+)
IPersistentString (+)
IPlaybackControl (+)
IPlaybackDevice (+)
IPlaybackDeviceList (+)
IPlayerControl (+)
IPlaylist (+)
IPlaylistExporter (+)
IPlaylistFilePlaylistItem (+)
IPlaylistImporter (+)
IPlaylistItem (+)
IPlaylistItemMetadata (+)
IPlaylistPlayerControl (+)
IPlaylistStorage (+)
IProgressIndicator (+)
IRecordDevice (+)
IRecordDeviceList (+)
IRecycleBinPlaylist (+)
IRegionContainerPlaylistItem (+)
IRemote (+)
IRemoteAction (+)
IRemoteController (+)
IRunnable (+)
ISerialPortManager (+)
ISilencePlaylistItem (+)
ISourceControl (+)
IStream (+)
IStreamPlaylistItem (+)
IStrings (+)
IStubPlaylistItem (+)
ITrackCueDataItem (+)
IUpdateObject (+)
IURLPlaylistItem (+)
IWritableStream (+)
TDatabaseNodeData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (InpOut32Interface)
Next (mAirListScript)


Previous
Next (IActionList)

Name
IAction

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
CloneAsAction (+)
Execute (+)
GetCaption (+)
GetPlaylist (+)
GetTimeOffset (+)
GetTitle (+)
GetUseVariables (+)
SetPlaylist (+)
SetTimeOffset (+)
SetTitle (+)
SetUseVariables (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (IActionList)


Previous
Next (Execute)

Name
CloneAsAction

Parent
IAction

Visibility
PUBLIC

Source code
function CloneAsAction : IAction

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Execute)


Previous (CloneAsAction)
Next (GetCaption)

Name
Execute

Parent
IAction

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous (CloneAsAction)
Next (GetCaption)


Previous (Execute)
Next (GetPlaylist)

Name
GetCaption

Parent
IAction

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetPlaylist)


Previous (GetCaption)
Next (GetTimeOffset)

Name
GetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
function GetPlaylist : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetTimeOffset)


Previous (GetPlaylist)
Next (GetTitle)

Name
GetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
function GetTimeOffset : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetTitle)


Previous (GetTimeOffset)
Next (GetUseVariables)

Name
GetTitle

Parent
IAction

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeOffset)
Next (GetUseVariables)


Previous (GetTitle)
Next (SetPlaylist)

Name
GetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
function GetUseVariables : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (SetPlaylist)


Previous (GetUseVariables)
Next (SetTimeOffset)

Name
SetPlaylist

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetPlaylist ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUseVariables)
Next (SetTimeOffset)


Previous (SetPlaylist)
Next (SetTitle)

Name
SetTimeOffset

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTimeOffset ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPlaylist)
Next (SetTitle)


Previous (SetTimeOffset)
Next (SetUseVariables)

Name
SetTitle

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTimeOffset)
Next (SetUseVariables)


Previous (SetTitle)
Next

Name
SetUseVariables

Parent
IAction

Visibility
PUBLIC

Source code
procedure SetUseVariables ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IAction)
Next (IActivePlaylist)

Name
IActionList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
Execute (+)
ExecuteAsync (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAction)
Next (IActivePlaylist)


Previous
Next (ExecuteAsync)

Name
Execute

Parent
IActionList

Visibility
PUBLIC

Source code
procedure Execute ( iPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (ExecuteAsync)


Previous (Execute)
Next (GetItem)

Name
ExecuteAsync

Parent
IActionList

Visibility
PUBLIC

Source code
procedure ExecuteAsync ( iDefaultPlaylist : integer ; iTimeOffset : integer )

Parameters
Parameter Description
iDefaultPlaylist : INTEGER
iTimeOffset : INTEGER

mAirListScript
Class Tree
Index
Previous (Execute)
Next (GetItem)


Previous (ExecuteAsync)
Next

Name
GetItem

Parent
IActionList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IAction

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (ExecuteAsync)
Next


Previous (IActionList)
Next (IActivePlaylistItemMetadata)

Name
IActivePlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPlaylist

Visibility
PUBLIC

Members
Methods
Method Description
AutomationForceNext (+)
AutomationNext (+)
AutomationPlay (+)
AutomationStop (+)
GetActivePlaylistItemMetadata (+)
GetAutomation (+)
GetAutomationPlaying (+)
GetItemPlaybackState (+)
GetSourceControl (+)
SetAutomation (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActionList)
Next (IActivePlaylistItemMetadata)


Previous
Next (AutomationNext)

Name
AutomationForceNext

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationForceNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutomationNext)


Previous (AutomationForceNext)
Next (AutomationPlay)

Name
AutomationNext

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationForceNext)
Next (AutomationPlay)


Previous (AutomationNext)
Next (AutomationStop)

Name
AutomationPlay

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationPlay

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationNext)
Next (AutomationStop)


Previous (AutomationPlay)
Next (GetActivePlaylistItemMetadata)

Name
AutomationStop

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure AutomationStop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationPlay)
Next (GetActivePlaylistItemMetadata)


Previous (AutomationStop)
Next (GetAutomation)

Name
GetActivePlaylistItemMetadata

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetActivePlaylistItemMetadata ( iIndex : integer ) : IActivePlaylistItemMetadata

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (AutomationStop)
Next (GetAutomation)


Previous (GetActivePlaylistItemMetadata)
Next (GetAutomationPlaying)

Name
GetAutomation

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetAutomation : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePlaylistItemMetadata)
Next (GetAutomationPlaying)


Previous (GetAutomation)
Next (GetItemPlaybackState)

Name
GetAutomationPlaying

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetAutomationPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutomation)
Next (GetItemPlaybackState)


Previous (GetAutomationPlaying)
Next (GetSourceControl)

Name
GetItemPlaybackState

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure GetItemPlaybackState ( iIndex : integer ; var oState : TPlaybackState ; var oPlayerIndex : integer ; var oPosition : TTimeValue )

Parameters
Parameter Description
iIndex : INTEGER
oState : TPlaybackState
oPlayerIndex : INTEGER
oPosition : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetAutomationPlaying)
Next (GetSourceControl)


Previous (GetItemPlaybackState)
Next (SetAutomation)

Name
GetSourceControl

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
function GetSourceControl ( iIndex : integer ) : ISourceControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItemPlaybackState)
Next (SetAutomation)


Previous (GetSourceControl)
Next

Name
SetAutomation

Parent
IActivePlaylist

Visibility
PUBLIC

Source code
procedure SetAutomation ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetSourceControl)
Next


Previous (IActivePlaylist)
Next (IAddableCueDataItem)

Name
IActivePlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetSourceControl (+)
SetSourceControl (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActivePlaylist)
Next (IAddableCueDataItem)


Previous
Next (SetSourceControl)

Name
GetSourceControl

Parent
IActivePlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetSourceControl)


Previous (GetSourceControl)
Next

Name
SetSourceControl

Parent
IActivePlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetSourceControl ( iValue : ISourceControl )

Parameters
Parameter Description
iValue : ISourceControl

mAirListScript
Class Tree
Index
Previous (GetSourceControl)
Next


Previous (IActivePlaylistItemMetadata)
Next (IAddablePlaylistItem)

Name
IAddableCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IActivePlaylistItemMetadata)
Next (IAddablePlaylistItem)


Previous (IAddableCueDataItem)
Next (IAlternativeMarkerCueDataItem)

Name
IAddablePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddableCueDataItem)
Next (IAlternativeMarkerCueDataItem)


Previous (IAddablePlaylistItem)
Next (IAudioDevice)

Name
IAlternativeMarkerCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
IBaseMarkerCueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAddablePlaylistItem)
Next (IAudioDevice)


Previous (IAlternativeMarkerCueDataItem)
Next (IAudioDeviceConfig)

Name
IAudioDevice

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetDisplayName (+)
GetID (+)
GetLocker (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAlternativeMarkerCueDataItem)
Next (IAudioDeviceConfig)


Previous
Next (GetID)

Name
GetDisplayName

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetDisplayName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetID)


Previous (GetDisplayName)
Next (GetLocker)

Name
GetID

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisplayName)
Next (GetLocker)


Previous (GetID)
Next

Name
GetLocker

Parent
IAudioDevice

Visibility
PUBLIC

Source code
function GetLocker : IUnknown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next


Previous (IAudioDevice)
Next (IAudioDeviceList)

Name
IAudioDeviceConfig

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
AddNode (+)
DeleteNodesByPrefix (+)
GetAssignment (+)
GetAudioDevice (+)
GetDefaultDevice (+)
GetNoAudioDevice (+)
GetNode (+)
GetNodeCount (+)
GetPlaybackDevice (+)
GetRecordDevice (+)
GetRegionDevices (+)
SetAssignment (+)
SetSingleAssignment (+)
UpdateDevices (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDevice)
Next (IAudioDeviceList)


Previous
Next (DeleteNodesByPrefix)

Name
AddNode

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure AddNode ( iDeviceType : TAudioDeviceType ; iID , iDefaultID , iReadablePath : string ; iFilterGUID : TGUID ; iAutoAddRegions : boolean )

Parameters
Parameter Description
iDeviceType : TAudioDeviceType
iID : STRING
iDefaultID : STRING
iReadablePath : STRING
iFilterGUID : TGUID
iAutoAddRegions : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (DeleteNodesByPrefix)


Previous (AddNode)
Next (GetAssignment)

Name
DeleteNodesByPrefix

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure DeleteNodesByPrefix ( iDeviceType : TAudioDeviceType ; iPrefix : string )

Parameters
Parameter Description
iDeviceType : TAudioDeviceType
iPrefix : STRING

mAirListScript
Class Tree
Index
Previous (AddNode)
Next (GetAssignment)


Previous (DeleteNodesByPrefix)
Next (GetAudioDevice)

Name
GetAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetAssignment ( iDeviceType : TAudioDeviceType ) : IStrings

Parameters
Parameter Description
iDeviceType : TAudioDeviceType

mAirListScript
Class Tree
Index
Previous (DeleteNodesByPrefix)
Next (GetAudioDevice)


Previous (GetAssignment)
Next (GetDefaultDevice)

Name
GetAudioDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetAudioDevice ( iDeviceType : TAudioDeviceType ; iID : string ) : IAudioDevice

Parameters
Parameter Description
iDeviceType : TAudioDeviceType
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetAssignment)
Next (GetDefaultDevice)


Previous (GetAudioDevice)
Next (GetNoAudioDevice)

Name
GetDefaultDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetDefaultDevice ( iDeviceType : TAudioDeviceType ) : IAudioDevice

Parameters
Parameter Description
iDeviceType : TAudioDeviceType

mAirListScript
Class Tree
Index
Previous (GetAudioDevice)
Next (GetNoAudioDevice)


Previous (GetDefaultDevice)
Next (GetNode)

Name
GetNoAudioDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetNoAudioDevice ( iDeviceType : TAudioDeviceType ) : INoAudioDevice

Parameters
Parameter Description
iDeviceType : TAudioDeviceType

mAirListScript
Class Tree
Index
Previous (GetDefaultDevice)
Next (GetNode)


Previous (GetNoAudioDevice)
Next (GetNodeCount)

Name
GetNode

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure GetNode ( iIndex : integer ; out oDeviceType : TAudioDeviceType ; out oID , oDefaultID , oReadablePath : string ; out oFilterGUID : TGUID )

Parameters
Parameter Description
iIndex : INTEGER
oDeviceType : TAudioDeviceType
oID : STRING
oDefaultID : STRING
oReadablePath : STRING
oFilterGUID : TGUID

mAirListScript
Class Tree
Index
Previous (GetNoAudioDevice)
Next (GetNodeCount)


Previous (GetNode)
Next (GetPlaybackDevice)

Name
GetNodeCount

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetNodeCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNode)
Next (GetPlaybackDevice)


Previous (GetNodeCount)
Next (GetRecordDevice)

Name
GetPlaybackDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetPlaybackDevice ( iID : string ) : IPlaybackDevice

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetNodeCount)
Next (GetRecordDevice)


Previous (GetPlaybackDevice)
Next (GetRegionDevices)

Name
GetRecordDevice

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetRecordDevice ( iID : string ) : IRecordDevice

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetPlaybackDevice)
Next (GetRegionDevices)


Previous (GetRecordDevice)
Next (SetAssignment)

Name
GetRegionDevices

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
function GetRegionDevices ( iID : string ) : IPlaybackDeviceList

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetRecordDevice)
Next (SetAssignment)


Previous (GetRegionDevices)
Next (SetSingleAssignment)

Name
SetAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SetAssignment ( iDeviceType : TAudioDeviceType ; iValue : IStrings )

Parameters
Parameter Description
iDeviceType : TAudioDeviceType
iValue : IStrings

mAirListScript
Class Tree
Index
Previous (GetRegionDevices)
Next (SetSingleAssignment)


Previous (SetAssignment)
Next (UpdateDevices)

Name
SetSingleAssignment

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure SetSingleAssignment ( iDeviceType : TAudioDeviceType ; iID : string ; iDevice : string )

Parameters
Parameter Description
iDeviceType : TAudioDeviceType
iID : STRING
iDevice : STRING

mAirListScript
Class Tree
Index
Previous (SetAssignment)
Next (UpdateDevices)


Previous (SetSingleAssignment)
Next

Name
UpdateDevices

Parent
IAudioDeviceConfig

Visibility
PUBLIC

Source code
procedure UpdateDevices

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetSingleAssignment)
Next


Previous (IAudioDeviceConfig)
Next (IAudioEffect)

Name
IAudioDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
Equals (+)
GetAudioDevice (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceConfig)
Next (IAudioEffect)


Previous
Next (GetAudioDevice)

Name
Equals

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function Equals ( iValue : IAudioDeviceList ) : boolean

Parameters
Parameter Description
iValue : IAudioDeviceList

mAirListScript
Class Tree
Index
Previous
Next (GetAudioDevice)


Previous (Equals)
Next (IndexOfID)

Name
GetAudioDevice

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function GetAudioDevice ( iIndex : integer ) : IAudioDevice

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Equals)
Next (IndexOfID)


Previous (GetAudioDevice)
Next

Name
IndexOfID

Parent
IAudioDeviceList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : string ) : integer

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetAudioDevice)
Next


Previous (IAudioDeviceList)
Next (IAudioEffectList)

Name
IAudioEffect

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
ProcessFile (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioDeviceList)
Next (IAudioEffectList)


Previous
Next

Name
ProcessFile

Parent
IAudioEffect

Visibility
PUBLIC

Source code
function ProcessFile ( iFile : IStream ; iProgressIndicator : IProgressIndicator ) : IStream

Parameters
Parameter Description
iFile : IStream
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous
Next


Previous (IAudioEffect)
Next (IAudioSource)

Name
IAudioEffectList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioEffect)
Next (IAudioSource)


Previous
Next

Name
GetItem

Parent
IAudioEffectList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IAudioEffect

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next


Previous (IAudioEffectList)
Next (IAutoCueEngine)

Name
IAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanChangeDevice (+)
ChangeDevice (+)
CueModeOff (+)
CueModeOn (+)
FadeOut (+)
GetAmplification (+)
GetCapabilities (+)
GetDuration (+)
GetDynamicTitle (+)
GetIsPlaying (+)
GetItem (+)
GetOptions (+)
GetPitch (+)
GetPosition (+)
GetRegion (+)
GetTempo (+)
GetVolume (+)
IsCueable (+)
Pause (+)
Reset (+)
SetAmplification (+)
SetCueData (+)
SetOptions (+)
SetPitch (+)
SetPosition (+)
SetRegion (+)
SetTempo (+)
SetVolume (+)
SetVolumeEnvelope (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioEffectList)
Next (IAutoCueEngine)


Previous
Next (ChangeDevice)

Name
CanChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
function CanChangeDevice ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList ) : boolean

Parameters
Parameter Description
iDevice : IPlaybackDevice
iRegionDevices : IPlaybackDeviceList

mAirListScript
Class Tree
Index
Previous
Next (ChangeDevice)


Previous (CanChangeDevice)
Next (CueModeOff)

Name
ChangeDevice

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure ChangeDevice ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList )

Parameters
Parameter Description
iDevice : IPlaybackDevice
iRegionDevices : IPlaybackDeviceList

mAirListScript
Class Tree
Index
Previous (CanChangeDevice)
Next (CueModeOff)


Previous (ChangeDevice)
Next (CueModeOn)

Name
CueModeOff

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure CueModeOff

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ChangeDevice)
Next (CueModeOn)


Previous (CueModeOff)
Next (FadeOut)

Name
CueModeOn

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure CueModeOn ( iPosition : TTimeValue )

Parameters
Parameter Description
iPosition : TTimeValue

mAirListScript
Class Tree
Index
Previous (CueModeOff)
Next (FadeOut)


Previous (CueModeOn)
Next (GetAmplification)

Name
FadeOut

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure FadeOut ( iDuration : TTimeValue )

Parameters
Parameter Description
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (CueModeOn)
Next (GetAmplification)


Previous (FadeOut)
Next (GetCapabilities)

Name
GetAmplification

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetCapabilities)


Previous (GetAmplification)
Next (GetDuration)

Name
GetCapabilities

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetCapabilities : TAudioSourceCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next (GetDuration)


Previous (GetCapabilities)
Next (GetDynamicTitle)

Name
GetDuration

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetDynamicTitle)


Previous (GetDuration)
Next (GetIsPlaying)

Name
GetDynamicTitle

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetDynamicTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetIsPlaying)


Previous (GetDynamicTitle)
Next (GetItem)

Name
GetIsPlaying

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetIsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDynamicTitle)
Next (GetItem)


Previous (GetIsPlaying)
Next (GetOptions)

Name
GetItem

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsPlaying)
Next (GetOptions)


Previous (GetItem)
Next (GetPitch)

Name
GetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetOptions : TAudioSourceOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetPitch)


Previous (GetOptions)
Next (GetPosition)

Name
GetPitch

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPosition)


Previous (GetPitch)
Next (GetRegion)

Name
GetPosition

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (GetRegion)


Previous (GetPosition)
Next (GetTempo)

Name
GetRegion

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetRegion : TRegion

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetTempo)


Previous (GetRegion)
Next (GetVolume)

Name
GetTempo

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegion)
Next (GetVolume)


Previous (GetTempo)
Next (IsCueable)

Name
GetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (IsCueable)


Previous (GetVolume)
Next (Pause)

Name
IsCueable

Parent
IAudioSource

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Pause)


Previous (IsCueable)
Next (Reset)

Name
Pause

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (Reset)


Previous (Pause)
Next (SetAmplification)

Name
Reset

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Reset ( iHookMode : boolean )

Parameters
Parameter Description
iHookMode : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetAmplification)


Previous (Reset)
Next (SetCueData)

Name
SetAmplification

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (Reset)
Next (SetCueData)


Previous (SetAmplification)
Next (SetOptions)

Name
SetCueData

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetCueData ( iValue : ICueData )

Parameters
Parameter Description
iValue : ICueData

mAirListScript
Class Tree
Index
Previous (SetAmplification)
Next (SetOptions)


Previous (SetCueData)
Next (SetPitch)

Name
SetOptions

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TAudioSourceOptions )

Parameters
Parameter Description
iValue : TAudioSourceOptions

mAirListScript
Class Tree
Index
Previous (SetCueData)
Next (SetPitch)


Previous (SetOptions)
Next (SetPosition)

Name
SetPitch

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetPosition)


Previous (SetPitch)
Next (SetRegion)

Name
SetPosition

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next (SetRegion)


Previous (SetPosition)
Next (SetTempo)

Name
SetRegion

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetRegion ( iValue : TRegion )

Parameters
Parameter Description
iValue : TRegion

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SetTempo)


Previous (SetRegion)
Next (SetVolume)

Name
SetTempo

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetRegion)
Next (SetVolume)


Previous (SetTempo)
Next (SetVolumeEnvelope)

Name
SetVolume

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetTempo)
Next (SetVolumeEnvelope)


Previous (SetVolume)
Next (Start)

Name
SetVolumeEnvelope

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter Description
iValue : IEnvelope

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Start)


Previous (SetVolumeEnvelope)
Next (Stop)

Name
Start

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolumeEnvelope)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IAudioSource

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IAudioSource)
Next (IBaseComPortRemote)

Name
IAutoCueEngine

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
PerformAutoCue (+)
PerformAutoCueSelective (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAudioSource)
Next (IBaseComPortRemote)


Previous
Next (PerformAutoCueSelective)

Name
PerformAutoCue

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCue ( iItem : IFilePlaylistItem )

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous
Next (PerformAutoCueSelective)


Previous (PerformAutoCue)
Next

Name
PerformAutoCueSelective

Parent
IAutoCueEngine

Visibility
PUBLIC

Source code
procedure PerformAutoCueSelective ( iItem : IFilePlaylistItem ; iTypes : TCuePositionTypes )

Parameters
Parameter Description
iItem : IFilePlaylistItem
iTypes : TCuePositionTypes

mAirListScript
Class Tree
Index
Previous (PerformAutoCue)
Next


Previous (IAutoCueEngine)
Next (IBaseList)

Name
IBaseComPortRemote

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IAutoCueEngine)
Next (IBaseList)


Previous
Next (SetPort)

Name
GetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
IBaseComPortRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (IBaseComPortRemote)
Next (IBaseMarkerCueDataItem)

Name
IBaseList

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddWithMetadata (+)
Append (+)
Assign (+)
Clear (+)
CreateEmpty (+)
Delete (+)
FindItemByGUID (+)
GetCount (+)
GetListItem (+)
GetListItemMetadata (+)
IndexOf (+)
Insert (+)
InsertList (+)
InsertWithMetadata (+)
Move (+)
REMOVE (+)
Sync (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseComPortRemote)
Next (IBaseMarkerCueDataItem)


Previous
Next (AddWithMetadata)

Name
ADD

Parent
IBaseList

Visibility
PUBLIC

Source code
function Add ( iItem : IUnknown ) : integer

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous
Next (AddWithMetadata)


Previous (ADD)
Next (Append)

Name
AddWithMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
function AddWithMetadata ( iItem : IUnknown ; iMetadata : IUnknown ) : integer

Parameters
Parameter Description
iItem : IUnknown
iMetadata : IUnknown

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Append)


Previous (AddWithMetadata)
Next (Assign)

Name
Append

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Append ( iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter Description
iValue : IBaseList
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (AddWithMetadata)
Next (Assign)


Previous (Append)
Next (Clear)

Name
Assign

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IBaseList )

Parameters
Parameter Description
iValue : IBaseList

mAirListScript
Class Tree
Index
Previous (Append)
Next (Clear)


Previous (Assign)
Next (CreateEmpty)

Name
Clear

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (CreateEmpty)


Previous (Clear)
Next (Delete)

Name
CreateEmpty

Parent
IBaseList

Visibility
PUBLIC

Source code
function CreateEmpty : IBaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (CreateEmpty)
Next (FindItemByGUID)

Name
Delete

Parent
IBaseList

Visibility
PUBLIC

Source code
function Delete ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateEmpty)
Next (FindItemByGUID)


Previous (Delete)
Next (GetCount)

Name
FindItemByGUID

Parent
IBaseList

Visibility
PUBLIC

Source code
function FindItemByGUID ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter Description
iGUID : TGUID
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Delete)
Next (GetCount)


Previous (FindItemByGUID)
Next (GetListItem)

Name
GetCount

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindItemByGUID)
Next (GetListItem)


Previous (GetCount)
Next (GetListItemMetadata)

Name
GetListItem

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetListItem ( iIndex : integer ) : IUnknown

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetListItemMetadata)


Previous (GetListItem)
Next (IndexOf)

Name
GetListItemMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
function GetListItemMetadata ( iIndex : integer ) : IUnknown

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetListItem)
Next (IndexOf)


Previous (GetListItemMetadata)
Next (Insert)

Name
IndexOf

Parent
IBaseList

Visibility
PUBLIC

Source code
function IndexOf ( iItem : IUnknown ) : integer

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (GetListItemMetadata)
Next (Insert)


Previous (IndexOf)
Next (InsertList)

Name
Insert

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iItem : IUnknown )

Parameters
Parameter Description
iIndex : INTEGER
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (InsertList)


Previous (Insert)
Next (InsertWithMetadata)

Name
InsertList

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure InsertList ( iIndex : integer ; iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter Description
iIndex : INTEGER
iValue : IBaseList
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Insert)
Next (InsertWithMetadata)


Previous (InsertList)
Next (Move)

Name
InsertWithMetadata

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure InsertWithMetadata ( iIndex : integer ; iItem : IUnknown ; iMetadata : IUnknown )

Parameters
Parameter Description
iIndex : INTEGER
iItem : IUnknown
iMetadata : IUnknown

mAirListScript
Class Tree
Index
Previous (InsertList)
Next (Move)


Previous (InsertWithMetadata)
Next (REMOVE)

Name
Move

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Move ( oldIndex : integer ; newIndex : integer )

Parameters
Parameter Description
oldIndex : INTEGER
newIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (InsertWithMetadata)
Next (REMOVE)


Previous (Move)
Next (Sync)

Name
REMOVE

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Remove ( iItem : IUnknown )

Parameters
Parameter Description
iItem : IUnknown

mAirListScript
Class Tree
Index
Previous (Move)
Next (Sync)


Previous (REMOVE)
Next

Name
Sync

Parent
IBaseList

Visibility
PUBLIC

Source code
procedure Sync ( iValue : IBaseList ; iWithMetadata : boolean = true )

Parameters
Parameter Description
iValue : IBaseList
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (REMOVE)
Next


Previous (IBaseList)
Next (IBaseMessage)

Name
IBaseMarkerCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPositionType (+)
SetPositionType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseList)
Next (IBaseMessage)


Previous
Next (SetPositionType)

Name
GetPositionType

Parent
IBaseMarkerCueDataItem

Visibility
PUBLIC

Source code
function GetPositionType : TCuePositionType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPositionType)


Previous (GetPositionType)
Next

Name
SetPositionType

Parent
IBaseMarkerCueDataItem

Visibility
PUBLIC

Source code
procedure SetPositionType ( iValue : TCuePositionType )

Parameters
Parameter Description
iValue : TCuePositionType

mAirListScript
Class Tree
Index
Previous (GetPositionType)
Next


Previous (IBaseMarkerCueDataItem)
Next (IBreakPlaylistItem)

Name
IBaseMessage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCreated (+)
GetData (+)
GetDataCount (+)
GetInfo (+)
GetMessageType (+)
GetSender (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseMarkerCueDataItem)
Next (IBreakPlaylistItem)


Previous
Next (GetData)

Name
GetCreated

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetCreated : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetData)


Previous (GetCreated)
Next (GetDataCount)

Name
GetData

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : Variant

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCreated)
Next (GetDataCount)


Previous (GetData)
Next (GetInfo)

Name
GetDataCount

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetDataCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetInfo)


Previous (GetDataCount)
Next (GetMessageType)

Name
GetInfo

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDataCount)
Next (GetMessageType)


Previous (GetInfo)
Next (GetSender)

Name
GetMessageType

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetMessageType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInfo)
Next (GetSender)


Previous (GetMessageType)
Next

Name
GetSender

Parent
IBaseMessage

Visibility
PUBLIC

Source code
function GetSender : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageType)
Next


Previous (IBaseMessage)
Next (ICartPlayerControl)

Name
IBreakPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBaseMessage)
Next (ICartPlayerControl)


Previous (IBreakPlaylistItem)
Next (ICartWallControl)

Name
ICartPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IPlayerControl

Visibility
PUBLIC

Members
Methods
Method Description
GetFadeTrigger (+)
GetPFLMode (+)
GetStack (+)
GetStackIndex (+)
GetStartTrigger (+)
GetStopTrigger (+)
SetFadeTrigger (+)
SetPFLMode (+)
SetStackIndex (+)
SetStartTrigger (+)
SetStopTrigger (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IBreakPlaylistItem)
Next (ICartWallControl)


Previous
Next (GetPFLMode)

Name
GetFadeTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetFadeTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetPFLMode)


Previous (GetFadeTrigger)
Next (GetStack)

Name
GetPFLMode

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeTrigger)
Next (GetStack)


Previous (GetPFLMode)
Next (GetStackIndex)

Name
GetStack

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStack : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLMode)
Next (GetStackIndex)


Previous (GetStack)
Next (GetStartTrigger)

Name
GetStackIndex

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStackIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStack)
Next (GetStartTrigger)


Previous (GetStackIndex)
Next (GetStopTrigger)

Name
GetStartTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStartTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStackIndex)
Next (GetStopTrigger)


Previous (GetStartTrigger)
Next (SetFadeTrigger)

Name
GetStopTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
function GetStopTrigger ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStartTrigger)
Next (SetFadeTrigger)


Previous (GetStopTrigger)
Next (SetPFLMode)

Name
SetFadeTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetFadeTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetStopTrigger)
Next (SetPFLMode)


Previous (SetFadeTrigger)
Next (SetStackIndex)

Name
SetPFLMode

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetFadeTrigger)
Next (SetStackIndex)


Previous (SetPFLMode)
Next (SetStartTrigger)

Name
SetStackIndex

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStackIndex ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPFLMode)
Next (SetStartTrigger)


Previous (SetStackIndex)
Next (SetStopTrigger)

Name
SetStartTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStartTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetStackIndex)
Next (SetStopTrigger)


Previous (SetStartTrigger)
Next

Name
SetStopTrigger

Parent
ICartPlayerControl

Visibility
PUBLIC

Source code
procedure SetStopTrigger ( iIndex : integer ; iValue : boolean )

Parameters
Parameter Description
iIndex : INTEGER
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetStartTrigger)
Next


Previous (ICartPlayerControl)
Next (IClientList)

Name
ICartWallControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CloseAll (+)
GetOptions (+)
GetPFLMode (+)
GetPlayer (+)
GetPlayerCount (+)
GetPlayerCountX (+)
GetPlayerCountY (+)
LoadFromXML (+)
SaveAsXML (+)
SetOptions (+)
SetPFLMode (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartPlayerControl)
Next (IClientList)


Previous
Next (GetOptions)

Name
CloseAll

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure CloseAll

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetOptions)


Previous (CloseAll)
Next (GetPFLMode)

Name
GetOptions

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetOptions : TCartwallControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CloseAll)
Next (GetPFLMode)


Previous (GetOptions)
Next (GetPlayer)

Name
GetPFLMode

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPFLMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayer)


Previous (GetPFLMode)
Next (GetPlayerCount)

Name
GetPlayer

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayer ( iIndex : integer ) : ICartPlayerControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPFLMode)
Next (GetPlayerCount)


Previous (GetPlayer)
Next (GetPlayerCountX)

Name
GetPlayerCount

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayer)
Next (GetPlayerCountX)


Previous (GetPlayerCount)
Next (GetPlayerCountY)

Name
GetPlayerCountX

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCountX : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (GetPlayerCountY)


Previous (GetPlayerCountX)
Next (LoadFromXML)

Name
GetPlayerCountY

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function GetPlayerCountY : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerCountX)
Next (LoadFromXML)


Previous (GetPlayerCountY)
Next (SaveAsXML)

Name
LoadFromXML

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (GetPlayerCountY)
Next (SaveAsXML)


Previous (LoadFromXML)
Next (SetOptions)

Name
SaveAsXML

Parent
ICartWallControl

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SetOptions)


Previous (SaveAsXML)
Next (SetPFLMode)

Name
SetOptions

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TCartwallControlOptions )

Parameters
Parameter Description
iValue : TCartwallControlOptions

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SetPFLMode)


Previous (SetOptions)
Next

Name
SetPFLMode

Parent
ICartWallControl

Visibility
PUBLIC

Source code
procedure SetPFLMode ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next


Previous (ICartWallControl)
Next (ICommandPlaylistItem)

Name
IClientList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddStrong (+)
Clone (+)
CloneStrong (+)
GetCount (+)
GetItem (+)
Insert (+)
REMOVE (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICartWallControl)
Next (ICommandPlaylistItem)


Previous
Next (AddStrong)

Name
ADD

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Add ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous
Next (AddStrong)


Previous (ADD)
Next (Clone)

Name
AddStrong

Parent
IClientList

Visibility
PUBLIC

Source code
procedure AddStrong ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (ADD)
Next (Clone)


Previous (AddStrong)
Next (CloneStrong)

Name
Clone

Parent
IClientList

Visibility
PUBLIC

Source code
function Clone : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddStrong)
Next (CloneStrong)


Previous (Clone)
Next (GetCount)

Name
CloneStrong

Parent
IClientList

Visibility
PUBLIC

Source code
function CloneStrong : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetCount)


Previous (CloneStrong)
Next (GetItem)

Name
GetCount

Parent
IClientList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CloneStrong)
Next (GetItem)


Previous (GetCount)
Next (Insert)

Name
GetItem

Parent
IClientList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IUnknown

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (Insert)


Previous (GetItem)
Next (REMOVE)

Name
Insert

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; intf : IUnknown )

Parameters
Parameter Description
iIndex : INTEGER
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (REMOVE)


Previous (Insert)
Next

Name
REMOVE

Parent
IClientList

Visibility
PUBLIC

Source code
procedure Remove ( intf : IUnknown )

Parameters
Parameter Description
intf : IUnknown

mAirListScript
Class Tree
Index
Previous (Insert)
Next


Previous (IClientList)
Next (IComPort)

Name
ICommandPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetCommand (+)
SetCommand (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IClientList)
Next (IComPort)


Previous
Next (SetCommand)

Name
GetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
function GetCommand : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetCommand)


Previous (GetCommand)
Next

Name
SetCommand

Parent
ICommandPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCommand ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetCommand)
Next


Previous (ICommandPlaylistItem)
Next (IConfigObject)

Name
IComPort

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
Close (+)
GetPort (+)
Open (+)
SendStr (+)
SetDTR (+)
SetParameters (+)
SetRxBuffer (+)
SetTxBuffer (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICommandPlaylistItem)
Next (IConfigObject)


Previous
Next (GetPort)

Name
Close

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (Close)
Next (Open)

Name
GetPort

Parent
IComPort

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Close)
Next (Open)


Previous (GetPort)
Next (SendStr)

Name
Open

Parent
IComPort

Visibility
PUBLIC

Source code
procedure Open

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SendStr)


Previous (Open)
Next (SetDTR)

Name
SendStr

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SendStr ( const Tx : string )

Parameters
Parameter Description
Tx : STRING

mAirListScript
Class Tree
Index
Previous (Open)
Next (SetDTR)


Previous (SendStr)
Next (SetParameters)

Name
SetDTR

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetDTR ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SendStr)
Next (SetParameters)


Previous (SetDTR)
Next (SetRxBuffer)

Name
SetParameters

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetParameters ( iBaudRate : integer ; iByteSize : byte ; iParity : char ; iStopBits : Single )

Parameters
Parameter Description
iBaudRate : INTEGER
iByteSize : BYTE
iParity : CHAR
iStopBits : SINGLE

mAirListScript
Class Tree
Index
Previous (SetDTR)
Next (SetRxBuffer)


Previous (SetParameters)
Next (SetTxBuffer)

Name
SetRxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetRxBuffer ( iSize : integer )

Parameters
Parameter Description
iSize : INTEGER

mAirListScript
Class Tree
Index
Previous (SetParameters)
Next (SetTxBuffer)


Previous (SetRxBuffer)
Next

Name
SetTxBuffer

Parent
IComPort

Visibility
PUBLIC

Source code
procedure SetTxBuffer ( iSize : integer )

Parameters
Parameter Description
iSize : INTEGER

mAirListScript
Class Tree
Index
Previous (SetRxBuffer)
Next


Previous (IComPort)
Next (IConfigObjectList)

Name
IConfigObject

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetActive (+)
GetCaption (+)
GetEnabled (+)
LoadConfig (+)
SaveConfig (+)
SetActive (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IComPort)
Next (IConfigObjectList)


Previous
Next (GetCaption)

Name
GetActive

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetCaption)


Previous (GetActive)
Next (GetEnabled)

Name
GetCaption

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActive)
Next (GetEnabled)


Previous (GetCaption)
Next (LoadConfig)

Name
GetEnabled

Parent
IConfigObject

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (LoadConfig)


Previous (GetEnabled)
Next (SaveConfig)

Name
LoadConfig

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure LoadConfig ( iCategory , iSection : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (SaveConfig)


Previous (LoadConfig)
Next (SetActive)

Name
SaveConfig

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SaveConfig ( iCategory , iSection : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (SetActive)


Previous (SaveConfig)
Next (SetEnabled)

Name
SetActive

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SetActive ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next (SetEnabled)


Previous (SetActive)
Next

Name
SetEnabled

Parent
IConfigObject

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetActive)
Next


Previous (IConfigObject)
Next (IConfiguration)

Name
IConfigObjectList

Parent
mAirListInterfaces

Class Hierarchy
IFactoryObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetActive (+)
LoadConfig (+)
SaveConfig (+)
SetActive (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigObject)
Next (IConfiguration)


Previous
Next (LoadConfig)

Name
GetActive

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
function GetActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (LoadConfig)


Previous (GetActive)
Next (SaveConfig)

Name
LoadConfig

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
procedure LoadConfig ( iCategory , iSectionPattern : string )

Parameters
Parameter Description
iCategory : STRING
iSectionPattern : STRING

mAirListScript
Class Tree
Index
Previous (GetActive)
Next (SaveConfig)


Previous (LoadConfig)
Next (SetActive)

Name
SaveConfig

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
procedure SaveConfig ( iCategory , iSectionPattern : string )

Parameters
Parameter Description
iCategory : STRING
iSectionPattern : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (SetActive)


Previous (SaveConfig)
Next

Name
SetActive

Parent
IConfigObjectList

Visibility
PUBLIC

Source code
procedure SetActive ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveConfig)
Next


Previous (IConfigObjectList)
Next (IContainerPlaylistItem)

Name
IConfiguration

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ConfigExists (+)
DeleteKey (+)
EraseCategory (+)
EraseSection (+)
Flush (+)
GetSections (+)
ReadColor (+)
ReadColorEx (+)
ReadFloat (+)
ReadFloatEx (+)
ReadFont (+)
ReadFontEx (+)
ReadInteger (+)
ReadIntegerEx (+)
ReadOnOff (+)
ReadOnOffEx (+)
ReadPassword (+)
ReadSectionValues (+)
ReadSectionValuesEx (+)
ReadString (+)
ReadStringEx (+)
ReadStringSafe (+)
ReleaseAllFiles (+)
SectionExists (+)
WriteColor (+)
WriteFloat (+)
WriteFont (+)
WriteInteger (+)
WriteOnOff (+)
WritePassword (+)
WriteSectionValues (+)
WriteString (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfigObjectList)
Next (IContainerPlaylistItem)


Previous
Next (DeleteKey)

Name
ConfigExists

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ConfigExists ( iCategory : string ) : boolean

Parameters
Parameter Description
iCategory : STRING

mAirListScript
Class Tree
Index
Previous
Next (DeleteKey)


Previous (ConfigExists)
Next (EraseCategory)

Name
DeleteKey

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure DeleteKey ( iCategory : string ; iSection : string ; iKey : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING

mAirListScript
Class Tree
Index
Previous (ConfigExists)
Next (EraseCategory)


Previous (DeleteKey)
Next (EraseSection)

Name
EraseCategory

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure EraseCategory ( iCategory : string )

Parameters
Parameter Description
iCategory : STRING

mAirListScript
Class Tree
Index
Previous (DeleteKey)
Next (EraseSection)


Previous (EraseCategory)
Next (Flush)

Name
EraseSection

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure EraseSection ( iCategory : string ; iSection : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (EraseCategory)
Next (Flush)


Previous (EraseSection)
Next (GetSections)

Name
Flush

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure Flush

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EraseSection)
Next (GetSections)


Previous (Flush)
Next (ReadColor)

Name
GetSections

Parent
IConfiguration

Visibility
PUBLIC

Source code
function GetSections ( iCategory : string ) : IStrings

Parameters
Parameter Description
iCategory : STRING

mAirListScript
Class Tree
Index
Previous (Flush)
Next (ReadColor)


Previous (GetSections)
Next (ReadColorEx)

Name
ReadColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColor ( iCategory : string ; iSection , iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : TColor

mAirListScript
Class Tree
Index
Previous (GetSections)
Next (ReadColorEx)


Previous (ReadColor)
Next (ReadFloat)

Name
ReadColorEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadColorEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : TColor ) : TColor

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : TColor

mAirListScript
Class Tree
Index
Previous (ReadColor)
Next (ReadFloat)


Previous (ReadColorEx)
Next (ReadFloatEx)

Name
ReadFloat

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadFloat ( iCategory : string ; iSection , iKey : string ; iDefault : single ) : single

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : SINGLE

mAirListScript
Class Tree
Index
Previous (ReadColorEx)
Next (ReadFloatEx)


Previous (ReadFloat)
Next (ReadFont)

Name
ReadFloatEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadFloatEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : single ) : single

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : SINGLE

mAirListScript
Class Tree
Index
Previous (ReadFloat)
Next (ReadFont)


Previous (ReadFloatEx)
Next (ReadFontEx)

Name
ReadFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (ReadFloatEx)
Next (ReadFontEx)


Previous (ReadFont)
Next (ReadInteger)

Name
ReadFontEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReadFontEx ( iCategory : string ; iSections : array of string ; iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (ReadFont)
Next (ReadInteger)


Previous (ReadFontEx)
Next (ReadIntegerEx)

Name
ReadInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadInteger ( iCategory : string ; iSection , iKey : string ; iDefault : integer ) : integer

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : INTEGER

mAirListScript
Class Tree
Index
Previous (ReadFontEx)
Next (ReadIntegerEx)


Previous (ReadInteger)
Next (ReadOnOff)

Name
ReadIntegerEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadIntegerEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : integer ) : integer

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : INTEGER

mAirListScript
Class Tree
Index
Previous (ReadInteger)
Next (ReadOnOff)


Previous (ReadIntegerEx)
Next (ReadOnOffEx)

Name
ReadOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOff ( iCategory : string ; iSection , iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : BOOLEAN

mAirListScript
Class Tree
Index
Previous (ReadIntegerEx)
Next (ReadOnOffEx)


Previous (ReadOnOff)
Next (ReadPassword)

Name
ReadOnOffEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadOnOffEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : boolean ) : boolean

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : BOOLEAN

mAirListScript
Class Tree
Index
Previous (ReadOnOff)
Next (ReadPassword)


Previous (ReadOnOffEx)
Next (ReadSectionValues)

Name
ReadPassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadPassword ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadOnOffEx)
Next (ReadSectionValues)


Previous (ReadPassword)
Next (ReadSectionValuesEx)

Name
ReadSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValues ( iCategory : string ; iSection : string ) : IStrings

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (ReadPassword)
Next (ReadSectionValuesEx)


Previous (ReadSectionValues)
Next (ReadString)

Name
ReadSectionValuesEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadSectionValuesEx ( iCategory : string ; iSections : array of string ) : IStrings

Parameters
Parameter Description
iCategory : STRING
iSections : STRING

mAirListScript
Class Tree
Index
Previous (ReadSectionValues)
Next (ReadString)


Previous (ReadSectionValuesEx)
Next (ReadStringEx)

Name
ReadString

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadString ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadSectionValuesEx)
Next (ReadStringEx)


Previous (ReadString)
Next (ReadStringSafe)

Name
ReadStringEx

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringEx ( iCategory : string ; iSections : array of string ; iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSections : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadString)
Next (ReadStringSafe)


Previous (ReadStringEx)
Next (ReleaseAllFiles)

Name
ReadStringSafe

Parent
IConfiguration

Visibility
PUBLIC

Source code
function ReadStringSafe ( iCategory : string ; iSection , iKey : string ; iDefault : string ) : string

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (ReadStringEx)
Next (ReleaseAllFiles)


Previous (ReadStringSafe)
Next (SectionExists)

Name
ReleaseAllFiles

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure ReleaseAllFiles

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadStringSafe)
Next (SectionExists)


Previous (ReleaseAllFiles)
Next (WriteColor)

Name
SectionExists

Parent
IConfiguration

Visibility
PUBLIC

Source code
function SectionExists ( iCategory , iSection : string ) : boolean

Parameters
Parameter Description
iCategory : STRING
iSection : STRING

mAirListScript
Class Tree
Index
Previous (ReleaseAllFiles)
Next (WriteColor)


Previous (SectionExists)
Next (WriteFloat)

Name
WriteColor

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteColor ( iCategory : string ; iSection , iKey : string ; iValue : TColor )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : TColor

mAirListScript
Class Tree
Index
Previous (SectionExists)
Next (WriteFloat)


Previous (WriteColor)
Next (WriteFont)

Name
WriteFloat

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteFloat ( iCategory : string ; iSection , iKey : string ; iValue : single )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (WriteColor)
Next (WriteFont)


Previous (WriteFloat)
Next (WriteInteger)

Name
WriteFont

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteFont ( iCategory : string ; iSection , iFontID : string ; iFont : TFont )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iFontID : STRING
iFont : TFont

mAirListScript
Class Tree
Index
Previous (WriteFloat)
Next (WriteInteger)


Previous (WriteFont)
Next (WriteOnOff)

Name
WriteInteger

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteInteger ( iCategory : string ; iSection , iKey : string ; iValue : integer )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (WriteFont)
Next (WriteOnOff)


Previous (WriteInteger)
Next (WritePassword)

Name
WriteOnOff

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteOnOff ( iCategory : string ; iSection , iKey : string ; iValue : boolean )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (WriteInteger)
Next (WritePassword)


Previous (WriteOnOff)
Next (WriteSectionValues)

Name
WritePassword

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WritePassword ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (WriteOnOff)
Next (WriteSectionValues)


Previous (WritePassword)
Next (WriteString)

Name
WriteSectionValues

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteSectionValues ( iCategory : string ; iSection : string ; iValues : IStrings )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iValues : IStrings

mAirListScript
Class Tree
Index
Previous (WritePassword)
Next (WriteString)


Previous (WriteSectionValues)
Next

Name
WriteString

Parent
IConfiguration

Visibility
PUBLIC

Source code
procedure WriteString ( iCategory : string ; iSection , iKey : string ; iValue : string )

Parameters
Parameter Description
iCategory : STRING
iSection : STRING
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (WriteSectionValues)
Next


Previous (IConfiguration)
Next (ICueData)

Name
IContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetInnerFadeDuration (+)
GetPlaylist (+)
SetInnerFadeDuration (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IConfiguration)
Next (ICueData)


Previous
Next (GetPlaylist)

Name
GetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetInnerFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaylist)


Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)

Name
GetPlaylist

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetInnerFadeDuration)
Next (SetInnerFadeDuration)


Previous (GetPlaylist)
Next

Name
SetInnerFadeDuration

Parent
IContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetInnerFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next


Previous (IContainerPlaylistItem)
Next (ICueDataItem)

Name
ICueData

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
LoadFromCueSheet (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IContainerPlaylistItem)
Next (ICueDataItem)


Previous
Next (LoadFromCueSheet)

Name
GetItem

Parent
ICueData

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : ICueDataItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (LoadFromCueSheet)


Previous (GetItem)
Next

Name
LoadFromCueSheet

Parent
ICueData

Visibility
PUBLIC

Source code
procedure LoadFromCueSheet ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (ICueData)
Next (IDatabase)

Name
ICueDataItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetDescription (+)
GetParameters (+)
GetPosition (+)
SetPosition (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueData)
Next (IDatabase)


Previous
Next (GetParameters)

Name
GetDescription

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetParameters)


Previous (GetDescription)
Next (GetPosition)

Name
GetParameters

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetParameters : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetPosition)


Previous (GetParameters)
Next (SetPosition)

Name
GetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (SetPosition)


Previous (GetPosition)
Next

Name
SetPosition

Parent
ICueDataItem

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next


Previous (ICueDataItem)
Next (IDatabaseAction)

Name
IDatabase

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
CreateFileStream (+)
CreatePlaylistItem (+)
ExecuteSQL (+)
FillDatabaseTree (+)
GetCapabilities (+)
GetCaption (+)
GetCurrentPlaylist (+)
GetCustomCaption (+)
GetErrorMessage (+)
GetID (+)
GetNextPlaylist (+)
GetPlaylist (+)
GetPlaylistByID (+)
GetState (+)
GetSubPlaylists (+)
GetUniqueID (+)
ReverseLookup (+)
SavePlaylistItem (+)
SearchItems (+)
SetActiveSync (+)
SetCustomCaption (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ICueDataItem)
Next (IDatabaseAction)


Previous
Next (CreatePlaylistItem)

Name
CreateFileStream

Parent
IDatabase

Visibility
PUBLIC

Source code
function CreateFileStream ( iDBUrl : string ) : IStream

Parameters
Parameter Description
iDBUrl : STRING

mAirListScript
Class Tree
Index
Previous
Next (CreatePlaylistItem)


Previous (CreateFileStream)
Next (ExecuteSQL)

Name
CreatePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
function CreatePlaylistItem ( iID : string ) : IPlaylistItem

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (CreateFileStream)
Next (ExecuteSQL)


Previous (CreatePlaylistItem)
Next (FillDatabaseTree)

Name
ExecuteSQL

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure ExecuteSQL ( iSQL : string )

Parameters
Parameter Description
iSQL : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItem)
Next (FillDatabaseTree)


Previous (ExecuteSQL)
Next (GetCapabilities)

Name
FillDatabaseTree

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure FillDatabaseTree ( iTree : IDatabaseTree ; iParent : cardinal ; const iParentData : TDatabaseNodeData )

Parameters
Parameter Description
iTree : IDatabaseTree
iParent : CARDINAL
iParentData : TDatabaseNodeData

mAirListScript
Class Tree
Index
Previous (ExecuteSQL)
Next (GetCapabilities)


Previous (FillDatabaseTree)
Next (GetCaption)

Name
GetCapabilities

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCapabilities : TDatabaseCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FillDatabaseTree)
Next (GetCaption)


Previous (GetCapabilities)
Next (GetCurrentPlaylist)

Name
GetCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetCurrentPlaylist)


Previous (GetCaption)
Next (GetCustomCaption)

Name
GetCurrentPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCurrentPlaylist ( iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter Description
iSubPlaylist : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCustomCaption)


Previous (GetCurrentPlaylist)
Next (GetErrorMessage)

Name
GetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetCustomCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentPlaylist)
Next (GetErrorMessage)


Previous (GetCustomCaption)
Next (GetID)

Name
GetErrorMessage

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCustomCaption)
Next (GetID)


Previous (GetErrorMessage)
Next (GetNextPlaylist)

Name
GetID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetNextPlaylist)


Previous (GetID)
Next (GetPlaylist)

Name
GetNextPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetNextPlaylist ( iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter Description
iSubPlaylist : INTEGER

mAirListScript
Class Tree
Index
Previous (GetID)
Next (GetPlaylist)


Previous (GetNextPlaylist)
Next (GetPlaylistByID)

Name
GetPlaylist

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylist ( iSlot : TDateTime ; iSubPlaylist : integer ) : IPlaylist

Parameters
Parameter Description
iSlot : TDateTime
iSubPlaylist : INTEGER

mAirListScript
Class Tree
Index
Previous (GetNextPlaylist)
Next (GetPlaylistByID)


Previous (GetPlaylist)
Next (GetState)

Name
GetPlaylistByID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetPlaylistByID ( iID : string ) : IPlaylist

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetPlaylist)
Next (GetState)


Previous (GetPlaylistByID)
Next (GetSubPlaylists)

Name
GetState

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetState : TDatabaseState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaylistByID)
Next (GetSubPlaylists)


Previous (GetState)
Next (GetUniqueID)

Name
GetSubPlaylists

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetSubPlaylists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (GetUniqueID)


Previous (GetSubPlaylists)
Next (ReverseLookup)

Name
GetUniqueID

Parent
IDatabase

Visibility
PUBLIC

Source code
function GetUniqueID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSubPlaylists)
Next (ReverseLookup)


Previous (GetUniqueID)
Next (SavePlaylistItem)

Name
ReverseLookup

Parent
IDatabase

Visibility
PUBLIC

Source code
function ReverseLookup ( iFilename : string ) : IPlaylistItem

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetUniqueID)
Next (SavePlaylistItem)


Previous (ReverseLookup)
Next (SearchItems)

Name
SavePlaylistItem

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SavePlaylistItem ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (ReverseLookup)
Next (SearchItems)


Previous (SavePlaylistItem)
Next (SetActiveSync)

Name
SearchItems

Parent
IDatabase

Visibility
PUBLIC

Source code
function SearchItems ( iSearchString : string ; iResultPlaylist : IPlaylist ) : IDatabaseSearchHandler

Parameters
Parameter Description
iSearchString : STRING
iResultPlaylist : IPlaylist

mAirListScript
Class Tree
Index
Previous (SavePlaylistItem)
Next (SetActiveSync)


Previous (SearchItems)
Next (SetCustomCaption)

Name
SetActiveSync

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SetActiveSync

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SearchItems)
Next (SetCustomCaption)


Previous (SetActiveSync)
Next

Name
SetCustomCaption

Parent
IDatabase

Visibility
PUBLIC

Source code
procedure SetCustomCaption ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetActiveSync)
Next


Previous (IDatabase)
Next (IDatabaseInlineLoader)

Name
IDatabaseAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Members
Methods
Method Description
GetDatabaseID (+)
GetSubPlaylist (+)
SetDatabaseID (+)
SetSubPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabase)
Next (IDatabaseInlineLoader)


Previous
Next (GetSubPlaylist)

Name
GetDatabaseID

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetSubPlaylist)


Previous (GetDatabaseID)
Next (SetDatabaseID)

Name
GetSubPlaylist

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
function GetSubPlaylist : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (SetDatabaseID)


Previous (GetSubPlaylist)
Next (SetSubPlaylist)

Name
SetDatabaseID

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetSubPlaylist)
Next (SetSubPlaylist)


Previous (SetDatabaseID)
Next

Name
SetSubPlaylist

Parent
IDatabaseAction

Visibility
PUBLIC

Source code
procedure SetSubPlaylist ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next


Previous (IDatabaseAction)
Next (IDatabaseList)

Name
IDatabaseInlineLoader

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
LoadInlineData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseAction)
Next (IDatabaseList)


Previous
Next

Name
LoadInlineData

Parent
IDatabaseInlineLoader

Visibility
PUBLIC

Source code
procedure LoadInlineData ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)

Name
IDatabaseList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
ConnectAllSync (+)
FindByUniqueID (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseInlineLoader)
Next (IDatabaseSearchHandler)


Previous
Next (FindByUniqueID)

Name
ConnectAllSync

Parent
IDatabaseList

Visibility
PUBLIC

Source code
procedure ConnectAllSync

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (FindByUniqueID)


Previous (ConnectAllSync)
Next (GetItem)

Name
FindByUniqueID

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function FindByUniqueID ( iUniqueID : string ) : IDatabase

Parameters
Parameter Description
iUniqueID : STRING

mAirListScript
Class Tree
Index
Previous (ConnectAllSync)
Next (GetItem)


Previous (FindByUniqueID)
Next

Name
GetItem

Parent
IDatabaseList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IDatabase

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (FindByUniqueID)
Next


Previous (IDatabaseList)
Next (IDatabaseTree)

Name
IDatabaseSearchHandler

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
IsActive (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseList)
Next (IDatabaseTree)


Previous
Next

Name
IsActive

Parent
IDatabaseSearchHandler

Visibility
PUBLIC

Source code
function IsActive : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDatabaseSearchHandler)
Next (IDebugObject)

Name
IDatabaseTree

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddNode (+)
GetDataOfNode (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseSearchHandler)
Next (IDebugObject)


Previous
Next (GetDataOfNode)

Name
AddNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
procedure AddNode ( iParent : cardinal ; iDatabase : IDatabase ; iNodeType : TDatabaseTreeNodeType ; iCaption : string ; iExpectChildren : boolean = true ; iDuration : TTimeValue = 0 ; iData : string = '' )

Parameters
Parameter Description
iParent : CARDINAL
iDatabase : IDatabase
iNodeType : TDatabaseTreeNodeType
iCaption : STRING
iExpectChildren : BOOLEAN
iDuration : TTimeValue
iData : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetDataOfNode)


Previous (AddNode)
Next

Name
GetDataOfNode

Parent
IDatabaseTree

Visibility
PUBLIC

Source code
function GetDataOfNode ( iNode : cardinal ) : TDatabaseNodeData

Parameters
Parameter Description
iNode : CARDINAL

mAirListScript
Class Tree
Index
Previous (AddNode)
Next


Previous (IDatabaseTree)
Next (IDummyAction)

Name
IDebugObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetObjectInfo (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDatabaseTree)
Next (IDummyAction)


Previous
Next

Name
GetObjectInfo

Parent
IDebugObject

Visibility
PUBLIC

Source code
function GetObjectInfo : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IDebugObject)
Next (IDummyObject)

Name
IDummyAction

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDebugObject)
Next (IDummyObject)


Previous (IDummyAction)
Next (IDummyPlaylistItem)

Name
IDummyObject

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyAction)
Next (IDummyPlaylistItem)


Previous (IDummyObject)
Next (IEmergencyAction)

Name
IDummyPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyObject)
Next (IEmergencyAction)


Previous (IDummyPlaylistItem)
Next (IEngine)

Name
IEmergencyAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IDummyPlaylistItem)
Next (IEngine)


Previous (IEmergencyAction)
Next (IEngineDesktopPlugin)

Name
IEngine

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
AddDesktopPlugin (+)
Finalize (+)
GetActivePlayers (+)
GetCartwallControl (+)
GetDesktopFilename (+)
GetModified (+)
GetPlaybackControl (+)
GetPlaybackControlCount (+)
Initialize (+)
LoadDesktop (+)
LoadFromXML (+)
NewDesktop (+)
RemoveDesktopPlugin (+)
SaveAsXML (+)
SaveDesktop (+)
SaveDesktopAs (+)
SetModified (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEmergencyAction)
Next (IEngineDesktopPlugin)


Previous
Next (Finalize)

Name
AddDesktopPlugin

Parent
IEngine

Visibility
PUBLIC

Source code
procedure AddDesktopPlugin ( iPlugin : IEngineDesktopPlugin )

Parameters
Parameter Description
iPlugin : IEngineDesktopPlugin

mAirListScript
Class Tree
Index
Previous
Next (Finalize)


Previous (AddDesktopPlugin)
Next (GetActivePlayers)

Name
Finalize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddDesktopPlugin)
Next (GetActivePlayers)


Previous (Finalize)
Next (GetCartwallControl)

Name
GetActivePlayers

Parent
IEngine

Visibility
PUBLIC

Source code
function GetActivePlayers : IInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCartwallControl)


Previous (GetActivePlayers)
Next (GetDesktopFilename)

Name
GetCartwallControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetCartwallControl : ICartwallControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActivePlayers)
Next (GetDesktopFilename)


Previous (GetCartwallControl)
Next (GetModified)

Name
GetDesktopFilename

Parent
IEngine

Visibility
PUBLIC

Source code
function GetDesktopFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartwallControl)
Next (GetModified)


Previous (GetDesktopFilename)
Next (GetPlaybackControl)

Name
GetModified

Parent
IEngine

Visibility
PUBLIC

Source code
function GetModified : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDesktopFilename)
Next (GetPlaybackControl)


Previous (GetModified)
Next (GetPlaybackControlCount)

Name
GetPlaybackControl

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetModified)
Next (GetPlaybackControlCount)


Previous (GetPlaybackControl)
Next (Initialize)

Name
GetPlaybackControlCount

Parent
IEngine

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControl)
Next (Initialize)


Previous (GetPlaybackControlCount)
Next (LoadDesktop)

Name
Initialize

Parent
IEngine

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next (LoadDesktop)


Previous (Initialize)
Next (LoadFromXML)

Name
LoadDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadDesktop ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (LoadFromXML)


Previous (LoadDesktop)
Next (NewDesktop)

Name
LoadFromXML

Parent
IEngine

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (LoadDesktop)
Next (NewDesktop)


Previous (LoadFromXML)
Next (RemoveDesktopPlugin)

Name
NewDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure NewDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (RemoveDesktopPlugin)


Previous (NewDesktop)
Next (SaveAsXML)

Name
RemoveDesktopPlugin

Parent
IEngine

Visibility
PUBLIC

Source code
procedure RemoveDesktopPlugin ( iPlugin : IEngineDesktopPlugin )

Parameters
Parameter Description
iPlugin : IEngineDesktopPlugin

mAirListScript
Class Tree
Index
Previous (NewDesktop)
Next (SaveAsXML)


Previous (RemoveDesktopPlugin)
Next (SaveDesktop)

Name
SaveAsXML

Parent
IEngine

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ; iAsTemplate : boolean ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument
iAsTemplate : BOOLEAN

mAirListScript
Class Tree
Index
Previous (RemoveDesktopPlugin)
Next (SaveDesktop)


Previous (SaveAsXML)
Next (SaveDesktopAs)

Name
SaveDesktop

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveDesktopAs)


Previous (SaveDesktop)
Next (SetModified)

Name
SaveDesktopAs

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SaveDesktopAs ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (SaveDesktop)
Next (SetModified)


Previous (SaveDesktopAs)
Next

Name
SetModified

Parent
IEngine

Visibility
PUBLIC

Source code
procedure SetModified ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveDesktopAs)
Next


Previous (IEngine)
Next (IEngineInfo)

Name
IEngineDesktopPlugin

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ClearDesktopContents (+)
LoadDesktopContents (+)
SaveDesktopContents (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngine)
Next (IEngineInfo)


Previous
Next (LoadDesktopContents)

Name
ClearDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure ClearDesktopContents

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (LoadDesktopContents)


Previous (ClearDesktopContents)
Next (SaveDesktopContents)

Name
LoadDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure LoadDesktopContents ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (ClearDesktopContents)
Next (SaveDesktopContents)


Previous (LoadDesktopContents)
Next

Name
SaveDesktopContents

Parent
IEngineDesktopPlugin

Visibility
PUBLIC

Source code
procedure SaveDesktopContents ( iDocument : IXMLDocument ; iParentNode : IXMLNode ; iAsTemplate : boolean )

Parameters
Parameter Description
iDocument : IXMLDocument
iParentNode : IXMLNode
iAsTemplate : BOOLEAN

mAirListScript
Class Tree
Index
Previous (LoadDesktopContents)
Next


Previous (IEngineDesktopPlugin)
Next (IEnvelope)

Name
IEngineInfo

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCartPlayerCount (+)
GetPlaybackControlCount (+)
GetPlayerCount (+)
SetCartPlayerCount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngineDesktopPlugin)
Next (IEnvelope)


Previous
Next (GetPlaybackControlCount)

Name
GetCartPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetCartPlayerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPlaybackControlCount)


Previous (GetCartPlayerCount)
Next (GetPlayerCount)

Name
GetPlaybackControlCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlaybackControlCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCartPlayerCount)
Next (GetPlayerCount)


Previous (GetPlaybackControlCount)
Next (SetCartPlayerCount)

Name
GetPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
function GetPlayerCount ( iPlaybackControl : integer ) : integer

Parameters
Parameter Description
iPlaybackControl : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlCount)
Next (SetCartPlayerCount)


Previous (GetPlayerCount)
Next

Name
SetCartPlayerCount

Parent
IEngineInfo

Visibility
PUBLIC

Source code
procedure SetCartPlayerCount ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next


Previous (IEngineInfo)
Next (IEnvelopePoint)

Name
IEnvelope

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
AddPoint (+)
GetItem (+)
GetPosition (+)
GetSortedPoints (+)
GetValue (+)
GetValueAtPosition (+)
Merge (+)
RemoveByTag (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEngineInfo)
Next (IEnvelopePoint)


Previous
Next (GetItem)

Name
AddPoint

Parent
IEnvelope

Visibility
PUBLIC

Source code
function AddPoint ( iPosition : TTimeValue ; iValue : single ; iTag : string = '' ) : IEnvelopePoint

Parameters
Parameter Description
iPosition : TTimeValue
iValue : SINGLE
iTag : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (AddPoint)
Next (GetPosition)

Name
GetItem

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IEnvelopePoint

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (AddPoint)
Next (GetPosition)


Previous (GetItem)
Next (GetSortedPoints)

Name
GetPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetPosition ( iIndex : integer ) : TTimeValue

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSortedPoints)


Previous (GetPosition)
Next (GetValue)

Name
GetSortedPoints

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure GetSortedPoints ( var oPositions : TTimeValueArray ; var oValues : TSingleArray )

Parameters
Parameter Description
oPositions : TTimeValueArray
oValues : TSingleArray

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetValue)


Previous (GetSortedPoints)
Next (GetValueAtPosition)

Name
GetValue

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValue ( iIndex : integer ) : single

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetSortedPoints)
Next (GetValueAtPosition)


Previous (GetValue)
Next (Merge)

Name
GetValueAtPosition

Parent
IEnvelope

Visibility
PUBLIC

Source code
function GetValueAtPosition ( iPosition , iDuration : TTimeValue ) : single

Parameters
Parameter Description
iPosition : TTimeValue
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (Merge)


Previous (GetValueAtPosition)
Next (RemoveByTag)

Name
Merge

Parent
IEnvelope

Visibility
PUBLIC

Source code
function Merge ( iValue : IEnvelope ; iDuration : TTimeValue ) : IEnvelope

Parameters
Parameter Description
iValue : IEnvelope
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetValueAtPosition)
Next (RemoveByTag)


Previous (Merge)
Next

Name
RemoveByTag

Parent
IEnvelope

Visibility
PUBLIC

Source code
procedure RemoveByTag ( iTag : string )

Parameters
Parameter Description
iTag : STRING

mAirListScript
Class Tree
Index
Previous (Merge)
Next


Previous (IEnvelope)
Next (IEOFWarningCueDataItem)

Name
IEnvelopePoint

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetPosition (+)
GetTag (+)
GetValue (+)
SetPosition (+)
SetTag (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEnvelope)
Next (IEOFWarningCueDataItem)


Previous
Next (GetTag)

Name
GetPosition

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTag)


Previous (GetPosition)
Next (GetValue)

Name
GetTag

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetTag : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetValue)


Previous (GetTag)
Next (SetPosition)

Name
GetValue

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
function GetValue : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (SetPosition)


Previous (GetValue)
Next (SetTag)

Name
SetPosition

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (SetTag)


Previous (SetPosition)
Next (SetValue)

Name
SetTag

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SetValue)


Previous (SetTag)
Next

Name
SetValue

Parent
IEnvelopePoint

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetTag)
Next


Previous (IEnvelopePoint)
Next (IEventList)

Name
IEOFWarningCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEnvelopePoint)
Next (IEventList)


Previous (IEOFWarningCueDataItem)
Next (IEventListItem)

Name
IEventList

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
GetEnabled (+)
GetItem (+)
GetNextExecution (+)
GetNextItem (+)
GetNextItemAssist (+)
GetNextItemAutomation (+)
SetEnabled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEOFWarningCueDataItem)
Next (IEventListItem)


Previous
Next (GetItem)

Name
GetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEnabled)
Next (GetNextExecution)

Name
GetItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IEventListItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetNextExecution)


Previous (GetItem)
Next (GetNextItem)

Name
GetNextExecution

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetNextItem)


Previous (GetNextExecution)
Next (GetNextItemAssist)

Name
GetNextItem

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetNextItemAssist)


Previous (GetNextItem)
Next (GetNextItemAutomation)

Name
GetNextItemAssist

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAssist : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItem)
Next (GetNextItemAutomation)


Previous (GetNextItemAssist)
Next (SetEnabled)

Name
GetNextItemAutomation

Parent
IEventList

Visibility
PUBLIC

Source code
function GetNextItemAutomation : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextItemAssist)
Next (SetEnabled)


Previous (GetNextItemAutomation)
Next

Name
SetEnabled

Parent
IEventList

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetNextItemAutomation)
Next


Previous (IEventList)
Next (IEventsModule)

Name
IEventListItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetActions (+)
GetDay (+)
GetDescription (+)
GetEnabled (+)
GetExpiration (+)
GetHour (+)
GetLastExecution (+)
GetMinute (+)
GetMonth (+)
GetNextExecution (+)
GetRunInAssist (+)
GetRunInAutomation (+)
GetSecond (+)
GetWeekday (+)
GetYear (+)
SetDay (+)
SetDescription (+)
SetEnabled (+)
SetExpiration (+)
SetHour (+)
SetLastExecution (+)
SetMinute (+)
SetMonth (+)
SetRunInAssist (+)
SetRunInAutomation (+)
SetSecond (+)
SetWeekday (+)
SetYear (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventList)
Next (IEventsModule)


Previous
Next (GetDay)

Name
GetActions

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetDay)


Previous (GetActions)
Next (GetDescription)

Name
GetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDay : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActions)
Next (GetDescription)


Previous (GetDay)
Next (GetEnabled)

Name
GetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDay)
Next (GetEnabled)


Previous (GetDescription)
Next (GetExpiration)

Name
GetEnabled

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetExpiration)


Previous (GetEnabled)
Next (GetHour)

Name
GetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetExpiration : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetHour)


Previous (GetExpiration)
Next (GetLastExecution)

Name
GetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetHour : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiration)
Next (GetLastExecution)


Previous (GetHour)
Next (GetMinute)

Name
GetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetLastExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHour)
Next (GetMinute)


Previous (GetLastExecution)
Next (GetMonth)

Name
GetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMinute : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLastExecution)
Next (GetMonth)


Previous (GetMinute)
Next (GetNextExecution)

Name
GetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetMonth : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMinute)
Next (GetNextExecution)


Previous (GetMonth)
Next (GetRunInAssist)

Name
GetNextExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetNextExecution : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMonth)
Next (GetRunInAssist)


Previous (GetNextExecution)
Next (GetRunInAutomation)

Name
GetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAssist : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextExecution)
Next (GetRunInAutomation)


Previous (GetRunInAssist)
Next (GetSecond)

Name
GetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetRunInAutomation : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAssist)
Next (GetSecond)


Previous (GetRunInAutomation)
Next (GetWeekday)

Name
GetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetSecond : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRunInAutomation)
Next (GetWeekday)


Previous (GetSecond)
Next (GetYear)

Name
GetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetWeekday : TSetOfByte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSecond)
Next (GetYear)


Previous (GetWeekday)
Next (SetDay)

Name
GetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
function GetYear : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWeekday)
Next (SetDay)


Previous (GetYear)
Next (SetDescription)

Name
SetDay

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDay ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (GetYear)
Next (SetDescription)


Previous (SetDay)
Next (SetEnabled)

Name
SetDescription

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDay)
Next (SetEnabled)


Previous (SetDescription)
Next (SetExpiration)

Name
SetEnabled

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetExpiration)


Previous (SetEnabled)
Next (SetHour)

Name
SetExpiration

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetExpiration ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetEnabled)
Next (SetHour)


Previous (SetExpiration)
Next (SetLastExecution)

Name
SetHour

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetHour ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetExpiration)
Next (SetLastExecution)


Previous (SetHour)
Next (SetMinute)

Name
SetLastExecution

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetLastExecution ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetHour)
Next (SetMinute)


Previous (SetLastExecution)
Next (SetMonth)

Name
SetMinute

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMinute ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetLastExecution)
Next (SetMonth)


Previous (SetMinute)
Next (SetRunInAssist)

Name
SetMonth

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetMonth ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetMinute)
Next (SetRunInAssist)


Previous (SetMonth)
Next (SetRunInAutomation)

Name
SetRunInAssist

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAssist ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetMonth)
Next (SetRunInAutomation)


Previous (SetRunInAssist)
Next (SetSecond)

Name
SetRunInAutomation

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetRunInAutomation ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetRunInAssist)
Next (SetSecond)


Previous (SetRunInAutomation)
Next (SetWeekday)

Name
SetSecond

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetSecond ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetRunInAutomation)
Next (SetWeekday)


Previous (SetSecond)
Next (SetYear)

Name
SetWeekday

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetWeekday ( iValue : TSetOfByte )

Parameters
Parameter Description
iValue : TSetOfByte

mAirListScript
Class Tree
Index
Previous (SetSecond)
Next (SetYear)


Previous (SetWeekday)
Next

Name
SetYear

Parent
IEventListItem

Visibility
PUBLIC

Source code
procedure SetYear ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetWeekday)
Next


Previous (IEventListItem)
Next (IFactory)

Name
IEventsModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventListItem)
Next (IFactory)


Previous (IEventsModule)
Next (IFactoryClass)

Name
IFactory

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateActionList (+)
CreateBreakPlaylistItem (+)
CreateCommandPlaylistItem (+)
CreateContainerPlaylistItem (+)
CreateDummyPlaylistItem (+)
CreateEventList (+)
CreateEventListItem (+)
CreateFilePlaylistItem (+)
CreateHookContainer (+)
CreateMultiPlaylist (+)
CreateObject (+)
CreatePersistentArray (+)
CreatePersistentBoolean (+)
CreatePersistentInteger (+)
CreatePersistentNull (+)
CreatePersistentNumber (+)
CreatePersistentObject (+)
CreatePersistentString (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+)
CreatePlaylistItemFromPersistentObject (+)
CreatePlaylistItemFromXML (+)
CreatePlaylistItemFromXMLString (+)
CreateRegionContainerPlaylistItem (+)
CreateSilencePlaylistItem (+)
CreateStreamPlaylistItem (+)
CreateTemporaryPlaylist (+)
CreateXMLDocument (+)
CreateXMLDocumentFromString (+)
GetClasses (+)
GetDefaultItemType (+)
GetFileImportOptions (+)
GetMMDFolder (+)
RegisterClass (+)
SetDefaultItemType (+)
SetFileImportOptions (+)
SetMMDFolder (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IEventsModule)
Next (IFactoryClass)


Previous
Next (CreateBreakPlaylistItem)

Name
CreateActionList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateActionList : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CreateBreakPlaylistItem)


Previous (CreateActionList)
Next (CreateCommandPlaylistItem)

Name
CreateBreakPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateBreakPlaylistItem : IBreakPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateActionList)
Next (CreateCommandPlaylistItem)


Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)

Name
CreateCommandPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateCommandPlaylistItem : ICommandPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateBreakPlaylistItem)
Next (CreateContainerPlaylistItem)


Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)

Name
CreateContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateCommandPlaylistItem)
Next (CreateDummyPlaylistItem)


Previous (CreateContainerPlaylistItem)
Next (CreateEventList)

Name
CreateDummyPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateDummyPlaylistItem : IDummyPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateEventList)


Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)

Name
CreateEventList

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateDummyPlaylistItem)
Next (CreateEventListItem)


Previous (CreateEventList)
Next (CreateFilePlaylistItem)

Name
CreateEventListItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateEventListItem : IEventListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateEventList)
Next (CreateFilePlaylistItem)


Previous (CreateEventListItem)
Next (CreateHookContainer)

Name
CreateFilePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iTasks : TFileImportTasks ) : IFilePlaylistItem

Parameters
Parameter Description
iFilename : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (CreateEventListItem)
Next (CreateHookContainer)


Previous (CreateFilePlaylistItem)
Next (CreateMultiPlaylist)

Name
CreateHookContainer

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateHookContainer ( iItems : IPlaylist ) : IContainerPlaylistItem

Parameters
Parameter Description
iItems : IPlaylist

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreateMultiPlaylist)


Previous (CreateHookContainer)
Next (CreateObject)

Name
CreateMultiPlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateMultiPlaylist : IMultiPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateHookContainer)
Next (CreateObject)


Previous (CreateMultiPlaylist)
Next (CreatePersistentArray)

Name
CreateObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateObject ( iGUID : TGUID ; iIndex : integer ) : IUnknown

Parameters
Parameter Description
iGUID : TGUID
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateMultiPlaylist)
Next (CreatePersistentArray)


Previous (CreateObject)
Next (CreatePersistentBoolean)

Name
CreatePersistentArray

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentArray : IPersistentArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateObject)
Next (CreatePersistentBoolean)


Previous (CreatePersistentArray)
Next (CreatePersistentInteger)

Name
CreatePersistentBoolean

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentBoolean ( iValue : boolean ) : IPersistentBoolean

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (CreatePersistentArray)
Next (CreatePersistentInteger)


Previous (CreatePersistentBoolean)
Next (CreatePersistentNull)

Name
CreatePersistentInteger

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentInteger ( iValue : int64 ) : IPersistentInteger

Parameters
Parameter Description
iValue : INT64

mAirListScript
Class Tree
Index
Previous (CreatePersistentBoolean)
Next (CreatePersistentNull)


Previous (CreatePersistentInteger)
Next (CreatePersistentNumber)

Name
CreatePersistentNull

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentNull : IPersistentNull

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentInteger)
Next (CreatePersistentNumber)


Previous (CreatePersistentNull)
Next (CreatePersistentObject)

Name
CreatePersistentNumber

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentNumber ( iValue : double ) : IPersistentNumber

Parameters
Parameter Description
iValue : DOUBLE

mAirListScript
Class Tree
Index
Previous (CreatePersistentNull)
Next (CreatePersistentObject)


Previous (CreatePersistentNumber)
Next (CreatePersistentString)

Name
CreatePersistentObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentNumber)
Next (CreatePersistentString)


Previous (CreatePersistentObject)
Next (CreatePlaylist)

Name
CreatePersistentString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePersistentString ( iValue : string ) : IPersistentString

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (CreatePersistentObject)
Next (CreatePlaylist)


Previous (CreatePersistentString)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePersistentString)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromPersistentObject)

Name
CreatePlaylistItemFromFile

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iTasks : TFileImportTasks ) : IPlaylistItem

Parameters
Parameter Description
iFilename : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromPersistentObject)


Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXML)

Name
CreatePlaylistItemFromPersistentObject

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromPersistentObject ( iValue : IPersistentObject ) : IPlaylistItem

Parameters
Parameter Description
iValue : IPersistentObject

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CreatePlaylistItemFromXML)


Previous (CreatePlaylistItemFromPersistentObject)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromXML

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXML ( iNode : IXMLNode ) : IPlaylistItem

Parameters
Parameter Description
iNode : IXMLNode

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromPersistentObject)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)

Name
CreatePlaylistItemFromXMLString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter Description
iXML : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXML)
Next (CreateRegionContainerPlaylistItem)


Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)

Name
CreateRegionContainerPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateRegionContainerPlaylistItem : IRegionContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CreateSilencePlaylistItem)


Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)

Name
CreateSilencePlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateSilencePlaylistItem : ISilencePlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateRegionContainerPlaylistItem)
Next (CreateStreamPlaylistItem)


Previous (CreateSilencePlaylistItem)
Next (CreateTemporaryPlaylist)

Name
CreateStreamPlaylistItem

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateStreamPlaylistItem : IStreamPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateSilencePlaylistItem)
Next (CreateTemporaryPlaylist)


Previous (CreateStreamPlaylistItem)
Next (CreateXMLDocument)

Name
CreateTemporaryPlaylist

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateTemporaryPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStreamPlaylistItem)
Next (CreateXMLDocument)


Previous (CreateTemporaryPlaylist)
Next (CreateXMLDocumentFromString)

Name
CreateXMLDocument

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateXMLDocument : IXMLDocument

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateTemporaryPlaylist)
Next (CreateXMLDocumentFromString)


Previous (CreateXMLDocument)
Next (GetClasses)

Name
CreateXMLDocumentFromString

Parent
IFactory

Visibility
PUBLIC

Source code
function CreateXMLDocumentFromString ( iString : string ) : IXMLDocument

Parameters
Parameter Description
iString : STRING

mAirListScript
Class Tree
Index
Previous (CreateXMLDocument)
Next (GetClasses)


Previous (CreateXMLDocumentFromString)
Next (GetDefaultItemType)

Name
GetClasses

Parent
IFactory

Visibility
PUBLIC

Source code
function GetClasses ( iGUID : TGUID ) : IInterfaceList

Parameters
Parameter Description
iGUID : TGUID

mAirListScript
Class Tree
Index
Previous (CreateXMLDocumentFromString)
Next (GetDefaultItemType)


Previous (GetClasses)
Next (GetFileImportOptions)

Name
GetDefaultItemType

Parent
IFactory

Visibility
PUBLIC

Source code
function GetDefaultItemType : TPlaylistItemType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClasses)
Next (GetFileImportOptions)


Previous (GetDefaultItemType)
Next (GetMMDFolder)

Name
GetFileImportOptions

Parent
IFactory

Visibility
PUBLIC

Source code
function GetFileImportOptions : TFileImportOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultItemType)
Next (GetMMDFolder)


Previous (GetFileImportOptions)
Next (RegisterClass)

Name
GetMMDFolder

Parent
IFactory

Visibility
PUBLIC

Source code
function GetMMDFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileImportOptions)
Next (RegisterClass)


Previous (GetMMDFolder)
Next (SetDefaultItemType)

Name
RegisterClass

Parent
IFactory

Visibility
PUBLIC

Source code
procedure RegisterClass ( iGUID : TGUID ; iClass : IFactoryClass ; iPriority : integer = 0 )

Parameters
Parameter Description
iGUID : TGUID
iClass : IFactoryClass
iPriority : INTEGER

mAirListScript
Class Tree
Index
Previous (GetMMDFolder)
Next (SetDefaultItemType)


Previous (RegisterClass)
Next (SetFileImportOptions)

Name
SetDefaultItemType

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetDefaultItemType ( iValue : TPlaylistItemType )

Parameters
Parameter Description
iValue : TPlaylistItemType

mAirListScript
Class Tree
Index
Previous (RegisterClass)
Next (SetFileImportOptions)


Previous (SetDefaultItemType)
Next (SetMMDFolder)

Name
SetFileImportOptions

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetFileImportOptions ( iValue : TFileImportOptions )

Parameters
Parameter Description
iValue : TFileImportOptions

mAirListScript
Class Tree
Index
Previous (SetDefaultItemType)
Next (SetMMDFolder)


Previous (SetFileImportOptions)
Next

Name
SetMMDFolder

Parent
IFactory

Visibility
PUBLIC

Source code
procedure SetMMDFolder ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetFileImportOptions)
Next


Previous (IFactory)
Next (IFactoryObjectList)

Name
IFactoryClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CreateInstance (+)
CreateInstanceWithParameters (+)
GetClassCategory (+)
GetClassDescription (+)
GetClassID (+)
GetClassPriority (+)
GetClassTypeDescription (+)
InitializeClass (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactory)
Next (IFactoryObjectList)


Previous
Next (CreateInstanceWithParameters)

Name
CreateInstance

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstance ( iInstance : IInstanceData ) : IUnknown

Parameters
Parameter Description
iInstance : IInstanceData

mAirListScript
Class Tree
Index
Previous
Next (CreateInstanceWithParameters)


Previous (CreateInstance)
Next (GetClassCategory)

Name
CreateInstanceWithParameters

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function CreateInstanceWithParameters ( iInstance : IInstanceData ; iParameters : array of Variant ) : IUnknown

Parameters
Parameter Description
iInstance : IInstanceData
iParameters : VARIANT

mAirListScript
Class Tree
Index
Previous (CreateInstance)
Next (GetClassCategory)


Previous (CreateInstanceWithParameters)
Next (GetClassDescription)

Name
GetClassCategory

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassCategory : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateInstanceWithParameters)
Next (GetClassDescription)


Previous (GetClassCategory)
Next (GetClassID)

Name
GetClassDescription

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassCategory)
Next (GetClassID)


Previous (GetClassDescription)
Next (GetClassPriority)

Name
GetClassID

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassDescription)
Next (GetClassPriority)


Previous (GetClassID)
Next (GetClassTypeDescription)

Name
GetClassPriority

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassPriority : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassID)
Next (GetClassTypeDescription)


Previous (GetClassPriority)
Next (InitializeClass)

Name
GetClassTypeDescription

Parent
IFactoryClass

Visibility
PUBLIC

Source code
function GetClassTypeDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClassPriority)
Next (InitializeClass)


Previous (GetClassTypeDescription)
Next

Name
InitializeClass

Parent
IFactoryClass

Visibility
PUBLIC

Source code
procedure InitializeClass ( iInstance : IInstanceData )

Parameters
Parameter Description
iInstance : IInstanceData

mAirListScript
Class Tree
Index
Previous (GetClassTypeDescription)
Next


Previous (IFactoryClass)
Next (IFileEncoder)

Name
IFactoryObjectList

Parent
mAirListInterfaces

Class Hierarchy
IObservableList

Visibility
PUBLIC

Members
Methods
Method Description
GetItemGUID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactoryClass)
Next (IFileEncoder)


Previous
Next

Name
GetItemGUID

Parent
IFactoryObjectList

Visibility
PUBLIC

Source code
function GetItemGUID : TGUID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFactoryObjectList)
Next (IFileEncoderSettings)

Name
IFileEncoder

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
EncodeFile (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFactoryObjectList)
Next (IFileEncoderSettings)


Previous
Next

Name
EncodeFile

Parent
IFileEncoder

Visibility
PUBLIC

Source code
procedure EncodeFile ( iSettings : IFileEncoderSettings ; iFile : IStream ; var oFilename : string ; iProgressIndicator : IProgressIndicator = nil )

Parameters
Parameter Description
iSettings : IFileEncoderSettings
iFile : IStream
oFilename : STRING
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileEncoder)
Next (IFileManager)

Name
IFileEncoderSettings

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
GetExtension (+)
GetSummary (+)
PreferLinear (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileEncoder)
Next (IFileManager)


Previous
Next (GetExtension)

Name
Assign

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IFileEncoderSettings )

Parameters
Parameter Description
iValue : IFileEncoderSettings

mAirListScript
Class Tree
Index
Previous
Next (GetExtension)


Previous (Assign)
Next (GetSummary)

Name
GetExtension

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
function GetExtension : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (GetSummary)


Previous (GetExtension)
Next (PreferLinear)

Name
GetSummary

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExtension)
Next (PreferLinear)


Previous (GetSummary)
Next

Name
PreferLinear

Parent
IFileEncoderSettings

Visibility
PUBLIC

Source code
procedure PreferLinear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSummary)
Next


Previous (IFileEncoderSettings)
Next (IFilePlaylistItem)

Name
IFileManager

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CreateStreamForFile (+)
GetEnabled (+)
GetMemoryFileLimit (+)
GetOptions (+)
SetEnabled (+)
SetMemoryFileLimit (+)
SetOptions (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileEncoderSettings)
Next (IFilePlaylistItem)


Previous
Next (GetEnabled)

Name
CreateStreamForFile

Parent
IFileManager

Visibility
PUBLIC

Source code
function CreateStreamForFile ( iFilename : string ) : IStream

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetEnabled)


Previous (CreateStreamForFile)
Next (GetMemoryFileLimit)

Name
GetEnabled

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetEnabled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateStreamForFile)
Next (GetMemoryFileLimit)


Previous (GetEnabled)
Next (GetOptions)

Name
GetMemoryFileLimit

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetMemoryFileLimit : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEnabled)
Next (GetOptions)


Previous (GetMemoryFileLimit)
Next (SetEnabled)

Name
GetOptions

Parent
IFileManager

Visibility
PUBLIC

Source code
function GetOptions : TFileManagementOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMemoryFileLimit)
Next (SetEnabled)


Previous (GetOptions)
Next (SetMemoryFileLimit)

Name
SetEnabled

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetEnabled ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (SetMemoryFileLimit)


Previous (SetEnabled)
Next (SetOptions)

Name
SetMemoryFileLimit

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetMemoryFileLimit ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetEnabled)
Next (SetOptions)


Previous (SetMemoryFileLimit)
Next

Name
SetOptions

Parent
IFileManager

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TFileManagementOptions )

Parameters
Parameter Description
iValue : TFileManagementOptions

mAirListScript
Class Tree
Index
Previous (SetMemoryFileLimit)
Next


Previous (IFileManager)
Next (IFilePlaylistItemClass)

Name
IFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
CreateFileStream (+)
GetFileData (+)
GetFilename (+)
GetFileTagData (+)
GetFileTypeHandler (+)
LoadMMD (+)
SaveMMD (+)
SetFileData (+)
SetFilename (+)
UpdateTilde (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileManager)
Next (IFilePlaylistItemClass)


Previous
Next (GetFileData)

Name
CreateFileStream

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function CreateFileStream : IStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetFileData)


Previous (CreateFileStream)
Next (GetFilename)

Name
GetFileData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileData : IStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFileStream)
Next (GetFilename)


Previous (GetFileData)
Next (GetFileTagData)

Name
GetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileData)
Next (GetFileTagData)


Previous (GetFilename)
Next (GetFileTypeHandler)

Name
GetFileTagData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTagData ( iTag : string ) : string

Parameters
Parameter Description
iTag : STRING

mAirListScript
Class Tree
Index
Previous (GetFilename)
Next (GetFileTypeHandler)


Previous (GetFileTagData)
Next (LoadMMD)

Name
GetFileTypeHandler

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function GetFileTypeHandler : IFileTypeHandler

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTagData)
Next (LoadMMD)


Previous (GetFileTypeHandler)
Next (SaveMMD)

Name
LoadMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function LoadMMD : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileTypeHandler)
Next (SaveMMD)


Previous (LoadMMD)
Next (SetFileData)

Name
SaveMMD

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveMMD

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadMMD)
Next (SetFileData)


Previous (SaveMMD)
Next (SetFilename)

Name
SetFileData

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetFileData ( iValue : IStream )

Parameters
Parameter Description
iValue : IStream

mAirListScript
Class Tree
Index
Previous (SaveMMD)
Next (SetFilename)


Previous (SetFileData)
Next (UpdateTilde)

Name
SetFilename

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetFileData)
Next (UpdateTilde)


Previous (SetFilename)
Next

Name
UpdateTilde

Parent
IFilePlaylistItem

Visibility
PUBLIC

Source code
function UpdateTilde : TCuePositionTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetFilename)
Next


Previous (IFilePlaylistItem)
Next (IFileStorageClass)

Name
IFilePlaylistItemClass

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItem)
Next (IFileStorageClass)


Previous
Next

Name
SupportsExtension

Parent
IFilePlaylistItemClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter Description
iExtension : STRING

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFilePlaylistItemClass)
Next (IFileTypeHandler)

Name
IFileStorageClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
GetFileFilter (+)
SupportsExtension (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFilePlaylistItemClass)
Next (IFileTypeHandler)


Previous
Next (SupportsExtension)

Name
GetFileFilter

Parent
IFileStorageClass

Visibility
PUBLIC

Source code
function GetFileFilter : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SupportsExtension)


Previous (GetFileFilter)
Next

Name
SupportsExtension

Parent
IFileStorageClass

Visibility
PUBLIC

Source code
function SupportsExtension ( iExtension : string ) : boolean

Parameters
Parameter Description
iExtension : STRING

mAirListScript
Class Tree
Index
Previous (GetFileFilter)
Next


Previous (IFileStorageClass)
Next (IFileTypeHandlerClass)

Name
IFileTypeHandler

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCapabilities (+)
GetTagData (+)
ReadDuration (+)
ReadNativeTags (+)
ReadTags (+)
SetItem (+)
WriteTags (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileStorageClass)
Next (IFileTypeHandlerClass)


Previous
Next (GetTagData)

Name
GetCapabilities

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetCapabilities : TFileTypeHandlerCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetTagData)


Previous (GetCapabilities)
Next (ReadDuration)

Name
GetTagData

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function GetTagData ( iTag : string ) : string

Parameters
Parameter Description
iTag : STRING

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (ReadDuration)


Previous (GetTagData)
Next (ReadNativeTags)

Name
ReadDuration

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadDuration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTagData)
Next (ReadNativeTags)


Previous (ReadDuration)
Next (ReadTags)

Name
ReadNativeTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure ReadNativeTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadDuration)
Next (ReadTags)


Previous (ReadNativeTags)
Next (SetItem)

Name
ReadTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
function ReadTags : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReadNativeTags)
Next (SetItem)


Previous (ReadTags)
Next (WriteTags)

Name
SetItem

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure SetItem ( iItem : IFilePlaylistItem )

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous (ReadTags)
Next (WriteTags)


Previous (SetItem)
Next

Name
WriteTags

Parent
IFileTypeHandler

Visibility
PUBLIC

Source code
procedure WriteTags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetItem)
Next


Previous (IFileTypeHandler)
Next (IHiddenModule)

Name
IFileTypeHandlerClass

Parent
mAirListInterfaces

Class Hierarchy
IFactoryClass

Visibility
PUBLIC

Members
Methods
Method Description
SupportsItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandler)
Next (IHiddenModule)


Previous
Next

Name
SupportsItem

Parent
IFileTypeHandlerClass

Visibility
PUBLIC

Source code
function SupportsItem ( iItem : IFilePlaylistItem ) : integer

Parameters
Parameter Description
iItem : IFilePlaylistItem

mAirListScript
Class Tree
Index
Previous
Next


Previous (IFileTypeHandlerClass)
Next (IInfiniteSilencePlaylistItem)

Name
IHiddenModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IFileTypeHandlerClass)
Next (IInfiniteSilencePlaylistItem)


Previous (IHiddenModule)
Next (IInlineData)

Name
IInfiniteSilencePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IHiddenModule)
Next (IInlineData)


Previous (IInfiniteSilencePlaylistItem)
Next (IInlineFilePlaylistItem)

Name
IInlineData

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
Clear (+)
GetBase64String (+)
GetHash (+)
GetSize (+)
HasData (+)
LoadFromFile (+)
LoadFromStream (+)
LoadFromStreamPersist (+)
SetBase64String (+)
WriteToStream (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInfiniteSilencePlaylistItem)
Next (IInlineFilePlaylistItem)


Previous
Next (Clear)

Name
Assign

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IInlineData )

Parameters
Parameter Description
iValue : IInlineData

mAirListScript
Class Tree
Index
Previous
Next (Clear)


Previous (Assign)
Next (GetBase64String)

Name
Clear

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (GetBase64String)


Previous (Clear)
Next (GetHash)

Name
GetBase64String

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetBase64String : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetHash)


Previous (GetBase64String)
Next (GetSize)

Name
GetHash

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetHash : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBase64String)
Next (GetSize)


Previous (GetHash)
Next (HasData)

Name
GetSize

Parent
IInlineData

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHash)
Next (HasData)


Previous (GetSize)
Next (LoadFromFile)

Name
HasData

Parent
IInlineData

Visibility
PUBLIC

Source code
function HasData : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (LoadFromFile)


Previous (HasData)
Next (LoadFromStream)

Name
LoadFromFile

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (HasData)
Next (LoadFromStream)


Previous (LoadFromFile)
Next (LoadFromStreamPersist)

Name
LoadFromStream

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromStream ( iStream : TStream )

Parameters
Parameter Description
iStream : TStream

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (LoadFromStreamPersist)


Previous (LoadFromStream)
Next (SetBase64String)

Name
LoadFromStreamPersist

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure LoadFromStreamPersist ( iPersist : IStreamPersist )

Parameters
Parameter Description
iPersist : IStreamPersist

mAirListScript
Class Tree
Index
Previous (LoadFromStream)
Next (SetBase64String)


Previous (LoadFromStreamPersist)
Next (WriteToStream)

Name
SetBase64String

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure SetBase64String ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (LoadFromStreamPersist)
Next (WriteToStream)


Previous (SetBase64String)
Next

Name
WriteToStream

Parent
IInlineData

Visibility
PUBLIC

Source code
procedure WriteToStream ( iStream : TStream )

Parameters
Parameter Description
iStream : TStream

mAirListScript
Class Tree
Index
Previous (SetBase64String)
Next


Previous (IInlineData)
Next (IInstanceData)

Name
IInlineFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetOriginalFilename (+)
SaveToMIF (+)
SetOriginalFilename (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlineData)
Next (IInstanceData)


Previous
Next (SaveToMIF)

Name
GetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
function GetOriginalFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SaveToMIF)


Previous (GetOriginalFilename)
Next (SetOriginalFilename)

Name
SaveToMIF

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SaveToMIF ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (GetOriginalFilename)
Next (SetOriginalFilename)


Previous (SaveToMIF)
Next

Name
SetOriginalFilename

Parent
IInlineFilePlaylistItem

Visibility
PUBLIC

Source code
procedure SetOriginalFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SaveToMIF)
Next


Previous (IInlineFilePlaylistItem)
Next (ILevelInfo)

Name
IInstanceData

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddModule (+)
DecPFLCount (+)
ExecuteAsync (+)
FakeNow (+)
Finalize (+)
GetClients (+)
GetCommandList (+)
GetConfig (+)
GetDatabases (+)
GetDefaultFadeDuration (+)
GetDescription (+)
GetDeviceConfig (+)
GetDisabledModules (+)
GetEndMonDuration (+)
GetEngine (+)
GetEngineInfo (+)
GetFactory (+)
GetFeatures (+)
GetFileManager (+)
GetLicenseManager (+)
GetLogger (+)
GetMessageDispatcher (+)
GetMMDFolder (+)
GetModules (+)
GetName (+)
GetOnAir (+)
GetOptions (+)
GetPlaybackDevices (+)
GetPlayoutMode (+)
GetProductName (+)
GetProductVersion (+)
GetRecordDevices (+)
GetRecycleBin (+)
GetRegions (+)
GetRemoteController (+)
GetRepositoryItem (+)
GetRootFolder (+)
GetRuntimeData (+)
GetSerialPortManager (+)
GetSupportedFileExtensions (+)
GetTimeCorrection (+)
IncPFLCount (+)
Initialize (+)
SetDefaultFadeDuration (+)
SetDescription (+)
SetEndMonDuration (+)
SetName (+)
SetOnAir (+)
SetOptions (+)
SetPlayoutMode (+)
SetRuntimeData (+)
SetTimeCorrection (+)
Shutdown (+)
Startup (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInlineFilePlaylistItem)
Next (ILevelInfo)


Previous
Next (DecPFLCount)

Name
AddModule

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure AddModule ( iModule : IModule )

Parameters
Parameter Description
iModule : IModule

mAirListScript
Class Tree
Index
Previous
Next (DecPFLCount)


Previous (AddModule)
Next (ExecuteAsync)

Name
DecPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function DecPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddModule)
Next (ExecuteAsync)


Previous (DecPFLCount)
Next (FakeNow)

Name
ExecuteAsync

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure ExecuteAsync ( iCode : IRunnable )

Parameters
Parameter Description
iCode : IRunnable

mAirListScript
Class Tree
Index
Previous (DecPFLCount)
Next (FakeNow)


Previous (ExecuteAsync)
Next (Finalize)

Name
FakeNow

Parent
IInstanceData

Visibility
PUBLIC

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteAsync)
Next (Finalize)


Previous (FakeNow)
Next (GetClients)

Name
Finalize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (GetClients)


Previous (Finalize)
Next (GetCommandList)

Name
GetClients

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetClients : IClientList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCommandList)


Previous (GetClients)
Next (GetConfig)

Name
GetCommandList

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClients)
Next (GetConfig)


Previous (GetCommandList)
Next (GetDatabases)

Name
GetConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetConfig : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandList)
Next (GetDatabases)


Previous (GetConfig)
Next (GetDefaultFadeDuration)

Name
GetDatabases

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDatabases : IDatabaseList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConfig)
Next (GetDefaultFadeDuration)


Previous (GetDatabases)
Next (GetDescription)

Name
GetDefaultFadeDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDefaultFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabases)
Next (GetDescription)


Previous (GetDefaultFadeDuration)
Next (GetDeviceConfig)

Name
GetDescription

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultFadeDuration)
Next (GetDeviceConfig)


Previous (GetDescription)
Next (GetDisabledModules)

Name
GetDeviceConfig

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDeviceConfig : IAudioDeviceConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetDisabledModules)


Previous (GetDeviceConfig)
Next (GetEndMonDuration)

Name
GetDisabledModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetDisabledModules : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceConfig)
Next (GetEndMonDuration)


Previous (GetDisabledModules)
Next (GetEngine)

Name
GetEndMonDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEndMonDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDisabledModules)
Next (GetEngine)


Previous (GetEndMonDuration)
Next (GetEngineInfo)

Name
GetEngine

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndMonDuration)
Next (GetEngineInfo)


Previous (GetEngine)
Next (GetFactory)

Name
GetEngineInfo

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetEngineInfo : IEngineInfo

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngine)
Next (GetFactory)


Previous (GetEngineInfo)
Next (GetFeatures)

Name
GetFactory

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFactory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEngineInfo)
Next (GetFeatures)


Previous (GetFactory)
Next (GetFileManager)

Name
GetFeatures

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFeatures : TmAirListFeatures

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFactory)
Next (GetFileManager)


Previous (GetFeatures)
Next (GetLicenseManager)

Name
GetFileManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetFileManager : IFileManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFeatures)
Next (GetLicenseManager)


Previous (GetFileManager)
Next (GetLogger)

Name
GetLicenseManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLicenseManager : ILicenseManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFileManager)
Next (GetLogger)


Previous (GetLicenseManager)
Next (GetMessageDispatcher)

Name
GetLogger

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetLogger : ILogger

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLicenseManager)
Next (GetMessageDispatcher)


Previous (GetLogger)
Next (GetMMDFolder)

Name
GetMessageDispatcher

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMessageDispatcher : IMessageDispatcher

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogger)
Next (GetMMDFolder)


Previous (GetMessageDispatcher)
Next (GetModules)

Name
GetMMDFolder

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetMMDFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageDispatcher)
Next (GetModules)


Previous (GetMMDFolder)
Next (GetName)

Name
GetModules

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetModules : IModuleList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMMDFolder)
Next (GetName)


Previous (GetModules)
Next (GetOnAir)

Name
GetName

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetModules)
Next (GetOnAir)


Previous (GetName)
Next (GetOptions)

Name
GetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOnAir : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetOptions)


Previous (GetOnAir)
Next (GetPlaybackDevices)

Name
GetOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetOptions : TGlobalOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAir)
Next (GetPlaybackDevices)


Previous (GetOptions)
Next (GetPlayoutMode)

Name
GetPlaybackDevices

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetPlaybackDevices : IPlaybackDeviceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayoutMode)


Previous (GetPlaybackDevices)
Next (GetProductName)

Name
GetPlayoutMode

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetPlayoutMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackDevices)
Next (GetProductName)


Previous (GetPlayoutMode)
Next (GetProductVersion)

Name
GetProductName

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayoutMode)
Next (GetProductVersion)


Previous (GetProductName)
Next (GetRecordDevices)

Name
GetProductVersion

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure GetProductVersion ( out oMajor , oMinor , oRelease , oBuild : integer ; var oBetaname : string )

Parameters
Parameter Description
oMajor : INTEGER
oMinor : INTEGER
oRelease : INTEGER
oBuild : INTEGER
oBetaname : STRING

mAirListScript
Class Tree
Index
Previous (GetProductName)
Next (GetRecordDevices)


Previous (GetProductVersion)
Next (GetRecycleBin)

Name
GetRecordDevices

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRecordDevices : IRecordDeviceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProductVersion)
Next (GetRecycleBin)


Previous (GetRecordDevices)
Next (GetRegions)

Name
GetRecycleBin

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRecycleBin : IRecycleBinPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRecordDevices)
Next (GetRegions)


Previous (GetRecycleBin)
Next (GetRemoteController)

Name
GetRegions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRegions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRecycleBin)
Next (GetRemoteController)


Previous (GetRegions)
Next (GetRepositoryItem)

Name
GetRemoteController

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRemoteController : IRemoteController

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetRepositoryItem)


Previous (GetRemoteController)
Next (GetRootFolder)

Name
GetRepositoryItem

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRepositoryItem ( iItem : TRepositoryItem ) : IPlaylistItem

Parameters
Parameter Description
iItem : TRepositoryItem

mAirListScript
Class Tree
Index
Previous (GetRemoteController)
Next (GetRootFolder)


Previous (GetRepositoryItem)
Next (GetRuntimeData)

Name
GetRootFolder

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRootFolder : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRepositoryItem)
Next (GetRuntimeData)


Previous (GetRootFolder)
Next (GetSerialPortManager)

Name
GetRuntimeData

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetRuntimeData ( iKey : string ) : string

Parameters
Parameter Description
iKey : STRING

mAirListScript
Class Tree
Index
Previous (GetRootFolder)
Next (GetSerialPortManager)


Previous (GetRuntimeData)
Next (GetSupportedFileExtensions)

Name
GetSerialPortManager

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSerialPortManager : ISerialPortManager

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRuntimeData)
Next (GetSupportedFileExtensions)


Previous (GetSerialPortManager)
Next (GetTimeCorrection)

Name
GetSupportedFileExtensions

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetSupportedFileExtensions : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerialPortManager)
Next (GetTimeCorrection)


Previous (GetSupportedFileExtensions)
Next (IncPFLCount)

Name
GetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
function GetTimeCorrection : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSupportedFileExtensions)
Next (IncPFLCount)


Previous (GetTimeCorrection)
Next (Initialize)

Name
IncPFLCount

Parent
IInstanceData

Visibility
PUBLIC

Source code
function IncPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeCorrection)
Next (Initialize)


Previous (IncPFLCount)
Next (SetDefaultFadeDuration)

Name
Initialize

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IncPFLCount)
Next (SetDefaultFadeDuration)


Previous (Initialize)
Next (SetDescription)

Name
SetDefaultFadeDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetDefaultFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (Initialize)
Next (SetDescription)


Previous (SetDefaultFadeDuration)
Next (SetEndMonDuration)

Name
SetDescription

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetDescription ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDefaultFadeDuration)
Next (SetEndMonDuration)


Previous (SetDescription)
Next (SetName)

Name
SetEndMonDuration

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetEndMonDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetDescription)
Next (SetName)


Previous (SetEndMonDuration)
Next (SetOnAir)

Name
SetName

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetName ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetEndMonDuration)
Next (SetOnAir)


Previous (SetName)
Next (SetOptions)

Name
SetOnAir

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetOnAir ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetName)
Next (SetOptions)


Previous (SetOnAir)
Next (SetPlayoutMode)

Name
SetOptions

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TGlobalOptions )

Parameters
Parameter Description
iValue : TGlobalOptions

mAirListScript
Class Tree
Index
Previous (SetOnAir)
Next (SetPlayoutMode)


Previous (SetOptions)
Next (SetRuntimeData)

Name
SetPlayoutMode

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetPlayoutMode ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetRuntimeData)


Previous (SetPlayoutMode)
Next (SetTimeCorrection)

Name
SetRuntimeData

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetRuntimeData ( iKey : string ; iValue : string )

Parameters
Parameter Description
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPlayoutMode)
Next (SetTimeCorrection)


Previous (SetRuntimeData)
Next (Shutdown)

Name
SetTimeCorrection

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure SetTimeCorrection ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetRuntimeData)
Next (Shutdown)


Previous (SetTimeCorrection)
Next (Startup)

Name
Shutdown

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Shutdown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetTimeCorrection)
Next (Startup)


Previous (Shutdown)
Next

Name
Startup

Parent
IInstanceData

Visibility
PUBLIC

Source code
procedure Startup ( iRunMode : TRunMode )

Parameters
Parameter Description
iRunMode : TRunMode

mAirListScript
Class Tree
Index
Previous (Shutdown)
Next


Previous (IInstanceData)
Next (ILicenseManager)

Name
ILevelInfo

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
GetLevelChannelCount (+)
GetLevels (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IInstanceData)
Next (ILicenseManager)


Previous
Next (GetLevels)

Name
GetLevelChannelCount

Parent
ILevelInfo

Visibility
PUBLIC

Source code
function GetLevelChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLevels)


Previous (GetLevelChannelCount)
Next

Name
GetLevels

Parent
ILevelInfo

Visibility
PUBLIC

Source code
function GetLevels ( var oLevels : TLevelArray ) : boolean

Parameters
Parameter Description
oLevels : TLevelArray

mAirListScript
Class Tree
Index
Previous (GetLevelChannelCount)
Next


Previous (ILevelInfo)
Next (ILogEntry)

Name
ILicenseManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
CheckHardware (+)
CheckModule (+)
GetEdition (+)
GetExpiresDateTime (+)
GetHardwareID (+)
GetName (+)
GetSerial (+)
GetTimeLimit (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILevelInfo)
Next (ILogEntry)


Previous
Next (CheckModule)

Name
CheckHardware

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function CheckHardware : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CheckModule)


Previous (CheckHardware)
Next (GetEdition)

Name
CheckModule

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function CheckModule ( iName : string ) : boolean

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (CheckHardware)
Next (GetEdition)


Previous (CheckModule)
Next (GetExpiresDateTime)

Name
GetEdition

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetEdition : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckModule)
Next (GetExpiresDateTime)


Previous (GetEdition)
Next (GetHardwareID)

Name
GetExpiresDateTime

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetExpiresDateTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEdition)
Next (GetHardwareID)


Previous (GetExpiresDateTime)
Next (GetName)

Name
GetHardwareID

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetHardwareID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpiresDateTime)
Next (GetName)


Previous (GetHardwareID)
Next (GetSerial)

Name
GetName

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHardwareID)
Next (GetSerial)


Previous (GetName)
Next (GetTimeLimit)

Name
GetSerial

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetSerial : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetTimeLimit)


Previous (GetSerial)
Next

Name
GetTimeLimit

Parent
ILicenseManager

Visibility
PUBLIC

Source code
function GetTimeLimit : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILicenseManager)
Next (ILogEntryList)

Name
ILogEntry

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCategory (+)
GetMessage (+)
GetSender (+)
GetSerial (+)
GetTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILicenseManager)
Next (ILogEntryList)


Previous
Next (GetMessage)

Name
GetCategory

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetCategory : TLogCategory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetMessage)


Previous (GetCategory)
Next (GetSender)

Name
GetMessage

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCategory)
Next (GetSender)


Previous (GetMessage)
Next (GetSerial)

Name
GetSender

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSender : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessage)
Next (GetSerial)


Previous (GetSender)
Next (GetTime)

Name
GetSerial

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetSerial : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSender)
Next (GetTime)


Previous (GetSerial)
Next

Name
GetTime

Parent
ILogEntry

Visibility
PUBLIC

Source code
function GetTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSerial)
Next


Previous (ILogEntry)
Next (ILogger)

Name
ILogEntryList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
GetEntryCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntry)
Next (ILogger)


Previous
Next (GetItem)

Name
GetEntryCount

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetEntryCount ( iCategory : TLogCategory ) : integer

Parameters
Parameter Description
iCategory : TLogCategory

mAirListScript
Class Tree
Index
Previous
Next (GetItem)


Previous (GetEntryCount)
Next

Name
GetItem

Parent
ILogEntryList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogEntry

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEntryCount)
Next


Previous (ILogEntryList)
Next (ILogInterface)

Name
ILogger

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetEntries (+)
GetLogInterfaces (+)
LoadConfig (+)
StartLog (+)
StopLog (+)
SystemLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogEntryList)
Next (ILogInterface)


Previous
Next (GetLogInterfaces)

Name
GetEntries

Parent
ILogger

Visibility
PUBLIC

Source code
function GetEntries : ILogEntryList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLogInterfaces)


Previous (GetEntries)
Next (LoadConfig)

Name
GetLogInterfaces

Parent
ILogger

Visibility
PUBLIC

Source code
function GetLogInterfaces : ILogInterfaceList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEntries)
Next (LoadConfig)


Previous (GetLogInterfaces)
Next (StartLog)

Name
LoadConfig

Parent
ILogger

Visibility
PUBLIC

Source code
procedure LoadConfig

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLogInterfaces)
Next (StartLog)


Previous (LoadConfig)
Next (StopLog)

Name
StartLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING

mAirListScript
Class Tree
Index
Previous (LoadConfig)
Next (StopLog)


Previous (StartLog)
Next (SystemLog)

Name
StopLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (StartLog)
Next (SystemLog)


Previous (StopLog)
Next

Name
SystemLog

Parent
ILogger

Visibility
PUBLIC

Source code
procedure SystemLog ( iCategory : TLogCategory ; iMessage : string )

Parameters
Parameter Description
iCategory : TLogCategory
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (StopLog)
Next


Previous (ILogger)
Next (ILogInterfaceList)

Name
ILogInterface

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Members
Methods
Method Description
GetIncludeItemTypes (+)
GetRegions (+)
SetIncludeItemTypes (+)
SetRegions (+)
StartLog (+)
StopLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogger)
Next (ILogInterfaceList)


Previous
Next (GetRegions)

Name
GetIncludeItemTypes

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetIncludeItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetRegions)


Previous (GetIncludeItemTypes)
Next (SetIncludeItemTypes)

Name
GetRegions

Parent
ILogInterface

Visibility
PUBLIC

Source code
function GetRegions : TRegions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIncludeItemTypes)
Next (SetIncludeItemTypes)


Previous (GetRegions)
Next (SetRegions)

Name
SetIncludeItemTypes

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SetIncludeItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter Description
iValue : TPlaylistItemTypes

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (SetRegions)


Previous (SetIncludeItemTypes)
Next (StartLog)

Name
SetRegions

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure SetRegions ( iValue : TRegions )

Parameters
Parameter Description
iValue : TRegions

mAirListScript
Class Tree
Index
Previous (SetIncludeItemTypes)
Next (StartLog)


Previous (SetRegions)
Next (StopLog)

Name
StartLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING

mAirListScript
Class Tree
Index
Previous (SetRegions)
Next (StopLog)


Previous (StartLog)
Next

Name
StopLog

Parent
ILogInterface

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (StartLog)
Next


Previous (ILogInterface)
Next (ImAirListInstance)

Name
ILogInterfaceList

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
StartLog (+)
StopLog (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterface)
Next (ImAirListInstance)


Previous
Next (StartLog)

Name
GetItem

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : ILogInterface

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (StartLog)


Previous (GetItem)
Next (StopLog)

Name
StartLog

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
procedure StartLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (StopLog)


Previous (StartLog)
Next

Name
StopLog

Parent
ILogInterfaceList

Visibility
PUBLIC

Source code
procedure StopLog ( iItem : IPlaylistItem ; iRegion : TRegion ; iUniqueID : string ; iDuration : TTimeValue )

Parameters
Parameter Description
iItem : IPlaylistItem
iRegion : TRegion
iUniqueID : STRING
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous (StartLog)
Next


Previous (ILogInterfaceList)
Next (IMarkerCueDataitem)

Name
ImAirListInstance

Parent
mAirListInterfaces

Class Hierarchy
IInstanceData

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ILogInterfaceList)
Next (IMarkerCueDataitem)


Previous (ImAirListInstance)
Next (IMessageDispatcher)

Name
IMarkerCueDataitem

Parent
mAirListInterfaces

Class Hierarchy
IBaseMarkerCueDataItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ImAirListInstance)
Next (IMessageDispatcher)


Previous (IMarkerCueDataitem)
Next (IMetaCueDataItem)

Name
IMessageDispatcher

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BroadcastMessage (+)
CreateQueue (+)
DeleteQueue (+)
PostMessage (+)
PostMessageDelayed (+)
SetCatchAll (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMarkerCueDataitem)
Next (IMetaCueDataItem)


Previous
Next (CreateQueue)

Name
BroadcastMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure BroadcastMessage ( iMessage : IBaseMessage )

Parameters
Parameter Description
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous
Next (CreateQueue)


Previous (BroadcastMessage)
Next (DeleteQueue)

Name
CreateQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
function CreateQueue ( iProc : TMessageProc ; iDirect : boolean ) : TMessageHandle

Parameters
Parameter Description
iProc : TMessageProc
iDirect : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BroadcastMessage)
Next (DeleteQueue)


Previous (CreateQueue)
Next (PostMessage)

Name
DeleteQueue

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure DeleteQueue ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous (CreateQueue)
Next (PostMessage)


Previous (DeleteQueue)
Next (PostMessageDelayed)

Name
PostMessage

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessage ( iHandle : TMessageHandle ; iMessage : IBaseMessage )

Parameters
Parameter Description
iHandle : TMessageHandle
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (DeleteQueue)
Next (PostMessageDelayed)


Previous (PostMessage)
Next (SetCatchAll)

Name
PostMessageDelayed

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure PostMessageDelayed ( iHandle : TMessageHandle ; iDelay : integer ; iMessage : IBaseMessage )

Parameters
Parameter Description
iHandle : TMessageHandle
iDelay : INTEGER
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (PostMessage)
Next (SetCatchAll)


Previous (PostMessageDelayed)
Next

Name
SetCatchAll

Parent
IMessageDispatcher

Visibility
PUBLIC

Source code
procedure SetCatchAll ( iHandle : TMessageHandle ; iValue : boolean )

Parameters
Parameter Description
iHandle : TMessageHandle
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (PostMessageDelayed)
Next


Previous (IMessageDispatcher)
Next (IMixdownEngine)

Name
IMetaCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMessageDispatcher)
Next (IMixdownEngine)


Previous
Next

Name
GetItem

Parent
IMetaCueDataItem

Visibility
PUBLIC

Source code
function GetItem : ICueDataItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IMetaCueDataItem)
Next (IMixdownEngine2)

Name
IMixdownEngine

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
GetPosition (+)
PrepareMixdown (+)
StartMixdown (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMetaCueDataItem)
Next (IMixdownEngine2)


Previous
Next (PrepareMixdown)

Name
GetPosition

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (PrepareMixdown)


Previous (GetPosition)
Next (StartMixdown)

Name
PrepareMixdown

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
procedure PrepareMixdown ( iItems : IMultiPlaylist ; iFilename , iEncoder : string )

Parameters
Parameter Description
iItems : IMultiPlaylist
iFilename : STRING
iEncoder : STRING

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (StartMixdown)


Previous (PrepareMixdown)
Next

Name
StartMixdown

Parent
IMixdownEngine

Visibility
PUBLIC

Source code
procedure StartMixdown

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (PrepareMixdown)
Next


Previous (IMixdownEngine)
Next (IMixer)

Name
IMixdownEngine2

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixdownEngine)
Next (IMixer)


Previous (IMixdownEngine2)
Next (IModule)

Name
IMixer

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDestinationCount (+)
GetProductName (+)
GetVolume (+)
IsMuted (+)
Mute (+)
SetVolume (+)
Unmute (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixdownEngine2)
Next (IModule)


Previous
Next (GetProductName)

Name
GetDestinationCount

Parent
IMixer

Visibility
PUBLIC

Source code
function GetDestinationCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetProductName)


Previous (GetDestinationCount)
Next (GetVolume)

Name
GetProductName

Parent
IMixer

Visibility
PUBLIC

Source code
function GetProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDestinationCount)
Next (GetVolume)


Previous (GetProductName)
Next (IsMuted)

Name
GetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure GetVolume ( iDestination , iConnection : integer ; var oLeft , oRight : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER
oLeft : INTEGER
oRight : INTEGER

mAirListScript
Class Tree
Index
Previous (GetProductName)
Next (IsMuted)


Previous (GetVolume)
Next (Mute)

Name
IsMuted

Parent
IMixer

Visibility
PUBLIC

Source code
function IsMuted ( iDestination , iConnection : integer ) : boolean

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (Mute)


Previous (IsMuted)
Next (SetVolume)

Name
Mute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Mute ( iDestination , iConnection : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (IsMuted)
Next (SetVolume)


Previous (Mute)
Next (Unmute)

Name
SetVolume

Parent
IMixer

Visibility
PUBLIC

Source code
procedure SetVolume ( iDestination , iConnection : integer ; iLeft , iRight : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER
iLeft : INTEGER
iRight : INTEGER

mAirListScript
Class Tree
Index
Previous (Mute)
Next (Unmute)


Previous (SetVolume)
Next

Name
Unmute

Parent
IMixer

Visibility
PUBLIC

Source code
procedure Unmute ( iDestination , iConnection : integer )

Parameters
Parameter Description
iDestination : INTEGER
iConnection : INTEGER

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next


Previous (IMixer)
Next (IModuleList)

Name
IModule

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CheckLicense (+)
Finalize (+)
GetAuthor (+)
GetCommandList (+)
GetDescription (+)
GetID (+)
GetVersion (+)
Initialize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMixer)
Next (IModuleList)


Previous
Next (Finalize)

Name
CheckLicense

Parent
IModule

Visibility
PUBLIC

Source code
function CheckLicense ( iLicenseManager : ILicenseManager ) : boolean

Parameters
Parameter Description
iLicenseManager : ILicenseManager

mAirListScript
Class Tree
Index
Previous
Next (Finalize)


Previous (CheckLicense)
Next (GetAuthor)

Name
Finalize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Finalize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckLicense)
Next (GetAuthor)


Previous (Finalize)
Next (GetCommandList)

Name
GetAuthor

Parent
IModule

Visibility
PUBLIC

Source code
function GetAuthor : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Finalize)
Next (GetCommandList)


Previous (GetAuthor)
Next (GetDescription)

Name
GetCommandList

Parent
IModule

Visibility
PUBLIC

Source code
function GetCommandList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAuthor)
Next (GetDescription)


Previous (GetCommandList)
Next (GetID)

Name
GetDescription

Parent
IModule

Visibility
PUBLIC

Source code
function GetDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandList)
Next (GetID)


Previous (GetDescription)
Next (GetVersion)

Name
GetID

Parent
IModule

Visibility
PUBLIC

Source code
function GetID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDescription)
Next (GetVersion)


Previous (GetID)
Next (Initialize)

Name
GetVersion

Parent
IModule

Visibility
PUBLIC

Source code
function GetVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetID)
Next (Initialize)


Previous (GetVersion)
Next

Name
Initialize

Parent
IModule

Visibility
PUBLIC

Source code
procedure Initialize

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVersion)
Next


Previous (IModule)
Next (IMultiAudioSource)

Name
IModuleList

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModule)
Next (IMultiAudioSource)


Previous
Next (GetCount)

Name
ADD

Parent
IModuleList

Visibility
PUBLIC

Source code
procedure Add ( iModule : IModule )

Parameters
Parameter Description
iModule : IModule

mAirListScript
Class Tree
Index
Previous
Next (GetCount)


Previous (ADD)
Next (GetItem)

Name
GetCount

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ADD)
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
IModuleList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IModule

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous (IModuleList)
Next (IMultiInstanceModule)

Name
IMultiAudioSource

Parent
mAirListInterfaces

Class Hierarchy
IAudioSource

Visibility
PUBLIC

Members
Methods
Method Description
FindNextOffset (+)
FindPreviousOffset (+)
GetItemOffset (+)
GetMinCueIn (+)
SyncPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IModuleList)
Next (IMultiInstanceModule)


Previous
Next (FindPreviousOffset)

Name
FindNextOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function FindNextOffset ( iFrom , iBefore : TTimeValue ) : TTimeValue

Parameters
Parameter Description
iFrom : TTimeValue
iBefore : TTimeValue

mAirListScript
Class Tree
Index
Previous
Next (FindPreviousOffset)


Previous (FindNextOffset)
Next (GetItemOffset)

Name
FindPreviousOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function FindPreviousOffset ( iFrom , iBefore : TTimeValue ) : TTimeValue

Parameters
Parameter Description
iFrom : TTimeValue
iBefore : TTimeValue

mAirListScript
Class Tree
Index
Previous (FindNextOffset)
Next (GetItemOffset)


Previous (FindPreviousOffset)
Next (GetMinCueIn)

Name
GetItemOffset

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function GetItemOffset ( iIndex : integer ) : TTimeValue

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (FindPreviousOffset)
Next (GetMinCueIn)


Previous (GetItemOffset)
Next (SyncPlaylist)

Name
GetMinCueIn

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
function GetMinCueIn : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemOffset)
Next (SyncPlaylist)


Previous (GetMinCueIn)
Next

Name
SyncPlaylist

Parent
IMultiAudioSource

Visibility
PUBLIC

Source code
procedure SyncPlaylist ( iPlaylist : IMultiPlaylist )

Parameters
Parameter Description
iPlaylist : IMultiPlaylist

mAirListScript
Class Tree
Index
Previous (GetMinCueIn)
Next


Previous (IMultiAudioSource)
Next (IMultiPlaylist)

Name
IMultiInstanceModule

Parent
mAirListInterfaces

Class Hierarchy
IModule

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiAudioSource)
Next (IMultiPlaylist)


Previous (IMultiInstanceModule)
Next (IMultiPlaylistItemMetadata)

Name
IMultiPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
AddItem (+)
AddPlaylist (+)
CreateCueSheet (+)
GetDuration (+)
GetItem (+)
GetMetadata (+)
GetRegions (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiInstanceModule)
Next (IMultiPlaylistItemMetadata)


Previous
Next (AddPlaylist)

Name
AddItem

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
procedure AddItem ( iItem : IPlaylistItem ; iOffset : TTimeValue ; iExpand : boolean ; iRegion : TRegion = 0 ; iLevel : integer = 0 )

Parameters
Parameter Description
iItem : IPlaylistItem
iOffset : TTimeValue
iExpand : BOOLEAN
iRegion : TRegion
iLevel : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (AddPlaylist)


Previous (AddItem)
Next (CreateCueSheet)

Name
AddPlaylist

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
procedure AddPlaylist ( iList : IPlaylist ; iOffset : TTimeValue ; iExpand : boolean ; iRegion : TRegion = 0 ; iLevel : integer = 0 ; iExtraOffset : TTimeValue = 0 )

Parameters
Parameter Description
iList : IPlaylist
iOffset : TTimeValue
iExpand : BOOLEAN
iRegion : TRegion
iLevel : INTEGER
iExtraOffset : TTimeValue

mAirListScript
Class Tree
Index
Previous (AddItem)
Next (CreateCueSheet)


Previous (AddPlaylist)
Next (GetDuration)

Name
CreateCueSheet

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function CreateCueSheet ( iFilename : string ; iMinCueIn : TTimeValue ; iRegions : TRegions ; iItemTypes : TPlaylistItemTypes ) : IStrings

Parameters
Parameter Description
iFilename : STRING
iMinCueIn : TTimeValue
iRegions : TRegions
iItemTypes : TPlaylistItemTypes

mAirListScript
Class Tree
Index
Previous (AddPlaylist)
Next (GetDuration)


Previous (CreateCueSheet)
Next (GetItem)

Name
GetDuration

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateCueSheet)
Next (GetItem)


Previous (GetDuration)
Next (GetMetadata)

Name
GetItem

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetMetadata)


Previous (GetItem)
Next (GetRegions)

Name
GetMetadata

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetMetadata ( iIndex : integer ) : IMultiPlaylistItemMetadata

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetRegions)


Previous (GetMetadata)
Next

Name
GetRegions

Parent
IMultiPlaylist

Visibility
PUBLIC

Source code
function GetRegions : TRegions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next


Previous (IMultiPlaylist)
Next (IMutex)

Name
IMultiPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetExpanded (+)
GetLevel (+)
GetOffset (+)
GetRegion (+)
SetExpanded (+)
SetLevel (+)
SetOffset (+)
SetRegion (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiPlaylist)
Next (IMutex)


Previous
Next (GetLevel)

Name
GetExpanded

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetExpanded : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetLevel)


Previous (GetExpanded)
Next (GetOffset)

Name
GetLevel

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetLevel : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExpanded)
Next (GetOffset)


Previous (GetLevel)
Next (GetRegion)

Name
GetOffset

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetOffset : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLevel)
Next (GetRegion)


Previous (GetOffset)
Next (SetExpanded)

Name
GetRegion

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetRegion : TRegion

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOffset)
Next (SetExpanded)


Previous (GetRegion)
Next (SetLevel)

Name
SetExpanded

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetExpanded ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetRegion)
Next (SetLevel)


Previous (SetExpanded)
Next (SetOffset)

Name
SetLevel

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetLevel ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetExpanded)
Next (SetOffset)


Previous (SetLevel)
Next (SetRegion)

Name
SetOffset

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetOffset ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetLevel)
Next (SetRegion)


Previous (SetOffset)
Next

Name
SetRegion

Parent
IMultiPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetRegion ( iValue : TRegion )

Parameters
Parameter Description
iValue : TRegion

mAirListScript
Class Tree
Index
Previous (SetOffset)
Next


Previous (IMultiPlaylistItemMetadata)
Next (INoAudioDevice)

Name
IMutex

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginRead (+)
BeginWrite (+)
EndRead (+)
EndWrite (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMultiPlaylistItemMetadata)
Next (INoAudioDevice)


Previous
Next (BeginWrite)

Name
BeginRead

Parent
IMutex

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeginWrite)


Previous (BeginRead)
Next (EndRead)

Name
BeginWrite

Parent
IMutex

Visibility
PUBLIC

Source code
function BeginWrite : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (EndRead)


Previous (BeginWrite)
Next (EndWrite)

Name
EndRead

Parent
IMutex

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginWrite)
Next (EndWrite)


Previous (EndRead)
Next

Name
EndWrite

Parent
IMutex

Visibility
PUBLIC

Source code
procedure EndWrite

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next


Previous (IMutex)
Next (INotifiedMessageReceiver)

Name
INoAudioDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMutex)
Next (INotifiedMessageReceiver)


Previous (INoAudioDevice)
Next (INotifyItemStarted)

Name
INotifiedMessageReceiver

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
BeginProcessMessages (+)
EndProcessMessages (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INoAudioDevice)
Next (INotifyItemStarted)


Previous
Next (EndProcessMessages)

Name
BeginProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure BeginProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndProcessMessages)


Previous (BeginProcessMessages)
Next

Name
EndProcessMessages

Parent
INotifiedMessageReceiver

Visibility
PUBLIC

Source code
procedure EndProcessMessages

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginProcessMessages)
Next


Previous (INotifiedMessageReceiver)
Next (IObservable)

Name
INotifyItemStarted

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ItemStarted (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifiedMessageReceiver)
Next (IObservable)


Previous
Next

Name
ItemStarted

Parent
INotifyItemStarted

Visibility
PUBLIC

Source code
procedure ItemStarted ( iSource : IAudioSource )

Parameters
Parameter Description
iSource : IAudioSource

mAirListScript
Class Tree
Index
Previous
Next


Previous (INotifyItemStarted)
Next (IObservableList)

Name
IObservable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddObserver (+)
GetObjectID (+)
RemoveObserver (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (INotifyItemStarted)
Next (IObservableList)


Previous
Next (GetObjectID)

Name
AddObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure AddObserver ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous
Next (GetObjectID)


Previous (AddObserver)
Next (RemoveObserver)

Name
GetObjectID

Parent
IObservable

Visibility
PUBLIC

Source code
function GetObjectID : TObjectID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddObserver)
Next (RemoveObserver)


Previous (GetObjectID)
Next

Name
RemoveObserver

Parent
IObservable

Visibility
PUBLIC

Source code
procedure RemoveObserver ( iHandle : TMessageHandle )

Parameters
Parameter Description
iHandle : TMessageHandle

mAirListScript
Class Tree
Index
Previous (GetObjectID)
Next


Previous (IObservable)
Next (IPeakAnalyzer)

Name
IObservableList

Parent
mAirListInterfaces

Class Hierarchy
IBaseList

Visibility
PUBLIC

Members
Methods
Method Description
FindByID (+)
FindByMetadataID (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IObservable)
Next (IPeakAnalyzer)


Previous
Next (FindByMetadataID)

Name
FindByID

Parent
IObservableList

Visibility
PUBLIC

Source code
function FindByID ( iID : TObjectID ) : IObservable

Parameters
Parameter Description
iID : TObjectID

mAirListScript
Class Tree
Index
Previous
Next (FindByMetadataID)


Previous (FindByID)
Next (IndexOfID)

Name
FindByMetadataID

Parent
IObservableList

Visibility
PUBLIC

Source code
function FindByMetadataID ( iID : TObjectID ) : IObservable

Parameters
Parameter Description
iID : TObjectID

mAirListScript
Class Tree
Index
Previous (FindByID)
Next (IndexOfID)


Previous (FindByMetadataID)
Next

Name
IndexOfID

Parent
IObservableList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : TObjectID ) : integer

Parameters
Parameter Description
iID : TObjectID

mAirListScript
Class Tree
Index
Previous (FindByMetadataID)
Next


Previous (IObservableList)
Next (IPersistent)

Name
IPeakAnalyzer

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
ClearCache (+)
GetData (+)
GetState (+)
Initialize (+)
SetCacheData (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IObservableList)
Next (IPersistent)


Previous
Next (GetData)

Name
ClearCache

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure ClearCache

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetData)


Previous (ClearCache)
Next (GetState)

Name
GetData

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
function GetData ( iOffset : TTimeValue ; iResolution : Extended ; var oData : TSingleArray ) : boolean

Parameters
Parameter Description
iOffset : TTimeValue
iResolution : EXTENDED
oData : TSingleArray

mAirListScript
Class Tree
Index
Previous (ClearCache)
Next (GetState)


Previous (GetData)
Next (Initialize)

Name
GetState

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
function GetState : TPeakAnalyzerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetData)
Next (Initialize)


Previous (GetState)
Next (SetCacheData)

Name
Initialize

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure Initialize ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetCacheData)


Previous (Initialize)
Next

Name
SetCacheData

Parent
IPeakAnalyzer

Visibility
PUBLIC

Source code
procedure SetCacheData ( iLevel , iIndex : integer ; iData : TPeakData )

Parameters
Parameter Description
iLevel : INTEGER
iIndex : INTEGER
iData : TPeakData

mAirListScript
Class Tree
Index
Previous (Initialize)
Next


Previous (IPeakAnalyzer)
Next (IPersistentArray)

Name
IPersistent

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Load (+)
Save (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPeakAnalyzer)
Next (IPersistentArray)


Previous
Next (Save)

Name
Load

Parent
IPersistent

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter Description
iSource : IPersistentStorage

mAirListScript
Class Tree
Index
Previous
Next (Save)


Previous (Load)
Next

Name
Save

Parent
IPersistent

Visibility
PUBLIC

Source code
function Save : IPersistentStorage

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Load)
Next


Previous (IPersistent)
Next (IPersistentBoolean)

Name
IPersistentArray

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddBoolean (+)
AddInteger (+)
AddNumber (+)
AddObject (+)
AddString (+)
GetCount (+)
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistent)
Next (IPersistentBoolean)


Previous
Next (AddBoolean)

Name
ADD

Parent
IPersistentArray

Visibility
PUBLIC

Source code
procedure Add ( iItem : IPersistentStorage )

Parameters
Parameter Description
iItem : IPersistentStorage

mAirListScript
Class Tree
Index
Previous
Next (AddBoolean)


Previous (ADD)
Next (AddInteger)

Name
AddBoolean

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddBoolean ( iValue : boolean ) : IPersistentBoolean

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (ADD)
Next (AddInteger)


Previous (AddBoolean)
Next (AddNumber)

Name
AddInteger

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddInteger ( iValue : integer ) : IPersistentInteger

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (AddBoolean)
Next (AddNumber)


Previous (AddInteger)
Next (AddObject)

Name
AddNumber

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddNumber ( iValue : double ) : IPersistentNumber

Parameters
Parameter Description
iValue : DOUBLE

mAirListScript
Class Tree
Index
Previous (AddInteger)
Next (AddObject)


Previous (AddNumber)
Next (AddString)

Name
AddObject

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddNumber)
Next (AddString)


Previous (AddObject)
Next (GetCount)

Name
AddString

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function AddString ( iValue : string ) : IPersistentString

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (AddObject)
Next (GetCount)


Previous (AddString)
Next (GetItem)

Name
GetCount

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddString)
Next (GetItem)


Previous (GetCount)
Next

Name
GetItem

Parent
IPersistentArray

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IPersistentStorage

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next


Previous (IPersistentArray)
Next (IPersistentDateTime)

Name
IPersistentBoolean

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentArray)
Next (IPersistentDateTime)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentBoolean

Visibility
PUBLIC

Source code
function GetValue : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentBoolean

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentBoolean)
Next (IPersistentInteger)

Name
IPersistentDateTime

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentBoolean)
Next (IPersistentInteger)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentDateTime

Visibility
PUBLIC

Source code
function GetValue : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentDateTime

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentDateTime)
Next (IPersistentList)

Name
IPersistentInteger

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentDateTime)
Next (IPersistentList)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentInteger

Visibility
PUBLIC

Source code
function GetValue : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentInteger

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : int64 )

Parameters
Parameter Description
iValue : INT64

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentInteger)
Next (IPersistentListItem)

Name
IPersistentList

Parent
mAirListInterfaces

Class Hierarchy
IFactoryObjectList

Visibility
PUBLIC

Members
Methods
Method Description
Clone (+)
Copy (+)
GetClipboardFormatName (+)
GetGUID (+)
GetPersistentListItem (+)
GetPersistentListItemMetadata (+)
GetXMLNodeName (+)
GetXMLUTF16 (+)
GetXMLUTF8 (+)
Load (+)
LoadFromFile (+)
LoadFromXML (+)
Save (+)
SaveAsXML (+)
SaveAsXMLRenamed (+)
SaveEx (+)
SaveToFile (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentInteger)
Next (IPersistentListItem)


Previous
Next (Copy)

Name
Clone

Parent
IPersistentList

Visibility
PUBLIC

Source code
function Clone ( iWithMetadata : boolean = true ) : IPersistentList

Parameters
Parameter Description
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (Copy)


Previous (Clone)
Next (GetClipboardFormatName)

Name
Copy

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure Copy ( iValue : IPersistentList ; iWithMetadata : boolean = true )

Parameters
Parameter Description
iValue : IPersistentList
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetClipboardFormatName)


Previous (Copy)
Next (GetGUID)

Name
GetClipboardFormatName

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetClipboardFormatName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Copy)
Next (GetGUID)


Previous (GetClipboardFormatName)
Next (GetPersistentListItem)

Name
GetGUID

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetGUID : TGUID

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClipboardFormatName)
Next (GetPersistentListItem)


Previous (GetGUID)
Next (GetPersistentListItemMetadata)

Name
GetPersistentListItem

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetPersistentListItem ( iIndex : Integer ) : IPersistentListItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetGUID)
Next (GetPersistentListItemMetadata)


Previous (GetPersistentListItem)
Next (GetXMLNodeName)

Name
GetPersistentListItemMetadata

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetPersistentListItemMetadata ( iIndex : integer ) : IPersistentListItemMetadata

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPersistentListItem)
Next (GetXMLNodeName)


Previous (GetPersistentListItemMetadata)
Next (GetXMLUTF16)

Name
GetXMLNodeName

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetXMLNodeName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPersistentListItemMetadata)
Next (GetXMLUTF16)


Previous (GetXMLNodeName)
Next (GetXMLUTF8)

Name
GetXMLUTF16

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetXMLUTF16 ( iOutputFormat : TOutputFormat ; iWithMetadata : boolean = false ) : WideString

Parameters
Parameter Description
iOutputFormat : TOutputFormat
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetXMLNodeName)
Next (GetXMLUTF8)


Previous (GetXMLUTF16)
Next (Load)

Name
GetXMLUTF8

Parent
IPersistentList

Visibility
PUBLIC

Source code
function GetXMLUTF8 ( iOutputFormat : TOutputFormat ; iWithMetadata : boolean = false ) : AnsiString

Parameters
Parameter Description
iOutputFormat : TOutputFormat
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetXMLUTF16)
Next (Load)


Previous (GetXMLUTF8)
Next (LoadFromFile)

Name
Load

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter Description
iSource : IPersistentStorage

mAirListScript
Class Tree
Index
Previous (GetXMLUTF8)
Next (LoadFromFile)


Previous (Load)
Next (LoadFromXML)

Name
LoadFromFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Load)
Next (LoadFromXML)


Previous (LoadFromFile)
Next (Save)

Name
LoadFromXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (Save)


Previous (LoadFromXML)
Next (SaveAsXML)

Name
Save

Parent
IPersistentList

Visibility
PUBLIC

Source code
function Save : IPersistentStorage

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (Save)
Next (SaveAsXMLRenamed)

Name
SaveAsXML

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ; iWithMetadata : boolean = false ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Save)
Next (SaveAsXMLRenamed)


Previous (SaveAsXML)
Next (SaveEx)

Name
SaveAsXMLRenamed

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveAsXMLRenamed ( iDocument : IXMLDocument ; iNodeName : string ; iWithMetadata : boolean = false ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument
iNodeName : STRING
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveAsXML)
Next (SaveEx)


Previous (SaveAsXMLRenamed)
Next (SaveToFile)

Name
SaveEx

Parent
IPersistentList

Visibility
PUBLIC

Source code
function SaveEx ( iWithMetadata : boolean = false ) : IPersistentStorage

Parameters
Parameter Description
iWithMetadata : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SaveAsXMLRenamed)
Next (SaveToFile)


Previous (SaveEx)
Next

Name
SaveToFile

Parent
IPersistentList

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (SaveEx)
Next


Previous (IPersistentList)
Next (IPersistentListItemMetadata)

Name
IPersistentListItem

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
Assign (+)
Clone (+)
GetHash (+)
GetXMLUTF16 (+)
GetXMLUTF8 (+)
Load (+)
LoadFromXML (+)
Save (+)
SaveAsXML (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentList)
Next (IPersistentListItemMetadata)


Previous
Next (Clone)

Name
Assign

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
procedure Assign ( iItem : IPersistentListItem )

Parameters
Parameter Description
iItem : IPersistentListItem

mAirListScript
Class Tree
Index
Previous
Next (Clone)


Previous (Assign)
Next (GetHash)

Name
Clone

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function Clone : IPersistentListItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (GetHash)


Previous (Clone)
Next (GetXMLUTF16)

Name
GetHash

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function GetHash : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetXMLUTF16)


Previous (GetHash)
Next (GetXMLUTF8)

Name
GetXMLUTF16

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function GetXMLUTF16 ( iOutputFormat : TOutputFormat ) : WideString

Parameters
Parameter Description
iOutputFormat : TOutputFormat

mAirListScript
Class Tree
Index
Previous (GetHash)
Next (GetXMLUTF8)


Previous (GetXMLUTF16)
Next (Load)

Name
GetXMLUTF8

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function GetXMLUTF8 ( iOutputFormat : TOutputFormat ) : AnsiString

Parameters
Parameter Description
iOutputFormat : TOutputFormat

mAirListScript
Class Tree
Index
Previous (GetXMLUTF16)
Next (Load)


Previous (GetXMLUTF8)
Next (LoadFromXML)

Name
Load

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentObject )

Parameters
Parameter Description
iSource : IPersistentObject

mAirListScript
Class Tree
Index
Previous (GetXMLUTF8)
Next (LoadFromXML)


Previous (Load)
Next (Save)

Name
LoadFromXML

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
procedure LoadFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (Load)
Next (Save)


Previous (LoadFromXML)
Next (SaveAsXML)

Name
Save

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function Save : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadFromXML)
Next (SaveAsXML)


Previous (Save)
Next

Name
SaveAsXML

Parent
IPersistentListItem

Visibility
PUBLIC

Source code
function SaveAsXML ( iDocument : IXMLDocument ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (Save)
Next


Previous (IPersistentListItem)
Next (IPersistentNull)

Name
IPersistentListItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
GetTag (+)
ReleaseOwner (+)
SetTag (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentListItem)
Next (IPersistentNull)


Previous
Next (ReleaseOwner)

Name
GetTag

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
function GetTag : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ReleaseOwner)


Previous (GetTag)
Next (SetTag)

Name
ReleaseOwner

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
procedure ReleaseOwner

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (SetTag)


Previous (ReleaseOwner)
Next

Name
SetTag

Parent
IPersistentListItemMetadata

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (ReleaseOwner)
Next


Previous (IPersistentListItemMetadata)
Next (IPersistentNumber)

Name
IPersistentNull

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentListItemMetadata)
Next (IPersistentNumber)


Previous (IPersistentNull)
Next (IPersistentObject)

Name
IPersistentNumber

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentNull)
Next (IPersistentObject)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentNumber

Visibility
PUBLIC

Source code
function GetValue : double

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentNumber

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : double )

Parameters
Parameter Description
iValue : DOUBLE

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentNumber)
Next (IPersistentPlaylistItemMetadata)

Name
IPersistentObject

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
CreateArray (+)
CreateObject (+)
FindArray (+)
FindBoolean (+)
FindInteger (+)
FindNumber (+)
FindObject (+)
FindString (+)
FindValue (+)
GetCount (+)
GetName (+)
GetValue (+)
GetValueFromIndex (+)
Merge (+)
SetArray (+)
SetBoolean (+)
SetInteger (+)
SetNull (+)
SetNumber (+)
SetObject (+)
SetString (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentNumber)
Next (IPersistentPlaylistItemMetadata)


Previous
Next (CreateArray)

Name
ADD

Parent
IPersistentObject

Visibility
PUBLIC

Source code
procedure Add ( iName : string ; iItem : IPersistentStorage )

Parameters
Parameter Description
iName : STRING
iItem : IPersistentStorage

mAirListScript
Class Tree
Index
Previous
Next (CreateArray)


Previous (ADD)
Next (CreateObject)

Name
CreateArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function CreateArray ( iName : string ) : IPersistentArray

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (ADD)
Next (CreateObject)


Previous (CreateArray)
Next (FindArray)

Name
CreateObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function CreateObject ( iName : string ) : IPersistentObject

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (CreateArray)
Next (FindArray)


Previous (CreateObject)
Next (FindBoolean)

Name
FindArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindArray ( iName : string ; out oResult : IPersistentArray ) : boolean

Parameters
Parameter Description
iName : STRING
oResult : IPersistentArray

mAirListScript
Class Tree
Index
Previous (CreateObject)
Next (FindBoolean)


Previous (FindArray)
Next (FindInteger)

Name
FindBoolean

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindBoolean ( iName : string ; iDefault : boolean = false ) : boolean

Parameters
Parameter Description
iName : STRING
iDefault : BOOLEAN

mAirListScript
Class Tree
Index
Previous (FindArray)
Next (FindInteger)


Previous (FindBoolean)
Next (FindNumber)

Name
FindInteger

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindInteger ( iName : string ; iDefault : int64 = 0 ) : int64

Parameters
Parameter Description
iName : STRING
iDefault : INT64

mAirListScript
Class Tree
Index
Previous (FindBoolean)
Next (FindNumber)


Previous (FindInteger)
Next (FindObject)

Name
FindNumber

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindNumber ( iName : string ; iDefault : double = 0 ) : double

Parameters
Parameter Description
iName : STRING
iDefault : DOUBLE

mAirListScript
Class Tree
Index
Previous (FindInteger)
Next (FindObject)


Previous (FindNumber)
Next (FindString)

Name
FindObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindObject ( iName : string ; out oResult : IPersistentObject ) : boolean

Parameters
Parameter Description
iName : STRING
oResult : IPersistentObject

mAirListScript
Class Tree
Index
Previous (FindNumber)
Next (FindString)


Previous (FindObject)
Next (FindValue)

Name
FindString

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindString ( iName : string ; iDefault : string = '' ) : string

Parameters
Parameter Description
iName : STRING
iDefault : STRING

mAirListScript
Class Tree
Index
Previous (FindObject)
Next (FindValue)


Previous (FindString)
Next (GetCount)

Name
FindValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function FindValue ( iName : string ) : IPersistentStorage

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (FindString)
Next (GetCount)


Previous (FindValue)
Next (GetName)

Name
GetCount

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindValue)
Next (GetName)


Previous (GetCount)
Next (GetValue)

Name
GetName

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetName ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetValue)


Previous (GetName)
Next (GetValueFromIndex)

Name
GetValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetValue ( iName : string ) : IPersistentStorage

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetValueFromIndex)


Previous (GetValue)
Next (Merge)

Name
GetValueFromIndex

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function GetValueFromIndex ( iIndex : integer ) : IPersistentStorage

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (Merge)


Previous (GetValueFromIndex)
Next (SetArray)

Name
Merge

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function Merge ( iValue : IPersistentObject ) : IPersistentObject

Parameters
Parameter Description
iValue : IPersistentObject

mAirListScript
Class Tree
Index
Previous (GetValueFromIndex)
Next (SetArray)


Previous (Merge)
Next (SetBoolean)

Name
SetArray

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetArray ( iName : string ; iValue : IPersistentArray ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : IPersistentArray

mAirListScript
Class Tree
Index
Previous (Merge)
Next (SetBoolean)


Previous (SetArray)
Next (SetInteger)

Name
SetBoolean

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetBoolean ( iName : string ; iValue : boolean ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetArray)
Next (SetInteger)


Previous (SetBoolean)
Next (SetNull)

Name
SetInteger

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetInteger ( iName : string ; iValue : int64 ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : INT64

mAirListScript
Class Tree
Index
Previous (SetBoolean)
Next (SetNull)


Previous (SetInteger)
Next (SetNumber)

Name
SetNull

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetNull ( iName : string ) : IPersistentObject

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous (SetInteger)
Next (SetNumber)


Previous (SetNull)
Next (SetObject)

Name
SetNumber

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetNumber ( iName : string ; iValue : double ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : DOUBLE

mAirListScript
Class Tree
Index
Previous (SetNull)
Next (SetObject)


Previous (SetNumber)
Next (SetString)

Name
SetObject

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetObject ( iName : string ; iValue : IPersistentObject ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : IPersistentObject

mAirListScript
Class Tree
Index
Previous (SetNumber)
Next (SetString)


Previous (SetObject)
Next (SetValue)

Name
SetString

Parent
IPersistentObject

Visibility
PUBLIC

Source code
function SetString ( iName : string ; iValue : string ) : IPersistentObject

Parameters
Parameter Description
iName : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetObject)
Next (SetValue)


Previous (SetString)
Next

Name
SetValue

Parent
IPersistentObject

Visibility
PUBLIC

Source code
procedure SetValue ( iName : string ; iItem : IPersistentStorage )

Parameters
Parameter Description
iName : STRING
iItem : IPersistentStorage

mAirListScript
Class Tree
Index
Previous (SetString)
Next


Previous (IPersistentObject)
Next (IPersistentStorage)

Name
IPersistentPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetFlags (+)
GetState (+)
GetUniqueID (+)
SetFlags (+)
SetState (+)
SetUniqueID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentObject)
Next (IPersistentStorage)


Previous
Next (GetState)

Name
GetFlags

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetFlags : TPlaylistItemFlags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetState)


Previous (GetFlags)
Next (GetUniqueID)

Name
GetState

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetState : TPlaylistItemState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFlags)
Next (GetUniqueID)


Previous (GetState)
Next (SetFlags)

Name
GetUniqueID

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetUniqueID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (SetFlags)


Previous (GetUniqueID)
Next (SetState)

Name
SetFlags

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetFlags ( iValue : TPlaylistItemFlags )

Parameters
Parameter Description
iValue : TPlaylistItemFlags

mAirListScript
Class Tree
Index
Previous (GetUniqueID)
Next (SetState)


Previous (SetFlags)
Next (SetUniqueID)

Name
SetState

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetState ( iValue : TPlaylistItemState )

Parameters
Parameter Description
iValue : TPlaylistItemState

mAirListScript
Class Tree
Index
Previous (SetFlags)
Next (SetUniqueID)


Previous (SetState)
Next

Name
SetUniqueID

Parent
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetUniqueID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetState)
Next


Previous (IPersistentPlaylistItemMetadata)
Next (IPersistentString)

Name
IPersistentStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
AsArray (+)
AsBoolean (+)
AsInteger (+)
AsJSon (+)
AsNull (+)
AsNumber (+)
AsObject (+)
AsString (+)
GetType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentPlaylistItemMetadata)
Next (IPersistentString)


Previous
Next (AsBoolean)

Name
AsArray

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsArray : IPersistentArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AsBoolean)


Previous (AsArray)
Next (AsInteger)

Name
AsBoolean

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsBoolean : IPersistentBoolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsArray)
Next (AsInteger)


Previous (AsBoolean)
Next (AsJSon)

Name
AsInteger

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsInteger : IPersistentInteger

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsBoolean)
Next (AsJSon)


Previous (AsInteger)
Next (AsNull)

Name
AsJSon

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsJSon ( iIndent : boolean = false ; iEscape : boolean = true ) : string

Parameters
Parameter Description
iIndent : BOOLEAN
iEscape : BOOLEAN

mAirListScript
Class Tree
Index
Previous (AsInteger)
Next (AsNull)


Previous (AsJSon)
Next (AsNumber)

Name
AsNull

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsNull : IPersistentNull

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsJSon)
Next (AsNumber)


Previous (AsNull)
Next (AsObject)

Name
AsNumber

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsNumber : IPersistentNumber

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsNull)
Next (AsObject)


Previous (AsNumber)
Next (AsString)

Name
AsObject

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsObject : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsNumber)
Next (AsString)


Previous (AsObject)
Next (GetType)

Name
AsString

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function AsString : IPersistentString

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsObject)
Next (GetType)


Previous (AsString)
Next

Name
GetType

Parent
IPersistentStorage

Visibility
PUBLIC

Source code
function GetType : TPersistentType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AsString)
Next


Previous (IPersistentStorage)
Next (IPlaybackControl)

Name
IPersistentString

Parent
mAirListInterfaces

Class Hierarchy
IPersistentStorage

Visibility
PUBLIC

Members
Methods
Method Description
GetValue (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentStorage)
Next (IPlaybackControl)


Previous
Next (SetValue)

Name
GetValue

Parent
IPersistentString

Visibility
PUBLIC

Source code
function GetValue : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetValue)


Previous (GetValue)
Next

Name
SetValue

Parent
IPersistentString

Visibility
PUBLIC

Source code
procedure SetValue ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetValue)
Next


Previous (IPersistentString)
Next (IPlaybackDevice)

Name
IPlaybackControl

Parent
mAirListInterfaces

Class Hierarchy
IActivePlaylist

Visibility
PUBLIC

Members
Methods
Method | Description
AssistNext (+) | Just like AutomationNext, but for assist mode: Fade out all active
AutomationBreak (+) | Stops automation after the current item.
AutomationJump (+) | Jumps to a specific item.
AutomationJumpSoft (+) | Marks all items before the specified one as played, so that iItem will
GetEventList (+)
GetIndex (+) | Returns the index of this PlaybackControl object within the mAirList system.
GetMaxHistoryCount (+)
GetNextIndex (+) | Determines the index of the item which will be played next. If one of
GetOptions (+)
GetPlayer (+) | Returns a player control object.
GetPlayerCount (+) | Returns the number of players associated with this PlaybackControl object.
GetPlayerOfItem (+) | Returns the player control object in which a specific item is loaded.
GetRemainingDuration (+)
IsPlaying (+)
LoadFromXMLEx (+)
MoveToHistory (+) | Moves an item into history by unloading it from any player and setting
PlayerAutoLoad (+) | Loads a player with the next available, unused item. The player must be empty.
PlayItemDetached (+) | Start playback of an item on the given device, without caring for it thereafter.
RecycleFromHistory (+) | Recycles an item from history.
ReleaseBackgroundSources (+)
SaveAsXMLEx (+)
SetMaxHistoryCount (+)
SetOptions (+)
SetPlayerCount (+) | Sets the number of players players associated with this PlaybackControl object.
SkipTo (+)
SwapPlayers (+) | Swaps the items loaded in the specified players.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPersistentString)
Next (IPlaybackDevice)


Previous
Next (AutomationBreak)

Name
AssistNext

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Just like AutomationNext, but for assist mode: Fade out all active
players and start the next item (which must be loaded already).

Source code
procedure AssistNext

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutomationBreak)


Previous (AssistNext)
Next (AutomationJump)

Name
AutomationBreak

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Stops automation after the current item.

Source code
procedure AutomationBreak

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AssistNext)
Next (AutomationJump)


Previous (AutomationBreak)
Next (AutomationJumpSoft)

Name
AutomationJump

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Jumps to a specific item.

Source code
procedure AutomationJump ( iItem : IPlaylistItem )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item, which must be inside the current playlist.

mAirListScript
Class Tree
Index
Previous (AutomationBreak)
Next (AutomationJumpSoft)


Previous (AutomationJump)
Next (GetEventList)

Name
AutomationJumpSoft

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Marks all items before the specified one as played, so that iItem will
be played next.

Source code
procedure AutomationJumpSoft ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (AutomationJump)
Next (GetEventList)


Previous (AutomationJumpSoft)
Next (GetIndex)

Name
GetEventList

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetEventList : IEventList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AutomationJumpSoft)
Next (GetIndex)


Previous (GetEventList)
Next (GetMaxHistoryCount)

Name
GetIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the index of this PlaybackControl object within the mAirList system.

Source code
function GetIndex : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The index, where 0 is the first PlaybackControl object.

mAirListScript
Class Tree
Index
Previous (GetEventList)
Next (GetMaxHistoryCount)


Previous (GetIndex)
Next (GetNextIndex)

Name
GetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetMaxHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetNextIndex)


Previous (GetMaxHistoryCount)
Next (GetOptions)

Name
GetNextIndex

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Determines the index of the item which will be played next. If one of
the players is marked as IsNext, the result of this function corresponds
to the index of that player's items. If all players are active, the result
will be the index of the "downmost" player plus one. If no players are
loaded, the result will correspond to GetPlayer.GetHistoryCount.

Source code
function GetNextIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxHistoryCount)
Next (GetOptions)


Previous (GetNextIndex)
Next (GetPlayer)

Name
GetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetOptions : TPlaybackControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextIndex)
Next (GetPlayer)


Previous (GetOptions)
Next (GetPlayerCount)

Name
GetPlayer

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns a player control object.

Source code
function GetPlayer ( iIndex : integer ) : IPlaylistPlayerControl

Parameters
Parameter | Description
iIndex : INTEGER | The number of the player to retrieve.

Return
Types | Description
IPlaylistPlayerControl | The player control object.

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPlayerCount)


Previous (GetPlayer)
Next (GetPlayerOfItem)

Name
GetPlayerCount

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the number of players associated with this PlaybackControl object.

Source code
function GetPlayerCount : integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | The number of players.

mAirListScript
Class Tree
Index
Previous (GetPlayer)
Next (GetPlayerOfItem)


Previous (GetPlayerCount)
Next (GetRemainingDuration)

Name
GetPlayerOfItem

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Returns the player control object in which a specific item is loaded.

Source code
function GetPlayerOfItem ( iItem : IPlaylistItem ) : integer

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to look for.

Return
Types Description
INTEGER The player object in which the item is loaded,
or -1 if the item was not found.

mAirListScript
Class Tree
Index
Previous (GetPlayerCount)
Next (GetRemainingDuration)


Previous (GetPlayerOfItem)
Next (IsPlaying)

Name
GetRemainingDuration

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function GetRemainingDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerOfItem)
Next (IsPlaying)


Previous (GetRemainingDuration)
Next (LoadFromXMLEx)

Name
IsPlaying

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRemainingDuration)
Next (LoadFromXMLEx)


Previous (IsPlaying)
Next (MoveToHistory)

Name
LoadFromXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure LoadFromXMLEx ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (MoveToHistory)


Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)

Name
MoveToHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Moves an item into history by unloading it from any player and setting
its history flag.

Source code
procedure MoveToHistory ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (LoadFromXMLEx)
Next (PlayerAutoLoad)


Previous (MoveToHistory)
Next (PlayItemDetached)

Name
PlayerAutoLoad

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Loads a player with the next available, unused item. The player must be empty.

Source code
function PlayerAutoLoad ( iPlayer : integer ; iAsync : boolean ) : boolean

Parameters
Parameter | Description
iPlayer : INTEGER | The player number.
iAsync : BOOLEAN If set to true, the function returns immediately, and
loading takes place in the background. GetStatus will
be psLoading until loading has finished.

Return
Types Description
BOOLEAN Returns false if loading was successful, false if not.
Note that when using asynchronous loading, the player might
still fail to load (GetState=psError), even if this function
returned true.

mAirListScript
Class Tree
Index
Previous (MoveToHistory)
Next (PlayItemDetached)


Previous (PlayerAutoLoad)
Next (RecycleFromHistory)

Name
PlayItemDetached

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Start playback of an item on the given device, without caring for it thereafter.
This function can be used to play items independent from the actual players.
To create a file playlist item on the fly, use the
CreatePlaylistItemFromFile method.
The audio device can be grabbed from one of the players, for example by
CurrentPlaybackControl.GetPlayer(0).GetOutputDevice, or you can use
the BuildAudioDevice function to create one.

Source code
procedure PlayItemDetached ( iItem : IPlaylistItem ; iDevice : IPlaybackDevice )

Parameters
Parameter | Description
iItem : IPlaylistItem | The item to play.
iDevice : IPlaybackDevice | The audio device to play to.

mAirListScript
Class Tree
Index
Previous (PlayerAutoLoad)
Next (RecycleFromHistory)


Previous (PlayItemDetached)
Next (ReleaseBackgroundSources)

Name
RecycleFromHistory

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Recycles an item from history.

Source code
procedure RecycleFromHistory ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (PlayItemDetached)
Next (ReleaseBackgroundSources)


Previous (RecycleFromHistory)
Next (SaveAsXMLEx)

Name
ReleaseBackgroundSources

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure ReleaseBackgroundSources

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RecycleFromHistory)
Next (SaveAsXMLEx)


Previous (ReleaseBackgroundSources)
Next (SetMaxHistoryCount)

Name
SaveAsXMLEx

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
function SaveAsXMLEx ( iDocument : IXMLDocument ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument

mAirListScript
Class Tree
Index
Previous (ReleaseBackgroundSources)
Next (SetMaxHistoryCount)


Previous (SaveAsXMLEx)
Next (SetOptions)

Name
SetMaxHistoryCount

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetMaxHistoryCount ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SaveAsXMLEx)
Next (SetOptions)


Previous (SetMaxHistoryCount)
Next (SetPlayerCount)

Name
SetOptions

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaybackControlOptions )

Parameters
Parameter Description
iValue : TPlaybackControlOptions

mAirListScript
Class Tree
Index
Previous (SetMaxHistoryCount)
Next (SetPlayerCount)


Previous (SetOptions)
Next (SkipTo)

Name
SetPlayerCount

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Sets the number of players players associated with this PlaybackControl object.

Source code
procedure SetPlayerCount ( iValue : integer )

Parameters
Parameter | Description
iValue : INTEGER | the new number of players

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SkipTo)


Previous (SetPlayerCount)
Next (SwapPlayers)

Name
SkipTo

Parent
IPlaybackControl

Visibility
PUBLIC

Source code
procedure SkipTo ( iItem : IPlaylistItem )

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (SetPlayerCount)
Next (SwapPlayers)


Previous (SkipTo)
Next

Name
SwapPlayers

Parent
IPlaybackControl

Visibility
PUBLIC

Description
Swaps the items loaded in the specified players.
Neither player may be in state PS_PLAYING.

Source code
procedure SwapPlayers ( iPlayer1 , iPlayer2 : integer )

Parameters
Parameter | Description
iPlayer1 : INTEGER | The first player.
iPlayer2 : INTEGER | The second player.

mAirListScript
Class Tree
Index
Previous (SkipTo)
Next


Previous (IPlaybackControl)
Next (IPlaybackDeviceList)

Name
IPlaybackDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Members
Methods
Method Description
BuildFileSource (+)
BuildMultiRegionSource (+)
BuildMultiSource (+)
BuildNetworkFileSource (+)
BuildNetworkStreamSource (+)
BuildRecordDeviceSource (+)
BuildVirtualFileSource (+)
GetCapabilities (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackControl)
Next (IPlaybackDeviceList)


Previous
Next (BuildMultiRegionSource)

Name
BuildFileSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildFileSource ( iItem : IPlaylistItem ; iFilename : string ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iFilename : STRING

mAirListScript
Class Tree
Index
Previous
Next (BuildMultiRegionSource)


Previous (BuildFileSource)
Next (BuildMultiSource)

Name
BuildMultiRegionSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildMultiRegionSource ( iItem : IPlaylistItem ; iItems : IMultiPlaylist ; iFailsafe : boolean = false ) : IMultiAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iItems : IMultiPlaylist
iFailsafe : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BuildFileSource)
Next (BuildMultiSource)


Previous (BuildMultiRegionSource)
Next (BuildNetworkFileSource)

Name
BuildMultiSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildMultiSource ( iItem : IPlaylistItem ; iItems : IMultiPlaylist ; iRegions : TRegions ; iFailsafe : boolean = false ) : IMultiAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iItems : IMultiPlaylist
iRegions : TRegions
iFailsafe : BOOLEAN

mAirListScript
Class Tree
Index
Previous (BuildMultiRegionSource)
Next (BuildNetworkFileSource)


Previous (BuildMultiSource)
Next (BuildNetworkStreamSource)

Name
BuildNetworkFileSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildNetworkFileSource ( iItem : IPlaylistItem ; iURL : string ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iURL : STRING

mAirListScript
Class Tree
Index
Previous (BuildMultiSource)
Next (BuildNetworkStreamSource)


Previous (BuildNetworkFileSource)
Next (BuildRecordDeviceSource)

Name
BuildNetworkStreamSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildNetworkStreamSource ( iItem : IPlaylistItem ; iURL : string ; iDelay : TTimeValue ; iTimeout : integer ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iURL : STRING
iDelay : TTimeValue
iTimeout : INTEGER

mAirListScript
Class Tree
Index
Previous (BuildNetworkFileSource)
Next (BuildRecordDeviceSource)


Previous (BuildNetworkStreamSource)
Next (BuildVirtualFileSource)

Name
BuildRecordDeviceSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildRecordDeviceSource ( iItem : IPlaylistItem ; iDevice : IRecordDevice ; iDelay : TTimeValue ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iDevice : IRecordDevice
iDelay : TTimeValue

mAirListScript
Class Tree
Index
Previous (BuildNetworkStreamSource)
Next (BuildVirtualFileSource)


Previous (BuildRecordDeviceSource)
Next (GetCapabilities)

Name
BuildVirtualFileSource

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function BuildVirtualFileSource ( iItem : IPlaylistItem ; iFile : IStream ) : IAudioSource

Parameters
Parameter Description
iItem : IPlaylistItem
iFile : IStream

mAirListScript
Class Tree
Index
Previous (BuildRecordDeviceSource)
Next (GetCapabilities)


Previous (BuildVirtualFileSource)
Next

Name
GetCapabilities

Parent
IPlaybackDevice

Visibility
PUBLIC

Source code
function GetCapabilities : TPlaybackDeviceCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildVirtualFileSource)
Next


Previous (IPlaybackDevice)
Next (IPlayerControl)

Name
IPlaybackDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IAudioDeviceList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackDevice)
Next (IPlayerControl)


Previous
Next

Name
GetItem

Parent
IPlaybackDeviceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IPlaybackDevice

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaybackDeviceList)
Next (IPlaylist)

Name
IPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
CanOpen (+)
Close (+)
ExecutePlayerCommand (+)
FadeOut (+)
GetAutoFadeOut (+)
GetCaption (+)
GetColor (+)
GetCommandID (+)
GetDeviceConfigID (+)
GetEOFWarning (+)
GetErrorMessage (+)
GetHookMode (+)
GetIndex (+)
GetIsNext (+)
GetItem (+)
GetOnAirSourceControl (+)
GetOptions (+)
GetPFL (+)
GetPFLSource (+)
GetPFLSourceControl (+)
GetPlaybackControlIndex (+)
GetPosition (+)
GetSource (+)
GetState (+)
GetVolume (+)
IsAfterEOFWarning (+)
IsAfterStartNext (+)
Open (+)
Pause (+)
ReleaseItem (+)
Reset (+)
SetAutoFadeOut (+)
SetCaption (+)
SetColor (+)
SetEOFWarning (+)
SetIsNext (+)
SetOptions (+)
SetPFL (+)
SetVolume (+)
Start (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaybackDeviceList)
Next (IPlaylist)


Previous
Next (Close)

Name
CanOpen

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure CanOpen ( iItem : IPlaylistItem ; var Accept : boolean )

Parameters
Parameter Description
iItem : IPlaylistItem
Accept : BOOLEAN

mAirListScript
Class Tree
Index
Previous
Next (Close)


Previous (CanOpen)
Next (ExecutePlayerCommand)

Name
Close

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CanOpen)
Next (ExecutePlayerCommand)


Previous (Close)
Next (FadeOut)

Name
ExecutePlayerCommand

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ExecutePlayerCommand ( iCommand : TPlayerCommand )

Parameters
Parameter Description
iCommand : TPlayerCommand

mAirListScript
Class Tree
Index
Previous (Close)
Next (FadeOut)


Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)

Name
FadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecutePlayerCommand)
Next (GetAutoFadeOut)


Previous (FadeOut)
Next (GetCaption)

Name
GetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetAutoFadeOut : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetCaption)


Previous (GetAutoFadeOut)
Next (GetColor)

Name
GetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCaption : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutoFadeOut)
Next (GetColor)


Previous (GetCaption)
Next (GetCommandID)

Name
GetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCaption)
Next (GetCommandID)


Previous (GetColor)
Next (GetDeviceConfigID)

Name
GetCommandID

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetCommandID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetDeviceConfigID)


Previous (GetCommandID)
Next (GetEOFWarning)

Name
GetDeviceConfigID

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetDeviceConfigID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommandID)
Next (GetEOFWarning)


Previous (GetDeviceConfigID)
Next (GetErrorMessage)

Name
GetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetEOFWarning : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDeviceConfigID)
Next (GetErrorMessage)


Previous (GetEOFWarning)
Next (GetHookMode)

Name
GetErrorMessage

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetErrorMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEOFWarning)
Next (GetHookMode)


Previous (GetErrorMessage)
Next (GetIndex)

Name
GetHookMode

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetHookMode : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetErrorMessage)
Next (GetIndex)


Previous (GetHookMode)
Next (GetIsNext)

Name
GetIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHookMode)
Next (GetIsNext)


Previous (GetIndex)
Next (GetItem)

Name
GetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetIsNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndex)
Next (GetItem)


Previous (GetIsNext)
Next (GetOnAirSourceControl)

Name
GetItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIsNext)
Next (GetOnAirSourceControl)


Previous (GetItem)
Next (GetOptions)

Name
GetOnAirSourceControl

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetOnAirSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetOptions)


Previous (GetOnAirSourceControl)
Next (GetPFL)

Name
GetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetOptions : TPlayerControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOnAirSourceControl)
Next (GetPFL)


Previous (GetOptions)
Next (GetPFLSource)

Name
GetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFL : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPFLSource)


Previous (GetPFL)
Next (GetPFLSourceControl)

Name
GetPFLSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFLSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFL)
Next (GetPFLSourceControl)


Previous (GetPFLSource)
Next (GetPlaybackControlIndex)

Name
GetPFLSourceControl

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPFLSourceControl : ISourceControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLSource)
Next (GetPlaybackControlIndex)


Previous (GetPFLSourceControl)
Next (GetPosition)

Name
GetPlaybackControlIndex

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPlaybackControlIndex : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPFLSourceControl)
Next (GetPosition)


Previous (GetPlaybackControlIndex)
Next (GetSource)

Name
GetPosition

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackControlIndex)
Next (GetSource)


Previous (GetPosition)
Next (GetState)

Name
GetSource

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetState)


Previous (GetSource)
Next (GetVolume)

Name
GetState

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetState : TPlayerState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (GetVolume)


Previous (GetState)
Next (IsAfterEOFWarning)

Name
GetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (IsAfterEOFWarning)


Previous (GetVolume)
Next (IsAfterStartNext)

Name
IsAfterEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsAfterEOFWarning : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (IsAfterStartNext)


Previous (IsAfterEOFWarning)
Next (Open)

Name
IsAfterStartNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
function IsAfterStartNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterEOFWarning)
Next (Open)


Previous (IsAfterStartNext)
Next (Pause)

Name
Open

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Open ( iItem : IPlaylistItem ; iSourceControl : ISourceControl = nil )

Parameters
Parameter Description
iItem : IPlaylistItem
iSourceControl : ISourceControl

mAirListScript
Class Tree
Index
Previous (IsAfterStartNext)
Next (Pause)


Previous (Open)
Next (ReleaseItem)

Name
Pause

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (ReleaseItem)


Previous (Pause)
Next (Reset)

Name
ReleaseItem

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure ReleaseItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (Reset)


Previous (ReleaseItem)
Next (SetAutoFadeOut)

Name
Reset

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Reset

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ReleaseItem)
Next (SetAutoFadeOut)


Previous (Reset)
Next (SetCaption)

Name
SetAutoFadeOut

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetAutoFadeOut ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (Reset)
Next (SetCaption)


Previous (SetAutoFadeOut)
Next (SetColor)

Name
SetCaption

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetCaption ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetAutoFadeOut)
Next (SetColor)


Previous (SetCaption)
Next (SetEOFWarning)

Name
SetColor

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter Description
iValue : TColor

mAirListScript
Class Tree
Index
Previous (SetCaption)
Next (SetEOFWarning)


Previous (SetColor)
Next (SetIsNext)

Name
SetEOFWarning

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetEOFWarning ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetIsNext)


Previous (SetEOFWarning)
Next (SetOptions)

Name
SetIsNext

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetIsNext ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetEOFWarning)
Next (SetOptions)


Previous (SetIsNext)
Next (SetPFL)

Name
SetOptions

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlayerControlOptions )

Parameters
Parameter Description
iValue : TPlayerControlOptions

mAirListScript
Class Tree
Index
Previous (SetIsNext)
Next (SetPFL)


Previous (SetOptions)
Next (SetVolume)

Name
SetPFL

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetPFL ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetVolume)


Previous (SetPFL)
Next (Start)

Name
SetVolume

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPFL)
Next (Start)


Previous (SetVolume)
Next (Stop)

Name
Start

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Start

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next (Stop)


Previous (Start)
Next

Name
Stop

Parent
IPlayerControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Start)
Next


Previous (IPlayerControl)
Next (IPlaylistExporter)

Name
IPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPersistentList

Visibility
PUBLIC

Members
Methods
Method Description
ErrorCheck (+)
GetActiveDuration (+)
GetBacktimingBaseTime (+)
GetBaseTime (+)
GetDuration (+)
GetEffectiveDuration (+)
GetEndTime (+)
GetHistoryCount (+)
GetItem (+)
GetMetadata (+)
GetMetadataOfItem (+)
GetNext (+)
GetRegions (+)
GetRemainingCount (+)
GetStartTime (+)
GetTag (+)
GetTitle (+)
InsertDirectory (+)
InsertFile (+)
InsertFiles (+)
InsertFilesEx (+)
LoadFromFileEx (+)
SetBaseTime (+)
SetTag (+)
SetTitle (+)
SkipToTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlayerControl)
Next (IPlaylistExporter)


Previous
Next (GetActiveDuration)

Name
ErrorCheck

Parent
IPlaylist

Visibility
PUBLIC

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetActiveDuration)


Previous (ErrorCheck)
Next (GetBacktimingBaseTime)

Name
GetActiveDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetActiveDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetBacktimingBaseTime)


Previous (GetActiveDuration)
Next (GetBaseTime)

Name
GetBacktimingBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBacktimingBaseTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetActiveDuration)
Next (GetBaseTime)


Previous (GetBacktimingBaseTime)
Next (GetDuration)

Name
GetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetBaseTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBacktimingBaseTime)
Next (GetDuration)


Previous (GetBaseTime)
Next (GetEffectiveDuration)

Name
GetDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBaseTime)
Next (GetEffectiveDuration)


Previous (GetDuration)
Next (GetEndTime)

Name
GetEffectiveDuration

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetEffectiveDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetEndTime)


Previous (GetEffectiveDuration)
Next (GetHistoryCount)

Name
GetEndTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetEndTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDuration)
Next (GetHistoryCount)


Previous (GetEndTime)
Next (GetItem)

Name
GetHistoryCount

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetHistoryCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndTime)
Next (GetItem)


Previous (GetHistoryCount)
Next (GetMetadata)

Name
GetItem

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetItem ( iIndex : Integer ) : IPlaylistItem

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetHistoryCount)
Next (GetMetadata)


Previous (GetItem)
Next (GetMetadataOfItem)

Name
GetMetadata

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetMetadata ( iIndex : integer ) : IPlaylistItemMetadata

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetMetadataOfItem)


Previous (GetMetadata)
Next (GetNext)

Name
GetMetadataOfItem

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetMetadataOfItem ( iItem : iPlaylistItem ) : IPlaylistItemMetadata

Parameters
Parameter Description
iItem : iPlaylistItem

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetNext)


Previous (GetMetadataOfItem)
Next (GetRegions)

Name
GetNext

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetNext ( iItem : IPlaylistItem ) : IPlaylistItem

Parameters
Parameter Description
iItem : IPlaylistItem

mAirListScript
Class Tree
Index
Previous (GetMetadataOfItem)
Next (GetRegions)


Previous (GetNext)
Next (GetRemainingCount)

Name
GetRegions

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetRegions ( iDefault : TRegion ) : TRegions

Parameters
Parameter Description
iDefault : TRegion

mAirListScript
Class Tree
Index
Previous (GetNext)
Next (GetRemainingCount)


Previous (GetRegions)
Next (GetStartTime)

Name
GetRemainingCount

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetRemainingCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetStartTime)


Previous (GetRemainingCount)
Next (GetTag)

Name
GetStartTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetStartTime ( iIndex : integer ; iType : TStartTimeType ) : TDateTime

Parameters
Parameter Description
iIndex : INTEGER
iType : TStartTimeType

mAirListScript
Class Tree
Index
Previous (GetRemainingCount)
Next (GetTag)


Previous (GetStartTime)
Next (GetTitle)

Name
GetTag

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetTag : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (GetTitle)


Previous (GetTag)
Next (InsertDirectory)

Name
GetTitle

Parent
IPlaylist

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTag)
Next (InsertDirectory)


Previous (GetTitle)
Next (InsertFile)

Name
InsertDirectory

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertDirectory ( iIndex : integer ; iDirectory : string ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iDirectory : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (InsertFile)


Previous (InsertDirectory)
Next (InsertFiles)

Name
InsertFile

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFile ( iIndex : integer ; iFilename : string ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iFilename : STRING
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (InsertDirectory)
Next (InsertFiles)


Previous (InsertFile)
Next (InsertFilesEx)

Name
InsertFiles

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFiles ( iIndex : integer ; iFiles : IStrings ; iTasks : TFileImportTasks ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iFiles : IStrings
iTasks : TFileImportTasks

mAirListScript
Class Tree
Index
Previous (InsertFile)
Next (InsertFilesEx)


Previous (InsertFiles)
Next (LoadFromFileEx)

Name
InsertFilesEx

Parent
IPlaylist

Visibility
PUBLIC

Source code
function InsertFilesEx ( iIndex : integer ; iFiles : IStrings ; iTasks : TFileImportTasks ; iProgressIndicator : IProgressIndicator ) : integer

Parameters
Parameter Description
iIndex : INTEGER
iFiles : IStrings
iTasks : TFileImportTasks
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous (InsertFiles)
Next (LoadFromFileEx)


Previous (InsertFilesEx)
Next (SetBaseTime)

Name
LoadFromFileEx

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure LoadFromFileEx ( iFilename : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator )

Parameters
Parameter Description
iFilename : STRING
iReferenceDatabase : IDatabase
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous (InsertFilesEx)
Next (SetBaseTime)


Previous (LoadFromFileEx)
Next (SetTag)

Name
SetBaseTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetBaseTime ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (LoadFromFileEx)
Next (SetTag)


Previous (SetBaseTime)
Next (SetTitle)

Name
SetTag

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetTag ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetBaseTime)
Next (SetTitle)


Previous (SetTag)
Next (SkipToTime)

Name
SetTitle

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTag)
Next (SkipToTime)


Previous (SetTitle)
Next

Name
SkipToTime

Parent
IPlaylist

Visibility
PUBLIC

Source code
procedure SkipToTime ( iTime : TDateTime )

Parameters
Parameter Description
iTime : TDateTime

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)

Name
IPlaylistExporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
SavePlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylist)
Next (IPlaylistFilePlaylistItem)


Previous
Next

Name
SavePlaylist

Parent
IPlaylistExporter

Visibility
PUBLIC

Source code
procedure SavePlaylist ( iPlaylist : IPlaylist ; iFilename : string ; iProgressIndicator : IProgressIndicator )

Parameters
Parameter Description
iPlaylist : IPlaylist
iFilename : STRING
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaylistExporter)
Next (IPlaylistImporter)

Name
IPlaylistFilePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistExporter)
Next (IPlaylistImporter)


Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)

Name
IPlaylistImporter

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistStorage

Visibility
PUBLIC

Members
Methods
Method Description
LoadPlaylist (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistFilePlaylistItem)
Next (IPlaylistItem)


Previous
Next

Name
LoadPlaylist

Parent
IPlaylistImporter

Visibility
PUBLIC

Source code
function LoadPlaylist ( iFilename : string ; iReferenceDatabase : IDatabase ; iProgressIndicator : IProgressIndicator ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING
iReferenceDatabase : IDatabase
iProgressIndicator : IProgressIndicator

mAirListScript
Class Tree
Index
Previous
Next


Previous (IPlaylistImporter)
Next (IPlaylistItemMetadata)

Name
IPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPersistentListItem

Visibility
PUBLIC

Members
Methods
Method Description
AsFile (+)
AutoSearchPosition (+)
BuildSource (+)
ErrorCheck (+)
GetAmplification (+)
GetArtists (+)
GetArtistsString (+)
GetAttributes (+)
GetCapabilities (+)
GetChildElements (+)
GetColor (+)
GetColored (+)
GetComment (+)
GetCueData (+)
GetCuePosition (+)
GetDatabase (+)
GetDatabaseID (+)
GetDuration (+)
GetEffectiveDisplayDuration (+)
GetEffectiveDisplayEnd (+)
GetEffectivePlaybackDuration (+)
GetEffectivePlaybackEnd (+)
GetEndType (+)
GetExternalID (+)
GetFadeDuration (+)
GetFadeEnd (+)
GetFilteredXML (+)
GetFixTime (+)
GetHearableDuration (+)
GetIconData (+)
GetIconFilename (+)
GetItemType (+)
GetOptions (+)
GetPersistentDatabaseID (+)
GetPitch (+)
GetRegions (+)
GetStartActions (+)
GetStopActions (+)
GetSummary (+)
GetTempo (+)
GetTiming (+)
GetTitle (+)
GetVolumeEnvelope (+)
IsCueable (+)
IsFile (+)
IsPlayable (+)
SaveAsFilteredXML (+)
SetAmplification (+)
SetColor (+)
SetColored (+)
SetComment (+)
SetCuePosition (+)
SetDatabase (+)
SetDatabaseID (+)
SetDuration (+)
SetEndType (+)
SetExternalID (+)
SetFadeDuration (+)
SetFixTime (+)
SetIconFilename (+)
SetItemType (+)
SetOptions (+)
SetPersistentDatabaseID (+)
SetPitch (+)
SetTempo (+)
SetTiming (+)
SetTitle (+)
SetVolumeEnvelope (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistImporter)
Next (IPlaylistItemMetadata)


Previous
Next (AutoSearchPosition)

Name
AsFile

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function AsFile : IFilePlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (AutoSearchPosition)


Previous (AsFile)
Next (BuildSource)

Name
AutoSearchPosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure AutoSearchPosition ( iType : TCuePositionType )

Parameters
Parameter Description
iType : TCuePositionType

mAirListScript
Class Tree
Index
Previous (AsFile)
Next (BuildSource)


Previous (AutoSearchPosition)
Next (ErrorCheck)

Name
BuildSource

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function BuildSource ( iDevice : IPlaybackDevice ; iRegionDevices : IPlaybackDeviceList ) : IAudioSource

Parameters
Parameter Description
iDevice : IPlaybackDevice
iRegionDevices : IPlaybackDeviceList

mAirListScript
Class Tree
Index
Previous (AutoSearchPosition)
Next (ErrorCheck)


Previous (BuildSource)
Next (GetAmplification)

Name
ErrorCheck

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function ErrorCheck : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BuildSource)
Next (GetAmplification)


Previous (ErrorCheck)
Next (GetArtists)

Name
GetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAmplification : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ErrorCheck)
Next (GetArtists)


Previous (GetAmplification)
Next (GetArtistsString)

Name
GetArtists

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetArtists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAmplification)
Next (GetArtistsString)


Previous (GetArtists)
Next (GetAttributes)

Name
GetArtistsString

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetArtistsString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtists)
Next (GetAttributes)


Previous (GetArtistsString)
Next (GetCapabilities)

Name
GetAttributes

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetAttributes : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtistsString)
Next (GetCapabilities)


Previous (GetAttributes)
Next (GetChildElements)

Name
GetCapabilities

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCapabilities : TPlaylistItemCapabilities

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAttributes)
Next (GetChildElements)


Previous (GetCapabilities)
Next (GetColor)

Name
GetChildElements

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetChildElements : IMultiPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCapabilities)
Next (GetColor)


Previous (GetChildElements)
Next (GetColored)

Name
GetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetColor : TColor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChildElements)
Next (GetColored)


Previous (GetColor)
Next (GetComment)

Name
GetColored

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetColored : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColor)
Next (GetComment)


Previous (GetColored)
Next (GetCueData)

Name
GetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetComment : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColored)
Next (GetCueData)


Previous (GetComment)
Next (GetCuePosition)

Name
GetCueData

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCueData : ICueData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetComment)
Next (GetCuePosition)


Previous (GetCueData)
Next (GetDatabase)

Name
GetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetCuePosition ( iType : TCuePositionType ) : TTimeValue

Parameters
Parameter Description
iType : TCuePositionType

mAirListScript
Class Tree
Index
Previous (GetCueData)
Next (GetDatabase)


Previous (GetCuePosition)
Next (GetDatabaseID)

Name
GetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabase : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCuePosition)
Next (GetDatabaseID)


Previous (GetDatabase)
Next (GetDuration)

Name
GetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabase)
Next (GetDuration)


Previous (GetDatabaseID)
Next (GetEffectiveDisplayDuration)

Name
GetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseID)
Next (GetEffectiveDisplayDuration)


Previous (GetDuration)
Next (GetEffectiveDisplayEnd)

Name
GetEffectiveDisplayDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetEffectiveDisplayEnd)


Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)

Name
GetEffectiveDisplayEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectiveDisplayEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayDuration)
Next (GetEffectivePlaybackDuration)


Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)

Name
GetEffectivePlaybackDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectiveDisplayEnd)
Next (GetEffectivePlaybackEnd)


Previous (GetEffectivePlaybackDuration)
Next (GetEndType)

Name
GetEffectivePlaybackEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEffectivePlaybackEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackDuration)
Next (GetEndType)


Previous (GetEffectivePlaybackEnd)
Next (GetExternalID)

Name
GetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetEndType : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEffectivePlaybackEnd)
Next (GetExternalID)


Previous (GetEndType)
Next (GetFadeDuration)

Name
GetExternalID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetExternalID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEndType)
Next (GetFadeDuration)


Previous (GetExternalID)
Next (GetFadeEnd)

Name
GetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFadeDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExternalID)
Next (GetFadeEnd)


Previous (GetFadeDuration)
Next (GetFilteredXML)

Name
GetFadeEnd

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFadeEnd : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFadeDuration)
Next (GetFilteredXML)


Previous (GetFadeEnd)
Next (GetFixTime)

Name
GetFilteredXML

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFilteredXML ( iFilter : TPlaylistItemDataFilter ) : string

Parameters
Parameter Description
iFilter : TPlaylistItemDataFilter

mAirListScript
Class Tree
Index
Previous (GetFadeEnd)
Next (GetFixTime)


Previous (GetFilteredXML)
Next (GetHearableDuration)

Name
GetFixTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetFixTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFilteredXML)
Next (GetHearableDuration)


Previous (GetFixTime)
Next (GetIconData)

Name
GetHearableDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetHearableDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFixTime)
Next (GetIconData)


Previous (GetHearableDuration)
Next (GetIconFilename)

Name
GetIconData

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetIconData : IInlineData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHearableDuration)
Next (GetIconFilename)


Previous (GetIconData)
Next (GetItemType)

Name
GetIconFilename

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetIconFilename : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIconData)
Next (GetItemType)


Previous (GetIconFilename)
Next (GetOptions)

Name
GetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetItemType : TPlaylistItemType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIconFilename)
Next (GetOptions)


Previous (GetItemType)
Next (GetPersistentDatabaseID)

Name
GetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetOptions : TPlaylistItemOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItemType)
Next (GetPersistentDatabaseID)


Previous (GetOptions)
Next (GetPitch)

Name
GetPersistentDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPersistentDatabaseID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPitch)


Previous (GetPersistentDatabaseID)
Next (GetRegions)

Name
GetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetPitch : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPersistentDatabaseID)
Next (GetRegions)


Previous (GetPitch)
Next (GetStartActions)

Name
GetRegions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetRegions ( iDefault : TRegion ) : TRegions

Parameters
Parameter Description
iDefault : TRegion

mAirListScript
Class Tree
Index
Previous (GetPitch)
Next (GetStartActions)


Previous (GetRegions)
Next (GetStopActions)

Name
GetStartActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStartActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegions)
Next (GetStopActions)


Previous (GetStartActions)
Next (GetSummary)

Name
GetStopActions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetStopActions : IActionList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartActions)
Next (GetSummary)


Previous (GetStopActions)
Next (GetTempo)

Name
GetSummary

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetSummary : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStopActions)
Next (GetTempo)


Previous (GetSummary)
Next (GetTiming)

Name
GetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTempo : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSummary)
Next (GetTiming)


Previous (GetTempo)
Next (GetTitle)

Name
GetTiming

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTiming : TTiming

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempo)
Next (GetTitle)


Previous (GetTiming)
Next (GetVolumeEnvelope)

Name
GetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTiming)
Next (GetVolumeEnvelope)


Previous (GetTitle)
Next (IsCueable)

Name
GetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function GetVolumeEnvelope : IEnvelope

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next (IsCueable)


Previous (GetVolumeEnvelope)
Next (IsFile)

Name
IsCueable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolumeEnvelope)
Next (IsFile)


Previous (IsCueable)
Next (IsPlayable)

Name
IsFile

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsFile : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (IsPlayable)


Previous (IsFile)
Next (SaveAsFilteredXML)

Name
IsPlayable

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function IsPlayable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsFile)
Next (SaveAsFilteredXML)


Previous (IsPlayable)
Next (SetAmplification)

Name
SaveAsFilteredXML

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
function SaveAsFilteredXML ( iDocument : IXMLDocument ; iFilter : TPlaylistItemDataFilter ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument
iFilter : TPlaylistItemDataFilter

mAirListScript
Class Tree
Index
Previous (IsPlayable)
Next (SetAmplification)


Previous (SaveAsFilteredXML)
Next (SetColor)

Name
SetAmplification

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetAmplification ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SaveAsFilteredXML)
Next (SetColor)


Previous (SetAmplification)
Next (SetColored)

Name
SetColor

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetColor ( iValue : TColor )

Parameters
Parameter Description
iValue : TColor

mAirListScript
Class Tree
Index
Previous (SetAmplification)
Next (SetColored)


Previous (SetColor)
Next (SetComment)

Name
SetColored

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetColored ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetColor)
Next (SetComment)


Previous (SetColored)
Next (SetCuePosition)

Name
SetComment

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetComment ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetColored)
Next (SetCuePosition)


Previous (SetComment)
Next (SetDatabase)

Name
SetCuePosition

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetCuePosition ( iType : TCuePositionType ; iValue : TTimeValue )

Parameters
Parameter Description
iType : TCuePositionType
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetComment)
Next (SetDatabase)


Previous (SetCuePosition)
Next (SetDatabaseID)

Name
SetDatabase

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabase ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetCuePosition)
Next (SetDatabaseID)


Previous (SetDatabase)
Next (SetDuration)

Name
SetDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDatabaseID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDatabase)
Next (SetDuration)


Previous (SetDatabaseID)
Next (SetEndType)

Name
SetDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetDatabaseID)
Next (SetEndType)


Previous (SetDuration)
Next (SetExternalID)

Name
SetEndType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetEndType ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetDuration)
Next (SetExternalID)


Previous (SetEndType)
Next (SetFadeDuration)

Name
SetExternalID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetExternalID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetEndType)
Next (SetFadeDuration)


Previous (SetExternalID)
Next (SetFixTime)

Name
SetFadeDuration

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFadeDuration ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetExternalID)
Next (SetFixTime)


Previous (SetFadeDuration)
Next (SetIconFilename)

Name
SetFixTime

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetFixTime ( iValue : TDateTime )

Parameters
Parameter Description
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetFadeDuration)
Next (SetIconFilename)


Previous (SetFixTime)
Next (SetItemType)

Name
SetIconFilename

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetIconFilename ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetFixTime)
Next (SetItemType)


Previous (SetIconFilename)
Next (SetOptions)

Name
SetItemType

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetItemType ( iValue : TPlaylistItemType )

Parameters
Parameter Description
iValue : TPlaylistItemType

mAirListScript
Class Tree
Index
Previous (SetIconFilename)
Next (SetOptions)


Previous (SetItemType)
Next (SetPersistentDatabaseID)

Name
SetOptions

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TPlaylistItemOptions )

Parameters
Parameter Description
iValue : TPlaylistItemOptions

mAirListScript
Class Tree
Index
Previous (SetItemType)
Next (SetPersistentDatabaseID)


Previous (SetOptions)
Next (SetPitch)

Name
SetPersistentDatabaseID

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetPersistentDatabaseID ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetPitch)


Previous (SetPersistentDatabaseID)
Next (SetTempo)

Name
SetPitch

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetPitch ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPersistentDatabaseID)
Next (SetTempo)


Previous (SetPitch)
Next (SetTiming)

Name
SetTempo

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTempo ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPitch)
Next (SetTiming)


Previous (SetTempo)
Next (SetTitle)

Name
SetTiming

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTiming ( iValue : TTiming )

Parameters
Parameter Description
iValue : TTiming

mAirListScript
Class Tree
Index
Previous (SetTempo)
Next (SetTitle)


Previous (SetTiming)
Next (SetVolumeEnvelope)

Name
SetTitle

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetTiming)
Next (SetVolumeEnvelope)


Previous (SetTitle)
Next

Name
SetVolumeEnvelope

Parent
IPlaylistItem

Visibility
PUBLIC

Source code
procedure SetVolumeEnvelope ( iValue : IEnvelope )

Parameters
Parameter Description
iValue : IEnvelope

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next


Previous (IPlaylistItem)
Next (IPlaylistPlayerControl)

Name
IPlaylistItemMetadata

Parent
mAirListInterfaces

Class Hierarchy
IPersistentPlaylistItemMetadata

Visibility
PUBLIC

Members
Methods
Method Description
GetCalculatedDuration (+)
GetOffset (+)
GetStartTime (+)
GetStatusFlags (+)
SetCalculatedDuration (+)
SetOffset (+)
SetStartTime (+)
SetStatusFlags (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItem)
Next (IPlaylistPlayerControl)


Previous
Next (GetOffset)

Name
GetCalculatedDuration

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetCalculatedDuration ( iType : TCalculatedDurationType ) : TTimeValue

Parameters
Parameter Description
iType : TCalculatedDurationType

mAirListScript
Class Tree
Index
Previous
Next (GetOffset)


Previous (GetCalculatedDuration)
Next (GetStartTime)

Name
GetOffset

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetOffset : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCalculatedDuration)
Next (GetStartTime)


Previous (GetOffset)
Next (GetStatusFlags)

Name
GetStartTime

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetStartTime ( iType : TStartTimeType ) : TDateTime

Parameters
Parameter Description
iType : TStartTimeType

mAirListScript
Class Tree
Index
Previous (GetOffset)
Next (GetStatusFlags)


Previous (GetStartTime)
Next (SetCalculatedDuration)

Name
GetStatusFlags

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
function GetStatusFlags : TPlaylistItemStatusFlags

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (SetCalculatedDuration)


Previous (GetStatusFlags)
Next (SetOffset)

Name
SetCalculatedDuration

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetCalculatedDuration ( iType : TCalculatedDurationType ; iValue : TTimeValue )

Parameters
Parameter Description
iType : TCalculatedDurationType
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (GetStatusFlags)
Next (SetOffset)


Previous (SetCalculatedDuration)
Next (SetStartTime)

Name
SetOffset

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetOffset ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetCalculatedDuration)
Next (SetStartTime)


Previous (SetOffset)
Next (SetStatusFlags)

Name
SetStartTime

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetStartTime ( iType : TStartTimeType ; iValue : TDateTime )

Parameters
Parameter Description
iType : TStartTimeType
iValue : TDateTime

mAirListScript
Class Tree
Index
Previous (SetOffset)
Next (SetStatusFlags)


Previous (SetStartTime)
Next

Name
SetStatusFlags

Parent
IPlaylistItemMetadata

Visibility
PUBLIC

Source code
procedure SetStatusFlags ( iValue : TPlaylistItemStatusFlags )

Parameters
Parameter Description
iValue : TPlaylistItemStatusFlags

mAirListScript
Class Tree
Index
Previous (SetStartTime)
Next


Previous (IPlaylistItemMetadata)
Next (IPlaylistStorage)

Name
IPlaylistPlayerControl

Parent
mAirListInterfaces

Class Hierarchy
IPlayerControl

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoLoadItemTypes (+)
SetAutoLoadItemTypes (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistItemMetadata)
Next (IPlaylistStorage)


Previous
Next (SetAutoLoadItemTypes)

Name
GetAutoLoadItemTypes

Parent
IPlaylistPlayerControl

Visibility
PUBLIC

Source code
function GetAutoLoadItemTypes : TPlaylistItemTypes

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetAutoLoadItemTypes)


Previous (GetAutoLoadItemTypes)
Next

Name
SetAutoLoadItemTypes

Parent
IPlaylistPlayerControl

Visibility
PUBLIC

Source code
procedure SetAutoLoadItemTypes ( iValue : TPlaylistItemTypes )

Parameters
Parameter Description
iValue : TPlaylistItemTypes

mAirListScript
Class Tree
Index
Previous (GetAutoLoadItemTypes)
Next


Previous (IPlaylistPlayerControl)
Next (IProgressIndicator)

Name
IPlaylistStorage

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistPlayerControl)
Next (IProgressIndicator)


Previous (IPlaylistStorage)
Next (IRecordDevice)

Name
IProgressIndicator

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Cancel (+)
CreateSubIndicator (+)
SetCurrentItem (+)
SetMax (+)
SetPosition (+)
SetTitle (+)
SkipRetryAbort (+)
StartProgress (+)
StepIt (+)
StopProgress (+)
WasCanceled (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IPlaylistStorage)
Next (IRecordDevice)


Previous
Next (CreateSubIndicator)

Name
Cancel

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure Cancel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (CreateSubIndicator)


Previous (Cancel)
Next (SetCurrentItem)

Name
CreateSubIndicator

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function CreateSubIndicator : IProgressIndicator

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Cancel)
Next (SetCurrentItem)


Previous (CreateSubIndicator)
Next (SetMax)

Name
SetCurrentItem

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetCurrentItem ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (CreateSubIndicator)
Next (SetMax)


Previous (SetCurrentItem)
Next (SetPosition)

Name
SetMax

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetMax ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetCurrentItem)
Next (SetPosition)


Previous (SetMax)
Next (SetTitle)

Name
SetPosition

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetMax)
Next (SetTitle)


Previous (SetPosition)
Next (SkipRetryAbort)

Name
SetTitle

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (SkipRetryAbort)


Previous (SetTitle)
Next (StartProgress)

Name
SkipRetryAbort

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function SkipRetryAbort ( iMessage : string ) : TSkipRetryAbort

Parameters
Parameter Description
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (SetTitle)
Next (StartProgress)


Previous (SkipRetryAbort)
Next (StepIt)

Name
StartProgress

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StartProgress

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SkipRetryAbort)
Next (StepIt)


Previous (StartProgress)
Next (StopProgress)

Name
StepIt

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StepIt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StartProgress)
Next (StopProgress)


Previous (StepIt)
Next (WasCanceled)

Name
StopProgress

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
procedure StopProgress

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StepIt)
Next (WasCanceled)


Previous (StopProgress)
Next

Name
WasCanceled

Parent
IProgressIndicator

Visibility
PUBLIC

Source code
function WasCanceled : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StopProgress)
Next


Previous (IProgressIndicator)
Next (IRecordDeviceList)

Name
IRecordDevice

Parent
mAirListInterfaces

Class Hierarchy
IAudioDevice

Visibility
PUBLIC

Members
Methods
Method Description
Acquire (+)
GetChannelCount (+)
GetSampleFormat (+)
GetSamplerate (+)
Release (+)
StartRecordingToStream (+)
StopRecordingToStream (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IProgressIndicator)
Next (IRecordDeviceList)


Previous
Next (GetChannelCount)

Name
Acquire

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure Acquire

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetChannelCount)


Previous (Acquire)
Next (GetSampleFormat)

Name
GetChannelCount

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetChannelCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Acquire)
Next (GetSampleFormat)


Previous (GetChannelCount)
Next (GetSamplerate)

Name
GetSampleFormat

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetSampleFormat : TSampleFormat

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetChannelCount)
Next (GetSamplerate)


Previous (GetSampleFormat)
Next (Release)

Name
GetSamplerate

Parent
IRecordDevice

Visibility
PUBLIC

Source code
function GetSamplerate : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSampleFormat)
Next (Release)


Previous (GetSamplerate)
Next (StartRecordingToStream)

Name
Release

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure Release

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSamplerate)
Next (StartRecordingToStream)


Previous (Release)
Next (StopRecordingToStream)

Name
StartRecordingToStream

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure StartRecordingToStream ( iStream : IWritableStream )

Parameters
Parameter Description
iStream : IWritableStream

mAirListScript
Class Tree
Index
Previous (Release)
Next (StopRecordingToStream)


Previous (StartRecordingToStream)
Next

Name
StopRecordingToStream

Parent
IRecordDevice

Visibility
PUBLIC

Source code
procedure StopRecordingToStream ( iStream : IWritableStream )

Parameters
Parameter Description
iStream : IWritableStream

mAirListScript
Class Tree
Index
Previous (StartRecordingToStream)
Next


Previous (IRecordDevice)
Next (IRecycleBinPlaylist)

Name
IRecordDeviceList

Parent
mAirListInterfaces

Class Hierarchy
IAudioDeviceList

Visibility
PUBLIC

Members
Methods
Method Description
GetItem (+)
IndexOfID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecordDevice)
Next (IRecycleBinPlaylist)


Previous
Next (IndexOfID)

Name
GetItem

Parent
IRecordDeviceList

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IRecordDevice

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (IndexOfID)


Previous (GetItem)
Next

Name
IndexOfID

Parent
IRecordDeviceList

Visibility
PUBLIC

Source code
function IndexOfID ( iID : string ) : integer

Parameters
Parameter Description
iID : STRING

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (IRecordDeviceList)
Next (IRegionContainerPlaylistItem)

Name
IRecycleBinPlaylist

Parent
mAirListInterfaces

Class Hierarchy
IPlaylist

Visibility
PUBLIC

Members
Methods
Method Description
GetMaxSize (+)
SetMaxSize (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecordDeviceList)
Next (IRegionContainerPlaylistItem)


Previous
Next (SetMaxSize)

Name
GetMaxSize

Parent
IRecycleBinPlaylist

Visibility
PUBLIC

Source code
function GetMaxSize : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetMaxSize)


Previous (GetMaxSize)
Next

Name
SetMaxSize

Parent
IRecycleBinPlaylist

Visibility
PUBLIC

Source code
procedure SetMaxSize ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetMaxSize)
Next


Previous (IRecycleBinPlaylist)
Next (IRemote)

Name
IRegionContainerPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetAutoFillMethod (+)
GetContent (+)
HasContent (+)
SetAutoFillMethod (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRecycleBinPlaylist)
Next (IRemote)


Previous
Next (GetContent)

Name
GetAutoFillMethod

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetAutoFillMethod : TAutoFillMethod

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetContent)


Previous (GetAutoFillMethod)
Next (HasContent)

Name
GetContent

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function GetContent ( iRegion : byte ) : IPlaylist

Parameters
Parameter Description
iRegion : BYTE

mAirListScript
Class Tree
Index
Previous (GetAutoFillMethod)
Next (HasContent)


Previous (GetContent)
Next (SetAutoFillMethod)

Name
HasContent

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
function HasContent ( iRegion : byte ) : boolean

Parameters
Parameter Description
iRegion : BYTE

mAirListScript
Class Tree
Index
Previous (GetContent)
Next (SetAutoFillMethod)


Previous (HasContent)
Next

Name
SetAutoFillMethod

Parent
IRegionContainerPlaylistItem

Visibility
PUBLIC

Source code
procedure SetAutoFillMethod ( iValue : TAutoFillMethod )

Parameters
Parameter Description
iValue : TAutoFillMethod

mAirListScript
Class Tree
Index
Previous (HasContent)
Next


Previous (IRegionContainerPlaylistItem)
Next (IRemoteAction)

Name
IRemote

Parent
mAirListInterfaces

Class Hierarchy
IConfigObject

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRegionContainerPlaylistItem)
Next (IRemoteAction)


Previous (IRemote)
Next (IRemoteController)

Name
IRemoteAction

Parent
mAirListInterfaces

Class Hierarchy
IAction

Visibility
PUBLIC

Members
Methods
Method Description
GetRemoteID (+)
SetRemoteID (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemote)
Next (IRemoteController)


Previous
Next (SetRemoteID)

Name
GetRemoteID

Parent
IRemoteAction

Visibility
PUBLIC

Source code
function GetRemoteID : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetRemoteID)


Previous (GetRemoteID)
Next

Name
SetRemoteID

Parent
IRemoteAction

Visibility
PUBLIC

Source code
procedure SetRemoteID ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetRemoteID)
Next


Previous (IRemoteAction)
Next (IRunnable)

Name
IRemoteController

Parent
mAirListInterfaces

Class Hierarchy
IConfigObjectList

Visibility
PUBLIC

Members
Methods
Method Description
BeginPFL (+)
EndPFL (+)
ExecuteCommand (+)
GetItem (+)
GetPFLCount (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteAction)
Next (IRunnable)


Previous
Next (EndPFL)

Name
BeginPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure BeginPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (EndPFL)


Previous (BeginPFL)
Next (ExecuteCommand)

Name
EndPFL

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure EndPFL

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginPFL)
Next (ExecuteCommand)


Previous (EndPFL)
Next (GetItem)

Name
ExecuteCommand

Parent
IRemoteController

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter Description
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (EndPFL)
Next (GetItem)


Previous (ExecuteCommand)
Next (GetPFLCount)

Name
GetItem

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : IRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (GetPFLCount)


Previous (GetItem)
Next

Name
GetPFLCount

Parent
IRemoteController

Visibility
PUBLIC

Source code
function GetPFLCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next


Previous (IRemoteController)
Next (ISerialPortManager)

Name
IRunnable

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
Run (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRemoteController)
Next (ISerialPortManager)


Previous
Next

Name
Run

Parent
IRunnable

Visibility
PUBLIC

Source code
procedure Run

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next


Previous (IRunnable)
Next (ISilencePlaylistItem)

Name
ISerialPortManager

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
GetPortList (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IRunnable)
Next (ISilencePlaylistItem)


Previous
Next (GetPortList)

Name
GetPort

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPort ( iName : string ) : IComPort

Parameters
Parameter Description
iName : STRING

mAirListScript
Class Tree
Index
Previous
Next (GetPortList)


Previous (GetPort)
Next

Name
GetPortList

Parent
ISerialPortManager

Visibility
PUBLIC

Source code
function GetPortList : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (ISerialPortManager)
Next (ISourceControl)

Name
ISilencePlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISerialPortManager)
Next (ISourceControl)


Previous (ISilencePlaylistItem)
Next (IStream)

Name
ISourceControl

Parent
mAirListInterfaces

Class Hierarchy
IUpdateObject

Visibility
PUBLIC

Members
Methods
Method Description
EndMon (+)
FadeOut (+)
GetDuration (+)
GetEOFWarning (+)
GetItem (+)
GetOptions (+)
GetPlaybackDuration (+)
GetPosition (+)
GetSource (+)
GetStartPosition (+)
GetStartTime (+)
GetState (+)
GetVolume (+)
IsAfterStartNext (+)
IsCueable (+)
IsPlaying (+)
Pause (+)
Play (+)
SetEOFWarning (+)
SetOptions (+)
SetPosition (+)
SetVolume (+)
Stop (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISilencePlaylistItem)
Next (IStream)


Previous
Next (FadeOut)

Name
EndMon

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure EndMon ( iDuration : TTimeValue = - 1 )

Parameters
Parameter Description
iDuration : TTimeValue

mAirListScript
Class Tree
Index
Previous
Next (FadeOut)


Previous (EndMon)
Next (GetDuration)

Name
FadeOut

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure FadeOut

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndMon)
Next (GetDuration)


Previous (FadeOut)
Next (GetEOFWarning)

Name
GetDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FadeOut)
Next (GetEOFWarning)


Previous (GetDuration)
Next (GetItem)

Name
GetEOFWarning

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetEOFWarning : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDuration)
Next (GetItem)


Previous (GetEOFWarning)
Next (GetOptions)

Name
GetItem

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetItem : IPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEOFWarning)
Next (GetOptions)


Previous (GetItem)
Next (GetPlaybackDuration)

Name
GetOptions

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetOptions : TSourceControlOptions

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetPlaybackDuration)


Previous (GetOptions)
Next (GetPosition)

Name
GetPlaybackDuration

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetPlaybackDuration : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetOptions)
Next (GetPosition)


Previous (GetPlaybackDuration)
Next (GetSource)

Name
GetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlaybackDuration)
Next (GetSource)


Previous (GetPosition)
Next (GetStartPosition)

Name
GetSource

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetSource : IAudioSource

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPosition)
Next (GetStartPosition)


Previous (GetSource)
Next (GetStartTime)

Name
GetStartPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetStartPosition : TTimeValue

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSource)
Next (GetStartTime)


Previous (GetStartPosition)
Next (GetState)

Name
GetStartTime

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetStartTime : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartPosition)
Next (GetState)


Previous (GetStartTime)
Next (GetVolume)

Name
GetState

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetState : TSourceControlState

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStartTime)
Next (GetVolume)


Previous (GetState)
Next (IsAfterStartNext)

Name
GetVolume

Parent
ISourceControl

Visibility
PUBLIC

Source code
function GetVolume : single

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetState)
Next (IsAfterStartNext)


Previous (GetVolume)
Next (IsCueable)

Name
IsAfterStartNext

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsAfterStartNext : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVolume)
Next (IsCueable)


Previous (IsAfterStartNext)
Next (IsPlaying)

Name
IsCueable

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsCueable : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterStartNext)
Next (IsPlaying)


Previous (IsCueable)
Next (Pause)

Name
IsPlaying

Parent
ISourceControl

Visibility
PUBLIC

Source code
function IsPlaying : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCueable)
Next (Pause)


Previous (IsPlaying)
Next (Play)

Name
Pause

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Pause

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsPlaying)
Next (Play)


Previous (Pause)
Next (SetEOFWarning)

Name
Play

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Play

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Pause)
Next (SetEOFWarning)


Previous (Play)
Next (SetOptions)

Name
SetEOFWarning

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetEOFWarning ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (Play)
Next (SetOptions)


Previous (SetEOFWarning)
Next (SetPosition)

Name
SetOptions

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetOptions ( iValue : TSourceControlOptions )

Parameters
Parameter Description
iValue : TSourceControlOptions

mAirListScript
Class Tree
Index
Previous (SetEOFWarning)
Next (SetPosition)


Previous (SetOptions)
Next (SetVolume)

Name
SetPosition

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetPosition ( iValue : TTimeValue )

Parameters
Parameter Description
iValue : TTimeValue

mAirListScript
Class Tree
Index
Previous (SetOptions)
Next (SetVolume)


Previous (SetPosition)
Next (Stop)

Name
SetVolume

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure SetVolume ( iValue : single )

Parameters
Parameter Description
iValue : SINGLE

mAirListScript
Class Tree
Index
Previous (SetPosition)
Next (Stop)


Previous (SetVolume)
Next

Name
Stop

Parent
ISourceControl

Visibility
PUBLIC

Source code
procedure Stop

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SetVolume)
Next


Previous (ISourceControl)
Next (IStreamPlaylistItem)

Name
IStream

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetSize (+)
Lock (+)
READ (+)
Seek (+)
Unlock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISourceControl)
Next (IStreamPlaylistItem)


Previous
Next (Lock)

Name
GetSize

Parent
IStream

Visibility
PUBLIC

Source code
function GetSize : int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Lock)


Previous (GetSize)
Next (READ)

Name
Lock

Parent
IStream

Visibility
PUBLIC

Source code
procedure Lock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSize)
Next (READ)


Previous (Lock)
Next (Seek)

Name
READ

Parent
IStream

Visibility
PUBLIC

Source code
function Read ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter Description
Buffer : pointer
Count : INTEGER

mAirListScript
Class Tree
Index
Previous (Lock)
Next (Seek)


Previous (READ)
Next (Unlock)

Name
Seek

Parent
IStream

Visibility
PUBLIC

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64

Parameters
Parameter Description
OFFSET : INT64
Origin : TSeekOrigin

mAirListScript
Class Tree
Index
Previous (READ)
Next (Unlock)


Previous (Seek)
Next

Name
Unlock

Parent
IStream

Visibility
PUBLIC

Source code
procedure Unlock

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Seek)
Next


Previous (IStream)
Next (IStrings)

Name
IStreamPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IURLPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetTimeout (+)
SetTimeout (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStream)
Next (IStrings)


Previous
Next (SetTimeout)

Name
GetTimeout

Parent
IStreamPlaylistItem

Visibility
PUBLIC

Source code
function GetTimeout : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetTimeout)


Previous (GetTimeout)
Next

Name
SetTimeout

Parent
IStreamPlaylistItem

Visibility
PUBLIC

Source code
procedure SetTimeout ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTimeout)
Next


Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)

Name
IStrings

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
ADD (+)
AddObject (+)
AddStrings (+)
AddValue (+)
Assign (+)
BeginRead (+)
BeginWrite (+)
Clear (+)
Clone (+)
Delete (+)
EndRead (+)
EndWrite (+)
GetCommaText (+)
GetCount (+)
GetData (+)
GetItem (+)
GetName (+)
GetSorted (+)
GetText (+)
GetValue (+)
GetValueFromIndex (+)
IndexOf (+)
IndexOfName (+)
Insert (+)
Load (+)
LoadFromFile (+)
LoadMap (+)
LoadMapFromXML (+)
Save (+)
SaveMap (+)
SaveMapAsXML (+)
SaveToFile (+)
SetCommaText (+)
SetItem (+)
SetSorted (+)
SetText (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStreamPlaylistItem)
Next (IStubPlaylistItem)


Previous
Next (AddObject)

Name
ADD

Parent
IStrings

Visibility
PUBLIC

Source code
function Add ( iValue : string ) : IStrings

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous
Next (AddObject)


Previous (ADD)
Next (AddStrings)

Name
AddObject

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddObject ( iValue : string ; iData : cardinal )

Parameters
Parameter Description
iValue : STRING
iData : CARDINAL

mAirListScript
Class Tree
Index
Previous (ADD)
Next (AddStrings)


Previous (AddObject)
Next (AddValue)

Name
AddStrings

Parent
IStrings

Visibility
PUBLIC

Source code
procedure AddStrings ( iValues : IStrings )

Parameters
Parameter Description
iValues : IStrings

mAirListScript
Class Tree
Index
Previous (AddObject)
Next (AddValue)


Previous (AddStrings)
Next (Assign)

Name
AddValue

Parent
IStrings

Visibility
PUBLIC

Source code
function AddValue ( iName , iValue : string ) : IStrings

Parameters
Parameter Description
iName : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (AddStrings)
Next (Assign)


Previous (AddValue)
Next (BeginRead)

Name
Assign

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Assign ( iValue : IStrings )

Parameters
Parameter Description
iValue : IStrings

mAirListScript
Class Tree
Index
Previous (AddValue)
Next (BeginRead)


Previous (Assign)
Next (BeginWrite)

Name
BeginRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Assign)
Next (BeginWrite)


Previous (BeginRead)
Next (Clear)

Name
BeginWrite

Parent
IStrings

Visibility
PUBLIC

Source code
function BeginWrite : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (Clear)


Previous (BeginWrite)
Next (Clone)

Name
Clear

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginWrite)
Next (Clone)


Previous (Clear)
Next (Delete)

Name
Clone

Parent
IStrings

Visibility
PUBLIC

Source code
function Clone : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (Delete)


Previous (Clone)
Next (EndRead)

Name
Delete

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Delete ( iIndex : integer )

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (Clone)
Next (EndRead)


Previous (Delete)
Next (EndWrite)

Name
EndRead

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Delete)
Next (EndWrite)


Previous (EndRead)
Next (GetCommaText)

Name
EndWrite

Parent
IStrings

Visibility
PUBLIC

Source code
procedure EndWrite

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (GetCommaText)


Previous (EndWrite)
Next (GetCount)

Name
GetCommaText

Parent
IStrings

Visibility
PUBLIC

Source code
function GetCommaText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndWrite)
Next (GetCount)


Previous (GetCommaText)
Next (GetData)

Name
GetCount

Parent
IStrings

Visibility
PUBLIC

Source code
function GetCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCommaText)
Next (GetData)


Previous (GetCount)
Next (GetItem)

Name
GetData

Parent
IStrings

Visibility
PUBLIC

Source code
function GetData ( iIndex : integer ) : cardinal

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCount)
Next (GetItem)


Previous (GetData)
Next (GetName)

Name
GetItem

Parent
IStrings

Visibility
PUBLIC

Source code
function GetItem ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetData)
Next (GetName)


Previous (GetItem)
Next (GetSorted)

Name
GetName

Parent
IStrings

Visibility
PUBLIC

Source code
function GetName ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetItem)
Next (GetSorted)


Previous (GetName)
Next (GetText)

Name
GetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
function GetSorted : boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetText)


Previous (GetSorted)
Next (GetValue)

Name
GetText

Parent
IStrings

Visibility
PUBLIC

Source code
function GetText : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSorted)
Next (GetValue)


Previous (GetText)
Next (GetValueFromIndex)

Name
GetValue

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValue ( iKey : string ) : string

Parameters
Parameter Description
iKey : STRING

mAirListScript
Class Tree
Index
Previous (GetText)
Next (GetValueFromIndex)


Previous (GetValue)
Next (IndexOf)

Name
GetValueFromIndex

Parent
IStrings

Visibility
PUBLIC

Source code
function GetValueFromIndex ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (IndexOf)


Previous (GetValueFromIndex)
Next (IndexOfName)

Name
IndexOf

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOf ( iValue : string ) : integer

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetValueFromIndex)
Next (IndexOfName)


Previous (IndexOf)
Next (Insert)

Name
IndexOfName

Parent
IStrings

Visibility
PUBLIC

Source code
function IndexOfName ( iValue : string ) : integer

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (IndexOf)
Next (Insert)


Previous (IndexOfName)
Next (Load)

Name
Insert

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Insert ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (IndexOfName)
Next (Load)


Previous (Insert)
Next (LoadFromFile)

Name
Load

Parent
IStrings

Visibility
PUBLIC

Source code
procedure Load ( iSource : IPersistentStorage )

Parameters
Parameter Description
iSource : IPersistentStorage

mAirListScript
Class Tree
Index
Previous (Insert)
Next (LoadFromFile)


Previous (Load)
Next (LoadMap)

Name
LoadFromFile

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadFromFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Load)
Next (LoadMap)


Previous (LoadFromFile)
Next (LoadMapFromXML)

Name
LoadMap

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadMap ( iSource : IPersistentStorage )

Parameters
Parameter Description
iSource : IPersistentStorage

mAirListScript
Class Tree
Index
Previous (LoadFromFile)
Next (LoadMapFromXML)


Previous (LoadMap)
Next (Save)

Name
LoadMapFromXML

Parent
IStrings

Visibility
PUBLIC

Source code
procedure LoadMapFromXML ( iXML : IXMLNode )

Parameters
Parameter Description
iXML : IXMLNode

mAirListScript
Class Tree
Index
Previous (LoadMap)
Next (Save)


Previous (LoadMapFromXML)
Next (SaveMap)

Name
Save

Parent
IStrings

Visibility
PUBLIC

Source code
function Save : IPersistentStorage

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (LoadMapFromXML)
Next (SaveMap)


Previous (Save)
Next (SaveMapAsXML)

Name
SaveMap

Parent
IStrings

Visibility
PUBLIC

Source code
function SaveMap : IPersistentObject

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Save)
Next (SaveMapAsXML)


Previous (SaveMap)
Next (SaveToFile)

Name
SaveMapAsXML

Parent
IStrings

Visibility
PUBLIC

Source code
function SaveMapAsXML ( iDocument : IXMLDocument ; iNodeName : string ) : IXMLElement

Parameters
Parameter Description
iDocument : IXMLDocument
iNodeName : STRING

mAirListScript
Class Tree
Index
Previous (SaveMap)
Next (SaveToFile)


Previous (SaveMapAsXML)
Next (SetCommaText)

Name
SaveToFile

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SaveToFile ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (SaveMapAsXML)
Next (SetCommaText)


Previous (SaveToFile)
Next (SetItem)

Name
SetCommaText

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetCommaText ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SaveToFile)
Next (SetItem)


Previous (SetCommaText)
Next (SetSorted)

Name
SetItem

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetItem ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetCommaText)
Next (SetSorted)


Previous (SetItem)
Next (SetText)

Name
SetSorted

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetSorted ( iValue : boolean )

Parameters
Parameter Description
iValue : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetItem)
Next (SetText)


Previous (SetSorted)
Next (SetValue)

Name
SetText

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetText ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetSorted)
Next (SetValue)


Previous (SetText)
Next

Name
SetValue

Parent
IStrings

Visibility
PUBLIC

Source code
procedure SetValue ( iKey : string ; iValue : string )

Parameters
Parameter Description
iKey : STRING
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetText)
Next


Previous (IStrings)
Next (ITrackCueDataItem)

Name
IStubPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStrings)
Next (ITrackCueDataItem)


Previous (IStubPlaylistItem)
Next (IUpdateObject)

Name
ITrackCueDataItem

Parent
mAirListInterfaces

Class Hierarchy
ICueDataItem

Visibility
PUBLIC

Members
Methods
Method Description
GetArtists (+)
GetArtistsString (+)
GetTitle (+)
SetTitle (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IStubPlaylistItem)
Next (IUpdateObject)


Previous
Next (GetArtistsString)

Name
GetArtists

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetArtists : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetArtistsString)


Previous (GetArtists)
Next (GetTitle)

Name
GetArtistsString

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetArtistsString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtists)
Next (GetTitle)


Previous (GetArtistsString)
Next (SetTitle)

Name
GetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
function GetTitle : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetArtistsString)
Next (SetTitle)


Previous (GetTitle)
Next

Name
SetTitle

Parent
ITrackCueDataItem

Visibility
PUBLIC

Source code
procedure SetTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetTitle)
Next


Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)

Name
IUpdateObject

Parent
mAirListInterfaces

Class Hierarchy
IObservable

Visibility
PUBLIC

Members
Methods
Method Description
BeginRead (+)
BeginUpdate (+)
EndRead (+)
EndUpdate (+)
GetMessageHandle (+)
GetObjectClassDescription (+)
GetObjectClassID (+)
GetTempData (+)
GetUpdateState (+)
Invalidate (+)
SetSharedLock (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ITrackCueDataItem)
Next (IURLPlaylistItem)


Previous
Next (BeginUpdate)

Name
BeginRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeginUpdate)


Previous (BeginRead)
Next (EndRead)

Name
BeginUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure BeginUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginRead)
Next (EndRead)


Previous (BeginUpdate)
Next (EndUpdate)

Name
EndRead

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndRead

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeginUpdate)
Next (EndUpdate)


Previous (EndRead)
Next (GetMessageHandle)

Name
EndUpdate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure EndUpdate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndRead)
Next (GetMessageHandle)


Previous (EndUpdate)
Next (GetObjectClassDescription)

Name
GetMessageHandle

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetMessageHandle : TMessageHandle

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EndUpdate)
Next (GetObjectClassDescription)


Previous (GetMessageHandle)
Next (GetObjectClassID)

Name
GetObjectClassDescription

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassDescription : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessageHandle)
Next (GetObjectClassID)


Previous (GetObjectClassDescription)
Next (GetTempData)

Name
GetObjectClassID

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetObjectClassID : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassDescription)
Next (GetTempData)


Previous (GetObjectClassID)
Next (GetUpdateState)

Name
GetTempData

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetTempData : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetObjectClassID)
Next (GetUpdateState)


Previous (GetTempData)
Next (Invalidate)

Name
GetUpdateState

Parent
IUpdateObject

Visibility
PUBLIC

Source code
function GetUpdateState : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTempData)
Next (Invalidate)


Previous (GetUpdateState)
Next (SetSharedLock)

Name
Invalidate

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure Invalidate

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUpdateState)
Next (SetSharedLock)


Previous (Invalidate)
Next

Name
SetSharedLock

Parent
IUpdateObject

Visibility
PUBLIC

Source code
procedure SetSharedLock ( iValue : IMutex )

Parameters
Parameter Description
iValue : IMutex

mAirListScript
Class Tree
Index
Previous (Invalidate)
Next


Previous (IUpdateObject)
Next (IWritableStream)

Name
IURLPlaylistItem

Parent
mAirListInterfaces

Class Hierarchy
IPlaylistItem

Visibility
PUBLIC

Members
Methods
Method Description
GetURL (+)
SetURL (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IUpdateObject)
Next (IWritableStream)


Previous
Next (SetURL)

Name
GetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetURL)


Previous (GetURL)
Next

Name
SetURL

Parent
IURLPlaylistItem

Visibility
PUBLIC

Source code
procedure SetURL ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetURL)
Next


Previous (IURLPlaylistItem)
Next (TDatabaseNodeData)

Name
IWritableStream

Parent
mAirListInterfaces

Class Hierarchy
IStream

Visibility
PUBLIC

Members
Methods
Method Description
Append (+)
CopyFrom (+)
WRITE (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IURLPlaylistItem)
Next (TDatabaseNodeData)


Previous
Next (CopyFrom)

Name
Append

Parent
IWritableStream

Visibility
PUBLIC

Source code
function Append ( Buffer : pointer ; Count : Integer ) : Integer

Parameters
Parameter Description
Buffer : pointer
Count : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (CopyFrom)


Previous (Append)
Next (WRITE)

Name
CopyFrom

Parent
IWritableStream

Visibility
PUBLIC

Source code
procedure CopyFrom ( Source : IStream )

Parameters
Parameter Description
Source : IStream

mAirListScript
Class Tree
Index
Previous (Append)
Next (WRITE)


Previous (CopyFrom)
Next

Name
WRITE

Parent
IWritableStream

Visibility
PUBLIC

Source code
function Write ( Buffer : pointer ; Count : Longint ) : Longint

Parameters
Parameter Description
Buffer : pointer
Count : LONGINT

mAirListScript
Class Tree
Index
Previous (CopyFrom)
Next


Previous (IWritableStream)
Next

Name
TDatabaseNodeData

Parent
mAirListInterfaces

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Caption (*)
Data (*)
Database (*)
Duration (*)
ExpectChildren (*)
NodeType (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IWritableStream)
Next


Previous
Next (Data)

Name
Caption

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Caption : string

mAirListScript
Class Tree
Index
Previous
Next (Data)


Previous (Caption)
Next (Database)

Name
Data

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Data : string

mAirListScript
Class Tree
Index
Previous (Caption)
Next (Database)


Previous (Data)
Next (Duration)

Name
Database

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Database : IDatabase

mAirListScript
Class Tree
Index
Previous (Data)
Next (Duration)


Previous (Database)
Next (ExpectChildren)

Name
Duration

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
Duration : TTimeValue

mAirListScript
Class Tree
Index
Previous (Database)
Next (ExpectChildren)


Previous (Duration)
Next (NodeType)

Name
ExpectChildren

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
ExpectChildren : boolean

mAirListScript
Class Tree
Index
Previous (Duration)
Next (NodeType)


Previous (ExpectChildren)
Next

Name
NodeType

Parent
TDatabaseNodeData

Visibility
PUBLISHED

Source code
NodeType : TDatabaseTreeNodeType

mAirListScript
Class Tree
Index
Previous (ExpectChildren)
Next


Previous
Next (TMessageProc)

Name
IAudioSourceArray

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
IAudioSourceArray = array of IAudioSource ;

mAirListScript
Class Tree
Index
Previous
Next (TMessageProc)


Previous (IAudioSourceArray)
Next

Name
TMessageProc

Parent
mAirListInterfaces

Visibility
PUBLIC

Source code
TMessageProc = procedure ( iMessage : IBaseMessage ) of object ;

Parameters
Parameter Description
iMessage : IBaseMessage

mAirListScript
Class Tree
Index
Previous (IAudioSourceArray)
Next


Previous (mAirListInterfaces)
Next (mAirListTypes)

Name
mAirListScript

Parent
mAirListScript

Methods
Method | Description
ComPort (+)
Config (+) | Returns an IConfiguration interface representing the configuration
CreateContainerPlaylistItem (+)
CreateEmptyPlaylist (+)
CreateFilePlaylistItem (+)
CreatePlaylist (+)
CreatePlaylistFromFile (+)
CreatePlaylistItemFromFile (+) | Creates a playlist item from the given file.
CreatePlaylistItemFromXMLString (+)
CurrentDatabase (+)
CurrentPlaybackControl (+)
CurrentPlaylist (+)
Database (+)
DatabaseCount (+)
Encoder (+)
Engine (+)
ExecuteCommand (+)
ExecuteCommandRPC (+)
Factory (+) | Return a reference to the Factory object which is used to create new
FakeNow (+) | Returns the (possibly faked) time of the internal mAirList clock.
HTTPGet (+)
HTTPGetAsync (+)
HTTPPost (+)
HTTPPostAsync (+)
Instance (+)
IOPort (+)
IOWarriorRemote (+)
ISOWeek (+) | Calculates the week number according to ISO 8601.
MidiOut (+)
MidiOutGetNumDevs (+)
MidiOutListDevices (+)
Mixer (+)
MixerCount (+)
NotifyConnect (+) | Notifies the GUI that the database connection has been established.
NotifyDisconnect (+) | Notifies the GUI that the database connection has been closed.
PlaybackControl (+)
Playlist (+)
PlaylistCount (+)
Random (+)
RunScript (+)
SASRemote (+)
SelectDatabase (+)
SelectPlaylist (+)
SetApplicationTitle (+)
SetWMClientOutput (+)
ShellExecute (+)
ShellExecuteHidden (+)
SystemLog (+)
URLEncode (+) | Encode a string so that it can by safely used as a parameter inside an
_FindFiles (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListInterfaces)
Next (mAirListTypes)


Previous
Next (Config)

Name
ComPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function ComPort ( iPort : string ) : IComPort

Parameters
Parameter Description
iPort : STRING

mAirListScript
Class Tree
Index
Previous
Next (Config)


Previous (ComPort)
Next (CreateContainerPlaylistItem)

Name
Config

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns an IConfiguration interface representing the configuration
of this mAirList instance.

Source code
function Config : IConfiguration

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ComPort)
Next (CreateContainerPlaylistItem)


Previous (Config)
Next (CreateEmptyPlaylist)

Name
CreateContainerPlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateContainerPlaylistItem : IContainerPlaylistItem

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Config)
Next (CreateEmptyPlaylist)


Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)

Name
CreateEmptyPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateEmptyPlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateContainerPlaylistItem)
Next (CreateFilePlaylistItem)


Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)

Name
CreateFilePlaylistItem

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreateFilePlaylistItem ( iFilename : string ; iLoadData : boolean ) : IFilePlaylistItem

Parameters
Parameter Description
iFilename : STRING
iLoadData : BOOLEAN

mAirListScript
Class Tree
Index
Previous (CreateEmptyPlaylist)
Next (CreatePlaylist)


Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)

Name
CreatePlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylist : IPlaylist

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateFilePlaylistItem)
Next (CreatePlaylistFromFile)


Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)

Name
CreatePlaylistFromFile

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistFromFile ( iFilename : string ) : IPlaylist

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylist)
Next (CreatePlaylistItemFromFile)


Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)

Name
CreatePlaylistItemFromFile

Parent
mAirListScript

Visibility
PUBLIC

Description
Creates a playlist item from the given file.

Source code
function CreatePlaylistItemFromFile ( iFilename : string ; iLoadData : boolean ) : IPlaylistItem

Parameters
Parameter | Description
iFilename : STRING | The name of the file to load.
iLoadData : BOOLEAN | If set to true, file tags and/or MMD will be loaded.

mAirListScript
Class Tree
Index
Previous (CreatePlaylistFromFile)
Next (CreatePlaylistItemFromXMLString)


Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)

Name
CreatePlaylistItemFromXMLString

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CreatePlaylistItemFromXMLString ( iXML : string ) : IPlaylistItem

Parameters
Parameter Description
iXML : STRING

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromFile)
Next (CurrentDatabase)


Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)

Name
CurrentDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentDatabase : IDatabase

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreatePlaylistItemFromXMLString)
Next (CurrentPlaybackControl)


Previous (CurrentDatabase)
Next (CurrentPlaylist)

Name
CurrentPlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaybackControl : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentDatabase)
Next (CurrentPlaylist)


Previous (CurrentPlaybackControl)
Next (Database)

Name
CurrentPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function CurrentPlaylist : IPlaybackControl

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CurrentPlaybackControl)
Next (Database)


Previous (CurrentPlaylist)
Next (DatabaseCount)

Name
Database

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Database ( iIndex : integer ) : IDatabase

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (CurrentPlaylist)
Next (DatabaseCount)


Previous (Database)
Next (Encoder)

Name
DatabaseCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function DatabaseCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Database)
Next (Encoder)


Previous (DatabaseCount)
Next (Engine)

Name
Encoder

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Encoder : IBassStreamingEncoder

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DatabaseCount)
Next (Engine)


Previous (Encoder)
Next (ExecuteCommand)

Name
Engine

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Engine : IEngine

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Encoder)
Next (ExecuteCommand)


Previous (Engine)
Next (ExecuteCommandRPC)

Name
ExecuteCommand

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommand ( iCommand : string )

Parameters
Parameter Description
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (Engine)
Next (ExecuteCommandRPC)


Previous (ExecuteCommand)
Next (Factory)

Name
ExecuteCommandRPC

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ExecuteCommandRPC ( iURL , iCommand : string )

Parameters
Parameter Description
iURL : STRING
iCommand : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteCommand)
Next (Factory)


Previous (ExecuteCommandRPC)
Next (FakeNow)

Name
Factory

Parent
mAirListScript

Visibility
PUBLIC

Description
Return a reference to the Factory object which is used to create new
playlist items etc. (see IFactory).

Source code
function Factory : IFactory

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteCommandRPC)
Next (FakeNow)


Previous (Factory)
Next (HTTPGet)

Name
FakeNow

Parent
mAirListScript

Visibility
PUBLIC

Description
Returns the (possibly faked) time of the internal mAirList clock.

Source code
function FakeNow : TDateTime

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Factory)
Next (HTTPGet)


Previous (FakeNow)
Next (HTTPGetAsync)

Name
HTTPGet

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPGet ( iURL : string ) : string

Parameters
Parameter Description
iURL : STRING

mAirListScript
Class Tree
Index
Previous (FakeNow)
Next (HTTPGetAsync)


Previous (HTTPGet)
Next (HTTPPost)

Name
HTTPGetAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPGetAsync ( iURL : string )

Parameters
Parameter Description
iURL : STRING

mAirListScript
Class Tree
Index
Previous (HTTPGet)
Next (HTTPPost)


Previous (HTTPGetAsync)
Next (HTTPPostAsync)

Name
HTTPPost

Parent
mAirListScript

Visibility
PUBLIC

Source code
function HTTPPost ( iURL : string ; iData : string ) : string

Parameters
Parameter Description
iURL : STRING
iData : STRING

mAirListScript
Class Tree
Index
Previous (HTTPGetAsync)
Next (HTTPPostAsync)


Previous (HTTPPost)
Next (Instance)

Name
HTTPPostAsync

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure HTTPPostAsync ( iURL : string ; iData : string )

Parameters
Parameter Description
iURL : STRING
iData : STRING

mAirListScript
Class Tree
Index
Previous (HTTPPost)
Next (Instance)


Previous (HTTPPostAsync)
Next (IOPort)

Name
Instance

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Instance : IInstanceData

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (HTTPPostAsync)
Next (IOPort)


Previous (Instance)
Next (IOWarriorRemote)

Name
IOPort

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOPort ( iPort : word ) : IIOPort

Parameters
Parameter Description
iPort : WORD

mAirListScript
Class Tree
Index
Previous (Instance)
Next (IOWarriorRemote)


Previous (IOPort)
Next (ISOWeek)

Name
IOWarriorRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function IOWarriorRemote ( iIndex : integer ) : IIOWarriorRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (IOPort)
Next (ISOWeek)


Previous (IOWarriorRemote)
Next (MidiOut)

Name
ISOWeek

Parent
mAirListScript

Visibility
PUBLIC

Description
Calculates the week number according to ISO 8601.

Source code
function ISOWeek ( DateTime : TDateTime ) : integer

Parameters
Parameter | Description
DateTime : TDateTime | The date for which the week number shall be calculated.

mAirListScript
Class Tree
Index
Previous (IOWarriorRemote)
Next (MidiOut)


Previous (ISOWeek)
Next (MidiOutGetNumDevs)

Name
MidiOut

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOut ( iDevice : integer ; iStatus , iData1 , iData2 : byte )

Parameters
Parameter Description
iDevice : INTEGER
iStatus : BYTE
iData1 : BYTE
iData2 : BYTE

mAirListScript
Class Tree
Index
Previous (ISOWeek)
Next (MidiOutGetNumDevs)


Previous (MidiOut)
Next (MidiOutListDevices)

Name
MidiOutGetNumDevs

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MidiOutGetNumDevs : cardinal

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOut)
Next (MidiOutListDevices)


Previous (MidiOutGetNumDevs)
Next (Mixer)

Name
MidiOutListDevices

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure MidiOutListDevices

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MidiOutGetNumDevs)
Next (Mixer)


Previous (MidiOutListDevices)
Next (MixerCount)

Name
Mixer

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Mixer ( iIndex : integer ) : IMixer

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (MidiOutListDevices)
Next (MixerCount)


Previous (Mixer)
Next (NotifyConnect)

Name
MixerCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function MixerCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Mixer)
Next (NotifyConnect)


Previous (MixerCount)
Next (NotifyDisconnect)

Name
NotifyConnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been established.
Only available in database scripts.

Source code
procedure NotifyConnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MixerCount)
Next (NotifyDisconnect)


Previous (NotifyConnect)
Next (PlaybackControl)

Name
NotifyDisconnect

Parent
mAirListScript

Visibility
PUBLIC

Description
Notifies the GUI that the database connection has been closed.
Only available in database scripts.

Source code
procedure NotifyDisconnect

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NotifyConnect)
Next (PlaybackControl)


Previous (NotifyDisconnect)
Next (Playlist)

Name
PlaybackControl

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaybackControl ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (NotifyDisconnect)
Next (Playlist)


Previous (PlaybackControl)
Next (PlaylistCount)

Name
Playlist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Playlist ( iIndex : integer ) : IPlaybackControl

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (PlaybackControl)
Next (PlaylistCount)


Previous (Playlist)
Next (Random)

Name
PlaylistCount

Parent
mAirListScript

Visibility
PUBLIC

Source code
function PlaylistCount : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Playlist)
Next (Random)


Previous (PlaylistCount)
Next (RunScript)

Name
Random

Parent
mAirListScript

Visibility
PUBLIC

Source code
function Random ( iRange : integer ) : integer

Parameters
Parameter Description
iRange : INTEGER

mAirListScript
Class Tree
Index
Previous (PlaylistCount)
Next (RunScript)


Previous (Random)
Next (SASRemote)

Name
RunScript

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure RunScript ( iFilename : string )

Parameters
Parameter Description
iFilename : STRING

mAirListScript
Class Tree
Index
Previous (Random)
Next (SASRemote)


Previous (RunScript)
Next (SelectDatabase)

Name
SASRemote

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SASRemote ( iIndex : integer ) : ISASRemote

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (RunScript)
Next (SelectDatabase)


Previous (SASRemote)
Next (SelectPlaylist)

Name
SelectDatabase

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectDatabase ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (SASRemote)
Next (SelectPlaylist)


Previous (SelectDatabase)
Next (SetApplicationTitle)

Name
SelectPlaylist

Parent
mAirListScript

Visibility
PUBLIC

Source code
function SelectPlaylist ( iIndex : integer ) : boolean

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (SelectDatabase)
Next (SetApplicationTitle)


Previous (SelectPlaylist)
Next (SetWMClientOutput)

Name
SetApplicationTitle

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetApplicationTitle ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SelectPlaylist)
Next (SetWMClientOutput)


Previous (SetApplicationTitle)
Next (ShellExecute)

Name
SetWMClientOutput

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SetWMClientOutput ( iIndex , iNumber , iValue : integer )

Parameters
Parameter Description
iIndex : INTEGER
iNumber : INTEGER
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetApplicationTitle)
Next (ShellExecute)


Previous (SetWMClientOutput)
Next (ShellExecuteHidden)

Name
ShellExecute

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecute ( iProgram , iParameters : string )

Parameters
Parameter Description
iProgram : STRING
iParameters : STRING

mAirListScript
Class Tree
Index
Previous (SetWMClientOutput)
Next (ShellExecuteHidden)


Previous (ShellExecute)
Next (SystemLog)

Name
ShellExecuteHidden

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure ShellExecuteHidden ( iProgram , iParameters : string )

Parameters
Parameter Description
iProgram : STRING
iParameters : STRING

mAirListScript
Class Tree
Index
Previous (ShellExecute)
Next (SystemLog)


Previous (ShellExecuteHidden)
Next (URLEncode)

Name
SystemLog

Parent
mAirListScript

Visibility
PUBLIC

Source code
procedure SystemLog ( iMessage : string )

Parameters
Parameter Description
iMessage : STRING

mAirListScript
Class Tree
Index
Previous (ShellExecuteHidden)
Next (URLEncode)


Previous (SystemLog)
Next (_FindFiles)

Name
URLEncode

Parent
mAirListScript

Visibility
PUBLIC

Description
Encode a string so that it can by safely used as a parameter inside an
HTTP request URL.

Source code
function URLEncode ( iString : string ) : string

Parameters
Parameter | Description
iString : STRING | The string to encode.

mAirListScript
Class Tree
Index
Previous (SystemLog)
Next (_FindFiles)


Previous (URLEncode)
Next

Name
_FindFiles

Parent
mAirListScript

Visibility
PUBLIC

Source code
function _FindFiles ( iPattern : string ; iRecursive : boolean ) : IStrings

Parameters
Parameter Description
iPattern : STRING
iRecursive : BOOLEAN

mAirListScript
Class Tree
Index
Previous (URLEncode)
Next


Previous (mAirListScript)
Next (MidiInterface)

Name
mAirListTypes

Parent
mAirListScript

Types
Type Description
TAudioDeviceType (+)
TAudioSourceCapabilities (+)
TAudioSourceCapability (+)
TAudioSourceOption (+)
TAudioSourceOptions (+)
TAutoFillMethod (+)
TCalculatedDurationType (+)
TCartwallControlOption (+)
TCartwallControlOptions (+)
TCuePositionCategory (+)
TCuePositionChangedDetail (+)
TCuePositionChangedDetails (+)
TCuePositions (+)
TCuePositionType (+)
TCuePositionTypes (+)
TDatabaseCapabilities (+)
TDatabaseCapability (+)
TDatabaseState (+)
TDatabaseTreeNodeType (+)
TDatabaseTreeNodeTypes (+)
TDefaultDirectory (+)
TEngineOption (+)
TEngineOptions (+)
TFileImportOption (+)
TFileImportOptions (+)
TFileImportTask (+)
TFileImportTasks (+)
TFileLocationType (+)
TFileManagementOption (+)
TFileManagementOptions (+)
TFileTypeHandlerCapabilities (+)
TFileTypeHandlerCapability (+)
TGlobalOption (+)
TGlobalOptions (+)
THourFilter (+)
TIntegerArray (+)
TLevelArray (+)
TLogCategories (+)
TLogCategory (+)
TmAirListFeature (+)
TmAirListFeatures (+)
TMessageHandle (+)
TObjectID (+)
TPeakAnalyzerState (+)
TPeakData (+)
TPersistentType (+)
TPlaybackControlOption (+)
TPlaybackControlOptions (+)
TPlaybackDeviceCapabilities (+)
TPlaybackDeviceCapability (+)
TPlaybackState (+)
TPlayerCommand (+)
TPlayerControlOption (+)
TPlayerControlOptions (+)
TPlayerState (+)
TPlayerStates (+)
TPlayerType (+)
TPlaylistItemCapabilities (+)
TPlaylistItemCapability (+)
TPlaylistItemCategory (+)
TPlaylistItemData (+)
TPlaylistItemDataFilter (+)
TPlaylistItemFlag (+)
TPlaylistItemFlags (+)
TPlaylistItemOption (+)
TPlaylistItemOptions (+)
TPlaylistItemState (+)
TPlaylistItemStatusFlag (+)
TPlaylistItemStatusFlags (+)
TPlaylistItemType (+)
TPlaylistItemTypes (+)
TRegion (+)
TRegions (+)
TRepositoryItem (+)
TRunMode (+)
TSampleFormat (+)
TSetOfByte (+)
TSingleArray (+)
TSkipRetryAbort (+)
TSourceControlOption (+)
TSourceControlOptions (+)
TSourceControlState (+)
TStandardActionList (+)
TStartTimeType (+)
TTimeValue (+)
TTimeValueArray (+)
TTiming (+)
TWeekdayHourFilter (+)

Constants
Constant Description
AllCuePositionTypes (+)
AllFileImportTasks (+)
AllLogCategories (+)
AllPlaylistItemChangedDetails (+)
AllPlaylistItemTypes (+)
AutoCuePositions (+)
CartPlayerCommands (+)
ccBASS (+)
ccCustom (+)
ccDatabase (+)
ccDefaultDirectories (+)
ccDemoLicense (+)
ccDevices (+)
ccEncoder (+)
ccGUI (+)
ccLayout (+)
ccLicense (+)
ccLogging (+)
ccMain (+)
ccMixdown (+)
ccPasswords (+)
ccPosition (+)
ccPreferences (+)
ccRemote (+)
ccScreenObjects (+)
ccSerial (+)
cdADCAssignment (+)
cdADCNodes (+)
cdBLContent (+)
cdCOGeneral (+)
cdCORestartCritical (+)
cdCOStatus (+)
cdDBConnectionDetails (+)
cdDBOther (+)
cdDBState (+)
cdForceUpdate (+)
cdMDBacktiming (+)
cdMDFlags (+)
cdMDGeneral (+)
cdMDLink (+)
cdMDState (+)
cdMDStatus (+)
cdMDTiming (+)
cdPCAllowAutomation (+)
cdPCAutomation (+)
cdPCAutomationPlaying (+)
cdPCOptions (+)
cdPCPlayerAssignment (+)
cdPCPlayerCount (+)
cdPIBacktimingStatus (+)
cdPIColor (+)
cdPIComment (+)
cdPIContent (+)
cdPICueData (+)
cdPIDuration (+)
cdPIHistoryFlag (+)
cdPIIcon (+)
cdPIItemData (+)
cdPILinked (+)
cdPIMetadata (+)
cdPIOther (+)
cdPIPitch (+)
cdPIPositionAlternatives (+)
cdPIPositionValue (+)
cdPIStartTimes (+)
cdPItem (+)
cdPITempo (+)
cdPIUnknown (+)
cdPIVolumeEnvelope (+)
cdPLBacktiming (+)
cdPLevelInfo (+)
cdPOptions (+)
cdPOther (+)
cdPVolume (+)
cdSCVolume (+)
ConfigTimePlaybackControlOptions (+)
DefaultCartPlayerControlOptions (+)
DefaultCartwallControlOptions (+)
DefaultEngineOptions (+)
DefaultFeatures (+)
DefaultFileImportOptions (+)
DefaultFileManagementOptions (+)
DefaultGlobalOptions (+)
DefaultPlaybackControlOptions (+)
DefaultPlayerControlOptions (+)
MAX_REGION (+)
MIN_DB (+)
MIN_REGION (+)
NoObjectID (+)
ntArtist (+)
ntArtistRoot (+)
ntAttribute (+)
ntAttributeRoot (+)
ntAttributeValue (+)
ntCustom (+)
ntFolder (+)
ntFolderRoot (+)
ntItem (+)
ntPlaylist (+)
ntPlaylistRoot (+)
ntRoot (+)
ntText (+)
ntType (+)
ntTypeRoot (+)
OrdinaryPlayerCommands (+)
PEAKDATA_LENGTH (+)
RuntimeCartPlayerControlOptions (+)
RuntimeOrdinaryPlayerControlOptions (+)

Classes
Class Description
ELicenseError (+)
EMessage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListScript)
Next (MidiInterface)


Previous
Next (EMessage)

Name
ELicenseError

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (EMessage)


Previous (ELicenseError)
Next

Name
EMessage

Parent
mAirListTypes

Class Hierarchy
Exception

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ELicenseError)
Next


Previous
Next (TAudioSourceCapabilities)

Name
TAudioDeviceType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioDeviceType = ( adtPlayback , adtRecording ) ;

mAirListScript
Class Tree
Index
Previous
Next (TAudioSourceCapabilities)


Previous (TAudioDeviceType)
Next (TAudioSourceCapability)

Name
TAudioSourceCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceCapabilities = set of TAudioSourceCapability ;

mAirListScript
Class Tree
Index
Previous (TAudioDeviceType)
Next (TAudioSourceCapability)


Previous (TAudioSourceCapabilities)
Next (TAudioSourceOption)

Name
TAudioSourceCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceCapability = ( ascCueable , ascDynamicTitle , ascCueMode ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceCapabilities)
Next (TAudioSourceOption)


Previous (TAudioSourceCapability)
Next (TAudioSourceOptions)

Name
TAudioSourceOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOption = ( asoLogging , asoWorkActionLists ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceCapability)
Next (TAudioSourceOptions)


Previous (TAudioSourceOption)
Next (TAutoFillMethod)

Name
TAudioSourceOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAudioSourceOptions = set of TAudioSourceOption ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOption)
Next (TAutoFillMethod)


Previous (TAudioSourceOptions)
Next (TCalculatedDurationType)

Name
TAutoFillMethod

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TAutoFillMethod = ( afmNone , afmSilence ) ;

mAirListScript
Class Tree
Index
Previous (TAudioSourceOptions)
Next (TCalculatedDurationType)


Previous (TAutoFillMethod)
Next (TCartwallControlOption)

Name
TCalculatedDurationType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCalculatedDurationType = ( cdtTotal , cdtRemaining , cdtUnderrun ) ;

mAirListScript
Class Tree
Index
Previous (TAutoFillMethod)
Next (TCartwallControlOption)


Previous (TCalculatedDurationType)
Next (TCartwallControlOptions)

Name
TCartwallControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallControlOption = ( cwcoSaveWithDesktop , cwcoSaveWithTemplate , cwcoKeepOpen , cwcoLogging , cwcoIndependentPFL , cwcoIndependentPFLEndMon , cwcoAutoPFLOff , cwcoAutoFadeOut , cwcoResetLoop , cwcoResetHook ) ;

mAirListScript
Class Tree
Index
Previous (TCalculatedDurationType)
Next (TCartwallControlOptions)


Previous (TCartwallControlOption)
Next (TCuePositionCategory)

Name
TCartwallControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCartwallControlOptions = set of TCartwallControlOption ;

mAirListScript
Class Tree
Index
Previous (TCartwallControlOption)
Next (TCuePositionCategory)


Previous (TCartwallControlOptions)
Next (TCuePositionChangedDetail)

Name
TCuePositionCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionCategory = ( cpcCueIn , cpcRamp , cpcHook , cpcOutro , cpcStartNext , cpcFadeOut , cpcCueOut , cpcMisc ) ;

mAirListScript
Class Tree
Index
Previous (TCartwallControlOptions)
Next (TCuePositionChangedDetail)


Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)

Name
TCuePositionChangedDetail

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetail = ( cdCPValue , cdCPAlternatives ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositionCategory)
Next (TCuePositionChangedDetails)


Previous (TCuePositionChangedDetail)
Next (TCuePositions)

Name
TCuePositionChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionChangedDetails = set of TCuePositionChangedDetail ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetail)
Next (TCuePositions)


Previous (TCuePositionChangedDetails)
Next (TCuePositionType)

Name
TCuePositions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositions = array [ TCuePositionType ] of TTimeValue ;

mAirListScript
Class Tree
Index
Previous (TCuePositionChangedDetails)
Next (TCuePositionType)


Previous (TCuePositions)
Next (TCuePositionTypes)

Name
TCuePositionType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionType = ( ptCueIn , ptRamp1 , ptRamp2 , ptRamp3 , ptHookIn , ptHookFade , ptHookOut , ptOutro , ptStartNext , ptFadeOut , ptCueOut , ptAnchor ) ;

mAirListScript
Class Tree
Index
Previous (TCuePositions)
Next (TCuePositionTypes)


Previous (TCuePositionType)
Next (TDatabaseCapabilities)

Name
TCuePositionTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TCuePositionTypes = set of TCuePositionType ;

mAirListScript
Class Tree
Index
Previous (TCuePositionType)
Next (TDatabaseCapabilities)


Previous (TCuePositionTypes)
Next (TDatabaseCapability)

Name
TDatabaseCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapabilities = set of TDatabaseCapability ;

mAirListScript
Class Tree
Index
Previous (TCuePositionTypes)
Next (TDatabaseCapability)


Previous (TDatabaseCapabilities)
Next (TDatabaseState)

Name
TDatabaseCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseCapability = ( dcUpdateItem , dcReverseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapabilities)
Next (TDatabaseState)


Previous (TDatabaseCapability)
Next (TDatabaseTreeNodeType)

Name
TDatabaseState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseState = ( dsDisconnected , dsConnecting , dsConnected ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseCapability)
Next (TDatabaseTreeNodeType)


Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)

Name
TDatabaseTreeNodeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeType = byte ;

mAirListScript
Class Tree
Index
Previous (TDatabaseState)
Next (TDatabaseTreeNodeTypes)


Previous (TDatabaseTreeNodeType)
Next (TDefaultDirectory)

Name
TDatabaseTreeNodeTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDatabaseTreeNodeTypes = set of TDatabaseTreeNodeType ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeType)
Next (TDefaultDirectory)


Previous (TDatabaseTreeNodeTypes)
Next (TEngineOption)

Name
TDefaultDirectory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TDefaultDirectory = ( ddAddDirectoryBrowser , ddAddPlaylistBrowser , ddCartwallLoad , ddCartwallSave , ddExportDatabase , ddImportDatabase , ddInsertFiles , ddLoadHourTemplate , ddOpenPlaylist , ddOpenDesktop , ddRunScript , ddSaveDesktop , ddSaveHourTemplate , ddSavePlaylist , ddSelectIcon , ddSchedulerLoadList , ddSchedulerSaveList ) ;

mAirListScript
Class Tree
Index
Previous (TDatabaseTreeNodeTypes)
Next (TEngineOption)


Previous (TDefaultDirectory)
Next (TEngineOptions)

Name
TEngineOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOption = ( eoDummy ) ;

mAirListScript
Class Tree
Index
Previous (TDefaultDirectory)
Next (TEngineOptions)


Previous (TEngineOption)
Next (TFileImportOption)

Name
TEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TEngineOptions = set of TEngineOption ;

mAirListScript
Class Tree
Index
Previous (TEngineOption)
Next (TFileImportOption)


Previous (TEngineOptions)
Next (TFileImportOptions)

Name
TFileImportOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOption = ( fioImportComment , fioImportTags , fioImportArtwork , fioVorbisDateAsYear , fioMP2OutroAsFadeOut , fioTildeAsStartNext , fioTildeAsOutro , fioTildeAsFadeOut , fioStripWhitespace , fioImportReplayGain , fioReplayGainAlbum , fioReplayGainPreventClipping , fioArtistTitleFromFilename , fioFilenameAsExternalID ) ;

mAirListScript
Class Tree
Index
Previous (TEngineOptions)
Next (TFileImportOptions)


Previous (TFileImportOption)
Next (TFileImportTask)

Name
TFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportOptions = set of TFileImportOption ;

mAirListScript
Class Tree
Index
Previous (TFileImportOption)
Next (TFileImportTask)


Previous (TFileImportOptions)
Next (TFileImportTasks)

Name
TFileImportTask

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTask = ( fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitDatabaseLookup ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportOptions)
Next (TFileImportTasks)


Previous (TFileImportTask)
Next (TFileLocationType)

Name
TFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileImportTasks = set of TFileImportTask ;

mAirListScript
Class Tree
Index
Previous (TFileImportTask)
Next (TFileLocationType)


Previous (TFileImportTasks)
Next (TFileManagementOption)

Name
TFileLocationType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileLocationType = ( fltLocal , fltNetwork , fltDatabase , fltRAM , fltEmpty ) ;

mAirListScript
Class Tree
Index
Previous (TFileImportTasks)
Next (TFileManagementOption)


Previous (TFileLocationType)
Next (TFileManagementOptions)

Name
TFileManagementOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOption = ( fmoCacheNetworkFiles , fmoLockFiles ) ;

mAirListScript
Class Tree
Index
Previous (TFileLocationType)
Next (TFileManagementOptions)


Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)

Name
TFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileManagementOptions = set of TFileManagementOption ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOption)
Next (TFileTypeHandlerCapabilities)


Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)

Name
TFileTypeHandlerCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapabilities = set of TFileTypeHandlerCapability ;

mAirListScript
Class Tree
Index
Previous (TFileManagementOptions)
Next (TFileTypeHandlerCapability)


Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)

Name
TFileTypeHandlerCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TFileTypeHandlerCapability = ( fthcReadDuration , fthcReadTags , fthcWriteTags , fthcReadNativeTags , fthcGetTagData ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapabilities)
Next (TGlobalOption)


Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)

Name
TGlobalOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOption = ( goStartNextEffectiveEnd , goFadeOutEffectiveEnd , goFadeOutToCueOut , goOutroEOFWarning , goOnlyOneInstance , goStartOnAir , goNoLoggingOffAir , goSplashScreen , goRemotesForTagging , goDebugMode , goCompat3x , goFailsafeContainers ) ;

mAirListScript
Class Tree
Index
Previous (TFileTypeHandlerCapability)
Next (TGlobalOptions)


Previous (TGlobalOption)
Next (THourFilter)

Name
TGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TGlobalOptions = set of TGlobalOption ;

mAirListScript
Class Tree
Index
Previous (TGlobalOption)
Next (THourFilter)


Previous (TGlobalOptions)
Next (TIntegerArray)

Name
THourFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
THourFilter = array [ 0 .. 23 ] of boolean ;

mAirListScript
Class Tree
Index
Previous (TGlobalOptions)
Next (TIntegerArray)


Previous (THourFilter)
Next (TLevelArray)

Name
TIntegerArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TIntegerArray = array of integer ;

mAirListScript
Class Tree
Index
Previous (THourFilter)
Next (TLevelArray)


Previous (TIntegerArray)
Next (TLogCategories)

Name
TLevelArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLevelArray = array of single ;

mAirListScript
Class Tree
Index
Previous (TIntegerArray)
Next (TLogCategories)


Previous (TLevelArray)
Next (TLogCategory)

Name
TLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategories = set of TLogCategory ;

mAirListScript
Class Tree
Index
Previous (TLevelArray)
Next (TLogCategory)


Previous (TLogCategories)
Next (TmAirListFeature)

Name
TLogCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TLogCategory = ( lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategories)
Next (TmAirListFeature)


Previous (TLogCategory)
Next (TmAirListFeatures)

Name
TmAirListFeature

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeature = ( mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfDirectoryContextMenu , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ) ;

mAirListScript
Class Tree
Index
Previous (TLogCategory)
Next (TmAirListFeatures)


Previous (TmAirListFeature)
Next (TMessageHandle)

Name
TmAirListFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TmAirListFeatures = set of TmAirListFeature ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeature)
Next (TMessageHandle)


Previous (TmAirListFeatures)
Next (TObjectID)

Name
TMessageHandle

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TMessageHandle = cardinal ;

mAirListScript
Class Tree
Index
Previous (TmAirListFeatures)
Next (TObjectID)


Previous (TMessageHandle)
Next (TPeakAnalyzerState)

Name
TObjectID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TObjectID = int64 ;

mAirListScript
Class Tree
Index
Previous (TMessageHandle)
Next (TPeakAnalyzerState)


Previous (TObjectID)
Next (TPeakData)

Name
TPeakAnalyzerState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPeakAnalyzerState = ( pasUninitialized , pasReady , pasError ) ;

mAirListScript
Class Tree
Index
Previous (TObjectID)
Next (TPeakData)


Previous (TPeakAnalyzerState)
Next (TPersistentType)

Name
TPeakData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPeakData = array [ 0 .. PEAKDATA_LENGTH - 1 ] of single ;

mAirListScript
Class Tree
Index
Previous (TPeakAnalyzerState)
Next (TPersistentType)


Previous (TPeakData)
Next (TPlaybackControlOption)

Name
TPersistentType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPersistentType = ( ptNull , ptNumber , ptInteger , ptString , ptBoolean , ptDateTime , ptArray , ptObject ) ;

mAirListScript
Class Tree
Index
Previous (TPeakData)
Next (TPlaybackControlOption)


Previous (TPersistentType)
Next (TPlaybackControlOptions)

Name
TPlaybackControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOption = ( plcoAllowAutomation , plcoAutomationSinglePlayer , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoCleanUpNonPlayables , plcoSaveEvents , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime , plcoFixedTimeWaitHard , plcoFixedTimeWaitSoft , plcoLiveBacktiming ) ;

mAirListScript
Class Tree
Index
Previous (TPersistentType)
Next (TPlaybackControlOptions)


Previous (TPlaybackControlOption)
Next (TPlaybackDeviceCapabilities)

Name
TPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackControlOptions = set of TPlaybackControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOption)
Next (TPlaybackDeviceCapabilities)


Previous (TPlaybackControlOptions)
Next (TPlaybackDeviceCapability)

Name
TPlaybackDeviceCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackDeviceCapabilities = set of TPlaybackDeviceCapability ;

mAirListScript
Class Tree
Index
Previous (TPlaybackControlOptions)
Next (TPlaybackDeviceCapability)


Previous (TPlaybackDeviceCapabilities)
Next (TPlaybackState)

Name
TPlaybackDeviceCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackDeviceCapability = ( pdcMultiRegion ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackDeviceCapabilities)
Next (TPlaybackState)


Previous (TPlaybackDeviceCapability)
Next (TPlayerCommand)

Name
TPlaybackState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaybackState = ( pbsNone , pbsBuffered , pbsPlaying , pbsPaused , pbsFading , pbsEOF , pbsError ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackDeviceCapability)
Next (TPlayerCommand)


Previous (TPlaybackState)
Next (TPlayerControlOption)

Name
TPlayerCommand

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerCommand = ( pcNone , pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose , pcNext , pcPrevious ) ;

mAirListScript
Class Tree
Index
Previous (TPlaybackState)
Next (TPlayerControlOption)


Previous (TPlayerCommand)
Next (TPlayerControlOptions)

Name
TPlayerControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOption = ( poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerCommand)
Next (TPlayerControlOptions)


Previous (TPlayerControlOption)
Next (TPlayerState)

Name
TPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerControlOptions = set of TPlayerControlOption ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOption)
Next (TPlayerState)


Previous (TPlayerControlOptions)
Next (TPlayerStates)

Name
TPlayerState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerState = ( psEmpty , psLoading , psLoaded , psPlaying , psFading , psEOF , psError , psPaused , psStopped , psPFL , psFlashEOF , psNext , psHistory , psOverflow , psUnderrun , psRegion ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerControlOptions)
Next (TPlayerStates)


Previous (TPlayerState)
Next (TPlayerType)

Name
TPlayerStates

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerStates = set of TPlayerState ;

mAirListScript
Class Tree
Index
Previous (TPlayerState)
Next (TPlayerType)


Previous (TPlayerStates)
Next (TPlaylistItemCapabilities)

Name
TPlayerType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlayerType = ( ptOrdinaryPlayer , ptCartPlayer , ptPFLPlayer , ptErrorCheck ) ;

mAirListScript
Class Tree
Index
Previous (TPlayerStates)
Next (TPlaylistItemCapabilities)


Previous (TPlayerType)
Next (TPlaylistItemCapability)

Name
TPlaylistItemCapabilities

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapabilities = set of TPlaylistItemCapability ;

mAirListScript
Class Tree
Index
Previous (TPlayerType)
Next (TPlaylistItemCapability)


Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)

Name
TPlaylistItemCapability

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCapability = ( picPlayable , picCueable , picEditDuration , picAutoCue , picPersistentCueData ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapabilities)
Next (TPlaylistItemCategory)


Previous (TPlaylistItemCapability)
Next (TPlaylistItemData)

Name
TPlaylistItemCategory

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemCategory = ( picFile , picStream , picBreak , picCommand , picContainer , picDummy , picOther ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCapability)
Next (TPlaylistItemData)


Previous (TPlaylistItemCategory)
Next (TPlaylistItemDataFilter)

Name
TPlaylistItemData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemData = ( pidArtist , pidTitle , pidDuration , pidItemType , pidFilename , pidAttributes , pidInlineData , pidDatabaseLink , pidComment , pidCueData , pidChildElements , pidFadeDuration , pidAmplification , pidEndType , pidColor , pidIcon , pidPitch , pidTempo , pidExternalID , pidTiming , pidCustomizationFlag ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemCategory)
Next (TPlaylistItemDataFilter)


Previous (TPlaylistItemData)
Next (TPlaylistItemFlag)

Name
TPlaylistItemDataFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemDataFilter = set of TPlaylistItemData ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemData)
Next (TPlaylistItemFlag)


Previous (TPlaylistItemDataFilter)
Next (TPlaylistItemFlags)

Name
TPlaylistItemFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemFlag = ( pifDummy ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemDataFilter)
Next (TPlaylistItemFlags)


Previous (TPlaylistItemFlag)
Next (TPlaylistItemOption)

Name
TPlaylistItemFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemFlags = set of TPlaylistItemFlag ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemFlag)
Next (TPlaylistItemOption)


Previous (TPlaylistItemFlags)
Next (TPlaylistItemOptions)

Name
TPlaylistItemOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOption = ( pioNoLogging , pioSkipInAutomation , pioFadeOutAll , pioAdjustTime , pioFadeOnStop , pioLinked , pioDontMoveToHistory , pioHourlyFixTime , pioNoPrebuffering , pioNoFileManager , pioVBR , pioExpandVariables , pioCustomized ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemFlags)
Next (TPlaylistItemOptions)


Previous (TPlaylistItemOption)
Next (TPlaylistItemState)

Name
TPlaylistItemOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemOptions = set of TPlaylistItemOption ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOption)
Next (TPlaylistItemState)


Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlag)

Name
TPlaylistItemState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemState = ( pisNormal , pisPlaying , pisHistory ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemOptions)
Next (TPlaylistItemStatusFlag)


Previous (TPlaylistItemState)
Next (TPlaylistItemStatusFlags)

Name
TPlaylistItemStatusFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatusFlag = ( pisfInLinkChain , pisfError , pisfPrebufferError , pisfFixedStart , pisfFixedStartWait , pisfOverflow , pisfWasStarted , pisfPrebuffering , pisfRealtime ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemState)
Next (TPlaylistItemStatusFlags)


Previous (TPlaylistItemStatusFlag)
Next (TPlaylistItemType)

Name
TPlaylistItemStatusFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemStatusFlags = set of TPlaylistItemStatusFlag ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatusFlag)
Next (TPlaylistItemType)


Previous (TPlaylistItemStatusFlags)
Next (TPlaylistItemTypes)

Name
TPlaylistItemType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemType = ( pitUnknown , pitMusic , pitVoice , pitNews , pitWeather , pitAdvertising , pitPackage , pitJingle , pitSound , pitEffect , pitTrailer , pitPromo , pitSponsorship , pitSweeper , pitDrop , pitStationID , pitBed , pitInstrumental , pitShow , pitStream , pitContainer , pitCommand , pitBreak , pitDummy , pitSilence , pitOther , pitCustom1 , pitCustom2 , pitCustom3 , pitCustom4 ) ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemStatusFlags)
Next (TPlaylistItemTypes)


Previous (TPlaylistItemType)
Next (TRegion)

Name
TPlaylistItemTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TPlaylistItemTypes = set of TPlaylistItemType ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemType)
Next (TRegion)


Previous (TPlaylistItemTypes)
Next (TRegions)

Name
TRegion

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRegion = byte ;

mAirListScript
Class Tree
Index
Previous (TPlaylistItemTypes)
Next (TRegions)


Previous (TRegion)
Next (TRepositoryItem)

Name
TRegions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRegions = TSetOfByte ;

mAirListScript
Class Tree
Index
Previous (TRegion)
Next (TRepositoryItem)


Previous (TRegions)
Next (TRunMode)

Name
TRepositoryItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRepositoryItem = ( riHookOpener , riHookSweeper , riHookCloser ) ;

mAirListScript
Class Tree
Index
Previous (TRegions)
Next (TRunMode)


Previous (TRepositoryItem)
Next (TSampleFormat)

Name
TRunMode

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TRunMode = ( rmPlayout , rmConfig , rmTagging , rmDatabase ) ;

mAirListScript
Class Tree
Index
Previous (TRepositoryItem)
Next (TSampleFormat)


Previous (TRunMode)
Next (TSetOfByte)

Name
TSampleFormat

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSampleFormat = ( sfFloat , sf16bit ) ;

mAirListScript
Class Tree
Index
Previous (TRunMode)
Next (TSetOfByte)


Previous (TSampleFormat)
Next (TSingleArray)

Name
TSetOfByte

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSetOfByte = set of byte ;

mAirListScript
Class Tree
Index
Previous (TSampleFormat)
Next (TSingleArray)


Previous (TSetOfByte)
Next (TSkipRetryAbort)

Name
TSingleArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSingleArray = array of single ;

mAirListScript
Class Tree
Index
Previous (TSetOfByte)
Next (TSkipRetryAbort)


Previous (TSingleArray)
Next (TSourceControlOption)

Name
TSkipRetryAbort

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSkipRetryAbort = ( srtSkip , srtRetry , srtAbort ) ;

mAirListScript
Class Tree
Index
Previous (TSingleArray)
Next (TSourceControlOption)


Previous (TSkipRetryAbort)
Next (TSourceControlOptions)

Name
TSourceControlOption

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOption = ( scoAutoFadeOut , scoAutoCueOut , scoAutoRewind , scoHookMode , scoLoop , scoLogging , scoWorkActionLists ) ;

mAirListScript
Class Tree
Index
Previous (TSkipRetryAbort)
Next (TSourceControlOptions)


Previous (TSourceControlOption)
Next (TSourceControlState)

Name
TSourceControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlOptions = set of TSourceControlOption ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOption)
Next (TSourceControlState)


Previous (TSourceControlOptions)
Next (TStandardActionList)

Name
TSourceControlState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TSourceControlState = ( scsStopped , scsPlaying , scsPaused , scsFading , scsEOF ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlOptions)
Next (TStandardActionList)


Previous (TSourceControlState)
Next (TStartTimeType)

Name
TStandardActionList

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStandardActionList = ( salMenu , salStartup , salShutdown , salPlaylistEmpty , salOnAir , salOffAir , salPFLOn , salPFLOff ) ;

mAirListScript
Class Tree
Index
Previous (TSourceControlState)
Next (TStartTimeType)


Previous (TStandardActionList)
Next (TTimeValue)

Name
TStartTimeType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TStartTimeType = ( sttStarted , sttCalculated , sttReal , sttSinceLastBreak ) ;

mAirListScript
Class Tree
Index
Previous (TStandardActionList)
Next (TTimeValue)


Previous (TStartTimeType)
Next (TTimeValueArray)

Name
TTimeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTimeValue = double ;

mAirListScript
Class Tree
Index
Previous (TStartTimeType)
Next (TTimeValueArray)


Previous (TTimeValue)
Next (TTiming)

Name
TTimeValueArray

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTimeValueArray = array of TTimeValue ;

mAirListScript
Class Tree
Index
Previous (TTimeValue)
Next (TTiming)


Previous (TTimeValueArray)
Next (TWeekdayHourFilter)

Name
TTiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TTiming = ( timNormal , timHard , timSoft , timBacktimed , timExcluded ) ;

mAirListScript
Class Tree
Index
Previous (TTimeValueArray)
Next (TWeekdayHourFilter)


Previous (TTiming)
Next

Name
TWeekdayHourFilter

Parent
mAirListTypes

Visibility
PUBLIC

Source code
TWeekdayHourFilter = array [ 1 .. 7 ] of THourFilter ;

mAirListScript
Class Tree
Index
Previous (TTiming)
Next


Previous
Next (AllFileImportTasks)

Name
AllCuePositionTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllCuePositionTypes = [ ptCueIn , ptRamp1 , ptRamp2 , ptRamp3 , ptHookIn , ptHookFade , ptHookOut , ptOutro , ptStartNext , ptFadeOut , ptCueOut , ptAnchor ]

mAirListScript
Class Tree
Index
Previous
Next (AllFileImportTasks)


Previous (AllCuePositionTypes)
Next (AllLogCategories)

Name
AllFileImportTasks

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllFileImportTasks = [ fitMMD , fitTags , fitNativeTags , fitDuration , fitTilde , fitAutoCue , fitDatabaseLookup ]

mAirListScript
Class Tree
Index
Previous (AllCuePositionTypes)
Next (AllLogCategories)


Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)

Name
AllLogCategories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllLogCategories = [ lcInfo , lcError , lcWarning , lcStatus , lcPlaylist , lcDebug , lcUnknown ]

mAirListScript
Class Tree
Index
Previous (AllFileImportTasks)
Next (AllPlaylistItemChangedDetails)


Previous (AllLogCategories)
Next (AllPlaylistItemTypes)

Name
AllPlaylistItemChangedDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllPlaylistItemChangedDetails = $FFFFFFFF

mAirListScript
Class Tree
Index
Previous (AllLogCategories)
Next (AllPlaylistItemTypes)


Previous (AllPlaylistItemChangedDetails)
Next (AutoCuePositions)

Name
AllPlaylistItemTypes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AllPlaylistItemTypes = [ pitUnknown , pitMusic , pitVoice , pitNews , pitAdvertising , pitPackage , pitJingle , pitSound , pitEffect , pitTrailer , pitPromo , pitSponsorship , pitSweeper , pitDrop , pitStationID , pitBed , pitInstrumental , pitShow , pitStream , pitContainer , pitCommand , pitBreak , pitDummy , pitSilence , pitOther , pitCustom1 , pitCustom2 , pitCustom3 , pitCustom4 ]

mAirListScript
Class Tree
Index
Previous (AllPlaylistItemChangedDetails)
Next (AutoCuePositions)


Previous (AllPlaylistItemTypes)
Next (CartPlayerCommands)

Name
AutoCuePositions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
AutoCuePositions = [ ptCueIn , ptFadeOut , ptCueOut ]

mAirListScript
Class Tree
Index
Previous (AllPlaylistItemTypes)
Next (CartPlayerCommands)


Previous (AutoCuePositions)
Next (ccBASS)

Name
CartPlayerCommands

Parent
mAirListTypes

Visibility
PUBLIC

Source code
CartPlayerCommands = [ pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose , pcNext , pcPrevious ]

mAirListScript
Class Tree
Index
Previous (AutoCuePositions)
Next (ccBASS)


Previous (CartPlayerCommands)
Next (ccCustom)

Name
ccBASS

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccBASS = 'bass'

mAirListScript
Class Tree
Index
Previous (CartPlayerCommands)
Next (ccCustom)


Previous (ccBASS)
Next (ccDatabase)

Name
ccCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccCustom = 'custom'

mAirListScript
Class Tree
Index
Previous (ccBASS)
Next (ccDatabase)


Previous (ccCustom)
Next (ccDefaultDirectories)

Name
ccDatabase

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDatabase = 'database'

mAirListScript
Class Tree
Index
Previous (ccCustom)
Next (ccDefaultDirectories)


Previous (ccDatabase)
Next (ccDemoLicense)

Name
ccDefaultDirectories

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDefaultDirectories = 'defaultdirectories'

mAirListScript
Class Tree
Index
Previous (ccDatabase)
Next (ccDemoLicense)


Previous (ccDefaultDirectories)
Next (ccDevices)

Name
ccDemoLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDemoLicense = 'demolicense'

mAirListScript
Class Tree
Index
Previous (ccDefaultDirectories)
Next (ccDevices)


Previous (ccDemoLicense)
Next (ccEncoder)

Name
ccDevices

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccDevices = 'devices'

mAirListScript
Class Tree
Index
Previous (ccDemoLicense)
Next (ccEncoder)


Previous (ccDevices)
Next (ccGUI)

Name
ccEncoder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccEncoder = 'encoder'

mAirListScript
Class Tree
Index
Previous (ccDevices)
Next (ccGUI)


Previous (ccEncoder)
Next (ccLayout)

Name
ccGUI

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccGUI = 'gui'

mAirListScript
Class Tree
Index
Previous (ccEncoder)
Next (ccLayout)


Previous (ccGUI)
Next (ccLicense)

Name
ccLayout

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLayout = 'layout'

mAirListScript
Class Tree
Index
Previous (ccGUI)
Next (ccLicense)


Previous (ccLayout)
Next (ccLogging)

Name
ccLicense

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLicense = 'license'

mAirListScript
Class Tree
Index
Previous (ccLayout)
Next (ccLogging)


Previous (ccLicense)
Next (ccMain)

Name
ccLogging

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccLogging = 'logging'

mAirListScript
Class Tree
Index
Previous (ccLicense)
Next (ccMain)


Previous (ccLogging)
Next (ccMixdown)

Name
ccMain

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMain = 'mAirList'

mAirListScript
Class Tree
Index
Previous (ccLogging)
Next (ccMixdown)


Previous (ccMain)
Next (ccPasswords)

Name
ccMixdown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccMixdown = 'mixdown'

mAirListScript
Class Tree
Index
Previous (ccMain)
Next (ccPasswords)


Previous (ccMixdown)
Next (ccPosition)

Name
ccPasswords

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPasswords = 'passwords'

mAirListScript
Class Tree
Index
Previous (ccMixdown)
Next (ccPosition)


Previous (ccPasswords)
Next (ccPreferences)

Name
ccPosition

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPosition = 'position'

mAirListScript
Class Tree
Index
Previous (ccPasswords)
Next (ccPreferences)


Previous (ccPosition)
Next (ccRemote)

Name
ccPreferences

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccPreferences = 'preferences'

mAirListScript
Class Tree
Index
Previous (ccPosition)
Next (ccRemote)


Previous (ccPreferences)
Next (ccScreenObjects)

Name
ccRemote

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccRemote = 'remote'

mAirListScript
Class Tree
Index
Previous (ccPreferences)
Next (ccScreenObjects)


Previous (ccRemote)
Next (ccSerial)

Name
ccScreenObjects

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccScreenObjects = 'screenobjects'

mAirListScript
Class Tree
Index
Previous (ccRemote)
Next (ccSerial)


Previous (ccScreenObjects)
Next (cdADCAssignment)

Name
ccSerial

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ccSerial = 'serial'

mAirListScript
Class Tree
Index
Previous (ccScreenObjects)
Next (cdADCAssignment)


Previous (ccSerial)
Next (cdADCNodes)

Name
cdADCAssignment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdADCAssignment = 2

mAirListScript
Class Tree
Index
Previous (ccSerial)
Next (cdADCNodes)


Previous (cdADCAssignment)
Next (cdBLContent)

Name
cdADCNodes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdADCNodes = 1

mAirListScript
Class Tree
Index
Previous (cdADCAssignment)
Next (cdBLContent)


Previous (cdADCNodes)
Next (cdCOGeneral)

Name
cdBLContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdBLContent = 1

mAirListScript
Class Tree
Index
Previous (cdADCNodes)
Next (cdCOGeneral)


Previous (cdBLContent)
Next (cdCORestartCritical)

Name
cdCOGeneral

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOGeneral = 1

mAirListScript
Class Tree
Index
Previous (cdBLContent)
Next (cdCORestartCritical)


Previous (cdCOGeneral)
Next (cdCOStatus)

Name
cdCORestartCritical

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCORestartCritical = 4

mAirListScript
Class Tree
Index
Previous (cdCOGeneral)
Next (cdCOStatus)


Previous (cdCORestartCritical)
Next (cdDBConnectionDetails)

Name
cdCOStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdCOStatus = 2

mAirListScript
Class Tree
Index
Previous (cdCORestartCritical)
Next (cdDBConnectionDetails)


Previous (cdCOStatus)
Next (cdDBOther)

Name
cdDBConnectionDetails

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBConnectionDetails = $10004

mAirListScript
Class Tree
Index
Previous (cdCOStatus)
Next (cdDBOther)


Previous (cdDBConnectionDetails)
Next (cdDBState)

Name
cdDBOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBOther = $40000

mAirListScript
Class Tree
Index
Previous (cdDBConnectionDetails)
Next (cdDBState)


Previous (cdDBOther)
Next (cdForceUpdate)

Name
cdDBState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdDBState = $20000

mAirListScript
Class Tree
Index
Previous (cdDBOther)
Next (cdForceUpdate)


Previous (cdDBState)
Next (cdMDBacktiming)

Name
cdForceUpdate

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdForceUpdate = $8000000

mAirListScript
Class Tree
Index
Previous (cdDBState)
Next (cdMDBacktiming)


Previous (cdForceUpdate)
Next (cdMDFlags)

Name
cdMDBacktiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDBacktiming = $0002

mAirListScript
Class Tree
Index
Previous (cdForceUpdate)
Next (cdMDFlags)


Previous (cdMDBacktiming)
Next (cdMDGeneral)

Name
cdMDFlags

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDFlags = $0010

mAirListScript
Class Tree
Index
Previous (cdMDBacktiming)
Next (cdMDGeneral)


Previous (cdMDFlags)
Next (cdMDLink)

Name
cdMDGeneral

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDGeneral = $0001

mAirListScript
Class Tree
Index
Previous (cdMDFlags)
Next (cdMDLink)


Previous (cdMDGeneral)
Next (cdMDState)

Name
cdMDLink

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDLink = $0008

mAirListScript
Class Tree
Index
Previous (cdMDGeneral)
Next (cdMDState)


Previous (cdMDLink)
Next (cdMDStatus)

Name
cdMDState

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDState = $0004

mAirListScript
Class Tree
Index
Previous (cdMDLink)
Next (cdMDStatus)


Previous (cdMDState)
Next (cdMDTiming)

Name
cdMDStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDStatus = $0040

mAirListScript
Class Tree
Index
Previous (cdMDState)
Next (cdMDTiming)


Previous (cdMDStatus)
Next (cdPCAllowAutomation)

Name
cdMDTiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdMDTiming = $0020

mAirListScript
Class Tree
Index
Previous (cdMDStatus)
Next (cdPCAllowAutomation)


Previous (cdMDTiming)
Next (cdPCAutomation)

Name
cdPCAllowAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAllowAutomation = 4

mAirListScript
Class Tree
Index
Previous (cdMDTiming)
Next (cdPCAutomation)


Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)

Name
cdPCAutomation

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomation = 1

mAirListScript
Class Tree
Index
Previous (cdPCAllowAutomation)
Next (cdPCAutomationPlaying)


Previous (cdPCAutomation)
Next (cdPCOptions)

Name
cdPCAutomationPlaying

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCAutomationPlaying = 2

mAirListScript
Class Tree
Index
Previous (cdPCAutomation)
Next (cdPCOptions)


Previous (cdPCAutomationPlaying)
Next (cdPCPlayerAssignment)

Name
cdPCOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCOptions = 64

mAirListScript
Class Tree
Index
Previous (cdPCAutomationPlaying)
Next (cdPCPlayerAssignment)


Previous (cdPCOptions)
Next (cdPCPlayerCount)

Name
cdPCPlayerAssignment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayerAssignment = 16

mAirListScript
Class Tree
Index
Previous (cdPCOptions)
Next (cdPCPlayerCount)


Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)

Name
cdPCPlayerCount

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPCPlayerCount = 32

mAirListScript
Class Tree
Index
Previous (cdPCPlayerAssignment)
Next (cdPIBacktimingStatus)


Previous (cdPCPlayerCount)
Next (cdPIColor)

Name
cdPIBacktimingStatus

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIBacktimingStatus = $40

mAirListScript
Class Tree
Index
Previous (cdPCPlayerCount)
Next (cdPIColor)


Previous (cdPIBacktimingStatus)
Next (cdPIComment)

Name
cdPIColor

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIColor = $1000

mAirListScript
Class Tree
Index
Previous (cdPIBacktimingStatus)
Next (cdPIComment)


Previous (cdPIColor)
Next (cdPIContent)

Name
cdPIComment

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIComment = $400

mAirListScript
Class Tree
Index
Previous (cdPIColor)
Next (cdPIContent)


Previous (cdPIComment)
Next (cdPICueData)

Name
cdPIContent

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIContent = $2000

mAirListScript
Class Tree
Index
Previous (cdPIComment)
Next (cdPICueData)


Previous (cdPIContent)
Next (cdPIDuration)

Name
cdPICueData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPICueData = $4000

mAirListScript
Class Tree
Index
Previous (cdPIContent)
Next (cdPIDuration)


Previous (cdPICueData)
Next (cdPIHistoryFlag)

Name
cdPIDuration

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIDuration = $1

mAirListScript
Class Tree
Index
Previous (cdPICueData)
Next (cdPIHistoryFlag)


Previous (cdPIDuration)
Next (cdPIIcon)

Name
cdPIHistoryFlag

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIHistoryFlag = $800

mAirListScript
Class Tree
Index
Previous (cdPIDuration)
Next (cdPIIcon)


Previous (cdPIHistoryFlag)
Next (cdPIItemData)

Name
cdPIIcon

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIIcon = $10000

mAirListScript
Class Tree
Index
Previous (cdPIHistoryFlag)
Next (cdPIItemData)


Previous (cdPIIcon)
Next (cdPILinked)

Name
cdPIItemData

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIItemData = $8

mAirListScript
Class Tree
Index
Previous (cdPIIcon)
Next (cdPILinked)


Previous (cdPIItemData)
Next (cdPIMetadata)

Name
cdPILinked

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPILinked = $200

mAirListScript
Class Tree
Index
Previous (cdPIItemData)
Next (cdPIMetadata)


Previous (cdPILinked)
Next (cdPIOther)

Name
cdPIMetadata

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIMetadata = $8000

mAirListScript
Class Tree
Index
Previous (cdPILinked)
Next (cdPIOther)


Previous (cdPIMetadata)
Next (cdPIPitch)

Name
cdPIOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIOther = $40000

mAirListScript
Class Tree
Index
Previous (cdPIMetadata)
Next (cdPIPitch)


Previous (cdPIOther)
Next (cdPIPositionAlternatives)

Name
cdPIPitch

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPitch = $100

mAirListScript
Class Tree
Index
Previous (cdPIOther)
Next (cdPIPositionAlternatives)


Previous (cdPIPitch)
Next (cdPIPositionValue)

Name
cdPIPositionAlternatives

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionAlternatives = $4

mAirListScript
Class Tree
Index
Previous (cdPIPitch)
Next (cdPIPositionValue)


Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)

Name
cdPIPositionValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIPositionValue = $2

mAirListScript
Class Tree
Index
Previous (cdPIPositionAlternatives)
Next (cdPIStartTimes)


Previous (cdPIPositionValue)
Next (cdPItem)

Name
cdPIStartTimes

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIStartTimes = $10

mAirListScript
Class Tree
Index
Previous (cdPIPositionValue)
Next (cdPItem)


Previous (cdPIStartTimes)
Next (cdPITempo)

Name
cdPItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPItem = 4

mAirListScript
Class Tree
Index
Previous (cdPIStartTimes)
Next (cdPITempo)


Previous (cdPItem)
Next (cdPIUnknown)

Name
cdPITempo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPITempo = $80

mAirListScript
Class Tree
Index
Previous (cdPItem)
Next (cdPIUnknown)


Previous (cdPITempo)
Next (cdPIVolumeEnvelope)

Name
cdPIUnknown

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIUnknown = $20

mAirListScript
Class Tree
Index
Previous (cdPITempo)
Next (cdPIVolumeEnvelope)


Previous (cdPIUnknown)
Next (cdPLBacktiming)

Name
cdPIVolumeEnvelope

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPIVolumeEnvelope = $20000

mAirListScript
Class Tree
Index
Previous (cdPIUnknown)
Next (cdPLBacktiming)


Previous (cdPIVolumeEnvelope)
Next (cdPLevelInfo)

Name
cdPLBacktiming

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPLBacktiming = 2

mAirListScript
Class Tree
Index
Previous (cdPIVolumeEnvelope)
Next (cdPLevelInfo)


Previous (cdPLBacktiming)
Next (cdPOptions)

Name
cdPLevelInfo

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPLevelInfo = 16

mAirListScript
Class Tree
Index
Previous (cdPLBacktiming)
Next (cdPOptions)


Previous (cdPLevelInfo)
Next (cdPOther)

Name
cdPOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPOptions = 8

mAirListScript
Class Tree
Index
Previous (cdPLevelInfo)
Next (cdPOther)


Previous (cdPOptions)
Next (cdPVolume)

Name
cdPOther

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPOther = 1

mAirListScript
Class Tree
Index
Previous (cdPOptions)
Next (cdPVolume)


Previous (cdPOther)
Next (cdSCVolume)

Name
cdPVolume

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdPVolume = 2

mAirListScript
Class Tree
Index
Previous (cdPOther)
Next (cdSCVolume)


Previous (cdPVolume)
Next (ConfigTimePlaybackControlOptions)

Name
cdSCVolume

Parent
mAirListTypes

Visibility
PUBLIC

Source code
cdSCVolume = 1

mAirListScript
Class Tree
Index
Previous (cdPVolume)
Next (ConfigTimePlaybackControlOptions)


Previous (cdSCVolume)
Next (DefaultCartPlayerControlOptions)

Name
ConfigTimePlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ConfigTimePlaybackControlOptions = [ plcoAllowAutomation ]

mAirListScript
Class Tree
Index
Previous (cdSCVolume)
Next (DefaultCartPlayerControlOptions)


Previous (ConfigTimePlaybackControlOptions)
Next (DefaultCartwallControlOptions)

Name
DefaultCartPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultCartPlayerControlOptions = [ ]

mAirListScript
Class Tree
Index
Previous (ConfigTimePlaybackControlOptions)
Next (DefaultCartwallControlOptions)


Previous (DefaultCartPlayerControlOptions)
Next (DefaultEngineOptions)

Name
DefaultCartwallControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultCartwallControlOptions = [ cwcoSaveWithTemplate , cwcoKeepOpen , cwcoLogging ]

mAirListScript
Class Tree
Index
Previous (DefaultCartPlayerControlOptions)
Next (DefaultEngineOptions)


Previous (DefaultCartwallControlOptions)
Next (DefaultFeatures)

Name
DefaultEngineOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultEngineOptions = [ ]

mAirListScript
Class Tree
Index
Previous (DefaultCartwallControlOptions)
Next (DefaultFeatures)


Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)

Name
DefaultFeatures

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFeatures = [ mfExtraPFL , mfProperties , mfSaveToTag , mfSaveToMMD , mfSaveToDatabase , mfMixdown , mfAttributeEditing , mfRuntimePlaylistOptions , mfRuntimePlayerOptions , mfSaveDefaultDesktop ]

mAirListScript
Class Tree
Index
Previous (DefaultEngineOptions)
Next (DefaultFileImportOptions)


Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)

Name
DefaultFileImportOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileImportOptions = [ fioImportComment , fioImportTags , fioTildeAsFadeOut , fioStripWhitespace , fioImportReplayGain , fioReplayGainPreventClipping , fioArtistTitleFromFilename ]

mAirListScript
Class Tree
Index
Previous (DefaultFeatures)
Next (DefaultFileManagementOptions)


Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)

Name
DefaultFileManagementOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultFileManagementOptions = [ fmoCacheNetworkFiles ]

mAirListScript
Class Tree
Index
Previous (DefaultFileImportOptions)
Next (DefaultGlobalOptions)


Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)

Name
DefaultGlobalOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultGlobalOptions = [ goFadeOutEffectiveEnd , goOutroEOFWarning , goStartOnAir , goNoLoggingOffAir , goSplashScreen ]

mAirListScript
Class Tree
Index
Previous (DefaultFileManagementOptions)
Next (DefaultPlaybackControlOptions)


Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)

Name
DefaultPlaybackControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlaybackControlOptions = [ plcoAllowAutomation , plcoCleanUpHistory , plcoCleanUpHistoryTop , plcoAutoSaveEvents , plcoUseRecycleBin , plcoHandleFixedTime , plcoFixedTimeWaitHard ]

mAirListScript
Class Tree
Index
Previous (DefaultGlobalOptions)
Next (DefaultPlayerControlOptions)


Previous (DefaultPlaybackControlOptions)
Next (MAX_REGION)

Name
DefaultPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
DefaultPlayerControlOptions = [ poAutoLoad , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poUseInAutomation , poHistoryOnClose , poLogging , poIndependentPFLEndMon ]

mAirListScript
Class Tree
Index
Previous (DefaultPlaybackControlOptions)
Next (MAX_REGION)


Previous (DefaultPlayerControlOptions)
Next (MIN_DB)

Name
MAX_REGION

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MAX_REGION = 255

mAirListScript
Class Tree
Index
Previous (DefaultPlayerControlOptions)
Next (MIN_DB)


Previous (MAX_REGION)
Next (MIN_REGION)

Name
MIN_DB

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MIN_DB = - 999

mAirListScript
Class Tree
Index
Previous (MAX_REGION)
Next (MIN_REGION)


Previous (MIN_DB)
Next (NoObjectID)

Name
MIN_REGION

Parent
mAirListTypes

Visibility
PUBLIC

Source code
MIN_REGION = 1

mAirListScript
Class Tree
Index
Previous (MIN_DB)
Next (NoObjectID)


Previous (MIN_REGION)
Next (ntArtist)

Name
NoObjectID

Parent
mAirListTypes

Visibility
PUBLIC

Source code
NoObjectID = 0

mAirListScript
Class Tree
Index
Previous (MIN_REGION)
Next (ntArtist)


Previous (NoObjectID)
Next (ntArtistRoot)

Name
ntArtist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntArtist = 13

mAirListScript
Class Tree
Index
Previous (NoObjectID)
Next (ntArtistRoot)


Previous (ntArtist)
Next (ntAttribute)

Name
ntArtistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntArtistRoot = 6

mAirListScript
Class Tree
Index
Previous (ntArtist)
Next (ntAttribute)


Previous (ntArtistRoot)
Next (ntAttributeRoot)

Name
ntAttribute

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttribute = 9

mAirListScript
Class Tree
Index
Previous (ntArtistRoot)
Next (ntAttributeRoot)


Previous (ntAttribute)
Next (ntAttributeValue)

Name
ntAttributeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeRoot = 8

mAirListScript
Class Tree
Index
Previous (ntAttribute)
Next (ntAttributeValue)


Previous (ntAttributeRoot)
Next (ntCustom)

Name
ntAttributeValue

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntAttributeValue = 10

mAirListScript
Class Tree
Index
Previous (ntAttributeRoot)
Next (ntCustom)


Previous (ntAttributeValue)
Next (ntFolder)

Name
ntCustom

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntCustom = 128

mAirListScript
Class Tree
Index
Previous (ntAttributeValue)
Next (ntFolder)


Previous (ntCustom)
Next (ntFolderRoot)

Name
ntFolder

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolder = 7

mAirListScript
Class Tree
Index
Previous (ntCustom)
Next (ntFolderRoot)


Previous (ntFolder)
Next (ntItem)

Name
ntFolderRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntFolderRoot = 5

mAirListScript
Class Tree
Index
Previous (ntFolder)
Next (ntItem)


Previous (ntFolderRoot)
Next (ntPlaylist)

Name
ntItem

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntItem = 1

mAirListScript
Class Tree
Index
Previous (ntFolderRoot)
Next (ntPlaylist)


Previous (ntItem)
Next (ntPlaylistRoot)

Name
ntPlaylist

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylist = 3

mAirListScript
Class Tree
Index
Previous (ntItem)
Next (ntPlaylistRoot)


Previous (ntPlaylist)
Next (ntRoot)

Name
ntPlaylistRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntPlaylistRoot = 2

mAirListScript
Class Tree
Index
Previous (ntPlaylist)
Next (ntRoot)


Previous (ntPlaylistRoot)
Next (ntText)

Name
ntRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntRoot = 0

mAirListScript
Class Tree
Index
Previous (ntPlaylistRoot)
Next (ntText)


Previous (ntRoot)
Next (ntType)

Name
ntText

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntText = 4

mAirListScript
Class Tree
Index
Previous (ntRoot)
Next (ntType)


Previous (ntText)
Next (ntTypeRoot)

Name
ntType

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntType = 12

mAirListScript
Class Tree
Index
Previous (ntText)
Next (ntTypeRoot)


Previous (ntType)
Next (OrdinaryPlayerCommands)

Name
ntTypeRoot

Parent
mAirListTypes

Visibility
PUBLIC

Source code
ntTypeRoot = 11

mAirListScript
Class Tree
Index
Previous (ntType)
Next (OrdinaryPlayerCommands)


Previous (ntTypeRoot)
Next (PEAKDATA_LENGTH)

Name
OrdinaryPlayerCommands

Parent
mAirListTypes

Visibility
PUBLIC

Source code
OrdinaryPlayerCommands = [ pcStart , pcPause , pcStop , pcFadeOut , pcStartPause , pcPauseStop , pcStartPauseStop , pcStartStop , pcStartFadeOut , pcPFLOn , pcPFLOff , pcPFLOnOff , pcReset , pcClose ]

mAirListScript
Class Tree
Index
Previous (ntTypeRoot)
Next (PEAKDATA_LENGTH)


Previous (OrdinaryPlayerCommands)
Next (RuntimeCartPlayerControlOptions)

Name
PEAKDATA_LENGTH

Parent
mAirListTypes

Visibility
PUBLIC

Source code
PEAKDATA_LENGTH = 4096

mAirListScript
Class Tree
Index
Previous (OrdinaryPlayerCommands)
Next (RuntimeCartPlayerControlOptions)


Previous (PEAKDATA_LENGTH)
Next (RuntimeOrdinaryPlayerControlOptions)

Name
RuntimeCartPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
RuntimeCartPlayerControlOptions = [ poLoopAudio , poHookMode , poResetLoop , poResetHook ]

mAirListScript
Class Tree
Index
Previous (PEAKDATA_LENGTH)
Next (RuntimeOrdinaryPlayerControlOptions)


Previous (RuntimeCartPlayerControlOptions)
Next

Name
RuntimeOrdinaryPlayerControlOptions

Parent
mAirListTypes

Visibility
PUBLIC

Source code
RuntimeOrdinaryPlayerControlOptions = [ poAutoLoad , poAutoLoadOnDemand , poAutoLoadSingle , poAutoUnloadSTOP , poAutoUnloadEOF , poAutoStopOnEOF , poAutoReleasePause , poAutoPFLOff , poAutoStopPFL , poAutoFadeOut , poUseInAutomation , poHistoryOnClose , poHistoryOnCloseLoaded , poLogging , poIndependentPFL , poPFLOutputPlayback , poIndependentPFLEndMon , poLoopAudio , poHookMode , poResetLoop , poResetHook ]

mAirListScript
Class Tree
Index
Previous (RuntimeCartPlayerControlOptions)
Next


Previous (mAirListTypes)
Next (SASInterface)

Name
MidiInterface

Parent
mAirListScript

Classes
Class Description
IMidiRemote (+)
TMidiMessage (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (mAirListTypes)
Next (SASInterface)


Previous
Next (TMidiMessage)

Name
IMidiRemote

Parent
MidiInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetDevice (+)
GetEvents (+)
SetDevice (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (TMidiMessage)


Previous
Next (GetEvents)

Name
GetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetDevice : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetEvents)


Previous (GetDevice)
Next (SetDevice)

Name
GetEvents

Parent
IMidiRemote

Visibility
PUBLIC

Source code
function GetEvents : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDevice)
Next (SetDevice)


Previous (GetEvents)
Next

Name
SetDevice

Parent
IMidiRemote

Visibility
PUBLIC

Source code
procedure SetDevice ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetEvents)
Next


Previous (IMidiRemote)
Next

Name
TMidiMessage

Parent
MidiInterface

Class Hierarchy
No Parent

Visibility
PUBLIC

Members
Fields
Field Description
Data1 (*)
Data2 (*)
Device (*)
MESSAGE (*)
Status (*)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IMidiRemote)
Next


Previous
Next (Data2)

Name
Data1

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data1 : byte

mAirListScript
Class Tree
Index
Previous
Next (Data2)


Previous (Data1)
Next (Device)

Name
Data2

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Data2 : byte

mAirListScript
Class Tree
Index
Previous (Data1)
Next (Device)


Previous (Data2)
Next (MESSAGE)

Name
Device

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Device : byte

mAirListScript
Class Tree
Index
Previous (Data2)
Next (MESSAGE)


Previous (Device)
Next (Status)

Name
MESSAGE

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
message : cardinal

mAirListScript
Class Tree
Index
Previous (Device)
Next (Status)


Previous (MESSAGE)
Next

Name
Status

Parent
TMidiMessage

Visibility
PUBLISHED

Source code
Status : byte

mAirListScript
Class Tree
Index
Previous (MESSAGE)
Next


Previous (MidiInterface)
Next (WMClientInterface)

Name
SASInterface

Parent
mAirListScript

Classes
Class Description
IIPSASRemote (+)
ISASAction (+)
ISASRemote (+)
ISASSetFaderInputGainAction (+)
ISASSetFaderLevelAction (+)
ISASSetFaderStartOffAction (+)
ISASSetFaderStartOnAction (+)
ISASSetGPIAction (+)
ISASSetGPIOffAction (+)
ISASSetGPIOnAction (+)
ISASSetPFLOffAction (+)
ISASSetPFLOnAction (+)
ISASSourceAction (+)
ISASSourceLevelAction (+)
ISerialSASRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (MidiInterface)
Next (WMClientInterface)


Previous
Next (ISASAction)

Name
IIPSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetHost (+)
GetPort (+)
SetHost (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (ISASAction)


Previous
Next (GetPort)

Name
GetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetHost : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetPort)


Previous (GetHost)
Next (SetHost)

Name
GetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
function GetPort : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHost)
Next (SetHost)


Previous (GetPort)
Next (SetPort)

Name
SetHost

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetHost ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next (SetPort)


Previous (SetHost)
Next

Name
SetPort

Parent
IIPSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : integer )

Parameters
Parameter Description
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (SetHost)
Next


Previous (IIPSASRemote)
Next (ISASRemote)

Name
ISASAction

Parent
SASInterface

Class Hierarchy
IRemoteAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IIPSASRemote)
Next (ISASRemote)


Previous (ISASAction)
Next (ISASSetFaderInputGainAction)

Name
ISASRemote

Parent
SASInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
FetchFaderLevel (+)
FetchFaderStatus (+)
GetAllSources (+)
GetFader (+)
GetFaderLevel (+)
GetFaderStatus (+)
GetGPIOffCommand (+)
GetGPIOnCommand (+)
GetOtherSources (+)
GetPlayerOptions (+)
GetPlayerSourceName (+)
GetVTMicSource (+)
GetVTPlayerASource (+)
GetVTPlayerBSource (+)
SendCommand (+)
SetFaderInputGain (+)
SetFaderLevel (+)
SetFaderStart (+)
SetGPI (+)
SetGPIOffCommand (+)
SetGPIOnCommand (+)
SetOtherSources (+)
SetPlayerOptions (+)
SetPlayerSourceName (+)
SetPrelisten1Off (+)
SetPrelisten1On (+)
SetVTMicSource (+)
SetVTPlayerASource (+)
SetVTPlayerBSource (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASAction)
Next (ISASSetFaderInputGainAction)


Previous
Next (FetchFaderStatus)

Name
FetchFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderLevel ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous
Next (FetchFaderStatus)


Previous (FetchFaderLevel)
Next (GetAllSources)

Name
FetchFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure FetchFaderStatus ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (FetchFaderLevel)
Next (GetAllSources)


Previous (FetchFaderStatus)
Next (GetFader)

Name
GetAllSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetAllSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FetchFaderStatus)
Next (GetFader)


Previous (GetAllSources)
Next (GetFaderLevel)

Name
GetFader

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFader ( iSourceName : string ) : byte

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetAllSources)
Next (GetFaderLevel)


Previous (GetFader)
Next (GetFaderStatus)

Name
GetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderLevel ( iSourceName : string ) : ShortInt

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetFader)
Next (GetFaderStatus)


Previous (GetFaderLevel)
Next (GetGPIOffCommand)

Name
GetFaderStatus

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetFaderStatus ( iSourceName : string ) : byte

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (GetFaderLevel)
Next (GetGPIOffCommand)


Previous (GetFaderStatus)
Next (GetGPIOnCommand)

Name
GetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOffCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFaderStatus)
Next (GetGPIOnCommand)


Previous (GetGPIOffCommand)
Next (GetOtherSources)

Name
GetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetGPIOnCommand ( iIndex : integer ) : string

Parameters
Parameter Description
iIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetGPIOffCommand)
Next (GetOtherSources)


Previous (GetGPIOnCommand)
Next (GetPlayerOptions)

Name
GetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetOtherSources : IStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetGPIOnCommand)
Next (GetPlayerOptions)


Previous (GetOtherSources)
Next (GetPlayerSourceName)

Name
GetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerOptions ( iPlaylist , iPlayer : integer ) : TSASPlayerOptions

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER

mAirListScript
Class Tree
Index
Previous (GetOtherSources)
Next (GetPlayerSourceName)


Previous (GetPlayerOptions)
Next (GetVTMicSource)

Name
GetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetPlayerSourceName ( iPlaylist , iPlayer : integer ) : string

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPlayerOptions)
Next (GetVTMicSource)


Previous (GetPlayerSourceName)
Next (GetVTPlayerASource)

Name
GetVTMicSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTMicSource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPlayerSourceName)
Next (GetVTPlayerASource)


Previous (GetVTMicSource)
Next (GetVTPlayerBSource)

Name
GetVTPlayerASource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTPlayerASource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTMicSource)
Next (GetVTPlayerBSource)


Previous (GetVTPlayerASource)
Next (SendCommand)

Name
GetVTPlayerBSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
function GetVTPlayerBSource : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVTPlayerASource)
Next (SendCommand)


Previous (GetVTPlayerBSource)
Next (SetFaderInputGain)

Name
SendCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SendCommand ( iCommand : byte ; iData : AnsiString )

Parameters
Parameter Description
iCommand : BYTE
iData : ANSISTRING

mAirListScript
Class Tree
Index
Previous (GetVTPlayerBSource)
Next (SetFaderInputGain)


Previous (SendCommand)
Next (SetFaderLevel)

Name
SetFaderInputGain

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderInputGain ( iSourceName : string ; iLevel : ShortInt )

Parameters
Parameter Description
iSourceName : STRING
iLevel : SHORTINT

mAirListScript
Class Tree
Index
Previous (SendCommand)
Next (SetFaderLevel)


Previous (SetFaderInputGain)
Next (SetFaderStart)

Name
SetFaderLevel

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderLevel ( iSourceName : string ; iLevel : ShortInt ; iFadeTime : word )

Parameters
Parameter Description
iSourceName : STRING
iLevel : SHORTINT
iFadeTime : WORD

mAirListScript
Class Tree
Index
Previous (SetFaderInputGain)
Next (SetFaderStart)


Previous (SetFaderLevel)
Next (SetGPI)

Name
SetFaderStart

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetFaderStart ( iSourceName : string ; iStatus : byte )

Parameters
Parameter Description
iSourceName : STRING
iStatus : BYTE

mAirListScript
Class Tree
Index
Previous (SetFaderLevel)
Next (SetGPI)


Previous (SetFaderStart)
Next (SetGPIOffCommand)

Name
SetGPI

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPI ( iNumber , iValue : byte )

Parameters
Parameter Description
iNumber : BYTE
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (SetFaderStart)
Next (SetGPIOffCommand)


Previous (SetGPI)
Next (SetGPIOnCommand)

Name
SetGPIOffCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOffCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetGPI)
Next (SetGPIOnCommand)


Previous (SetGPIOffCommand)
Next (SetOtherSources)

Name
SetGPIOnCommand

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetGPIOnCommand ( iIndex : integer ; iValue : string )

Parameters
Parameter Description
iIndex : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetGPIOffCommand)
Next (SetOtherSources)


Previous (SetGPIOnCommand)
Next (SetPlayerOptions)

Name
SetOtherSources

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetOtherSources ( iValue : IStrings )

Parameters
Parameter Description
iValue : IStrings

mAirListScript
Class Tree
Index
Previous (SetGPIOnCommand)
Next (SetPlayerOptions)


Previous (SetOtherSources)
Next (SetPlayerSourceName)

Name
SetPlayerOptions

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerOptions ( iPlaylist , iPlayer : integer ; iValue : TSASPlayerOptions )

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER
iValue : TSASPlayerOptions

mAirListScript
Class Tree
Index
Previous (SetOtherSources)
Next (SetPlayerSourceName)


Previous (SetPlayerOptions)
Next (SetPrelisten1Off)

Name
SetPlayerSourceName

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPlayerSourceName ( iPlaylist , iPlayer : integer ; iValue : string )

Parameters
Parameter Description
iPlaylist : INTEGER
iPlayer : INTEGER
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPlayerOptions)
Next (SetPrelisten1Off)


Previous (SetPlayerSourceName)
Next (SetPrelisten1On)

Name
SetPrelisten1Off

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1Off ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (SetPlayerSourceName)
Next (SetPrelisten1On)


Previous (SetPrelisten1Off)
Next (SetVTMicSource)

Name
SetPrelisten1On

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetPrelisten1On ( iSourceName : string )

Parameters
Parameter Description
iSourceName : STRING

mAirListScript
Class Tree
Index
Previous (SetPrelisten1Off)
Next (SetVTMicSource)


Previous (SetPrelisten1On)
Next (SetVTPlayerASource)

Name
SetVTMicSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTMicSource ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetPrelisten1On)
Next (SetVTPlayerASource)


Previous (SetVTMicSource)
Next (SetVTPlayerBSource)

Name
SetVTPlayerASource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerASource ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetVTMicSource)
Next (SetVTPlayerBSource)


Previous (SetVTPlayerASource)
Next

Name
SetVTPlayerBSource

Parent
ISASRemote

Visibility
PUBLIC

Source code
procedure SetVTPlayerBSource ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetVTPlayerASource)
Next


Previous (ISASRemote)
Next (ISASSetFaderLevelAction)

Name
ISASSetFaderInputGainAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASRemote)
Next (ISASSetFaderLevelAction)


Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)

Name
ISASSetFaderLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceLevelAction

Visibility
PUBLIC

Members
Methods
Method Description
GetFadeTime (+)
SetFadeTime (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderInputGainAction)
Next (ISASSetFaderStartOffAction)


Previous
Next (SetFadeTime)

Name
GetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
function GetFadeTime : word

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetFadeTime)


Previous (GetFadeTime)
Next

Name
SetFadeTime

Parent
ISASSetFaderLevelAction

Visibility
PUBLIC

Source code
procedure SetFadeTime ( iValue : word )

Parameters
Parameter Description
iValue : WORD

mAirListScript
Class Tree
Index
Previous (GetFadeTime)
Next


Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)

Name
ISASSetFaderStartOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderLevelAction)
Next (ISASSetFaderStartOnAction)


Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)

Name
ISASSetFaderStartOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOffAction)
Next (ISASSetGPIAction)


Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)

Name
ISASSetGPIAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetNumber (+)
SetNumber (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetFaderStartOnAction)
Next (ISASSetGPIOffAction)


Previous
Next (SetNumber)

Name
GetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
function GetNumber : byte

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetNumber)


Previous (GetNumber)
Next

Name
SetNumber

Parent
ISASSetGPIAction

Visibility
PUBLIC

Source code
procedure SetNumber ( iValue : byte )

Parameters
Parameter Description
iValue : BYTE

mAirListScript
Class Tree
Index
Previous (GetNumber)
Next


Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)

Name
ISASSetGPIOffAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIAction)
Next (ISASSetGPIOnAction)


Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)

Name
ISASSetGPIOnAction

Parent
SASInterface

Class Hierarchy
ISASSetGPIAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOffAction)
Next (ISASSetPFLOffAction)


Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)

Name
ISASSetPFLOffAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetGPIOnAction)
Next (ISASSetPFLOnAction)


Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)

Name
ISASSetPFLOnAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOffAction)
Next (ISASSourceAction)


Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)

Name
ISASSourceAction

Parent
SASInterface

Class Hierarchy
ISASAction

Visibility
PUBLIC

Members
Methods
Method Description
GetSourceName (+)
SetSourceName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSetPFLOnAction)
Next (ISASSourceLevelAction)


Previous
Next (SetSourceName)

Name
GetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
function GetSourceName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetSourceName)


Previous (GetSourceName)
Next

Name
SetSourceName

Parent
ISASSourceAction

Visibility
PUBLIC

Source code
procedure SetSourceName ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetSourceName)
Next


Previous (ISASSourceAction)
Next (ISerialSASRemote)

Name
ISASSourceLevelAction

Parent
SASInterface

Class Hierarchy
ISASSourceAction

Visibility
PUBLIC

Members
Methods
Method Description
GetLevel (+)
SetLevel (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceAction)
Next (ISerialSASRemote)


Previous
Next (SetLevel)

Name
GetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
function GetLevel : ShortInt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetLevel)


Previous (GetLevel)
Next

Name
SetLevel

Parent
ISASSourceLevelAction

Visibility
PUBLIC

Source code
procedure SetLevel ( iValue : ShortInt )

Parameters
Parameter Description
iValue : SHORTINT

mAirListScript
Class Tree
Index
Previous (GetLevel)
Next


Previous (ISASSourceLevelAction)
Next

Name
ISerialSASRemote

Parent
SASInterface

Class Hierarchy
ISASRemote

Visibility
PUBLIC

Members
Methods
Method Description
GetPort (+)
SetPort (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (ISASSourceLevelAction)
Next


Previous
Next (SetPort)

Name
GetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
function GetPort : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (SetPort)


Previous (GetPort)
Next

Name
SetPort

Parent
ISerialSASRemote

Visibility
PUBLIC

Source code
procedure SetPort ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (GetPort)
Next


Previous (SASInterface)
Next (ZDbcIntfs)

Name
WMClientInterface

Parent
mAirListScript

Classes
Class Description
IWMClientRemote (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (SASInterface)
Next (ZDbcIntfs)


Previous
Next

Name
IWMClientRemote

Parent
WMClientInterface

Class Hierarchy
IInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetMessages (+)
GetRegisterMessage (+)
GetSetOutputMessage (+)
GetUnregisterMessage (+)
GetWindowName (+)
SetOutput (+)
SetRegisterMessage (+)
SetSetOutputMessage (+)
SetUnregisterMessage (+)
SetWindowName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next


Previous
Next (GetRegisterMessage)

Name
GetMessages

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetMessages : TStringList

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetRegisterMessage)


Previous (GetMessages)
Next (GetSetOutputMessage)

Name
GetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetRegisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMessages)
Next (GetSetOutputMessage)


Previous (GetRegisterMessage)
Next (GetUnregisterMessage)

Name
GetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetSetOutputMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetRegisterMessage)
Next (GetUnregisterMessage)


Previous (GetSetOutputMessage)
Next (GetWindowName)

Name
GetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetUnregisterMessage : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSetOutputMessage)
Next (GetWindowName)


Previous (GetUnregisterMessage)
Next (SetOutput)

Name
GetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
function GetWindowName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUnregisterMessage)
Next (SetOutput)


Previous (GetWindowName)
Next (SetRegisterMessage)

Name
SetOutput

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetOutput ( iNumber : integer ; iValue : integer )

Parameters
Parameter Description
iNumber : INTEGER
iValue : INTEGER

mAirListScript
Class Tree
Index
Previous (GetWindowName)
Next (SetRegisterMessage)


Previous (SetOutput)
Next (SetSetOutputMessage)

Name
SetRegisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetRegisterMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetOutput)
Next (SetSetOutputMessage)


Previous (SetRegisterMessage)
Next (SetUnregisterMessage)

Name
SetSetOutputMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetSetOutputMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetRegisterMessage)
Next (SetUnregisterMessage)


Previous (SetSetOutputMessage)
Next (SetWindowName)

Name
SetUnregisterMessage

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetUnregisterMessage ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetSetOutputMessage)
Next (SetWindowName)


Previous (SetUnregisterMessage)
Next

Name
SetWindowName

Parent
IWMClientRemote

Visibility
PUBLIC

Source code
procedure SetWindowName ( iValue : string )

Parameters
Parameter Description
iValue : STRING

mAirListScript
Class Tree
Index
Previous (SetUnregisterMessage)
Next


Previous (WMClientInterface)
Next

Name
ZDbcIntfs

Parent
mAirListScript

Types
Type Description
TZBestRowIdentifier (+)
TZColumnNullableType (+)
TZFetchDirection (+)
TZImportedKey (+)
TZLocateUpdatesMode (+)
TZPostUpdatesMode (+)
TZProcedureColumnType (+)
TZProcedureResultType (+)
TZResultSetConcurrency (+)
TZResultSetType (+)
TZScopeBestRowIdentifier (+)
TZSQLType (+)
TZTableIndex (+)
TZTransactIsolationLevel (+)
TZVersionColumn (+)

Constants
Constant Description
ProcedureReturnsResult (+)
TypeSearchable (+)

Variables
Variable Description
DriverManager (+)

Classes
Class Description
EZSQLException (+)
EZSQLThrowable (+)
EZSQLWarning (+)
IZBlob (+)
IZCallableStatement (+)
IZConnection (+)
IZDatabaseMetadata (+)
IZDriver (+)
IZDriverManager (+)
IZNotification (+)
IZPreparedStatement (+)
IZResultSet (+)
IZResultSetMetadata (+)
IZSequence (+)
IZStatement (+)
TZDriverManager (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (WMClientInterface)
Next


Previous
Next (EZSQLThrowable)

Name
EZSQLException

Parent
ZDbcIntfs

Class Hierarchy
EZSQLThrowable

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous
Next (EZSQLThrowable)


Previous (EZSQLException)
Next (EZSQLWarning)

Name
EZSQLThrowable

Parent
ZDbcIntfs

Class Hierarchy
Exception

Visibility
PUBLIC

Members
Fields
Field Description
FErrorCode (-)
FStatusCode (-)

Methods
Method | Description
Create (+)
CreateClone (+) | Creates an exception with message string.
CreateWithCode (+) | Creates an exception with message string.
CreateWithStatus (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLException)
Next (EZSQLWarning)


Previous
Next (FStatusCode)

Name
FErrorCode

Parent
EZSQLThrowable

Visibility
PRIVATE

Source code
FErrorCode : Integer

mAirListScript
Class Tree
Index
Previous
Next (FStatusCode)


Previous (FErrorCode)
Next

Name
FStatusCode

Parent
EZSQLThrowable

Visibility
PRIVATE

Source code
FStatusCode : String

mAirListScript
Class Tree
Index
Previous (FErrorCode)
Next


Previous
Next (CreateClone)

Name
Create

Parent
EZSQLThrowable

Visibility
PUBLIC

Source code
constructor Create ( const Msg : string )

Parameters
Parameter Description
Msg : STRING

mAirListScript
Class Tree
Index
Previous
Next (CreateClone)


Previous (Create)
Next (CreateWithCode)

Name
CreateClone

Parent
EZSQLThrowable

Visibility
PUBLIC

Description
Creates an exception with message string.

Source code
constructor CreateClone ( const E : EZSQLThrowable )

Parameters
Parameter Description
E : EZSQLThrowable

mAirListScript
Class Tree
Index
Previous (Create)
Next (CreateWithCode)


Previous (CreateClone)
Next (CreateWithStatus)

Name
CreateWithCode

Parent
EZSQLThrowable

Visibility
PUBLIC

Description
Creates an exception with message string.

Source code
constructor CreateWithCode ( const ErrorCode : Integer ; const Msg : string )

Parameters
Parameter | Description
ErrorCode : INTEGER | a native server error code.
Msg : STRING | a error description.

mAirListScript
Class Tree
Index
Previous (CreateClone)
Next (CreateWithStatus)


Previous (CreateWithCode)
Next

Name
CreateWithStatus

Parent
EZSQLThrowable

Visibility
PUBLIC

Source code
constructor CreateWithStatus ( const StatusCode : String ; const Msg : string )

Parameters
Parameter Description
StatusCode : STRING
Msg : STRING

mAirListScript
Class Tree
Index
Previous (CreateWithCode)
Next


Previous (EZSQLThrowable)
Next (IZBlob)

Name
EZSQLWarning

Parent
ZDbcIntfs

Class Hierarchy
EZSQLThrowable

Visibility
PUBLIC

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLThrowable)
Next (IZBlob)


Previous (EZSQLWarning)
Next (IZCallableStatement)

Name
IZBlob

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
Clear (+)
Clone (+)
GetBytes (+)
GetStream (+)
GetString (+)
GetUnicodeString (+)
IsEmpty (+)
IsUpdated (+)
Length (+)
SetBytes (+)
SetStream (+)
SetString (+)
SetUnicodeString (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (EZSQLWarning)
Next (IZCallableStatement)


Previous
Next (Clone)

Name
Clear

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure Clear

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Clone)


Previous (Clear)
Next (GetBytes)

Name
Clone

Parent
IZBlob

Visibility
PUBLIC

Source code
function Clone : IZBlob

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clear)
Next (GetBytes)


Previous (Clone)
Next (GetStream)

Name
GetBytes

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetBytes : TByteDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Clone)
Next (GetStream)


Previous (GetBytes)
Next (GetString)

Name
GetStream

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetStream : TStream

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetString)


Previous (GetStream)
Next (GetUnicodeString)

Name
GetString

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStream)
Next (GetUnicodeString)


Previous (GetString)
Next (IsEmpty)

Name
GetUnicodeString

Parent
IZBlob

Visibility
PUBLIC

Source code
function GetUnicodeString : WideString

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetString)
Next (IsEmpty)


Previous (GetUnicodeString)
Next (IsUpdated)

Name
IsEmpty

Parent
IZBlob

Visibility
PUBLIC

Source code
function IsEmpty : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (IsUpdated)


Previous (IsEmpty)
Next (Length)

Name
IsUpdated

Parent
IZBlob

Visibility
PUBLIC

Source code
function IsUpdated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsEmpty)
Next (Length)


Previous (IsUpdated)
Next (SetBytes)

Name
Length

Parent
IZBlob

Visibility
PUBLIC

Source code
function Length : LongInt

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsUpdated)
Next (SetBytes)


Previous (Length)
Next (SetStream)

Name
SetBytes

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetBytes ( const Value : TByteDynArray )

Parameters
Parameter Description
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (Length)
Next (SetStream)


Previous (SetBytes)
Next (SetString)

Name
SetStream

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetStream ( Value : TStream )

Parameters
Parameter Description
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetBytes)
Next (SetString)


Previous (SetStream)
Next (SetUnicodeString)

Name
SetString

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetString ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetStream)
Next (SetUnicodeString)


Previous (SetString)
Next

Name
SetUnicodeString

Parent
IZBlob

Visibility
PUBLIC

Source code
procedure SetUnicodeString ( const Value : WideString )

Parameters
Parameter Description
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (SetString)
Next


Previous (IZBlob)
Next (IZConnection)

Name
IZCallableStatement

Parent
ZDbcIntfs

Class Hierarchy
IZPreparedStatement

Visibility
PUBLIC

Members
Methods
Method Description
GetBigDecimal (+)
GetBoolean (+)
GetByte (+)
GetBytes (+)
GetDate (+)
GetDouble (+)
GetFloat (+)
GetInt (+)
GetLong (+)
GetPChar (+)
GetShort (+)
GetString (+)
GetTime (+)
GetTimestamp (+)
GetUnicodeString (+)
GetValue (+)
IsNull (+)
RegisterOutParameter (+)
WasNull (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZBlob)
Next (IZConnection)


Previous
Next (GetBoolean)

Name
GetBigDecimal

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBigDecimal ( ParameterIndex : Integer ) : Extended

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetBoolean)


Previous (GetBigDecimal)
Next (GetByte)

Name
GetBoolean

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBoolean ( ParameterIndex : Integer ) : Boolean

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBigDecimal)
Next (GetByte)


Previous (GetBoolean)
Next (GetBytes)

Name
GetByte

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetByte ( ParameterIndex : Integer ) : ShortInt

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBoolean)
Next (GetBytes)


Previous (GetByte)
Next (GetDate)

Name
GetBytes

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetBytes ( ParameterIndex : Integer ) : TByteDynArray

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetByte)
Next (GetDate)


Previous (GetBytes)
Next (GetDouble)

Name
GetDate

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetDate ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetDouble)


Previous (GetDate)
Next (GetFloat)

Name
GetDouble

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetDouble ( ParameterIndex : Integer ) : Double

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDate)
Next (GetFloat)


Previous (GetDouble)
Next (GetInt)

Name
GetFloat

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetFloat ( ParameterIndex : Integer ) : Single

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDouble)
Next (GetInt)


Previous (GetFloat)
Next (GetLong)

Name
GetInt

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetInt ( ParameterIndex : Integer ) : Integer

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFloat)
Next (GetLong)


Previous (GetInt)
Next (GetPChar)

Name
GetLong

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetLong ( ParameterIndex : Integer ) : Int64

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetInt)
Next (GetPChar)


Previous (GetLong)
Next (GetShort)

Name
GetPChar

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetPChar ( ParameterIndex : Integer ) : PChar

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetLong)
Next (GetShort)


Previous (GetPChar)
Next (GetString)

Name
GetShort

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetShort ( ParameterIndex : Integer ) : SmallInt

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPChar)
Next (GetString)


Previous (GetShort)
Next (GetTime)

Name
GetString

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetString ( ParameterIndex : Integer ) : string

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetShort)
Next (GetTime)


Previous (GetString)
Next (GetTimestamp)

Name
GetTime

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetTime ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetString)
Next (GetTimestamp)


Previous (GetTime)
Next (GetUnicodeString)

Name
GetTimestamp

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetTimestamp ( ParameterIndex : Integer ) : TDateTime

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTime)
Next (GetUnicodeString)


Previous (GetTimestamp)
Next (GetValue)

Name
GetUnicodeString

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetUnicodeString ( ParameterIndex : Integer ) : WideString

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTimestamp)
Next (GetValue)


Previous (GetUnicodeString)
Next (IsNull)

Name
GetValue

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function GetValue ( ParameterIndex : Integer ) : TZVariant

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (IsNull)


Previous (GetValue)
Next (RegisterOutParameter)

Name
IsNull

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function IsNull ( ParameterIndex : Integer ) : Boolean

Parameters
Parameter Description
ParameterIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (RegisterOutParameter)


Previous (IsNull)
Next (WasNull)

Name
RegisterOutParameter

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
procedure RegisterOutParameter ( ParameterIndex : Integer ; SQLType : Integer )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : INTEGER

mAirListScript
Class Tree
Index
Previous (IsNull)
Next (WasNull)


Previous (RegisterOutParameter)
Next

Name
WasNull

Parent
IZCallableStatement

Visibility
PUBLIC

Source code
function WasNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RegisterOutParameter)
Next


Previous (IZCallableStatement)
Next (IZDatabaseMetadata)

Name
IZConnection

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
ClearWarnings (+)
Close (+)
Commit (+)
CommitPrepared (+)
CreateNotification (+)
CreateSequence (+)
CreateStatement (+)
CreateStatementWithParams (+)
EscapeString (+)
GetAutoCommit (+)
GetCatalog (+)
GetClientVersion (+)
GetDriver (+)
GetHostVersion (+)
GetMetadata (+)
GetParameters (+)
GetTransactionIsolation (+)
GetWarnings (+)
IsClosed (+)
IsReadOnly (+)
NativeSQL (+)
Open (+)
PingServer (+)
PrepareCall (+)
PrepareCallWithParams (+)
PrepareStatement (+)
PrepareStatementWithParams (+)
PrepareTransaction (+)
Rollback (+)
RollbackPrepared (+)
SetAutoCommit (+)
SetCatalog (+)
SetReadOnly (+)
SetTransactionIsolation (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZCallableStatement)
Next (IZDatabaseMetadata)


Previous
Next (Close)

Name
ClearWarnings

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (Close)


Previous (ClearWarnings)
Next (Commit)

Name
Close

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (Commit)


Previous (Close)
Next (CommitPrepared)

Name
Commit

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Commit

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Close)
Next (CommitPrepared)


Previous (Commit)
Next (CreateNotification)

Name
CommitPrepared

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure CommitPrepared ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (Commit)
Next (CreateNotification)


Previous (CommitPrepared)
Next (CreateSequence)

Name
CreateNotification

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateNotification ( const Event : string ) : IZNotification

Parameters
Parameter Description
Event : STRING

mAirListScript
Class Tree
Index
Previous (CommitPrepared)
Next (CreateSequence)


Previous (CreateNotification)
Next (CreateStatement)

Name
CreateSequence

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateSequence ( const Sequence : string ; BlockSize : Integer ) : IZSequence

Parameters
Parameter Description
Sequence : STRING
BlockSize : INTEGER

mAirListScript
Class Tree
Index
Previous (CreateNotification)
Next (CreateStatement)


Previous (CreateSequence)
Next (CreateStatementWithParams)

Name
CreateStatement

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateStatement : IZStatement

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CreateSequence)
Next (CreateStatementWithParams)


Previous (CreateStatement)
Next (EscapeString)

Name
CreateStatementWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function CreateStatementWithParams ( Info : TStrings ) : IZStatement

Parameters
Parameter Description
Info : TStrings

mAirListScript
Class Tree
Index
Previous (CreateStatement)
Next (EscapeString)


Previous (CreateStatementWithParams)
Next (GetAutoCommit)

Name
EscapeString

Parent
IZConnection

Visibility
PUBLIC

Source code
function EscapeString ( Value : String ) : String

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (CreateStatementWithParams)
Next (GetAutoCommit)


Previous (EscapeString)
Next (GetCatalog)

Name
GetAutoCommit

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetAutoCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (EscapeString)
Next (GetCatalog)


Previous (GetAutoCommit)
Next (GetClientVersion)

Name
GetCatalog

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetCatalog : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetAutoCommit)
Next (GetClientVersion)


Previous (GetCatalog)
Next (GetDriver)

Name
GetClientVersion

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetClientVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalog)
Next (GetDriver)


Previous (GetClientVersion)
Next (GetHostVersion)

Name
GetDriver

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetDriver : IZDriver

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetHostVersion)


Previous (GetDriver)
Next (GetMetadata)

Name
GetHostVersion

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetHostVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetMetadata)


Previous (GetHostVersion)
Next (GetParameters)

Name
GetMetadata

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetMetadata : IZDatabaseMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetHostVersion)
Next (GetParameters)


Previous (GetMetadata)
Next (GetTransactionIsolation)

Name
GetParameters

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetParameters : TStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetTransactionIsolation)


Previous (GetParameters)
Next (GetWarnings)

Name
GetTransactionIsolation

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetTransactionIsolation : TZTransactIsolationLevel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (GetWarnings)


Previous (GetTransactionIsolation)
Next (IsClosed)

Name
GetWarnings

Parent
IZConnection

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTransactionIsolation)
Next (IsClosed)


Previous (GetWarnings)
Next (IsReadOnly)

Name
IsClosed

Parent
IZConnection

Visibility
PUBLIC

Source code
function IsClosed : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (IsReadOnly)


Previous (IsClosed)
Next (NativeSQL)

Name
IsReadOnly

Parent
IZConnection

Visibility
PUBLIC

Source code
function IsReadOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsClosed)
Next (NativeSQL)


Previous (IsReadOnly)
Next (Open)

Name
NativeSQL

Parent
IZConnection

Visibility
PUBLIC

Source code
function NativeSQL ( const SQL : string ) : string

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (Open)


Previous (NativeSQL)
Next (PingServer)

Name
Open

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Open

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NativeSQL)
Next (PingServer)


Previous (Open)
Next (PrepareCall)

Name
PingServer

Parent
IZConnection

Visibility
PUBLIC

Source code
function PingServer : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Open)
Next (PrepareCall)


Previous (PingServer)
Next (PrepareCallWithParams)

Name
PrepareCall

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareCall ( const SQL : string ) : IZCallableStatement

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (PingServer)
Next (PrepareCallWithParams)


Previous (PrepareCall)
Next (PrepareStatement)

Name
PrepareCallWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareCallWithParams ( const SQL : string ; Info : TStrings ) : IZCallableStatement

Parameters
Parameter Description
SQL : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (PrepareCall)
Next (PrepareStatement)


Previous (PrepareCallWithParams)
Next (PrepareStatementWithParams)

Name
PrepareStatement

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareStatement ( const SQL : string ) : IZPreparedStatement

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (PrepareCallWithParams)
Next (PrepareStatementWithParams)


Previous (PrepareStatement)
Next (PrepareTransaction)

Name
PrepareStatementWithParams

Parent
IZConnection

Visibility
PUBLIC

Source code
function PrepareStatementWithParams ( const SQL : string ; Info : TStrings ) : IZPreparedStatement

Parameters
Parameter Description
SQL : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (PrepareStatement)
Next (PrepareTransaction)


Previous (PrepareStatementWithParams)
Next (Rollback)

Name
PrepareTransaction

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure PrepareTransaction ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (PrepareStatementWithParams)
Next (Rollback)


Previous (PrepareTransaction)
Next (RollbackPrepared)

Name
Rollback

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure Rollback

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (PrepareTransaction)
Next (RollbackPrepared)


Previous (Rollback)
Next (SetAutoCommit)

Name
RollbackPrepared

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure RollbackPrepared ( const transactionid : string )

Parameters
Parameter Description
transactionid : STRING

mAirListScript
Class Tree
Index
Previous (Rollback)
Next (SetAutoCommit)


Previous (RollbackPrepared)
Next (SetCatalog)

Name
SetAutoCommit

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetAutoCommit ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (RollbackPrepared)
Next (SetCatalog)


Previous (SetAutoCommit)
Next (SetReadOnly)

Name
SetCatalog

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetCatalog ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetAutoCommit)
Next (SetReadOnly)


Previous (SetCatalog)
Next (SetTransactionIsolation)

Name
SetReadOnly

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetReadOnly ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetCatalog)
Next (SetTransactionIsolation)


Previous (SetReadOnly)
Next

Name
SetTransactionIsolation

Parent
IZConnection

Visibility
PUBLIC

Source code
procedure SetTransactionIsolation ( Value : TZTransactIsolationLevel )

Parameters
Parameter Description
Value : TZTransactIsolationLevel

mAirListScript
Class Tree
Index
Previous (SetReadOnly)
Next


Previous (IZConnection)
Next (IZDriver)

Name
IZDatabaseMetadata

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddEscapeCharToWildcards (+)
AllProceduresAreCallable (+)
AllTablesAreSelectable (+)
ClearCache (+)
DataDefinitionCausesTransactionCommit (+)
DataDefinitionIgnoredInTransactions (+)
DoesMaxRowSizeIncludeBlobs (+)
GetBestRowIdentifier (+)
GetCatalogs (+)
GetCatalogSeparator (+)
GetCatalogTerm (+)
GetColumnPrivileges (+)
GetColumns (+)
GetConnection (+)
GetCrossReference (+)
GetDatabaseProductName (+)
GetDatabaseProductVersion (+)
GetDefaultTransactionIsolation (+)
GetDriverMajorVersion (+)
GetDriverMinorVersion (+)
GetDriverName (+)
GetDriverVersion (+)
GetExportedKeys (+)
GetExtraNameCharacters (+)
GetIdentifierConvertor (+)
GetIdentifierQuoteString (+)
GetImportedKeys (+)
GetIndexInfo (+)
GetMaxBinaryLiteralLength (+)
GetMaxCatalogNameLength (+)
GetMaxCharLiteralLength (+)
GetMaxColumnNameLength (+)
GetMaxColumnsInGroupBy (+)
GetMaxColumnsInIndex (+)
GetMaxColumnsInOrderBy (+)
GetMaxColumnsInSelect (+)
GetMaxColumnsInTable (+)
GetMaxConnections (+)
GetMaxCursorNameLength (+)
GetMaxIndexLength (+)
GetMaxProcedureNameLength (+)
GetMaxRowSize (+)
GetMaxSchemaNameLength (+)
GetMaxStatementLength (+)
GetMaxStatements (+)
GetMaxTableNameLength (+)
GetMaxTablesInSelect (+)
GetMaxUserNameLength (+)
GetNumericFunctions (+)
GetPrimaryKeys (+)
GetProcedureColumns (+)
GetProcedures (+)
GetProcedureTerm (+)
GetSchemas (+)
GetSchemaTerm (+)
GetSearchStringEscape (+)
GetSequences (+)
GetSQLKeywords (+)
GetStringFunctions (+)
GetSystemFunctions (+)
GetTablePrivileges (+)
GetTables (+)
GetTableTypes (+)
GetTimeDateFunctions (+)
GetTypeInfo (+)
GetUDTs (+)
GetURL (+)
GetUserName (+)
GetVersionColumns (+)
IsCatalogAtStart (+)
IsReadOnly (+)
NullPlusNonNullIsNull (+)
NullsAreSortedAtEnd (+)
NullsAreSortedAtStart (+)
NullsAreSortedHigh (+)
NullsAreSortedLow (+)
StoresLowerCaseIdentifiers (+)
StoresLowerCaseQuotedIdentifiers (+)
StoresMixedCaseIdentifiers (+)
StoresMixedCaseQuotedIdentifiers (+)
StoresUpperCaseIdentifiers (+)
StoresUpperCaseQuotedIdentifiers (+)
SupportsAlterTableWithAddColumn (+)
SupportsAlterTableWithDropColumn (+)
SupportsANSI92EntryLevelSQL (+)
SupportsANSI92FullSQL (+)
SupportsANSI92IntermediateSQL (+)
SupportsBatchUpdates (+)
SupportsCatalogsInDataManipulation (+)
SupportsCatalogsInIndexDefinitions (+)
SupportsCatalogsInPrivilegeDefinitions (+)
SupportsCatalogsInProcedureCalls (+)
SupportsCatalogsInTableDefinitions (+)
SupportsColumnAliasing (+)
SupportsConvert (+)
SupportsConvertForTypes (+)
SupportsCoreSQLGrammar (+)
SupportsCorrelatedSubqueries (+)
SupportsDataDefinitionAndDataManipulationTransactions (+)
SupportsDataManipulationTransactionsOnly (+)
SupportsDifferentTableCorrelationNames (+)
SupportsExpressionsInOrderBy (+)
SupportsExtendedSQLGrammar (+)
SupportsFullOuterJoins (+)
SupportsGroupBy (+)
SupportsGroupByBeyondSelect (+)
SupportsGroupByUnrelated (+)
SupportsIntegrityEnhancementFacility (+)
SupportsLikeEscapeClause (+)
SupportsLimitedOuterJoins (+)
SupportsMinimumSQLGrammar (+)
SupportsMixedCaseIdentifiers (+)
SupportsMixedCaseQuotedIdentifiers (+)
SupportsMultipleResultSets (+)
SupportsMultipleTransactions (+)
SupportsNonNullableColumns (+)
SupportsOpenCursorsAcrossCommit (+)
SupportsOpenCursorsAcrossRollback (+)
SupportsOpenStatementsAcrossCommit (+)
SupportsOpenStatementsAcrossRollback (+)
SupportsOrderByUnrelated (+)
SupportsOuterJoins (+)
SupportsPositionedDelete (+)
SupportsPositionedUpdate (+)
SupportsResultSetConcurrency (+)
SupportsResultSetType (+)
SupportsSchemasInDataManipulation (+)
SupportsSchemasInIndexDefinitions (+)
SupportsSchemasInPrivilegeDefinitions (+)
SupportsSchemasInProcedureCalls (+)
SupportsSchemasInTableDefinitions (+)
SupportsSelectForUpdate (+)
SupportsStoredProcedures (+)
SupportsSubqueriesInComparisons (+)
SupportsSubqueriesInExists (+)
SupportsSubqueriesInIns (+)
SupportsSubqueriesInQuantifieds (+)
SupportsTableCorrelationNames (+)
SupportsTransactionIsolationLevel (+)
SupportsTransactions (+)
SupportsUnion (+)
SupportsUnionAll (+)
UsesLocalFilePerTable (+)
UsesLocalFiles (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZConnection)
Next (IZDriver)


Previous
Next (AllProceduresAreCallable)

Name
AddEscapeCharToWildcards

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AddEscapeCharToWildcards ( const Pattern : string ) : string

Parameters
Parameter Description
Pattern : STRING

mAirListScript
Class Tree
Index
Previous
Next (AllProceduresAreCallable)


Previous (AddEscapeCharToWildcards)
Next (AllTablesAreSelectable)

Name
AllProceduresAreCallable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AllProceduresAreCallable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddEscapeCharToWildcards)
Next (AllTablesAreSelectable)


Previous (AllProceduresAreCallable)
Next (ClearCache)

Name
AllTablesAreSelectable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function AllTablesAreSelectable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AllProceduresAreCallable)
Next (ClearCache)


Previous (AllTablesAreSelectable)
Next (DataDefinitionCausesTransactionCommit)

Name
ClearCache

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
procedure ClearCache

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AllTablesAreSelectable)
Next (DataDefinitionCausesTransactionCommit)


Previous (ClearCache)
Next (DataDefinitionIgnoredInTransactions)

Name
DataDefinitionCausesTransactionCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DataDefinitionCausesTransactionCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearCache)
Next (DataDefinitionIgnoredInTransactions)


Previous (DataDefinitionCausesTransactionCommit)
Next (DoesMaxRowSizeIncludeBlobs)

Name
DataDefinitionIgnoredInTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DataDefinitionIgnoredInTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DataDefinitionCausesTransactionCommit)
Next (DoesMaxRowSizeIncludeBlobs)


Previous (DataDefinitionIgnoredInTransactions)
Next (GetBestRowIdentifier)

Name
DoesMaxRowSizeIncludeBlobs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function DoesMaxRowSizeIncludeBlobs : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DataDefinitionIgnoredInTransactions)
Next (GetBestRowIdentifier)


Previous (DoesMaxRowSizeIncludeBlobs)
Next (GetCatalogs)

Name
GetBestRowIdentifier

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetBestRowIdentifier ( const Catalog : string ; const Schema : string ; const Table : string ; Scope : Integer ; Nullable : Boolean ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
Scope : INTEGER
Nullable : BOOLEAN

mAirListScript
Class Tree
Index
Previous (DoesMaxRowSizeIncludeBlobs)
Next (GetCatalogs)


Previous (GetBestRowIdentifier)
Next (GetCatalogSeparator)

Name
GetCatalogs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogs : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBestRowIdentifier)
Next (GetCatalogSeparator)


Previous (GetCatalogs)
Next (GetCatalogTerm)

Name
GetCatalogSeparator

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogSeparator : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogs)
Next (GetCatalogTerm)


Previous (GetCatalogSeparator)
Next (GetColumnPrivileges)

Name
GetCatalogTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCatalogTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogSeparator)
Next (GetColumnPrivileges)


Previous (GetCatalogTerm)
Next (GetColumns)

Name
GetColumnPrivileges

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetColumnPrivileges ( const Catalog : string ; const Schema : string ; const Table : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetCatalogTerm)
Next (GetColumns)


Previous (GetColumnPrivileges)
Next (GetConnection)

Name
GetColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetColumns ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetColumnPrivileges)
Next (GetConnection)


Previous (GetColumns)
Next (GetCrossReference)

Name
GetConnection

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetColumns)
Next (GetCrossReference)


Previous (GetConnection)
Next (GetDatabaseProductName)

Name
GetCrossReference

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetCrossReference ( const PrimaryCatalog : string ; const PrimarySchema : string ; const PrimaryTable : string ; const ForeignCatalog : string ; const ForeignSchema : string ; const ForeignTable : string ) : IZResultSet

Parameters
Parameter Description
PrimaryCatalog : STRING
PrimarySchema : STRING
PrimaryTable : STRING
ForeignCatalog : STRING
ForeignSchema : STRING
ForeignTable : STRING

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetDatabaseProductName)


Previous (GetCrossReference)
Next (GetDatabaseProductVersion)

Name
GetDatabaseProductName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDatabaseProductName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCrossReference)
Next (GetDatabaseProductVersion)


Previous (GetDatabaseProductName)
Next (GetDefaultTransactionIsolation)

Name
GetDatabaseProductVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDatabaseProductVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseProductName)
Next (GetDefaultTransactionIsolation)


Previous (GetDatabaseProductVersion)
Next (GetDriverMajorVersion)

Name
GetDefaultTransactionIsolation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDefaultTransactionIsolation : TZTransactIsolationLevel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDatabaseProductVersion)
Next (GetDriverMajorVersion)


Previous (GetDefaultTransactionIsolation)
Next (GetDriverMinorVersion)

Name
GetDriverMajorVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverMajorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDefaultTransactionIsolation)
Next (GetDriverMinorVersion)


Previous (GetDriverMajorVersion)
Next (GetDriverName)

Name
GetDriverMinorVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverMinorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverMajorVersion)
Next (GetDriverName)


Previous (GetDriverMinorVersion)
Next (GetDriverVersion)

Name
GetDriverName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverMinorVersion)
Next (GetDriverVersion)


Previous (GetDriverName)
Next (GetExportedKeys)

Name
GetDriverVersion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetDriverVersion : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriverName)
Next (GetExportedKeys)


Previous (GetDriverVersion)
Next (GetExtraNameCharacters)

Name
GetExportedKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetExportedKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetDriverVersion)
Next (GetExtraNameCharacters)


Previous (GetExportedKeys)
Next (GetIdentifierConvertor)

Name
GetExtraNameCharacters

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetExtraNameCharacters : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExportedKeys)
Next (GetIdentifierConvertor)


Previous (GetExtraNameCharacters)
Next (GetIdentifierQuoteString)

Name
GetIdentifierConvertor

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIdentifierConvertor : IZIdentifierConvertor

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetExtraNameCharacters)
Next (GetIdentifierQuoteString)


Previous (GetIdentifierConvertor)
Next (GetImportedKeys)

Name
GetIdentifierQuoteString

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIdentifierQuoteString : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIdentifierConvertor)
Next (GetImportedKeys)


Previous (GetIdentifierQuoteString)
Next (GetIndexInfo)

Name
GetImportedKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetImportedKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetIdentifierQuoteString)
Next (GetIndexInfo)


Previous (GetImportedKeys)
Next (GetMaxBinaryLiteralLength)

Name
GetIndexInfo

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetIndexInfo ( const Catalog : string ; const Schema : string ; const Table : string ; Unique : Boolean ; Approximate : Boolean ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING
Unique : BOOLEAN
Approximate : BOOLEAN

mAirListScript
Class Tree
Index
Previous (GetImportedKeys)
Next (GetMaxBinaryLiteralLength)


Previous (GetIndexInfo)
Next (GetMaxCatalogNameLength)

Name
GetMaxBinaryLiteralLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxBinaryLiteralLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIndexInfo)
Next (GetMaxCatalogNameLength)


Previous (GetMaxBinaryLiteralLength)
Next (GetMaxCharLiteralLength)

Name
GetMaxCatalogNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCatalogNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxBinaryLiteralLength)
Next (GetMaxCharLiteralLength)


Previous (GetMaxCatalogNameLength)
Next (GetMaxColumnNameLength)

Name
GetMaxCharLiteralLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCharLiteralLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCatalogNameLength)
Next (GetMaxColumnNameLength)


Previous (GetMaxCharLiteralLength)
Next (GetMaxColumnsInGroupBy)

Name
GetMaxColumnNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCharLiteralLength)
Next (GetMaxColumnsInGroupBy)


Previous (GetMaxColumnNameLength)
Next (GetMaxColumnsInIndex)

Name
GetMaxColumnsInGroupBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInGroupBy : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnNameLength)
Next (GetMaxColumnsInIndex)


Previous (GetMaxColumnsInGroupBy)
Next (GetMaxColumnsInOrderBy)

Name
GetMaxColumnsInIndex

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInIndex : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInGroupBy)
Next (GetMaxColumnsInOrderBy)


Previous (GetMaxColumnsInIndex)
Next (GetMaxColumnsInSelect)

Name
GetMaxColumnsInOrderBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInOrderBy : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInIndex)
Next (GetMaxColumnsInSelect)


Previous (GetMaxColumnsInOrderBy)
Next (GetMaxColumnsInTable)

Name
GetMaxColumnsInSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInSelect : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInOrderBy)
Next (GetMaxColumnsInTable)


Previous (GetMaxColumnsInSelect)
Next (GetMaxConnections)

Name
GetMaxColumnsInTable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxColumnsInTable : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInSelect)
Next (GetMaxConnections)


Previous (GetMaxColumnsInTable)
Next (GetMaxCursorNameLength)

Name
GetMaxConnections

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxConnections : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxColumnsInTable)
Next (GetMaxCursorNameLength)


Previous (GetMaxConnections)
Next (GetMaxIndexLength)

Name
GetMaxCursorNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxCursorNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxConnections)
Next (GetMaxIndexLength)


Previous (GetMaxCursorNameLength)
Next (GetMaxProcedureNameLength)

Name
GetMaxIndexLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxIndexLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxCursorNameLength)
Next (GetMaxProcedureNameLength)


Previous (GetMaxIndexLength)
Next (GetMaxRowSize)

Name
GetMaxProcedureNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxProcedureNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxIndexLength)
Next (GetMaxRowSize)


Previous (GetMaxProcedureNameLength)
Next (GetMaxSchemaNameLength)

Name
GetMaxRowSize

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxRowSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxProcedureNameLength)
Next (GetMaxSchemaNameLength)


Previous (GetMaxRowSize)
Next (GetMaxStatementLength)

Name
GetMaxSchemaNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxSchemaNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxRowSize)
Next (GetMaxStatementLength)


Previous (GetMaxSchemaNameLength)
Next (GetMaxStatements)

Name
GetMaxStatementLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxStatementLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxSchemaNameLength)
Next (GetMaxStatements)


Previous (GetMaxStatementLength)
Next (GetMaxTableNameLength)

Name
GetMaxStatements

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxStatements : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxStatementLength)
Next (GetMaxTableNameLength)


Previous (GetMaxStatements)
Next (GetMaxTablesInSelect)

Name
GetMaxTableNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxTableNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxStatements)
Next (GetMaxTablesInSelect)


Previous (GetMaxTableNameLength)
Next (GetMaxUserNameLength)

Name
GetMaxTablesInSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxTablesInSelect : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxTableNameLength)
Next (GetMaxUserNameLength)


Previous (GetMaxTablesInSelect)
Next (GetNumericFunctions)

Name
GetMaxUserNameLength

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetMaxUserNameLength : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxTablesInSelect)
Next (GetNumericFunctions)


Previous (GetMaxUserNameLength)
Next (GetPrimaryKeys)

Name
GetNumericFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetNumericFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxUserNameLength)
Next (GetPrimaryKeys)


Previous (GetNumericFunctions)
Next (GetProcedureColumns)

Name
GetPrimaryKeys

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetPrimaryKeys ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetNumericFunctions)
Next (GetProcedureColumns)


Previous (GetPrimaryKeys)
Next (GetProcedures)

Name
GetProcedureColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedureColumns ( const Catalog : string ; const SchemaPattern : string ; const ProcedureNamePattern : string ; const ColumnNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
ProcedureNamePattern : STRING
ColumnNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetPrimaryKeys)
Next (GetProcedures)


Previous (GetProcedureColumns)
Next (GetProcedureTerm)

Name
GetProcedures

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedures ( const Catalog : string ; const SchemaPattern : string ; const ProcedureNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
ProcedureNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetProcedureColumns)
Next (GetProcedureTerm)


Previous (GetProcedures)
Next (GetSchemas)

Name
GetProcedureTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetProcedureTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProcedures)
Next (GetSchemas)


Previous (GetProcedureTerm)
Next (GetSchemaTerm)

Name
GetSchemas

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSchemas : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetProcedureTerm)
Next (GetSchemaTerm)


Previous (GetSchemas)
Next (GetSearchStringEscape)

Name
GetSchemaTerm

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSchemaTerm : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSchemas)
Next (GetSearchStringEscape)


Previous (GetSchemaTerm)
Next (GetSequences)

Name
GetSearchStringEscape

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSearchStringEscape : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSchemaTerm)
Next (GetSequences)


Previous (GetSearchStringEscape)
Next (GetSQLKeywords)

Name
GetSequences

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSequences ( const Catalog : string ; const SchemaPattern : string ; const SequenceNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
SequenceNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetSearchStringEscape)
Next (GetSQLKeywords)


Previous (GetSequences)
Next (GetStringFunctions)

Name
GetSQLKeywords

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSQLKeywords : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSequences)
Next (GetStringFunctions)


Previous (GetSQLKeywords)
Next (GetSystemFunctions)

Name
GetStringFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetStringFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSQLKeywords)
Next (GetSystemFunctions)


Previous (GetStringFunctions)
Next (GetTablePrivileges)

Name
GetSystemFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetSystemFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStringFunctions)
Next (GetTablePrivileges)


Previous (GetSystemFunctions)
Next (GetTables)

Name
GetTablePrivileges

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTablePrivileges ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING

mAirListScript
Class Tree
Index
Previous (GetSystemFunctions)
Next (GetTables)


Previous (GetTablePrivileges)
Next (GetTableTypes)

Name
GetTables

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTables ( const Catalog : string ; const SchemaPattern : string ; const TableNamePattern : string ; const Types : TStringDynArray ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TableNamePattern : STRING
Types : TStringDynArray

mAirListScript
Class Tree
Index
Previous (GetTablePrivileges)
Next (GetTableTypes)


Previous (GetTables)
Next (GetTimeDateFunctions)

Name
GetTableTypes

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTableTypes : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTables)
Next (GetTimeDateFunctions)


Previous (GetTableTypes)
Next (GetTypeInfo)

Name
GetTimeDateFunctions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTimeDateFunctions : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTableTypes)
Next (GetTypeInfo)


Previous (GetTimeDateFunctions)
Next (GetUDTs)

Name
GetTypeInfo

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetTypeInfo : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimeDateFunctions)
Next (GetUDTs)


Previous (GetTypeInfo)
Next (GetURL)

Name
GetUDTs

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetUDTs ( const Catalog : string ; const SchemaPattern : string ; const TypeNamePattern : string ; const Types : TIntegerDynArray ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
SchemaPattern : STRING
TypeNamePattern : STRING
Types : TIntegerDynArray

mAirListScript
Class Tree
Index
Previous (GetTypeInfo)
Next (GetURL)


Previous (GetUDTs)
Next (GetUserName)

Name
GetURL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetURL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUDTs)
Next (GetUserName)


Previous (GetURL)
Next (GetVersionColumns)

Name
GetUserName

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetUserName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetURL)
Next (GetVersionColumns)


Previous (GetUserName)
Next (IsCatalogAtStart)

Name
GetVersionColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function GetVersionColumns ( const Catalog : string ; const Schema : string ; const Table : string ) : IZResultSet

Parameters
Parameter Description
Catalog : STRING
Schema : STRING
Table : STRING

mAirListScript
Class Tree
Index
Previous (GetUserName)
Next (IsCatalogAtStart)


Previous (GetVersionColumns)
Next (IsReadOnly)

Name
IsCatalogAtStart

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function IsCatalogAtStart : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetVersionColumns)
Next (IsReadOnly)


Previous (IsCatalogAtStart)
Next (NullPlusNonNullIsNull)

Name
IsReadOnly

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function IsReadOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsCatalogAtStart)
Next (NullPlusNonNullIsNull)


Previous (IsReadOnly)
Next (NullsAreSortedAtEnd)

Name
NullPlusNonNullIsNull

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullPlusNonNullIsNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (NullsAreSortedAtEnd)


Previous (NullPlusNonNullIsNull)
Next (NullsAreSortedAtStart)

Name
NullsAreSortedAtEnd

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedAtEnd : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullPlusNonNullIsNull)
Next (NullsAreSortedAtStart)


Previous (NullsAreSortedAtEnd)
Next (NullsAreSortedHigh)

Name
NullsAreSortedAtStart

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedAtStart : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedAtEnd)
Next (NullsAreSortedHigh)


Previous (NullsAreSortedAtStart)
Next (NullsAreSortedLow)

Name
NullsAreSortedHigh

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedHigh : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedAtStart)
Next (NullsAreSortedLow)


Previous (NullsAreSortedHigh)
Next (StoresLowerCaseIdentifiers)

Name
NullsAreSortedLow

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function NullsAreSortedLow : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedHigh)
Next (StoresLowerCaseIdentifiers)


Previous (NullsAreSortedLow)
Next (StoresLowerCaseQuotedIdentifiers)

Name
StoresLowerCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresLowerCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (NullsAreSortedLow)
Next (StoresLowerCaseQuotedIdentifiers)


Previous (StoresLowerCaseIdentifiers)
Next (StoresMixedCaseIdentifiers)

Name
StoresLowerCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresLowerCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresLowerCaseIdentifiers)
Next (StoresMixedCaseIdentifiers)


Previous (StoresLowerCaseQuotedIdentifiers)
Next (StoresMixedCaseQuotedIdentifiers)

Name
StoresMixedCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresMixedCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresLowerCaseQuotedIdentifiers)
Next (StoresMixedCaseQuotedIdentifiers)


Previous (StoresMixedCaseIdentifiers)
Next (StoresUpperCaseIdentifiers)

Name
StoresMixedCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresMixedCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresMixedCaseIdentifiers)
Next (StoresUpperCaseIdentifiers)


Previous (StoresMixedCaseQuotedIdentifiers)
Next (StoresUpperCaseQuotedIdentifiers)

Name
StoresUpperCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresUpperCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresMixedCaseQuotedIdentifiers)
Next (StoresUpperCaseQuotedIdentifiers)


Previous (StoresUpperCaseIdentifiers)
Next (SupportsAlterTableWithAddColumn)

Name
StoresUpperCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function StoresUpperCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresUpperCaseIdentifiers)
Next (SupportsAlterTableWithAddColumn)


Previous (StoresUpperCaseQuotedIdentifiers)
Next (SupportsAlterTableWithDropColumn)

Name
SupportsAlterTableWithAddColumn

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsAlterTableWithAddColumn : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (StoresUpperCaseQuotedIdentifiers)
Next (SupportsAlterTableWithDropColumn)


Previous (SupportsAlterTableWithAddColumn)
Next (SupportsANSI92EntryLevelSQL)

Name
SupportsAlterTableWithDropColumn

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsAlterTableWithDropColumn : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsAlterTableWithAddColumn)
Next (SupportsANSI92EntryLevelSQL)


Previous (SupportsAlterTableWithDropColumn)
Next (SupportsANSI92FullSQL)

Name
SupportsANSI92EntryLevelSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92EntryLevelSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsAlterTableWithDropColumn)
Next (SupportsANSI92FullSQL)


Previous (SupportsANSI92EntryLevelSQL)
Next (SupportsANSI92IntermediateSQL)

Name
SupportsANSI92FullSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92FullSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92EntryLevelSQL)
Next (SupportsANSI92IntermediateSQL)


Previous (SupportsANSI92FullSQL)
Next (SupportsBatchUpdates)

Name
SupportsANSI92IntermediateSQL

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsANSI92IntermediateSQL : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92FullSQL)
Next (SupportsBatchUpdates)


Previous (SupportsANSI92IntermediateSQL)
Next (SupportsCatalogsInDataManipulation)

Name
SupportsBatchUpdates

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsBatchUpdates : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsANSI92IntermediateSQL)
Next (SupportsCatalogsInDataManipulation)


Previous (SupportsBatchUpdates)
Next (SupportsCatalogsInIndexDefinitions)

Name
SupportsCatalogsInDataManipulation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInDataManipulation : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsBatchUpdates)
Next (SupportsCatalogsInIndexDefinitions)


Previous (SupportsCatalogsInDataManipulation)
Next (SupportsCatalogsInPrivilegeDefinitions)

Name
SupportsCatalogsInIndexDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInIndexDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInDataManipulation)
Next (SupportsCatalogsInPrivilegeDefinitions)


Previous (SupportsCatalogsInIndexDefinitions)
Next (SupportsCatalogsInProcedureCalls)

Name
SupportsCatalogsInPrivilegeDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInPrivilegeDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInIndexDefinitions)
Next (SupportsCatalogsInProcedureCalls)


Previous (SupportsCatalogsInPrivilegeDefinitions)
Next (SupportsCatalogsInTableDefinitions)

Name
SupportsCatalogsInProcedureCalls

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInProcedureCalls : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInPrivilegeDefinitions)
Next (SupportsCatalogsInTableDefinitions)


Previous (SupportsCatalogsInProcedureCalls)
Next (SupportsColumnAliasing)

Name
SupportsCatalogsInTableDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCatalogsInTableDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInProcedureCalls)
Next (SupportsColumnAliasing)


Previous (SupportsCatalogsInTableDefinitions)
Next (SupportsConvert)

Name
SupportsColumnAliasing

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsColumnAliasing : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCatalogsInTableDefinitions)
Next (SupportsConvert)


Previous (SupportsColumnAliasing)
Next (SupportsConvertForTypes)

Name
SupportsConvert

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsConvert : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsColumnAliasing)
Next (SupportsConvertForTypes)


Previous (SupportsConvert)
Next (SupportsCoreSQLGrammar)

Name
SupportsConvertForTypes

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsConvertForTypes ( FromType : TZSQLType ; ToType : TZSQLType ) : Boolean

Parameters
Parameter Description
FromType : TZSQLType
ToType : TZSQLType

mAirListScript
Class Tree
Index
Previous (SupportsConvert)
Next (SupportsCoreSQLGrammar)


Previous (SupportsConvertForTypes)
Next (SupportsCorrelatedSubqueries)

Name
SupportsCoreSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCoreSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsConvertForTypes)
Next (SupportsCorrelatedSubqueries)


Previous (SupportsCoreSQLGrammar)
Next (SupportsDataDefinitionAndDataManipulationTransactions)

Name
SupportsCorrelatedSubqueries

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsCorrelatedSubqueries : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCoreSQLGrammar)
Next (SupportsDataDefinitionAndDataManipulationTransactions)


Previous (SupportsCorrelatedSubqueries)
Next (SupportsDataManipulationTransactionsOnly)

Name
SupportsDataDefinitionAndDataManipulationTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDataDefinitionAndDataManipulationTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsCorrelatedSubqueries)
Next (SupportsDataManipulationTransactionsOnly)


Previous (SupportsDataDefinitionAndDataManipulationTransactions)
Next (SupportsDifferentTableCorrelationNames)

Name
SupportsDataManipulationTransactionsOnly

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDataManipulationTransactionsOnly : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDataDefinitionAndDataManipulationTransactions)
Next (SupportsDifferentTableCorrelationNames)


Previous (SupportsDataManipulationTransactionsOnly)
Next (SupportsExpressionsInOrderBy)

Name
SupportsDifferentTableCorrelationNames

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsDifferentTableCorrelationNames : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDataManipulationTransactionsOnly)
Next (SupportsExpressionsInOrderBy)


Previous (SupportsDifferentTableCorrelationNames)
Next (SupportsExtendedSQLGrammar)

Name
SupportsExpressionsInOrderBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsExpressionsInOrderBy : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsDifferentTableCorrelationNames)
Next (SupportsExtendedSQLGrammar)


Previous (SupportsExpressionsInOrderBy)
Next (SupportsFullOuterJoins)

Name
SupportsExtendedSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsExtendedSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsExpressionsInOrderBy)
Next (SupportsFullOuterJoins)


Previous (SupportsExtendedSQLGrammar)
Next (SupportsGroupBy)

Name
SupportsFullOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsFullOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsExtendedSQLGrammar)
Next (SupportsGroupBy)


Previous (SupportsFullOuterJoins)
Next (SupportsGroupByBeyondSelect)

Name
SupportsGroupBy

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupBy : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsFullOuterJoins)
Next (SupportsGroupByBeyondSelect)


Previous (SupportsGroupBy)
Next (SupportsGroupByUnrelated)

Name
SupportsGroupByBeyondSelect

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupByBeyondSelect : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupBy)
Next (SupportsGroupByUnrelated)


Previous (SupportsGroupByBeyondSelect)
Next (SupportsIntegrityEnhancementFacility)

Name
SupportsGroupByUnrelated

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsGroupByUnrelated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupByBeyondSelect)
Next (SupportsIntegrityEnhancementFacility)


Previous (SupportsGroupByUnrelated)
Next (SupportsLikeEscapeClause)

Name
SupportsIntegrityEnhancementFacility

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsIntegrityEnhancementFacility : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsGroupByUnrelated)
Next (SupportsLikeEscapeClause)


Previous (SupportsIntegrityEnhancementFacility)
Next (SupportsLimitedOuterJoins)

Name
SupportsLikeEscapeClause

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsLikeEscapeClause : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsIntegrityEnhancementFacility)
Next (SupportsLimitedOuterJoins)


Previous (SupportsLikeEscapeClause)
Next (SupportsMinimumSQLGrammar)

Name
SupportsLimitedOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsLimitedOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsLikeEscapeClause)
Next (SupportsMinimumSQLGrammar)


Previous (SupportsLimitedOuterJoins)
Next (SupportsMixedCaseIdentifiers)

Name
SupportsMinimumSQLGrammar

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMinimumSQLGrammar : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsLimitedOuterJoins)
Next (SupportsMixedCaseIdentifiers)


Previous (SupportsMinimumSQLGrammar)
Next (SupportsMixedCaseQuotedIdentifiers)

Name
SupportsMixedCaseIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMixedCaseIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMinimumSQLGrammar)
Next (SupportsMixedCaseQuotedIdentifiers)


Previous (SupportsMixedCaseIdentifiers)
Next (SupportsMultipleResultSets)

Name
SupportsMixedCaseQuotedIdentifiers

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMixedCaseQuotedIdentifiers : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMixedCaseIdentifiers)
Next (SupportsMultipleResultSets)


Previous (SupportsMixedCaseQuotedIdentifiers)
Next (SupportsMultipleTransactions)

Name
SupportsMultipleResultSets

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMultipleResultSets : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMixedCaseQuotedIdentifiers)
Next (SupportsMultipleTransactions)


Previous (SupportsMultipleResultSets)
Next (SupportsNonNullableColumns)

Name
SupportsMultipleTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsMultipleTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMultipleResultSets)
Next (SupportsNonNullableColumns)


Previous (SupportsMultipleTransactions)
Next (SupportsOpenCursorsAcrossCommit)

Name
SupportsNonNullableColumns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsNonNullableColumns : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsMultipleTransactions)
Next (SupportsOpenCursorsAcrossCommit)


Previous (SupportsNonNullableColumns)
Next (SupportsOpenCursorsAcrossRollback)

Name
SupportsOpenCursorsAcrossCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenCursorsAcrossCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsNonNullableColumns)
Next (SupportsOpenCursorsAcrossRollback)


Previous (SupportsOpenCursorsAcrossCommit)
Next (SupportsOpenStatementsAcrossCommit)

Name
SupportsOpenCursorsAcrossRollback

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenCursorsAcrossRollback : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenCursorsAcrossCommit)
Next (SupportsOpenStatementsAcrossCommit)


Previous (SupportsOpenCursorsAcrossRollback)
Next (SupportsOpenStatementsAcrossRollback)

Name
SupportsOpenStatementsAcrossCommit

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenStatementsAcrossCommit : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenCursorsAcrossRollback)
Next (SupportsOpenStatementsAcrossRollback)


Previous (SupportsOpenStatementsAcrossCommit)
Next (SupportsOrderByUnrelated)

Name
SupportsOpenStatementsAcrossRollback

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOpenStatementsAcrossRollback : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenStatementsAcrossCommit)
Next (SupportsOrderByUnrelated)


Previous (SupportsOpenStatementsAcrossRollback)
Next (SupportsOuterJoins)

Name
SupportsOrderByUnrelated

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOrderByUnrelated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOpenStatementsAcrossRollback)
Next (SupportsOuterJoins)


Previous (SupportsOrderByUnrelated)
Next (SupportsPositionedDelete)

Name
SupportsOuterJoins

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsOuterJoins : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOrderByUnrelated)
Next (SupportsPositionedDelete)


Previous (SupportsOuterJoins)
Next (SupportsPositionedUpdate)

Name
SupportsPositionedDelete

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsPositionedDelete : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsOuterJoins)
Next (SupportsPositionedUpdate)


Previous (SupportsPositionedDelete)
Next (SupportsResultSetConcurrency)

Name
SupportsPositionedUpdate

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsPositionedUpdate : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsPositionedDelete)
Next (SupportsResultSetConcurrency)


Previous (SupportsPositionedUpdate)
Next (SupportsResultSetType)

Name
SupportsResultSetConcurrency

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsResultSetConcurrency ( _Type : TZResultSetType ; Concurrency : TZResultSetConcurrency ) : Boolean

Parameters
Parameter Description
_Type : TZResultSetType
Concurrency : TZResultSetConcurrency

mAirListScript
Class Tree
Index
Previous (SupportsPositionedUpdate)
Next (SupportsResultSetType)


Previous (SupportsResultSetConcurrency)
Next (SupportsSchemasInDataManipulation)

Name
SupportsResultSetType

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsResultSetType ( _Type : TZResultSetType ) : Boolean

Parameters
Parameter Description
_Type : TZResultSetType

mAirListScript
Class Tree
Index
Previous (SupportsResultSetConcurrency)
Next (SupportsSchemasInDataManipulation)


Previous (SupportsResultSetType)
Next (SupportsSchemasInIndexDefinitions)

Name
SupportsSchemasInDataManipulation

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInDataManipulation : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsResultSetType)
Next (SupportsSchemasInIndexDefinitions)


Previous (SupportsSchemasInDataManipulation)
Next (SupportsSchemasInPrivilegeDefinitions)

Name
SupportsSchemasInIndexDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInIndexDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInDataManipulation)
Next (SupportsSchemasInPrivilegeDefinitions)


Previous (SupportsSchemasInIndexDefinitions)
Next (SupportsSchemasInProcedureCalls)

Name
SupportsSchemasInPrivilegeDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInPrivilegeDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInIndexDefinitions)
Next (SupportsSchemasInProcedureCalls)


Previous (SupportsSchemasInPrivilegeDefinitions)
Next (SupportsSchemasInTableDefinitions)

Name
SupportsSchemasInProcedureCalls

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInProcedureCalls : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInPrivilegeDefinitions)
Next (SupportsSchemasInTableDefinitions)


Previous (SupportsSchemasInProcedureCalls)
Next (SupportsSelectForUpdate)

Name
SupportsSchemasInTableDefinitions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSchemasInTableDefinitions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInProcedureCalls)
Next (SupportsSelectForUpdate)


Previous (SupportsSchemasInTableDefinitions)
Next (SupportsStoredProcedures)

Name
SupportsSelectForUpdate

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSelectForUpdate : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSchemasInTableDefinitions)
Next (SupportsStoredProcedures)


Previous (SupportsSelectForUpdate)
Next (SupportsSubqueriesInComparisons)

Name
SupportsStoredProcedures

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsStoredProcedures : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSelectForUpdate)
Next (SupportsSubqueriesInComparisons)


Previous (SupportsStoredProcedures)
Next (SupportsSubqueriesInExists)

Name
SupportsSubqueriesInComparisons

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInComparisons : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsStoredProcedures)
Next (SupportsSubqueriesInExists)


Previous (SupportsSubqueriesInComparisons)
Next (SupportsSubqueriesInIns)

Name
SupportsSubqueriesInExists

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInExists : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInComparisons)
Next (SupportsSubqueriesInIns)


Previous (SupportsSubqueriesInExists)
Next (SupportsSubqueriesInQuantifieds)

Name
SupportsSubqueriesInIns

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInIns : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInExists)
Next (SupportsSubqueriesInQuantifieds)


Previous (SupportsSubqueriesInIns)
Next (SupportsTableCorrelationNames)

Name
SupportsSubqueriesInQuantifieds

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsSubqueriesInQuantifieds : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInIns)
Next (SupportsTableCorrelationNames)


Previous (SupportsSubqueriesInQuantifieds)
Next (SupportsTransactionIsolationLevel)

Name
SupportsTableCorrelationNames

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTableCorrelationNames : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsSubqueriesInQuantifieds)
Next (SupportsTransactionIsolationLevel)


Previous (SupportsTableCorrelationNames)
Next (SupportsTransactions)

Name
SupportsTransactionIsolationLevel

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTransactionIsolationLevel ( Level : TZTransactIsolationLevel ) : Boolean

Parameters
Parameter Description
Level : TZTransactIsolationLevel

mAirListScript
Class Tree
Index
Previous (SupportsTableCorrelationNames)
Next (SupportsTransactions)


Previous (SupportsTransactionIsolationLevel)
Next (SupportsUnion)

Name
SupportsTransactions

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsTransactions : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsTransactionIsolationLevel)
Next (SupportsUnion)


Previous (SupportsTransactions)
Next (SupportsUnionAll)

Name
SupportsUnion

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsUnion : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsTransactions)
Next (SupportsUnionAll)


Previous (SupportsUnion)
Next (UsesLocalFilePerTable)

Name
SupportsUnionAll

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function SupportsUnionAll : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsUnion)
Next (UsesLocalFilePerTable)


Previous (SupportsUnionAll)
Next (UsesLocalFiles)

Name
UsesLocalFilePerTable

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function UsesLocalFilePerTable : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (SupportsUnionAll)
Next (UsesLocalFiles)


Previous (UsesLocalFilePerTable)
Next

Name
UsesLocalFiles

Parent
IZDatabaseMetadata

Visibility
PUBLIC

Source code
function UsesLocalFiles : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UsesLocalFilePerTable)
Next


Previous (IZDatabaseMetadata)
Next (IZDriverManager)

Name
IZDriver

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AcceptsURL (+)
Connect (+)
GetClientVersion (+)
GetMajorVersion (+)
GetMinorVersion (+)
GetPropertyInfo (+)
GetStatementAnalyser (+)
GetSubVersion (+)
GetSupportedProtocols (+)
GetTokenizer (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDatabaseMetadata)
Next (IZDriverManager)


Previous
Next (Connect)

Name
AcceptsURL

Parent
IZDriver

Visibility
PUBLIC

Source code
function AcceptsURL ( const Url : string ) : Boolean

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous
Next (Connect)


Previous (AcceptsURL)
Next (GetClientVersion)

Name
Connect

Parent
IZDriver

Visibility
PUBLIC

Source code
function Connect ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (AcceptsURL)
Next (GetClientVersion)


Previous (Connect)
Next (GetMajorVersion)

Name
GetClientVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (Connect)
Next (GetMajorVersion)


Previous (GetClientVersion)
Next (GetMinorVersion)

Name
GetMajorVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetMajorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetMinorVersion)


Previous (GetMajorVersion)
Next (GetPropertyInfo)

Name
GetMinorVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetMinorVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMajorVersion)
Next (GetPropertyInfo)


Previous (GetMinorVersion)
Next (GetStatementAnalyser)

Name
GetPropertyInfo

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetPropertyInfo ( const Url : string ; Info : TStrings ) : TStrings

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (GetMinorVersion)
Next (GetStatementAnalyser)


Previous (GetPropertyInfo)
Next (GetSubVersion)

Name
GetStatementAnalyser

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetStatementAnalyser : IZStatementAnalyser

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPropertyInfo)
Next (GetSubVersion)


Previous (GetStatementAnalyser)
Next (GetSupportedProtocols)

Name
GetSubVersion

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetSubVersion : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetStatementAnalyser)
Next (GetSupportedProtocols)


Previous (GetSubVersion)
Next (GetTokenizer)

Name
GetSupportedProtocols

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetSupportedProtocols : TStringDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSubVersion)
Next (GetTokenizer)


Previous (GetSupportedProtocols)
Next

Name
GetTokenizer

Parent
IZDriver

Visibility
PUBLIC

Source code
function GetTokenizer : IZTokenizer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetSupportedProtocols)
Next


Previous (IZDriver)
Next (IZNotification)

Name
IZDriverManager

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddLoggingListener (+)
DeregisterDriver (+)
GetClientVersion (+)
GetConnection (+)
GetConnectionWithLogin (+)
GetConnectionWithParams (+)
GetDriver (+)
GetDrivers (+)
GetLoginTimeout (+)
LogError (+)
LogMessage (+)
RegisterDriver (+)
RemoveLoggingListener (+)
SetLoginTimeout (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDriver)
Next (IZNotification)


Previous
Next (DeregisterDriver)

Name
AddLoggingListener

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure AddLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter Description
Listener : IZLoggingListener

mAirListScript
Class Tree
Index
Previous
Next (DeregisterDriver)


Previous (AddLoggingListener)
Next (GetClientVersion)

Name
DeregisterDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure DeregisterDriver ( Driver : IZDriver )

Parameters
Parameter Description
Driver : IZDriver

mAirListScript
Class Tree
Index
Previous (AddLoggingListener)
Next (GetClientVersion)


Previous (DeregisterDriver)
Next (GetConnection)

Name
GetClientVersion

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (DeregisterDriver)
Next (GetConnection)


Previous (GetClientVersion)
Next (GetConnectionWithLogin)

Name
GetConnection

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnection ( const Url : string ) : IZConnection

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetConnectionWithLogin)


Previous (GetConnection)
Next (GetConnectionWithParams)

Name
GetConnectionWithLogin

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnectionWithLogin ( const Url : string ; const User : string ; const Password : string ) : IZConnection

Parameters
Parameter Description
Url : STRING
User : STRING
Password : STRING

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetConnectionWithParams)


Previous (GetConnectionWithLogin)
Next (GetDriver)

Name
GetConnectionWithParams

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetConnectionWithParams ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter Description
Url : STRING
Info : TStrings

mAirListScript
Class Tree
Index
Previous (GetConnectionWithLogin)
Next (GetDriver)


Previous (GetConnectionWithParams)
Next (GetDrivers)

Name
GetDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetDriver ( const Url : string ) : IZDriver

Parameters
Parameter Description
Url : STRING

mAirListScript
Class Tree
Index
Previous (GetConnectionWithParams)
Next (GetDrivers)


Previous (GetDriver)
Next (GetLoginTimeout)

Name
GetDrivers

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetDrivers : IZCollection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetLoginTimeout)


Previous (GetDrivers)
Next (LogError)

Name
GetLoginTimeout

Parent
IZDriverManager

Visibility
PUBLIC

Source code
function GetLoginTimeout : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDrivers)
Next (LogError)


Previous (GetLoginTimeout)
Next (LogMessage)

Name
LogError

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure LogError ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string ; ErrorCode : Integer ; const Error : string )

Parameters
Parameter Description
Category : TZLoggingCategory
Protocol : STRING
Msg : STRING
ErrorCode : INTEGER
Error : STRING

mAirListScript
Class Tree
Index
Previous (GetLoginTimeout)
Next (LogMessage)


Previous (LogError)
Next (RegisterDriver)

Name
LogMessage

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure LogMessage ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string )

Parameters
Parameter Description
Category : TZLoggingCategory
Protocol : STRING
Msg : STRING

mAirListScript
Class Tree
Index
Previous (LogError)
Next (RegisterDriver)


Previous (LogMessage)
Next (RemoveLoggingListener)

Name
RegisterDriver

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure RegisterDriver ( Driver : IZDriver )

Parameters
Parameter Description
Driver : IZDriver

mAirListScript
Class Tree
Index
Previous (LogMessage)
Next (RemoveLoggingListener)


Previous (RegisterDriver)
Next (SetLoginTimeout)

Name
RemoveLoggingListener

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure RemoveLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter Description
Listener : IZLoggingListener

mAirListScript
Class Tree
Index
Previous (RegisterDriver)
Next (SetLoginTimeout)


Previous (RemoveLoggingListener)
Next

Name
SetLoginTimeout

Parent
IZDriverManager

Visibility
PUBLIC

Source code
procedure SetLoginTimeout ( Seconds : Integer )

Parameters
Parameter Description
Seconds : INTEGER

mAirListScript
Class Tree
Index
Previous (RemoveLoggingListener)
Next


Previous (IZDriverManager)
Next (IZPreparedStatement)

Name
IZNotification

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
CheckEvents (+)
DoNotify (+)
GetConnection (+)
GetEvent (+)
Listen (+)
Unlisten (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZDriverManager)
Next (IZPreparedStatement)


Previous
Next (DoNotify)

Name
CheckEvents

Parent
IZNotification

Visibility
PUBLIC

Source code
function CheckEvents : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (DoNotify)


Previous (CheckEvents)
Next (GetConnection)

Name
DoNotify

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure DoNotify

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CheckEvents)
Next (GetConnection)


Previous (DoNotify)
Next (GetEvent)

Name
GetConnection

Parent
IZNotification

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DoNotify)
Next (GetEvent)


Previous (GetConnection)
Next (Listen)

Name
GetEvent

Parent
IZNotification

Visibility
PUBLIC

Source code
function GetEvent : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (Listen)


Previous (GetEvent)
Next (Unlisten)

Name
Listen

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure Listen

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetEvent)
Next (Unlisten)


Previous (Listen)
Next

Name
Unlisten

Parent
IZNotification

Visibility
PUBLIC

Source code
procedure Unlisten

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Listen)
Next


Previous (IZNotification)
Next (IZResultSet)

Name
IZPreparedStatement

Parent
ZDbcIntfs

Class Hierarchy
IZStatement

Visibility
PUBLIC

Members
Methods
Method Description
AddBatchPrepared (+)
ClearParameters (+)
ExecutePrepared (+)
ExecuteQueryPrepared (+)
ExecuteUpdatePrepared (+)
GetMetadata (+)
SetAsciiStream (+)
SetBigDecimal (+)
SetBinaryStream (+)
SetBlob (+)
SetBoolean (+)
SetByte (+)
SetBytes (+)
SetDate (+)
SetDefaultValue (+)
SetDouble (+)
SetFloat (+)
SetInt (+)
SetLong (+)
SetNull (+)
SetPChar (+)
SetShort (+)
SetString (+)
SetTime (+)
SetTimestamp (+)
SetUnicodeStream (+)
SetUnicodeString (+)
SetValue (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZNotification)
Next (IZResultSet)


Previous
Next (ClearParameters)

Name
AddBatchPrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure AddBatchPrepared

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (ClearParameters)


Previous (AddBatchPrepared)
Next (ExecutePrepared)

Name
ClearParameters

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure ClearParameters

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddBatchPrepared)
Next (ExecutePrepared)


Previous (ClearParameters)
Next (ExecuteQueryPrepared)

Name
ExecutePrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecutePrepared : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearParameters)
Next (ExecuteQueryPrepared)


Previous (ExecutePrepared)
Next (ExecuteUpdatePrepared)

Name
ExecuteQueryPrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteQueryPrepared : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecutePrepared)
Next (ExecuteUpdatePrepared)


Previous (ExecuteQueryPrepared)
Next (GetMetadata)

Name
ExecuteUpdatePrepared

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function ExecuteUpdatePrepared : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteQueryPrepared)
Next (GetMetadata)


Previous (ExecuteUpdatePrepared)
Next (SetAsciiStream)

Name
GetMetadata

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
function GetMetadata : IZResultSetMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteUpdatePrepared)
Next (SetAsciiStream)


Previous (GetMetadata)
Next (SetBigDecimal)

Name
SetAsciiStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetAsciiStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (SetBigDecimal)


Previous (SetAsciiStream)
Next (SetBinaryStream)

Name
SetBigDecimal

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBigDecimal ( ParameterIndex : Integer ; Value : Extended )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (SetAsciiStream)
Next (SetBinaryStream)


Previous (SetBigDecimal)
Next (SetBlob)

Name
SetBinaryStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBinaryStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetBigDecimal)
Next (SetBlob)


Previous (SetBinaryStream)
Next (SetBoolean)

Name
SetBlob

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBlob ( ParameterIndex : Integer ; SQLType : TZSQLType ; Value : IZBlob )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : TZSQLType
Value : IZBlob

mAirListScript
Class Tree
Index
Previous (SetBinaryStream)
Next (SetBoolean)


Previous (SetBlob)
Next (SetByte)

Name
SetBoolean

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBoolean ( ParameterIndex : Integer ; Value : Boolean )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetBlob)
Next (SetByte)


Previous (SetBoolean)
Next (SetBytes)

Name
SetByte

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetByte ( ParameterIndex : Integer ; Value : ShortInt )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (SetBoolean)
Next (SetBytes)


Previous (SetByte)
Next (SetDate)

Name
SetBytes

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetBytes ( ParameterIndex : Integer ; const Value : TByteDynArray )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (SetByte)
Next (SetDate)


Previous (SetBytes)
Next (SetDefaultValue)

Name
SetDate

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDate ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetBytes)
Next (SetDefaultValue)


Previous (SetDate)
Next (SetDouble)

Name
SetDefaultValue

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDefaultValue ( ParameterIndex : Integer ; const Value : string )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetDate)
Next (SetDouble)


Previous (SetDefaultValue)
Next (SetFloat)

Name
SetDouble

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetDouble ( ParameterIndex : Integer ; Value : Double )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (SetDefaultValue)
Next (SetFloat)


Previous (SetDouble)
Next (SetInt)

Name
SetFloat

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetFloat ( ParameterIndex : Integer ; Value : Single )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (SetDouble)
Next (SetInt)


Previous (SetFloat)
Next (SetLong)

Name
SetInt

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetInt ( ParameterIndex : Integer ; Value : Integer )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFloat)
Next (SetLong)


Previous (SetInt)
Next (SetNull)

Name
SetLong

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetLong ( ParameterIndex : Integer ; Value : Int64 )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : INT64

mAirListScript
Class Tree
Index
Previous (SetInt)
Next (SetNull)


Previous (SetLong)
Next (SetPChar)

Name
SetNull

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetNull ( ParameterIndex : Integer ; SQLType : TZSQLType )

Parameters
Parameter Description
ParameterIndex : INTEGER
SQLType : TZSQLType

mAirListScript
Class Tree
Index
Previous (SetLong)
Next (SetPChar)


Previous (SetNull)
Next (SetShort)

Name
SetPChar

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetPChar ( ParameterIndex : Integer ; Value : PChar )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (SetNull)
Next (SetShort)


Previous (SetPChar)
Next (SetString)

Name
SetShort

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetShort ( ParameterIndex : Integer ; Value : SmallInt )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (SetPChar)
Next (SetString)


Previous (SetShort)
Next (SetTime)

Name
SetString

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetString ( ParameterIndex : Integer ; const Value : string )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetShort)
Next (SetTime)


Previous (SetString)
Next (SetTimestamp)

Name
SetTime

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTime ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetString)
Next (SetTimestamp)


Previous (SetTime)
Next (SetUnicodeStream)

Name
SetTimestamp

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetTimestamp ( ParameterIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (SetTime)
Next (SetUnicodeStream)


Previous (SetTimestamp)
Next (SetUnicodeString)

Name
SetUnicodeStream

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetUnicodeStream ( ParameterIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetTimestamp)
Next (SetUnicodeString)


Previous (SetUnicodeStream)
Next (SetValue)

Name
SetUnicodeString

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetUnicodeString ( ParameterIndex : Integer ; const Value : WideString )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (SetUnicodeStream)
Next (SetValue)


Previous (SetUnicodeString)
Next

Name
SetValue

Parent
IZPreparedStatement

Visibility
PUBLIC

Source code
procedure SetValue ( ParameterIndex : Integer ; const Value : TZVariant )

Parameters
Parameter Description
ParameterIndex : INTEGER
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (SetUnicodeString)
Next


Previous (IZPreparedStatement)
Next (IZResultSetMetadata)

Name
IZResultSet

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AfterLast (+)
BeforeFirst (+)
CancelRowUpdates (+)
ClearWarnings (+)
Close (+)
CompareRows (+)
DeleteRow (+)
FindColumn (+)
First (+)
GetAsciiStream (+)
GetAsciiStreamByName (+)
GetBigDecimal (+)
GetBigDecimalByName (+)
GetBinaryStream (+)
GetBinaryStreamByName (+)
GetBlob (+)
GetBlobByName (+)
GetBoolean (+)
GetBooleanByName (+)
GetByte (+)
GetByteByName (+)
GetBytes (+)
GetBytesByName (+)
GetConcurrency (+)
GetCursorName (+)
GetDate (+)
GetDateByName (+)
GetDouble (+)
GetDoubleByName (+)
GetFetchDirection (+)
GetFetchSize (+)
GetFloat (+)
GetFloatByName (+)
GetInt (+)
GetIntByName (+)
GetLastRowNo (+)
GetLocateUpdates (+)
GetLong (+)
GetLongByName (+)
GetMetadata (+)
GetPChar (+)
GetPCharByName (+)
GetPostUpdates (+)
GetRow (+)
GetShort (+)
GetShortByName (+)
GetStatement (+)
GetString (+)
GetStringByName (+)
GetTime (+)
GetTimeByName (+)
GetTimestamp (+)
GetTimestampByName (+)
GetType (+)
GetUnicodeStream (+)
GetUnicodeStreamByName (+)
GetUnicodeString (+)
GetUnicodeStringByName (+)
GetValue (+)
GetValueByName (+)
GetWarnings (+)
InsertRow (+)
IsAfterLast (+)
IsBeforeFirst (+)
IsFirst (+)
IsLast (+)
IsNull (+)
IsNullByName (+)
Last (+)
MoveAbsolute (+)
MoveRelative (+)
MoveToCurrentRow (+)
MoveToInsertRow (+)
Next (+)
Previous (+)
RefreshRow (+)
RowDeleted (+)
RowInserted (+)
RowUpdated (+)
SetFetchDirection (+)
SetFetchSize (+)
UpdateAsciiStream (+)
UpdateAsciiStreamByName (+)
UpdateBigDecimal (+)
UpdateBigDecimalByName (+)
UpdateBinaryStream (+)
UpdateBinaryStreamByName (+)
UpdateBoolean (+)
UpdateBooleanByName (+)
UpdateByte (+)
UpdateByteByName (+)
UpdateBytes (+)
UpdateBytesByName (+)
UpdateDate (+)
UpdateDateByName (+)
UpdateDouble (+)
UpdateDoubleByName (+)
UpdateFloat (+)
UpdateFloatByName (+)
UpdateInt (+)
UpdateIntByName (+)
UpdateLong (+)
UpdateLongByName (+)
UpdateNull (+)
UpdateNullByName (+)
UpdatePChar (+)
UpdatePCharByName (+)
UpdateRow (+)
UpdateShort (+)
UpdateShortByName (+)
UpdateString (+)
UpdateStringByName (+)
UpdateTime (+)
UpdateTimeByName (+)
UpdateTimestamp (+)
UpdateTimestampByName (+)
UpdateUnicodeStream (+)
UpdateUnicodeStreamByName (+)
UpdateUnicodeString (+)
UpdateUnicodeStringByName (+)
UpdateValue (+)
UpdateValueByName (+)
WasNull (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZPreparedStatement)
Next (IZResultSetMetadata)


Previous
Next (BeforeFirst)

Name
AfterLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure AfterLast

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (BeforeFirst)


Previous (AfterLast)
Next (CancelRowUpdates)

Name
BeforeFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure BeforeFirst

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AfterLast)
Next (CancelRowUpdates)


Previous (BeforeFirst)
Next (ClearWarnings)

Name
CancelRowUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure CancelRowUpdates

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (BeforeFirst)
Next (ClearWarnings)


Previous (CancelRowUpdates)
Next (Close)

Name
ClearWarnings

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CancelRowUpdates)
Next (Close)


Previous (ClearWarnings)
Next (CompareRows)

Name
Close

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (CompareRows)


Previous (Close)
Next (DeleteRow)

Name
CompareRows

Parent
IZResultSet

Visibility
PUBLIC

Source code
function CompareRows ( Row1 , Row2 : Integer ; const ColumnIndices : TIntegerDynArray ; const ColumnDirs : TBooleanDynArray ) : Integer

Parameters
Parameter Description
Row1 : INTEGER
Row2 : INTEGER
ColumnIndices : TIntegerDynArray
ColumnDirs : TBooleanDynArray

mAirListScript
Class Tree
Index
Previous (Close)
Next (DeleteRow)


Previous (CompareRows)
Next (FindColumn)

Name
DeleteRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure DeleteRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (CompareRows)
Next (FindColumn)


Previous (DeleteRow)
Next (First)

Name
FindColumn

Parent
IZResultSet

Visibility
PUBLIC

Source code
function FindColumn ( const ColumnName : string ) : Integer

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (DeleteRow)
Next (First)


Previous (FindColumn)
Next (GetAsciiStream)

Name
First

Parent
IZResultSet

Visibility
PUBLIC

Source code
function First : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (FindColumn)
Next (GetAsciiStream)


Previous (First)
Next (GetAsciiStreamByName)

Name
GetAsciiStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetAsciiStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (First)
Next (GetAsciiStreamByName)


Previous (GetAsciiStream)
Next (GetBigDecimal)

Name
GetAsciiStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetAsciiStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetAsciiStream)
Next (GetBigDecimal)


Previous (GetAsciiStreamByName)
Next (GetBigDecimalByName)

Name
GetBigDecimal

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBigDecimal ( ColumnIndex : Integer ) : Extended

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetAsciiStreamByName)
Next (GetBigDecimalByName)


Previous (GetBigDecimal)
Next (GetBinaryStream)

Name
GetBigDecimalByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBigDecimalByName ( const ColumnName : string ) : Extended

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBigDecimal)
Next (GetBinaryStream)


Previous (GetBigDecimalByName)
Next (GetBinaryStreamByName)

Name
GetBinaryStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBinaryStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBigDecimalByName)
Next (GetBinaryStreamByName)


Previous (GetBinaryStream)
Next (GetBlob)

Name
GetBinaryStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBinaryStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBinaryStream)
Next (GetBlob)


Previous (GetBinaryStreamByName)
Next (GetBlobByName)

Name
GetBlob

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBlob ( ColumnIndex : Integer ) : IZBlob

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBinaryStreamByName)
Next (GetBlobByName)


Previous (GetBlob)
Next (GetBoolean)

Name
GetBlobByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBlobByName ( const ColumnName : string ) : IZBlob

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBlob)
Next (GetBoolean)


Previous (GetBlobByName)
Next (GetBooleanByName)

Name
GetBoolean

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBoolean ( ColumnIndex : Integer ) : Boolean

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBlobByName)
Next (GetBooleanByName)


Previous (GetBoolean)
Next (GetByte)

Name
GetBooleanByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBooleanByName ( const ColumnName : string ) : Boolean

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBoolean)
Next (GetByte)


Previous (GetBooleanByName)
Next (GetByteByName)

Name
GetByte

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetByte ( ColumnIndex : Integer ) : ShortInt

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetBooleanByName)
Next (GetByteByName)


Previous (GetByte)
Next (GetBytes)

Name
GetByteByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetByteByName ( const ColumnName : string ) : ShortInt

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetByte)
Next (GetBytes)


Previous (GetByteByName)
Next (GetBytesByName)

Name
GetBytes

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBytes ( ColumnIndex : Integer ) : TByteDynArray

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetByteByName)
Next (GetBytesByName)


Previous (GetBytes)
Next (GetConcurrency)

Name
GetBytesByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetBytesByName ( const ColumnName : string ) : TByteDynArray

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetBytes)
Next (GetConcurrency)


Previous (GetBytesByName)
Next (GetCursorName)

Name
GetConcurrency

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetConcurrency : TZResultSetConcurrency

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBytesByName)
Next (GetCursorName)


Previous (GetConcurrency)
Next (GetDate)

Name
GetCursorName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetCursorName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConcurrency)
Next (GetDate)


Previous (GetCursorName)
Next (GetDateByName)

Name
GetDate

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDate ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetCursorName)
Next (GetDateByName)


Previous (GetDate)
Next (GetDouble)

Name
GetDateByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDateByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetDate)
Next (GetDouble)


Previous (GetDateByName)
Next (GetDoubleByName)

Name
GetDouble

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDouble ( ColumnIndex : Integer ) : Double

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDateByName)
Next (GetDoubleByName)


Previous (GetDouble)
Next (GetFetchDirection)

Name
GetDoubleByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetDoubleByName ( const ColumnName : string ) : Double

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetDouble)
Next (GetFetchDirection)


Previous (GetDoubleByName)
Next (GetFetchSize)

Name
GetFetchDirection

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFetchDirection : TZFetchDirection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetDoubleByName)
Next (GetFetchSize)


Previous (GetFetchDirection)
Next (GetFloat)

Name
GetFetchSize

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFetchSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchDirection)
Next (GetFloat)


Previous (GetFetchSize)
Next (GetFloatByName)

Name
GetFloat

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFloat ( ColumnIndex : Integer ) : Single

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFetchSize)
Next (GetFloatByName)


Previous (GetFloat)
Next (GetInt)

Name
GetFloatByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetFloatByName ( const ColumnName : string ) : Single

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetFloat)
Next (GetInt)


Previous (GetFloatByName)
Next (GetIntByName)

Name
GetInt

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetInt ( ColumnIndex : Integer ) : Integer

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetFloatByName)
Next (GetIntByName)


Previous (GetInt)
Next (GetLastRowNo)

Name
GetIntByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetIntByName ( const ColumnName : string ) : Integer

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetInt)
Next (GetLastRowNo)


Previous (GetIntByName)
Next (GetLocateUpdates)

Name
GetLastRowNo

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLastRowNo : integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetIntByName)
Next (GetLocateUpdates)


Previous (GetLastRowNo)
Next (GetLong)

Name
GetLocateUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLocateUpdates : TZLocateUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLastRowNo)
Next (GetLong)


Previous (GetLocateUpdates)
Next (GetLongByName)

Name
GetLong

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLong ( ColumnIndex : Integer ) : Int64

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetLocateUpdates)
Next (GetLongByName)


Previous (GetLong)
Next (GetMetadata)

Name
GetLongByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetLongByName ( const ColumnName : string ) : Int64

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetLong)
Next (GetMetadata)


Previous (GetLongByName)
Next (GetPChar)

Name
GetMetadata

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetMetadata : IZResultSetMetadata

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLongByName)
Next (GetPChar)


Previous (GetMetadata)
Next (GetPCharByName)

Name
GetPChar

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPChar ( ColumnIndex : Integer ) : PChar

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetMetadata)
Next (GetPCharByName)


Previous (GetPChar)
Next (GetPostUpdates)

Name
GetPCharByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPCharByName ( const ColumnName : string ) : PChar

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetPChar)
Next (GetPostUpdates)


Previous (GetPCharByName)
Next (GetRow)

Name
GetPostUpdates

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetPostUpdates : TZPostUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPCharByName)
Next (GetRow)


Previous (GetPostUpdates)
Next (GetShort)

Name
GetRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetRow : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPostUpdates)
Next (GetShort)


Previous (GetRow)
Next (GetShortByName)

Name
GetShort

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetShort ( ColumnIndex : Integer ) : SmallInt

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetRow)
Next (GetShortByName)


Previous (GetShort)
Next (GetStatement)

Name
GetShortByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetShortByName ( const ColumnName : string ) : SmallInt

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetShort)
Next (GetStatement)


Previous (GetShortByName)
Next (GetString)

Name
GetStatement

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetStatement : IZStatement

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetShortByName)
Next (GetString)


Previous (GetStatement)
Next (GetStringByName)

Name
GetString

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetString ( ColumnIndex : Integer ) : string

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStatement)
Next (GetStringByName)


Previous (GetString)
Next (GetTime)

Name
GetStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetStringByName ( const ColumnName : string ) : string

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetString)
Next (GetTime)


Previous (GetStringByName)
Next (GetTimeByName)

Name
GetTime

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTime ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetStringByName)
Next (GetTimeByName)


Previous (GetTime)
Next (GetTimestamp)

Name
GetTimeByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimeByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetTime)
Next (GetTimestamp)


Previous (GetTimeByName)
Next (GetTimestampByName)

Name
GetTimestamp

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimestamp ( ColumnIndex : Integer ) : TDateTime

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTimeByName)
Next (GetTimestampByName)


Previous (GetTimestamp)
Next (GetType)

Name
GetTimestampByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetTimestampByName ( const ColumnName : string ) : TDateTime

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetTimestamp)
Next (GetType)


Previous (GetTimestampByName)
Next (GetUnicodeStream)

Name
GetType

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetType : TZResultSetType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetTimestampByName)
Next (GetUnicodeStream)


Previous (GetType)
Next (GetUnicodeStreamByName)

Name
GetUnicodeStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStream ( ColumnIndex : Integer ) : TStream

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetType)
Next (GetUnicodeStreamByName)


Previous (GetUnicodeStream)
Next (GetUnicodeString)

Name
GetUnicodeStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStreamByName ( const ColumnName : string ) : TStream

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetUnicodeStream)
Next (GetUnicodeString)


Previous (GetUnicodeStreamByName)
Next (GetUnicodeStringByName)

Name
GetUnicodeString

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeString ( ColumnIndex : Integer ) : WideString

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeStreamByName)
Next (GetUnicodeStringByName)


Previous (GetUnicodeString)
Next (GetValue)

Name
GetUnicodeStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetUnicodeStringByName ( const ColumnName : string ) : WideString

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetUnicodeString)
Next (GetValue)


Previous (GetUnicodeStringByName)
Next (GetValueByName)

Name
GetValue

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetValue ( ColumnIndex : Integer ) : TZVariant

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (GetUnicodeStringByName)
Next (GetValueByName)


Previous (GetValue)
Next (GetWarnings)

Name
GetValueByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetValueByName ( const ColumnName : string ) : TZVariant

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (GetValue)
Next (GetWarnings)


Previous (GetValueByName)
Next (InsertRow)

Name
GetWarnings

Parent
IZResultSet

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetValueByName)
Next (InsertRow)


Previous (GetWarnings)
Next (IsAfterLast)

Name
InsertRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure InsertRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (IsAfterLast)


Previous (InsertRow)
Next (IsBeforeFirst)

Name
IsAfterLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsAfterLast : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (InsertRow)
Next (IsBeforeFirst)


Previous (IsAfterLast)
Next (IsFirst)

Name
IsBeforeFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsBeforeFirst : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsAfterLast)
Next (IsFirst)


Previous (IsBeforeFirst)
Next (IsLast)

Name
IsFirst

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsFirst : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsBeforeFirst)
Next (IsLast)


Previous (IsFirst)
Next (IsNull)

Name
IsLast

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsLast : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsFirst)
Next (IsNull)


Previous (IsLast)
Next (IsNullByName)

Name
IsNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsNull ( ColumnIndex : Integer ) : Boolean

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (IsLast)
Next (IsNullByName)


Previous (IsNull)
Next (Last)

Name
IsNullByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
function IsNullByName ( const ColumnName : string ) : Boolean

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (IsNull)
Next (Last)


Previous (IsNullByName)
Next (MoveAbsolute)

Name
Last

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Last : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (IsNullByName)
Next (MoveAbsolute)


Previous (Last)
Next (MoveRelative)

Name
MoveAbsolute

Parent
IZResultSet

Visibility
PUBLIC

Source code
function MoveAbsolute ( Row : Integer ) : Boolean

Parameters
Parameter Description
Row : INTEGER

mAirListScript
Class Tree
Index
Previous (Last)
Next (MoveRelative)


Previous (MoveAbsolute)
Next (MoveToCurrentRow)

Name
MoveRelative

Parent
IZResultSet

Visibility
PUBLIC

Source code
function MoveRelative ( Rows : Integer ) : Boolean

Parameters
Parameter Description
Rows : INTEGER

mAirListScript
Class Tree
Index
Previous (MoveAbsolute)
Next (MoveToCurrentRow)


Previous (MoveRelative)
Next (MoveToInsertRow)

Name
MoveToCurrentRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure MoveToCurrentRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveRelative)
Next (MoveToInsertRow)


Previous (MoveToCurrentRow)
Next (Next)

Name
MoveToInsertRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure MoveToInsertRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveToCurrentRow)
Next (Next)


Previous (MoveToInsertRow)
Next (Previous)

Name
Next

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Next : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (MoveToInsertRow)
Next (Previous)


Previous (Next)
Next (RefreshRow)

Name
Previous

Parent
IZResultSet

Visibility
PUBLIC

Source code
function Previous : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Next)
Next (RefreshRow)


Previous (Previous)
Next (RowDeleted)

Name
RefreshRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure RefreshRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Previous)
Next (RowDeleted)


Previous (RefreshRow)
Next (RowInserted)

Name
RowDeleted

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowDeleted : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RefreshRow)
Next (RowInserted)


Previous (RowDeleted)
Next (RowUpdated)

Name
RowInserted

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowInserted : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RowDeleted)
Next (RowUpdated)


Previous (RowInserted)
Next (SetFetchDirection)

Name
RowUpdated

Parent
IZResultSet

Visibility
PUBLIC

Source code
function RowUpdated : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (RowInserted)
Next (SetFetchDirection)


Previous (RowUpdated)
Next (SetFetchSize)

Name
SetFetchDirection

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure SetFetchDirection ( Value : TZFetchDirection )

Parameters
Parameter Description
Value : TZFetchDirection

mAirListScript
Class Tree
Index
Previous (RowUpdated)
Next (SetFetchSize)


Previous (SetFetchDirection)
Next (UpdateAsciiStream)

Name
SetFetchSize

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure SetFetchSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFetchDirection)
Next (UpdateAsciiStream)


Previous (SetFetchSize)
Next (UpdateAsciiStreamByName)

Name
UpdateAsciiStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateAsciiStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (SetFetchSize)
Next (UpdateAsciiStreamByName)


Previous (UpdateAsciiStream)
Next (UpdateBigDecimal)

Name
UpdateAsciiStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateAsciiStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateAsciiStream)
Next (UpdateBigDecimal)


Previous (UpdateAsciiStreamByName)
Next (UpdateBigDecimalByName)

Name
UpdateBigDecimal

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBigDecimal ( ColumnIndex : Integer ; Value : Extended )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (UpdateAsciiStreamByName)
Next (UpdateBigDecimalByName)


Previous (UpdateBigDecimal)
Next (UpdateBinaryStream)

Name
UpdateBigDecimalByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBigDecimalByName ( const ColumnName : string ; Value : Extended )

Parameters
Parameter Description
ColumnName : STRING
Value : EXTENDED

mAirListScript
Class Tree
Index
Previous (UpdateBigDecimal)
Next (UpdateBinaryStream)


Previous (UpdateBigDecimalByName)
Next (UpdateBinaryStreamByName)

Name
UpdateBinaryStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBinaryStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateBigDecimalByName)
Next (UpdateBinaryStreamByName)


Previous (UpdateBinaryStream)
Next (UpdateBoolean)

Name
UpdateBinaryStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBinaryStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateBinaryStream)
Next (UpdateBoolean)


Previous (UpdateBinaryStreamByName)
Next (UpdateBooleanByName)

Name
UpdateBoolean

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBoolean ( ColumnIndex : Integer ; Value : Boolean )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (UpdateBinaryStreamByName)
Next (UpdateBooleanByName)


Previous (UpdateBoolean)
Next (UpdateByte)

Name
UpdateBooleanByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBooleanByName ( const ColumnName : string ; Value : Boolean )

Parameters
Parameter Description
ColumnName : STRING
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (UpdateBoolean)
Next (UpdateByte)


Previous (UpdateBooleanByName)
Next (UpdateByteByName)

Name
UpdateByte

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateByte ( ColumnIndex : Integer ; Value : ShortInt )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (UpdateBooleanByName)
Next (UpdateByteByName)


Previous (UpdateByte)
Next (UpdateBytes)

Name
UpdateByteByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateByteByName ( const ColumnName : string ; Value : ShortInt )

Parameters
Parameter Description
ColumnName : STRING
Value : SHORTINT

mAirListScript
Class Tree
Index
Previous (UpdateByte)
Next (UpdateBytes)


Previous (UpdateByteByName)
Next (UpdateBytesByName)

Name
UpdateBytes

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBytes ( ColumnIndex : Integer ; const Value : TByteDynArray )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (UpdateByteByName)
Next (UpdateBytesByName)


Previous (UpdateBytes)
Next (UpdateDate)

Name
UpdateBytesByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateBytesByName ( const ColumnName : string ; const Value : TByteDynArray )

Parameters
Parameter Description
ColumnName : STRING
Value : TByteDynArray

mAirListScript
Class Tree
Index
Previous (UpdateBytes)
Next (UpdateDate)


Previous (UpdateBytesByName)
Next (UpdateDateByName)

Name
UpdateDate

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDate ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateBytesByName)
Next (UpdateDateByName)


Previous (UpdateDate)
Next (UpdateDouble)

Name
UpdateDateByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDateByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateDate)
Next (UpdateDouble)


Previous (UpdateDateByName)
Next (UpdateDoubleByName)

Name
UpdateDouble

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDouble ( ColumnIndex : Integer ; Value : Double )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (UpdateDateByName)
Next (UpdateDoubleByName)


Previous (UpdateDouble)
Next (UpdateFloat)

Name
UpdateDoubleByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateDoubleByName ( const ColumnName : string ; Value : Double )

Parameters
Parameter Description
ColumnName : STRING
Value : DOUBLE

mAirListScript
Class Tree
Index
Previous (UpdateDouble)
Next (UpdateFloat)


Previous (UpdateDoubleByName)
Next (UpdateFloatByName)

Name
UpdateFloat

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateFloat ( ColumnIndex : Integer ; Value : Single )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (UpdateDoubleByName)
Next (UpdateFloatByName)


Previous (UpdateFloat)
Next (UpdateInt)

Name
UpdateFloatByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateFloatByName ( const ColumnName : string ; Value : Single )

Parameters
Parameter Description
ColumnName : STRING
Value : SINGLE

mAirListScript
Class Tree
Index
Previous (UpdateFloat)
Next (UpdateInt)


Previous (UpdateFloatByName)
Next (UpdateIntByName)

Name
UpdateInt

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateInt ( ColumnIndex : Integer ; Value : Integer )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateFloatByName)
Next (UpdateIntByName)


Previous (UpdateInt)
Next (UpdateLong)

Name
UpdateIntByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateIntByName ( const ColumnName : string ; Value : Integer )

Parameters
Parameter Description
ColumnName : STRING
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateInt)
Next (UpdateLong)


Previous (UpdateIntByName)
Next (UpdateLongByName)

Name
UpdateLong

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateLong ( ColumnIndex : Integer ; Value : Int64 )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : INT64

mAirListScript
Class Tree
Index
Previous (UpdateIntByName)
Next (UpdateLongByName)


Previous (UpdateLong)
Next (UpdateNull)

Name
UpdateLongByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateLongByName ( const ColumnName : string ; Value : Int64 )

Parameters
Parameter Description
ColumnName : STRING
Value : INT64

mAirListScript
Class Tree
Index
Previous (UpdateLong)
Next (UpdateNull)


Previous (UpdateLongByName)
Next (UpdateNullByName)

Name
UpdateNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateNull ( ColumnIndex : Integer )

Parameters
Parameter Description
ColumnIndex : INTEGER

mAirListScript
Class Tree
Index
Previous (UpdateLongByName)
Next (UpdateNullByName)


Previous (UpdateNull)
Next (UpdatePChar)

Name
UpdateNullByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateNullByName ( const ColumnName : string )

Parameters
Parameter Description
ColumnName : STRING

mAirListScript
Class Tree
Index
Previous (UpdateNull)
Next (UpdatePChar)


Previous (UpdateNullByName)
Next (UpdatePCharByName)

Name
UpdatePChar

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdatePChar ( ColumnIndex : Integer ; Value : PChar )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (UpdateNullByName)
Next (UpdatePCharByName)


Previous (UpdatePChar)
Next (UpdateRow)

Name
UpdatePCharByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdatePCharByName ( const ColumnName : string ; Value : PChar )

Parameters
Parameter Description
ColumnName : STRING
Value : PCHAR

mAirListScript
Class Tree
Index
Previous (UpdatePChar)
Next (UpdateRow)


Previous (UpdatePCharByName)
Next (UpdateShort)

Name
UpdateRow

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateRow

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UpdatePCharByName)
Next (UpdateShort)


Previous (UpdateRow)
Next (UpdateShortByName)

Name
UpdateShort

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateShort ( ColumnIndex : Integer ; Value : SmallInt )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (UpdateRow)
Next (UpdateShortByName)


Previous (UpdateShort)
Next (UpdateString)

Name
UpdateShortByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateShortByName ( const ColumnName : string ; Value : SmallInt )

Parameters
Parameter Description
ColumnName : STRING
Value : SMALLINT

mAirListScript
Class Tree
Index
Previous (UpdateShort)
Next (UpdateString)


Previous (UpdateShortByName)
Next (UpdateStringByName)

Name
UpdateString

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateString ( ColumnIndex : Integer ; const Value : string )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : STRING

mAirListScript
Class Tree
Index
Previous (UpdateShortByName)
Next (UpdateStringByName)


Previous (UpdateString)
Next (UpdateTime)

Name
UpdateStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateStringByName ( const ColumnName : string ; const Value : string )

Parameters
Parameter Description
ColumnName : STRING
Value : STRING

mAirListScript
Class Tree
Index
Previous (UpdateString)
Next (UpdateTime)


Previous (UpdateStringByName)
Next (UpdateTimeByName)

Name
UpdateTime

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTime ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateStringByName)
Next (UpdateTimeByName)


Previous (UpdateTime)
Next (UpdateTimestamp)

Name
UpdateTimeByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimeByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTime)
Next (UpdateTimestamp)


Previous (UpdateTimeByName)
Next (UpdateTimestampByName)

Name
UpdateTimestamp

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimestamp ( ColumnIndex : Integer ; Value : TDateTime )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTimeByName)
Next (UpdateTimestampByName)


Previous (UpdateTimestamp)
Next (UpdateUnicodeStream)

Name
UpdateTimestampByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateTimestampByName ( const ColumnName : string ; Value : TDateTime )

Parameters
Parameter Description
ColumnName : STRING
Value : TDateTime

mAirListScript
Class Tree
Index
Previous (UpdateTimestamp)
Next (UpdateUnicodeStream)


Previous (UpdateTimestampByName)
Next (UpdateUnicodeStreamByName)

Name
UpdateUnicodeStream

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStream ( ColumnIndex : Integer ; Value : TStream )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateTimestampByName)
Next (UpdateUnicodeStreamByName)


Previous (UpdateUnicodeStream)
Next (UpdateUnicodeString)

Name
UpdateUnicodeStreamByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStreamByName ( const ColumnName : string ; Value : TStream )

Parameters
Parameter Description
ColumnName : STRING
Value : TStream

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStream)
Next (UpdateUnicodeString)


Previous (UpdateUnicodeStreamByName)
Next (UpdateUnicodeStringByName)

Name
UpdateUnicodeString

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeString ( ColumnIndex : Integer ; const Value : WideString )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStreamByName)
Next (UpdateUnicodeStringByName)


Previous (UpdateUnicodeString)
Next (UpdateValue)

Name
UpdateUnicodeStringByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateUnicodeStringByName ( const ColumnName : string ; const Value : WideString )

Parameters
Parameter Description
ColumnName : STRING
Value : WIDESTRING

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeString)
Next (UpdateValue)


Previous (UpdateUnicodeStringByName)
Next (UpdateValueByName)

Name
UpdateValue

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateValue ( ColumnIndex : Integer ; const Value : TZVariant )

Parameters
Parameter Description
ColumnIndex : INTEGER
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (UpdateUnicodeStringByName)
Next (UpdateValueByName)


Previous (UpdateValue)
Next (WasNull)

Name
UpdateValueByName

Parent
IZResultSet

Visibility
PUBLIC

Source code
procedure UpdateValueByName ( const ColumnName : string ; const Value : TZVariant )

Parameters
Parameter Description
ColumnName : STRING
Value : TZVariant

mAirListScript
Class Tree
Index
Previous (UpdateValue)
Next (WasNull)


Previous (UpdateValueByName)
Next

Name
WasNull

Parent
IZResultSet

Visibility
PUBLIC

Source code
function WasNull : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (UpdateValueByName)
Next


Previous (IZResultSet)
Next (IZSequence)

Name
IZResultSetMetadata

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetCatalogName (+)
GetColumnCount (+)
GetColumnDisplaySize (+)
GetColumnLabel (+)
GetColumnName (+)
GetColumnType (+)
GetColumnTypeName (+)
GetDefaultValue (+)
GetPrecision (+)
GetScale (+)
GetSchemaName (+)
GetTableName (+)
HasDefaultValue (+)
IsAutoIncrement (+)
IsCaseSensitive (+)
IsCurrency (+)
IsDefinitelyWritable (+)
IsNullable (+)
IsReadOnly (+)
IsSearchable (+)
IsSigned (+)
IsWritable (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZResultSet)
Next (IZSequence)


Previous
Next (GetColumnCount)

Name
GetCatalogName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetCatalogName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous
Next (GetColumnCount)


Previous (GetCatalogName)
Next (GetColumnDisplaySize)

Name
GetColumnCount

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnCount : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCatalogName)
Next (GetColumnDisplaySize)


Previous (GetColumnCount)
Next (GetColumnLabel)

Name
GetColumnDisplaySize

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnDisplaySize ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnCount)
Next (GetColumnLabel)


Previous (GetColumnDisplaySize)
Next (GetColumnName)

Name
GetColumnLabel

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnLabel ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnDisplaySize)
Next (GetColumnName)


Previous (GetColumnLabel)
Next (GetColumnType)

Name
GetColumnName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnLabel)
Next (GetColumnType)


Previous (GetColumnName)
Next (GetColumnTypeName)

Name
GetColumnType

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnType ( Column : Integer ) : TZSQLType

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnName)
Next (GetColumnTypeName)


Previous (GetColumnType)
Next (GetDefaultValue)

Name
GetColumnTypeName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetColumnTypeName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnType)
Next (GetDefaultValue)


Previous (GetColumnTypeName)
Next (GetPrecision)

Name
GetDefaultValue

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetDefaultValue ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetColumnTypeName)
Next (GetPrecision)


Previous (GetDefaultValue)
Next (GetScale)

Name
GetPrecision

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetPrecision ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetDefaultValue)
Next (GetScale)


Previous (GetPrecision)
Next (GetSchemaName)

Name
GetScale

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetScale ( Column : Integer ) : Integer

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetPrecision)
Next (GetSchemaName)


Previous (GetScale)
Next (GetTableName)

Name
GetSchemaName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetSchemaName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetScale)
Next (GetTableName)


Previous (GetSchemaName)
Next (HasDefaultValue)

Name
GetTableName

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function GetTableName ( Column : Integer ) : string

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetSchemaName)
Next (HasDefaultValue)


Previous (GetTableName)
Next (IsAutoIncrement)

Name
HasDefaultValue

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function HasDefaultValue ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (GetTableName)
Next (IsAutoIncrement)


Previous (HasDefaultValue)
Next (IsCaseSensitive)

Name
IsAutoIncrement

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsAutoIncrement ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (HasDefaultValue)
Next (IsCaseSensitive)


Previous (IsAutoIncrement)
Next (IsCurrency)

Name
IsCaseSensitive

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsCaseSensitive ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsAutoIncrement)
Next (IsCurrency)


Previous (IsCaseSensitive)
Next (IsDefinitelyWritable)

Name
IsCurrency

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsCurrency ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsCaseSensitive)
Next (IsDefinitelyWritable)


Previous (IsCurrency)
Next (IsNullable)

Name
IsDefinitelyWritable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsDefinitelyWritable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsCurrency)
Next (IsNullable)


Previous (IsDefinitelyWritable)
Next (IsReadOnly)

Name
IsNullable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsNullable ( Column : Integer ) : TZColumnNullableType

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsDefinitelyWritable)
Next (IsReadOnly)


Previous (IsNullable)
Next (IsSearchable)

Name
IsReadOnly

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsReadOnly ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsNullable)
Next (IsSearchable)


Previous (IsReadOnly)
Next (IsSigned)

Name
IsSearchable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsSearchable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsReadOnly)
Next (IsSigned)


Previous (IsSearchable)
Next (IsWritable)

Name
IsSigned

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsSigned ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsSearchable)
Next (IsWritable)


Previous (IsSigned)
Next

Name
IsWritable

Parent
IZResultSetMetadata

Visibility
PUBLIC

Source code
function IsWritable ( Column : Integer ) : Boolean

Parameters
Parameter Description
Column : INTEGER

mAirListScript
Class Tree
Index
Previous (IsSigned)
Next


Previous (IZResultSetMetadata)
Next (IZStatement)

Name
IZSequence

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
GetBlockSize (+)
GetConnection (+)
GetCurrentValue (+)
GetCurrentValueSQL (+)
GetName (+)
GetNextValue (+)
GetNextValueSQL (+)
SetBlockSize (+)
SetName (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZResultSetMetadata)
Next (IZStatement)


Previous
Next (GetConnection)

Name
GetBlockSize

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetBlockSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous
Next (GetConnection)


Previous (GetBlockSize)
Next (GetCurrentValue)

Name
GetConnection

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetBlockSize)
Next (GetCurrentValue)


Previous (GetConnection)
Next (GetCurrentValueSQL)

Name
GetCurrentValue

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetCurrentValue : Int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetCurrentValueSQL)


Previous (GetCurrentValue)
Next (GetName)

Name
GetCurrentValueSQL

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetCurrentValueSQL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentValue)
Next (GetName)


Previous (GetCurrentValueSQL)
Next (GetNextValue)

Name
GetName

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetName : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetCurrentValueSQL)
Next (GetNextValue)


Previous (GetName)
Next (GetNextValueSQL)

Name
GetNextValue

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetNextValue : Int64

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetName)
Next (GetNextValueSQL)


Previous (GetNextValue)
Next (SetBlockSize)

Name
GetNextValueSQL

Parent
IZSequence

Visibility
PUBLIC

Source code
function GetNextValueSQL : string

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetNextValue)
Next (SetBlockSize)


Previous (GetNextValueSQL)
Next (SetName)

Name
SetBlockSize

Parent
IZSequence

Visibility
PUBLIC

Source code
procedure SetBlockSize ( const Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (GetNextValueSQL)
Next (SetName)


Previous (SetBlockSize)
Next

Name
SetName

Parent
IZSequence

Visibility
PUBLIC

Source code
procedure SetName ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (SetBlockSize)
Next


Previous (IZSequence)
Next (TZDriverManager)

Name
IZStatement

Parent
ZDbcIntfs

Class Hierarchy
IZInterface

Visibility
PUBLIC

Members
Methods
Method Description
AddBatch (+)
Cancel (+)
ClearBatch (+)
ClearWarnings (+)
Close (+)
Execute (+)
ExecuteBatch (+)
ExecuteQuery (+)
ExecuteUpdate (+)
GetConnection (+)
GetFetchDirection (+)
GetFetchSize (+)
GetLocateUpdates (+)
GetMaxFieldSize (+)
GetMaxRows (+)
GetMoreResults (+)
GetParameters (+)
GetPostUpdates (+)
GetQueryTimeout (+)
GetResultSet (+)
GetResultSetConcurrency (+)
GetResultSetType (+)
GetUpdateCount (+)
GetWarnings (+)
SetCursorName (+)
SetEscapeProcessing (+)
SetFetchDirection (+)
SetFetchSize (+)
SetLocateUpdates (+)
SetMaxFieldSize (+)
SetMaxRows (+)
SetPostUpdates (+)
SetQueryTimeout (+)
SetResultSetConcurrency (+)
SetResultSetType (+)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZSequence)
Next (TZDriverManager)


Previous
Next (Cancel)

Name
AddBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure AddBatch ( const SQL : string )

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous
Next (Cancel)


Previous (AddBatch)
Next (ClearBatch)

Name
Cancel

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure Cancel

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddBatch)
Next (ClearBatch)


Previous (Cancel)
Next (ClearWarnings)

Name
ClearBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure ClearBatch

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Cancel)
Next (ClearWarnings)


Previous (ClearBatch)
Next (Close)

Name
ClearWarnings

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure ClearWarnings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearBatch)
Next (Close)


Previous (ClearWarnings)
Next (Execute)

Name
Close

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure Close

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ClearWarnings)
Next (Execute)


Previous (Close)
Next (ExecuteBatch)

Name
Execute

Parent
IZStatement

Visibility
PUBLIC

Source code
function Execute ( const SQL : string ) : Boolean

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (Close)
Next (ExecuteBatch)


Previous (Execute)
Next (ExecuteQuery)

Name
ExecuteBatch

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteBatch : TIntegerDynArray

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (Execute)
Next (ExecuteQuery)


Previous (ExecuteBatch)
Next (ExecuteUpdate)

Name
ExecuteQuery

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteQuery ( const SQL : string ) : IZResultSet

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteBatch)
Next (ExecuteUpdate)


Previous (ExecuteQuery)
Next (GetConnection)

Name
ExecuteUpdate

Parent
IZStatement

Visibility
PUBLIC

Source code
function ExecuteUpdate ( const SQL : string ) : Integer

Parameters
Parameter Description
SQL : STRING

mAirListScript
Class Tree
Index
Previous (ExecuteQuery)
Next (GetConnection)


Previous (ExecuteUpdate)
Next (GetFetchDirection)

Name
GetConnection

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetConnection : IZConnection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (ExecuteUpdate)
Next (GetFetchDirection)


Previous (GetConnection)
Next (GetFetchSize)

Name
GetFetchDirection

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetFetchDirection : TZFetchDirection

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetFetchSize)


Previous (GetFetchDirection)
Next (GetLocateUpdates)

Name
GetFetchSize

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetFetchSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchDirection)
Next (GetLocateUpdates)


Previous (GetFetchSize)
Next (GetMaxFieldSize)

Name
GetLocateUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetLocateUpdates : TZLocateUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetFetchSize)
Next (GetMaxFieldSize)


Previous (GetLocateUpdates)
Next (GetMaxRows)

Name
GetMaxFieldSize

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMaxFieldSize : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetLocateUpdates)
Next (GetMaxRows)


Previous (GetMaxFieldSize)
Next (GetMoreResults)

Name
GetMaxRows

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMaxRows : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxFieldSize)
Next (GetMoreResults)


Previous (GetMaxRows)
Next (GetParameters)

Name
GetMoreResults

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetMoreResults : Boolean

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMaxRows)
Next (GetParameters)


Previous (GetMoreResults)
Next (GetPostUpdates)

Name
GetParameters

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetParameters : TStrings

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetMoreResults)
Next (GetPostUpdates)


Previous (GetParameters)
Next (GetQueryTimeout)

Name
GetPostUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetPostUpdates : TZPostUpdatesMode

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetParameters)
Next (GetQueryTimeout)


Previous (GetPostUpdates)
Next (GetResultSet)

Name
GetQueryTimeout

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetQueryTimeout : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetPostUpdates)
Next (GetResultSet)


Previous (GetQueryTimeout)
Next (GetResultSetConcurrency)

Name
GetResultSet

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSet : IZResultSet

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetQueryTimeout)
Next (GetResultSetConcurrency)


Previous (GetResultSet)
Next (GetResultSetType)

Name
GetResultSetConcurrency

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSetConcurrency : TZResultSetConcurrency

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSet)
Next (GetResultSetType)


Previous (GetResultSetConcurrency)
Next (GetUpdateCount)

Name
GetResultSetType

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetResultSetType : TZResultSetType

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSetConcurrency)
Next (GetUpdateCount)


Previous (GetResultSetType)
Next (GetWarnings)

Name
GetUpdateCount

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetUpdateCount : Integer

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetResultSetType)
Next (GetWarnings)


Previous (GetUpdateCount)
Next (SetCursorName)

Name
GetWarnings

Parent
IZStatement

Visibility
PUBLIC

Source code
function GetWarnings : EZSQLWarning

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (GetUpdateCount)
Next (SetCursorName)


Previous (GetWarnings)
Next (SetEscapeProcessing)

Name
SetCursorName

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetCursorName ( const Value : string )

Parameters
Parameter Description
Value : STRING

mAirListScript
Class Tree
Index
Previous (GetWarnings)
Next (SetEscapeProcessing)


Previous (SetCursorName)
Next (SetFetchDirection)

Name
SetEscapeProcessing

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetEscapeProcessing ( Value : Boolean )

Parameters
Parameter Description
Value : BOOLEAN

mAirListScript
Class Tree
Index
Previous (SetCursorName)
Next (SetFetchDirection)


Previous (SetEscapeProcessing)
Next (SetFetchSize)

Name
SetFetchDirection

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetFetchDirection ( Value : TZFetchDirection )

Parameters
Parameter Description
Value : TZFetchDirection

mAirListScript
Class Tree
Index
Previous (SetEscapeProcessing)
Next (SetFetchSize)


Previous (SetFetchDirection)
Next (SetLocateUpdates)

Name
SetFetchSize

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetFetchSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetFetchDirection)
Next (SetLocateUpdates)


Previous (SetFetchSize)
Next (SetMaxFieldSize)

Name
SetLocateUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetLocateUpdates ( Value : TZLocateUpdatesMode )

Parameters
Parameter Description
Value : TZLocateUpdatesMode

mAirListScript
Class Tree
Index
Previous (SetFetchSize)
Next (SetMaxFieldSize)


Previous (SetLocateUpdates)
Next (SetMaxRows)

Name
SetMaxFieldSize

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetMaxFieldSize ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetLocateUpdates)
Next (SetMaxRows)


Previous (SetMaxFieldSize)
Next (SetPostUpdates)

Name
SetMaxRows

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetMaxRows ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetMaxFieldSize)
Next (SetPostUpdates)


Previous (SetMaxRows)
Next (SetQueryTimeout)

Name
SetPostUpdates

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetPostUpdates ( Value : TZPostUpdatesMode )

Parameters
Parameter Description
Value : TZPostUpdatesMode

mAirListScript
Class Tree
Index
Previous (SetMaxRows)
Next (SetQueryTimeout)


Previous (SetPostUpdates)
Next (SetResultSetConcurrency)

Name
SetQueryTimeout

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetQueryTimeout ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (SetPostUpdates)
Next (SetResultSetConcurrency)


Previous (SetQueryTimeout)
Next (SetResultSetType)

Name
SetResultSetConcurrency

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetResultSetConcurrency ( Value : TZResultSetConcurrency )

Parameters
Parameter Description
Value : TZResultSetConcurrency

mAirListScript
Class Tree
Index
Previous (SetQueryTimeout)
Next (SetResultSetType)


Previous (SetResultSetConcurrency)
Next

Name
SetResultSetType

Parent
IZStatement

Visibility
PUBLIC

Source code
procedure SetResultSetType ( Value : TZResultSetType )

Parameters
Parameter Description
Value : TZResultSetType

mAirListScript
Class Tree
Index
Previous (SetResultSetConcurrency)
Next


Previous (IZStatement)
Next

Name
TZDriverManager

Parent
ZDbcIntfs

Class Hierarchy
TInterfacedObject,IZDriverManager

Visibility
PUBLIC

Members
Fields
Field Description
FDrivers (-)
FLoggingListeners (-)
FLoginTimeout (-)

Methods
Method | Description
AddLoggingListener (+) | Adds a logging listener to log SQL events.
Create (+) | Constructs this object with default properties.
DeregisterDriver (+) | Unregisters a driver for specific database.
Destroy (+) | Destroys this object and cleanups the memory.
GetClientVersion (+) | Locates a required driver and returns the client library version number.
GetConnection (+) | Locates a required driver and opens a connection to the specified database.
GetConnectionWithLogin (+) | Locates a required driver and opens a connection to the specified database.
GetConnectionWithParams (+) | Locates a required driver and opens a connection to the specified database.
GetDriver (+) | Gets a driver which accepts the specified url.
GetDrivers (+) | Gets a collection of registered drivers.
GetLoginTimeout (+) | Gets a login timeout value.
LogError (+) | Logs a message about event with error result code.
LogMessage (+) | Logs a message about event with normal result code.
RegisterDriver (+) | Registers a driver for specific database.
RemoveLoggingListener (+) | Removes a logging listener from the list.
SetLoginTimeout (+) | Sets a new login timeout value.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

mAirListScript
Class Tree
Index
Previous (IZStatement)
Next


Previous
Next (FLoggingListeners)

Name
FDrivers

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FDrivers : IZCollection

mAirListScript
Class Tree
Index
Previous
Next (FLoggingListeners)


Previous (FDrivers)
Next (FLoginTimeout)

Name
FLoggingListeners

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FLoggingListeners : IZCollection

mAirListScript
Class Tree
Index
Previous (FDrivers)
Next (FLoginTimeout)


Previous (FLoggingListeners)
Next

Name
FLoginTimeout

Parent
TZDriverManager

Visibility
PRIVATE

Source code
FLoginTimeout : Integer

mAirListScript
Class Tree
Index
Previous (FLoggingListeners)
Next


Previous
Next (Create)

Name
AddLoggingListener

Parent
TZDriverManager

Visibility
PUBLIC

Description
Adds a logging listener to log SQL events.

Source code
procedure AddLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter | Description
Listener : IZLoggingListener | a logging interface to be added.

mAirListScript
Class Tree
Index
Previous
Next (Create)


Previous (AddLoggingListener)
Next (DeregisterDriver)

Name
Create

Parent
TZDriverManager

Visibility
PUBLIC

Description
Constructs this object with default properties.

Source code
constructor Create

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (AddLoggingListener)
Next (DeregisterDriver)


Previous (Create)
Next (Destroy)

Name
DeregisterDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Unregisters a driver for specific database.

Source code
procedure DeregisterDriver ( Driver : IZDriver )

Parameters
Parameter | Description
Driver : IZDriver | a driver to be unregistered.

mAirListScript
Class Tree
Index
Previous (Create)
Next (Destroy)


Previous (DeregisterDriver)
Next (GetClientVersion)

Name
Destroy

Parent
TZDriverManager

Visibility
PUBLIC

Description
Destroys this object and cleanups the memory.

Source code
destructor Destroy ; override

Parameters
Parameter Description

mAirListScript
Class Tree
Index
Previous (DeregisterDriver)
Next (GetClientVersion)


Previous (Destroy)
Next (GetConnection)

Name
GetClientVersion

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and returns the client library version number.

Source code
function GetClientVersion ( const Url : string ) : Integer

Parameters
Parameter | Description
Url : STRING | a database connection Url.

Return
Types | Description
INTEGER | client library version number.

mAirListScript
Class Tree
Index
Previous (Destroy)
Next (GetConnection)


Previous (GetClientVersion)
Next (GetConnectionWithLogin)

Name
GetConnection

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnection ( const Url : string ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetClientVersion)
Next (GetConnectionWithLogin)


Previous (GetConnection)
Next (GetConnectionWithParams)

Name
GetConnectionWithLogin

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnectionWithLogin ( const Url : string ; const User : string ; const Password : string ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.
User : STRING | a user's name.
Password : STRING | a user's password.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetConnection)
Next (GetConnectionWithParams)


Previous (GetConnectionWithLogin)
Next (GetDriver)

Name
GetConnectionWithParams

Parent
TZDriverManager

Visibility
PUBLIC

Description
Locates a required driver and opens a connection to the specified database.

Source code
function GetConnectionWithParams ( const Url : string ; Info : TStrings ) : IZConnection

Parameters
Parameter | Description
Url : STRING | a database connection Url.
Info : TStrings | an extra connection parameters.

Return
Types | Description
IZConnection | an opened connection.

mAirListScript
Class Tree
Index
Previous (GetConnectionWithLogin)
Next (GetDriver)


Previous (GetConnectionWithParams)
Next (GetDrivers)

Name
GetDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a driver which accepts the specified url.

Source code
function GetDriver ( const Url : string ) : IZDriver

Parameters
Parameter | Description
Url : STRING | a database connection url.

Return
Types | Description
IZDriver | a found driver or null otherwise.

mAirListScript
Class Tree
Index
Previous (GetConnectionWithParams)
Next (GetDrivers)


Previous (GetDriver)
Next (GetLoginTimeout)

Name
GetDrivers

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a collection of registered drivers.

Source code
function GetDrivers : IZCollection

Parameters
Parameter Description

Return
Types | Description
IZCollection | an unmodifiable collection with registered drivers.

mAirListScript
Class Tree
Index
Previous (GetDriver)
Next (GetLoginTimeout)


Previous (GetDrivers)
Next (LogError)

Name
GetLoginTimeout

Parent
TZDriverManager

Visibility
PUBLIC

Description
Gets a login timeout value.

Source code
function GetLoginTimeout : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | a login timeout.

mAirListScript
Class Tree
Index
Previous (GetDrivers)
Next (LogError)


Previous (GetLoginTimeout)
Next (LogMessage)

Name
LogError

Parent
TZDriverManager

Visibility
PUBLIC

Description
Logs a message about event with error result code.

Source code
procedure LogError ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string ; ErrorCode : Integer ; const Error : string )

Parameters
Parameter | Description
Category : TZLoggingCategory | a category of the message.
Protocol : STRING | a name of the protocol.
Msg : STRING | a description message.
ErrorCode : INTEGER | an error code.
Error : STRING | an error message.

mAirListScript
Class Tree
Index
Previous (GetLoginTimeout)
Next (LogMessage)


Previous (LogError)
Next (RegisterDriver)

Name
LogMessage

Parent
TZDriverManager

Visibility
PUBLIC

Description
Logs a message about event with normal result code.

Source code
procedure LogMessage ( Category : TZLoggingCategory ; const Protocol : string ; const Msg : string )

Parameters
Parameter | Description
Category : TZLoggingCategory | a category of the message.
Protocol : STRING | a name of the protocol.
Msg : STRING | a description message.

mAirListScript
Class Tree
Index
Previous (LogError)
Next (RegisterDriver)


Previous (LogMessage)
Next (RemoveLoggingListener)

Name
RegisterDriver

Parent
TZDriverManager

Visibility
PUBLIC

Description
Registers a driver for specific database.

Source code
procedure RegisterDriver ( Driver : IZDriver )

Parameters
Parameter | Description
Driver : IZDriver | a driver to be registered.

mAirListScript
Class Tree
Index
Previous (LogMessage)
Next (RemoveLoggingListener)


Previous (RegisterDriver)
Next (SetLoginTimeout)

Name
RemoveLoggingListener

Parent
TZDriverManager

Visibility
PUBLIC

Description
Removes a logging listener from the list.

Source code
procedure RemoveLoggingListener ( Listener : IZLoggingListener )

Parameters
Parameter | Description
Listener : IZLoggingListener | a logging interface to be removed.

mAirListScript
Class Tree
Index
Previous (RegisterDriver)
Next (SetLoginTimeout)


Previous (RemoveLoggingListener)
Next

Name
SetLoginTimeout

Parent
TZDriverManager

Visibility
PUBLIC

Description
Sets a new login timeout value.

Source code
procedure SetLoginTimeout ( Value : Integer )

Parameters
Parameter Description
Value : INTEGER

mAirListScript
Class Tree
Index
Previous (RemoveLoggingListener)
Next


Previous
Next (TZColumnNullableType)

Name
TZBestRowIdentifier

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZBestRowIdentifier = ( brUnknown , brNotPseudo , brPseudo ) ;

mAirListScript
Class Tree
Index
Previous
Next (TZColumnNullableType)


Previous (TZBestRowIdentifier)
Next (TZFetchDirection)

Name
TZColumnNullableType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZColumnNullableType = ( ntNoNulls , ntNullable , ntNullableUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TZBestRowIdentifier)
Next (TZFetchDirection)


Previous (TZColumnNullableType)
Next (TZImportedKey)

Name
TZFetchDirection

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZFetchDirection = ( fdForward , fdReverse , fdUnknown ) ;

mAirListScript
Class Tree
Index
Previous (TZColumnNullableType)
Next (TZImportedKey)


Previous (TZFetchDirection)
Next (TZLocateUpdatesMode)

Name
TZImportedKey

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZImportedKey = ( ikCascade , ikRestrict , ikSetNull , ikNoAction , ikSetDefault , ikInitiallyDeferred , ikInitiallyImmediate , ikNotDeferrable ) ;

mAirListScript
Class Tree
Index
Previous (TZFetchDirection)
Next (TZLocateUpdatesMode)


Previous (TZImportedKey)
Next (TZPostUpdatesMode)

Name
TZLocateUpdatesMode

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZLocateUpdatesMode = ( loWhereAll , loWhereChanged , loWhereKeyOnly ) ;

mAirListScript
Class Tree
Index
Previous (TZImportedKey)
Next (TZPostUpdatesMode)


Previous (TZLocateUpdatesMode)
Next (TZProcedureColumnType)

Name
TZPostUpdatesMode

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZPostUpdatesMode = ( poColumnsAll , poColumnsChanged ) ;

mAirListScript
Class Tree
Index
Previous (TZLocateUpdatesMode)
Next (TZProcedureColumnType)


Previous (TZPostUpdatesMode)
Next (TZProcedureResultType)

Name
TZProcedureColumnType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZProcedureColumnType = ( pctUnknown , pctIn , pctInOut , pctOut , pctReturn , pctResultSet ) ;

mAirListScript
Class Tree
Index
Previous (TZPostUpdatesMode)
Next (TZProcedureResultType)


Previous (TZProcedureColumnType)
Next (TZResultSetConcurrency)

Name
TZProcedureResultType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZProcedureResultType = ( prtUnknown , prtNoResult , prtReturnsResult ) ;

mAirListScript
Class Tree
Index
Previous (TZProcedureColumnType)
Next (TZResultSetConcurrency)


Previous (TZProcedureResultType)
Next (TZResultSetType)

Name
TZResultSetConcurrency

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZResultSetConcurrency = ( rcReadOnly , rcUpdatable ) ;

mAirListScript
Class Tree
Index
Previous (TZProcedureResultType)
Next (TZResultSetType)


Previous (TZResultSetConcurrency)
Next (TZScopeBestRowIdentifier)

Name
TZResultSetType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZResultSetType = ( rtForwardOnly , rtScrollInsensitive , rtScrollSensitive ) ;

mAirListScript
Class Tree
Index
Previous (TZResultSetConcurrency)
Next (TZScopeBestRowIdentifier)


Previous (TZResultSetType)
Next (TZSQLType)

Name
TZScopeBestRowIdentifier

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZScopeBestRowIdentifier = ( sbrTemporary , sbrTransaction , sbrSession ) ;

mAirListScript
Class Tree
Index
Previous (TZResultSetType)
Next (TZSQLType)


Previous (TZScopeBestRowIdentifier)
Next (TZTableIndex)

Name
TZSQLType

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZSQLType = ( stUnknown , stBoolean , stByte , stShort , stInteger , stLong , stFloat , stDouble , stBigDecimal , stString , stUnicodeString , stBytes , stDate , stTime , stTimestamp , stAsciiStream , stUnicodeStream , stBinaryStream ) ;

mAirListScript
Class Tree
Index
Previous (TZScopeBestRowIdentifier)
Next (TZTableIndex)


Previous (TZSQLType)
Next (TZTransactIsolationLevel)

Name
TZTableIndex

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZTableIndex = ( tiStatistic , tiClustered , tiHashed , tiOther ) ;

mAirListScript
Class Tree
Index
Previous (TZSQLType)
Next (TZTransactIsolationLevel)


Previous (TZTableIndex)
Next (TZVersionColumn)

Name
TZTransactIsolationLevel

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZTransactIsolationLevel = ( tiNone , tiReadUncommitted , tiReadCommitted , tiRepeatableRead , tiSerializable ) ;

mAirListScript
Class Tree
Index
Previous (TZTableIndex)
Next (TZVersionColumn)


Previous (TZTransactIsolationLevel)
Next

Name
TZVersionColumn

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TZVersionColumn = ( vcUnknown , vcNotPseudo , vcPseudo ) ;

mAirListScript
Class Tree
Index
Previous (TZTransactIsolationLevel)
Next


Previous
Next (TypeSearchable)

Name
ProcedureReturnsResult

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
ProcedureReturnsResult = 2

mAirListScript
Class Tree
Index
Previous
Next (TypeSearchable)


Previous (ProcedureReturnsResult)
Next

Name
TypeSearchable

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
TypeSearchable = 3

mAirListScript
Class Tree
Index
Previous (ProcedureReturnsResult)
Next


Previous
Next

Name
DriverManager

Parent
ZDbcIntfs

Visibility
PUBLIC

Source code
DriverManager : IZDriverManager

mAirListScript
Class Tree
Index
Previous
Next